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New Features & Enhancements 
 

New features and enhancements in PC*MILER Version 31 products are briefly described below. For 
more details, see the PC*MILER User’s Guide that was installed with PC*MILER.  

 
IMPORTANT NOTES: 
• The routing and map data that this Beta Release of PC*MILER 31 uses for route calculations 

and mapping has not been finalized and may change before the final version release. 
• Additional features and enhancements may also be added for the final version release. 
• Some features described below require additional licensing. 

SUMMARY 
 ENHANCED!  Improved truck-specific route and mileage calculations, including Version 31 

map data updates in Worldwide regions. 

 NEW!  Insert new stops in the Route window by clicking the plus sign. 

 ENHANCED!  Improved reporting of conditional route and road restrictions in the Detailed 
Route and Driver’s Reports. 

 ENHANCED!  “Truck Restrictions” and “Commercially Prohibited” road attributes now 
displayed by default on the map. 

 NEW!  Default average road speeds by jurisdiction have been updated to improve drive 
times and ETA calculations. 

 NEW!  Cities can now be searched by full state name. 

 ENHANCED!  Expanded range of amenity icons in Place of Interest (POI) searches. 

 ENHANCED!  “Distance” renamed “Geographical Distance” in results tables. 

 NEW!  Now calculate distances in whole numbers. 

 NEW!  Support for the change in Mexico's capital name from Distrito Federal (Federal 
District) to Ciudad de Mexico (Mexico City). 

 ENHANCED!  Some Route Option categories have been renamed for clarity. 

 NEW!  Current and forecasted weather-related road surface conditions display on the map. 

 NEW!  New Weather Alert category for “Wind Alerts”. 

 NEW!  PC*MILER now runs on Windows Server 2016. 

 ENHANCED!  Custom Place icon is now visible at higher zoom levels on the map. 

 NEW!  The Drag Map and Box Zoom tools can now be selected in the Map window. 

 ENHANCED!  Simplified layout of the settings in the Map Features dialog. 

 NEW!  Visibility of turn restriction icons are now controlled from the Map window. 

 NEW!  Save button in the Report window. 

 S
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 ENHANCED!  Clicking the “X” in the Route window error message clears the message. 

 NEW!  “Distribution Center” Place of Interest (POI) category has been added. 

 ENHANCED!  Report titles added to the top of previewed and printed reports. 

 NEW!  The Remote Support and License Tools are now accessible from the Help tab. 

 ENHANCED!  The Route window's "Show/Hide" control is now synchronized with the 
Comparison Report’s “Visibility” checkboxes. 

 NEW!  Automatic verification of disk space before installation. 

 NEW!  Internet-enabled features of PC*MILER can now connect with IPv6 addresses 
(PC*MILER|TCP/IP). 

 NEW!  A shortcut to the License Tool is placed on the desktop during installation. 

 ENHANCED!  Reset to Default option now available in Application Settings > Route Costs. 

 ENHANCED!  New PCMSLookup option 3 for address lookups (PC*MILER|Connect). 

 ENHANCED!  Improved log files include product key codes. 

 ENHANCED!  Improved sample code is compatible with 64-bit API libraries (PC*MILER|Connect). 
 

 

 ENHANCED!  Improved truck-specific route and mileage calculations. 

Routing improvements are a major part of a PC*MILER release and each annual version release confirms 
our commitment to enhancing the quality of PC*MILER’s truck-specific routing database, mileage 
calculations and driving directions. This year's focus was on: 
 

• Improving how a route’s path interacts with conditional road restrictions such as restrictions 
based on direction of travel, no through truck restrictions, and maneuvering restrictions (e.g. no 
left turn based on time of day). 

• Redefining routing logic so that the use of left turns, right turns, sharp turns, U-turns and K-turns 
in the route were specified for the vehicle dimensions entered in Route Profiles as well as based 
on road type of where the turns would occur. 

• Improving precision and coverage of nationwide U.S. street-level roads and address ranges 
(requires a license for PC*MILER|Streets). 

• Adding newly constructed roads and exit interchanges. 
• Improving city and ZIP/Postal Code placement and alignment. 
• Specifically for commercial vehicles, additional updates include but are not limited to: 

o Applying urban coding to appropriate city-centers to aid in generating better routes 
through congested areas. 

o Improving highway-level coverage and truck-specific through-travel routing within city 
limits (e.g. keeping drivers on roads designated by local and state authorities as 
preferred/designated for truck travel). 

o Updating vertical clearance data to accurately model posted limits at railroad crossings 
and overpasses, as well as other types of lower clearance bridges. 

PC*MILER User Interface - DETAILS 
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o Verifying truck restrictions and allowances. Classifications include truck designated 
roads, truck discouraged roads, height/weight restrictions and allowances, commercial 
prohibited road classifications, hazardous materials restrictions/allowances, and others. 

 

• Fixed reported issue with ZIP code 32542 Eglin Air Force Base, FL. 
• (SPLC data license required) New SPLCs added: 

656972270 Fort Polk Alongside Coco SE5932, LA, Vernon 

844156301 Phillips 66 Ferndale Terminal, WA, Whatcom 

880219270 DFSP Twenty-Nine Palms, CA, San Bernardino 

889513270 Camp Pendleton Super Station SE5P2M, CA, San Diego 

890510241 Hawaii ANG SE8F0G, HI, Honolulu 

890564304 Island Energy Services Kapolei Terminal, HI, Honolulu 

890564305 3D Global Solutions Kapolei Terminal, HI, Honolulu 

 
Worldwide region enhancements for Version 31 include:  
 

• Extensive data updates in over 200 countries, islands and territories. 
• Country code fixes/changes were made for the following countries: 

o Congo, Republic of the: ISO code changed from CD to CG 
o Timor-Leste: GENC code changed from TMP to TLS 
o Congo, Democratic Republic: ISO code changed from CG to CD 

• Added prefecture information to Japan cities to address the issue with duplicate entries being 
returned. 

• Three ferries were added between Hakodate, Aomori, Oma, and Wakinosawa in northern Japan. 
• Added Kuwait Naval Base, KU. 

 

 ENHANCED!  Improved reporting of conditional route and road restrictions in the Detailed 
Route and Driver’s Reports. 

PC*MILER 31 now provides a more complete description of conditional route restrictions in the Detailed 
Route and Driver’s reports, as well as in the Route window’s stop list. 
 
Conditional Restrictions are any link and turn restrictions and/or allowances that are not applicable to all 
types of vehicles at all times. These restrictions include: 
 

• Road Closures – e.g. when a road is closed between 8:00 am and 4:00 pm 
• Truck Restrictions – e.g. when a road is restricted to one direction of travel based on weight 
• Turn Restrictions – e.g. when a road has a left turn restriction from 7:00 am and 11:00 pm 

 
In general, if a special or conditional restriction is encountered along a route, it is now described in the 
Detailed Route Report and Driver's Report in greater detail as well as tagged and summarized in the 
Route window's stop list.  
 
 

 
 



 
PC*MILER 31 Windows Version Release Notes | Page 4  

 
 

 NEW!  Insert new stops in the Route window by clicking the plus sign. 
Inserting stops in the Route window is simplified with this release. Just click the “plus” sign ( + ) in the 
left column at the point where you want to insert the stop. A new row is inserted. This is functionally the 
same as right-clicking a row and selecting “Insert Stop Above” from the menu. 
 
 

 
 

 ENHANCED!  “Truck Restrictions” and “Commercially Prohibited” road attributes now 
displayed by default on the map. 

These attributes can be turned on or off in the Map > Map Features dialog. In previous versions, they 
were turned off by default when PC*MILER was installed. However, based on customer feedback, these 
features are now turned on by default.  
 

 NEW!  Default average road speeds by jurisdiction have been updated to improve drive times 
and ETA calculations. 

Recalibrated default road speeds for trucks now yield more accurate drive times and ETA calculations. 
Users can continue to adjust default average road speeds by accessing the Application Settings window, 
at File > Application Settings > General > Road Speeds.  
 

 NEW!  Cities can now be searched by full state name. 

In the route window, the City field can include the spelled-out name of a state as part of a place name. 
Prior to PC*MILER 31, only state abbreviations could be used when specifying a state.  
 
For example, all of the following forms are now accepted: 
 

princeton, nj 
princeton nj 
princeton, new jersey 
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 ENHANCED!  Expanded range of amenity icons in Place of Interest (POI) searches. 

PC*MILER 31 has expanded the range of amenity icons that appear in POI searches. The new 
icons enable better-informed choices when planning routes. An example of this enhancement is 
shown below: 

 

 
 

 NEW!  Now calculate distances in whole numbers. 

In addition to distance calculations rounded to tenths, hundredths, and thousandths, PC*MILER 31 can 
report distances rounded to the nearest whole number. The setting for this can be found in File > 
Application Settings > Units > Distance Precision.  
 

 NEW!  Support for the change in Mexico's capital name from Distrito Federal (Federal District) 
to Ciudad de Mexico (Mexico City). 

Recently, Mexico changed the name of the country’s capital from “Distro Federal” to “Ciudad de 
Mexico”. To accommodate this change, PC*MILER 31 now accepts the following forms of input for the 
city: 
 

• Mexico City, DF 
• Mexico City, CMX 
• Mexico City, Ciudad de Mexico 

 
"Mexico City, Distrito Federal" and "Mexico City, DIF" no longer exist in the database and cannot be 
entered by the user.  
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 ENHANCED!  “Distance” renamed “Geographical Distance” in results tables. 

In results tables showing the distance to locations or Places of Interest (POI), the “Distance” 
column has been renamed “Geographical Distance.” This was done to clarify that the distance 
shown is a straight-line air distance from the starting point, and not an over-the-road distance 
(which is always longer). An example in the Location Radius window is below: 

 

 
 

 ENHANCED!  Some Route Option categories have been renamed for clarity. 

The following Route Option categories have been renamed as follows: 
 

• “Size and Weight Restrictions” has been renamed “Restrictions”.  
• “Hazardous Materials” has been renamed “Hazmat”. (Requires a license for PC*MILER|Hazmat.) 

 
The changes were made to better reflect their use when generating a route. 
 

 NEW!  New Weather Alert category for “Wind Alerts”. 

(NOTE: Requires a license for PC*MILER|Weather.) A new Weather Alert group called “Wind Alerts” has 
been created. The group contains watches, warnings, and advisories for wind-related weather events 
that were previously grouped in other alert categories, such as Storm Alerts, Winter/Snow Alerts, and 
Air Quality Alerts.  
 

 NEW!  Current and forecasted weather-related road surface conditions displayed on the map. 

(NOTE: Requires a license for PC*MILER|Weather.) PC*MILER now displays real-time weather-related 
road conditions on the map so you can gauge potential impacts on a route plan. Road conditions are 
designated as dry, wet/slippery, water/snow and ice/snow and display as a road-level highlight. NOTE: 
Road condition information requires an active Internet connection. Road conditions are informational 
only and are not used in route calculation. 
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 NEW!  PC*MILER now runs on Windows Server 2016. 

Installation on Windows Server 2016 is supported with this release.  
 

 ENHANCED!  Custom Place icon is now visible at higher zoom levels on the map. 

Users can now view custom places at a greater range of zoom levels on the map.  
 

 NEW!  The Drag Map and Box Zoom tools can now be selected in the Map window. 

The Drag Map and Box Zoom tools have been added to the Map window for ease of use. The tools are 
also available at their original location on the Map ribbon bar.  

 

 
 

 ENHANCED!  Simplified layout of the settings in the Map Features dialog. 

To provide a better user experience, the Map Features settings have been optimized so that they are 
grouped by functional categories. (NOTE: Some features shown may require additional licenses.) 
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 NEW!  Visibility of turn restriction icons are now controlled from the Map window. 

With this release, turn restriction icons (such as no-right or no-left) can be turned on or off within the 
map by right-clicking the map and selecting “Turn Restrictions” from the menu. 
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 NEW!  Save button in the Report window. 

For convenience, a button in the upper right corner of the Report window enables you to Save the 
report. This button works the same as selecting Save Report to File from the File menu. 

 

 
 

 ENHANCED!  Clicking the “X” in the Route window error message clears the message. 

With PC*MILER 31, error messages appearing in the route window can be dismissed by selecting the “X” 
to the right of the message. 

 

 
 

 NEW!  “Distribution Center” Place of Interest (POI) category has been added. 

Now search for and route to POI locations of distribution centers frequented by carriers. Examples 
include Walmart, Target and Amazon distribution centers. 
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 ENHANCED!  Report titles added to the top of previewed and printed reports. 

To help users identify the source and content of reports generated by PC*MILER, the report title is now 
printed at the top.  
 

 NEW!  The Remote Support and License Tools are now accessible from the Help tab. 

From the Help tab, two existing support tools have new ways to access them: 
 

• The Remote Support Tool can be opened by selecting it in the Technical Support group. 
• The License Tool can be opened by selecting it in the Help group. 

 

 
 

 ENHANCED!  Reset to Default option now available in Application Settings > Route Costs. 

A “Reset To Default” button in the Route Costs settings enables the resetting of these values to the 
PC*MILER defaults. 
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 ENHANCED!  The Route window's "Show/Hide" control is now synchronized with the 
Comparison Report’s “Visibility” checkboxes. 

The Comparison Report’s “Visibility” checkboxes and the Route window’s “Show/Hide” controls are 
functionally identical; however, in previous releases, changing one did not change the other. With this 
release, the two controls are synchronized, so that changing one changes the other to the same state. 

 

 
 

 

 NEW!  Automatic verification of disk space before installation. 

The software installation program now verifies that there is enough space on the computer hard drive 
before attempting an installation. 
 

 NEW!  A shortcut to the License Tool is placed on the desktop during installation. 

In addition to a new button on the Help tab, the License Tool can be accessed by selecting a shortcut 
that is placed on the desktop when PC*MILER 31 is installed.  
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 NEW!  Internet-enabled features of PC*MILER can now connect with IPv6 addresses. 

(NOTE: Requires a license for PC*MILER|TCP/IP.) For companies that have migrated to an IPv6 data 
communications schema for added speed and security, PC*MILER can now connect with IPv6 network 
addresses.  
 

 ENHANCED!  New PCMSLookup option 3 for address lookups. 

(NOTE: Requires a license for PC*MILER|Connect.) A new option 3 for the function PCMSLookup() has 
been added to enable address lookup in conjunction with PCMSGetFmtMatch4().  This new functionality 
can be used in place of the deprecated function PCMSLatLongToAddress().  For example: 
 

PCMSLookup (trip, “32.921474,-97.225534”, 3) 
and 
PCMSFmtMatch4() (used as described in the PC*MILER|Connect User’s Guide) 

 

 ENHANCED!  Improved log files include product key codes. 

PC*MILER generates log files that are sometimes used by support staff when customer support is 
necessary. In this release, the log files include the product key codes for your installed products. This 
information can inform support staff of the specific versions of the software installed; which can be 
helpful in troubleshooting.  

 ENHANCED!  Improved sample code is compatible with 64-bit API libraries. 

(NOTE: Requires a license for PC*MILER|Connect.) For programmers who use the PC*MILER|Connect 
application programming interface (API), the sample code included has been updated and verified to be 
compatible with 64-bit libraries.  

Integration Products - DETAILS 


