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PC*MILER® Product Line 

END-USER LICENSE AGREEMENT 
 

1. Grant of License:  Subject to the terms, conditions, use limitations and payment of fees 
as set forth herein, ALK Technologies, Inc. (“ALK”) grants the end-user (“you”) a 
license to install and use the PC*MILER solution(s) (including traffic data 
subscriptions) you have purchased (“PC*MILER”) on a single personal computer.  The 
PC*MILER software, data and documentation are provided for your personal, internal 
use only and not for resale.  They are protected by copyright held by ALK and its 
licensors and are subject to the following terms and conditions which are agreed to by 
you, on the one hand, and ALK and its licensors (including their licensors and suppliers) 
on the other hand. 

 
2. Title:  You acknowledge that the PC*MILER computer programs, data, concepts, 

graphics, documentation, manuals and other material by, developed by or licensed to 
ALK, including but not limited to program output (together, “program materials”), are 
the exclusive property of ALK or its licensors.  You do not secure title to any 
PC*MILER program materials by virtue of this license. 
 

3. Copies:  You may make one (1) copy of the PC*MILER program materials, provided 
you retain such copy in your possession and use it solely for backup purposes.  You 
agree to reproduce the copyright and other proprietary rights notices of ALK and its 
licensors on such a copy.  Otherwise, you agree not to copy, reverse engineer, 
interrogate or decode any PC*MILER program materials or attempt to defeat protection 
provided by ALK for preventing unauthorized copying or use of PC*MILER or to 
derive any source code or algorithms therefrom.  You acknowledge that unauthorized 
use or reproduction of copies of any program materials or unauthorized transfer of any 
copy of the program materials is a serious crime and is grounds for suit for damages, 
injunctive relief and attorneys' fees. 
 

4. Limitations on Transfer:  This license is granted to you by ALK.  You may not directly 
or indirectly lease, sublicense, sell or otherwise transfer PC*MILER or any PC*MILER 
program materials to third parties, or offer information services to third parties utilizing 
the PC*MILER program materials without ALK's prior written consent. To comply with 
this limitation, you must uninstall PC*MILER from your computer prior to selling or 
transferring that computer to a third party. 
 

5. Limitations on Network Access:  You may not allow end-users or software applications 
on other computers or devices to directly or indirectly access this copy of PC*MILER 
via any type of computer or communications network (including but not limited to local 
area networks, wide area networks, intranets, extranets, the internet, virtual private 
networks, Wi-Fi, Bluetooth, and cellular and satellite communications systems), using 
middleware (including but not limited to Citrix MetaFrame and Microsoft Terminal 
Server) or otherwise (including but not limited to access through PC*MILER 
connectivity products), or install or use PC*MILER on a network file server, without 
first notifying ALK, executing a written supplemental license agreement, and paying the 
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license fee that corresponds to the number and types of uses to which access is to be 
allowed. 

 
6. Limitations on Data Extraction:   You may extract data (including but not limited to 

program output such as distances, maps, and driving directions) from PC*MILER and 
use it in other applications on the same computer on which PC*MILER is legally 
licensed and installed.  You may not transfer data extracted from PC*MILER onto any 
other computer or device unless you have licensed PC*MILER for that computer or 
device. 

 
7. Limitations on Mobile Communications:  Without limiting the generality of the 

foregoing, you may not transmit PC*MILER street-level driving directions through 
mobile communications systems such as Qualcomm, satellite, or cellular services or to 
mobile devices such as computers, handhelds, pagers, or telephones without first 
executing a written supplemental license agreement with ALK and paying the license 
fee that corresponds to the number and types of devices and systems to and through 
which transmission is to be permitted. 

 
8. Limitations on Disclosure: You may disclose PC*MILER distances to trading partners 

for specific origin-destination moves for which you provide transportation services and 
use PC*MILER distances as a basis for payment.  You may not make any other 
disclosure of PC*MILER programs and materials, including but not limited to program 
output, to anyone outside the legal entity that paid for and holds this license, without 
prior written permission of ALK.  You acknowledge that the PC*MILER programs and 
materials by, developed by or licensed to ALK are very valuable to ALK and its 
licensors, and their use or disclosure to third parties except as permitted by this license 
or by a written supplemental license agreement with ALK is strictly prohibited. 

 
9.  Security:  You agree to take reasonable and prudent steps to safeguard the security of the 

PC*MILER program materials and to notify ALK immediately if you become aware of 
the theft or unauthorized possession, use, transfer or sale of the PC*MILER program 
materials licensed to you by ALK. 

 
10.  Acceptance:  You are deemed to have accepted the PC*MILER program materials upon 

receipt.  
 
11. Warranties:  ALK represents and warrants that:  

 
A. For ninety (90) days from date of purchase, PC*MILER, when delivered and 

properly installed, will function substantially according to its specifications on a 
computer purchased independently by you. 

 
B. For ninety (90) days from date of purchase, the software media on which ALK 

provides PC*MILER to you will function substantially free of errors and defects.  
ALK will replace defective media during the warranty period at no charge to you 
unless the defect is the result of accident, abuse, or misapplication of the product.  
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C. THE FOREGOING WARRANTIES ARE IN LIEU OF ALL OTHER 
WARRANTIES EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITING 
THE GENERALITY OF THE FOREGOING ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE.  THE 
PC*MILER PROGRAM, DATA AND DOCUMENTATION IS SOLD "AS IS". IN 
NO EVENT SHALL ALK OR ITS LICENSORS BE LIABLE FOR ANY 
INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES SUCH AS, BUT NOT 
LIMITED TO, LOSS IN CONNECTION WITH OR ARISING OUT OF THE 
EXISTENCE OF THE FURNISHING, FUNCTIONING OR USE OF ANY ITEM 
OF SOFTWARE, DATA OR SERVICES PROVIDED FOR IN THIS 
AGREEMENT.  IN THE EVENT THAT A COURT OF PROPER JURISDICTION 
DETERMINES THAT THE DAMAGE LIMITATIONS SET FORTH ABOVE 
ARE ILLEGAL OR UNENFORCEABLE THEN, IN NO EVENT SHALL 
DAMAGES EXCEED THE CONTRACT PRICE.  THIS WARRANTY SHALL 
NOT ACCRUE TO THE BENEFIT OF THIRD PARTIES OR ASSIGNEES. 
 

12. Disclaimer: The data may contain inaccurate, incomplete or untimely information due to 
the passage of time, changing circumstances, sources used and the nature of collecting 
comprehensive geographic data, any of which may lead to incorrect results.  
PC*MILER’s suggested routings and traffic data are provided without a warranty of any 
kind.  The user assumes full responsibility for any delay, expense, loss or damage that 
may occur as a result of their use.  The user shall have no recourse against Canada, 
whether by way of any suit or action, for any loss, liability, damage or cost that may 
occur at any time, by reason of possession or use of Natural Resources Canada data. 

 
13.  Termination:  This Agreement will terminate immediately upon any of the following 

events: 
 

A. If you seek an order for relief under the bankruptcy laws of the United States or 
similar laws of any other jurisdiction, or a composition with or assignment for the 
benefit of creditors, or dissolution or liquidation, or if proceedings under any 
bankruptcy or insolvency law are commenced against you and are not discharged 
within thirty (30) calendar days. 

 
B. If you materially breach any terms, conditions, use limitations, payment 

obligations, or any other terms of this Agreement. 
 
C. Upon expiration of any written supplemental license agreement between you and 

ALK of which this license is a part. 
 

14. Obligations on Termination:  Termination or expiration of this Agreement shall not be 
construed to release you from any obligations that existed prior to the date of such 
termination or expiration. 

 
15. Hold Harmless and Indemnity:  To the maximum extent permitted by applicable law, 

you agree to hold harmless and indemnify ALK and its subsidiaries, affiliates, officers, 
agents, licensors, co-branders or other partners, and employees from and against any 
third party claim (other than a third party claim for Intellectual Property Rights) arising 
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from or in any way related to your use of PC*MILER, including any liability or expense 
arising from all claims, losses, damages (actual and/or consequential), suits, judgments, 
litigation costs and attorneys' fees, of every kind and nature. ALK shall use good faith 
efforts to provide you with written notice of such claim, suit or action. 

 
16. Disclosure for products containing Historical or Real-time Traffic data:  traffic data, 

including historical traffic data, is licensed as a subscription service which must be 
renewed annually for continued use.   ALK and its licensor(s) will use commercially 
reasonable efforts to make traffic data available at least 99.5% of the time each calendar 
month, excluding minor performance or technical issues as well as downtime 
attributable to necessary maintenance, and Force Majeure. 

 
17. Limitations on Export: You hereby expressly agree not to export PC*MILER, in whole 

or in part, or any data derived therefrom, in violation of any export laws or regulations 
of the United States. 

 
18. Miscellaneous:  This Agreement shall be construed and applied in accordance with the 

laws of the State of New Jersey.  The Courts of the State of New Jersey shall be the 
exclusive forum for all actions or interpretation pertaining to this Agreement.  Any 
amendments or addenda to this Agreement shall be in writing executed by all parties 
hereto.  This is the entire Agreement between the parties and supersedes any prior or 
contemporaneous agreements or understandings.  Should any provision of this 
Agreement be found to be illegal or unenforceable, then only so much of this Agreement 
as shall be illegal or unenforceable shall be stricken and the balance of this Agreement 
shall remain in full force and effect. 
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                 Introduction 
 

 
Welcome to ALK Technologies’ PC*MILER!  By purchasing a PC*MILER 
product, you have made a cost-effective investment in the transportation and 
logistics industry’s leading routing, mileage, and mapping software solution.  
Accuracy, reliability, and stability have positioned PC*MILER as the technology 
used by 98% of the top motor carriers and 92% of the top freight transportation 
firms in North America. The U.S. Department of Defense (DoD), the General 
Services Administration (GSA) and the Federal Motor Carrier Safety 
Administration (FMCSA) also rely on PC*MILER as their worldwide distance 
standard. If you're seeking to maximize revenues and minimize costs while 
utilizing the safest, most cost-effective routing for your vehicles and shipments, 
PC*MILER is the answer. 

 
PC*MILER is both easy to learn and easy to use.  You simply enter an origin, a 
destination, and any stops in between, and PC*MILER goes to work to calculate 
truck-specific routing that is displayed on a map.  Distances are returned along 
with time and cost estimates based on adjustable speed, time, and cost parameters.  
Detailed driving directions and a state mileage summary can quickly be generated 
with a click of the mouse.  Multiple routing options and additional features 
provide the tools you need to work effectively and productively.  
 
PC*MILER can be used for rate determination and quotes, trip cost and time 
estimates, dispatch, driver pay calculation, fuel tax reporting, driver log auditing, 
load planning, carrier selection, freight bill auditing, and logistics analysis.  
 
Before you go any further please read the License Agreement that starts on page i.  
It details the terms under which ALK Technologies, Inc. grants you a license, 
ALK's copyrights, and your rights as a licensee.   
 
YOU MAY MAKE ONE COPY OF YOUR PC*MILER PRODUCT DVD FOR 
BACK-UP PURPOSES ONLY.  THE SOFTWARE LICENSE CONTAINED 
IN THIS MANUAL LIMITS THE NUMBER AND TYPE OF COMPUTER ON 
WHICH YOU CAN LEGALLY USE PC*MILER.  BY OPENING AND USING 
THE PC*MILER DVD, YOU HAVE ACCEPTED THE TERMS AND 
CONDITIONS OF THE LICENSE AGREEMENT.  ALK TECHNOLOGIES, 
INC. WILL TAKE PROPER LEGAL ACTION AGAINST ANY ILLEGAL USE 
OF THE PC*MILER SOFTWARE. 
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1.1  What is PC*MILER? 

PC*MILER generates point-to-point mileage, routes, and driving instructions 
over complete highway systems in North America, Bermuda, Greenland and 
Puerto Rico. It can be supplemented with the PC*MILER|Worldwide global 
highway network as a separate purchase.* 

* All instructions for PC*MILER|Worldwide included in this User’s Guide pertain only when 
PC*MILER|Worldwide or DTOD data has been purchased and installed with PC*MILER.    
PC*MILER|Worldwide data is updated and released yearly after the release of the North 
American version of PC*MILER. 
 
PC*MILER will calculate an unlimited number of routes and mileage on a single 
personal computer or a network installation. 
 
PC*MILER calculates point-to-point mileage for an origin-destination pair of 
locations with intermediate stop-off points.  It provides leg and cumulative 
mileage, time and cost estimates, state/country distance summaries, driving 
directions, and  much more.  PC*MILER provides Practical, Shortest, Fastest, and 
Least Cost routing, as well as additional options in North America for National 
Network, Toll Discouraged, 53'/102'' Trailer and Twins, and Hazardous Material 
routing and (optionally in the U.S. and Canada) local street networks. 
 
PC*MILER Version 28 includes the following major features: 
 
 Time-based routing gives users the ability to define a departure or arrival 

time for more precise calculation of ETA/ETD. 

 Fastest Routing – In addition to standard PC*MILER Practical and Shortest 
route types, Fastest routing calculates the quickest feasible way to get to a 
destination.  (North America only, PC*MILER|Traffic required) 

 Least Cost Routing – Least Cost routing generates several alternative routes 
based on multiple user-specified trip cost values.  (PC*MILER|Tolls required for toll 
cost calculation) 

 Optional traffic data feed for more realistic transit times and real-time, historical 
or typical traffic display on the map (North America only, PC*MILER|Traffic required) 

 ALK’s RouteSync® provides a direct link between PC*MILER in the back 
office and ALK’s CoPilot Truck GPS navigation software in the cab.  
(RouteSync license purchase required)  

 User-specified vehicle dimensions for routing and toll calculation (includes 
an automobile routing option for vehicles classed less than 9,000 lbs./ 4,082 
kgs. and custom vehicle profiles). (PC*MILER|Tolls required for toll cost calculation) 

 Custom Routing Preferences – Avoid, favor, or override specific roads, and 
create and manage multiple sets of routing preferences. 

 Custom Route and Vehicle Profiles for custom routes and vehicle 
dimensions you use often. 
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 Toll Calculation with the purchase of the PC*MILER|Tolls add-on. (U.S. and 
Canada only) 

 Greenhouse Gas Estimator – For estimating greenhouse gas emissions by 
route. 

 Ability to customize place names to conform to the name of your facilities 
and customer locations. 

 Import Custom Place feature, allowing seamless importing of custom address 
and pickup/delivery information to eliminate manual trip entry. 

 RouteMap, "the electronic road atlas" for map quality graphics. 

 A Drag Route map feature for instant route customization and visualization. 

 Via Points creation and management for customized routing. 

 Geofence Tools – Create geofenced areas on the map and have PC*MILER 
avoid these areas or send a warning if routes travel in or out of them. 

 Location Radius – For rate determination and operations planning, this tool 
lets you search for all cities, ZIP and postal codes, towns, points of interest, 
and custom points within a specified mileage radius around any location. 

 Unlimited number of stop-off locations.  

 Multiple route generation with on-screen comparison reports to determine 
the best route. 

 Points of Interest (POI) database with customizable categories. 

 County name designations for all U.S. locations.  

 Comprehensive height and weight restrictions, including 53'/102'' Trailer 
or Twins and enhanced Light and Heavy Vehicle routing. 

 Reports and maps that can be exported via clipboard for use with 
spreadsheet, word processing and database software. 

 Ability to point and click on the map to select origin, stop-offs and 
destination, plus mouse-driven map customization. 

 Custom cost/time estimates for empty/loaded miles. 

 Custom average road speed estimates. 

 Optional remaining U.S. DOT Hours of Service (HOS) user input, with HOS 
breaks included in driving instructions. 

 A Border Wait Time option that takes into account expected delays at 
international border crossings. 

 Hub mode that determines routing, total mileage and state mileage summaries 
from one origin point to unlimited destinations.  

 State/Country mileage summaries including ferry miles. 

 Latitude/Longitude routing that generates point to point routes and mileage 
between lat/long coordinates. 

 Speed limits by state/province/estado. 

 A system of Help files that is easy to use and comprehensive. 
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 U.S. Department of Defense compliance. 

 The complete North American highway network that includes the United 
States, Canada, and Mexico plus Bermuda, Greenland and Puerto Rico. 

 ALK Technologies’ complete Worldwide Highway Network, updated yearly 
to include the most current data available. (PC*MILER|Worldwide or DTOD data 
required for global routing) 

 Optional add-on data modules for street-level addresses and map detail in 
the United States and Canada, Europe, India, and available countries in 
Africa, the Middle East, Oceania and South America. (PC*MILER|Worldwide 
required for address data outside North America) 

 Optional add-on data module for hazardous material routing. (U.S. and 
Canada only; PC*MILER|HazMat add-on module required) 

 

1.2  What can PC*MILER be used for? 

You can use PC*MILER for:  
 

 Truck-specific routing and mileage calculations for Shortest, Practical, Fastest 
and Least Cost routes, with additional options for Toll Discouraged, National 
Network, and 53'/102'' Trailer routing in North America 

 A direct link between PC*MILER in the back office and CoPilot Truck in the 
cab (ALK’s RouteSync license required) 

 Hazardous material routing for safety and compliance (with the 
PC*MILER|HazMat add-on module, U.S. and Canada only) 

 Toll cost calculation (with the PC*MILER|Tolls add-on module, U.S. and Canada only) 

 Least Cost routing 

 Dispatch 

 Driver pay  

 Rate determination 

 Instant customer quotes  

 Fuel tax reporting 

 Trip time and/or cost estimation 

 Driver log audits 

 Load planning 

 Empty and loaded mile reporting 

 Stop optimization 

 Carrier selection 

 Logistics analysis 

 Freight bill auditing 

 IFTA and IRP auditing 

 FHWA safety auditing 
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1.3  What’s New in PC*MILER Version 28? 

NOTE for PC*MILER|Worldwide and DTOD Data Customers:  Beginning 
with Version 28, the .1 versions of PC*MILER have been discontinued.  
PC*MILER|Worldwide and DTOD Data users who historically purchased a .1 
version of PC*MILER can now install the base version of PC*MILER and then 
install PC*MILER|Worldwide or DTOD data as a separate add-on – see section 
2.5.4 for installation instructions.  This is the same seamless data installation as in 
the past, only the additional .1 version number has been dropped. 
 
NOTE:  Beginning in Version 27, the PC*MILER interface was redesigned and 
now looks very different from previous versions.  For users of Version 26 and 
earlier who are updating, a Feature Reference Guide provides the new locations 
for features that you are already familiar with.  To access it, select the Windows® 
Start menu > All Programs (or the equivalent in your version of Windows) > 
PCMILER 28 > User Guides > Feature Reference Guide.  

 
NOTE Also:  PC*MILER includes an easy way to check for upates from within 
the application.  Keeping current on updates is important to maintain the 
usability of your copy of PC*MILER.  See section 15.3, PC*MILER Updates, 
or the Check for Updates topic in the PC*MILER Help files. 
 
 
Version 28 includes the following new features and enhancements: 
 
 NEW!... PC*MILER|Energy.  Available as a data add-on module that is 

separately purchased and licensed, PC*MILER|Energy provides oil- and gas-
specific data and facilities including bonded or leased access roads.  Users can 
now generate driving directions that take them directly to facilities including 
off-road wells, compressor stations and plants. 

 NEW!... Custom Route Profiles.  A new Route Profiles Manager enables 
you to create and save Custom Route profiles that include routing preferences 
and vehicle dimensions you use often.  See section 11.3. 

 NEW!... Vehicle Type Identifier.  When setting vehicle dimensions in the 
Route Options dialog, a new Vehicle Type field now clearly identifies the 
PC*MILER routing characteristics that will be factored in when the route is 
generated.  See section 9.6.1 and 9.6.3. 

 NEW!... Import Default Configuration and Route Settings.  Many 
additional custom default settings can now be imported from the previous 
version of PC*MILER, including route options, custom road speeds, custom 
vehicle profiles, and more.  See section 2.8. 

 NEW!... Copy Geocoded Stops.  For ease of use, a geocoded stop can now 
be copied or moved from one route window to another, or dragged to a 
different position in the same window.  See section 3.6.25. 
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 NEW!... A Column Chooser In Route Windows and Reports.  The new 
Column Chooser lets you hide, display or change the order of data columns in 
any route window or report.  To access it, right click any stop on the stop list 
in a route window or the column headers in any report.  See section 3.9.2. 

 NEW!... Print Reports With User-Defined Views.  When columns in a 
report are hidden, repositioned or resized by the user, these changes are now 
retained for printing and can be seen in Print Preview mode.   

 NEW!... Report Location Menu To Place the Reports Pane Where You 
Want It.  Now choose where the Reports pane will appear when a report is 
generated.  This menu in the Window tab replaces the Reports Window button 
in PC*MILER 27.   

 NEW!... Individual Routes and Reports In Their Own Modal Windows.  
Each individual route or report can now be floated in its own window.  See 
section 3.3 and Chapter 8. 

 NEW!... Proxy Server Setup Option.  This new option in PC*MILER 28 is 
for those users who need to bypass their current corporate security settings to 
access the internet during license activation and while using PC*MILER (for 
example, when accessing real-time traffic data or periodic PC*MILER 
updates).  See section 2.5.2 or 2.7. 

 NEW!...  Assign Custom Road Speeds to the New “Ramp” Road Class.  
PC*MILER road categories now include “Ramp” for access ramps on and off 
major highways or interstates.  The default road speed assigned to ramps is 20 
MPH and can be changed using the Route Options dialog.  See section 9.7.1. 

 NEW!...  Ability to Hide/Display the Comment Box for Road Preferences.  
If you don’t want to have the Add Comments box pop up every time you 
designate a road preference on the RouteMap, a new setting in the Application 
Settings dialog provides the option to hide these prompts.  See section 11.1. 

 ENHANCED!... Custom Categories in the Custom Place Manager.  Using 
updated tools for creating custom places, users can now create and save their 
own custom place categories.  See section 3.13. 

 ENHANCED!...  New Custom Road Manager Dialogs.  The Custom Roads 
Manager in earlier versions of PC*MILER has been replaced with two 
Manager dialogs, the Avoid/Favor Manager and the States/Roads Manager.  
These dialogs include an interactive map for easier selection of road 
preferences, eliminating the need to switch between the RouteMap and the 
Manager.  See section 11.1. 

 ENHANCED!...  “Special Restrictions” Supported in Routes and Reports.  
Time-based routing now integrates road restrictions that are active only during 
specific times.  When you select an arrival or departure time for a trip, 
PC*MILER will now route around roads that have time-based restrictions.  
See section 5.4. 
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 ENHANCED!... PC*MILER|Tolls Discount Program Update.  NEXUS 
has been removed from the PC*MILER database of toll discount programs.  
No new toll discount programs were added in Version 28.  (PC*MILER|Tolls 
must be installed)   

 ENHANCED!... Yearly Database Enhancements and Routing 
Improvements in North America and Worldwide (Includes U.S. ZIP 
Code & SPLC Updates) – The PC*MILER industry-standard highway 
network database is updated yearly to include the most current data available.  
Throughout the year, ALK Technologies’ team of network editors and 
Geographic Information System (GIS) specialists spend countless hours 
gathering new data, researching current road construction and other changes, 
and incorporating customer feedback. 

The PC*MILER|Worldwide 28 release integrates the following routing 
improvements: extensive updates in 61 countries, with upgrades to 
Comprehensive coverage in Egypt, Lesotho, Morocco, Namibia, South Africa, 
Swaziland, India, Bahrain, Jordan, Kuwait, Lebanon, Oman, Qatar, Saudi 
Arabia and United Arab Emirates. See Appendix I for more on worldwide data 
coverage and postal code access. 

Additionally, a new Middle East region was added and the following countries 
were reclassified: 

 Bahrain, Jordan, Kuwait, Lebanon, Oman, Qatar, Saudi Arabia, United 
Arab Emirates, Iran, Iraq, Israel, Syria, West Bank and Yemen are now 
grouped in Middle East. 

 Cyprus is now included in Europe instead of Asia. 

 Central American countries of Belize, Costa Rica, El Salvador, 
Guatemala , Honduras, Nicaragua, Panama, Curacao, Saint Barthelemy, 
Saint Martin, Sint Maarten are now grouped with South America. 

 US Virgin Islands is included in North America. 
 
Version 28 also includes the following improvements to ALK’s North 
American highway network: 

 Addition of newly built roads along with new road names to the database 

 Improved routing results when selected vehicle dimensions match a 
medium duty sized vehicle 

 Realignment of the existing road network to GPS standards 

 Update and addition of exit interchanges and alignment of ramp structures 

 Reclassification of roads where necessary (e.g. changing a road from 
secondary to primary, confirming one-way designations) to provide safer 
navigation and guidance 

 Update of street-level address changes 

 Improvement of ZIP/Postal Code placement and alignment 
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 Specifically for commercial vehicles, additional updates include but are 
not limited to: 
o Defining urban-classed roads to keep commercial vehicles out of city 

centers and on higher-classed beltway roads 
o Verifying and coding truck-designated routing attributes throughout 

the network with a special focus on metropolitan areas (e.g. keeping 
drivers on roads designated by local and state authorities as 
preferred/ designated for truck travel) 

o Reclassing vertical clearance data to accurately model low viaducts 
o Defining specific routing designations for truck-through travel 

within a city’s limits 
o Verifying truck restrictions and allowances  (classifications include 

truck designated roads, truck discouraged roads, height/weight 
restrictions and allowances, commercial prohibited road classifications, 
hazardous materials restrictions/allowances, and others) 

 

 ENHANCED!... Annual Updates of Defaults for US$/CAD$ Conversion 
Rate and Trip Costs.  In Version 28, the default US dollar/Canadian dollar 
conversion rate as applied to toll rates (if PC*MILER|Tolls is installed) and 
default fuel/trip costs are as follows (in U.S. dollars): 

 
Cost/Time Parameter  Version 28  Version 27 

US$/Canadian$ Conversion Rate  $1.00/$.951  $1.00/$.995 

Fuel Cost Per Gallon  $3.95  $3.94 

Fuel Cost Per Liter   $1.04  $1.0408 

Fuel Cost Per Mile (Loaded or Empty)  $.61  $.6080 

Fuel Cost Per Kilometer (Loaded or Empty)  $.61  $.3778 

Other Cost Per Mile (Loaded or Empty)  $.18  $.19 

Other Cost Per Kilometer (Loaded or Empty)  $.11  $.1180 

Labor Cost Per Hour (Loaded or Empty)  $31.64  $36.19 
 

 

1.4  The PC*MILER Highway Database 

All PC*MILER products are based on ALK Technologies' proprietary computer 
representation of the North American and Worldwide highway systems.  The 
distances contained in PC*MILER are derived from official highway maps 
obtained from state, provincial, and national governments, state DOT maps, county 
maps, local maps, and information received from thousands of industry contacts.  
All U.S. Interstate, Federal and truck-specific State highways are included.   
 
PC*MILER Version 28 data features thousands of new and updated North 
American road miles and locations including: bridges and tunnels, border 
crossings, highway exits, truck stops, state weigh stations, CAT Scale weigh 
stations, all year-2014 five-digit U.S. ZIP codes, all U.S. Department of 
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Defense military installations, commercial truck restrictions in the United 
States, Canada, and Mexico, plus all highway junctions and hundreds of 
thousands of cities, towns, and points of interest.  
  
With the purchase of separate add-on data modules, updated databases of 
Canadian Postal Codes, SPLC, and comprehensive U.S. federal, state, and 
local Hazardous Material restrictions and designations are available as well.   
 
In addition, ALK offers several other regularly updated add-on data modules for 
use with the base PC*MILER product: PC*MILER|Streets for address-to-
address routing (see below); PC*MILER|Energy for oil and gas specific data 
and facilities; PC*MILER|Worldwide for global point-to-point routing; 
PC*MILER|Tolls for toll calculation. 
 
 

1.4.1  PC*MILER Local Street and International Data 
 

In North America, users have the ability to add street-level detail to generate 
door-to-door routes and mileage.  PC*MILER's local street-level databases, 
included with the purchase of the PC*MILER|Streets data module, cover the 
United States and Canada* and include a comprehensive address database, along 
with related routing options and map detail.   
 

* Note that with the purchase of PC*MILER|Streets, street-level detail in the U.S. comes standard 
and a separate purchase of the Canadian Street-Level Add-On is necessary to access related data 
in Canada. 
 
Also available for purchase is the PC*MILER|Worldwide data add-on to generate 
point-to-point truck-specific mileage, driving directions and maps over the entire 
international highway network.  PC*MILER|Worldwide includes access to 
highway data in Africa, Asia, Europe, Middle East, North America, Oceania, and 
South America.  Worldwide data is updated yearly after the base release is 
completed.  Optional street-level data in many countries and regions can be 
purchased along with a PC*MILER|Worldwide installation. 
   

1.5  Distance Calculation 

NOTE for PC*MILER|Streets Users:  By default, routes in North America are 
calculated with the “Use Highway Only” option turned on in the Route Options 
dialog box.  This option can affect distance calculation, and may be turned off – 
see section 9.3.2 for a description of distance calculations for highway-only and 
street-level routing. 

 
Distances and routing directions are calculated by first determining which roads a 
vehicle will travel to get between two points and then adding up the distances 
over each section of road to arrive at a total mileage, similar to the manual task 
that one might follow if using an atlas. 
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Routing to all stops will “clean up” to the nearest truck-usable road on the 
highway or local street network.  This local distance equals the short air distance 
between where the point is plotted on the map and the closest truck-usable road.  
In the Detailed Route report, which lists every route segment and interchange on a 
route, this distance may appear as “Local”. 
 

1.6  PC*MILER Route Types 

PC*MILER offers three basic route types: Practical, Shortest and Fastest. For 
routing in North America, any of these may be combined with one or more of the 
three other PC*MILER route types (Toll Discouraged and National Network or 
53'/102'' Trailer or Twins Routing).   
 
Light Vehicle routing for vans, automobiles, pickup trucks, SUVs, etc. is also 
available (North America only), and Least Cost routing may be generated for the 
Practical, Shortest or Fastest route type.  See sections 1.6.1 – 1.6.8 below for 
detailed descriptions of each route type.  See Chapter 9 for route options. 
 
 

1.6.1  PC*MILER Practical Routes 
 

PC*MILER Practical Routes represent distances and driving routes that a driver 
would normally take to minimize time and cost. Practical Routes model the trade-
off between taking the most direct path and staying on major, high quality 
highways.  Interstate highways are given a higher priority than toll roads, which, 
in turn, are given a higher priority than secondary highways, and so on.  Routing 
instructions and mileage can be used when actual travel distances and directions 
are needed. 
 
PC*MILER Practical routings consider distance, road quality, terrain, urban/rural 
classifications, truck-restricted roads, and designated principal and secondary 
through routes. 
 
In the United States, PC*MILER Practical Route mileage and state-by-state 
mileage breakdowns can be used to supplement your regular fuel tax reporting 
documents for many states.  Many state audit departments have purchased 
licenses to incorporate PC*MILER into their audit procedures. 
 
NOTE:  A PC*MILER user may still be assessed additional taxes even by 
those states using PC*MILER in their audit procedures.  However, your 
chances of being assessed additional taxes greatly diminishes by utilizing a 
computerized mileage system in conjunction with your driver logs, trip sheets, 
invoices, and bills of lading. 
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In order to minimize the possibility of significant tax assessments, you must 
verify that the PC*MILER generated route is the same as that reported on your 
driver logs and/or trip sheets.  In addition, you must add the appropriate vicinity 
miles to the PC*MILER generated mileage so that the following equation is true: 
 
TOTAL ODOMETER MILES = PC*MILER Miles + Vicinity Miles 
 
NOTE:  PC*MILER accounts for some vicinity miles if non-Keypoints 
(generally postal code locations and/or place names not associated with the 
downtown metropolitan area) are used as stop-off locations. 
 
ALK Technologies continues to work closely with the member states of the 
International Fuel Tax Agreement (IFTA) and the International Registration Plan 
(IRP).  Currently many IFTA/IRP states are using PC*MILER as an auditing tool 
in their fuel and mileage tax audit procedures. 
 
 

1.6.2  PC*MILER Shortest Routes 
 

PC*MILER Shortest Routes represent distances and driving routes that a vehicle 
would take to minimize total distance traveled while still following a reasonable 
route.  For instance, Shortest Route mileage and routes will also avoid truck-
restricted roads and, in some cases, may favor a beltway rather than traveling 
directly through a city. 
 
ALK believes, however, that carriers and shippers alike would all be better served 
by using a mileage tariff based on actual miles traveled (i.e. similar to those 
generated using the PC*MILER Practical Route option), which would more 
accurately reflect true transportation costs. 
 
 

1.6.3  PC*MILER Fastest Routing (North America only) 
 
(PC*MILER|Traffic must be installed and activated.)  In addition to the standard 
Practical and Shortest routing types, PC*MILER now provides a Fastest routing 
type.  Fastest routing uses any day of the week or time of day information that has 
been set for a route (these are optional settings for Fastest routing) in conjunction 
with Inrix® real-time and/or historic traffic data to calculate the quickest route to 
the trip’s destination(s).  Users who ship time-sensitive freight can select a Fastest 
route that may be longer in distance but save time over the standard Practical 
route. 
 
Additionally, Least Cost routing (see section 1.6.8) now considers Fastest and 
Fastest with Toll Avoidance route types, increasing the number of routes 
considered to six.  Users can opt to utilize Least Cost routing to select the route 
that arrives on time but costs the least, using default or user-specified costs. 
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1.6.4  PC*MILER National Network Routes (U.S. only) 
 

The National Network is a U.S. government-designated system of highways 
originally established by the Surface Transportation Assistance Act of 1982 
(STAA).  This routing option is based on the federally-designated National 
Network system updated in the April, 1992 Code of Federal Regulations, Part 
658, Appendix A.  The National Network includes the Interstate System (several 
minor segments are not included), and many selected U.S. and state highways.  
Highways continue to be added to the National Network by federal and state 
governments. 
 
PC*MILER National Network routing represents distances and driving routes 
which are most reasonable and legal for the larger trucks authorized by the 
Surface Transportation Assistance Act of 1982. 
 
National Network routing stays on the National Network to the maximum extent 
possible.  Given that many areas are not directly served by the National Network, 
the origin and stop-offs of your route may not be on the National Network.  In 
these cases PC*MILER will take the shortest reasonable path from the origin and 
stop-offs to the Network.  Detailed Route Reports (driving directions) for 
PC*MILER National Network routes provide a warning wherever the route is 
forced to use a non-conforming link.  These road segments should be checked 
before traveling. 
 
National Network mileage tends to be higher than Shortest or Practical mileage. 
 
These designated highways permit, at a minimum, 102" wide, single 48 ft. trailers 
and 28 ft. double trailers.  The Interstate system and most, but not all, remaining 
designated routes are open to 80,000 pound vehicles.  Certain states, notably 
Arkansas and Mississippi, have designated certain National Network segments 
with less than an 80,000 pound capacity. 
 
In addition to the National Network highways, access routes and access policies 
are components of routing STAA dimensioned trucks.  The Federal government 
has mandated that no state may prohibit travel from the National Network for a 
minimum of one road mile unless safety restrictions apply.  Also, no state may 
deny reasonable access to terminals and facilities for food, fuel, repairs and rest. 
 
Several states maintain more generous access policies and lists of specifically 
designated access routes to terminals and facilities.  Should you need to travel 
beyond the National Network and the access roads, you must acquire the proper 
permit.  See Appendix A for access rules by state. For detailed information about 
pre-approved access routes, contact the individual states. 

 
NOTES: These suggested National Network routings are based on official 
highway maps, the Code of Federal Regulations, and information provided by 
state governments.  It is provided without a warranty of any kind.  The user 
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assumes full responsibility for any delay, expense, loss, or damage which may 
occur as a result of its use. 
 

See Appendix A, Access Policies From National Network Routes, for the current 
status of National Network access policies.  For detailed information about pre-
approved access routes, contact the individual states. 

 
 

1.6.5  PC*MILER 53' Trailer or Twins Routing (U.S. only) 
 
Because every mile equals money, PC*MILER offers enhanced routing 
specifically for 53'/102'' trailers or 28' tandem trailers (“twins”).  The calculations 
for these routes are based on National Network routing, with the addition of roads 
that permit 53'/102'' trailers or twins.   
 
The regulations that govern the routing of trucks in North America are a function 
of weight, height, number of axles, distance between axles, number of trailers, and 
commodity.  These regulations take two principal forms: restrictions and 
designations.  In the case of designations, trucks may deviate from the designated 
road network, on any road that is not otherwise restricted, to access points of 
loading, unloading and services.   
 
Under a 1991 U.S. federal law known as the STAA, the most important 
distinction in truck designations is between 96'' wide, 48' long trailers on the one 
hand and 102'' wide, 53' long trailers (and twin 28' long trailers) on the other hand.  
When the 53' Trailer and Twins routing option is used in PC*MILER, or when a 
width of greater than 96'' or a length greater than 48' is entered into PC*MILER as 
the vehicle size, PC*MILER’s routing algorithm switches to favoring roads 
designated by the states for “oversize” trucks (meaning over 96'' wide or over 48' 
long).     
 
In PC*MILER, the routing designations for the following equipment types are 
included in the 53' Trailer or Twins (formerly named “53' Trailer”) routing 
category: 

 double trailers no more than 28' long and 102'' wide; 
 semi-trailers longer than 48' or wider than 96'', but no longer than 53' and no 

wider than 102''. 
 
Detailed Route reports for PC*MILER 53' Trailer and Twins routes warn that a 
road is “Not Designated” if that road is necessary to reach an origin, destination 
or stop-off outside of the maximum access distance for that state.  In this case a 
red bar also appears in the route window to the left of the stops on that link. 
   
If such a warning appears, then a legal route for 53' equipment is either not 
possible under current state designations or would be so circuitous that you should 
either consider assigning smaller equipment or petitioning the state to designate a 
more direct access route.  Users should check the legal requirements on these 
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roads because they vary; for example, delivery may be legal, but stopping for 
food or services may not be. 
 
 

 
 

53' Trailer and Twins Restriction in Detailed Route Report 
 
 
If the Designated Truck Routes layer in the Map Features dialog is turned on 
(see section 10.7), the RouteMap will display the 53-foot designated network with 
a blue underlay when the map scale is approximately 1'' equals 8 miles or less. 
This underlay is hidden by default.  (Note: If you have the PC*MILER|HazMat 
module installed and the Hazardous Material layer is turned on, you may want 
to turn it off for a better view of designated truck routes.) 
 
 

1.6.6  PC*MILER Toll Discouraged Routes 
 

For those who desire to avoid long stretches of toll roads, ALK provides a Toll 
Discouraged routing option.  Toll Discouraged routing will avoid long stretches of 
toll roads but will not take long, impractical detours to avoid toll bridges and 
tunnels.  For example, a routing from Boston, MA to Albany, NY will avoid the 
Massachusetts Turnpike, but a routing from Camden, NJ to Philadelphia, PA will 
include a toll bridge. 
 
NOTE:  PC*MILER chooses routes by minimizing a cost equation that combines 
distance, certain factors times distance, and certain fixed factors.  When Toll 
Discouraged is selected for a route, the factor that is multiplied times distance for 
toll roads is higher than when Toll Discouraged is not chosen.  This causes the 
route chosen to go a somewhat longer distance (all other factors being equal), but 
not an extremely longer distance, in order to avoid paying a toll. 
 
To see whether the Toll Discouraged option is cost-effective for you or your fleet, 
you may want to consider using ALK’s PC*MILER|Tolls add-on module and  
PC*MILER|Spreadsheets to analyze how much toll cost you will save versus how 
much additional mileage and time cost you will incur, for the particular  origin-
destination pairs that you run frequently.  See Chapter 7, Getting Toll Costs for 
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more details about PC*MILER|Tolls.  To purchase PC*MILER|Tolls and/or 
PC*MILER|Spreadsheets, contact your Enterprise Solutions account executive. 
 
 

1.6.7  Routing For Different Sizes of Vehicles, and Restriction Overrides 
 

By default, PC*MILER generates routes and mileages for large, heavy trucks of a 
particular size and weight (in North America, 5-axle tractor-semitrailer 
combination, 96” wide, 48’ long trailer, 13’6” high, 80,000 lbs GVW; routing for 
102” wide 53’ long trailers and 28’ twin trailers is available by checking “53’ 
Trailer or Twins” in the Route Options dialog box).   You can route other sizes 
and weights of trucks by setting vehicle dimensions, choosing among pre-defined 
vehicle profiles, or creating a user-defined vehicle profile.  See Chapter 9, Using 
the Route Options Dialog Box, specifically sections 9.2, 9.3 and 9.6. 
 
PC*MILER also includes a routing option specifically for automobiles and other 
light vehicles (vans, pickup trucks, SUVs, etc.) that relaxes all truck and 
commercial vehicle regulations (see section 9.6.5). 
 
Additionally, the “Override Restrictions” setting in the Route Options dialog box 
is available.  This option relaxes truck restrictions for particular sizes and weights, 
but still avoids roads that are prohibited to or discouraged for all trucks.  If a 
resulting route uses any roads that have restrictions for particular sizes and 
weights, the Detailed Route Report will list them.  This allows you to determine 
the largest or heaviest vehicle you can assign to drive that route.   
 
By default Override Restrictions is off, in which case PC*MILER routing will 
avoid both truck-prohibited and truck-discouraged roads, as well as truck-
restricted roads that pertain to the size and weight set in the current vehicle 
dimensions or profile.  In addition, nationwide 13' 6" height restrictions will be 
taken into account.  
 
 

1.6.8  Least Cost Routing 
 

In response to the needs of our customers, ALK has developed the new “Least 
Cost” routing feature that considers user-specified values for miles per gallon, 
cost per gallon, fuel cost per mile, maintenance cost per mile, labor cost per hour, 
and stop cost – and includes a parameter for a greenhouse gas emission estimate. 
If PC*MILER|Tolls is installed, toll costs are factored in as well. 
 
Least Cost routing presents a series of alternative routes with time and costs, 
identifying the route that is least-cost, and lets the dispatcher or driver (or an 
external system, such as a truck dispatch optimization system) choose the 
alternative route that’s optimal for them, considering the factors that are external 
to the route.  See Chapter 4 for a full description of this routing type.   
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             Getting Started 
 

 

Before installing PC*MILER, please make sure that you have the required 
hardware and software configuration.  All PC*MILER software, databases and 
auxiliary files are provided on the PC*MILER installation DVD. 
 

2.1  System Requirements 

 

NOTE:  Please check for updates regularly in order to maintain the usability of 
your current copy of PC*MILER – select the Help tab > Check for Updates. 
 
 

2.1.1  Platforms 
 

 Windows XP, 7 and 8 running in 32-bit compatibility mode as well as support 
for 64-bit native applications on Windows 7 and 8 – please see section 2.4 if 
installing connectivity products on a 64-bit machine 

 AS/400 
 CICS/MVS 
 UNIX (AIX, HP-UX, Sun-Solaris) and Linux™ 
 Citrix Metaframe 
 Windows Server (Terminal Servers, Server 2003, Server 2008 including Server 

2008 R2 running in 32-bit compatibility mode for the Interactive GUI and on 64-
bit processors for PC*MILER Connect, Mapping, BatchPro, and Spreadsheets) 

 TCP/IP functionality for use with other platforms 

NOTE:  Platforms not supported include: SCO UNIX, Windows® 95, 98 First/ 
Second Edition, Me, 2000, NT, 2003 and Vista. 
 
 

2.1.2  Requirements 
 
Environment: 
 Stand-alone PC with a 1.5-2 GHz processor or networked personal computers 

(LANs and Server/Thin Client Networks)  
 512 MB RAM minimum, 1 GB strongly recommended for standard desktop 

users.  For Citrix and Terminal Server, 200 MB RAM for each user running 
PC*MILER|Connect and PC*MILER|Spreadsheets. 
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Other Requirements: 
 DVD-ROM or CD/DVD Drive 
 Minimum screen resolution 800X600 
 Color quality settings supported: 16-bit and 32-bit (8-bit & 24-bit not supported) 
 Internet connection for license activation (recommended) and access to select 

features such as Satellite imagery and real-time Traffic data on the RouteMap. 
 Email address for license activation 
 

NOTE:  The hard disk requirements listed below are approximate.   
 
PC*MILER: 
 PC*MILER – 2.6 GB hard disk space for full install (including all Add-Ons 

listed below except PC*MILER|Energy, and all Connectivity products) 

o PC*MILER|Tolls – 50 MB hard disk space 
o PC*MILER|Hazmat – 50 MB hard disk space 
o PC*MILER|Streets (U.S. Data) – 1.3 GB hard disk space 
o PC*MILER|Streets (Canadian Data) – 60 MB hard disk space 
o Canadian Postal Codes – 50 MB hard disk space 
o Standard Point Location Codes (SPLC) – 2 MB hard disk space 
o PC*MILER|Energy – 2.5 GB hard disk space 

  
Connectivity Products: 
 PC*MILER|Connect – 3 MB hard disk space 
 PC*MILER|Mapping – 3 MB hard disk space 
 PC*MILER|Spreadsheets – 3 MB hard disk space 
 PC*MILER|BatchPro – 2 MB hard disk space 
 PC*MILER|TCP/IP – 2 MB hard disk space 
 

NOTE:  PC*MILER|Connect and PC*MILER|Spreadsheets support x86-64 
architecture.  Our software was not ported to IA-64 architecture although it 
will still be supported through a hardware compatibility mode. 

 

PC*MILER|Worldwide: 
 Worldwide Highway Network Only – 5.3 GB hard disk space 
 PC*MILER|Streets Data hard disk space requirements: 

 United States – 1.3 GB 
 Canada – 60 MB 
 Africa – 263 MB 
 Europe – 3.38 GB 
 Asia – 616 MB 
 Middle East – 179 MB 
 Oceania – 189 MB 
 South America – 339 MB 

 
RouteSync™ Requirements: 
 CoPilot Truck running on one or more mobile devices and registered with 

CoPilot Live Messaging 
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 CoPilot Truck Version 9 supported platforms are: Windows® XP, Windows 7, 
Windows Mobile, Windows CE, iPhone, iPad, and Android 

 RouteSync license key code and street-level data in the US and/or Canada 
 
These additional components will also be installed: 
 Microsoft Visual C++ 2005 Redistributable Package (x86) – 6 MB disk space 

 WindowsInstaller-KB884016-v2-x86.exe (x86) – 2 MB disk space 

 .NET dotnetfx.exe (x86) – 280 MB disk space 
 

 
2.1.3  AS/400 Requirements 

 
PC to AS/400 Connectivity Options (Not Provided by ALK): 

 PC with a 2+ GHz processor 
 Client Access Express V4R4MO or higher, also known as iSeries Access 

(recommended) 
 Supports OS/400, i5/OS and IBMi operating systems; Version 4.2 (V4R2) and 

higher on IBM AS/400, systemi and power Systems hardware. 
 
 

2.1.4  CICS Requirements 
 
Because PC*MILER-CICS employs a distributed processing solution, the 
following additional hardware is required to run the software: 

 A dedicated PC with a high-end Pentium processor (1.5-2 GHz or greater) 
 512 MB RAM (minimum), 1 GB recommended 
 Communication software from Quotium Technologies (formerly ICOM 

Informatics) called Winsurf+ can be found at www.Quotium.com 
 
 

2.1.5  UNIX and LINUX Requirements 
 
Contact PC*MILER Technical Support for more information. 

 

2.2  General Licensing Information 

Single-User License 

A single-user license can be installed to only one PC or workstation locally. 
 

Multi-User License 

A multi-user license can be installed to a server environment, on the computer 
that will be sharing the licenses to other computers.  It allows “x” number of 
concurrent workstation connections to PC*MILER at a time.  For example, a  
5-User License allows one installation on a central server or PC with as many 



   
 

 
 Chapter 2:  Getting Started  19 

workstation PCs as you want having access, but only 5 users can access 
PC*MILER at the same time. 

 
Enterprise License 

An Enterprise License allows users to install PC*MILER on any combination of 
end-user PCs or workstations without license limitations.  It’s a cost-effective 
installation and licensing solution for larger companies with several users.  It does 
not require license activation but requires signing an enterprise license 
supplemental agreement directly with ALK. 

 
Additional Copy License 

Users can install PC*MILER locally onto additional PCs by purchasing additional 
copy licenses.  If you purchase 5-copy licenses, you can install PC*MILER 
locally onto five additional PCs or workstations.  If you’re installing onto a 
desktop PC and a laptop, two licenses are needed. 

 

2.3  Installation Types 

Non-Network (Local) Installations 

A non-network installation allows you to install PC*MILER to a PC or 
workstation locally, not to be shared with other computers. 

 
Network Installations 

A networked installation allows you to install PC*MILER on network file servers 
where each end-user can save their own option settings or can share option 
settings that are stored on the server. 

 
Citrix/Terminal Services Installations 

PC*MILER can be installed onto a Citrix Server or Terminal Services 
environment, if you have purchased a license to do so.  Each end-user must have a 
license to gain access to PC*MILER. 
 
Trial Installation 

A trial installation is a 15-day license to access PC*MILER’s features and data.  It 
includes an installation of PC*MILER that provides highway-level routing, 
mileage and mapping, with options for a trial installation of street-level routing, 
truck-specific toll costs, hazardous materials routing, and/or worldwide routing.  
 

2.4  Important Notes 

COM DLL’s on a 64-Bit Computer: If you install PC*MILER|Connect or 
PC*MILER|Mapping Version 28 on a 64-bit computer, you are given the option 
of using either the 32-bit versions or the 64-bit versions of the COM dll’s. To 
switch between the versions, you can run “Modify” in the setup to make the 
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decision again or run “UseCom32.bat” to switch to 32-bits or “UseCom64.bat” to 
switch to 64-bits. These .bat files are found in both your 
PCMILER28/Mapping/com and your PCMILER28/Connect/com folders. 
 
PC*MILER Interfaces:  For those who interface any PC*MILER component to 
a transportation management, logistics management or other third party software 
system, please contact the vendor directly to make sure that the interface to this 
new version of PC*MILER is updated and complete before you install. 
 
Access to Updates and Patches: Check the PC*MILER Updater frequently for 
posted updates and patches applicable to your license type and components.  In 
PC*MILER, go the Help tab > Check for Updates.  
 
Microsoft® Windows® 7 and 8 Users Only: Your license must be installed and 
activated using an Administrator Account.  Once installed, you do not have to 
Run as Administrator provided you install to the recommended default directory 
or to another directory that doesn’t require users to Run as Administrator. 
 

2.5  Installing PC*MILER  

  
2.5.1  Single User Local (Non-Network) Installation 

 
NOTE:  Have your Product Key Code on hand before beginning the installation 
process.  It will be emailed to you from alkservices@alk.com in an email titled 
“PC*MILER Software Order…” (Enterprise License customers excluded, see 
note in Step 5 below.)  You should see “Single” in this product key email. 
 
CONVERTING SAVED FILES:  To import saved custom settings and files 
from your previous version of PC*MILER, see section 2.8. 
   
NOTE for PC*MILER|Traffic Installation: If PC*MILER|Traffic was 
purchased, a separate email will be sent with a second Product Key Code and you 
will need to upgrade the PC*MILER license with this code at the end of the 
installation.  Instructions for installing RouteSync and/or PC*MILER|Traffic 
are included as options in the installation instructions below. 
 
NOTE:  For those installing to Windows 7 or 8, you must install as an 
Administrator.  You do not have to “Run as an Administrator” to use PC*MILER 
28, provided you install to the default directory or to another directory that does 
not require users to “Run as an Administrator”. 
 
NOTE:  If you have a Multi-User Product Key Code and need to perform a 
Single User install, you will need to contact PC*MILER Technical Support for 
assistance, as a new Product Key Code is needed.  If you cannot get in touch with 
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Technical Support at the time of installation, you can install a Single User License 
by typing “FREE” in the Product Key field.  After installing, please contact 
Technical Support to update your license status. 
 
UNINSTALLING an OLDER VERSION: If you need to uninstall a previous 
version of PC*MILER on the computer that you are now installing to, you must 
do it before installing PC*MILER 28.  If you do not need to uninstall, you can 
have both versions of the desktop program installed on the same system.  Please 
note that PC*MILER|Connect, PC*MILER|Mapping and PC*MILER| 
Spreadsheets will be updated to the new version. 
 
 
BEFORE INSTALLING, please double-check that the emailed Product Key 
Code(s) lists all purchased components.  For example, the code shown below 
unlocks the following components: PC*MILER|BatchPro, RouteSync, 
PC*MILER|Tolls, PC*MILER|Streets (U.S. and Canada) and Worldwide 
highway data. 
 

Order #: SO-000000001 
Product Order #: PC*MILER 28 
Date: 7/1/2014 10:33 AM 
Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2 
== PC*MILER 28 (Single) BatchPro, Canadian Streets, RouteSync, Tolls, US 

Streets, Worldwide Data V8 
 

To install your single-user version of PC*MILER 28, follow these steps: 
 

1. If you are downloading the installation, click the provided link in the email 
that was sent to you from ALK Technologies (mentioned above).   
 

If you are installing using a DVD, place the PC*MILER Install DVD in the 
DVD or CD/DVD drive and the installation will start automatically.  If it does 
not start automatically, click the Windows Start menu. Then, depending on 
your operating system, either 1) click Run…, then type “d:\setup.exe” and 
click OK (Windows XP – if the DVD drive is not the D drive, substitute the 
letter that designates the DVD drive); or 2) select Computer > [DVD drive 
letter] > setup.exe.  
  

2. The Installshield Wizard Welcome screen will open.  Click Next to review 
the End-User License Agreement.  NOTE:  Depending on the current status 
of your Windows operating system, some Windows updates may install 
automatically before the PC*MILER installation begins.  

3. In the next screen, review the license agreement then choose “I accept…”  If 
this option isn’t selected, the setup won’t continue.  After selecting it, click 
Next to continue. 
 

4. When prompted, enter a User Name and Company Name and click Next. 
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5. Enter the Product Key Code.*  This 25-character code will have been 
emailed from alkservices@alk.com in an email with the subject line 
“PC*MILER Software Order…”.  It can be copied from the email and pasted 
in.  If entering the code manually, dashes are not required – dashes, spaces, or 
no spaces are all acceptable.  Click Next when finished. 

* NOTE: As a convenience to Enterprise License customers, the Product Key Code is hard-
coded into the installation and is valid for each install under the contracted terms. 

 
6. In the next screen you will see a list of the Licensed Features that will be 

installed.  Check to make sure all the purchased features are in the list, then 
click Next to continue. 

 
7. Now you will see the Destination Location where all components will be 

installed.  To install to the default directory* (recommended), do not make 
any changes and click Next. 
 

* By default, PC*MILER 28 installs directly to C:\ALK Technologies\PCMILER28.   
 

To install to a location other than the default, click Browse to select a 
directory.  (Be sure to add “PCMILER28” to the end of the new path; for 
example, “C:\PCMILER\Version 28\PCMILER28”.  If you don’t, PC*MILER 
will install to the root of the specified directory.)  Click OK then Next to 
continue. 
 

8. In the next screen you will Start Copying Files.  To change any settings, 
select Back.  If you are satisfied with the settings, click Next to continue. 
 

If you have a previous version of PC*MILER|Connect or PC*MILER| 
Mapping installed, this alert will appear: “The install found a previous version 
of Connect (Mapping).  These files will be renamed with a .bak extension”.  If 
both products were previously installed, you will receive two alerts.  Click 
OK in the dialog box(es) to continue. 

9. Follow through with the rest of the installation.  This may take some time 
depending on the speed of the computer you are installing to.  Do not exit or 
reboot the computer during the installation.  If any error messages appear, 
please contact PC*MILER Technical Support.   

10. When the installation is complete, you will be prompted to view the 
ReadMe.txt and to activate your license.  If you need to use a Proxy Server 
to access the Internet, skip to section 2.5.2, Activation Using a Proxy Server.  
Otherwise, leave these boxes checked and click Finish to proceed to the 
automatic activation (Step 11 below).  When the ReadMe opens, review the 
information in it and then close the window. 

 
IMPORTANT NOTE:  ALK provides a 15-day temporary license prior to 
completing the activation process.  If you make a second attempt to install you 
will lose this license.  If you experience an activation error and need access to 
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PC*MILER before Technical Support is available, please do not attempt a 
second installation without assistance – you’ll be able to use PC*MILER for 
15 days without completing the activation. 
 

 
AUTOMATIC LICENSE ACTIVATION 

 
11. The PC*MILER Product Activation window should be open.  (If it is not 

open, select Start menu > Programs (or All Programs) > PCMILER 28 > 
License Status to open the License Tool window.)  
 

If you are an Enterprise License Customer: You can bypass the following 
license activation steps of the install because you are already activated and 
registered with ALK.  To continue, close the Product Activation window then 
proceed to Step 15 to open PC*MILER and start using the application. 
 

If you are not an Enterprise License Customer: If the computer you are 
installing to has an Internet connection and you have a valid email address, the 
license activation can be processed automatically.  Enter your Email Address 
then click Activate.  “Manual Activation” should be left unchecked. 
 

If RouteSync is one of the components you are installing, before clicking 
“Activate” you will also need to enter an alphanumeric or alphabet-only 
password of your choosing.  (Record this password and keep it handy, as you 
will be asked to enter it again when you use RouteSync for the first time in 
PC*MILER.)   

 

NOTE:  Internet license activation is available 24 hours a day.  If you don’t 
have an active Internet connection or email address, please contact 
PC*MILER Technical Support during business hours for assistance. 

 
12. When the activation process is complete, you will receive a message in the 

Product Activation window saying, “License Activation Complete!”.  Close 
the window to continue.  If the activation failed, skip to Step 16 below for 
manual activation.   
 

13. To verify that PC*MILER is now licensed, go to the Windows Start menu > 
Programs (or All Programs) > License Status.  In the PC*MILER License 
Tool window, verify that “Licensed” appears under Status.  PC*MILER is 
now activated.  If “Licensed” is NOT in the Status field, skip to Step 16 below 
for manual activation. 
 
If PC*MILER|Traffic was purchased, you can install it now or it can be 
installed at a later time.  See section 2.5.3 below for instructions on how to 
add the license to your base PC*MILER application. 
 

14. If the automatic activation was completed, close the License Tool window.  
An email titled “PC*MILER 28 Activation Code for Product XXXXX…” 
from alkservices@alk.com will be sent to the email you entered in Step 11.  
You only need to keep this email for your records.   
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15. To start PC*MILER once the installation is complete, click the PC*MILER 
icon on the desktop, or click the Windows Start menu > Programs (or All 
Programs) > PCMILER 28 > PCMILER 28. 

 
MANUAL ACTIVATION 

 
16. (You only need to follow these steps if the automatic license activation 

process failed.)  If the automatic activation (Steps 11-12 above) fails for any 
reason, try manually activating.  In the Product Activation window, enter your 
Email Address (and RouteSync password if applicable) then check “Manual 
Activation”.  

 
17. Next, click the provided URL for the ALK activation site. 
 
18. You will be taken to the ALK Technical Support “Activate Product” web 

page, and your PC*MILER product key will automatically populate the 
Product Key fields.  Click Next to continue. 

 
19. In the next screen, enter your Email address (and RouteSync password if 

applicable) and click Finish. 
 
20. An email titled “PC*MILER 28 Activation Code for Product XXXXX…” 

from alkservices@alk.com will immediately be sent to the email you entered. 
 
21. Copy the activation code directly from the Activation web page or from the 

email sent to you, and paste it into the Activation Code field in the Product 
Activation window. 

 
22. Click Activate in the Product Activation window to complete the activation. 
 
23. You will see the message “License Activation Complete!”.  Close the Product 

Activation window.  PC*MILER is now activated. 
 
24. Start PC*MILER once the installation is complete: click the PC*MILER icon 

on the desktop, or click the Windows Start menu > Programs (or All 
Programs) > PCMILER 28 > PCMILER 28. 

 
 

2.5.2  Activation Using a Proxy Server 
 

To activate PC*MILER using a Proxy Server, follow these steps: 
 
1. When the installation is complete (Steps 1-9 in section 2.5.1 above), uncheck 

the Activate check box and then click Finish. 
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2. Next, start PC*MILER:  either click the PC*MILER icon on the desktop, or 
click the Windows Start menu and then select Programs (or All Programs) 
> PCMILER 28 > PCMILER 28. 

 
3. Select the Help tab > Windows group > Proxy Setup. 
 
4. In the Proxy Setup dialog, check Use Proxy Server then enter a Host and Port. 
5. If needed, check Proxy Authentication then enter a Username and Password. 
 
6. Click OK to save your settings and close the dialog.  PC*MILER is now set up 

to use the indicated proxy server when connecting to the Internet. 
 
7. Close PC*MILER. 
 
8. In the Windows Start menu, select Programs (or All Programs) > PCMILER 

28 > License Status to open the PC*MILER License Tool window, then click 
Activate. 

 
9. Follow the steps in section 2.5.1 for automatic activation, beginning at Step 11. 
 
 

2.5.3  Adding PC*MILER|Traffic to the Installation  
 

If a PC*MILER|Traffic subscription was purchased, a separate upgrade product 
key was sent in an email along with the base PC*MILER product key. Follow the 
steps below to install the PC*MILER|Traffic upgrade after PC*MILER has been 
installed and activated.   
 
1.  If the PC*MILER License Tool window is not already open, click the 

Windows Start menu and select Programs > PCMILER 28 > License 
Status to open this window. 

2. Click Add License. 

3.  In the PC*MILER Product Activation window, enter the PC*MILER|Traffic 
Upgrade product key that was emailed to you and click Add License. 

4. When prompted, enter your Email Address then click Activate. 

5. When the activation process is complete, you will see the message “License 
Activated Successfully.”  The upgrade is now complete. 

6. You will immediately receive an email from ALK Technologies that contains 
the new activation code for this upgrade.  Keep this email for your records. 

7. To start PC*MILER, double-click the PC*MILER icon on the desktop, or 
click the Windows Start menu and then select Programs > PCMILER 28 > 
PCMILER 28. 
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2.5.4  Adding PC*MILER Worldwide, Energy or DTOD Data  
 

To install additional PC*MILER|Worldwide*, PC*MILER|Energy or DTOD 
Data to the base installation of PC*MILER, follow the steps below.  The steps 
assume that, after purchasing the data add-on(s), you either 1) received an email 
from ALK Technologies that provides one or more URL link(s) to the setup.exe 
required for the data install; or 2) received an installation DVD which includes the 
data you are adding (or two DVDs if you purchased Worldwide data). 
*  Including PC*MILER|Worldwide Streets data sets. 
 

IMPORTANT NOTE:  Please check that you have the latest updates before 
installing additional components. Open PC*MILER and select the Help tab > 
Check for Updates.   

 
1. If you are using a DVD, insert the DVD and skip to Step 7 below. 

If you are using the email sent to you by ALK, click the download link at the 
bottom of the email.  The email’s subject line will say “PC*MILER 28 Software 
Oder #...”.  You may see more than one link, depending on what was purchased 
– begin by clicking the topmost link.   

2. A web page will open and you will be prompted to open or save the PC*MILER 
zip file.  Click Save and select a folder where you want to save the zip file. 

3. The download will begin.  A very small progress bar in the upper right corner of 
the web page will track the progress of the download.  The progress bar will 
disappear when the download is finished. 

4. Navigate to the folder where you saved the zip file, and double-click the file to 
open it. 

5. Click Extract at the top of the window that opens to extract the contents of the 
zip file to a separate folder in the same location.  The progress of the extraction 
will be tracked at the bottom of the window. 

6. When the extraction is complete, open the extracted folder and run the setup.exe 
as follows:  For Windows 7 users, right click the setup.exe and select "Run as 
administrator".  For other operating systems, just double-click the setup.exe. 

7. The PC*MILER Data Installer – InstallShield Wizard will open.  Click Next to 
continue. 

NOTE: If an update to PC*MILER is available, you will be prompted to 
install it before continuing with the upgrade.  Click OK at the prompt. 
 

8. Select “I accept the terms of the license agreement” then click Next. 

9. A prompt will tell you to select “Add License” in the next screen – click OK. 
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10. After a few seconds the PC*MILER License Tool window will open – click 
Add License. 

11. In the PC*MILER Product Activation window, enter the Product Key for the 
purchased data add-on, then click Add License.  The product key can be 
copied and pasted from the email that was sent to you at the time of purchase. 

12. Enter your Email Address in the next screen, then click Activate. 

13. When the activation is finished you will see a “License Activation 
Complete!” message.  Close the Product Activation  and License Tool 
windows by clicking on the “X” in the upper right corner of each window. 

14. (AUP Customers Only)  At this point, you may see a prompt asking if you 
want to delete the data from the previous quarter.  Select Yes or No. 

15. Back in the InstallShield Wizard, you will see a list of all the PC*MILER 
Licensed Features that will now be installed.  Click Next. 

16. Now you will see the Destination Location where the new data will be 
installed.  To install to the default directory (recommended), do not make any 
changes and click Next; or click Change to change the destination folder.  
The default destination folder is C:\ALK Technologies\PCMILER28. 

17. In the next screen, click Next to Start Copying Files. 

18. At the end of the copying process, a prompt will appear that says “Setup will 
now create a backup copy of your user.cfg file…”.  Click OK. 

19. Click Finish in the next screen.  Your data add-on is now ready to use. 

The title bar of the PC*MILER application window will include the installed data 
add-ons, and you will see the new data set in the Map tab > Utilities group > 
Change Data Set menu.  All installed data sets are listed in this menu, and the 
data set you just installed will be activated by default.  See section 3.6.6 on 
changing the map data set. 
 
 

2.5.5  Multi-User Network Installation 
 

NOTE:  Have your Product Key Code on hand before beginning the installation 
process.  It will have been emailed from alkservices@alk.com in an email titled 
“PC*MILER Software Order…” (Enterprise License customers excluded)  You 
should see “X-User” in the Product Key email, indicating that you have purchased 
a multi-user license.  If not, please contact an Enterprise Solutions account 
executive to purchase the correct license. 
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UNINSTALLING AN OLDER VERSION: If you need to uninstall a previous 
version of PC*MILER on the computer that you are now installing to, you must 
do it before installing PC*MILER 28.  If you do not need to uninstall, you can 
have both versions of the desktop program installed on the same system.  Please 
note that PC*MILER|Connect, PC*MILER|Mapping and PC*MILER| 
Spreadsheets will be updated to the new version. 
 

 
CONVERTING SAVED FILES:  To import saved custom settings and files 
from your previous version of PC*MILER, see section 2.8. 
   
BEFORE INSTALLING, please double-check that the emailed Product Key Code(s) 
lists all purchased components.  For example, the code shown below unlocks the 
following components: PC*MILER|Connect, PC*MILER|Tolls, RouteSync, 
PC*MILER| Streets (U.S. and Canada) and Worldwide highway data. 
 
Order #: SO-000000001 
Product Order #: PC*MILER 28 
Date: 7/1/2014 10:33 AM 
Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2 
== PC*MILER 28 (XX-User), Canadian Streets, Connect, Tolls, 
RouteSync, US Streets, Worldwide Data V8 
 
To install PC*MILER 28 on a network, follow these steps: 

1. Begin by installing PC*MILER to the server: follow steps 1-9 for a Single 
User Local Installation (section 2.5.1 above). 

 
2. When the installation is done, you will see the screen shown below.  Click OK. 

 
 

3. You will be prompted to view the ReadMe.txt and to activate your license.  
If you need to use a Proxy Server to access the Internet, skip to section 2.5.2, 
Activation Using a Proxy Server.  Otherwise, leave these boxes checked and 
click Finish to continue.  Review the ReadMe and then close the window. 

 
IMPORTANT NOTE:  ALK provides a 15-day temporary license prior to 
completing the activation process.  If you make a second attempt to install you 
will lose this license.  If you experience an activation error and need access to 
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PC*MILER before Technical Support is available, please do not attempt a 
second installation without assistance – you’ll be able to use PC*MILER for 
15 days without completing the activation. 

 
4. After you click Finish, the PC*MILER Product Activation window will open.     

 

If you are an Enterprise License Customer: You can bypass the following 
license activation steps of the install because you are already activated and 
registered with ALK.  To continue, close the Product Activation window. 
PC*MILER is installed on the server and can be opened by double-clicking 
the PC*MILER icon on the desktop, or clicking the Windows Start menu and 
selecting Programs > PCMILER 28 > PCMILER 28. 
 

If you are not an Enterprise License Customer: If the computer you are 
installing to has an Internet connection and you have a valid email address, the 
license activation can be processed automatically.  Enter your Email Address 
then click Activate.  “Manual Activation” should be left unchecked. 
 

If RouteSync is one of the components you are installing, before clicking 
“Activate” you will also need to enter an alphanumeric or alphabet-only 
password of your choosing and then enter it again to confirm.  (Record this 
password and keep it handy, as you will be asked to enter it again when you 
use RouteSync for the first time in PC*MILER.)   

 
NOTE:  Internet license activation is available 24 hours a day.  If you don’t 
have an active Internet connection or email address, please contact Technical 
Support during business hours for assistance – see section 15.1. 

5. If the activation is successful, you will see a “License Activation Complete” 
message that directs you to open an email from ALK Technologies for further 
instructions.  If the activation was NOT successful, try activating manually 
(Steps 16-23 in section 2.5.1) before calling Technical Support.  To contact 
Technical Support, see section 15.1 in this User’s Guide. 

6. After activation, open the email you received, then follow the instructions for 
copying the “net.lic” file included with the email to the “App” folder in your 
PC*MILER installation.  Net.lic holds the license or user count for your 
installation.  Until you save this file to the designated folder, you will only 
have a single-user installation.  The PC*MILER application is now accessible 
on the server (see Step 2 below for access options). 

INSTALLING ON A WORKSTATION 

To install PC*MILER on each workstation, follow these steps: 

1. Click the Windows Start menu and enter the network path, then press Enter 
on the keyboard.  To find this path, navigate to the server’s “PCMILER28” 
folder, right-click the folder, and go to Properties > Sharing.  The network 
path can be copied and pasted from there. 
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2. Next, you will be asked to choose your workstation setup options.  Two 
screens will prompt you to select the type of settings you would like to use.   

The setup options in the first screen (Settings Location) are: 

 Use local setting – Allows the user at each workstation to customize 
default options and manage settings, including custom roads and places. 

 Share network settings – Provides each workstation the same default 
options and settings within the application. 

 
The setup options in the second screen (Settings Data) are: 

 Use local data – Installs data to the local workstation.  This option can 
decrease the time it takes PC*MILER to open and begin processing, and 
reduces network traffic.  In general, the performance is better.  However, 
there must be enough hard disk space to accommodate the data.  

 Share data on your network, default – This is the default choice.  
PC*MILER uses the shared data that was installed on the server.  

  
NOTE for RouteSync Users:  Currently only one RouteSync account is 
allowed per installation.  To access RouteSync functionality from multiple 
workstations, one master RouteSync account must be shared. 

3.  To start PC*MILER on a workstation once the installation is complete, 
double-click the PC*MILER icon on the desktop, or click the Windows Start 
menu and select Programs (or All Programs) > PCMILER 28 > PCMILER 
28. 

 
 

 2.5.6  Citrix and Terminal Services Installations 
 

NOTE: Have your Product Key Code(s) on hand before beginning the 
installation process.  They will be emailed to you from alkservices@alk.com in an 
email with the subject line “PC*MILER Software Order…” (Enterprise License 
customers excluded).  “(Citrix/Terminal Services)” will be included in the Product 
Key email signifying that you have purchased a Citrix or Terminal Services 
license.  If this is not listed, please contact an Enterprise Solutions account 
executive to purchase the correct license and request one Product Key Code for 
each individual server you are installing to.  
UNINSTALLING AN OLDER VERSION: If you need to uninstall a previous 
version of PC*MILER on the computer that you are now installing to, you must 
do it before installing PC*MILER 28.  If you do not need to uninstall, you can 
have both versions of the desktop program installed on the same system.  Please 
note that PC*MILER|Connect, PC*MILER|Mapping and PC*MILER| 
Spreadsheets will be updated to the new version. 
 

Custom places, custom road preferences, and geofence files that were saved in an 
older version of PC*MILER can be transferred and converted to Version 28.  For 
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custom place conversion, see section 3.13.5.  For custom road conversion, see 
section 11.1.7.  For geofence conversion, see section 11.6.7. 

 
BEFORE USING PC*MILER:  Citrix supports 16 bit and 24 bit color, while 
PC*MILER supports 16 bit and 32 bit color.  A Citrix end user must set the color 
resolution on their workstation to 16 bit before they log into a Citrix server to run 
PC*MILER.  If an end user has their color resolution set to 32 bit and logs in to 
Citrix, the Citrix software will adjust it downward to 24 bit prior to loading 
PC*MILER, and PC*MILER will fail to load. 

 
BEFORE INSTALLING, please double-check that the emailed Product Key Code 
lists all purchased components.  For example, the code shown below unlocks 
the following components: PC*MILER|BatchPro, PC*MILER|Tolls, 
RouteSync,  PC*MILER|Streets (U.S. and Canada), and Worldwide highway 
data. 
   

Order #: SO-000000001 
Product Order #: PC*MILER 28 
Date: 7/1/2014 10:33 AM 
Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2 
== PC*MILER 28 (Citrix/Term Serv), BatchPro, Canadian Streets, Tolls, 
RouteSync, US Streets, Worldwide Data V8 

 
If you were using an existing version of PC*MILER with PC*MILER|Connect 
and/or PC*MILER|Mapping in your Citrix environment, there may be existing 
files that require deletion.  Citrix and Terminal Servers can have multiple copies 
underneath C:\Users\<username>\Windows,  C:\Documents and Settings\ 
<username>\Windows or in %homedir%\windows like H:\Windows.  Copies of 
the following files should be deleted from any location outside of C:\WINDOWS: 

 Pcmserve.ini 
 Pcmserve.ctx 
 Pmwssrv.ini 
 Pmwssrv.ctx 

 
Only a qualified Citrix administrator should be installing PC*MILER on a 
Citrix system.  With Citrix in Install Mode, follow the steps in section 2.5.1, 
Single User Local (Non-Network) Installation. 
 

 
2.5.7  AS/400 and CICS Installations 

 
Installation instructions can be downloaded from ALK’s website Support Center 
at:  http://www.alk.com/support. 
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2.6  Starting and Closing PC*MILER 

To start the PC*MILER application, double-click the PC*MILER icon on the 
desktop, or click the Windows Start menu > Programs (or the equivalent on your 
computer) > PCMILER 28 > PCMILER 28. 
 
To close PC*MILER, choose Exit from the red File application menu, press 
Alt+F4, or simply close the application window.  
 

2.7  Proxy Setup For Internet Access 

The following PC*MILER features require a connection to the Internet: 
 

 License activation 
 Software update and patch downloads via the Updater tool 
 Real-time traffic data 
 Satellite imagery on the RouteMap 
 RouteSync 

 
For those who need to bypass current security settings to access the Internet while 
using PC*MILER, the steps to complete the proxy setup are below.  The setup 
can be implemented after PC*MILER has been activated or before activation 
during the temporary grace period after installation. 
 

1. Open PC*MILER and select the Help tab > Windows group > Proxy Setup. 

2. In the Proxy Setup dialog, check Use Proxy Server then enter a Host and Port. 

3. If needed, check Proxy Authentication then enter a Username and Password. 

4. Click OK to save your settings and close the dialog.  PC*MILER is now set up 
to use the indicated proxy server when connecting to the Internet. 

 

2.8  Importing Saved Files and Settings From a Previous Version 

Saved route files, custom road preferences, custom places, and geofence files can 
all be transferred from an older version of PC*MILER (Version 27 or 27.1) to the 
newly-installed version.  Saved route files will be automatically updated when 
they are opened in PC*MILER 28.  For custom place conversion, see section 
3.13.5.  For custom road conversion, see section 11.1.7.  For geofence conversion, 
see section 11.6.7. 
 
Additionally, a Settings Importer utility is provided that lets you import 
customized route options, custom road speeds, map feature settings, custom 
vehicle profiles, custom routing profiles, and general application settings from the 
previous version.   
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PC*MILER Settings Importer 

 
 
Here are a few things to note about this utility: 
 

 It will only import from the previous year’s release – i.e. from Version 27 
or 27.1 to Version 28. 

 Settings that change annually, such as currency conversion rate and fuel 
cost, are not imported. 

 The current default values in PC*MILER will be overwritten.  For trip 
options and road speeds, only those values that have been customized in 
the previous version will be imported. 

 The import utility includes a license check and won’t run on workstations 
using shared data.  An error message will appear if an import request 
cannot be processed. 

 
 
To use the Settings Importer, follow these steps: 
 

1. Select the Windows Start menu > All Programs (or the equivalent for 
your operating system) > PCMILER 28 > Settings Importer. 

2. In this dialog, uncheck any settings you do NOT want to import. 

3. Choose a version from the Import Settings from Version pick list. 

4. Click Import to proceed with the import (click Close if you decide not to 
proceed).  Close the Settings Importer window when the process is 
complete.  
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2.9  Adding New PC*MILER Products 

NOTE:  A multi-user license cannot be changed to a single-user installation of 
PC*MILER by simply adding the license – you must fully uninstall, deactivate 
your multi-user license, then reinstall using the new Product Key Code.   
 
NOTE:  To install a PC*MILER|Traffic subscription, see section 2.5.3.  To 
install PC*MILER|Worldwide, PC*MILER|Energy or DTOD data, see section 
2.5.4.   
 
You may find that you want to purchase an additional PC*MILER component 
sometime after the initial installation of PC*MILER.   

 
First, call PC*MILER SALES at 1-800-377-6453 ext. 1 (or 1.609.683.0220 ext. 
1 outside of the U.S.) 9:00am-5:00pm EST, Monday-Friday to purchase the 
product(s) and obtain a new Product Key Code to license and install the new 
product(s).  Once you receive the new product key code, follow the instructions 
below for a single user or multi-user workstation. 

 
SINGLE USER AND MULTI-USER SERVER INSTALLATION 

1. Go to the Windows Start menu > Programs (or All Programs) > 
PCMILER 28 > License Status. 

2. In the PC*MILER License Tool window, click Add License. 

3. In the PC*MILER Product Activation window, enter the product key for the 
purchased component(s) and click Add License. 

4. When prompted, enter your Email Address.  If you are installing RouteSync, 
you will also need to enter a Password and confirm it. 

5. Click Activate.  

6. When the activation process is complete, you will see the message “License 
Activation Complete!”.  Close the Product Activation window. 

7. Back in the License Tool window, make sure all new and existing PC*MILER 
components are listed under Licensed Components.  

8. Some components include data that needs to be installed after the license has 
been activated.  These components will appear on the Licensed Components 
list with an asterisk (for example, “Canadian Postal Codes*”).  In this case, 
follow Steps 9-14 below.   

If there are no components that need to be installed, you can close the License 
Tool window and begin using the newly-added PC*MILER products. 
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Components that do NOT have additional data that needs to be installed 
include: PC*MILER|Traffic, PC*MILER|HazMat, PC*MILER|RouteMatrix, 
and RouteSync.   

9. To install newly added components, go to the Windows Start menu > 
Control Panel > Programs and Features (or the equivalent on your system, 
for Windows XP this is Settings > Control Panel > Add/Remove Programs). 

10. In the list of installed programs, right click PC*MILER 28 and choose 
Change. 

11. In the InstallShield Wizard, choose Modify and click Next. 

12. In the next screen, you will see the list of Licensed Features (all activated 
features will be listed – check that the component you are installing is 
included in the list). Click Next to continue. 

13. In the next screen you’ll see the Destination Folder for the installation.  Click 
Next to start copying files. 

14. When the installation is complete, click Finish. 
  

MULTI-USER INSTALLATION, FROM A WORKSTATION 

1. Go to the workstation. 

2. Browse to the shared …\PCMILER28\network folder on the server. 

3. Run the setup.exe and choose “Modify”. 

4. Follow through with the rest of the installation. 
 

2.10  Deactivating and Uninstalling a License 

You must fully deactivate the product’s license and uninstall all PC*MILER 
components, including local, network, enterprise, or server installations if you are: 

 

 Moving any PC*MILER installation to a new computer. 

 Reformatting a computer that PC*MILER is currently installed to. 

 Returning the product. 

 Reinstalling on the same PC. 
 

Here are the steps for deactivating and uninstalling: 
 

1. Go to Start > Programs (or All Programs) > PCMILER 28 > License 
Status and in the PC*MILER License Tool window click Deactivate. 

2. In the PC*MILER Product Deactivation window, click Deactivate. 
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3. When the deactivation is complete, you will see a “Deactivation Complete” 
message, with the deactivated product keys listed below.   

4. Close the Product Deactivation and License Tool windows. 

5. To uninstall after deactivating, go to the Start menu > Settings > Control 
Panel > Programs and Features (in Windows XP, this is Add/Remove 
Programs). 

6. In the Programs and Features (or Add/Remove Programs) window, 
highlight PC*MILER 28.  Right-mouse click and select Uninstall (Windows 
7), or click the Remove button on the right in the highlighted text (Windows 
XP). 

7. Click Yes at the prompt to completely remove the application. 

8. Click Finish when the installation process is complete. 

NOTE:  If any messages appear during the uninstall process that say that a 
certain file cannot be removed, click OK to continue.   

 
9. !! IMPORTANT STEP !!  Once the uninstall process is finished, you will 

need to delete the …ALK Technologies\PCMILER28 folder manually to 
completely remove the PC*MILER application from your system.  The 
default location for this folder is C:\ALK Technologies\PCMILER28. 

 
NOTE:  If you deactivated/uninstalled an installation that included PC*MILER 
components that were licensed and added after the initial installation, you will 
need to add those components separately again when you reinstall. 
 

2.11  Installation: Frequently Asked Questions 

For FAQs related to problems you may have with the installation of your 
PC*MILER products, please go to www.alk.com/support.   
 

2.12  Help Files, Technical Support and ReadMe 

HELP FILES 
 

PC*MILER includes a complete system of Help files that are easy to use.  There 
are three ways to open the Help window: 
 
1.  Click a help button in any dialog box that has one.   

2.  Press F1 on your keyboard. 

3.  Select the Help tab > Help group > Help Index. 
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In the left pane of the Help window, use the Contents, Index, or word Search tab 
to navigate to the topic you need.   
 
The Contents tab lists all available topics.  Click any plus sign next to a main 
topic to see the related topics underneath.  Click on any topic in the Contents tab 
to open it in the right pane.  Scroll the topic in the right pane if necessary to read 
all of it.  Many topics include links to additional related topics. 
 
In the Index tab, click on any index entry to see the related topics and double-
click on a related topic to open it.   
 
In the Search tab, type a word or phrase then click List Topics to find topics that 
contain that word or phrase.  In the list of topics that displays, double-click a topic 
to navigate to it.  
 

TECHNICAL SUPPORT 
 

See Chapter 14, Technical Support and Contact Options. 
 

README FILE 
 

Consult the ReadMe file for last-minute product information, updates to the 
PC*MILER documentation, and additional feature information.  To see this file 
after PC*MILER has been installed, click the Windows® Start menu > All 
Programs (or the equivalent option) > PCMILER 28 > ReadMe. 
 

2.13  PC*MILER Feature Reference Guide 

Beginning with Version 27, the PC*MILER user interface was updated with a 
new look and feel while retaining the same functionality as in previous versions.  
The new interface features a ribbon style design, a more organized layout for 
smoother navigation, and windows that can be floated outside the PC*MILER 
application to better accommodate your workspace needs.  Users of recent 
versions of  Microsoft® Office 2007 and higher will already be familiar with the 
Ribbon format.  
   
For users of Version 26 and previous versions of PC*MILER who are updating, a 
reference table in PDF format is provided so you can quickly look up the new 
way to access features and options that are already familiar to you.  
  
To access the reference table, click the Windows® Start menu and select All 
Programs (or the equivalent option for your version of Windows) > PCMILER 28 
> User Guides > Feature Reference Guide.  
 
PDF documents can be searched for a key word – type the word into the Find box 
on the toolbar.  If this box is not visible, select the View menu > Toolbars > Find.  
The drop-down menu off the Find box can be used to refine your search. 
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          Basic Routing 
 
 

3.1  The PC*MILER Application Window 

When you first open PC*MILER, you’ll see an active route window on the left, 
the RouteMap window on the right, and a Ribbon toolbar at the top.  The Ribbon 
contains layered toolbars organized in tabs like a set of file folders. When you 
click a tab, the attached toolbar becomes visible.  Users of recent versions of 
Microsoft® Office® and Windows® will already be familiar with the Ribbon 
format.  
 
The options in each toolbar on the Ribbon pertain to tasks that are related to each 
other.  For example, all tools in the Map tab perform tasks related to the 
RouteMap window.  In the screenshot below that shows your initial view of 
PC*MILER, the Routes toolbar is visible.  

 
 

 

PC*MILER Application Window – Initial View 
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1 - The File Application Menu.  Click the red File drop-down to open the 
PC*MILER application menu.  This menu can be used to print and save 
maps and reports, change application settings, close all open routes or 
reports, and to exit PC*MILER. 

 

2 - The Ribbon, with the Routes tab selected.  As mentioned above, the 
Ribbon at the top of the application window contains layered toolbars 
organized in tabs like a set of file folders.  The Routes toolbar provides tools 
for entering and editing stops on a route, setting route options, and 
generating routes and reports.  

 
There are six tabs on the PC*MILER Ribbon: Routes, Map, Tools, 
Window, RouteSync, and Help.  The Ribbon can be minimized if needed: 
right-click on it and select Minimize the Ribbon. 
 

 
 

3 - The Routes Window.  This is a floatable pane that houses all the individual 
route windows that are created.  Up to eight routes can be open 
simultaneously inside the Routes window.  Click New Route in the Routes 
tab > General group to open a new route window in which you can enter 
stops and then generate costs, miles and time estimates.  When there’s not 
enough room to display all open routes, a scroll bar appears on the right 
edge of the Routes window that allows access to the hidden routes.    

 

4 - The RouteMap™ Window.   The PC*MILER RouteMap window is now 
floatable.  The RouteMap provides a graphical representation of ALK’s 
proprietary highway and local street* network.  Each route you run is 
automatically drawn on the map in the indicated color. This color is shown 
on the left edge of each route window, in the Route legend on the map, and 
on the Ribbon.  Use this window to compare routes, zoom into stops and 
specific locations, pick stops directly from the map, drag a generated route 
onto new roads, create avoid/favor preferences, and more. 
* Local streets are only available if PC*MILER|Streets is installed.   

 
 

3.2  Using the Quick Access Toolbar 
 
A Quick Access Toolbar is available in the PC*MILER application window.  This 
is a customizable toolbar that allows you to quickly access some of the features on 
the Ribbon that you use frequently, without clicking a tab first.  The toolbar is 
only displayed when at least one button has been added to it. 
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Not all buttons can be placed on the Quick Access Toolbar, only buttons that 
perform an action (e.g. New Route or Options).  Drop-downs (e.g. Save) and 
toggle buttons (e.g. Avoid Roads) can’t be added, but items in a drop-down that 
have an icon can be.  See NOTE below. 
 
To place a button on the toolbar, right-click the button and select Add to Quick 
Access Toolbar.  The toolbar will appear in its default location below the Ribbon.   
 

 
 
To remove a button, right-click it on the Quick Access Toolbar and select Remove 
from Quick Access Toolbar. 
 

 
 
To put the toolbar above the Ribbon, right-click it and select Show Quick Access 
Toolbar above the Ribbon.  The Quick Access menu also gives you the option to 
minimize the Ribbon to increase the workspace in the application window. 
 

NOTE:  Features on the Ribbon that cannot be added to the Quick Access Toolbar 
are listed below. 
 

Routes Tab: Save, Optimize, Reports (but all menu items can be added) 

Map Tab: Map Style, Legends, Stop Labels, Tooltips, Drag Map, Box 
Zoom, Frame, Change Data Set 

Tools Tab: Create Geofence, Geofence Options (menu items can be 
added), Avoid Roads, Favor Roads, Toggle Overrides,  
Adjust for Permits, Pick Places on Map 

Window Tab: Routes Window, Report Location, Map Window, Layouts 
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3.3  Window and Layout Options 

The three panes in the PC*MILER application window – Routes, RouteMap and 
Reports – can be arranged in several different layouts.  Select the Window tab > 
Windows group > Layouts and choose your preferred layout from the options in 
the drop-down menu.  
  
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Default Layout 

Routes on the Left, Floating Reports Routes on the Right, Bottom Reports 

Routes and Reports, Hidden Map 
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Additionally, these panes can each be manually resized, floated as a separate 
window, or hidden.  Click the down arrow in the window controls and select an 
option.   
 
 

Float Detaches the pane from the main PC*MILER application 
window, so that it can be moved around your screen and 
placed in a convenient position. 

Dock Reverses the “Float” command – the pane will return to its 
previous position inside the PC*MILER application 
window. 

Hide Hides the pane.  Another way to do this is to simply click 
the “X” next to the drop-down arrow.  To reopen, use the 
Window tab > Windows group options. 

 
 

3.4  PC*MILER Shortcut Keys 
 
For those who prefer using a keystroke rather than making a selection with the 
mouse, PC*MILER provides shortcut keys for commonly-used options.  These 
alternate keystrokes are listed below. 
 

KEY(S) FUNCTION  

F1 Invoke Topic Look Up in Help. 

F2 Invoke the Custom Place Manager. 

Alt+F2 Invoke the Avoid/Favor Manager. 

F3 Open a scrollable list of state abbreviations. 

Alt+F3 Invoke the Route Options dialog box for the active route. 

F4 Generate a Comparison Report. 

Alt+F4 Exit PC*MILER. 

F5 Display the Detailed Route Report for the active window. 

F6 Display the State/Country Report. 

F7 Insert a stop above the one highlighted on the stop list. 

F8 Delete the stop that is highlighted on the stop list. 

Alt+F8 Delete all stops in the route window. 

F10 Generate routes and distances (“Run” in the route window). 

Alt+F10 Optimize the stop order for an optimal route. 

Alt+Bkspace Undo typing in any entry field. 

Ctrl+S Save the active route with the existing filename. 
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Ctrl+Shift+S Save the active route with a new filename. 

Ctrl+C Copy the open report to the clipboard for use with another 
 program. 

Ctrl+N Open a new route. 

Shift+ Move the highlighted stop up one line on the stop list. 

Shift+ Move the highlighted stop down one line on the stop list. 

  
 

3.5  Application Settings    
 
There are several application settings that affect the way PC*MILER calculates 
routes and displays information.  To open the Application Settings dialog box, 
click the red File menu > Application Settings. 
 
 

 

Application Settings Dialog 

 
 
Options in the Application Settings dialog are: 
 
Precision:  Choose how precise mileage reporting will be.  This option affects all 
reports that include mileage as well as the calculations in route windows. 

Time Format:  Choose whether times of day should be displayed in AM/PM or 
24-hour (“military”) format; e.g. 3:20 PM or 15:20. 
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Time Zone:  Use the pick list to select how times/dates are reported (local, 
system, or a specific time zone).  This option affects how dates/times are reported 
but not how they are calculated.  See section 5.1, Route Generation With 
ETA/ETD. 

Postal Code Preference:  Use the pick list to select how PC*MILER handles 
Mexican and U.S. locations that have the same postal code.  Possible options are 
described below, but note that if Provide Pick List is checked below the drop-
down, a pick list of Mexican and U.S. locations will always open if both are in the 
database for the location that was entered.   

 Use Default US Zip Codes:  The default U.S. ZIP code will be returned. 
Mexican codes cannot be entered. 

 Use Default Mexican Zip Codes:  The default Mexican postal code will be 
returned.  U.S. codes cannot be entered. 

 Use Default US and Mexican Zip Codes:  The default U.S. ZIP code will be 
returned.  However, Mexican codes can be entered with “EM” as the state 
abbreviation; for example, “50510, EM”. 

 
Provide Pick List:  This option is checked by default.  It provides a pick list of 
postal codes when there is more than one listing in the database for a location 
entered as a stop.  The order in which locations are listed in the pick list is based 
on such factors as population and geographic centrality, putting the most densely 
populated cities at the top. When this option is not checked, PC*MILER will 
select the first match that is found in the database.   

Country Abbreviation Format:  (With PC*MILER|Worldwide or DTOD only) 
Select a country code format to use when entering stops in regions outside North 
America. 

Show Toll Discount Info:  (PC*MILER|Tolls must be installed to generate toll 
costs)  Check to have a breakdown of toll discount programs shown in the 
state/country summary section of the State/Country report.  See section 7.5, Toll 
Information in the State/Country Report. 

Show Custom Road Comment Box:  When this option is checked, the Comment 
dialog opens each time an avoid/favor road preference is created.  The dialog 
prompts the user to enter an optional comment.  Uncheck this option to disable it   
(comments can still be entered in the Avoid/Favor Manager). 

NL Abbreviation:  Choose whether to use the state/province abbreviation “NL” 
for Nuevo Leon in Mexico or Newfoundland and Labrador in Canada. 
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3.6  Building a Route    
 
To create a new route, you should be in the Routes tab of the Ribbon.  If a blank 
route window is not visible, open a new route window by selecting the Routes tab 
> General group > New Route or Ctrl+N on your keyboard. The elements in a 
new route window are shown below. 
 
 

 

New Route Window 
 
 

1 - Route Name.  By default, each new route is named “Route 1”, “Route 2”, 
etc.  A custom route name can be assigned in the Route Options dialog box 
(see section 9.1).  The route name appears in all reports and in the Route 
legend on the RouteMap. 

 

2 - Current Route Options.  Current route options are displayed here, under the 
route name. The drop-downs below can be used to change the route type, set 
an arrival or departure time, and enable/disable traffic features.  Additional 
general route options – including the region for PC*MILER|Worldwide or 
DTOD users – can be changed using the Route Options dialog box (see 
section 9.3). 

 

3 - Color Bar.  Each route displays in a different color on the RouteMap.  A 
route’s color is shown in this color bar, on the Ribbon, and in the Route 
legend on the map.   

 

4 - Route Options Button.  Click the gear button to generate reports, access the 
Route Options dialog box (see Chapter 9), access RouteSync (see Chapter 
13), and to float, dock or close the route window.     

 

5 - More/Less Button.  Use this button to toggle between a fully expanded and 
a minimal view of the route window. 

 

1 

2 

4 5

6

7 

3 

8 
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6 -  “Run” Button.  When at least two valid stops are entered for a route, this 
button turns green.  Click it to generate distances, costs, and time estimates. 

 

7 - Stop Entry.  Stops are entered here in the City field.  If PC*MILER|Streets 
is installed, an address can also be entered in the Address field.  Click Add 
Stop or press Enter on your keyboard to validate the stop and add it to the 
stop list for this route. 

 

8 - Postal Code/SPLC Drop-down.  To enter a SPLC, you must choose SPLC 
from this drop-down menu.  City names and postal codes won’t be accepted 
when SPLC is selected.  (A SPLC add-on license is required to enter SPLCs.) 

   
 

3.6.1  Stop Entry 
 

VERY IMPORTANT For PC*MILER|Worldwide and DTOD Users:  You 
must have the proper region selected in the Route Options dialog box when you 
enter stops on a route. See section 3.6.4 on region selection.  Also see section 
3.6.6 on changing the data set if you are entering local street addresses, and 
section 10.2 to frame the correct region on the map. 
 
To generate distances and driving instructions for a route, you need to specify at 
least two stops – an origin and destination.  An unlimited number of stops may be 
entered.  PC*MILER will always treat the stop at the top of the stop list as the 
origin of the route and the last stop on the list as the destination, unless you are 
generating hub distances (see section 9.3.3).  As you add stops, each one will be 
placed below the previous stop on the list, creating the stop order from origin to 
destination. 
 
To enter a stop, follow these steps: 
 
1. Select the Routes tab > General group > New Route or the Ctrl+N keys. 
 
2. In the City field of the new route window, type a location using any valid 

format (see the list of formats below); a street address can be included in the 
Address field if PC*MILER|Streets is installed. 

 
3. Click Add Stop or press the Enter key on your keyboard.   
 
4. If the location you entered is valid, the stop will appear above the City field in 

a stop list.  For a stop to be valid, there must be a match in the PC*MILER 
database.  If an error is returned, see section 3.6.22.  To enter an arrival or 
departure time, see Chapter 5.  To set options for a route, see Chapter 9.   

 
You can input a city, town or location in any of the formats that are listed below 
and described on the following pages: 
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 Type a city name, followed by a comma or space and the state abbreviation  
(see section 3.6.2 below); a street address may be included if PC*MILER|Streets 
data is installed (see section 3.6.3) 

 Get spelling help using a pick list of matches (section 3.6.8) 

 Enter a 5-digit ZIP or postal code (section 3.6.9) 

 Enter a 6-digit Canadian Postal Code (if the separate add-on data module is 
installed – see section 3.6.10) 

 Enter a SPLC (if the separate add-on data module is installed – see section 
3.6.11) 

 Point and click with the mouse on a location in the map window  
(section 3.6.21) 

 Type in or point-and-click on a latitude/longitude point (sections 3.6.14 and 
3.6.21) 

 Locations may also be entered as custom places, and for U.S./North American 
locations, as border crossings, highway junctions, highway exits, truck stops, 
CAT scale or state weigh stations.  See sections 3.6.12-3.6.19 and 3.13. 

 
TIP on DATA MATCHING:  To confirm that your location data matches the 
PC*MILER database, please see section 3.13.4, Importing Custom Places. 
 
 

3.6.2  City Name and State/Country Abbreviation 
 

To enter a city or town using the city/state format, first type the city name and 
two-letter state/province/country abbreviation in the City field, then click Add 
Stop or press the Enter key on your keyboard.  The city name can be any length.  
The city and state/country do not need to be capitalized, but do need to be 
separated by either a comma or a space.   
 
Examples:   chicago, il     chicago il     paris,fr (PC*MILER|Worldwide or DTOD users only) 
 
 

 

Entering Trenton, NJ as a Stop  
 
 

If the city name contains two or three words, each portion of the city name must 
be separated by spaces. For example: 

 



 
  

 

 PC*MILER User’s Guide 48 

los angeles, ca 
salt lake city ut 
belle croix,fr (PC*MILER|Worldwide or DTOD users only) 

 
After you click Add Stop, PC*MILER will search through the database for a 
location that matches the city name you entered.  If multiple listings are found in 
the database for the same location, a scrollable pick list will open.  Highlight your 
choice and click OK. 
 
If your entry was valid, a stop list will open above the City field and the stop you 
entered will be displayed along with a time zone:  
 
 

 

Stop List Populated With a Stop  
 
 
If you want to have PC*MILER pick a default match rather than open a pick list 
of multiple postal codes, select the File application menu > Application Settings,  
then uncheck Provide Pick List and click Save.  By default “Provide Pick List” 
is checked and if there is more than one location for a city name, the most densely 
populated city will appear at the top of the pick list, with an alphabetical listing of 
other cities below.  See section 3.6.7 for a description of the default city/postal 
code selection process when this option is turned off. 
 
If you are unsure of the correct spelling for a city name, spelling help is available 
– see section 3.6.8.  To look up state/province/country abbreviations, press the F3 
key to bring up a scrollable reference list.  
 
If PC*MILER|Worldwide or DTOD data is installed, country abbreviations 
outside North America may be entered using FIPS 2-character, ISO 2-character, 
ISO 3-character, GENC 2-character or GENC 3-character codes.  FIPS codes are 
accepted by default.  To use another format for stop entry, select the File 
application menu > Application Settings.  Choose an option from the Country 
Abbreviation Format drop-down list.  
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3.6.2.1  Entering Mexican and Canadian Locations 
 

Mexican place names can be entered using a postal code, or a city name plus a 
two-letter ISO abbreviation.  (Press F3 or see Appendix C in this Guide for a 
complete list of Mexican estado abbreviations.)  Examples of Mexican locations: 

 

puerto vallarta, ja 
99250 

 
Some Mexican and U.S. locations have the same postal code assigned to them.  
The way PC*MILER handles Mexican versus U.S. postal codes in these cases is 
determined by the setting in the Applications dialog box.  (Select the File 
application menu > Application Settings, and use the Postal Code Preference 
drop-down.)  Possible options are described below, but note that if Provide Pick 
List is checked below the drop-down, a pick list of Mexican and U.S. locations 
will always open if both are in the database.   
 

 Use Default US Zip Codes:  The default U.S. ZIP code will be returned. 
Mexican codes cannot be entered. 

 Use Default Mexican Zip Codes:  The default Mexican postal code will be 
returned.  U.S. codes cannot be entered. 

 Use Default US and Mexican Zip Codes:  The default U.S. ZIP code will be 
returned.  However, Mexican codes can be entered with “EM” as the state 
abbreviation; for example, “50510, EM”. 

 
Canadian postal codes can be entered only if the separate PC*MILER Canadian 
Postal Codes add-on data module is installed.  With this module installed, a pick 
list of Canadian postal codes will be invoked when a Canadian place name is 
entered that has multiple postal codes assigned to it – provided that Provide Pick 
List is checked in the Application Settings dialog (File application menu > 
Application Settings…).  See section 3.6.10 on entering Canadian postal codes.  
 
If the postal code data module is not installed, Canadian place names can only be 
entered using the city name and province abbreviation, for example: 
 

montreal, qc   
 
Press F3 or see Appendix C in this Guide for a complete list of Canadian province 
abbreviations.   
 
NOTE:  “NL” is recognized as Newfoundland and Labrador unless this setting 
has been changed to mean Nuevo Leon using the Application Settings dialog (File 
application menu > Application Settings). 
 
NOTE Also:  To enter a location name that includes one or more accented letters 
(for example, Felipe Ángeles, CI), you can either 1) use the postal code, or 2) use 
the Insert > Symbol option in Microsoft® Word or Excel® to type the location 
name and then copy and paste into the route window in PC*MILER. 
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3.6.2.2  Entering Locations in Australia (PC*MILER|Worldwide only)   
 
If the Streets Oceania address data set is installed and activated (see section 
3.6.6), locations in Australia must be entered using jurisdiction abbreviations 
rather than a country code.  These abbreviations are listed below.  If the Streets 
data set is not activated, any of the valid country codes listed in Appendix C can 
be used for highway-only routing. 
 
Australian Jurisdiction PC*MILER Abbreviation 
Australian Capital Territory ACT 
New South Wales NSW 
Northern Territory NT 
Queensland QLD 
South Australia SA 
Tasmania TAS 
Victoria VIC 
Western Australia WA 
  

 
3.6.3  Address Entry 

 
(Applies only in countries for which Streets data has been purchased)  If 
PC*MILER|Streets address data is purchased and installed with PC*MILER, you 
can – optionally – specify a street-level address in the Address field.  PC*MILER 
will route to each address, and addresses will be labeled on the RouteMap when 
you run your route. Addresses can be added to a city/state or postal code entry. 
 
An address can also be combined with a latitude/longitude point for more precise 
geocoding – see section 3.6.15.   
 
If, when entering a stop, you enter an address when the “Use Highway Only” 
route option is activated, a highlighted warning that says “Highway Only route 
option enabled” will appear above the stop list in the route entry window.   
 

 
“Highway Only” Warning in a Route Window 

Click the “X” 
to delete the 

warning. 
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The above-mentioned warning reminds you that a route won’t use local streets 
unless the highway-only option is turned off.  This option is turned on by default 
in the Route Options dialog, General tab.  To delete the warning, click the “X” on 
the far right.  To use local streets in routing, select the gear button      > Options, 
uncheck Use Highway Only, then close the Route Options dialog.  To have local 
street routing turned on by default for every new route, select the Routes tab > 
General group > Defaults and uncheck Use Highway Only in the Default Route 
Options dialog. 

 
In North America, address data is available for the US and Canada. With 
PC*MILER|Worldwide installed, address data is also available in Europe, India, 
and available countries in Africa, the Middle East, Oceania and South America.  
The appropriate data set must be selected – see sections 3.6.4 and 3.6.6 below.  
For Australia, see section 3.6.2.2 above. 
 
For PC*MILER|Worldwide Users:   In addition to having the correct region and 
data set selected, you may need to frame a different map region – see section 10.2. 
 
NOTE:   The pick list setting in the Application Settings dialog box determines 
how PC*MILER handles incomplete or inaccurate street names that are entered in 
the route window.  Select the red Application Menu > Application Settings to see 
this setting.  If Provide Pick List is unchecked, the first approximate match that is 
found in the database (if there is one) will be returned.  When Provide Pick List is 
checked (this is the default setting), a pick list will open and you can choose an 
address from it.  
 
TIP:  If you enter a ZIP/postal code and PC*MILER can’t find an address that 
you specify within that code, try expanding your search by entering the city name.  
In general it is recommended that, when entering or importing addresses, you use 
the corresponding city/state instead of the location’s postal code.  (For example, 
enter “457 North Harrison Street, Princeton, NJ” rather than “457 North Harrison 
Street, 08540”.)  Using the city and state/province will increase the geocoding “hit 
rate” and provide a more accurate representation of the address when routing. 
 
 

3.6.4  Changing the Region (PC*MILER|Worldwide and DTOD only) 
 
If the PC*MILER|Worldwide or DTOD data add-on module is installed, the 
correct world region must be selected in the Route Options or Default Route 
Options dialog box when entering stops.  In each route entry window, the 
currently selected region is displayed under the route name. To change the region 
for the active trip, select the Routes tab > Route group > Options or click the gear 
button in the route entry window and select Options, then choose a region from 
the Region pick list in the General tab of the Route Options dialog. 
 
To change the default region for all trips, select the Routes tab > General group > 
Defaults and choose a region as described above.  Now every route entry window 
you open will be set to the region you selected. 



 
  

 

 PC*MILER User’s Guide 52 

If the wrong region is selected (i.e. it does not match the stop you are attempting 
to enter), normally either an error message will appear or your input will be 
matched with a city by the same name in the selected region; for example, if you 
enter “Paris, FR” when your region is North America, “Paris, AR” will be 
returned as a stop.  The currently selected region is always displayed above the 
route name in the route entry window.   
 
However, with PC*MILER’s trans-regional routing, in certain cases the above 
rule does not apply.  Because routing between Europe, Asia, Africa, and the 
Middle East is possible, locations may be entered that do not match the selected 
region when any of these regions are selected.  For example, entering “Paris, FR” 
will return the correct stop if Asia or Africa is the selected region. 
 
You must also change the RouteMap window to the desired region if you 
wish to see graphic displays of the routes you run.  Select the Map tab > View 
group > Frame > Regions > and choose a region from the sub-menu. 
 
NOTE:  Options are set for each region separately.  PC*MILER remembers 
the options you last used for each region.  When you change regions, all options 
that were previously used for the new region will become active.  To create your 
own custom default settings for each region, select the Routes tab > General 
group > Defaults. 
 
 

3.6.5  Changing the Country Format (PC*MILER|Worldwide and DTOD only) 
 
Worldwide country abbreviations may be entered using either FIPS 2-character, 
ISO 2-character, ISO 3-character, GENC 2-character or GENC 3-character codes.   
FIPS codes are accepted by default.  To use another format for stop entry, click 
the File application menu and select Application Settings, then choose an option 
from the Country Abbreviation Format drop-down list.  For a complete list of 
worldwide country abbreviations, see Appendix C. 
 
 

3.6.6  Changing the Data Set 
 
 

 

Change Data Set Menu (with PC*MILER|Worldwide installed) 
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Select the Map tab > Utilities group > Change Data Set > to change the version 
of the map data that PC*MILER uses to calculate routes.  The currently loaded 
data set will be displayed in the title bar of the RouteMap window, shown at the 
bottom of each page in any generated reports in Print View, and selected with a 
checkmark in the Change Data Set menu. 
 
For ALK’s Annual Update Program (AUP) Licensed Users:  For PC*MILER 
(North America only), the options in the drop-down will include the base version 
data set plus any mid-year versions that have been released since the base version, 
including PC*MILER|Streets U.S. and Canadian street-level data if installed. 
 
For PC*MILER|Worldwide Users: PC*MILER|Streets data modules are available 
for local street addresses in Canada, the United States, Europe, and some 
countries in Africa, Asia, Middle East, Oceania and South America.  Each module 
may be purchased separately or in combination with other data sets. The correct 
data set must be activated before you enter an address.  When you activate a 
data set, the correct region will automatically be selected in the Route Options 
dialog.   
 
For PC*MILER|Energy Users:  You will see the NA – Streets Canada Energy 
data set in the Change Data Set menu. 
 
 

3.6.7  Pick List Option 
 
By default, when you enter a stop that has multiple listings in the database, a pick 
list of matching locations will open.  The order in which locations are listed in the 
pick list is based on such factors as population and geographic centrality. The 
most densely populated cities that match your entry will be at the top of the pick 
list.   
 
If you want to have PC*MILER pick a default postal code or address rather than 
open a pick list, select the File application menu > Application Settings.  In the 
Application Settings dialog, uncheck Provide Pick List, then click Save.  When 
“Provide Pick List” is turned off, if a city name has multiple postal codes or other 
database entries, the PC*MILER default match will be the first exact match that is 
found in the database. 
 
 

3.6.8  Spelling Help 
 
If you're not sure how to spell a city name, or if you received an error message 
when entering a city and state abbreviation, try getting spelling help as follows:  
  
1. In the City field of a route window, type the first letter or first few letters of 

the city name followed by a comma or space and the two-letter state/province/ 
estado abbreviation.  Note that typing more letters of the city name (i.e. two or 
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three rather than just one) will decrease the processing time needed to create a 
list of matches. 

 
Examples: chi,il       los ang, ca       pa fr       los a,ca 
 

2. Click Add Stop or press Enter.   
 
3. A pick list of possible matches will open unless this option is turned off in the 

Application Settings dialog box (File application menu > Application 
Settings…).  Scroll the list if necessary and highlight the city or ZIP/Postal 
code that you wish to select, then click OK. 
 

 

 
 

Pick List of Matches for Spelling Help 
 

 
3.6.9  Entering ZIP/Postal Codes 

 
Entering any valid postal code creates a search for the corresponding city. The 
city name will be entered as a stop, along with the state abbreviation and postal 
code. 
 
If you enter:  08540  (NA region)    
PC*MILER will return:  08540 Princeton, NJ, Mercer 
 
NOTE:  If the +4 ZIP code designation is entered, PC*MILER will ignore it. 

 
IMPORTANT NOTES for PC*MILER|Worldwide and DTOD USERS:  
When you are entering postal codes outside of North America, you need to enter a 
country abbreviation to avoid being routed to the wrong country in cases where the 
same postal code exists in more than one country. 
   
Enter the postal code, a comma, and the correct two-letter country abbreviation; e.g. 
“46001, sp” for Valencia, Spain.  Remember that the correct region must be 
selected in the Route Options dialog box (see section 9.3.1).  Not all countries have 
postal codes in the database.  Users can import absent postal codes as custom places 
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if needed.  For the format of postal codes in PC*MILER|Worldwide regions and 
various countries in those regions, see Appendix H. 

 
 

3.6.9.1  ZIP/Postal Code Help 
 

If you’re unsure of a particular postal code or if you receive an error message 
when entering a postal code, do the following:  
 
1. In the City field of a route window, type at least the first two digits of the 

postal code.  For postal codes outside North America, enter a country code as 
well.  Examples: 60 or 606 fr. 

 
2.  Click Add Stop or press Enter.   

3. A pick list of all matching codes will be returned unless this option is turned 
off in the Application Settings dialog box (File application menu > 
Application Settings > Provide Pick List).  Scroll the list if necessary and 
highlight the city or ZIP/postal code that you wish to select, then click OK. 

 

 
 

Pick List of Matches for “606 fr” Entry 
 
 

3.6.10  Canadian Postal Codes 
 

If the Canadian Postal Code add-on data module is installed, a list of six-digit 
Canadian postal codes is available for stop entry.  The codes are always 
alphanumeric in the format “ANA NAN” where “A” represents an alphabetic 
character and “N” represents a numeric character.  Entering any valid Canadian 
postal code will invoke a search for the corresponding city and province name, 
and these will be entered as a stop along with the postal code.  
  
If you enter: K7L 4E7     PC*MILER will return: K7L 4E7      Kingston, ON 
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3.6.11  SPLC Entry (North America only) 
 

If the SPLC add-on data module is installed, a SPLC can be entered as a stop for 
any location in North America that has a SPLC assigned to it.  SPLCs may be six or 
nine digits in length.  SPLC data used in PC*MILER products is owned, 
maintained and copyrighted by the National Motor Freight Traffic Association, Inc. 
To enter a SPLC, do the following: 
 
1.  Select “SPLC” from the drop-down list to the left of the City field. 
 
2. Type your entry and click Add Stop or press Enter.   
 
NOTE:  If you enter a SPLC when “SPLC” has not been selected in the drop-
down list, you’ll get an error message.  When “SPLC” is selected, you won’t be 
able to enter other types of locations. 
 
 

3.6.11.1  SPLC Help 
 

If you need help finding the correct SPLC for a particular location, a pick list of 
SPLC can be invoked. First make sure that “SPLC” is selected in the drop-
down list to the left of the City field, then type at least the first two digits of the 
SPLC and click Add Stop.  A pick list of matches will be generated unless this 
option is turned off in the Application Settings dialog box (File application menu 
> Application Settings).   
 
 

3.6.12  Border Crossings (U.S. only) 
 
You can enter a U.S. state border crossing as a stop on a route using the 
PC*MILER border crossing naming convention. To quickly locate all possible 
border crossings between two states, use the [*] wildcard character.  
 
For example, to generate a pick list of all Pennsylvania/New Jersey border 
crossings, enter: 

 

!njpa*, nj 
 
NOTE:  A pick list will only be generated if Provide Pick List is checked in the 
Application Settings dialog (File application menu > Application Settings…).  By 
default, this setting is turned on. 
 
Border crossings have the following syntax: 
 

!XXYY  Name,  XX 
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where XX is the two-letter abbreviation of the state that is first in alphabetical 
order, YY is the abbreviation of the state that is second in alphabetical order, and 
Name is the route name of the route that crosses the border. 

 
In cases where the road name is different on either side of the border, the road 
name used is the one that lies within the state first in alphabetical order. 

 
 

 
 

Pick List of NJ/PA Border Crossings 
 
 

3.6.13  Highway Junctions (North America only) 
 
PC*MILER allows you to access highway junctions between major road types in 
the United States, Canada, and Mexico.  (Note, however, that there are some 
highway junctions which are truck-inaccessible.  These junctions will not be 
recognized as stops.)  The best way to enter a highway junction is to invoke a pick 
list of matches. Type “+” (a plus sign) followed by a comma and the state 
abbreviation.  For example, enter 
 

+, in 
 

to generate an alphabetical list of all highway junctions in Indiana.  Scroll the pick 
list, highlight your choice, and click OK. 
 
NOTE:  A pick list will only be generated if Provide Pick List is checked in the 
Application Settings dialog (File application menu > Application Settings…).  By 
default, this setting is turned on. 
 
The format for junction names is as follows: the first route name is the lower 
numbered one, the second route name is the higher numbered one, and the route 
names are followed by the abbreviation of the state in which the junction is 
located.  An example of this is: 
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+I 469  IN 37, IN 
 

In cases where two junctions by the same highway pair occur within the same 
state, the junctions are designated by a location direction (N,S,E,W) relative to the 
location of the other junction.  For example: 
 
+US231 IN 66W, IN  is located one mile west of  +US231 IN 66E, IN 
 
 

 
 

Pick List of Highway Junctions in Indiana 
 
 

3.6.14  Latitude/Longitude Points 
 
PC*MILER enables you to enter latitude/longitude points as stops on a route.  
These points can be entered in degrees minutes seconds direction format (e.g. 
0401750N,0742131W) or decimal degrees (e.g. 40.123N,100.333W) - see the 
instructions below on format.   
 
Lat/long points are labeled in the RouteMap window just like other stops.   
 
REMINDER:  When you pass your cursor over the map without pressing the 
mouse button, its latitude/longitude position is automatically tracked and 
appears in the status bar in the lower left corner of the RouteMap window. 
 
In Pick Stops mode, lat/longs can be entered by clicking on the map.  To turn this 
mode on, select the Routes tab > Route group > Pick Stop on Map button.  
Alternatively, use the right mouse menu off the map to Copy Latitude/Longitude, 
then paste the point into the route window as a stop: 
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                              Latitude/Longitude Point on the Map 
                                   (in North America, with PC*MILER|Streets installed) 

 
 
Degrees-minutes-seconds format: 
In degrees-minutes-seconds format the latitude and longitude are each 8-character 
strings in the following format: 

 

Characters 1-3  specify the degrees (be sure to include  leading zero if required) 
Characters 4-5  specify the minutes 
Characters 6-7 specify the seconds 
Character   8   N, n, W, or w, with N’s for latitude and W’s for longitude  

Latitude and longitude must be separated by a comma WITHOUT A SPACE.  In 
general the format for a point is:   dddmmssN,dddmmssW. 
 
Decimal degrees format: 
In decimal degrees format, latitude and longitude are strings of up to 8 characters 
representing a decimal number with up to 3 decimal places. No leading zeros are 
required. The decimal point counts as one of the characters. Latitude and longitude 
must be separated by a comma WITHOUT A SPACE. In general the format for a 
point is:   dddd.dddN,dddd.dddW. 
 
Converting between formats: 
To convert from degrees-minutes-seconds to decimal degrees use the following 
formula:   dddmmssN  ddd + mm/60 + ss/3600. 
 
Decimal degrees format: 
In decimal degrees format, latitude and longitude are strings of up to 8 characters 
representing a decimal number with up to 3 decimal places. No leading zeros are 
required. The decimal point counts as one of the characters. Latitude and longitude 
must be separated by a comma WITHOUT A SPACE.  In general the format for a 
point is:   dddd.dddN,dddd.dddW. 
 
 

Right Mouse Menu  
Off the RouteMap 
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3.6.15  Latitude/Longitude With Street Address 
 
For more precise geocoding and directions, latitude/longitude points can be 
combined with street addresses as in the example shown below. This functionality 
(new in Version 28) geocodes the lat/long to the nearest point on the particular 
street in the address, rather than to the nearest street in the direction of travel, as 
would be the case for a lat/long by itself.  If the lat/long is more than .5 miles 
from the street in the address, an error message will be returned.  The minimum 
input when using this combination should include the lat/long plus a street name.  
Including a street address will provide more precise geocoding. 
 
NOTE:  “Use Highway Only” must be turned off in the Route Options dialog in 
order to geocode to a street that only exists in the street-level network.   
 

 

 

Stop Entry Using a Latitude/Longitude With an Address 
 

 

 

Trip To 1200 Kuser Road, 40.21167N,74.70348W (Trenton, NJ) 
 
 

 

 

 
 
 
 
 

Using a Lat/Long and Kuser Road Address –  
Routes to a Point Off Kuser Road (Route 619) 

Using Only a Lat/Long –  
Routes to a Point Off Interstate 295 
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3.6.16  Highway Exits (U.S. only) 
 
PC*MILER includes all Interstate-to-Interstate exit numbers.  It also includes all 
Interstate exits leading to non-Interstate highways. 
 
To enter a highway exit as a stop, you can enter “^” (Shift-6) followed by a 
comma and state abbreviation to bring up a pick list of all highway exits in that 
state.  For example, to create a pick list of all exits in New Jersey, enter: 
 

^, nj 
 

NOTE:  A pick list will only be generated if Provide Pick List is checked in the 
Application Settings dialog (File application menu > Application Settings…).  By 
default, this setting is turned on. 
 
You can also enter an exit directly.  For example, you could type “^I 80 E x273, 
pa” to enter Exit 273 off Interstate 80 East in Pennsylvania.  No spaces are 
necessary, but the east/west designation must be included.   
 
So, for example, valid entries would be: 
 

^I-90 w x35, ny  
^I 90w x35, ny 
^I-90wx35, ny 
 
 

 
 

Pick List of Highway Exits in New Jersey 
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3.6.17  Truck Stop Locations (U.S. and Canada only)  
 
Truck stops can be entered as stops on a route like other places in the PC*MILER 
database.   
 
The syntax for a truck stop starts with an "at" symbol [@], then the truck stop 
name, and the state or province in which the truck stop is located.   

 
To generate a pick list of truck stops in a particular state, use the [@] symbol, a 
comma, and the state/province abbreviation.  For example, for truck stops in 
Georgia you would enter: 
 

@, ga 
 

Or to speed up a search for a known truck stop, use the first letter of the truck 
stop's name.  For example, to generate a pick list of all truck stops in Georgia 
beginning with the letter "C" that are in the PC*MILER database, enter: 
 

@c*, ga 
 

NOTE:  A pick list will only be generated if Provide Pick List is checked in the 
Application Settings dialog (File application menu > Application Settings…).  By 
default, this setting is turned on. 
 
You can also pick a truck stop off the map using the mouse (section 3.6.21).  To 
find truck stops within a specified radius of a location, use the Location Radius 
tool (see section 3.8).   
 
Truck stops with fueling stations are represented on the map by gas pump icons  
(       ).  These icons can be seen at zoom level 11 or higher. 

 
 

 
 

Pick List of Truck Stops in Georgia 



 

 
 Chapter 3:  Basic Routing 63 

3.6.18  CAT Scale Weigh Stations (U.S. and Canada only) 
 
CAT Scale weigh station locations may be entered as stops on a route.  To enter a 
weigh station, you can type its location in the City field preceded by a pound sign 
(#).  An example is: 

 

#Petro Stopping Center, NJ 
 
To bring up a pick list of all CAT weigh stations in a particular state, enter a 
pound sign followed by a comma and the state abbreviation. For example: 
 

#, nj 
 

NOTE:  Users can import newer CAT Scale locations by downloading a file from 
www.catscale.com.  Instructions are provided on the website. 
 
You may also pick a CAT weigh station off the map using the mouse (see section 
3.6.21).  CAT Scale weigh stations are represented on the map by a cat icon 
(     ).  These icons can be seen at zoom level 11.  To find CAT weigh stations 
within a specified radius of a location, use the Location Radius tool (see section 
3.8).   
 

 

Pick List of CAT Weigh Stations in New York 
 
 
NOTE:  A pick list will only be generated if Provide Pick List is checked in the 
Application Settings dialog (File application menu > Application Settings…).  By 
default, this setting is turned on. 
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3.6.19  State Weigh Stations (U.S. only) 
 
You can also search for and enter state weigh stations as stops.  To search for all 
weight stations in a particular state, use a dollar sign ($).   For example: 
 

$, nj 
 
will bring up a pick list of all state weigh stations in New Jersey.   
 
 

 

Pick List of State Weigh Stations in New Jersey 
 
 
NOTE:  A pick list will only be generated if Provide Pick List is checked in the 
Application Settings dialog (File application menu > Application Settings…).  By 
default, this setting is turned on. 
 
To find state weigh stations within a specified radius of a location, use the 
Location Radius tool (see section 3.8). 
 
  

3.6.20  Entering An Arrival or Departure Time 
 
The ability to generate more precise estimated times of arrival/departure is a feature 
added in Version 25 of PC*MILER, and is described in Chapter 5, Time-Based 
Routing.  See section 5.1 for detailed instructions about how to enter a departure or 
arrival time and date or day of the week.  
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3.6.21  Picking Stops From the Map 
 

TIP:  Pass your cursor over the map without pressing the mouse button.  Notice 
that its lat/long position is automatically tracked and appears in the status bar in 
the lower left corner of the RouteMap window.  

 
PC*MILER lets you enter stops directly from the RouteMap window by pointing 
and clicking with the mouse.  To pick a stop, do the following: 
 
1. Select the Routes tab > Route group > Stops > Pick Stop on Map; or select 

Pick/Label > Pick Stops from the right mouse menu off the map.   

2. In the RouteMap window, the cursor will now be in the shape of a hand.  Use 
the mouse to point to the location you wish to enter and click once.  The 
location will be entered as a stop in the currently active route window. 

3. Alternatively, use the right mouse menu in the RouteMap window to select 
Copy Latitude/Longitude to copy the lat/long displayed in the status bar of the 
window, then paste this lat/long into a route window as a stop. 

 
You can use the mouse to select any point on the map.  If the point is a node on a 
highway, the place name will be returned; otherwise, a latitude/longitude position 
will be returned.  
 
NOTE:  There are some highway junctions which are truck-inaccessible.  These 
junctions won’t be recognized if you try to enter them as stops.  

 
 

3.6.22  Input Errors 
 
One of several error messages might be returned when entering stops.  If you 
encounter an error message, you should try the following:  

 

 Double-check that you separated the city name and state abbreviation with a 
comma or space. 

 Double-check for typos and spelling errors. 

 Get spelling help (see section 3.6.8). 

 Use the exact postal code or get ZIP/postal code help (see section 3.6.9.1). 

 Press the F3 key or see Appendix C for a list of valid two-letter 
state/province/estado abbreviations. 

 If entering a SPLC, make sure that “SPLC” is selected in the drop-down list to 
the left of the City field.  

 
In all cases, the ZIP/postal code takes precedence over the city and 
state/province/estado name.  Certain suburbs or small towns may not have their 
actual names in the database, but rather the name of the larger nearby city.  In 
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these cases, the ZIP or postal code for the smaller community will have to be 
entered to achieve correct results.  
 
Also see section 3.6.7 for a description of how a default location is selected when 
duplicate or multiple cities exist in the database. 
 
 

3.6.23  Duplicate City Names and County Designations 
 
In the PC*MILER database, there are several thousand instances of towns in the 
same state, province or estado that share the same name.  For example, in the U.S. 
state of Pennsylvania, there are two towns named Hamlin: one in Wayne County 
and one in Lebanon County.  Another example is the towns of Londonderry in the 
United Kingdom: one is in Londonderry and one is in North Yorkshire.  
 
In certain circumstances, duplicates can be separately identified by means of their 
differing postal codes.  However, some duplicate towns do not have postal codes 
assigned to them.  You can identify your desired stop by the county listing in the 
town name.  In the database, the county name follows the state abbreviation (e.g. 
Hamlin, PA, Wayne).  It appears in the route window after a stop has been 
entered, in small letters after the city name and state abbreviation. 
 
If you are not sure which city is the stop you want, first click the File application 
menu > Application Settings… and make sure that Provide Pick List is checked.  
Then enter the city name and state/province/estado abbreviation.  When you click 
Add Stop, a pick list will provide all the possible choices in the database along 
with county names.  The order in which locations are listed in the pick list is 
based on such factors as population and geographic centrality. The most densely 
populated cities that match your entry will be at the top of the pick list.  Select the 
correct city from the pick list and click OK to enter it as a stop. 
 
If you know the county in which the duplicate city is located, you can enter that 
exact city in the stop entry field.  Do so by entering the city and state in a normal 
fashion, followed by a comma and the county name.  Your entry must be in one of 
the following formats: 

  
hamlin, pa, wayne hamlin,pa, wayne 
hamlin, pa,wayne hamlin,pa,wayne 
 

TIP:  Another way to see the county name: in the RouteMap window, place your 
cursor over a town without clicking – the full name of the town, with its county, 
will appear in a tooltip. 
 
In Canada, duplicate city names are found in the same provinces.  PC*MILER 
identifies the town by assigning a county to it in the same way that the county 
name follows a U.S. city name.  For a list of Canadian counties in the PC*MILER 
database, see Appendix B or the PC*MILER Help files. 
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3.6.24  Editing the Stop List 
 
All options related to editing the stop list are found in the Routes tab > Route 
group, under Stops.  Alternatively, several editing options are available in a right 
mouse menu off any stop name on the list.  Here are all the editing options in the 
Routes tab, with the right mouse menu option noted where available: 
 
 

Editing Option Button/Shortcut Option Description 

Add Stop at End 
 

Type a location in the location entry fields 
and, instead of clicking Add Stop, click this 
button to add the stop at the end of the stop 
list. 

Insert Stop Above    F7 

Click to insert a stop above the highlighted 
stop; or right mouse click on the 
highlighted stop and choose Insert Above 
from the menu. 

Edit Stop 
 

Click to edit the highlighted stop, or right 
mouse click on the highlighted stop name 
and choose Edit from the menu. When done 
editing, click Add Stop to add the edited 
stop back to the same position on the list. 

Delete Stop    F8 

Click to delete the highlighted stop; or right 
mouse click the stop name and choose 
Remove from the menu. 

Delete All Stops    Alt+F8 
Click to delete all stops from the currently 
active route window. 

Frame Stop on Map 
 

Click to frame the highlighted stop on the 
map; or right mouse click on the stop name 
and choose Zoom to Stop from the menu. 

Pick Stop on Map 
 

Click to activate this option. Then pick a 
stop from the map: in the map window zoom 
in to the target location, point the cursor to a 
town, address, intersection, or lat/long on the 
map, then click to add this place as a stop. 

Move Stop Up    Shift+ 

Move the highlighted stop up on the list, or 
right mouse click on the stop name and 
choose Move Up. 

Move Stop Down    Shift+ 

Move the highlighted stop down on the list, 
or right mouse click on the stop name and 
choose Move Down. 

Reverse Stops 
 

Click to reverse the order of stops in the 
currently active route window. 
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3.6.25  Dragging and Copying Stops 
 
A geocoded stop can be copied or moved from one route window to another, or 
dragged to a different position in the same window.      
 
To copy a stop to another route window, left click the stop name while holding 
down the Ctrl key and drag it onto the stop list in the target window, letting go 
when the stop is in the desired position on the list.  The geocoded stop will be 
copied but also remains in its original window.   
 
To move a stop either to another position on the list of stops or to a different route 
window, left click the stop name and drag to the desired position.  If placed in 
another window, the stop will be deleted from the original window. 
 
To move or copy a stop using the right mouse menu, right click the stop name and 
select either Move to > or Copy to > from the menu.  Select a target window 
from the list of all open windows in the sub-menu.  The stop will be placed at the 
bottom of the stop list in the target window.  
 

 

Moving a Stop to the Route 2 Window 
 

 
NOTE:  Waypoints can be copied or moved just like stops.  However, if a 
waypoint is moved to the Origin or Destination position on the stop list, it will 
become a stop rather than a waypoint. 
 
 

3.6.26  Reversing the Order of Stops 
 
To reverse the order of all stops on the stop list, select the Routes tab > Route 
group > Reverse Stops.   
 
This option is especially useful when used with the route optimization feature (see 
section 3.7).  For example, say you need to make multiple pickups and you want 
to start at the farthest one on the route and end up at some other location for 
delivery.  Enter the delivery location first, then enter your pickup points.  Next, 
optimize your route keeping the first and last stops the same.  After optimizing, 
reverse the order of stops.  This will put your farthest pickup point first on the list, 
and your delivery point last, with an efficient route in-between. 
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3.6.27  Frame a Location On the Map     
 
To zoom directly to a specific location on the map, first enter the location as a 
stop in the route window and make sure it is highlighted on the stop list.  Then 
you can either 1) double-click the stop name; 2) right mouse click on the stop 
name and select Zoom to Stop from the menu; 3) select the Routes tab > Route 
group > Frame button; or 4) select Zoom to Stop from the right mouse menu in 
the RouteMap window. 

 
NOTE:  If PC*MILER|Streets data is installed and you're trying to find an 
address, you can place your cursor, without clicking, on any road segment on the 
map to see a tooltip containing the street name and address range of that segment.  

 
TIP:  Pass your cursor over the map without pressing the mouse button.  Notice 
that its latitude/longitude position is automatically tracked and appears in the 
status bar in the lower left corner of the RouteMap window. 

 
 

 
 

Zoomed Into a Stop in Idaho 
 

3.7  Route Optimization 

PC*MILER can optimize the order of stops in the active route window to 
minimize the total time (when using Practical routing), the total distance (when 
using Shortest routing), total toll distance (when using Toll Discouraged routing), 
and distance of the National Network (when using the National Network or 53-
Foot Trailer routing).  Optimizing a route provides the optimal order of stops, 
keeping the origin the same (or optionally, keeping both the origin and destination 
the same).    
 
Optimization cannot be undone.  The original order of stops cannot be 
recovered, so you may want to save the original route before optimizing (see 
section 3.10).   
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To optimize a route, select the Routes tab > Route group > Optimize > Optimize 
Stops from the drop-down list or press Alt+F10 on your keyboard to bring up the 
Optimize Route dialog box: 
 
 

 
 

Optimize Route Dialog Box 
 
 
This dialog gives you the following options: 
 

 Route Through All: Stops will be optimized in any order, with only the 
origin remaining fixed. 

 Destination Fixed:  Keeps the origin and destination the same. 

 Run route after optimizing stops: Automatically generates the route when 
optimization is finished. 

 
NOTE:  You need at least three stops to optimize with Route Through All and 
four stops using Destination Fixed. 
 

3.8  Location Radius 

PC*MILER includes a Location Radius search tool for easier rate determination 
and trip planning.  This tool enables you to find every city, postal code, custom 
place, and/or point of interest – including intermodal ramps – within a specified 
radius around any location.    
 
To use the Location Radius feature, select the Routes tab > Route group > 
Location Radius then follow the steps below: 

 
1. Enter a location in the City field.  Any format that can be used for stop entry 

will be accepted here (city/state, postal code, latitude/longitude, custom place, 
point of interest, etc.).  If PC*MILER|Streets is installed, an address can also 
be entered.   

2. Use the check boxes to select which types of places to include in your search.  
If POIs is checked, a category of POIs can be chosen from the list below to 
narrow the search.  (If a category is not chosen, all categories will be 
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searched.)  Choose “Custom” under “Custom Category” to list all custom 
places within the radius that have been saved to the PC*MILER database. 

3. Enter a Radius (a number of miles or kilometers, depending on the unit of 
distance setting in the Route Options dialog, General tab). 

4. Click Find to search.  The list below will be populated with the search results. 

You can select one, several, or all matching places to add as stops to the active 
trip, plot on the map, or save to a text file.  Highlight the one(s) you wish to select 
– hold down the Shift or Ctrl key to pick multiple places. To select all places, 
highlight the first place on the list, then hold down the Shift key and highlight the 
last place, scrolling down if necessary.   
 

 

 

Weigh Stations Within 10 Miles of Ames, IA 
 
 
To add the selected places as stops in the active route window, click Add Stops.  
To save them to a text file, click Save.  To plot the selected points on the map, 
click Plot Points.  The plotted points will appear as small red squares. 
 
To copy the selected points to the Windows clipboard for pasting into another 
application, highlight your selection and press Ctrl+C on your keyboard. 

  
To clear points from the picklist, click Clear.  Plotted points will remain on the 
map until another set of points is plotted or the Location Radius window is closed. 
 
NOTE:  The maximum number of matching places that can be displayed after 
you execute the search is 15,000.  In some cases you may need to specify a 
smaller radius to get a complete list of matches.   
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3.9  Running a Route 

NOTE for PC*MILER|Streets Users:  By default, routes in North America are 
calculated with the “Use Highway Only” option turned on.  This option can affect 
distance calculation, and may be turned off using the Route Options or Default 
Route Options dialog.   
 
 

 

Mileage, Time and Cost Calculations For a Generated Route 
 
 
For a route to be generated, there must be a valid origin and at least one valid 
destination entered in the active route window.  To generate a route, you can:  
 

 click Run in the active route window; or 
 press the F10 key; or 
 select the Routes tab > Route group > Run. 

 
Active routing options are listed at the top of the route window, under the route 
name.  The routing options that are active by default are listed below. See Chapter 
9 to change routing options.   
 

 For North America: Practical, Borders Open, Highway Only, Use Ferry 
Distances, Tolls Discount - US$*  (* With PC*MILER|Tolls installed) 

 For All Other Regions:  (PC*MILER|Worldwide and DTOD only) 
Practical, Borders Open, Use Ferry Distances 

 
When processing is finished, the route will be drawn and framed on the 
RouteMap, and mileage, cost, and time estimates by trip leg will appear to the 
right of each stop on the list.  If an arrival or departure time was entered, the ETA 
at each stop will also be calculated.  The route window can be resized horizontally 
if necessary to see all the columns.  From left to right, the columns are: 
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 Time Zone – Displays the time zone for each stop. See section 5.1 on how 
time zones are reported and setting this option.  

 Tolls – (Only if PC*MILER|Tolls is installed) At each stop, shows toll 
costs for the trip leg from the previous stop, with the total toll cost for the 
trip at the bottom.   

 Cost – At each stop, shows the estimated cost of the trip leg from the 
previous stop, including tolls if PC*MILER|Tolls is installed.  Trip costs 
are calculated by multiplying PC*MILER’s default cost per mile by the 
number of miles. The cost per mile settings can be customized using the 
Route Options or Default Route Options dialog box – see sections 9.4 and 
9.8. 

 Time – At each stop, shows the estimated driving time for the trip leg 
from the previous stop.  Cumulative driving time is shown at the bottom. 

 Miles –  At each stop, shows the mileage for the trip leg from the previous 
stop.  Cumulative miles for the trip are shown at the bottom. 

 ETA/ETD – If an arrival or departure time was entered, this column 
shows the departure time at the origin (this time is an estimate if an arrival 
time was entered) and estimated arrival time(s) at each stop. 

 
 

3.9.1  Warnings in Route Windows 
 
When PC*MILER generates any type of warning regarding a routing issue, the 
stop on the trip leg to which the warning applies will have a red bar to the left, 
and the stop number will turn red as well.  Place the cursor over the red bar to see 
a tool tip that briefly describes the reason for the warning, then generate a 
Detailed or Driver’s Report to see more details. 
 
 

 

Warning Indicator in the Route Window 
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3.9.2  Editing Columns in a Route Window 
 
The columns in any route window can be hidden and the column order can be 
changed in any route window using the Column Chooser dialog.  To access this 
feature, right click any stop on the stop list in a route window, then select 
Column Chooser in the right mouse menu that pops up. 
 
 
 
 
 
 
 
 
 
 
 
       
 
 
 
 
 
In the Column Chooser dialog, all possible columns are listed.  Columns that are 
displayed are checked. (Note that the ETA/ETD column only displays if an 
arrival or departure time has been entered for a route.)  Uncheck any column to 
hide it.  To change the column order, click on a column name to highlight it and 
then click Move Up or Move Down.  As the column name moves up the list, it 
will be moved to the left in the route window, and vice versa.  Click the Reset 
button to reset to the default column order. 
 
NOTE:  The Column Chooser is also available in reports – right click any column 
header to access it. 
 
 

3.9.3  Route Framing on the Map 
 
 To automatically frame each route after it is run, select the Map tab > View 

group > Frame > Auto Frame Routes (this option is turned on by default). 
 
 To frame one route, select the Routes tab > Route group > Frame or the Map 

tab > View group > Frame One Route > and select a route. 
   
 To frame all generated routes, select the Map tab > View group > Frame > All 

Routes.  
 
 

Right Mouse Menu Off a Stop Column Chooser Dialog 
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3.9.4  Copy and Paste the Mileage Report 
 
After a route is generated, the results in the route window can be copied and 
pasted into a text editor such as Microsoft Word.  With your cursor inside the 
route window, press Ctrl + C.  Then open the text editor and press Ctrl + V.  The 
example below is in a WordPad file.  The widths of the data columns have been 
adjusted by changing the position of the tabs in those paragraphs. 
 
 

 

Mileage, Time and Cost Data Pasted Into WordPad 

 

3.10  Working with Multiple Routes and Windows 

For comparison purposes, you may want to route through different locations while 
keeping the routes you already generated open.  Up to eight route windows can be 
kept open simultaneously.   
 
When there are hidden or partially hidden windows open, a scroll bar will appear 
on the right side of the Routes pane.  The active route window will have a 
highlighted title bar at the top.   
 
Each open route will be drawn in a different color in the RouteMap window.  
Routes are identified in the Route Legend (if this legend is not visible, select the 
Map tab > Customize group > Legends > Route) and their corresponding route 
color appears on the left side of each individual route window.  
 
Reports can be run for each generated route, with each report appearing in a 
separate window.  See section 3.3 on screen layout options. 
 
To bring a window forward, click the Window tab and select the window you 
want to see from the Windows group.  
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3.11  Duplicating a Route for Easy Comparison 

To duplicate a route either before or after it is run, select the Routes tab > Route 
group > Duplicate.  A new route window will open that contains all the stops 
from the original route.  This option makes it easy to compare different route 
types (for example, Shortest and Practical) for the same route. 
 

3.12  Saving and Retrieving Trips 

Routes generated in PC*MILER can be saved for later retrieval, either before or 
after they are generated.  This is particularly useful for trips you run frequently.  
To save a route either before or after processing, select the Routes tab > Route 
group > Save > Save Route As to bring up the Save Route dialog box. 
 
NOTE:  When route files from previous PC*MILER versions are opened as trips, 
they are automatically converted to Version 28 format. 
 
This dialog is a standard Windows® dialog box.  Choose the folder where you 
want your route file to be placed, assign a file name and type to the file, then click 
Save.  There is no limit to the number of characters a file name can contain.   
 
Select the route type “.r21” from the Save as Type drop-down for trips that will 
be retrieved at a later time from within PC*MILER.   When you save a file with 
the .r21 extension, route options will be saved together with the route, but saved 
route files do not retain mileage, cost and time information. 
 
To save sets of points in text format for batch processing using 
PC*MILER|BatchPro or for use with PC*MILER|FuelTax, select the rout type 
“.in”.  Files saved with the extension “.in” do not include any route options. 

 
 

 
 

Save Route Dialog Box 
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To load a previously saved .r21 route file, select the Routes tab > General group > 
Open.  This will bring up a standard Windows dialog similar to the one you used 
to save your route.  Select your saved file from the File Name pick list and click 
Open.  As mentioned above, all settings used to create the file will be restored, 
but you will need to rerun the route to see reports and a RouteMap display of the 
route.  
 

3.13  Custom Place Names and Categories 

PC*MILER gives you the capability to assign your own custom names to an 
unlimited number of locations in the PC*MILER database.  Custom place 
categories can also be created.  To create a new custom category and a custom 
place within that category, follow the steps below. 
 
 

 

Add a Place Dialog 
 
 
1. Select the Tools tab > Custom Place Manager group > Add Places.   

 

2. To add a new custom place category in the Add a Place dialog, click New. 

3. Enter a Name for this category (the same name cannot be used more than once). 

4. From the drop-down Pin list, choose an icon to represent this category on the map.  
(If none is chosen, the generic gray pushpin will be used.) 

  
 

5. Click Save to save the new category. 
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6. Back in the Add a Place dialog, select the category you just created from the 
Category pick list. 

7. Enter your custom name in the Name field (the same name cannot be used 
more than once).   

8. Enter the PC*MILER location (real name) in the Location and (optionally) 
Address fields.  The location can be in any format that is valid for stop entry.  

9. Click Save to save the new custom place name to the PC*MILER database. 
 

 
   
 

Once a custom place is created, you can enter it as a stop on a route: type the 
custom name into the City field in the route window.   
 
NOTE:  Custom place names are sensitive to spacing – for example, the name 
“01586,GM” is not the same as “01586, GM”. 
 

 

Entering a Custom Place as a Stop 
 

 
To view or edit custom places, press F2 or select the Tools tab > Custom Place 
Manager group > Manage (see section 3.13.1 below). 
 
To view or edit custom categories, select the Tools tab > Custom Place Manager 
group > Categories. 
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To pick a location off the map for a custom place, select the Tools tab > Custom 
Place Manager group > Pick Places on Map and click on the desired location on 
the RouteMap. 
 
 

3.13.1  Using the Custom Place Manager 
 

To view, edit or delete custom places, select the Tools tab > Custom Place 
Manager group > Manage.  All custom places in the database are listed in the 
Custom Place Manager.  To sort any column, click the column header. 
 

 

 

Custom Place Manager 
(Address data shown above can be entered only if PC*MILER|Streets data is installed) 

 
 

To edit a custom place, click the Edit button for that place in the last column. 
Make the desired changes and click Save to save your edits. 
 

 

Edit a Place Dialog 
 
 

To delete a place, click the Delete button for that place.  To delete all places on the 
list, click Delete All.  A prompt will ask you to confirm if you mean to delete all 
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places.  To Export the list of places, see section 3.13.3 below.  Click the “X” in 
the upper right corner to close the Custom Place Manager and save your edits. 
 
 

3.13.2  Creating Custom Latitude/Longitude Points  
 
You can assign a name of your choosing to a latitude/longitude point in the 
PC*MILER database by using the Add a Place dialog (section 3.13 above).  For 
example, you could type “Home Office” in the Name field, and “40n,100w” in 
the Location field.  After you add this name to the list, you’ll be able to enter 
“Home Office” as a stop on your route. 
 
Note that PC*MILER tracks the latitude and longitude position of your cursor as 
it passes over the RouteMap (watch the status bar in the lower left corner of the 
program window). 
 
 

3.13.3  Exporting Custom Places 
 
PC*MILER gives you the ability to export all custom places listed in the Custom 
Place Manager into a .csv (“Comma Separated Value”) file or a tab-delimited text 
file.   
 
To export custom places from the Custom Place Manager, follow these steps:  
 
1. Select the Tools tab > Custom Place Manager group > Manage. 

2. In the Custom Place Manager, click Export.   

3. In the Export window, select a file type in the Save as type pick list.  For a 
comma-delimited value file choose “.csv”, or choose “.txt” to save as a 
comma-delimited text file.   

4. Assign a file name. 

5. Select a target location where the export file will be saved.   

6. Click Save to create the export file. 
 
 

 

Custom Places Exported to Excel (Column Formatting Adjusted) 
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3.13.4  Importing Custom Places  
 
NOTE:  See section 3.6.14 for the correct way to format latitude/longitude points.  
See section 3.6.1 for all other stop entry formats that are accepted by the Import 
Custom Place Wizard.   
 
TIP:  Did you know that the Import Custom Place Wizard can be used as a batch 
geocoding tool to clean up your data?  If you have a list of customer locations that 
include street addresses and/or other information, you can import those locations 
to confirm that they match locations in the PC*MILER map database.  
(PC*MILER|Streets is required to process address data.)  The original input file 
does not need to include custom place names but does have to be correctly 
formatted – see Step 1 below. 

 
NOTE Also:  Importing a file containing more than 4,000 places may take a very 
long time and is not recommended.  Consider dividing a large input file into 
smaller files for importing. 

 
Using the Import Custom Place Wizard, you can import sets of custom places 
which were created in an environment independent of PC*MILER.  During the 
import process, PC*MILER provides the option to 1) enter the whole set of 
imported places as stops on a route, or 2) save the imported places as custom 
places in the map database for future use.       
 
The Import Custom Place Wizard first tries to match each record in the input file 
to a place or address range in the database, converting the records to a format that 
PC*MILER can use.  The input file must be a text file with columns delimited by 
a tab or other character such as a comma.  Here are several lines from a sample 
text file of custom places that are suitable for importing: 
 
 

 

Sample Text File, Tab Delimited 
 
 
The import process includes five basic steps, covered on the following pages: 
 
Step 1. Setting Up a Correctly Formatted Input File 

Step 2. Open the Input File 

Step 3. Select and Preview Input 

Step 4. Confirm Matches 

Step 5: Add Places to a Route Window or the Custom Place Manager 
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STEP 1:  Set Up a Correctly Formatted Input File 
 

The first step is to ensure that your input file is correctly organized and formatted.  
Making the effort to properly organize the input file can make a big difference in 
how efficiently the locations in the file are processed.  The input file must be a 
text file with columns delimited by a tab or other character such as a comma.  If 
the original file is a text file, try opening it in Excel, formatting as necessary, and 
then saving it again as a tab-delimited .txt file 
 
To successfully add places to the database, at minimum the input file must include 
a location column.  The required location for each place must be either a 
latitude/longitude, postal code, or city and state/province/country abbreviation.  
(PC*MILER|Worldwide or DTOD data must be installed for countries outside 
North America.)  Other location information can be included in additional 
columns.  As you will see in Step 3, you can tell PC*MILER to ignore columns in 
the input file that contain data that can’t be imported. 
 
It is recommended to organize the information in each column of the input file 
into like groups, separating the data that PC*MILER will accept from the data 
that won’t be accepted.  For example, from left to right the file might include: 
 

 Place Name – A custom place name (required).  If the file does not 
include place names and you are importing places for the purpose of data 
matching, you can insert a column with any appropriate custom name. 

 Address Line 1 – A location address including a street number and street 
name.  PO Box numbers are not accepted by PC*MILER and should be 
removed.  (PC*MILER|Streets is required for address data to be accepted.) 

 Address Line 2 – Secondary address information such as suites, floors, 
apartments, units, building names, etc.  Not accepted by PC*MILER. 

 City – The city name. 
 State/Province – A two-letter state/province/estado abbreviation, the name 

should not be spelled out (e.g. “ON” is correct, “Ontario” won’t be accepted). 
 ZIP/Postal Code –  

o U.S. addresses can be a ZIP or ZIP+4 Code (use a dash with 
ZIP+4, e.g. 12345-1155).  PC*MILER will only read in the first 
five digits and will ignore the last four. 

o Canadian addresses should include spaces, do not use dashes (e.g. 
G1A 1B1, the format is ANA<space>NAN where “A” stands for 
“letter” and “N” stands for “number”). 

 Country – Not usually needed, but should be in its own column. 
 Region – (PC*MILER|Worldwide or DTOD data must be installed)  A region 

is only needed if locations are outside North America.  Region names should 
be spelled out as they appear in the Route Options dialog box. 

 
Example File: 

 
 Place Name  Address Line 1  Address Line 2  City  State/Province  ZIP/Postal Code  Country 
 Warehouse1  4 Moore Street  First Floor  Princeton  NJ  08540  US 
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STEP 2:  Open the Input File 
 

1. To begin, open the Import Custom Place Wizard: select the Tools tab > 
Custom Place Manager group > Import… . 

 
 

 

Import Custom Place Wizard – Initial View 

 
2. In the Wizard, select Tab Delimited if the input file is tab-delimited text.  

Otherwise, select Other Delimited and enter a delimiter in the box to the 
right.  This setting tells the Wizard where a new column should begin in the 
input file.  Usually the delimiter is either a tab or a comma. 

 
3. Click Browse and navigate to the drive and directory where your data file is 

located.  Be sure to select the correct file type in the drop-down, then select 
the file to be imported and click Open.   

 
 

 

Open Input File Dialog 
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STEP 3:  Select and Preview Input 
 

Now you’ll see the data from the input file, organized in columns.  Initially, all 
column headers are labeled Skip, meaning that PC*MILER cannot interpret what 
type of data is in each column.  Use the drop-down pick list at the top of each 
column to assign a new column header; or if the first row of the input file 
included appropriate headers, check First row contains column headers.   
 
 

 

Import Custom Place Wizard – Select and Preview Input 
(Address data shown above can be imported only if PC*MILER|Streets data is installed) 

 
 
To successfully import places, there must be at least one location column.  The 
location must be a LatLong (latitude/longitude), PostCode (postal code), and/or 
City and State (state/province/country abbreviation) with an optional Address.  
Other available headers are: Region (used only with PC*MILER|Worldwide or 
DTOD data), Description and Category. 
 
TIP:  The “Category” header can be used to assign a map icon of your choosing 
to a set of custom places.  Simply create a custom category (see section 3.13) and 
make sure the category name in your input file exactly matches the custom 
category name. 
 
Each of the headers can be applied to only one column, with the exception of 
Skip.  Label a column Skip if the data in it should not be read (e.g. memos or 
descriptions) or if it is blank. 
 
To adjust column widths in the table for better visibility, place your cursor 
between two column headers.  When the cursor changes to an arrow, hold down 
the left mouse button, drag the margin to the desired width, then let go. 
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The options under Records to Process determine how many and which rows of 
data in the table will become custom places.  Select All to have all the data 
processed, or Selected to process only some of the records.  If you choose 
Selected, enter the range of records to be processed. 
 
With the columns and input selection set, click Next to continue. 

 
TIP:  If you want to import a file that has different types of locations (postal 
code, city and state, and/or latlong) on different rows, and/or different 
combinations of types (such as postal code and state), first use the 
=citytolatlong() function in PC*MILER|Spreadsheets to convert those types 
consistently to LatLong, then import that file specifying a Name column and a 
LatLong column as the only location.  See the PC*MILER|Spreadsheets User’s 
Guide for instructions on how to use the =citytolatlong() function. 
 
ADDITIONAL NOTES:  The more information you include, the more certain it 
is that a unique match will be found.  Import Custom Places will import a file that 
has city and state combined into a single column (label this column "City"), or zip 
code, city and state combined into a single column (label this column "Zipcode"). 
A county name may optionally be included at the end of either one. A space 
should separate the ZIP code from the city, a comma should separate the city from 
the state, and a comma should separate the state from the county. For example, 
any of the following are acceptable: 
 

City 
Princeton 
Princeton, NJ 
Princeton, NJ, Mercer 
 

ZipCode 
08540 
08540, NJ 
08540 Princeton, NJ 
08540 Princeton, NJ, Mercer 

 
 
STEP 4:  Confirm Matches 

 
When all records have finished processing, the Confirm Matches screen will 
display the processed records along with results data and output options. 
 
Results: 
 

 Total Processed: The total number of records processed. 

 Total Matches: The total number of records that were successfully 
matched with a location in the PC*MILER database.   

 Seconds/Records:  The average time spent on processing each record. 
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 Time Elapsed: The time elapsed since the start of the record matching 
process. 

 

 

Import Custom Place Wizard – Confirm Matches 
 
 

Confidence Level: 
There are four possible levels of confidence in the accuracy of the data matching 
for each record: 
 

1  Exact An exact match was made.  For street addresses, trust is 95% or 
greater AND if address is outside the range listed in the 
database, the top match is within 100 address units of input 
address*; OR for any other match level if there are multiple 
matches they are all within .1 air miles of each other. 
* For example, “100 Main Street” was input and the best match in the 
database is “150-250 Main Street”. 

2  Fair Inexact match but unique result (i.e. there is only one match). 
For street addresses, trust is 85% or greater AND if address is 
outside the range listed in the database, the top match is within 
500 address units of input address*; OR for any other match 
level if there are multiple matches they are all within .5 air 
miles of each other. 
* For example, “100 Main Street” was input and the best match in the 
database is “450-550 Main Street”. 

3  Uncertain Inexact match and there is more than one match in the 
database.  For street addresses, trust is 50% or greater. 

4  Failed Match not found. Trust is below 50% for street addresses. 
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# of Records: 
This column displays the total number of records which fall into each of the above 
categories. 
 
% of Records: 
This column shows the percentage of all records that fall into each category. 

 
In the Accept column, accepted records will be checked to indicate that they were 
successfully matched with a location in the PC*MILER database with either an 
Exact or Fair confidence level.  Locations that were not accepted will have an 
error message in the Error(s) column that briefly describes the reason for the 
error.  Check marks can be manually entered or deleted in the Accept column.   
 
The Conf (Confidence) column shows the confidence level of each record’s 
match (described above).  The Match column displays the record in the database 
that was matched to the input location. 

 
 

STEP 5:  Add Places to a Route Window or the Custom Place Manager 
 
Once the validity of all the Accepted matches have been confirmed, you are ready 
to add the imported places to a route window or the Custom Place Manager.  You 
only need to make a few option selections, described below.   
 

Add Selected Places:  

Choose whether output should be added to the Custom Place Manager (i.e. 
the PC*MILER database) or a Route Entry Window.   Check Accepted to 
only add the accepted names, or All Matched to include all matches except 
those in the “Failed” category.  

Options:  

Here, if you selected to save the imported places to the Custom Place 
Manager, choose whether to automatically overwrite any duplicate custom 
place names or PC*MILER place names that already exist in the database.  If 
Prompt for each duplicate is selected, a prompt will be displayed when a 
duplicate is detected and processing won’t proceed until there is an 
interaction.  If you are adding the output to a route window,  under Add 
Places to Route Window choose whether to open a new route window or add 
them to the currently active window. 

 
When ready, click Add Selected Places to send the output to the target route 
window and/or the Custom Place Manager. 
 
Click Export Results in the upper right corner to create a text file containing the 
confirmed matches.  
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3.13.4.1  Editing Custom Place Records 
 
To edit or verify a record, highlight it in the Results window and click Edit 
Selected Custom Place in the upper right corner of the Confirm Matches screen.  
In the Edit Match window, you’ll see all matches that were found in the 
PC*MILER database for that location listed and displayed on a map.  
 
The map in this window is set to “Box Zoom” mode.  To zoom to a match on the 
map, hold and drag a box around it with the left mouse button. 
   
 

 

Edit Match Window 
 
 
Under the map, the fields on the left show the name and data included in the 
highlighted record.  These fields can be edited.  On the right, all matches are listed 
and the Selected Match field shows the complete record in the PC*MILER 
database for the match that is highlighted on the list. 
   
To search for a wide range of possible matches, you can enter the first few 
characters of a faulty postal code or city/state name and then click Find All 
Matches.  For example, type “085” in the LatLong, Postal Code, or City, State 
field to get a list of all postal codes that begin with “085”.  (Note that if there is an 
address in the Street Address field, you should delete it before performing the 
search for best results.) 
 
Click OK to exit the window and save your edits, or Cancel to cancel the edits. 
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3.13.5  Converting Custom Place Files from a Previous Version 
 
Custom places that were saved in the previous version of PC*MILER can be 
transferred and converted to PC*MILER Version 28 using the steps below. 
 
IMPORTANT: You should convert your old custom places to the new format 
following the steps below before using the Custom Place Manager to create 
new places in Version 28.  If you have already created new places in Version 28, 
you’ll need to contact Technical Support – see section 15.1. 
 
NOTE Also:  After you complete the steps below, it could take up to 5 minutes to 
start PC*MILER when a large number of files need to be updated. 

 
 

1. Close PC*MILER if it is open.   

2. In Windows Explorer, navigate to the folder where PC*MILER 27 or 27.1 is 
installed.  The installation folder PMW270 or PMW271 is usually located in 
C:\ALK Technologies. 

3. Select and copy all files EXCEPT version.dat* in the NA\Q1\Save\ 
user_places\user (version 27) or World\WW\Save\user_places\user 
(version 27.1) folder. 

4. Now navigate to the folder where PC*MILER 28 is installed.  The installation 
folder PCMILER28 is usually located in C:\ALK Technologies.   

5. Paste the files you copied into the 
PCMILER28\Data\Q1\Save\user_places\user folder. 

* It is very important to avoid copying and pasting the version.dat file, because POI’s won’t 
be recognized in Version 28 if this file is copied and pasted. 

 
The next time you run PC*MILER Version 28, your custom places will 
automatically be updated for compatibility. 
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                   Least Cost Routing 
 
 

Costing has always been an important use of PC*MILER.  Among ALK 
customers there has been a growing interest in using PC*MILER to help with the 
trade-off of toll costs, costs per mile, and costs per hour in determining a “least 
cost” route. 

 
In response to the needs of our customers, ALK began to research the relevant 
costing issues using several cost factors (typical miles per gallon, cost per gallon, 
fuel cost per mile, other cost per mile, and labor cost per hour for an 18-wheeler) 
and found that: 

 
 a slower (less “practical”) route is the least-cost route 58% of the time, 

regardless of diesel price, provided the truck can still make its delivery 
window and its pickup window for its next load; 

 if the least-cost route is chosen, there is the potential to save 0.6/% - 0.9% 
in costs, on average1; 

 when diesel prices are high, the least-cost route is more likely to be a 
“shorter” route compared to when diesel prices are low; and 

 the absolute amount of savings from choosing a least-cost route is 
insensitive to diesel price. 

 
Of the 90 origin/destination pairs used in ALK’s study2, the O/D with the largest 
difference in cost, regardless of diesel price, was Chicago, IL to Washington, DC.  
At a fuel price of $2.71/gallon, the savings if the “least cost” route was chosen 
would be $79, or 7.8% 3: 
 
 

Chicago, IL to Washington, DC 

Route Miles Hours 
Cost 

Total Tolls Fuel Time Maint 

Prac 697.1 11.60 $1,010 $147 $315 $465 $84 

Prac|Toll 776.8 12.90 $961 $0 $351 $517 $93 

Short 689.9 12.10 $994 $115 $312 $485 $83 

Short|Toll 700.1 13.23 $931 $0 $316 $531 $84 

Least-cost difference 3.0 1.63 -$79 -$147 $1 $66 $0 
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r 
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Would a customer in the above scenario actually save $79 in cost if they chose the 
“least cost” route?  That would depend on a lot of factors that are external to the 
route: 

 where the driver is in their hours of service cycle 

 the delivery time window for the truck and driver’s current load 

 the pickup time window for the truck and driver’s next load 

 alternative opportunities to match a different truck and driver to the next 
load (for a dispatcher of company drivers) or to choose a different next 
load (for an owner-operator) 

 
On the basis of all the above findings, ALK has developed a new Least Cost 
routing feature that considers user-specified values for miles per gallon, cost per 
gallon, fuel cost per mile, other costs per mile, labor cost per hour, and stop costs 
– and includes a parameter for a greenhouse gas emission estimate.   
 
Least Cost routing generates a series of alternative routes with distance, time and 
cost estimates, and lets the dispatcher or driver (or an external system, such as a 
truck dispatch optimization system) choose an optimal route, considering factors 
such as those cited above that are external to the route.  If PC*MILER|Tolls is 
installed, toll costs are factored in as well. 
 
______________________________ 
Reference Notes: 
1 - These results are for 48' equipment.  It is expected that the potential savings for 53' equipment will be 

lower, due to fewer opportunities for legal alternative routes. 
2 - The O/D pairs used for the study connect the centers of the 10 largest metro areas in the U.S. 
3 - Sources of “average” data used in the study were default values for drivers paid by the hour, along with 

values from a recent American Transportation Research Institute (ATRI) study (An Analysis of the 
Operational Costs of Trucking), the U.S. Energy Administration, and typical miles per gallon for an 18-
wheeler. 
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4.1  Using Least Cost Routing  

To calculate Least Cost routing, follow the steps below: 
 

1. In a new route window, enter an origin and at least one destination, then run 
the route – click Run or press F10.  If there are any time/cost settings that 
need to be specified, they can be entered in the Route Options dialog box – 
see sections 9.4 and 9.5 – either before or after running the trip. 

 
2. Select the Routes tab > Route group > Optimize > Least Cost Routing.  A 

separate window will open that displays the possible routes on a map and the 
calculated totals for each route below the map.  The most efficient calculated 
totals for distance, costs, hours and tolls will be highlighted in yellow below 
the map. 

 

 

 

Least Cost Options Window 
 
 

To hide a route on the map, uncheck it in the Visible column. 
 
To use one of the generated routes, highlight it and click Save Selected 
Options.  The calculated totals will appear in the route window, replacing the 
original route. 
 
Click Print to print the Least Cost route calculations in a Comparison report. 
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Least Cost Comparison Report 

 
 

NOTE:  Internally, PC*MILER calculates six route types for Least Cost 
routing, but if the total cost is the same for two or more of these routes, not all 
routes will be displayed.  Route types that PC*MILER calculates for every 
route are: Practical, Practical - Toll Discouraged, Shortest, Shortest - Toll 
Discouraged, Fastest, and Fastest - Toll Discouraged. 
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        Time-Based Routing 
 
 

In recent years, ALK Technologies has become aware that a number of our 
customers are interested in considering time of day, day of the week, and time 
zones when calculating and reporting routes, distances, travel times, and toll 
costs.  Up to and including Version 28, PC*MILER default routes, distances, 
travel times and toll costs are calculated based on: 
 

 average road speeds by state/province, urban/rural, and class of road; 

 height, length, width, and weight restrictions that apply during the 
majority of the commonly traveled seasons of the year, days of the week, 
and times of day; 

 seasonal roads being open during shipping and receiving seasons, but not 
to through traffic; 

 and peak-period toll costs for the most recently updated quarter of the 
release year. 

 
These fundamental routing criteria work well for the many purposes of our users, 
and will always be foundational to ALK’s industry-leading PC*MILER products. 
 
The time-based feature enhancements described in this chapter were added in 
PC*MILER Version 25 and now offer more precise travel time estimates to those 
users who are interested.  PC*MILER capabilities related to time-based routing 
allow users to: 
 

 specify a departure or arrival date and time for more realistic transit times; 

 calculate truck-specific toll costs based on the time of day (PC*MILER|Tolls 
must be installed); 

 and calculate more accurate transit times based on industry-leading 
historical traffic data. 

 
Time-based routing can be run with or without the use of traffic data to increase 
the precision of travel time calculations.  When time-based routing is used, 
ETA/ETD information appears in the route window, Detailed Route Report, and 
Driver’s Report.   
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5.1  Route Generation With ETA/ETD 

 
 
 
 

 

Time-Based Routing Options in the Route window 
 

 
Optional time and date settings in the route window can be used to generate time-
based routing that determines estimated times of arrival (ETA) and departure 
(ETD) based on a user-specified departure or arrival day and time.  An ETA is 
calculated for every stop and toll plaza on the route (PC*MILER|Tolls must be installed 
to access toll information).  Follow the steps below to generate time-based routing. 
 
1. Select the red File application menu > Application Settings. 
 
2. In the Application Settings dialog, choose the desired option in the Time 

Zone drop-down (note that this setting affects how dates/times are reported, 
not how they are calculated): 

  
 

 Local: Reported ETA/ETD will conform to the time zone where each stop 
or toll plaza is located (applies in all world regions).  

 System: ETA/ETD at stops and toll plazas will be reported based on the 
time zone setting on the host computer. 

 Specific: Select a time zone by region (options will reflect the world region 
selected in the Route Options dialog).  ETA/ETD at all stops and toll plazas 
will be reported using this time zone (available only for NA and Europe). 

Optional Arrival/Departure  
and Traffic Settings 
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3.  In the route window, click the middle drop-down to open time options and 
specify an arrival/departure time and date or day of the week: 

 

 
 Depart by/Arrive by:   

Select Depart by (to set the departure day/time at the trip’s origin) or 
Arrive By (to set the arrival time at the trip’s last stop).  If this setting is 
changed after a route is calculated, the ETD and ETA’s will automatically 
recalculate.  The default setting here is None – time-based routing won’t be 
used for the trip. 

 

 Specific Date or Day of the Week:   

Select either Specific Date or Day of the Week.  To enter a date, either 
type it in the text box or click the calendar and select a date.  To specify a 
day of the week, click the drop-down list. 

         
 
 
 
 
 
 
 
 
    

   

           Day of the Week Pick List           Picking a Date from the Calendar 
  

NOTE:  To change the defaults for the Depart/Arrive and Specific 
Date/Day of Week settings to those you want to use frequently, select the 
Routes tab > Defaults > Cost/Time  tab. 
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 Local Time: 

A time of day must also be entered.  Type the targeted local time at the 
arrival/departure location. 
 

 
 
To change the time format from AM/PM to 24 Hours (“military time”), 
select the File application menu > Application Settings and choose the 
desired option: 

 

 
 
4.  Now add at least two locations (an origin and destination) to the stop list and 

click Run to generate the route.  Estimated arrival and departure times at all 
stops on a route will be shown in the mileage report in the route window after 
the route has been generated.  If a target Arrival time was entered, the 
necessary ETD from the origin to meet that target is calculated. 
 
Note that the calculated ETA/ETD shown below reflect driving times that 
include a scheduled break time (10 hours, after 14 hours of driving).  Stop 
durations, break times, remaining Hours of Service and border wait times may 
be entered in the Route Options dialog box, Cost/Time tab.  

 
 

 

Generated Route With ETA/ETD 
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5.2  Using Traffic Data for More Precise Time Estimates  
(U.S. and Canada only) 

 
NOTE:  A subscription to PC*MILER|Traffic must be purchased to access traffic 
data in PC*MILER, and you must have an Internet connection to use these 
features. 
 
Time-based routing can be generated with or without using traffic data.  
Conversely, traffic data may be used whether or not an arrival or departure 
day/time has been entered.  Using traffic data will increase the precision of time 
estimates. 
 
If you choose not to use traffic data, travel times and ETA’s will be calculated in 
the same manner as in all previous versions of PC*MILER, based on average road 
speeds (either PC*MILER default or user-specified) by class of road in each 
state/province.  Road speeds can be customized in the Route Options or Default 
Route Options dialog box.  
 
To calculate a route’s ETA/ETD using traffic data, use the drop-down menu in the 
route window to change Traffic Disabled to Traffic Enabled.  This option will 
remain active until it is changed by the user again (to set the default for all route 
windows, see section 5.2.1 below). 
 

 
 
If Traffic is enabled and a departure or arrival time and date are not entered, 
INRIX default travel times that reflect free-flow conditions – think middle of the 
night – are used.  (This is the “Typical” option mentioned below.) 
 
Traffic data is collected by road segment.  With the Use Traffic Data option 
selected and a departure or arrival time and date are entered, travel times and 
ETA’s will be calculated based on historical, typical and/or real-time traffic 
data, depending on the arrive/depart and day/time settings.  “Historical” data 
reflects how average traffic patterns affect road speeds on the road segments used 
by the generated route.  (An “average” pattern is created using a historical time 
slice: 7 days in a week, with each day divided into 15-minute time slices.)  
“Typical” data uses road speeds that would occur if there were no traffic on those 
road segments.  “Real-time” data is just that: current traffic patterns that are fed 
into the system in real-time. 
 
NOTE:  The three types of traffic data mentioned above can be displayed in the 
RouteMap window – see Chapter 6. 
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If Depart by is selected and the day/time is within 15 minutes of the current time, 
real-time traffic data will be used for the first 15 miles and Historical data will be 
used for the remainder of the route.  (This is because after 15 miles of driving, 
conditions will have changed and they are more likely to resemble historical 
conditions than current conditions.)  When Arrive by is selected, Historical data 
is always used.    
 
 

5.2.1  Use Traffic Data By Default 
 
To use traffic data by default in every new route window, select the Routes tab > 
General group > Defaults > Road Speeds tab and check Use Traffic Data.  When 
Use Traffic Data is checked, custom road speeds cannot be entered in the Route 
Options dialog and, if already entered, are not available.   
 
 

 

Default Route Options Dialog Box, Road Speeds Tab 
 

5.3  Time-Based Routing  in Reports 

Estimated arrival and departure times at all stops on a route are shown in the 
mileage report in the route window after the route has been generated.  These 
times appear in the ETA/ETD column to the far right.  This column is inactive 
when an arrival or departure day/time has not been entered. 
 
ETA/ETD information also appears in the far right column of the Detailed Route 
Report if a day/time was entered for the route (the report may need to be scrolled 
to the right – see section 8.2 for a detailed description of this report).  This report 
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column will show the estimated times of arrival at every stop and toll plaza on the 
route.  If a target arrival time was entered, the estimated departure time from the 
origin will be shown.  If a departure time was entered, that time will be shown at 
the origin. 
 
In the Driver’s Report (see section 8.4), if a route was run using real-time traffic 
data, a Delay column will appear just to the right of the Time column.  The 
“delay” time identifies delays caused by the current traffic conditions on the first 
15 miles of the trip.  (Note that real-time traffic data is used for the first 15 miles 
of a generated route if “Use Traffic Data” is turned on, unless a time is entered 
and Day of Week is selected rather than a date – in that case, historical traffic data 
is used for the whole route.)  
 

5.4  “Special Restrictions” in Routing and Reports 

Beginning in Version 28,  time-based routing now integrates road restrictions that 
are active only during specific times.  These new restrictions are enabled when 
you open the Arrival/Departure window in a route window and select an arrival 
or departure time.  This action will cause PC*MILER to route around roads that 
have time-based restrictions. 
 
These special restrictions may include roads that are closed in one or more 
directions; have a temporary closure in one or more directions 
(construction/natural disaster); have a restriction on a particular truck 
configuration (weight, hazardous material) in one or both directions; have a 
special speed limit in effect;  or have a particular lane closed or allowed.  
 
For example, the I-82 highway from Aspen, CO to Buena Vista, CO is closed in 
winter;  so if an arrival or departure time during the winter season is entered, 
PC*MILER will route around I-82. (Note that the roads the alternate route takes 
may vary depending on whether the Highway Only option is turned on in the 
Route Options dialog.  Using local streets in routing generally provides a route 
that is closer to the original one – in this case the spring, summer and fall route.) 
 
Selecting “Override Restrictions” in the Route Options dialog will override these 
time-based restrictions, along with all other restrictions, but warning messages 
will appear in the Detailed and Driver’s reports where a restriction exists. 
 
The information provided in warnings will be formatted as follows: 

Days of the Week:  SMTWTFS.  Any days during which the restrictions don’t 
apply appear as a dash, e.g. S-T-TFS. 

Hours: XX:XX AM – XX:XX PM, or XX:XX – XX:XX (Military Time – The 
format can be changed in the Application Settings dialog.) 

Months: Includes the three-letter abbreviation of all valid months. 
Days:  Date range in every month from X-Y, e.g. 7-10. 
Weeks:  Week range in every month from X-Y, e.g. 1-2. 
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5.5  Time-Based Toll Cost Reporting 

(Installation of PC*MILER|Tolls required) Prior to Version 25, PC*MILER 
calculated toll costs based exclusively on peak hour rates while factoring in 
vehicle dimension settings that affect those rates.  Beginning in Version 25, when 
an arrival or departure time is entered in the route window, truck-specific toll 
costs can be calculated even more precisely because time-of-day variations are 
factored into toll rates when and where they occur, including peak and non-peak 
tolls.   
 
See Chapter 7, Getting Toll Costs, for more on generating routes with toll costs.  
 
NOTE:  Toll costs are always calculated in the local time as the planned route 
crosses the toll booth.  By default, the date/time of the toll collection is also 
reported in that local time.  To change this setting, select the File application 
menu > Application Settings and use the Time Zone option to choose either 
System (your computer’s time) or a specific time zone.  The date/time of the toll 
collection will then be reported in the time zone you specified.  Note that time 
zones displayed for each stop in the route windows will also be affected by this 
setting change. 
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        Traffic Display 
 
 

PC*MILER gives users the option to purchase access to traffic data for roads 
throughout the U.S. and Canada that can be used for more precise time-based 
routing, as described in Chapter 5.  This data can also be used to display 
historical, typical or real-time traffic patterns in the RouteMap window.  (Note 
that an internet connection is needed for real-time data and for subsequent updates 
to the historical and typical traffic data.)  For general instructions on using the 
RouteMap window, see Chapter 10. 
 
 

 

Traffic Display Showing Level of Congestion – Lincoln Tunnel, New York, NY 
 
 
PC*MILER’s new traffic display feature lets users instantly visualize traffic data 
on the map in any location throughout the continental United States to help with 
route planning, analysis, and diagnostics. 
 
NOTE:  An internet connection is required for the display of real-time traffic 
patterns.  If you are not connected to the Internet and request traffic data to be 
displayed, you won’t see any traffic flows on the map, and the Traffic legend will 
show the default text: “Actual: Last Update: 12:00 AM”. 
 
NOTE Also:  The traffic display options described in this chapter do not affect 
how traffic data is used in time-based routing.   
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6.1  Traffic Display Options 

To access the traffic display and set options for it, select Traffic… in the right 
mouse menu off the RouteMap.  The Traffic Display window can be left open and 
moved around anywhere on the screen as you work in PC*MILER.  
 
 

 

Traffic Display Window 
 
 
When traffic display is turned on and your computer is connected to the internet, 
you will see traffic data displayed on the map at zoom level 5 and higher within 
the area you are zoomed into.  (The current zoom level is shown in the title bar of 
the RouteMap window.)   
 
To turn on the display, select either Congestion or Speed at the top of the Traffic 
Display window.  When you change an option in this window, the map will 
immediately redraw to reflect the new data.   
 
Options in the Traffic Display window are the following: 
 

 Show: 
Select Congestion to show the amount of congestion (relative to Typical – 
see the Time options description below), or Speed to show absolute traffic 
speeds.  Select Off if you don’t wish to see traffic displayed on the map. 

 
 Time: 

Select Now to see real-time data displayed (internet connection required). 
 

Select Historical to see past traffic patterns.  The Historical option displays 
average traffic based on patterns created using a historical time slice: 7 
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days in a week, with each day divided into 15-minute time slices.  The 
Historical display depends on the day and time selected (see below). 
 

The Typical option pertains only to road speeds (not congestion) and 
represents road speeds that are typical when there is no traffic congestion. 

 
 Historical Day and Time: 

Using the radio buttons and slider bar or arrows, indicate a day and time of 
day for which historical data will be displayed.   

 
If you close the Traffic Display window, the selected options will remain in effect 
(unless you turn the traffic display on or off using the Map Features dialog box). 
 

6.2  Traffic Display on the Map 

 

 

Real-Time Traffic Display – Holland and Lincoln Tunnels, New York, NY 
 
 
The traffic display can be seen on the map at a zoom level of 5 or higher (the 
zoom level is shown in the title bar of the RouteMap window). 
 
To turn the Traffic legend on or off, select the Map tab > Customize group > 
Legends > Traffic.  As with the other legends in the map window, you can click 
on this legend and drag it to where you want it.   
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The settings in the Traffic Display window determine which Traffic legend – 
Traffic Congestion or Road Speeds – appears on the map.  In the example above, 
congestion is displayed and the Traffic Congestion legend shows the colors used 
to draw traffic patterns.   
 
Both legends shown below include update times, indicating the display of real-
time data.  
 

                         

Traffic Legends – Real-time Display  
 
 
The legends below pertain to a Historic traffic display, and show the day of the 
week and time that are set in the Traffic Display window. 

 

          

Traffic Legends – Historic Display 
 
 

In the Road Speeds legend, distances are in miles by default.  This setting can be 
changed in the Route Options or Default Route Options dialog box (see 8.10 and 
8.11). 
 
NOTE:  If you are working with a real-time display, it may take anywhere from a 
few seconds to a minute or so for the display to update, depending on the speed of 
your Internet connection and when updated traffic information becomes available. 
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        Getting Toll Costs 
 
 

If ALK’s PC*MILER|Tolls add-on module was purchased with PC*MILER, you 
can generate accurate, up-to-date toll costs for U.S. and Canadian lanes with these 
costs integrated directly into the routing database and reported turn-by-turn per 
trip.  Columns for toll costs appear in the Detailed Route Report, State/Country 
Summary Report, and Comparison Report, and tolls can be reported in the 
currency of choice – either U.S. or Canadian dollars – using the current 
conversion rate. 
 
Accurate toll cost calculations can optimize productivity in multiple departments 
of your organization by assisting in the routing, rating, and reconciliation 
processes. Now you can determine whether it’s more cost-effective to take a toll 
route, or a non-toll route with a few additional miles, before routing a vehicle.  
 
PC*MILER|Tolls generates up-to-date, truck-specific toll costs for toll roads, 
bridges, tunnels, and border crossings for U.S. and Canadian toll authorities.  The 
data that PC*MILER|Tolls provides includes: 
 
 Both cash and discount toll program transactions.    

 Range (ticket) and barrier (coin drop) data in addition to two-way tolls, one-
way tolls, and tolls that vary by direction.  

 Quarterly toll data updates to ensure accuracy when calculating toll costs 
throughout the year.  (PC*MILER|Tolls users receive notification by email 
when quarterly updates are available, or may use Check for Updates in the 
Help tab to ensure they have the most current data.) 

 Time-of-day variations factored into truck-specific toll rates when and where 
they occur, including peak and non-peak tolls, if time-based routing is active 
in the route window.  (See Chapter 5 for a detailed description of how to use 
time-based routing.) 

 Toll rates for smaller 2-axle vehicles when automobile routing is generated. 

 Future expected changes to toll rates included as available. 

 Thirty-eight (38) toll discount programs throughout the U.S. and Canada 
(states in which each program apply are listed below). 

 
GENERAL NOTES on TOLL RATES: Unless vehicle dimension settings are 
customized in the Route Options dialog (see section 9.6), PC*MILER|Tolls 
calculates toll costs for an 80,000 pound, 5-axle vehicle.  Reported toll amounts 
are accurate and up-to-date, but not always exact due to several factors: first, 
several – though not many – toll roads have rates that are based on weight (for 
example, the Detroit-Windsor Tunnel charges a set rate per 100 lbs. gross weight 
in both directions); second, some toll charges (in various states) are time-of-day 
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driven, and in this case, tolls will be calculated using the highest (peak) rate 
unless PC*MILER’s new time-based routing is used; and third, future and 
proposed toll rates are incorporated into the database where appropriate and these 
rate changes may occasionally be cancelled at the last minute. 
 
Also note the following:  if the user does not specify a departure/arrival date, the 
computer’s system date is used as the date of departure to determine the effective 
toll rates for the trip (which include any rate changes that become effective during 
the trip).  However, this is not true for the time of day.  If the user does not 
specify a time of departure/arrival, the base rate for the date (i.e. highest rate) is 
used without reference to the system time. 

 
 
States/Provinces Where Each Discount Program Applies: 

 
SPECIAL NOTE:  The “EZPass-WV” or “EZPass-NJ” options apply to those who 
purchased the EZPass service in West Virginia or New Jersey. 
 

Discount Program Valid In  Discount Program Valid In 

407 ETR Transponder ON Canada  GO-PASS CO 
A25 Transponder QC Canada  I-Pass IL 
A30 EXPRESS 
Transponder 

QC Canada 
 

K-Tag KS 

BreezeBy OR  Laredo Trade Tag TX 
C-Pass FL  LeeWay FL 
Cruise Card GA  MACPASS NS Canada 
Downbeach Express 
Pass 

NJ 
 

NC Quick Pass NC 

E-Pass TX 
 

NEXPRESS TOLL 
MI 
ON Canada 

E-Pass Canada NS Canada 
 Palmetto Pass 

(PAL PASS) 
SC 

ExpressPass NY, ON Canada  Peach Pass GA 
EXpressToll CO  PikePass OK 
EZ Tag TX  Quickpass BC Canada 

EZPass 
DE, IL, IN, ME, MD, 
MA, NH, NJ, NY, NC, 
OH, PA, RI, VA, WV 

 
Smart Tag VA 

EZPass-NJ NJ  StraitPASS PEI Canada 
EZPass-WV WV  SunPass FL 

FAST LANE 
MA and all E-ZPass-
equipped facilities 

 
TollTag LA, TX 

FasTrak CA  TReO BC Canada 
GeauxPass LA  TxTag TX 
Good To Go WA  Wabash Pass IN 
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The following discount programs have been discontinued in the database: 
 
Discontinued 
Program 

State Versions 
Available

Version 
Discontinued 

Reason 

NEXUS NY, 
ON 

27 28 Discontinued 

I-Zoom IN 21-26 27 Replaced by EZPass 
B-Pass NB 17-25 26 Toll discontinued 
M-Tag MD 17-23 24 Replaced by EZPass
NH Tokens NH 17, 18 19 Replaced by EZPass
O-Pass FL 21-23 24 Absorbed into SunPass
Ready Toll OH 17, 18 19 There is no discount 

associated with this program, 
it’s simply a “debit card” used 
to pay tolls 

Transpass ME 17- 23 24 Replaced by EZPass

 
 
NOTE:  Toll costs on the New York State Thruway for “5-axle 48’ Trailer” and 
“5-axle 53’ Trailer” vehicles are now accurately reported.  The N.Y. Thruway 
lists separate toll rates for these vehicle types and now PC*MILER|Tolls has been 
calibrated to report the correct rate depending on the routing option selected.  If 
the Vehicle Dimension length is set to 53’ in the Route Options dialog box, the 
corresponding 5-axle 53’ Trailer toll cost will be reported. 
 
NOTE Also:  Some toll exits in the U.S. and Canada have recently become 
“electronic only”; for example, starting December 1st, 2008, the 183A toll road in 
Texas has become cashless. The way to pay for this toll road is either by TXTag 
(their electronic toll payment method) or Pay By Mail.  Pay By Mail is for those 
who don’t have the electronic discount program – their license plates get 
photographed and a bill is mailed to the owner.  Commonly referred to as “video 
tolling” or “video billing”, the rates for this payment method are higher to cover 
processing costs. 
 
See Appendix G for a list of all electronic-only toll roads. 
 
All Pay By Mail and video toll rates are considered as “Cash” in PC*MILER toll 
rate calculations. 
 

7.1  Turning On Toll Cost Calculation (U.S. and Canada only)  

(PC*MILER|Tolls must be purchased and licensed)  Toll costs can be calculated 
along with mileage, cost and time estimates when you generate any PC*MILER 
route with at least an origin and a destination using any available route type or 
option, including Hub routing.   
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To turn on toll calculations for an individual route, select the Routes tab > Route 
group > Options > Tolls tab and make sure Tolls Enabled is checked.  To keep 
tolls enabled by default for every route,  select the Routes tab > General group > 
Defaults > Tolls tab). 
 
Toll costs can be calculated with or without discount programs applied.  By 
default, Use Discount Programs is checked on in the Route Options dialog and 
all discount programs are selected.  You can customize these settings by 
unchecking the Use Discount Programs option or any of the listed discount 
programs.   
 
 

 
 

Route Options Dialog, Tolls Tab 
 
   
To switch to Canadian dollars as the currency for toll calculations, use the 
Currency drop-down list to choose Canadian Dollars.  The Conversion Rate is 
displayed to the right and can be customized by simply typing in a new rate.  
Whenever toll calculations are turned on, the currency in use is shown in each 
route window along with the discount program status. 
 
NOTE:  Settings in the Tolls tab not only affect PC*MILER, but also determine 
which discount programs will be in effect whenever you use PC*MILER|Connect, 
PC*MILER|Spreadsheets, or PC*MILER|BatchPro to calculate tolls.  
 
When toll calculations are turned on, you’ll see a Tolls column in the route 
window on the far right.  Toll fees for each leg (not cumulative) will be listed in 
addition to mileage and cost/time estimates.  For total cumulative toll costs, run a 
State Summary Report or Comparison Report (see sections 8.3 and 8.6). 
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Toll Calculation by Trip Leg in the Route window 
 
 
The default Tolls settings are: 
 

 Tolls Enabled is checked 
 Use Discount Programs is checked 
 All discount programs are selected 
 Currency is US$ 
 Conversion Rate is USD/CAD = $1.00/$1.051 
 

7.2  Customizing Toll Costs By Weight and Axle  

Jurisdictions in the U.S. and Canada that have toll roads class their toll rates either 
by vehicle weight or by a vehicle’s number of axles. Beginning in PC*MILER 
Version 22, setting the vehicle’s dimensions in the Vehicle Dimensions tab of the 
Route Options dialog box enables toll cost reporting based on vehicle weight and 
number of axles.   
 
The available toll rates by axle are from 2 (two axle dual rear wheel vehicles 
only) up to 14 axles, including multi-trailer rates and automobile routing.  For toll 
rates categorized by weight, each toll road authority publishes its own definition 
of weight classes, and PC*MILER categorizes and reports these toll rates based 
on the published weight category and range provided. 
 
For those who are new to the arena of toll cost reporting, the jurisdictions that 
charge toll costs by weight and those that charge by axle are identified below.    
This information is important to know if you intend to use PC*MILER to 
generate toll costs that are customized by weight and axle. 

Discount Status & CurrencyTolls Column
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 Jurisdictions Charging Tolls by Vehicle Weight:  MI, NJ, NS, ON, PA 

 Jurisdictions Charging Tolls by Axle: AK, AL, BC, CA, CO, DE, 
FL, GA, IL, IN, KS, LA, MA, MD, ME, MI, MN, MO, NB, NC, NE, 
NH, NJ, NS, NY, OK, OR, PA, PEI, QC, RI, SC, TX, UT,  VA, VT, 
WA, and WV 

 
To enter the weight and/or number of axles for a vehicle either before or after 
stops have been entered for a route, select the Routes tab > Route group > Options 
> Vehicle Dimensions tab.   
 
 

 

Route Options Dialog, Vehicle Dimensions Tab 
 
 
In the Vehicle Dimensions tab, only the weight, axle number and multiple trailer 
settings affect toll cost reporting.  Enter these parameters as follows: 

 
Weight:  Weight may be entered in pounds or kilograms (select English or 

Metric at the top of the dialog).  Weights up to 132,000 lbs. or 59,874 
kg. may be entered.  Weights less than 9,000 lbs./4,082 kgs. will 
generate routing appropriate for automobiles and small vans.  See 
section 9.6 for more on how PC*MILER handles vehicle weight, and 
section 11.2 on custom vehicle profiles.  Vehicle weight is 80,000 lbs. 
by default. 

 
Axles:  Select a number from the drop-down pick list.  The default is 5 axles.  

Note that 2 axle includes two axle dual rear wheel vehicles only. 
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Multiple Trailer (MT):  Check this option if the vehicle is a long combination 
vehicle with multiple trailers. (See Important Note below.) 

 
IMPORTANT NOTE:  Twin trailers with 7 or more axles are not allowed on the 
Massachusetts Turnpike east of Exit 14. If you enter 7 or more axles and check 
“Multiple Trailer (MT)”, PC*MILER will return a $0 toll rate for that section 
without a warning. 
 
When done, click Save to close the Route Options dialog, then generate your 
route.  PC*MILER will calculate the appropriate route and report the 
corresponding toll costs according to the vehicle dimensions you set.    
 
If custom information is not entered in the Vehicle Dimensions tab, the default 
values will be used.  The default values are based on a typical Class 8 vehicle 
with a weight of 80,000 lbs./36,287 kg. and 5 axles. 
 
NOTE:  Users have the option to set up profiles for individual vehicles or for 
specific vehicle types that include vehicle dimensions and time/cost settings (the 
same ones that are found in the Route Options dialog box).  See section 11.2 for a 
full description of this option. 
 

 

7.3  Tolls and Plaza Names in the Detailed Route Report 

Toll costs are calculated by trip leg in the Detailed Route Report.  To generate this 
report, select the Routes tab > Route group > Reports > Detailed Report or press 
F5 on your keyboard.  For more on this report, see section 8.2. 

 
To assist users in toll cost reconciliation, toll plaza names have been added to the 
database.  Some plazas listed in this report have multiple sub-plazas at the same 
location, but PC*MILER assigns one name to all of them.  For a list of toll 
authorities and names where sub-plazas exist, see Appendix F.   
 
Abbreviated plaza names appear in the Detailed Route Report in a new column 
titled “Toll Plaza”.  If the Toll Plaza column is blank, either the agency does not 
have a transponder program or the agency has a transponder program but the toll 
plaza abbreviations used on that agency’s invoices could not be determined at this 
time. 
 
The format of the plaza names is as follows: the agency abbreviation, the entry 
plaza abbreviation, and the exit abbreviation.  In cases where the entry and exit 
plazas are the same (barrier toll), the plaza abbreviation will be shown only once. 
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Detailed Route Report 
 
 

7.4  Getting Toll Totals in the Comparison Report  

The PC*MILER Comparison Report calculates total toll amounts, along with 
mileage and estimated time and cost, for two or more trips.  To generate this 
report, click the Comparison button on the toolbar or press F4 on your keyboard.   
The two routes shown below in this sample report are identical except that the 
Toll Discouraged routing option was turned on for Route 2. 
 
 

 
 
 
 

 
 

Comparison Report Showing Toll Discouraged Routing Option 
 
 
 
 

Toll Costs by Trip Leg 
and Toll Plazas 

Toll Total 
For Each Trip 
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7.5  Toll Information in the State/Country Report 

The PC*MILER State/Country Report automatically calculates toll totals at each 
stop, by state, and by trip if tolls were calculated.    
 
A breakdown of toll costs by the type of discount program applied is also 
available.   To obtain this breakdown, select the File application menu > 
Application Settings… and check Show Toll Discount Info in the Application 
Setttings dialog then click Save.  This can be done before or after the 
State/Country Report is generated. Discount program information will appear in 
the state/country summary section at the bottom of the report, in the Tolls column 
(see the example below). 
 
To generate this report, first run the trip in the route window, then press F6 on 
your keyboard or click the State button on the toolbar.  See section 8.3 for 
additional information about this report.  The location of toll cost data in the 
report is shown below. 
 
 

 
 

State/Country Report – 
Display of Toll Costs and Discount Program Information 

 

 

 

 

 

 

 

 

 

 

 

 

State/Country Report with Toll Discount Information (Print Preview)

Toll Amounts  
by State/Country

Toll Total 
For the Trip 

Discount Information – 
“Show Toll Discount Info” 
must be turned on in the 

Application Settings dialog. 

Leg Tolls & 
Toll Total at 
Each Stop 
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Generating Reports 
 

In addition to the mileage, time and cost information that is returned when a route 
is run, there are six different PC*MILER reports that can be generated:  Mileage, 
Detailed Route, State/Country, Driver’s, Road Type, and Comparison.   
 
When a report is generated, it opens in a separate pane.  You can control the 
location of this pane within the PC*MILER application window using the Report 
Location and Layouts buttons in the Window tab.  Any subsequent reports will 
open in the same pane. 
 
 
 
 

To float an individual report in its own window, right-click the report title in the 
tab at the top of the report, then select “Float”.  To dock it, right-click the report 
title again and select “Dock”. 

 

 

Display Options for an Individual Report Window 
 

8.1  Mileage Report 

When a route is run, mileage, time and cost information is returned in the route 
entry window.  A Mileage Report can be printed that summarizes this information 
and also includes cumulative miles by trip leg and greenhouse gas estimates.  
Select the File application menu > Print Report… > Mileage.   
 
Note that this report does not appear on-screen, printing it is the only way to 
generate it.   
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Printed Mileage Report 
 

8.2  Detailed Route Report 

After generating a route, select the Routes tab > Route group > Reports > 
Detailed or press the F5 key to display a Detailed Route Report for the active 
route.   
 
 

 
 

Detailed Route Report 
 
 
This report includes direction of travel, roads, interchanges, stops, scheduled 
break times, empty/loaded status at each stop, on-duty stop times and costs, leg 
and cumulative times and distances, and toll costs (if PC*MILER|Tolls is 
installed and toll calculation is turned on).  The report displays additional 
information depending on the options selected when the route was run.  Values 
that affect reported cost and time estimates and toll costs are set in the Route 
Options dialog box.   
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TIP:  Double-click a line in this report to zoom into that route segment on the 
map. 

 
The columns from left to right in the Detailed Route Report give you the 
following information for each route segment: state, toll or free road, turn 
direction, route (with exit number where available), segment distance, driving 
time, interchange point, leg mileage and time, cumulative trip mileage and total 
trip time.  
  
If PC*MILER|Tolls is installed and toll calculations are turned on in the Route 
Options dialog box, leg toll costs and the corresponding toll plazas will be shown 
in two columns on the far right.   
 
If day/time information was entered for the route, there will be an additional Stop 
Time column to the far right.  This column will show the estimated time of arrival 
at every stop and toll plaza on the route.  If a target arrival time was entered, the 
estimated departure time from the origin will be shown.  If a departure time was 
entered, that time will be shown at the origin.  The column header for the Stop 
Time column will reflect the Time Zone Display setting (File application menu > 
Application Settings).    
 
A dollar sign ( $ ) to the left of the directional column marks segments that are 
toll roads.  Alerts such as height, weight, 53-Foot restrictions, and geofence 
warnings are noted where they exist, appearing before the pertinent road segment 
in the report.  (See section 1.6.5 for more on 53-Foot restrictions in reports.)   
 
NOTE:  Due to the way PC*MILER identifies locations and calculates routes and 
distances, occasionally a toll barrier won’t be reported in the Detailed Route 
Report.  When this happens anywhere on a route, an alert will appear at the very 
bottom of the report stating that this has occurred.  You can then check all route 
segments marked with a dollar sign to find the omission. 
 
At the point where a route begins to use a road segment that travels through a 
geofenced area, a warning like this will appear that includes the name of the road, 
the name of the geofence set, and the name of the individual geofence: 
 
Warning * US-1 * : New Jersey : NewBrunswickNJ  

 
If time/cost settings were designated, the Detailed Route Report will also include 
a time and cost for each stop, the empty/loaded status for each leg, a border wait 
time, and the time at which a break should be taken if the number of on-duty 
hours allowed between breaks was specified for the route.  Stop times and costs, 
empty/loaded mileage, a border wait time, and break time information are 
calculated using input you may enter or edit in the Route Options dialog box (see 
sections 9.4 and 9.5).   
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If one of the Hazardous Material route types was used (PC*MILER|HazMat 
installation rquired), the Detailed Route Report will include a Restriction column 
(shown below).  Any restricted road segments on the route will be labeled with 
the appropriate hazmat restriction type in this column.  (PC*MILER uses these 
route segments in its calculations only if no other alternative is possible, or the 
alternative is extremely impractical.)  Routes designated as preferred for 
hazardous materials will not be indicated in the report. 
 

 

 
 

Detailed Route Report Showing HazMat Restriction Column 
(PC*MILER|HazMat installation required) 

 

8.3  State/Country Report 

 

 
 

State/Country Report (Print Preview) 
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After running a route, you can select the Routes tab > Route group > Reports > 
State/Country or press the F6 key to display a table summarizing mileage by state, 
province, or country traveled.  
 
The State/Country Report lists leg and total distances and cost and time estimates 
in columns from left to right.  The last two columns show leg and cumulative 
greenhouse gas estimates in pounds or kilograms of carbon dioxide equivalent per 
gallon/liter of fuel.  (Values that affect cost, time, toll and greenhouse gas 
estimates are set in the Route Options dialog box.)  At the bottom of this report, 
distances are broken down into toll/free, empty/loaded, and ferry mileage by 
state/country.   
 
If PC*MILER|Tolls is installed and toll calculation is turned on in the Route 
Options dialog box, a Total Tolls column to the left of the greenhouse gas 
columns will list cumulative toll costs for each leg of the trip.  The summary at 
the bottom of the report will include a breakdown of toll costs by state/country. 
 
A breakdown of toll costs by the type of discount program applied is also 
available.  Select the File application menu > Application Settings and check 
Show Toll Discount Info in the Application Setttings dialog, then click Save.  This 
can be done before or after the State/Country Report is generated.  You will see 
the discount breakdown in the Toll($) column in the State/Country summary 
section. 
 

 
8.3.1  Order of States in the State/Country Report 

 
In the State/Country Report, states and countries are displayed in alphabetical 
order by default.  To display them in the order in which the route travels through 
them, select the Routes tab > Route group > Options (or to change the default 
setting, General group > Defaults) and choose Route Order under State/Country 
Report Order.  States/countries will now appear on the report as they would in a 
driver log. 
 

8.4  Driver’s Report (Driving Instructions)    

Select the Routes tab > Route group > Reports > Driver’s to generate easy-to-read 
detailed driving instructions, including break times, turn direction and distance 
between turns.  This report includes all alerts that appear in the Detailed Route 
Report. 
 
If the route was run using real-time traffic data and the departure time for the trip 
is within 15 minutes of the current time, the Delay column just to the right of the 
Time column identifies delays caused by the current traffic conditions on the first 
15 miles of the trip.  
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Driver’s Report (Print Preview) 
 

8.5  Road Type Report 

Select the Routes tab > Route group > Reports > Road Type to generate a distance 
breakdown by PC*MILER road category for the active trip.  See section 9.7.1, 
Average Road Speeds, for detailed descriptions of these road types. 

 
 

 
 

Road Type Report (Print Preview)  
 
 

8.6  Comparison Report 

If two or more routes have been generated and are open, a Comparison Report is 
available that lists the total mileage, cost and time estimates for all open routes. 
To create this report, select the Routes tab > Utilities group > Comparison Report 
or press F4 on your keyboard.   
 
Columns from left to right show trip totals for miles, estimated cost, estimated 
hours, toll costs (if PC*MILER|Tolls is installed and toll calculation is turned on), 
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estimated fuel cost, estimated cost of labor, estimated miscellaneous costs, and 
estimated greenhouse gas emission (these last four columns are not shown in the 
resized report window below).  Values that affect cost, time, toll and greenhouse 
gas estimates are set in the Route Options dialog box. 
 
 

 

Comparison Report, Practical vs. Shortest Routing (Print Preview) 
 
 
NOTE:  The Comparison Report lists only the origin and destination of each 
route.  If there are stop-off points in one route and no stop-offs in another, the 
mileage discrepancy between these routes could be large.  Be sure to check 
intermediate stops in the route window if you see differences in mileage that are 
larger than expected. 

 

8.7  Font Size and Page Layout 

To see a preview of how the report will look when it is printed, check Show Print 
Preview in the upper left corner of the report.  The Print Preview view will be 
displayed along with a toolbar for editing the page layout and font size.  Place 
your cursor over any button on the tool bar to see a tooltip that briefly describes 
what that button is for. 
 
To change the font size in the active report, use the Font Size drop-down on the 
toolbar.  For adjustments to the page layout, there are six buttons that control 
formatting (portrait vs. landscape) and magnification. 
 

 
 
To hide columns or change their position or width, right click on any column 
header in a report and click on “Column Chooser…”.  See section 3.9.2 on how 
to use the Column Chooser.   

 

 

Right Clicking a Column Header in a Report 
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8.8  Printing Reports 

All PC*MILER reports can be printed.  To print a report, first check Show Print 
Preview in the upper left corner.   
 
 
 
A toolbar for editing will display and you’ll be able to see what the printed copy 
will look like.  To print, do one of the following: 
 
1.  Click the Print button (upper right corner);   

2.  Click the Print icon on the toolbar; or 

3. Press Ctrl+P.   
 
To directly print a report without first generating it in its own window, select the 
File application menu > Print Report > and choose a report type.        

 

8.9  Saving and Copying Reports 
 

PC*MILER reports can be saved to disk – choose Save Report to File from the 
File application menu.  In the Save Report dialog box, select the folder where the 
file will be saved and enter a file name in the File Name field.  Click OK to save.  
  
In addition, PC*MILER reports can be copied to the clipboard for use with other 
Windows® programs such as Microsoft® Word.  To copy and paste a report: 
 

1. Select the report in the Reports window. 

2. Check Show Print Preview in the upper left corner. 

3. In the toolbar that displays, click the Copy icon.   
 

4. In the application you are copying to, press Ctrl+V to paste. 
 
NOTE:  With some reports you may get better results if you save the report as a 
.CSV (comma separated value) file and then import that file into your target 
application.  This may be especially true for the Detailed Route report with its 
many columns.  To save the active report, select the File application menu > Save 
Report to File and select “.csv” as the file type. 
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Using the 
Route Options Dialog Box 

 
 

The Route Options dialog box enables you to change the options and parameters 
used to calculate a route.  There are three ways to open the Route Options dialog: 
 

 Select the Routes tab > Route group > Options; 
 Press Alt+F3; or 
 Click the gear button (     ) in a route window and choose Options. 

 
When you edit routing options in this dialog, only the currently active route 
window will use the new parameters.  If you open a new route window, it will use 
the PC*MILER default options.  To edit the defaults, see section 9.8.  Note that if 
you save a route, the options that were active for that route will be saved along 
with it. 
 
PC*MILER chooses routes by minimizing a cost equation that combines distance, 
certain factors times distance, and certain fixed factors.  A PC*MILER user can 
choose between different versions of the equation and numerical values by 
choosing among different routing options.  Options in the General, Vehicle 
Dimensions, and Hazmat* tabs affect which route is chosen.  The Cost/Time, 
Road Speeds, and Tolls* route options affect time/cost and toll data that is 
returned when a route is generated, but do not affect which route is chosen. 
* The Hazmat and Tolls tabs are available only if the related data modules have been purchased.  
 

 

 

Route Options Dialog Box 
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9.1 Route Name 

The Route Name field at the top of the Route Options dialog can be used to 
assign a name to your route that will appear at the top of the route window, in the 
title bar of report windows, and in the Route legend in the map window.   
 

9.2  Route Profile 

The Route Profile drop-down list at the top of the Route Options dialog makes it 
possible to set, save and edit options for a specific vehicle profile. Each time that 
profile is selected in a route window, the options associated with it will 
automatically be in effect.  This field may be left blank.   
 
Select a Vehicle Profile to use from the drop-down pick list.  Each profile 
includes a vehicle’s weight, dimensions, number of axles, and cost/time settings. 
See sections 9.6 and 9.8 on custom vehicle dimensions, default settings, and 
creating custom vehicle profiles. 
 

9.3 General Options 

 

 
 

Route Options Dialog Box, General Tab 
 

 
9.3.1  Region 

 
North America is the only region that is available with PC*MILER.  If 
PC*MILER|Worldwide or DTOD data is installed, other regions can be selected: 
click the down arrow and select a region from the pick list.  Available worldwide 



 

 
 Chapter 9:  Using the Route Options Dialog Box 125 

regions are: Africa, Asia, Europe, Middle East, Oceania and South America.  
The active region is displayed at the top of each new route window. 
 
To change the default region from North America to another region, see section 
9.8 on creating default options. 
 
 

9.3.2  Route Type 
 

NOTE:  Changing the route type may affect the time and cost estimates that are 
calculated for any given route.  See the explanation of how route type affects 
routing at the beginning of Chapter 9.     
 
In the drop-down Route Type list you will see the three basic route types that 
PC*MILER can generate: Practical, Shortest, and Fastest.  Fastest routing is 
available only if  PC*MILER|Traffic is installed and activated.  See sections 1.6.1 
– 1.6.3 for full descriptions of these route types.  

In addition to selecting a basic route type, check any of the routing options to the 
right that you wish to apply to route calculations: 

Use Ferry Distances:  Includes ferry distances in mileage and cost calculations.  
When turned off, the ferry portion of a route will not contribute to the mileage and 
cost.  The setting does not affect the actual route on the map and travel time is not 
affected.  Note that the “Total” column of the State/Country report always 
includes ferry distances, even if this option is turned off here.  

Toll Discouraged:  Avoids long stretches of toll roads without taking long or 
impractical detours to avoid toll bridges and tunnels.  See section 1.6.6 for the full 
description. 

National Network:  (U.S. only)  Based on the National Network, a U.S. 
government-designated system of highways originally established by the Surface 
Transportation Assistance Act of 1982 (STAA).  This option will calculate routes 
that stay on the National Network to the maximum extent possible.  Given that 
many areas are not directly served by the National Network, the origin and stop-
offs on a route may not be on the Network.  See section 1.6.4. 

53' Trailer or Twins:  (U.S. only)  This option is only available if National 
Network is checked.  Its calculations are based on National Network routing, with 
the addition of roads that permit 53’/102” trailers or twins.  See section 1.6.5 for 
the full description. 

Hub Routing:  Check this option to generate mileage from one origin to a 
virtually unlimited number of destinations.  See section 9.3.3. 

Borders Open:  If Borders Open is checked, PC*MILER will ignore international 
boundaries in generating the best route.  If this option is not checked, the number 
of border crossings will be minimized; for example, if all your stops are in the 
“lower 48” United States, the resulting route will stay in the United States even 
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though the most practical or shortest route would normally involve some 
Canadian mileage.  “Open” or "Closed" will appear in the title of each route 
window, indicating which option is selected. 

Use Custom Roads: If checked, the route you run will take into account the road, 
state, and override preferences found in the Avoid/Favor and States/Roads 
Managers.  "Custom" will appear in the title of the route window when this 
options is active.  See sections 11.1-11.3.   This box must be checked for user-
designated road preferences to be active when running routes. 

Use Highway Only: (Only available with PC*MILER|Streets in North America 
and is turned on by default.)  When checked, routes are calculated using an air 
distance from the midpoint of the truck-usable highway segment that is nearest to 
the destination postal code or city/state.  Routes to stops that include a street-level 
address are calculated to the truck-usable highway-level road that is closest to the 
entered address.  This functionality matches the base PC*MILER highway 
product.  If this option is not checked, PC*MILER calculates the route and 
driving distance using local streets between the nearest truck-usable highway 
segment and the stop. All stops, whether they contain a street-level address or not, 
clean up via the shortest air distance to the nearest road (highway or street level).  
This distance may appear as “Local” in the Detailed Route report. 
 

Override Restrictions:  Check “Override Restrictions” to generate routes that 
waive truck restrictions pertaining to specific sizes and weights, but that continue 
to avoid truck-prohibited and truck-discouraged roads.  When this option is 
active, all height, length, width and weight restrictions will be overridden.  If a 
route uses roads that have any of these types of restrictions, the Detailed Route 
Report will list them.  This allows you to determine the largest or heaviest vehicle 
you can assign to drive that route. 

By default the Override Restrictions option is not checked, in which case 
PC*MILER routing will avoid truck-prohibited and truck-discouraged roads, as 
well as truck-restricted roads that pertain to the size and weight set in the current 
vehicle dimensions or profile. 

Below is a table showing the North American states/provinces that have a 
jurisdiction-wide weight limit, with exceptions listed. 
 

State/ 
Province 

Weight 
Limit* 

Exceptions Ref.

SK 76,038 lb 
(34,500 kg) 

- 87,058 lbs (39,500 kg) on designated primary highways year-round and other 
designated primary highways for 9 months/year, and a maximum distance of 15 
kilometers on any secondary provincial [not including municipal] highway or 
provincial road 
- 91,466 lbs (41,500 kg) on most roads in winter, i.e. Nov16-Mar14 (except for 
certain restricted exceptions) 
- special restrictions on certain listed highways

(1)
(2) 

MB 76,038 lb 
(34,500 kg) 

- 82,650 lbs (37,500 kg) on designated “A1” highways
- 87,058 lbs (39,500 kg) on designated “RTAC” highways 
- Winter weights higher in some cases

(3)
(4) 
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- “If a delivery needs to be made off of a designated truck route the vehicle is 
allowed to stray from the truck route via the shortest distance to its destination.  
Once the delivery has been completed the vehicle must return to the truck 
route the same way”

*  For the PC*MILER default vehicle configuration:  5-axle tractor/48’ long semitrailer 
combination.  Higher limits > 80,000 lbs apply in SK & MB for 6+ axles. 

Ref: 
1. http://www.highways.gov.sk.ca/trucking/ 
2. Saskatchewan Vehicle Weight and Dimension Regulations, 1999, page 17, Sec 12(1)(KK) 
3. http://www.gov.mb.ca/mit/mcd/mcpd/pdf/normalloading.pdf & http://www.gov.mb.ca/mit/mcd/mcpd/twlm.html 
4. Email from Dwight Solon, Director, Motor Carrier Enforcement Programs, Province of Manitoba, 11/03/08 

 
NOTE for PC*MILER|Streets Users: An error message will appear if you 
attempt to enter an address that is on a truck-prohibited road. 

SAFETY NOTE:  For winter roads in Manitoba and North West Territories, 
Canada, road safety information for heavy vehicles using these roads can be 
found at: http://www.gov.mb.ca/ 
 
The default route type settings are: 

 For North America:  Practical, Borders Open, Highway Only, Use Ferry 
Distances, Discount Tolls – USD*    
* PC*MILER|Tolls must be installed  

 For All Other Regions: Practical, Borders Open, Highway Only, Use Ferry   

 
 

9.3.3  Hub Routing 
 
PC*MILER enables you to generate mileage from one origin defined as the 
"Hub" to an unlimited number of destinations in the same route window.  To 
generate a route in Hub mode, check Hub Routing in the Route Options dialog 
box and click Save to save this setting.  All subsequent routes run in the current 
route window will be in Hub mode unless this setting is changed.  The Detailed 
Route Report and State/Country Report are both available for hub routing.   

 

 

Hub Routing with New York, NY 10001 as the Hub 
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9.3.4  Distance In and Fuel In 
 
You can choose to have PC*MILER report distances in either miles or kilometers, 
and fuel quantities in either gallons or liters.  Both options affect trip costs, 
average road speeds, and the distances shown on reports and in route windows 
when you generate a route.   
 
Under Distance in select Miles or Kilometers.  Under Fuel in select Gallons or 
Liters. The default settings for all world regions are Miles and Gallons. 
 

 
9.3.5  State/Country Report Order 

 
Choose whether State/Country reports will have states/countries listed in 
Alphabetical order by state/country, or in the Route order (as in a driver log).  
The default setting is alphabetical. 
  

  
9.3.6  Report Memo (Customized Reports) 

 
The Report Memo field allows you to create custom report headers.  The text 
you type in this field will appear at the top of all printed reports (check Show 
Print Preview in the Reports window to see how the header looks).  By default 
the Report Memo field is left blank. 
 

9.4  Cost/Time Options – Trip Costs 

 

 
 

Route Options Dialog Box, Cost/Time Tab 
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PC*MILER calculates a total cost for each route generated.  This cost estimate is 
determined by multiplying a dollar amount per mile by the number of miles.   
 
Cost parameters can be edited for empty and loaded miles to better reflect your 
actual costs, or you may choose to use the PC*MILER default values.   

 
In the Cost/Time tab of the Route Options dialog box, the trip costs that go into 
the dollar amount per mile have been broken out into fuel costs, labor costs, and 
“other” maintenance or miscellaneous costs.  (Note that stop costs have their own 
separate “Stops” tab.)  For information purposes only, a greenhouse gas emissions 
value is also included.  You will see these values reflected in the columns of the 
Comparison report.  The greenhouse gas estimate also appears in the State 
Distance Summary report.   
 
 

9.4.1  Fuel Costs 
 
The fuel cost parameters that can be edited are Fuel Cost Per Gallon and Miles 
Per Gallon.   
 
NOTE:  If the measure of distance is set to Kilometers and/or the unit of 
measure for fuel is set to Liters in the General tab, the units in the Cost/Time tab 
will change accordingly. 
 
Fuel Cost Per Gallon/Liter:  All world regions have the same default value for 
fuel cost, depending on the unit of measure (see note above), as follows: 
 
 Per Gallon = $3.95  Per Liter = $1.04 

 
NOTE:  The default Fuel Cost Per Gallon/Liter is based on an ALK study of 
Least Cost routing (the “average” data were default values for drivers paid by the 
hour), along with values from a recent American Transportation Research 
Institute (ATRI) study (An Analysis of the Operational Costs of Trucking), the 
U.S. Energy Administration, and typical miles per gallon for an 18-wheeler. 
 
Miles/Kilometers Per Gallon/Liter: Default values for all world regions are:  
 
 Miles/Gallon = 6.48  Miles/Liter = 1.71 

 Kilometers/Gallon = 10.43  Kilometers/Liter = 2.75 
 
Fuel Cost Per Mile/Kilometer:  These fields are grayed out because they are 
reference fields only. Values in these fields are based on the Fuel Cost Per Gallon 
and MPG, and are used only to calculate the fuel cost total that appears in the 
Comparison Report (this report is automatically created when Least Cost routing 
is generated, or it may be run whenever two or more generated routes are active). 
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9.4.2  Labor and Other Costs 
 
Enter your own Other Cost Per Mile and Labor Cost Per Mile values, or use 
the default values.  Labor and Other cost totals for a route appear only in the 
Comparison Report (this report is automatically created when Least Cost routing 
is generated, or may be run whenever two or more routes have been generated). 
 
The default values for these settings* in all world regions are: 

 
 Other Cost Per Mile (loaded or empty) = $0.18 

 Other Cost Per Kilometer (loaded or empty) = $.11  

 Labor Cost Per Hour (loaded or empty) = $31.64 
 
* These default values are based on an ALK study of Least Cost routing (the 

“average” data were default values for drivers paid by the hour), along with 
values from a recent American Transportation Research Institute (ATRI) study 
(An Analysis of the Operational Costs of Trucking), the U.S. Energy 
Administration, and typical miles per gallon for an 18-wheeler. 

 
 

9.4.3  Greenhouse Gases Emission Estimate 
 
Enter the pounds per gallon (or liter) emissions as CO2 equivalent in the 
Greenhouse Gases field, or use the default values.  Leg and total greenhouse gas 
(GHG) emission estimates appear in the State/Country Report, and a total GHG 
estimate appears in the Comparison Report (this report is automatically created 
when Least Cost routing is generated, or may be run whenever two or more routes 
have been generated). 

 
The default Greenhouse Gases settings for all world regions* are as follows: 
 

 If Gallons are selected in the Fuel In field: 22.20 lbs. 

 If Liters are selected in the Fuel In field: 5.86 lbs. 
 

*  These default settings are based on values for North America that were provided 
by the U.S. Environmental Protection Agency (EPA).  See 
http://www.epa.gov/otaq/climate for more information. 

 
 

9.4.4  Border Wait, Break and Hours of Service (HOS) Hours 
 
Additional time that affects time estimates for a route can be added as described 
below.  Note that times less than one hour can be entered using decimals (e.g. “.5” 
for 30 minutes). 
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Border Wait:  Enter any expected delay due to border crossing.  The number of 
hours you enter will affect time estimates for any trip that includes at least one 
international border crossing, and will be included in the Detailed Route Report.  
The default border wait time is 0 hours. 
 
Break Every and Break Length:  Enter the number of on-duty hours allowed 
between breaks and how many hours each break should be.  The number of hours 
you enter will determine where breaks are indicated along the route in the 
Detailed Route Report.  Calculations of break times take into account whether 
time spent at each stop is on-duty (determined in the Stops tab).  The default for 
these fields is 0 hours. 

 
Remaining Hours of Service:  (U.S. only)  Enter the remaining Hours of Service 
(HOS) for the driver on this trip.  Based on this input, PC*MILER will calculate 
when the driver needs to take a break and this will be noted in the Detailed Route 
Report.  The HOS text box will be enabled/disabled in real time as the break time 
and break wait time boxes are modified.  The HOS entered cannot be larger than 
the “Break Every” number of hours. 
 
By default, these time fields are left blank. 
 
 

9.4.5  Arrival/Departure Time 
 
A target arrival or departure date/day of the week and local stop time can be set 
here for the trip.  This setting can also be created in each individual route window 
using the provided drop-down.  If an arrival/departure time is set, PC*MILER 
will return the estimated time of arrival/departure (ETA/ETD) at each stop on the 
route along with cost and time information when the route is generated.  Use the 
Arrival/Departure fields as follows: 

 
1. Select either Depart by or Arrive by.  Depending on your choice, 

PC*MILER will calculate time estimates at each stop based on either a 
departure time at the origin of the trip or an arrival time at the trip’s final 
destination. 

2. Select either a Specific Date or Day of the Week as the target day for 
departure or arrival.  For a specific date, you can either type in a date in the 
format MM/DD/YYYY (zeros are not necessary for single-digit months and 
days), or click the calendar icon to choose a day from the calendar.  For a day 
of the week, select a day from the drop-down list. 

3. Enter the targeted local time at the trip’s origin (if entering a departure time) 
or destination (if entering an arrival time). 

4. Click Save to save your settings. 
 
See Chapter 5, Time-Based Routing, for more information. 
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9.5  Stop Costs   

 

 
Route Options Dialog Box, Stops Tab  

 
 
The Stop Costs fields in the Stops tab will only be displayed after one or more 
stops have been entered in the currently active route window. 
 
The Stop Costs fields enable you to assign a customized time and cost estimate 
for each individual stop on the route.  In the Stops tab you can also indicate 
whether the stop time you entered is on-duty or off-duty, whether to include the 
time and cost estimate for the origin in the totals for the route, and whether the leg 
between stops is a loaded move or a backhaul. 
 
Combined with other trip costs entered for loaded and empty miles, the Stop 
Costs fields determine the total time and cost estimates for the trip.  (This estimate 
appears on reports and in the route window when you run the route.)   
 
For example, if your route includes eight stops and you assign a 1-hour on-duty 
stop-off time estimate to each one, the total time estimate for the trip (driving time 
plus delay time at each stop) will reflect an increase of eight hours along with the 
associated costs.   
 
For each listed stop, you can adjust one or more of the following parameters: 
 
Loaded:  Check this option if the leg preceding the stop should be considered as 
loaded. 
 
Cost per Stop:  Enter a total cost for this stop. 
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On-Duty:  Check this option if time spent at this stop should be considered as on-
duty.  Note that if a break time is entered in the Cost/Time tab, the points at which 
breaks are indicated in the Detailed Route Report will be affected by whether the 
hours per stop (below) are on-duty for each stop. 
 
Hours per Stop:  Enter the estimated time that will be spent at this stop.      
 
Use Origin Cost and Hours For All Stops:  To include the origin stop time and 
cost in totals for the route, check this option before closing the dialog box. 

 
The default Stop Costs settings for all regions are: 
  

 Cost/Stop:  0.0000 
 Loaded:  checked 
 Hours/Stop:  0.00 
 On Duty:  checked 
 Use Origin Cost and Hours:  checked 

 

9.6  Vehicle Dimensions   

 

 
Route Options Dialog Box, Vehicle Dimensions Tab 

  
 

9.6.1  Overview  
 
The vehicle dimension options enable you to generate routes based on custom 
vehicle dimensions.  Building on the foundation of PC*MILER’s previously 
existing routing database and routing options, users can generate routing that 
conforms to the requirements of a vehicle’s height, length, width and weight. 
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If a vehicle weight and/or height is entered, PC*MILER route calculations will 
take into account restrictions on roads and bridges to ensure that the vehicle’s 
weight/height is below the restriction(s).  Vehicle weight, length and width 
information is checked against the threshold at which a truck becomes 
“oversized” and appropriate routing is generated. 
 
Additionally, PC*MILER supports calculation of routes and toll costs for smaller 
vehicles (vans, pickup trucks, SUVs, automobiles, etc. that are classed less than 
9,000 lbs./4,082 kgs.) with a “Full-size van” profile option or your own custom 
vehicle profile that includes dimensions that meet the required criteria.  
 
 

9.6.2  Vehicle Dimensions, Profiles and Types 
 

Below is a description of how PC*MILER vehicle types, profiles and dimensions 
are related. 
 
The Vehicle Type indicates how PC*MILER will route the vehicle.  You will see 
the vehicle type displayed in the upper right corner of the Vehicle Dimensions 
tab.  The vehicle type is determined by the vehicle dimensions entered, either 
manually or by choosing a Vehicle Profile.  In other words, the vehicle type will 
update automatically when dimensions are changed.  It is informational only and 
cannot be edited by the user.  Possible categories are Auto, Truck (Medium-
Duty), or Truck (Heavy). 

 
   

A Vehicle Profile (full-size van, 48 ft semitrailer, etc.) is a template containing a 
particular combination of vehicle dimensions that can be conveniently reapplied 
as needed.  A selection of vehicle profiles are shipped with the software and 
appear in the Vehicle Profile pick list out of the box.  Vehicle profiles can also be 
defined by end users (see section 11.2).  Custom vehicle profiles appear in the 
Vehicle Profile pick list after they are created and saved. 

 
 
Vehicle Dimensions (weight, length, height, width, axles, trailers) are specific 
values that will affect the selection or avoidance of road segments that restrict 
vehicles to below those dimensions.  These dimensions can trigger warning 
messages if a restriction is violated because an alternate road segment was either 
unavailable or too impractical.  Additionally, the number of axles is used in 
calculating tolls.  Vehicle dimensions determine the vehicle type (mentioned 
above) as shown in Table 1 below.  
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Table 1.  PC*MILER Rules for Inferring Vehicle Type from Vehicle Dimensions 

Dimension  Automobile 
if ALL values 
are less than  
or equal to 

Medium Truck  
if ALL values  
are less than or 
equal to 

Heavy truck 

All other 
values are 
regular 
heavy truck, 
unless… 

In USA, 
National 
Network and 
State Oversize 
if ANY values 
are greater 
than

In Canada* in 
SK and MB, 
State Oversize 
if greater than 

In Canada* in MB, 
National Network if 
greater than 

Weight 8,500 lbs. 26,000 lbs.     76,038 lbs. 
(34,500 kg.) 

82,650 lbs. 
(37,500 kg.)

Length 20 ft. 26 ft.   48 ft.    
Height 7 ft. 13 ft. 6 in.        
Width 96 in. 96 in.   96 in.    
Axles 2 (4 tires) 2 (6 tires)        
Trailers None None        

 
* The rules for Canada in the table above are for truck tractors with a single 5 or 6 
axle semi-trailer.  Customers who run heavy straight trucks (this would be 
unusual) or doubles (more common) in SK or MB are advised to consult the 
Weights and Dimensions Compliance Guides published by those provinces, and 
to select the PC*MILER National Network and/or 53 ̍Foot Trailer or Twins route 
type as appropriate. 
 
NOTE:  An alternative to entering vehicle dimensions manually is, where 
appropriate, to select the PC*MILER National Network and/or 53 Foot Trailer or 
Twins routing type. 
 
NOTE ALSO:  Beginning in Version 28, if the user enters a vehicle height over 
13 ft. 6 in., PC*MILER will avoid jurisdictions with lower overall limits in its 
calculations wherever possible and practical.  You will receive a warning message 
in the Detailed and Driver’s reports if any of these jurisdictions cannot be avoided 
on a route. 
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9.6.3  Setting Vehicle Dimensions  
 
NOTE:  Oversize permits will allow for “normal” truck routing if you have 
purchased the appropriate permits for your oversize vehicle for routing on 
assumed 80,000 lb./36,287 kg. roadways.  Nonetheless, if the route includes a 
road segment for which the truck as configured will require a permit, a red bar  
will appear to the left of the route segment in the route window and “Oversize 
Permit Required” will appear on the Detailed and Driver’s reports. 
 
Units:  Select English (feet, inches, and pounds) or Metric (meters and 
kilograms) as the unit of measure for the options in this tab.  The default is 
English in all regions 
 
Height:  The maximum vehicle height is 13 feet 6 inches, or 4.11 meters, and this 
is the default setting for all regions except Europe.  For Europe, it is 12 feet 5 
inches, or 3.78 meters.  The minimum height is > 0.  
 
Length:  The maximum trailer length is 53 feet or 16.15 meters, and this 
is the default setting for all regions except Europe.  For Europe, it is 39 
feet 4 inches, or 11.99 meters.  The minimum length is > 0.   
 
NOTE:  If the 53' Trailer or National Network routing option is selected in the 
General tab and a custom vehicle dimension is also entered in the Length field, 
both attributes are weighed in the overall calculation but the routing option takes 
precedence. 

 
Width:  For English units, select 96 or less, 102 or more, or 98.  For Metric units 
select 2.44 or less, 2.59 or more, or 2.48.  Note that entering the larger vehicle 
width category will use National Network routing in the U.S. and Canada except 
where necessary for local deliveries.  The default width setting for all regions is 
96 or less. 
  
Weight:  For all regions except Europe, weights up to 132,000 lbs. or 59,874 kg. 
may be entered, and minimum weight is 1000 lbs. or 454 kg.  In Europe, the range 
is 1500 – 156,748 lbs. or 680.39 – 71099.7 kg.  Weight less than 9000 lbs./4082 
kg. will generate routing appropriate for automobiles and small vans (see section 
9.6.5).  See section 9.6.1 above for more on vehicle weight.  The default weight 
setting for all regions is 80,000 lbs.  
 
Axles:  (For PC*MILER|Tolls users only)  The number of axles entered here is 
used only for the calculation of toll costs using the PC*MILER|Tolls add-on 
module.  If PC*MILER|Tolls is not installed, this option will be disabled.  See 
Chapter 7 for toll cost calculation information.  The default number of axles is 5. 
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9.6.4  Permit and Multiple Trailer Options 
 
Checking Permit assumes that you have entered a vehicle weight greater than 
80,000 lbs. or 36,387 kg. in the Weight field. If a weight greater than 80,000 
lbs/36,387 kg is entered in the Weight field, and you have not checked the 
“Permit” checkbox, the following message box will be displayed: “Trucks with 
the entered configuration require a permit in the following states:  Arizona, 
Connecticut, Illinois, Indiana, Kansas, Louisiana, Massachusetts, Michigan, 
Minnesota, North Carolina, New York, Oklahoma, Wisconsin.”  This field does 
not affect routing, it only serves as a reminder that a permit may be required for 
the vehicle dimensions entered.   
 
Multiple Trailer (MT):  Check if the vehicle is a long combination vehicle with 
multiple trailers. (See section 7.2 for toll calculation considerations.) 
 
By default, neither of the above options are checked. 
 
 

9.6.5  Vehicle Dimensions for Automobile Routing 
 
To generate a route that ignores all commercial truck restrictions (Truck 
Restricted, Truck Prohibited and Truck Discouraged), you can either 1) use the 
“Full-size van” vehicle profile (select it from the Vehicle Profile pick list in the 
Routes tab on the ribbon or in the General tab of the Route Options dialog box), 
or 2) enter your own vehicle dimensions that conform to the criteria for 
automobile routing in PC*MILER.  Those criteria are as follows (all criteria 
must be met): 

 2 axles; 
 less than or equal to 9,000 pounds/4,082 kilograms in weight; 
 less than or equal to 7 feet/2.133 meters in height; 
 less than or equal to 20 feet/6.096 meters in length; 
 less than or equal to 96 inches/2.438 meters in width. 

 
Automobile routing will relax all regulations that pertain to trucks, allowing the 
route to take advantage of parkways and other roads that larger and/or heavier 
and/or commercial vehicles are prohibited from using.  PC*MILER will also use 
toll rates that apply to 4-tire vehicles with 2-axles, which often differ from rates 
that apply to 6-tire 2-axle vehicles.  (PC*MILER|Tolls must be installed to access 
toll costs.) 
 
 

9.6.6  Custom Vehicle Profiles 
 
In addition to setting default route options, PC*MILER also lets users create 
custom vehicle profiles to enable quick entry of vehicle or fleet attribute sets that 
you use often when routing.  This time-saving feature enables you to set up and 
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save groups of vehicle dimension and cost/time settings for easy access in the 
future.  Using custom vehicle profiles ensures that the defined settings are 
consistent for the particular vehicle type selected for a route.   
 

To use custom vehicle profiles, select the Routes tab > Utilities group > Vehicle 
Profile.  In the Vehicle Profiles Manager dialog box that opens, you can select a 
profile to view, edit, or delete, or you can create a new custom profile.  For North 
America, sample profiles are provided in the pick list for full-size van, 26' straight 
truck, 28' double trailers, 40' straight truck, 48' semi-trailer, and 53' semi-trailer 
vehicles.  The sample profiles can be edited, but not deleted.   
 
To create a new custom profile, click New.  A dialog box will open that has two 
tabs – Cost/Time and Vehicle Dimensions.  The editable fields in these tabs are 
the same ones found in the Route Options dialog box.  Enter a profile name and 
the desired edits in each tab and click Save to save your changes. 
 

 
Vehicle Profiles Manager 

 
 

 
 

 
 

 
 

 
 

 
 
 
 
 
 
 
 Options for Vehicle Profile –  

Cost/Time Tab
Options for Vehicle Profile –  

Vehicle Dimensions Tab
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NOTE:  The “Full-size van” profile is intended for use with vans, pickup 
trucks, SUVs, automobiles, etc. that are classed less than 9,000 lbs./4,082 kgs. 
The automobile routing that is generated from this profile ignores all commercial 
truck restrictions, and if toll rates are calculated, will use toll rates that apply to 
small vehicles with 2-axles, which often differ from rates that apply to larger 2-
axle vehicles.  
 
NOTE For PC*MILER|Worldwide or DTOD Users:  When creating, 
accessing, or editing a custom vehicle profile, you must perform the additional 
step of specifying a region.  Each vehicle profile is applicable to only one region. 
 
An unlimited number of custom profiles can be defined.  The profiles you create 
will appear in the pick list of available profiles in the Route Options and Default 
Route Options dialog boxes, General tab.  
 
Once a profile is set up, it can be used globally (all new routes will use the 
selected profile in route calculations) or applied to each new route as appropriate:   
 
 To apply a profile to all new routes, choose the Routes tab > General group > 

Defaults.  At the top of the Default Route Options dialog box, select the 
desired profile from the drop-down Vehicle Profile pick list.  Click Save to 
save this profile as the default. 

 
 To apply a profile to a single route, choose the Routes tab > Route group > 

Options.  At the top of the Route Options dialog box, select the desired profile 
from the drop-down Vehicle Profile pick list.  Click Save when you are 
finished editing options for this route.  Repeat for each new route. 

 
By default, custom profiles are not used.  Sample vehicle profiles are provided in 
the Vehicle Profile pick list (Route Options and Default Route Options dialog 
boxes). 
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9.7  Road Speeds 

 

 
 

Route Options Dialog Box, Road Speeds Tab  
 
 

9.7.1  Average Road Speeds (Estimated Travel Time) 
 
PC*MILER calculates time estimates for each generated route.  These estimates 
are computed by summing up the estimated time traveled on each road segment 
on the route, plus an added stop-off time for each stop along the route if this was 
set in the Stops tab of the Route Options dialog box.  
 
There are fourteen road speed classes: seven road types, with “urban” and “rural” 
classifications for each.  Each class has an average road speed parameter assigned 
to it.  Spreading the estimated average speed over the various road classes gets a 
more accurate estimate of the total time traveled based on the quality of the road 
used.  See descriptions of road classes below.   
 
For PC*MILER default road speeds for jurisdictions in all world regions, see 
Appendix E.  
 
To customize road speeds, first select a jurisdiction from the State pick list, then 
enter your new road speed(s) by road class.  Click Save to save your changes, or 
Cancel to exit the Route Options dialog without saving changes.   
 
To apply your changes globally to all jurisdictions, click Update All Road 
Speeds.  These changes will affect time and cost estimates in route calculations. 
 
To restore all road speeds to the PC*MILER default settings, click Reset All to 
Default.  For a table of PC*MILER default road speeds, see Appendix E. 
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To use traffic data in time estimate calculations, click the Use Traffic Data 
button, then click Save to close the dialog box.  This same option is displayed as a 
pick list in each route window.  See section 5.2 on using traffic data.   
 
NOTE:  Custom road speeds cannot be entered and are not available when Use 
Traffic Data is active. 

 
                      

PC*MILER ROAD CLASSIFICATIONS 
 

Interstate Highways  The primary function of these roads is to move high volumes of vehicular 
traffic over medium to long distances at high speeds  

 Can be accessed only via access ramps  
 Always have a barrier or median between opposing lanes of traffic  
 Multi-lane 

Divided Highways  Major arteries that move heavy volumes of traffic at moderate speeds 
 Can be limited access in some areas but may also offer access from local 

roads 
 Usually have a barrier or median that prevents movement between lanes of 

opposing traffic 
 Medians may have crossovers that are part of the normal traffic pattern 
 Left turns are often restricted, both off of the highway and onto the highway 
 Usually multi-lane 
 Many but not all U.S. highways are in this class 

Primary Highways   Move significant volumes of traffic at moderate speeds 
 Most state roads fall into this class 

Secondary Roads  These roads move moderate volumes of traffic over short to moderate 
distances 

 Carry vehicles from local roads to higher class roads 

Ramp  A connecting road leading on or off of a main road or highway 

Local Roads  Function is to provide access to homes and properties 

Ferry  Ferry routes (boarding/exit time not included) 
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9.8  Creating Your Own Default Options 

To change the default values for the settings in the Route Options dialog box, 
select the Routes tab > General group > Defaults.  The Default Route Options 
dialog is identical to the Route Options dialog, but lets you set and save defaults 
rather than changing the settings only for the currently active route window.   
 
Enter your edits as you would in the Route Options dialog box (covered in 
sections 9.1 - 9.7).  Click Save to save your settings.  Every time you open a new 
route, the defaults that you set will be in effect.  Note that default options will not 
be applied to saved routes when you open them. 
 

 

Default Route Options Dialog Box 
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         Using the  
RouteMap™ Window 

 
 

The PC*MILER RouteMap window is like an electronic road atlas.  All routes 
generated by PC*MILER are automatically displayed on a map in the RouteMap 
window.  This enables you to examine routes in detail, visually evaluate routing 
alternatives, and perform a variety of "what-if" analyses.   
 
 

 
 

The RouteMap Window 
 

10.1  Routes on the Map 

To see a route on the map, first enter an origin, a destination, and any intermediate 
stop-off points in a route window and then click the Run button in the route 
window or press the F10 key on your keyboard.  PC*MILER will automatically 
create a graphic display of the route you just ran.   
 
Up to eight routes can be displayed simultaneously, with each route drawn in a 
different color to differentiate them.  The Route Legend on the map and a color 
bar in the route window show the color used for each route (see section 10.6 on 
legends). 
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To maximize the size of the RouteMap so that it fills the whole PC*MILER 
application window, close the Routes and Reports panes.  To toggle the map 
window between hide and display, select the Window tab > Windows group > 
Map Window.  To restore the default layout, in the same tab select Layouts > 
Default Layout. 

 

10.2  Frame Options 

To frame a region on the map, select the Map tab > View group > Frame > 
Regions and choose a region from the drop-down menu.   
 
PC*MILER|Worldwide and DTOD users can frame an area within one of the 
worldwide regions: select the Map tab > View group > Frame > Frame Areas > 
and choose an area from the drop-down menu.  Available areas to frame will 
depend on the region selected in the Route Options dialog. 
 
To frame the active route on the map, do one of the following: 

 select the Routes tab > Route group > Frame; or 

 select the Map tab > View group > Frame > Frame One Route >; or  
> Auto Frame Routes to automatically frame each route that is generated. 

 
To frame all currently open routes, select the Map tab > View group > Frame > 
All Routes. 
 
There are several ways to frame a stop, see section 10.3, Zoom Options, below. 

 
 

 

Framed Routes on the RouteMap 
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10.3  Zoom Options 

The RouteMap window features 18 possible zoom levels.  You will see the 
current zoom level in the window’s title bar (e.g. “Zoom Level 14 of 18”).  There 
are several ways to zoom your view of the RouteMap in and out, described below.   
 
To zoom into a specific area, select the Map tab > View group > Box Zoom (this 
option is turned on by default).  Then just place your cursor on the map, press and 
hold the left mouse button, and drag a box around the area.  Repeat as necessary.  
 
To zoom directly to a stop you have entered in the route window, highlight it 
on the stop list, then do one of the following:  

 double-click the highlighted stop; 

 right-click the stop name and select Zoom to Stop from the menu; 

 select the Routes tab > Route group > Frame Stop on Map; 

 or choose Zoom to Stop from the right mouse menu off the RouteMap. 

Other ways to zoom your view of the map are:  

 simply double-click a point on the map; 

 use your mouse’s scroll wheel: rotate the mouse wheel up to zoom in and 
down to zoom out; 

 choose Zoom In or Zoom Out from the right mouse menu off the 
RouteMap; 

 or use the slider bar and compass in the upper left corner of the map as 
follows: either 1) click, hold and drag the zoom control to move up (zoom 
in) or down (zoom out); or 2) click the plus sign or minus sign to move up 
or down one zoom level.  To pan north, south, east or west as needed, 
click the directional arrows on the compass.  The current zoom level is 
displayed in the title bar of the RouteMap window. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Zoom Control

Compass 

Zoom Out 

Zoom In
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10.4  Drag Map or Pan To Shift the View 

There are several ways to pan your view of the map in any direction. 
 
Drag the Map: 

Select Drag Map in the right mouse menu off the RouteMap or click the Map tab 
> View group > Drag Map.  With your cursor (now in the shape of a hand) in the 
RouteMap window, press the left mouse button down and hold, then drag in the 
desired direction.  The map will redraw the new view. 
 

To turn this feature off, click Drag Map again. 
 
Pan: 

One way to pan the map is: select Pan in the right mouse menu off the RouteMap, 
then select any direction from the sub-menu.  You will see the map view shift in 
the chosen direction.  Other ways to pan are using the scroll bar (see section 10.5 
below) or the compass (see section 10.3). 

 

10.5  Scroll Bars in the Map Window 

The PC*MILER RouteMap window includes scroll bars that are hidden from 
view until activated.  To activate, touch any edge of the map window with your 
cursor and a translucent scroll bar will appear.  Click on this scroll bar to move 
the map incrementally in the direction indicated by the arrow, or click and hold to 
pan your view. 
   

 
 
 
 
        

 

Scroll Bar for Map Panning 

 

Scroll Bar with 
directional arrow 
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10.6  Legends  

Legends on the map can be hidden or shown – select the Map tab > Customize 
group > Legends.  Legends that are checked in the menu will be displayed.   
 
Any legend can be moved to a different position – simply click on it, hold down 
the left mouse button, and drag it to the desired location.  Available legends are: 
 
 Road Legend: Shows how PC*MILER road classes appear on the map; 

appears whenever roads are displayed.   This legend is normally displayed, 
unless it is turned off in the Map Features dialog box.  Road colors will 
depend on which map style is chosen. 

 
 
Road types that are included in each classification in the Road Legend are: 

 
Interstate Multi-lane toll free and urban highways 

Divided Divided highways, urban access roads 

Primary Non-divided highways 

Ferry Ferries 

Secondary Non-divided highways, urban access roads, ferries 

Ramp Ramps 

Local Truck-discouraged roads (as defined by PC*MILER) 

Toll Toll roads and urban highways 

Discouraged* Not compatible for trucks, as determined by PC*MILER 

Restricted* Most kinds of truck prohibited, as determined by the 
controlling governmental authority – appears in the 
Road Legend only if “Truck Restrictions” is checked in 
the Map Features dialog box.   * For more on truck-
discouraged vs. truck-restricted roads, see sections 1.6.7 and 11.1.2. 

Designated Designated 53' road network (these roads have either 
“State Oversized”, “Oversized Access”, or “National 
Network” designations on them) – appears in the Road 
Legend only if “Designated Truck Routes” is checked in 
Map Features. 
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 Route Legend:  Appears if at least one route window is open; provides a key 
to the color(s) used to draw each generated route on the map.  Routes are 
listed in the order they were generated. 

 
 

 Scale Bar:  A standard component of most maps, providing the scale of 
miles/kilometers.  To change from miles to kilometers, use the Default Route 
Options dialog box – see section 9.8. 

 
 

 HazMat Legend:  If the PC*MILER|HazMat add-on data module was 
installed, a legend showing hazmat restrictions will be available. 

 
 

 Traffic Legend:  For PC*MILER|Traffic subscribers only, this legend 
appears if the traffic option in the route window is turned on and shows the 
significance of the colors used for traffic flows on the map, along with update 
times (for real-time data) or day/time information (for historic data). 
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10.7  Hiding, Displaying and Layering Map Features 

You can control what features are displayed and in what order features are drawn 
using the Map Features dialog box.  Select the Map tab > Customize group > Map 
Features, or choose Features... from the right mouse menu off the RouteMap to 
bring up this dialog. 
 
 

 
 

Map Features Dialog Box 
 
 
All the features listed in this dialog box can be displayed or hidden.  Checked 
features will be displayed – click any check box to toggle between hiding and 
displaying an individual feature.  Click Show All or Hide All to check or uncheck 
all listed features.  Click on the Reset button to return to the default settings. 
 
Additionally, the Up, Down, To Top, and To Bottom buttons can be used to 
manipulate the order in which the features on the left are drawn.  Placing 
“Routes” at the top of the list, for example, will draw routes on top of all other 
features on the map, causing them to stand out more.  The order of features in the 
list on the right cannot be changed, but these features can be shown or hidden.   
 
Click OK to close the Map Features dialog box and redraw the map. 
 
TIPS:  Truck Restrictions: Note that by default “Truck Restrictions” is turned 
off in the map display.  If you want to see all truck-restricted roads highlighted on 
the map, check this feature.  Then refer to the Road Legend to see the color of the 
highlight that is used in the active map style for these roads. 
 

Points of Interest: If your map is too cluttered with points of interest, uncheck 
“POIs” to hide them. 
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  10.8  Map Styles 

PC*MILER gives users the option to choose one of eight map styles for the 
RouteMap window.  Each style features a different color scheme and overall 
appearance.  Available styles are Classic, Contemporary, Default, Lightness, 
Black and White, Night, Road Atlas, Satellite, and Smooth.  
 
To change the map style, select the Map tab > Customize group > Map Style > 
and click on one of the listed styles. 

 

10.9  Satellite Image Layer on the Map (North America only) 

To have a photographic satellite image superimposed onto the PC*MILER map in 
the RouteMap window, select the Map tab > Customize group > Map Style > 
Satellite. 
 
To see the satellite images, the map must be zoomed in to at least Zoom Level 10.  
(The zoom level is displayed in the title bar of the RouteMap window – use the 
slider bar on the map to zoom in or out.)   
 
If the zoom level is not sufficient, a message will be displayed in the left bottom 
corner of the map stating that this is the case.  Satellite maps require Internet 
connectivity, and a similar message will be displayed if there is no Internet 
connection detected. 
 
 

 
Portion of Chicago, IL on the RouteMap with Satellite Image Superimposed 
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10.10  Route Distance Tooltips 

Select the Map tab > Customize group > Tooltips > Route Distance to have a 
tooltip appear when you place your cursor over a generated route on the map.  The 
tooltip will show the distance between the selected point and the route’s origin, and 
between the selected point and the route’s final destination. 
 

10.11  Right Mouse Map Menu 

A right mouse menu off the RouteMap is available to give you quicker access to 
frequently-used map options.  To use it, place your cursor in the map window and 
click the right mouse button, then highlight the option you want.   

 

10.12  Stop Labels 

You can indicate how you want the names of your stops to appear on the map.  
Select Map tab > Customize group > Stop Labels.  The choices in the drop-down 
are: 

 No Label labels stops with their names alone. 

 Name Only labels stops with the city or location name alone. 

 Number Only labels stops with their order in the trip.  The origin of the route 
is labeled “O”. The final stop is labeled “D” (destination).  The intermediate 
stops are labeled in the format “S#”, for example, Stop 1 is labeled “S1”. 

 Name and Number labels stops with both their name and order in the trip.  
For example, O: Miami, FL 33101 or 1: Princeton, NJ 08540. 

 

10.13  Using the Mouse To Pick Stops   

PC*MILER gives you the ability to enter stops in the route window directly from 
the RouteMap window without typing.  You can use the mouse to select any point 
on a highway, labeled city, unlabeled location, intersection, truck stop, or 
latitude/longitude point.  See section 3.6.21 for a description of this feature.   

 
NOTE:  There are some highway junctions which are truck-inaccessible.  These 
junctions won’t be recognized if you try to enter them as stops. 
 
TIP:  Notice that as you pass your cursor over the map without pressing the 
mouse button, its latitude/longitude position is automatically tracked and appears 
in the status bar in the lower left corner of the program window. 
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10.14  Infogroup Points of Interest on the Map (U.S. only) 

PC*MILER now offers as a standard feature the ability to search, display and 
route to millions of points of interest (“POI”) from Infogroup’s U.S. business 
database.  Truck stops, weigh stations, business locations, rest areas, intermodal 
ramps, and many other landmarks are included.   
 
Each of the icons below represents a category of POI that you might see on the 
RouteMap.  You can search for POI in these categories using the Location Radius 
tool (see section 3.8).   
 

 

 Airport   Government     Place of Worship 

 Attractions   Grocery Store   Police Station 

 Auto Dealership   Guest House, Lodging   Railway Station 

  Bank   Highway Exit   Rent A Car 

 Bridges & Tunnels   Hotel or Motel   Rest Area 

  Bus/Taxi/Limo   Intermodal Ramp ‐ Large   Restaurant 

 CAT Scales   Intermodal Ramp ‐ Medium   Retail 

 City Hall   Intermodal Ramp ‐ Small   RV Services 

 Custom Places 1   LCV Lot 3    Schools & Universities 

 Diesel Exhaust Fluid   Marina   Sports & Recreation 

 Emergency & Medical   Municipal   Travel & Transportation 

 Entertainment   Node (Hwy Intersection)   Truck Services 

 Event Facility   Other   Vehicle Repair 

 Ferry Terminal   Parking  Weigh Station 

 Gas, Fueling Station   Parks    Multiple POIs 

 Geographic Features 2 
   

 
TIP:  If the map is too cluttered with points of interest at a particular location, 
select the Map tab > Customize group > Map Features… and uncheck “Places” to 
hide them.  
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1  This icon can represent custom places that have not been assigned to a custom category, 
as well as POI that are in the “Other” category. 

 
2  “Geographic Features” icons identify the location of naturally-occurring features on the 
earth’s surface, grouping those features together as follows: 
 

Arches  Benches  Cliffs  Flats  Islands  Oilfields  Ridges  Swamps

Arroyos  Bends  Craters  Gaps  Isthmus  Pillars  Slopes  Valleys 

Basins  Canals  Crossings Glaciers  Lavas  Plains  Springs  Wells 

Bays  Capes  Dams  Guts  Levees  Ranges  Streams  

Beaches  Channels  Falls  Harbors  Mines  Rapids  Summits  

  
3 Most LCV lots require gate permits and are reserved for authorized, certified and 
registered companies only.  Before you plan on utilizing these areas or using them in 
route calculations, please make sure you’ve obtained the proper permits. 
 

10.15  Printing or Copying a Map 

The map in the RouteMap window can be printed or copied.  
 
To print the map, either select Print Map… from the File application menu or 
select the Map tab > Utilities group > Print Map.  A standard Windows® setup 
dialog for printing will open. 

 
To copy a map to the clipboard for pasting into another Windows program, select 
the Map tab > Utilities group > Copy Map. 
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Custom Routing 
 
 

PC*MILER provides a number of ways to customize routing, described in this 
chapter, including via point creation, dragging a route on the map, avoid and favor 
preference designations, truck and hazardous material restriction overrides, and 
geofence options. 
 
  

11.1  Picking Roads to Avoid or Favor  

IMPORTANT:  The avoid/favor preferences you designate will affect routing 
only when Use Custom Roads is checked in the Route Options or Default Route 
Options dialog box, General tab.  Select the Routes tab > Route group > Options 
or Routes tab > General group > Defaults, then check “Use Custom Roads”.  This 
option is turned off by default.  It does not affect via points or routes that have 
been dragged onto another road on the map.  

 
You may wish to indicate road segments that PC*MILER should avoid or favor 
when generating a route.  An avoided road segment is effectively treated as if it 
were closed unless no other road can be used for the route.  Favored road 
segments will be used unless it is not practical to do so.  Preferences are saved 
in a file called avoidfavor.db in the Data\Q1\Save folder of your installation. 
 
Road segments to avoid or favor can be picked from the RouteMap.  
Alternatively, you can use the map provided in the Avoid/Favor Manager dialog – 
see section 11.1.1. below for a description of this Manager.  Here are the steps to 
create a road preference using the RouteMap: 
 
1. First select the Tools tab > Avoids/Favors group > Avoid Roads or Favor Roads.   

2. On the RouteMap, click on the road segment to be avoided/favored (zoom in 
for a closer view if necessary). The cursor will appear with a minus or plus 
sign.   

3. An Add Comments box will appear on the map.  To add a comment that will 
be saved along with the avoid/favor, type it in then click OK.  (A comment 
can also be added at a later time – see section 11.1.1 below.)  If you do 
nothing, the dialog will close on its own as soon as another action is initiated. 

 
NOTE:  If you don’t want the Add Comments box to keep appearing, check 
“Do not show this dialog again” in the lower left corner.  To activate it 
again, select the red File menu > Application Settings and check Show 
Custom Road Comment Box, then click Save. 
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Add Comments Dialog 

 
4. The selected road segment will be marked with red highlighting if it is to be 

avoided or green highlighting if it is to be favored. You may need to click on 
several adjoining segments to cover the entire area you wish to designate.   

 
 

 

Avoid and Favor Designations on the Map – Philadelphia, PA 
 

5. If you want to cancel an existing preference on the map, click on the road 
segment again with the Avoid Roads or Favor Roads tool selected.  

 
NOTE on Favored Roads:  The PC*MILER long-distance “backbone” contains 
the roads that PC*MILER uses for its default Practical and Shortest routes over 
long distances.  If a favored road is not in the PC*MILER long-distance 
backbone, it will not be used for long-distance routes even if it is favored, unless 
an intermediate stop on that road is inserted into the route. 
 
 

11.1.1  Using the Avoid/Favor Manager 
 
All avoid/favor road preferences are saved in the Avoid/Favor Manager.  To open 
this dialog, select the Tools tab > Avoids/Favors group > Manager or press 
Alt+F2 on your keyboard. 
 
From within this Manager dialog you can create, delete, edit or export existing 
avoid/favor preferences using the tabs, buttons and map provided.   
 

Favor 

Avoid 



  

 

 PC*MILER User’s Guide           156 

 

 

Avoid/Favor Manager 
 
 

In the Avoid/Favor Manager, you will see a map that includes most but not all of 
the functionality that exists in the RouteMap window.  It can be used just like the 
RouteMap to designate road preferences – click one of the avoid/favor buttons at 
the top (Avoid Roads, Favor Roads, Toggle Overrides, or Adjust for Permits), 
then click a road segment on the map to add it to the list in the corresponding tab.  
Clicking again on the designated road segment deletes the preference.   
 
See section 11.1.2 below on overriding truck restricted roads, and section 12.3 on 
overriding hazardous material restrictions to accommodate hazmat permits. 
 
The map can be navigated like the RouteMap using the translucent scroll bars at 
the map’s edges, or the Drag Map and Box Zoom functionality via the buttons at 
the top.  A right mouse menu provides additional options.  To zoom your map 
view to a road segment listed in any tab of the Manager, first highlight it in the 
applicable tab and then double-click. 
 
To delete an individual route segment from any tab in the Manager, highlight it 
and click the “X” on the far right.  Click Delete All to delete the entire contents of 
the list in any tab.  
 
To add or edit a comment, highlight a preference, then click it again and type 
directly in the Comments column. 
 
To save your edits and close the Manager, simply click the “X” in the upper right 
corner to close the window. 
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11.1.2  Overriding Truck-Restricted Roads 
   

NOTE:  A road that is flagged as “truck-discouraged” (versus “truck-restricted”) 
in the PC*MILER database cannot be overridden only by using the method 
described below.  In addition to overriding the road, you must designate all the 
road segments on it as favored to make it fully truck-accessible (see section 11.1 
above).  To determine if a road is truck-discouraged, refer to the Road legend on 
the map for the color of the highlighting used to indicate a truck-discouraged 
road.   
 
A truck-restricted road, as determined by the controlling governmental authority, 
prohibits trucks larger than a certain size and weight.  To see these roads on the 
map, select the Map tab > Customize group > Map Features… and turn on Truck 
Restrictions.   In accordance with these regulations, PC*MILER does not use 
truck-restricted roads when routing vehicles larger or heavier than the restricted 
size or weight.  However, you can override these restrictions using the Restriction 
Override feature described in this section, to determine the largest and heaviest 
vehicle that can be assigned to a route. 
 
A truck-discouraged road is one that is open for local deliveries, but unsuitable for 
through trucks, as determined either by the controlling authority or by 
PC*MILER.  The road may be discouraged because it is narrow, winding, not 
well paved, or for a variety of other reasons.  Refer to the Road Legend on the 
map for the color used to draw truck-discouraged roads.  PC*MILER avoids 
routing over truck-discouraged roads whenever possible, with the following 
exceptions: if the destination is located on such a road; if avoiding the truck-
discouraged road will add a very significant amount of time and distance to a 
route; or if you have marked the road to be favored. 
 
If you have questions about truck restrictions, please contact each jurisdiction 
directly.  
 
NOTE Also:  You can set PC*MILER to override truck restrictions by default in 
the Default Route Options dialog box – check Override Restrictions. 

 
IMPORTANT:  The road preferences you designate will affect routing only 
when Use Custom Roads is checked in the Route Options or Default Route 
Options dialog box, General tab.  Select the Routes tab > Route group > Options 
or General group > Defaults, then check “Use Custom Roads”.  
 
PC*MILER normally routes around all truck-restricted roads.  However, some of 
these restrictions may be overridden, making the roads accessible. (This assumes 
that you have been granted permission to use these roads from the controlling 
authority, or that you are going to be using special equipment.) 
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To see truck-restricted roads highlighted on the map, turn on the Truck 
Restrictions layer in the Map Features dialog box.  A “Restricted” category will 
appear in the Road legend, showing the color of the highlighting on these roads. 
 
Overriding restrictions on a road is similar to designating road segments to be 
avoided or favored – you can pick overrides from the RouteMap or from the map 
in the Restriction Overrides tab of the Avoid/Favor Manager.  Remember 
though, that a “truck-discouraged” road must be favored as well; and to override a 
road restriction you must click on each segment of the road until the whole road is 
redrawn.  The color of the new highlighting will depend on which map style is 
selected.  Comments can be added if needed.  Be sure to override all segments 
included on the route; otherwise the entire road will continue to be treated as 
inaccessible. 
 
To undo an override, click on it with the Toggle Overrides tool activated.  The 
road will be restored to its original truck-restricted status.  Alternatively, you can 
delete it from the Restriction Overrides tab of the Avoid/Favor Manager.  
 
 

 

Truck Restricted Roads on the RouteMap, Chicago, IL 
 
 

11.1.3  HazMat Permit Overrides 
 
To change the status of roads that are restricted for hazardous materials, see 
section 12.3.  To transport hazardous materials on these roads, the applicable 
permits must have been obtained. 
 
 

11.1.4  Creating Sets of Custom Road Preferences 
 
The Avoid/Favor Manager enables you to manage multiple sets of custom road 
preferences by allowing you to create and save sets of these preferences.  You 
may find that custom sets are a useful tool for working with special equipment 
you operate, or for seasonal routing requirements.  Sets can include road segment 
avoids/favors, and hazmat and truck restriction overrides.   
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NOTE:  Many states and provinces in the north central part of the North 
American continent have seasonal weight limits that apply either to all 
commodities or to particular commodities (such as grain) at certain times of year 
(harvest season, winter, spring thaw, etc.). 
 
In these areas, the carrier typically works with the shipper to adjust how much 
material is loaded into the truck in order to max out the limit for the season in 
question, rather than adjust the route traveled.    So (for example) more grain 
would be loaded into the truck during harvest season or winter than during spring 
thaw.   That is the only way to have a legal load when an origin or destination is 
on a road with a seasonal limit.    In addition to legal considerations there are also 
practical physical considerations since many loading and unloading points in that 
part of the country are on unpaved surfaces, and to overload a truck during spring 
thaw risks the truck getting stuck during pickup or delivery. 
 
In PC*MILER, we have coded the weight limit that applies to general 
commodities during most seasons of the year.   For situations where the low-limit 
road is used as a through route rather than for pickup or delivery, the Sets feature 
described below can be used to create avoid/favor/restriction override “sets” for 
each season of the year for each commodity. Custom routing must be turned on in 
the Route Options dialog box; then use the set that applies for a specific 
commodity at the appropriate season of the year. 
 
REMEMBER:  The road preferences you designate will affect routing only when 
Use Custom Roads is checked in the Route Options or Default Route Options 
dialog box, General tab.  Select the Routes tab > Route group > Options or 
General group > Defaults, then check “Use Custom Roads”.  
 
 
To create a set, do the following: 
 
1. Select the Tools tab > Avoids/Favors group > Manager to open the 

Avoid/Favor Manager. 

2. Click Create Set in the lower left corner. 

3. At the prompt, enter a Name for the new set. 

 

4. Click Save. 
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5. You will see the new set under Available Sets on the left.  Uncheck the 
DefaultNA set and any other existing sets that are checked in this list. 

NOTE: If more than one set is enabled in the Avoid/Favor Manager, the 
avoid/favor buttons in the Tools tab will be disabled. 
 

6.  Now you can begin to add road segments in any tab of the Manager.  These 
avoid/favors will be specific to this set.  The set you are adding them to must 
be the only set selected in the Available Sets list. 

Note the following guidelines for creating new sets: 
 

 Set names cannot be longer than 50 characters, and must be comprised of 
letters and/or numbers. 

 Spaces are not allowed in the set name, but underscores (“_”) are 
permitted.   

 
To delete an individual set, place the cursor over the set name and click the “X” 
that appears on the right: 
 

 

Deleting a Set 
 
 
To delete all sets, click the Delete All Sets button in the lower left corner.  The 
Default NA set cannot be deleted. 
 
When more than one set is checked, all preferences included in the active sets will 
be visible on the map and listed in the corresponding tabs.  However, only one set 
must be active when you want to add or delete preferences to a set.  When 
multiple sets are active, the Favor Roads, Avoid Roads, Toggle Overrides, and 
Adjust for Permit buttons will be grayed out on the toolbar and in the right 
mouse map menu. 
 

 
11.1.5 Exporting Custom Roads Data To a Report 

 
To create a report in a text file (.txt) or Excel file (.csv) that contains all the 
preferences in the open tab of the Avoid/Favor Manager, click Export All.  In the 
dialog that opens, name the file and choose a file format from the Save as type 
drop-down.  Here are examples of the two types of file formats (the formatting in 
these files has been edited): 
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Exported File of Avoided Roads in .TXT Format 
 
 

 

Exported File of Avoided Roads in .CVS Format 
 
 

 
11.1.6  Avoiding or Favoring Whole Roads or States/Countries  

 
REMEMBER:  The road preferences you designate will affect routing only when 
Use Custom Roads is checked in the Route Options or Default Route Options 
dialog box, General tab.  Select the Routes tab > Route group > Options or 
General group > Defaults, then check “Use Custom Roads”.  
 
In addition to the road preferences described above, whole roads and whole states 
can be selected to be avoided or favored for a route using the States/Roads 
Manager.  If PC*MILER|Worldwide or DTOD data is installed and a region other 
than North America is selected, whole countries can be avoided/favored as well.   
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Avoid/Favor a State or Country: 
 
1. Select the Tools tab > Avoids/Favors group > States/Roads to open the 

States/Roads Manager.  
 
2. VERY IMPORTANT:  Make sure “Enable” is checked in the upper left 

corner of the State Restrictions tab. 
 
3. Select a state (or country) from the States list. 
 
4. Click either Avoid or Favor to add to the desired list. 
 
To delete a state (or country) from one of the lists, place the cursor over it and 
click the “X” that appears to the right.  To clear either list, click Clear All at the 
bottom of the list. 
 
 

 

States/Roads Manager, State Restrictions Tab 
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Avoid/Favor a Whole Road: 
 
NOTE for PC*MILER|Streets Users:  You cannot designate a local street by 
name to be avoided or favored in the Roads tab; a local road can only be 
avoided/favored by designating it as such on the map.  

 
1. Click the Roads Restrictions tab. 

2. Select a state (or country) from the drop-down State pick list. 

3. Type the road name* in the Road Name field (e.g. I 95) without a state 
abbreviation. 

4. Click Avoid or Favor under the road name.   
 
To delete a road from one of the lists, place the cursor over it and click the “X” 
that appears to the right.  To clear either list, click Clear All. 
  
*  To see how the name of a particular road appears in the PC*MILER database, 
you can zoom to that road on the map and place your cursor over the road without 
clicking.  Some highway labels may include a common name along with the road 
number; for example, “Pennsylvania Turnpike (I 276)”.  In these cases, use the 
road number from within the parentheses (“I 276” in this example). 
 
NOTE:  You won’t see any indication on the RouteMap that a whole road or 
whole state/country has been designated to be avoided or favored.  To see the 
difference a designation makes on a route, first run the route with the Enable 
option unchecked, and duplicate that route; then go back and check this option 
and run the duplicated route.  You will see the difference between the two routes 
on the map and in reports.  Another way to do this is to check and uncheck the 
Use Custom Roads option in the Route Options or Default Route Options dialog. 

 
 

11.1.7  Converting Custom Road Files from a Previous Version  
 
Saved custom road preferences from the previous version of PC*MILER can be 
imported using PC*MILER’s file conversion utility as in the steps below.  
  
1. Select the Tools tab > Avoids/Favors group > Convert.   

2. Click Import… and navigate to your existing custom road file(s) that are 
located in the NA\Q1\Save or World\WW\Save folder in your PC*MILER 
27 or 27.1 installation folder.  In that folder there will be one or more of the 
following custom road files: 

 avoid.dat 
 permit.dat 
 afRoutes.dat 
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 flattened_af.dat 
 NAafSt.dat 
 *afSt/dat  (* = EU or another world region)  

3. After you select the file(s), click Open to start the import.   

4. Once the import process is complete, check to make sure all the avoid/favors 
were imported successfully.  Due to changes in the highway and street-level 
network database over time, some avoid/favors may not be successfully 
imported.  Double-clicking on any listed road segment in the Conversion 
Utility dialog will zoom to that segment on the map where you can edit your 
preferences further if necessary.   

 
IMPORTANT NOTE:  Because of recent enhancements to the PC*MILER 
database that incorporate express, local, north/south and east/west lanes, etc., 
some of your avoid/favor/override designations from a previous version may need 
to be edited link-by-link to be sure the designated preference will operate in both 
directions. In the Avoid/Favor Manager, open the Avoid, Favor, Restriction 
Overrides or Haz Permits tab to see a list of your preferences. Then zoom in to 
the maximum level (18) on each listed link on the map (you can double-click each 
link to do this) and make sure that lanes in both directions are marked with the 
desired designation.    

 

11.2  Custom Vehicle Profiles 

For those who make use of custom vehicle dimensions, PC*MILER provides the 
ability to create custom vehicle profiles that enable quick entry of vehicle or fleet 
attribute sets that you use often when routing.  This time-saving feature lets you 
set up and save groups of vehicle dimension and cost/time settings for easy access 
in the future.  Using custom vehicle profiles ensures that the defined settings are 
consistent for the particular vehicle type selected for a route.   
 

To use custom vehicle profiles, select the Routes tab > Utilities group > Vehicle 
Profile.  In the Vehicle Profiles Manager dialog box that opens, you can select a 
profile to view, edit, or delete, or you can create a new custom profile.  For North 
America, sample profiles are provided in the pick list for full-size van, 26’ 
straight truck, 28' double trailer, 40' straight truck, 48' semi-trailer, and 53' semi-
trailer vehicles.  The sample profiles can be edited, but not deleted.   
 
NOTE:  The “Full-size van” profile is intended for use with vans, pickup 
trucks, SUVs, automobiles, etc. that are classed less than 9,000 lbs./4,082 kgs. 
The automobile routing that is generated from this profile ignores all commercial 
truck restrictions, and if toll rates are calculated, will use toll rates that apply to 
small vehicles with 2-axles, which often differ from rates that apply to larger 2-
axle vehicles.  
 



  

 
 Chapter 11:  Custom Routing 165 

NOTE For PC*MILER|Worldwide and DTOD Users:  When creating, 
accessing, or editing a custom vehicle profile, you must perform the additional 
step of specifying a region.  Each vehicle profile is applicable to only one region. 
 

 

Vehicle Profiles Manager 
 
 

To create a new custom profile, click New.  A dialog box will open that has two 
tabs – Cost/Time and Vehicle Dimensions.  The editable fields in these tabs are 
the same ones found in the Route Options dialog box.  Enter a profile name and 
the desired edits in each tab and click Save to save your changes. 
 

 
 

 

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
An unlimited number of custom profiles can be defined.  The profiles you create 
will appear in the pick list of available profiles in the Vehicle Dimensions tab of 
the Route Options and Default Route Options dialog boxes. 
  
Once a profile is set up, it can be used globally (all new routes will use the 
selected profile in route calculations) or applied to each new route as appropriate:   

Options for Vehicle Profile –  
Cost/Time Tab

Options for Vehicle Profile –  
Vehicle Dimensions Tab 
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 To apply a profile to all new routes, choose the Routes tab > General 
group > Defaults.  In the Vehicle Dimensions tab, select the desired 
profile from the drop-down Vehicle Profile pick list.  Click Save to save 
this profile as the default. 
 

 To apply a profile to a single route, choose the Routes tab > Route group > 
Options.  In the Vehicle Dimensions tab, select the desired profile from 
the drop-down Vehicle Profile pick list.  Click Save when you are 
finished editing options for this route.   

 
By default, custom profiles are not used.  Sample vehicle profiles are provided in 
the Vehicle Profile pick list as follows: 
 

 North America:  48' semitrailer, 28' double trailer, 40' straight truck, 53' 
semitrailer, full-size van 

 Europe:  16.5m articulated, 12m straight truck, 18.75m road train, full-
size van 

 All Other Regions:  none 
 

11.3  Custom Route Profiles 

In addition to custom vehicle profiles, you can create and save route profiles that 
include custom settings available in the Route Options dialog.  This feature is a 
time-saver if there are combinations of route option settings that you need to use 
frequently but do not want to set as defaults.   
 
To create and use a new route profile, follow these steps: 
 
1. Select the Routes tab > Utilities > Route Profiles.  
 
2. In the Route Profiles Manager, click New. 
 
 

 

Route Profiles Manager 
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3. The Route Profile Options dialog will open.  You will see the same options 
here as in the Route Options dialog.  Type a name for the new profile under 
Route Profile Name at the top of the dialog. 

4. Set the route options as you want them for this profile. 

5. Click Save to save the profile and close the Route Profile Options dialog. 

6. Click Close to close the Route Profiles Manager. 

7. Now the new profile is available for every route you run – click the gear 
button (      ) in a route window and choose Options, then select it from the 
Route Profile pick list at the top of the Route Options dialog. 

8. To edit or delete a profile, open the Route Profiles Manager as in Step 1, 
select a profile from the pick list and then click Edit or Delete. 

 

11.4  Using Via Points For Route Customization 

PC*MILER gives users the ability to enter up to 12 via points between an origin 
and destination to guide a route along user-preferred roads.  The via points you 
create can be designated as stops or waypoints (the “waypoint” designation means 
that these locations were added only to guide the route along desired roads).   All 
via points appear on the stop list as “stops” and are listed as stops in the Detailed 
Route and State/Country reports; however, waypoints do not appear in driving 
directions.  All via points are shown on the RouteMap, with a gray flag if they are 
waypoints or a yellow flag if they are stops.     
 
Via points are saved in a set and can be entered, optionally, with a click of the 
mouse when subsequent trips between the same origin and destination are entered.  
Once a set is created, it can be edited, deleted, or exported to a text file as 
described below. 
 
To create a via point set, follow these steps: 
 
1. In a new route window, enter at least two stops. 

2. Highlight the stop that you wish to designate as the origin.  This need not 
be the origin of the route if multiple stops are entered.  You will be creating 
via points between this highlighted stop and the next stop or destination on the 
stop list. 

3. Select the Routes tab > Route group > Create Via Point Set to open the Via 
Points Set Manager. 
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Via Points Set Manager 
 
 
4. In the Set Begins and Set Ends fields, enter a new radial value or keep the 

default value (10 miles).  This defines the radius of the origin and destination 
locations (city center or postal code center).  The set of via points you are 
creating will be an option for all future routes run between any points included 
in this radius. 

5. Type a PC*MILER location (city/state, postal code, etc.) and, optionally, a 
street address in the Via Point Location fields then press Enter or click Add 
to Set.  The city name is entered in the first cell of this field and an address 
can be entered in the second cell on the right. 

6. Select whether this point will be a Stop or a Waypoint.  Waypoints are 
treated like stops (routes travel through the centroid of a town or city) but are 
shown differently on the map: waypoints have gray flags, whereas stops have 
yellow flags. 

7. Select whether the points in this set will apply only on a route To the 
destination, only on a route From the destination, or in Both directions. 

8. Steps 5-7 can be repeated to add any number of additional via points to the set. 

9. When finished adding via points to this set, click Save Set to save the new 
vias then close the dialog box (click the “X” in the upper right corner). 

10. In the route window, you will see a line added where you created via points.  
Click the Add Via Set button on this line to add the points to the stop list.  If 
you decide not to use the via points for this route, ignore this button and the 
via points won’t be used. 
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“Add Via Set” Button in the Route Window 
 

11. Click Run to run the route.  If you activated the via points in Step 10, the 
route will travel on the preferred roads through the via points.   

 
To Edit a Set: 

To edit a set at any time, select the Routes tab > Utilities group > Manage Via 
Point Sets to open the Via Points Set Manager.  Then select the set you want to 
edit from the pick list of sets, make your changes, and click Save Set.  Editing 
options include: 

 Edit the set name – click Edit Set Name, enter a new name, then click Apply 
Name. 

 Delete the set – click Delete Set in the upper right corner of the dialog box.  
This action cannot be undone. 

 Change the direction to which the set will be applied. 

 Add more stops or waypoints as described above. 

 Delete one or more via points – highlight a point on the list and click the 
Delete Point button below the list. 

 Change the type of via point – highlight a location on the list and click the 
Stop or Waypoint button. 

 
 
To Export Via Points to a Text File: 
 

1. In the Via Points Set Manager, select a set from the pick list. 

2. With the set you want to export selected, click Export Data. 

3. Give the new file a name in the File Name field. 

4. Select a location where the file will be saved. 

5. Click Save to save the text file. 
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11.5  Dragging a Route on the Map 

Once a trip has been generated, any point along the generated route on the map 
can be dragged onto another road in order to re-route the trip.  To drag a route, do 
the following: 
 
1. Select the Routes tab > Utilities group > Drag Route.   
 
2. In the RouteMap window, click on the route and hold down the cursor, then 

drag to the desired location and let go.   
 
3. This action will create a via point at the location to which the route was 

dragged, marked by a gray waypoint flag. The trip will be re-routed to 
accommodate the new via point.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

11.6  Geofence Options 

PC*MILER now provides tools that enable you to create, modify and manage 
geofences.  A geofence defines a geographic area that will either generate an alert 
when a route enters it, or will be avoided by the route.  Its use has many different 
applications, such as: 

 
 Drawing zones around a warehouse to identify delivery/billing zones 

 Alerting dispatchers when a vehicle enters an area that it wasn’t 
authorized to enter –  for example, leaving the country 

 Avoiding or warning about steep grades, mountain passes susceptible to 
snow closures, tunnels requiring escorts, etc. 

 Avoiding or warning if an asset has crossed into a high crime or high 
accident area 

New Via Point 

Original Route New Route Created by Dragging
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 Avoiding or warning about areas where bad weather is expected or has 
occurred: heavy snowfalls, floods, hurricane evacuation areas, etc. 

 

The geofence tools in PC*MILER allow users to: 
 

 Create and modify the characteristics of a geofence: 

-  Define its size and shape as a circle, rectangle, or a user-defined polygon 

-  Give the geofence a unique name (with  the exact text that will appear in 
report warnings) 

-  Delete the geofence 

 Identify points and roads that fall within the boundaries of a geofence 

 Group geofences into sets and assign and modify the characteristics of a set: 

-  Create and uniquely name a set with the name that will appear in report 
warnings 

-  Define the border color, border width and fill color of the geofences in 
the set 

-  Define the set properties: off (not active), warning only, or avoid and warn 

-  Delete the set 
 

 
11.6.1  Creating a Geofence 

 
NOTE:  There is no limit to the number of individual geofences that can be 
created and added to a geofence set, or to the number of sets that can be created.   
 
TIP:  A geofence that covers a very large area (for example, a whole state) will 
draw very slowly on the map and will affect other map functions that involve a 
map redraw.  Whole states and whole roads can be avoided or favored using the 
States/Roads Manager – see section 11.1.6. 
 
Follow these steps to create an individual geofence: 

1. Open the RouteMap window and bring the targeted area into view.   

2. In the Tools tab > Geofences group > Create Geofence drop-down, select 
one of the options: Create Rectangle, Create Circle, or Create Polygon.  
These options are also available in the right mouse menu off the map. 

3. In the RouteMap window, depending on which shape you chose, the cursor 
will change to one of the following: 

 

 When drawing a rectangle:  
 When drawing a circle:  
 When drawing a user-defined polygon:    
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GeofenceManager 
 

If using the circle or rectangle shape, drag the cursor over the desired area.  
If using the polygon tool, click all the points of the desired perimeter and 
finish by clicking on the first point again to close the polygon.  If you are 
not satisfied with the area that is covered, delete the geofence using the right 
mouse menu off the map. 
 
NOTE:  See sections 11.6.6 and 11.6.8 on identifying points and roads that 
are included within the boundary of a geofence. 

 
4. To name and assign properties to the geofence, select the Tools tab > 

Geofences group > Geofence Options > Manage.  
 

5. In the Available Geofences list, you will see a generic name assigned 
(“Geofence_#”) to the geofence you just created on the map.  (If more than 
one geofence is on the list, they will be listed alphabetically, e.g. 
Geofence_1, Geofence_10, Geofence_2, etc.)  To assign a unique name to 
this geofence (for example, a geographic location): 

a. Click on the defaulted name. 
b. Click Edit Geofence Name below the list. 
c. In the prompt that pops up, type a new name. 

 
 
 
 
  

d. Click Apply Name. 
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6. A geofence must belong to a set before a warning status and display 

properties can be assigned to it: 

a. Click Create a New Geofence Set. 
b. Type a name for the new set. 

 
 
 
 
  

c. Click Create Set.  The set name will appear as the selected set in the 
Geofences In This Set pick list.   

d. Go back to the Available Geofences list, highlight the geofence you 
want to add and click Add Selected Geofence To Set. 

 
 

11.6.2  Customizing Geofence Sets 
 
The properties of each geofence set can be customized so that all geofences in the 
set will have the same appearance and activity status.  Individual geofences 
cannot be customized.  
 
To customize the appearance of a set: 
 

 
 
1. Select the set name from the Geofences In This Set pick list. 

2. To change the Fill Color or Border Color, click on the block of color and 
select another color. 

3. To change the border width, use the Border Width drop-down to set the 
thickness of the perimeter. 

4. Click Apply Changes to see these atributes appear on the map. 
 
 

To designate the behavior of geofences in the set: 
 

 
 
 1. Select one of these options: 
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Detailed Route Report with Geofence Warning 

Off:  Geofences are not active. They do not affect the Detailed Route Report 
and are not visible on the map. 

Warning Only:  Geofences are visible on the map, and a warning will appear 
in the Detailed Route Report at the points where the route begins to 
travel on a road segment that is part of a geofenced area.  The warning 
will include the road name, geofence set name, and geofence name, for 
example: 

Warning * US 69 *: Montana Geofences: ButteMT 

Avoid + Warning:  Geofences are visible on the map.  The route will avoid 
road segments within the geofenced area if “Use Custom Routing” is 
checked in the Route Options or Default Route Options dialog box. A 
warning will appear in the Detailed Route Report in cases where the 
route has to enter the geofence (for example, if the destination is within 
the geofenced area). 

 
2. Click Apply Changes to save your selection.  

 

 
 
 

 
11.6.3  Deleting or Renaming Geofences and Sets 

 
Follow the steps below to delete an individual geofence or geofence set. 
 
To delete an individual geofence using the Geofence Manager: 
 

a. Select the Tools tab > Geofences group > Geofence Options > Manage… . 

b. Select a set from the Select an Existing Geofence Set drop-down. 

c. Under Geofences In This Set, highlight the geofence you want to remove,  
then click Remove Selected Geofence. 

d. Under Available Geofence, highlight the geofence and click Delete Selected 
Geofence.  Alternatively, the geofence can be left on the list if you just want 
to remove it from the set without deleting it. 
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To delete an individual geofence directly from the map: 
 
First open the RouteMap window and zoom to the location of the geofence you 
want to delete.  (“Geofences” must be checked in the Map Features dialog box.)  
Now there are two ways to complete the deletion: 

 Select the Tools tab > Geofences group > Delete , then click your cursor 
anywhere within the boundaries of the geofence. 

 Right-click on the map and select Geofencing > Delete Geofence from the menu.  
Then click your cursor anywhere within the boundaries of the geofence. 

 
NOTE:  When in “Delete Geofence” mode, your cursor will change to look like 
this:        To exit from delete mode, select Delete again.  
 
 

To delete a set: 

1. Select the Tools tab > Geofences group > Geofence Options > Manage… . 

2. Select a set from the Select an Existing Geofence Set drop-down. 

3. Click Delete This Geofence Set.  When you delete a set that has geofences 
assigned to it, those geofences will not be deleted – only the set name and its 
properties will be deleted. The individual geofences will be moved back onto 
the Available Geofences list to be reassigned or deleted, and they won’t be 
visible on the map. 

 
To rename a set: 

1. Select the Tools tab > Geofences group > Geofence Options > Manage… . 

2. Select a set from the Select an Existing Geofence Set drop-down. 

3. Under Rename Selected Geofence Set (top right corner) type a new name. 

4. Click Apply Changes.  You will see the new name of the set in the Select an 
Existing Geofence Set drop-down. 

 
 

11.6.4  Editing Geofence Sets 
 
To remove a geofence from a set and reassign it to another set, do the following: 
 
1. Select the Tools tab > Geofences group > Geofence Options > Manage… . 

2. Select a set from the Select an Existing Geofence Set drop-down. 

3. Under Geofences In This Set, highlight the target geofence then click 
Remove Selected Geofence. 

4. Select another set from the Select an Existing Geofence Set drop-down. 
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5. Under Available Geofences, highlight the geofence you removed from the 
previous set and click Add Selected Geofence To Set.  

 
 

11.6.5  Geofence Behavior on the Map 
 
By default, geofences that are created will initially appear on the map with light 
gray fill and a thin red border.  Fill color and border width can be edited as 
described in section 11.6.2. 
 
When a geofence is either inactivated or deleted, it will no longer be visible on the 
map. 
 
There are also two settings in the Map Features dialog box that affect the 
geofence display on the map: if Avoids & Favors is unchecked, the blue 
highlighting that designates road segments inside each geofence will be hidden; 
and if Geofences is unchecked, the geofence shapes will be hidden but the blue 
highlighting on road segments will still be visible.  All geofences are affected by 
these settings. 
 
 

11.6.6  Identify Points Within a Geofence Boundary 
 
To determine if particular points lie within a geofence boundary, follow the steps 
below. 
 

 

Geofence Identifier 
 
 
1. Select the Tools tab > Geofences group > Geofence Options > Identify. 

2. Enter a location in the City field, with or without an Address.  Any 
PC*MILER location is acceptable, including lat/long points and custom place 
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names.  If you enter a city name without an address, PC*MILER will use the 
city center of that town. 

3. Under Search Within, select to search All geofence sets for the location, or 
within A specific geofence set.  Choose a set from the drop-down pick list if 
you want to search within a specific set. 

4. Click Search.  All geofences that include the location will be listed under 
Matching Geofences.  If the point is not within the boundary of any 
geofence, a “No matches found” message will appear. 

5. Click Reset to clear the search before entering another location. 

 
11.6.7  Using the Geofences Conversion Utility 

 
If you created and saved geofences in the previous version of PC*MILER, you 
can easily import those files into Version 28 using the Geofences Conversion 
Utility.  To do this, follow the steps below.   
 
1. Select the Tools tab > Geofences group > Convert > Import Geofences.  

2. In the window that opens, navigate to the PC*MILER 27 or 27.1 installation 
folder (usually C:\ALK Technologies\PMW270 or PMW271).  In that folder, 
navigate to NA\Q1\Save\geofences, then select the geofence files 
(flattened_gf.dat and flattened_af.dat) and click Open. 

3. You will see the saved geofence files being copied into Version 28. 

4. When the process is complete, close the dialog box.  The geofences should 
now be accessible in Version 28.  

 
 
11.6.8  Generating a Geofence Report 

 
To create a report that shows all road segments included within the perimeter of a 
geofence, do the following: 
 
1. Select the Tools tab > Geofences group > Convert > Export Geofences.   

2. In the Save dialog, select a file type (*.txt or *.csv), enter a file name, and 
select a target location where the report will be saved.    

 
To open the report, navigate to the folder where it was saved.  If the report was 
saved as a *.txt file, it will open in Notepad.  If it was saved as a *.csv file, it will 
open in Excel.   
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This report includes the following data: the name of the geofence, the set that the 
geofence belongs to, the corresponding road segments included in the geofence, 
and the date the geofence was added.  A sample *.txt report for two geofences is 
shown below.   

 
 

 

Geofence Report in *.txt Format 
 

Geofence Location, Set 
Name, Date Created, Shape, 
and Defining Lat/Longs  

Each road segment listing 
includes Segment, Length, 
Nearest Town, Date and 
Set Name     

List of road 
segments in both 
geofences begins 
here.  
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Hazardous Material Routing 
 

If the separate PC*MILER|HazMat data add-on module is installed, routing can 
be generated in North America, Europe and Oceania for various types of 
hazardous materials and dangerous goods using any PC*MILER route type.  To 
use a hazardous materials routing option, click the gear button in a route window  
(     ) and select Options or select the Routes tab > Route group > Options, then 
click the HazMat tab. 

 

 
 

Route Options Dialog, HazMat Tab (North America Region) 
 

 
Hazardous material routing options for North America include:  General, 
Corrosive, Explosives, Flammable, Inhalants, and Radioactive.  When Europe 
or Oceania is the selected region, the options are: General, Explosives, 
Flammable, and Harmful to Water (with additional tunnel restrictions 
categories in Europe – see Table 2 below).  For non-hazmat routes, select None 
(this is the default).   
 
Tables 1 and 2 below show how each PC*MILER hazmat route type handles 
each hazmat road category.  Table 3 shows U.S. DOT Hazmat classes and the 
corresponding PC*MILER route type.   
 
NOTE:  The “General” option should be used for any hazardous material that 
presents a danger during transportation and is not corrosive, explosive, 
flammable, inhalant, or radioactive.  Common examples include: oxidizers (such 
as compressed oxygen tanks), combustible liquids (such as diesel fuel), and 
poisons (such as pesticides). 
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TABLE 1:  PC*MILER Hazardous Material Route Types and Road Categories 

 

favor = routing will prefer these segments 
no change = routing will not be altered in any way 
avoid = routing will go around these segments whenever possible 
discourage = a lesser degree of avoidance, used when a state or road authority allows hazmat only at certain times of day, with 

prior notification, by permit, or in limited quantities, and for tunnels not otherwise classified 
 
 

 
 

(continued on next page) 
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NOTE: U.S. hazardous material routing restriction/designation information taken from The National Hazardous Materials 
Route Registry provided by the Federal Motor Carrier Safety Administration (FMCSA); and various other state and federal 
sources.  Canadian hazmat/dangerous goods routing data derived from government and municipal sources in each Province and 
Territory, and includes restrictions for major Canadian bridges and tunnels. 

 
 

NOTE:  Canadian dangerous goods routing data is derived from government and municipal sources in each Province and 
Territory, and includes hazmat restrictions for major Canadian bridges and tunnels. 
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TABLE 2:  PC*MILER HazMat Route Types and Road Categories – EU Harmful 

to Water and EU Tunnels 
 

(PC*MILER|Worldwide or DTOD data must be installed)  For PC*MILER|Worldwide and 
DTOD users, the hazmat categories below are used in the Europe and Oceania regions. 
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TABLE 3:  U.S. DOT Hazmat Classes and Corresponding PC*MILER Hazmat Route Types 
 
The table below shows how the wording used for PC*MILER hazmat routing options, which is 
derived from industry-standard placarded descriptions of hazardous materials, corresponds to the 
U.S. Department of Transportation Hazmat classifications.  See sections 12.1 and 12.2 below on 
how to use this table. 
 

U.S. DOT Hazmat Classes (corresponding PC*MILER routing options are bolded): 

Class 1: Explosives – Explosive  

Class 2: Compressed Gases 
              2.1: Flammable Gas – Flammable 
              2.2: Non-Flammable Compressed Gas – General  
              2.3: Poisonous Gas – Inhalant  

Class 3: Flammable and Combustible Liquid – Flammable  

Class 4: Flammable Solids 
              4.1: Flammable Solid – Flammable 
              4.2: Spontaneously Combustible Material – Flammable  
              4.3: Dangerous When Wet Material – General  

Class 5: Oxidizers – General  

Class 6: Poisons 
              6.1: (part) Inhalation Hazard – Inhalant  
              6.1: (balance) – General  
              6.2: Infectious Substance (Etiologic agent) [“Biohazard”] – General  

Class 7: Radioactive Materials – Radioactive  

Class 8: Corrosive Liquids – Corrosive (“Caustic” in PC*MILER 22 and earlier) 

Class 9: Miscellaneous – General  
 

12.1  Determining Which Route Type to Use 

NOTE:  Hazmat regulations for a particular tunnel on a route should be checked 
if there is any doubt about which materials are permitted, as regulations may 
change over time and might not be included in the version of the PC*MILER 
database that you are currently using. 
 
The shipper of hazardous materials is legally responsible for determining the U.S. 
DOT Hazmat Class for their shipment and communicating that class to the carrier 
in their shipping papers. 
 
To determine the U.S. DOT Hazmat Class, go to the online 49 CFR 172.101 at 
www.ecfr.gov.  Once the Class is identified for a shipment, use Table 2 above to 
determine which route type should be used when generating a PC*MILER route 
for that shipment. 



  

 

 PC*MILER User’s Guide 184 

For example, on the government web site, hydrogen is classified as a Flammable 
Gas (DOT class 2.1), while oxygen, nitrogen, carbon dioxide, and argon are Non-
Flammable Compressed Gases (DOT class 2.2). 
 
Using Table 2 above, DOT class 2.1 corresponds to the PC*MILER Hazmat route 
type “Flammable”, while DOT class 2.2 corresponds to the PC*MILER Hazmat 
route type “General”.  
  

12.2  Routing Multiple Hazmat Classes 

For routing a single shipment containing multiple hazmat classes, the following 
procedures are suggested: 
 
1. First, determine the weight of each commodity and check the U.S. DOT 

(PHMSA) rule to see if that combination is permissible and if so, which 
placard(s) are to be used. 

2. Then, for each placard, look up the PC*MILER|Hazmat routing options in the 
table above. 

 a. If all the placards correspond to one routing option, use that option. 
 b. If the placards correspond to multiple routing options, then run the route 

 for each option, and: 
  i.  If all the routes are the same, that common route is the route to be used. 
  ii. If the routes are different, then there may or may not exist a legal route  

     for that combination of commodities for the specified origin/destination  
     (this will occur only rarely). 

 

12.3  Changing the Status of Hazmat-Prohibited Roads 

Customers who have obtained permits can change the status of hazmat-prohibited 
roads as follows: 
 

1. First make sure “Hazardous Materials” is checked in the Map Features 
dialog (Map tab > Map Features…).   

2. Select the Tools tab > Avoids/Favors group > Adjust for Permits,  

3. In the RouteMap window click on the prohibited road(s) that you wish to 
make accessible for routing.  The adjusted route segments will change 
color (the color will depend on which map style is currently active).  

 
All user-created road preferences are saved and managed in the Haz Permits tab 
of the Avoid/Favor Manager (Tools tab > Avoids/Favors group > Manage – see 
section 11.1.1).  A comment may be added to each record, either by typing a 
comment in the Add Comment dialog box that appears when a road segment is 
clicked or by entering it directly in the Avoid/Favor Manager.   
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HazMat Restriction Override Shown on the RouteMap 
 

 
The custom road settings you create can be removed by clicking again on the 
same roads with the Adjust for Permits tool active, or by using the Avoid/Favor 
Manager. 
 

12.4  Hazardous Material Routing on the RouteMap 

 

 

Map Showing Hazmat Restricted Roads & Restrictions Legend 

Restrictions 
Override near 
Greenville, RI 
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With the PC*MILER|HazMat add-on data module installed, hazmat-prohibited 
and -designated roads will be highlighted in the RouteMap window provided this 
feature is checked in the Map Features dialog (see TIP below). The Restrictions 
legend shows the highlight color for various designations (to show/hide this 
legend, select the Map tab > Customize > Legends). 

 
 

TIP:  If you do not want hazmat routing to show up on maps, the highlighting can 
be hidden from view by turning off the Hazardous Material feature in the Map 
Features dialog box.  Select the Map tab > Customize group > Map Features…. 
and uncheck “Hazardous Material”, then click OK to save. 
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Using PC*MILER|Energy 
 
 

Beginning in Version 28, PC*MILER now offers users an integrated energy-
focused map data set for the oil and gas industry.  Through partnership with 
GEOTrac Systems Inc. of Calgary, ALK has created the PC*MILER|Energy data 
set that includes access roads and infrastructure coverage across states and 
provinces in North America where oil and gas wells are actively developed and 
known reserves are found. 
 
PC*MILER|Energy is available as a separate add-on data module for PC*MILER.  
Your PC*MILER installation must also include the PC*MILER|Streets US and 
PC*MILER|Streets Canada data modules.  With these three modules installed, 
PC*MILER|Energy gives users the ability to: 
 

 plot the latitude/longitude of a wellhead and route directly to it, then view 
that route on the PC*MILER RouteMap; 

 generate turn-by-turn directions on leased or bonded roads in and out of 
well sites and other facilities; 

 switch between the base PC*MILER map data set, accessible to general 
users of PC*MILER, and the PC*MILER|Energy oil- and gas-specific 
data set; 

 use the PC*MILER Import Custom Place Wizard to customize the 
PC*MILER database with specific wellhead and facility locations, and 
group those locations into one or more POI (points of interest) category 
(see section 3.13.4). 

 
 

 

Satellite View of PC*MILER Routing To a Wellhead Near Homer City, PA 
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The PC*MILER|Energy road network in Version 28 includes approximately 
288,550 miles of access roads that are not included in the base PC*MILER map 
data set.  These roads are found in the following states and provinces:  Alberta 
(Canada), Arkansas, Colorado, Louisiana, Mississippi, New York, North Dakota, 
Ohio, Oklahoma, Pennsylvania, Saskatchewan (Canada), Texas, Utah, West 
Virginia, and Wyoming. 
 

13.1  Accessing the PC*MILER|Energy Data Set 

With PC*MILER|Energy data purchased and installed, select the Map tab > 
Utilities group > Change Data Set and select NA – Streets US/Canada Energy.  (If 
PC*MILER|Energy data has not been installed yet, see section 2.5.4.)   
 
The currently loaded data set will be displayed in the title bar of the RouteMap 
window, shown at the bottom of each page in any reports that are generated, and 
checked in the Change Data Set menu.  To switch to another data set, simply 
select it in the menu. 
 
 

 
 

Change Data Set Menu 
 
 

13.2  PC*MILER|Energy Routing and Mapping 

With the NA – Streets US/Canada Energy data set selected, you are ready to 
generate PC*MILER routes directly to the latitude/longitude points where 
wellheads or other oil and gas facilities are located, using leased or bonded access 
roads to get there.  For lat/long formats that PC*MILER accepts, see section 
3.6.14. 
 
Energy-specific access roads will be unlabeled on the RouteMap.  When the 
cursor is placed over one of these roads, an “Energy Road” tooltip will appear. 
 
The two maps shown below are zoomed into a wellhead location near Killdeer, 
North Dakota.  The first map is drawn in PC*MILER’s default map style.  The 
map style in the second image has been changed to Satellite to reveal the terrain 
surrounding the route.  To change the map style, select the Map tab > Customize 
group > Map Style.  An internet connection is required to display satellite images. 
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Route To a Wellhead Near Killdeer, ND 
 
 
 

 

Route To a Wellhead Near Killdeer, ND – Satellite Image 
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Using ALK’s RouteSync® 
 
 

RouteSync by ALK Technologies is an add-on to PC*MILER that provides a 
direct link between two of ALK’s existing industry-standard products: 
PC*MILER routing, mileage and mapping software in the back office and CoPilot 
Truck – ALK’s truck-specific GPS navigation system – in the vehicle.   
 
PC*MILER, synced with CoPilot Truck in the cab via RouteSync, now offers the 
transportation and logistics industry a unique tracking and route management 
capability.  PC*MILER route compliance ensures that CoPilot Truck will follow 
user-defined routing (Practical, Hazmat, Toll Discouraged, etc.) that includes 
vehicle dimensions and custom avoid/favor routing preferences. 
 
RouteSync is an ideal fit for motor carriers, private fleets and owner operators 
who need to maintain operational consistency between PC*MILER operations 
and accounting functions in the back office and their vehicles.  It offers a flexible 
approach to minimizing the mileage variance between actual and planned routes. 
 

14.1  Background 

PC*MILER is ALK’s routing, mileage and mapping software that’s used by 98% 
of the top motor carriers and 96% of the top freight transportation firms in North 
America.  The U.S. Department of Defense (DoD), the General Services 
Administration (GSA) and the Federal Motor Carrier Safety Administration 
(FMCSA) also rely on PC*MILER as their worldwide distance standard.  
Accuracy and reliability have positioned PC*MILER as the industry-standard 
software for the transportation and logistics industry. 
 
CoPilot Truck is ALK’s industry-leading GPS navigation system for truck-
specific routing, offering an easy-to-use, intuitive interface with spoken turn-by-
turn directions and easy to follow, non-distracting guidance displays. Unlike 
standard car navigation systems, its routing takes into account known truck 
restrictions to provide safe, reliable routes on truck-legal roads.  CoPilot Truck 
calculates routes based on vehicle size and load type to avoid commercial truck 
restrictions, including vehicle dimension limits, low bridge heights and 
clearances, left-hand and dangerous turns, U-turns, and hazardous materials 
restrictions.  
 
ALK’s RouteSync integrates these two products, now allowing PC*MILER-
optimized routes to be sent directly to CoPilot Truck running on numerous mobile 
devices.   
 
From the back office, RouteSync can be used in the following ways: 

14 C
h

ap
te

r 



  
 

 
 Chapter 14:  Using ALK’s RouteSync® 191 

 Send route information and trip options to CoPilot Truck 

 Send a PC*MILER route’s lat/long sequence to CoPilot Truck  
 Tell CoPilot Truck how strictly its in-cab directions should follow the exact 

route calculated by PC*MILER for a trip 
 Track a vehicle’s route in real-time for up-to-the-minute actual vs. planned 

route comparisons 
 Receive real-time Out-of-Route warnings and a trip summary of OoR events 

and miles on each trip 
 Send avoid/favor routing preferences to all or selected vehicles. 
 

14.2  Getting Started With RouteSync 

To begin using RouteSync, you must first sign in to the RouteSync account you 
set up when installing and activating PC*MILER.  After signing in, you can start 
sending invitations to CoPilot Truck-equipped vehicles to begin communication.  
(Note that CoPilot users must be registered with CoPilot Live Messaging to be 
connected via RouteSync.)  As soon as a vehicle’s driver accepts your invitation, 
you’ll be able to send routes and route options to that vehicle and receive alerts 
from CoPilot. 
 

 
 
Follow these steps to get started:  
 
1.  Open PC*MILER and click the Sign In button in the RouteSync tab.  The 

Account Sign-In prompt will pop up: 
 

 

RouteSync Account Sign-In 
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2.  Enter the email address and password that were used for activation when 
PC*MILER with RouteSync was installed.  You have the option to have 
PC*MILER save your email and password to speed up future sign-ins (check 
“Save my username and password”).  You can also choose to bypass this 
sign-in step in the future (check “Automatically Sign-In”).  

 
3. If the sign-in attempt was successful, you will see the yellow icon on the 

RouteSync tab turn green: 
 

 
 
 

4. Now you can start inviting CoPilot-equipped vehicles to be managed through 
RouteSync.  To send a new invitation, select the RouteSync tab > Vehicle 
Manager and click Add Vehicles. 

 

 
 

RouteSync Vehicle Manager 
 

 
5.  At the prompt, enter an Email Address for a CoPilot Truck user who is 

registered with CoPilot Live Messaging.  Optionally, you can also enter a 
Vehicle Nickname for identification (this can be any name you choose, and 
may be edited at any time in the future).  Click Add to send the invitation.  

 

 



  
 

 
 Chapter 14:  Using ALK’s RouteSync® 193 

6.   If the email address identifies an existing Live Messaging user, a Live 
message requesting tracking access will be sent and the CoPilot user will have 
the option to accept or decline the tracking request.  

 
7. When the driver accepts, you will see the email and vehicle name (if entered) 

appear in the Vehicle List.  Now two-way communication is established with 
the vehicle you added.  In the Manager you can click Update Vehicles at any 
time to see the updated online/offline status and last known position of all 
listed vehicles. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8.  You can click the Invitation List button in the RouteSync tab to see a list of 
invitations that have not yet received a response. If CoPilot is turned off on 
the driver’s device, “Offline” will appear in the Status column.  If the driver 
has not yet accepted an invitation but is online, the invitation will remain 
“Pending” on the list.  To delete an invitation, highlight it on the list and click 
Delete.  

 

 
 

Invitation Received in CoPilot 

Invitation List in PC*MILER

Managed Vehicles Listed 
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14.3  Sending Routes and Options from PC*MILER to CoPilot 

The two general types of input that CoPilot Truck can receive in the cab from 
PC*MILER – managed routes and unmanaged avoid/favor routing preferences – 
are described below in sections 13.3.1 and 13.3.2.    
 
 

14.3.1  Managed Routes 
 
By sending a route to CoPilot, the sender requires the driver to adhere precisely to 
that route – in other words, the route is managed.  The route and the driver’s  
adherence to it are governed by a small number of options (described below).  
The location of a vehicle on a managed route can be displayed on the PC*MILER 
RouteMap and updated every five minutes. Whenever the CoPilot-equipped 
vehicle goes off route, CoPilot generates an alert for the driver that is also sent to 
the PC*MILER-side dispatcher (see section 14.4).  
 
To send and track a managed route from PC*MILER to a vehicle equipped with 
CoPilot Truck with Live Messaging, follow the steps below. 
 
 
1. Run a PC*MILER Route 

 

In PC*MILER, open a route window, then enter and run the route you wish to 
send. 

 
 
2. Open the Send Route Dialog 
 

In the route window, click the gear button and select RouteSync from the 
menu to open the Send Route dialog. 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

RouteSync Send Route Dialog in PC*MILER 
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3. Select a Vehicle 
 

In the RouteSync tab on the Ribbon, click the Vehicle Manager button then 
highlight a vehicle on the list in the Vehicle Manager.  When you select a 
vehicle, its Last Known Position will be displayed if it is available.  If a 
vehicle is offline, the route that you send will be received when CoPilot Truck 
comes back online in the vehicle. 

 
 

 

Checking the Last Known Position of a Vehicle 
 
 
4.  Add the Vehicle Location to the Planned Trip 
 

   
Click the Set As Origin button to set the vehicle’s last known position as the 
planned route’s origin, replacing the original origin.  In this case, the entire 
trip becomes managed and the Out-of-Route miles get reported on a per trip 
basis. 

 

 
Alternatively, you can click the Add Before Origin button to insert the last 
known position of the vehicle before the planned trip’s origin.  In this case, 
the leg from the truck’s last known position to the trip’s origin will be 
unmanaged. 

 
 
5. Enter Vehicle Dimensions and Weight 
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The vehicle dimensions and weight that will be used for the route are 
displayed under Vehicle Options.  Click Use CoPilot Settings to query 
CoPilot for its vehicle options.  When the query is returned, the vehicle 
options in CoPilot will replace the current PC*MILER options.  If necessary, 
you can then choose to modify the new options before sending the route to 
CoPilot.  

 
 
6. Select Route Compliance Level 
 

 
Under Route Compliance, you can select how strictly CoPilot should try to 
return to the original route once the driver is out-of-route: 

Strict:  This is the default compliance level.  CoPilot will try to navigate back 
to the original route at all costs, even if it means the driver needs to turn 
around and drive back to rejoin the prescribed route. 

Moderate:  CoPilot will try to navigate back to the original route but will take 
into account the driver’s current position in relation to the destination; i.e. 
CoPilot will try to rejoin the prescribed route as it navigates towards the 
destination, but along a route that is more reasonable than what the Strict 
compliance level would follow. 

Minimal:  At this level, the original prescribed route is not taken into 
consideration.  The route taken may still rejoin the original route, but its first 
objective is to navigate to the destination from the driver’s current position. 

 
 
7. Set Distance for OoR Alert 
 

 
By default, an out-of-route alert is generated when the CoPilot-equipped 
vehicle reaches a point .2 miles away from the planned route.  To adjust this 
distance, type in a new distance under Alert. 
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8. Send the Route 
 

 
Click the active Send to Copilot button in the lower right corner of the Send 
Route dialog. 
 
The CoPilot user will receive an onscreen alert that a managed route has been 
sent and may choose to click OK to accept the route, or Details to see driving 
instructions.   
 
As soon as the driver interacts with the alert, the route will be accepted.  If the 
driver does not interact with the alert, after 20 seconds the trip will 
automatically be accepted.  At this point CoPilot Truck will begin navigation 
along the PC*MILER route that was sent. 

 
 

 

New Managed Route Alert in CoPilot 
 
 

14.3.2  Sending Avoids/Favors As Unmanaged Options 
 
Avoid/favor routing preferences may be sent via RouteSync to an individual 
vehicle to modify an existing trip, or they can be sent to multiple vehicles.  These 
preferences are considered to be unmanaged options because once they are 
received and accepted in CoPilot they are retained until the next time they are 
edited. Once received, these preferences will affect any routes that are run 
subsequently, regardless of whether the route is a PC*MILER-managed route or 
one that the driver initiated independently. 
 
Avoid/favor preferences that are sent via RouteSync can include only road 
segments that are part of a set in the Avoid/Favor Manager in PC*MILER.  
Whole road and whole state preferences cannot be included. 
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Follow these steps to send avoids/favors: 
 
1.  To send avoid/favor preferences, first you must create them in PC*MILER  

(see section 11.1 on how to do this). 
 
2. When the preferences are set the way you want them, click Vehicle Manager 

in the RouteSync tab on the Ribbon. 

3. Highlight one or more vehicles by clicking them on the list.  The list has a 
multiple selection property (you can hold down the Ctrl or Shift key to 
simultaneously select multiple vehicles). 

4. Click Send Avoids/Favors to send. 

5. When a vehicle receives the avoids/favors, a status message will appear in 
CoPilot and the favored and avoided roads will be highlighted on the CoPilot 
map. 

 
 

14.3.3  Editing, Updating and Tracking Vehicles 
 
RouteSync allows the PC*MILER user to view, edit and update vehicle 
information, and control the display of vehicles on the PC*MILER RouteMap. 
 

 
14.3.3.1  Viewing, Editing and Updating Vehicles 

 
 

 

RouteSync Send Route Dialog 
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View Vehicles: 

Click View Vehicle List in the Send Route dialog to see a scrollable list of all 
vehicles that have been accepted to be managed.  Vehicles are listed by their 
associated CoPilot ID under Truck Name.  For each vehicle, PC*MILER 
displays an online/offline Status in the first column and the last known position.  
For trucks that are offline, the date/time when the truck went offline is shown.  
The last column in the Vehicle List records the last message that the dispatcher 
received from a truck, including a timestamp and message description.  From the 
Vehicle Manager you can zoom to a vehicle on the map if needed. 
 

Delete Vehicle: 

You can delete a CoPilot ID and not track that CoPilot user any longer by 
highlighting it on the list in the Vehicle Manager and clicking Delete Vehicle. 
The list has a multiple selection property (hold down the Ctrl or Shift key when 
selecting multiple vehicles) that enables you to delete more than one vehicle at a 
time.  The driver does not receive an alert from this action. 
 

Update Vehicles: 

To refresh the information in the Vehicle Manager, click Update Vehicles. 
   

Edit Vehicle: 

Click Edit Vehicle in the Vehicle Manager to edit the vehicle name that is 
highlighted.  The email address that identifies the CoPilot device cannot be edited.       
 
 

 

Editing a Vehicle Name 
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14.3.3.2  Vehicle Display on the RouteMap 
 
 

 
Two Online Vehicles on the RouteMap 

 
 
Zoom to Selected Vehicle: 

In the Vehicle Manager, click Zoom to Selected Vehicle to zoom to the vehicle’s 
last known position on the PC*MILER map (Display Vehicle Locations on Map 
must be checked at the bottom of the window).  The vehicle is represented on the 
map by a round green or red icon – green for online or red for offline.  
 
 

 
 

 

Update Frequency: 

To set how often the information in the list will be automatically updated, click 
the down arrow in the “Update every…” pick list at the bottom of the Vehicle 
Manager and choose an interval from the choices provided.  By default the list 
automatically updates every 5 minutes. 
 

14.4  CoPilot Truck OoR Output to PC*MILER 

An out-of-route alert is automatically triggered whenever a vehicle’s position 
departs .2 miles from the managed route it received via RouteSync.  (The distance 
that triggers an alert can be changed – see section 14.3.1.)   
 
Another alert is generated when the vehicle rejoins the planned route.  These 
alerts appear on the CoPilot user’s screen, and are also sent via CoPilot Live 
messaging to the PC*MILER user at the email address that is registered with 
RouteSync. 
 
Additionally, when a vehicle reaches its destination, a RouteSync Summary of 
OoR Events is triggered and sent to the PC*MILER user.  This summary lists all 
OoR events that occurred on the trip and shows the total OoR mileage for the trip. 
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Rejoined Route Alert in CoPilot  
 
 
 

 

Summary of OoR Events in Email Message 
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Technical Support & 
Contact Options 

 
 

15.1  Technical Support Options 

ALK Technologies offers one year of free unlimited technical support to all 
registered users of PC*MILER.  If  you have unresolved questions about 
PC*MILER or problems with the software, visit us at www.alk.com/support for 
answers to frequently asked questions (FAQ) or contact us in the following ways:  
 
Phone: 1.800.377.6453, ext 2 or 609.683.0220, ext. 2.  When calling, ask for 

PC*MILER Technical Support.  Please be sure to have your PC*MILER 
Product Key Code, version number, Windows® version number, and 
hardware configuration information (manufacturer, speed, and monitor 
type) available before your call.  Please include this information in your 
message if you are contacting us by email. 

Email: pcmsupport@alk.com, or from within PC*MILER select the Help tab > 
Technical Support group > Email Technical Support and follow the 
instructions provided.  If you have any supporting material, click Attach 
File and browse for the file(s) to attach. Attachments of supporting 
documentation can be up to 10 MB.  When ready, click Send.  ALK's 
technical support team will send a confirmation email to the email entered 
in the "Enter your email here" field when it is received. 

Web Site: www.pcmiler.com 

Hours: 9:00am – 5:00pm EST, Mon-Fri 
 

To print additional copies of this User’s Guide, click the Windows Start button, 
then go to All Programs > PCMILER 28 > User Guides and select the .pdf file 
from the sub-menu.   
 

15.2  PC*MILER Sales Contact Information 

Phone: 800.377.6453, ext 1  
  609.683.0220 (outside the U.S.) 
Fax:  609.683.0290 
Email: sales@alk.com 
Web Site: www.alk.com/support 
Address: ALK Technologies, Inc. 
     457 North Harrison Street 
     Princeton, NJ 08540  USA 
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15.3  PC*MILER Updates 

A new, updated release of PC*MILER is offered on an annual basis.  Updated 
releases of PC*MILER|Worldwide and DTOD data are provided annually several 
months following the PC*MILER for North America release.  Updates may 
include revisions to the software, updates to the North American and Worldwide 
highway and road network databases, and updates to the SPLC and ZIP/Postal 
code databases.  To order your annual update contact ALK Technologies, Inc. or 
your PC*MILER dealer.  
 
Between version releases, updates and patches are periodically made available as 
the need arises.  These may include corrections to any reported errors in the 
software or data, or access to new data releases (for applicable products and 
license types*).  Note that these patches and updates are now cumulative, 
meaning they include items from previously released patches/updates of the same 
type.  ALK strongly recommends checking for the most current updates 
regularly.  This is recommended for all users, but particularly important for 
PC*MILER|Tolls users. 
 
* NOTE:  If a PC*MILER product was purchased along with signing up for 
ALK’s Annual Update Program (AUP license purchase), customers are entitled to 
use PC*MILER during the term of their agreement as well as to receive data 
updates when and if available.  AUP licensed users will have access to the base 
version data set as well as to any more recently released data sets as they are 
available, if they are downloaded and installed.  For those who do not sign up for 
the AUP, PC*MILER is purchased as a Perpetual license which entitles the 
licensed user to any available software patches released for the purchased version, 
and any available toll data updates if PC*MILER|Tolls was purchased.   
 
For more information on upgrading a Perpetual license to an AUP license, please 
contact an Enterprise Solutions account executive at 800-377-6453 ext. 1 or email 
sales@alk.com.  
 
 

15.3.1  Using the Updater Tool 
 

Provided you have an internet connection, follow the steps below to install the 
available updates: 

 
1. Close all open instances of PC*MILER and its connectivity products.  If a 

third-party program that accesses any PC*MILER component is running, 
(for example, PC*MILER|Connect or PC*MILER|Mapping) it must be 
closed before updating. 

2. Open PC*MILER and select the Help tab > Windows group > Check for 
Updates.  The PC*MILER Updater dialog will open.  The Updater first 
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checks for valid license information and then begins checking for available 
updates. 

 

 
PC*MILER Updater 

 
3. When the search for updates is complete you will see all available updates 

listed.  In the Download & Install drop-down menu next to each available 
update, select either Download & Install to download and install right away 
or Download to download now and install at a later time.  

 
 

 

Download and Install Options 
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4. Note the version number of the updates you will be downloading so you can 
check if the update installed properly (see Step 7 below).   

5. Selecting either option will begin the download process.  You will see the 
progress of the download reflected in a progress bar.  If any PC*MILER-
related application is open, you will be prompted to close it.  After closing 
the application(s), click OK to continue with the download. 

 

 

 
6. If you chose Download and Install, the InstallShield Wizard will open when 

the download is finished.  Follow the instructions to complete the installation.  
After installing, you will see the update listed under “Installed Updates” in the 
Updater window. 

 
If you chose Download, when the download is finished the button to the 
right will now say “Install”.  You can complete the installation as described 
above at any time in the future by opening the Updater window and clicking 
Install. 
 

7. As a last step, check to make sure the update installed properly.  Select the 
Help tab > About group > About… and look for the Software Version 
number under “This Product is Licensed To”.  It should match what you 
downloaded. 

 
 

 

PC*MILER “About” Window 
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15.4  Reporting Data Errors 

ALK Technologies' North American and Worldwide highway and road networks 
– the primary databases used by PC*MILER products – undergo constant 
revision.  Revisions include the addition of new roads, upgrades of improved 
sections of highway, and addition of new Key Cities. 
 
ALK Technologies is dedicated to maintaining a highway and street-level 
network of the highest quality and welcomes user input and comments.  If you 
encounter any problems related to mileage, routing or highway names, from 
within PC*MILER please go to the Help tab > Technical Support group > Email 
Data Correction and follow the on-screen guidelines to submit the issue.  
Supporting documentation can be attached to this email form, just click the 
Attach File button and browse for the file.  Attachments can be up to 10 MB.  
 
When you are finished filling out the form, click Send to send it.  Our digital 
cartography team will make every effort to correctly analyze and incorporate your 
data suggestions.  
 
You can also print a copy of the route, highlighting the problem (such as incorrect 
road name, mileage, city name, postal code) and send it to: 
  

 

PC*MILER Products Division 
ALK TECHNOLOGIES, INC. 

457 North Harrison Street · Princeton, NJ 08540 · USA 
Email: pcmsupport@alk.com 
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        About ALK Technologies 
 
 
 

ALK® Technologies, Inc., a Trimble® company headquartered in Princeton, NJ, 
was founded in 1979 as a transportation industry pioneer. ALK harnesses the 
power of information technology to enhance transportation and mobility, 
supporting competitive advantage and improved quality of life. 
 
Today, ALK is a global leader in GeoLogistics® Solutions and navigation 
software. GeoLogistics is our portfolio of specialized enterprise solutions for 
worldwide routing, mileage and mapping, used by customers in transportation, 
logistics, manufacturing, mobile workforce management and government. Our 
commercial trucking applications are relied upon by companies worldwide and 
our in-vehicle GPS navigation and route guidance solutions are among the most 
award-winning solutions in the world. 
 
We pride ourselves on being a market leader in transportation and travel 
technology. ALK's leadership in applying that technology to solve important 
problems continues as strongly today as when we began over 30 years ago. Now 
part of Trimble's international Transportation and Logistics division, we remain 
committed to providing our customers with solutions that work for them to lower 
costs, improve service and safety and minimize harm to the environment. 
 
See section 16.1 below for an overview of ALK’s Enterprise Solutions.  For 
detailed product information, visit us at www.alk.com or www.pcmiler.com. 
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16.1  Enterprise Solutions from ALK Technologies 

Contact an Enterprise Solutions account executive to find out how the following 
value-add on solutions can boost productivity, reduce out-of-route mileage and 
improve return on investment. 
 
 PC*MILER — PC*MILER is truck-specific, point to point routing, mileage 

and mapping software that the transportation and logistics industry depends on 
to succeed. Accuracy and reliability have positioned PC*MILER as the 
software used by 98 of the top 100 motor carrier, 46 of the top 50 freight 
transportation firms and 47 of the top 50 logistics companies in North 
America. The U.S. Department of Defense (DoD), the General Services 
Administration (GSA) and the Federal Motor Carrier Safety Administration 
(FMCSA) also rely on PC*MILER as their worldwide distance standard. 

 PC*MILER|Streets — PC*MILER|Streets is street-level routing, mileage 
and mapping software designed to provide dock-to-dock driving directions 
over truck-specific routes.  It includes all the features and functionality of 
PC*MILER plus an enhanced street-level routing network, map database, and 
street address database. Ensure that your vehicles and loads get to the right 
place using the most precise truck-specific route possible, taking into 
consideration truck-preferred and truck-restricted roads. PC*MILER|Streets 
data is available for the U.S. and Canada and, with PC*MILER|Worldwide, 
for many countries outside North America. 

 
 PC*MILER|Traffic — PC*MILER|Traffic calculates more accurate transit 

times and ETAs with real time, historical and predictive traffic speed data. It 
allows visualization of traffic trends directly on the PC*MILER map. 
PC*MILER|Traffic includes a “Fastest” routing type that optimizes overall 
transit time, taking into account real time traffic congestion and predictive 
traffic speeds, by the hour and by the day. 
 

 PC*MILER|Tolls — PC*MILER|Tolls calculates truck-specific toll costs 
based on a vehicle’s weight, axle count, trailer count, transaction type (cash or 
discount program), and time of day travel in the U.S. and Canada. It is driven 
by the same technology and map data set as ALK's industry-standard 
PC*MILER routing, mileage and mapping software. When generating routes, 
truck-specific toll costs are added into a route’s overall calculation. Determine 
whether it's more cost-effective to take a toll route, or a non-toll route with a 
few additional miles, before routing a vehicle.  

 
 PC*MILER|HazMat — PC*MILER|HazMat generates point to point and 

street-level routes, mileage and driving directions for hauling hazardous 
materials and dangerous goods in the U.S. and Canada. Federal government 
mandates state that shippers and carriers are to implement security plans 
regarding the transport of hazardous materials. A major step in that process is 
providing drivers with routes and mileage that ensure compliance with these 
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federal, state/province and local restrictions and route designations. To ensure 
fleet and driver safety, PC*MILER|HazMat identifies where drivers should 
legally be traveling for the particular type of hazardous commodity they are 
hauling.  
 

 PC*MILER|Worldwide — PC*MILER|Worldwide is point-to-point routing, 
mileage and mapping software that generates routes, distances, maps and 
driving directions over the entire international highway network. Employ the 
functionality of PC*MILER across worldwide data coverage, including 
Africa, Asia, Europe, the Middle East, North America, Oceania, and South 
America.  Additionally, street-level address data modules are available for the 
U.S. and Canada, Europe, and many countries in worldwide regions. 
 

 PC*MILER|Rail — PC*MILER|Rail is the rail and logistics industry's 
leading routing, mileage and mapping software. Widely used in fuel surcharge 
calculation, equipment management, rail car mileage auditing, carrier 
selection, rate determination and negotiation, and ad valorem tax reporting, 
PC*MILER|Rail determines actual operating or fuel surcharge routes and 
mileage using station/state abbreviations or railroad industry codes. Through 
ALK’s close working relationship with all major railroads, PC*MILER|Rail 
features the most accurate digital representation of the North American rail 
network. 
 

 CoPilot® Truck — CoPilot Truck offers an easy to use, intuitive interface 
with spoken turn-by-turn directions and easy to follow, non-distracting 
guidance displays. Unlike standard car navigation systems, it calculates 
efficient routes based on your vehicle profile information, routing parameters 
and load type, including hazardous materials.  Running conveniently on a 
wide range of smartphones, tablets and laptops, CoPilot Truck uses street-
level ALK Digital Maps™ enhanced with industry standard PC*MILER 
truck-specific attributes featuring 3.52 million commercial truck restrictions 
and allowances. With powerful multi-stop routing it effortlessly provides the 
optimal route for any itinerary, while automatically avoiding commercial 
truck restrictions to increase efficiency, reduce mileage and help avoid costly 
fines and vehicle damage. 

 
 

CONNECTIVITY and INTERFACE PRODUCTS 
   
 PC*MILER|Connect — PC*MILER|Connect seamlessly interfaces 

PC*MILER routes, mileage and reports with third-party and custom systems, 
such as transportation and logistics management software systems. Client 
applications are able to retrieve PC*MILER distances, detailed driving 
directions, drive times, state-by-state mileage summaries, stop optimization 
functionalities and more. 
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 Multi-Version Switch (MVS) — Multi-Version Switch is a high-end 
function of PC*MILER|Connect that serves as an integration tool designed to 
simultaneously support multiple versions of PC*MILER that are installed on 
one server or on several different servers.  Instead of manually querying data 
from each individual version, the Multi-Version Switch functions as the main 
connection point to programmatically gain access to the version of choice. 
 

 PC*MILER Web Services — PC*MILER Web Services is an integration 
tool designed to efficiently fulfill all PC*MILER routing, mileage and 
mapping transactions in a simple hardware and software-agnostic system 
interface to any computing platform. It offers a standardized way of 
integrating PC*MILER with Web Services, .NET, or Web-based applications 
using XML (Extensible Markup Language) and SOAP (Simple Object Access 
Protocol) over an Internet Protocol Backbone – all developed in Microsoft® 
.NET. 
 

 PC*MILER|Mapping — PC*MILER|Mapping seamlessly interfaces 
PC*MILER routes and geographic data on maps for integration with real-time 
dispatch and operations analysis programs. PC*MILER|Mapping allows you 
to include commands in spreadsheets, databases and custom systems to obtain 
a visual overview of your data.  
 

 PC*MILER|Spreadsheets — PC*MILER|Spreadsheets gives you the ability 
to access PC*MILER features and functionality from within your own 
spreadsheet software. Generate point-to-point or street-level mileage and drive 
times within a spreadsheet program, and then use built-in functions to 
summarize and analyze your data. PC*MILER|Spreadsheets provides a 
seamless interface with PC*MILER and Microsoft® Excel®, allowing you to 
perform customized data analyses. 
 

 PC*MILER|BatchPro — PC*MILER|BatchPro is a batch-processing tool 
that permits the simultaneous processing of large volumes of lanes (set as 
origin/destination pairs) entered as city/state combinations, ZIP or Postal 
Codes, or latitude/longitude coordinates rather than entering routes 
individually. It gives you the ability to generate routes, mileage, as well as 
cost and time information per route. 
 

 PC*MILER|TCP/IP — PC*MILER|TCP/IP is an integration tool that 
provides an interface to PC*MILER|Connect running in a Windows® 
environment to an application residing on another platform. Through a 
TCP/IP network, client applications can access a text-based interface to call 
PC*MILER|Connect's features and functionality. The interface opens cross 
platform communications in a thread-safe manner, giving you the flexibility to 
transmit the output of PC*MILER|Connect to multiple networks within your 
organization.  
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ADDITIONAL DATA MODULES 

 Canadian Postal Codes — Enhance the PC*MILER database with six-digit 
Canadian Postal Codes.  Enables search and display of corresponding 
city/province names to enter them as stops along a route. 
 

 Standard Point Location Codes (SPLC) — Add SPLC to the PC*MILER 
database to generate routes for rating and freight bill auditing.  A SPLC 
provides each point originating freight and each point receiving freight in 
North America with a unique code number that identifies the point by its 
geographic location. 

 PC*MILER|Energy — Provides oil- and gas-specific data and facilities 
including bonded or leased access roads.  Users can now generate driving 
directions that take them directly to facilities including off-road wells, 
compressor stations, and plants. 

 
 

 
 

1-800-377-MILE 
www.alk.com 

ALK Technologies, Inc. 
457 North Harrison Street 

Princeton, New Jersey 08540 
U.S.A. 
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Appendix A: 
 Access Policies from National Network 

Routes to Terminals & Services 
 
 
 

Reasonable Access Defined 
 

Reasonable access is the deviation allowed between the specified truck network and any allowable stops.  
A stop is typically defined as a place of loading or unloading or facilities for food, fuel, repairs and rest.  
In all cases, local signs and warnings prohibiting truck access or providing an applicable restriction take 
precedence over reasonable access rules.  In some states the deviation allowed from the National Network 
or 53 Foot Designated Truck Network may vary depending on the roads used to get to the stop.  If this is 
the case, we have differentiated between reasonable access from the truck route and on a state highway  
versus local roads. 
 
For detailed information about pre-approved routes, contact the individual states. 

 

State National Network 
53 Foot Designated  
Truck Network 
 

Notes 

Alabama 1 mile on state 
highways;  1 mile on 
local roads 
 

1 mile on state highways; 
1 mile on local roads 

One mile of reasonable access is 
allowed as long as the pavement is 
12' wide. 

Alaska Unlimited on state 
highways;  Unlimited  
on local roads 
 

Unlimited on state highways; 
Unlimited on local roads 

 

Arizona 1 mile on state 
highways; 1 mile on 
local roads 
 

1 mile on state highways;               
1 mile on local roads 

 

Arkansas Unlimited on state 
highways;  1 mile on  
local roads 
 

Unlimited on state highways;         
1 mile on local roads 

 

California 1 mile on state 
highways; 1 mile on 
local roads 

No access on state highways;         
No access on local roads 

Reasonable access of one mile off 
of the National Network is only 
allowed where the "S" sign 
indicates. 

Colorado Unlimited on state 
highways; 1 mile on  
local roads 
 

Unlimited on state highways;         
1 mile on local roads 

 

Connecticut 1 mile on state 
highways; 1 mile on 
local roads 

1 mile on state highways;               
1 mile on local roads 

Reasonable access of one mile is 
permitted for access to a place of 
loading or unloading, terminals, 
food, fuel, repair and rest.  
Commercial vehicles are not 
allowed on parkways. 
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Delaware 1 mile on state 
highways; 1 mile on 
local roads 
 

1 mile on state highways;               
1 mile on local roads 

 

District of 
Columbia 

No access on state 
highways; No access  
on local roads 
 

No access on state highways;         
No access on local roads 

All 53' trailers require a permit for 
reasonable access. 

Florida Unlimited on state 
highways; 1 mile on  
local roads 
 

Unlimited on state highways;         
1 mile on local roads 

 

Georgia 1 mile on state 
highways; 1 mile on 
local roads 
 

1 mile on state highways;               
1 mile on local roads 

 

Hawaii Unlimited on state 
highways; Unlimited  
on local roads 
 

Unlimited on state highways; 
Unlimited on local roads 

 

Idaho Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 
 

Illinois 5 miles on state 
highways; 1 mile on  
local roads 

1 mile on state highways;               
1 mile on local roads 

Reasonable access of five miles 
on state roads from Class I-III 
roads is permitted unless 
prohibited by other restrictions, 
such as height or weight, to a 
place of loading or unloading, 
terminals, food, fuel, repair and 
rest.  Reasonable access of one 
mile on roads from Class I roads 
is permitted unless prohibited by 
other restrictions, such as height 
or weight, to a place of loading or 
unloading, terminals, food, fuel, 
repair and rest. 
 

Indiana Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

Non-permitted loads are legally 
allowed to travel on all state roads 
without other restrictions, such as 
height or weight, to their delivery 
point. 

Iowa 1 mile on state 
highways; 1 mile on 
local roads 
 

1 mile on state highways;               
1 mile on local roads 

 

Kansas Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 
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Kentucky 5 miles on state 
highways; 1 mile on  
local roads 

1 mile on state highways;               
1 mile on local roads 

Please see Section 5 of 603 KAR 
5:250,"Selection of National 
Truck Network highways and 
reasonable access to these 
highways", for exceptions. 
 

Louisiana 10 mile on state 
highways; 10 mile on 
local roads 
 

10 mile on state highways;             
10 mile on local roads 

 

Maine Unlimited on state 
highways; 1 mile on  
local roads 
 

Unlimited on state highways;         
1 mile on local roads 

 

Maryland 1mile allowed off for 
food, fuel, rest or 
shortest practical route 
to destination. 

1mile allowed off for food, fuel, 
rest or shortest practical route to 
destination. 

The shortest practical access route 
between a highway designated [as 
national network or state oversize] 
and a truck terminal, point of 
origin or destination cargo must 
be used. 

 

Massachusetts Unlimited on state 
highways; 1 mile on  
local roads 
 

Unlimited on state highways;         
1 mile on local roads 

 

Michigan 5 miles on state 
highways; 1 mile on  
local roads 

5 miles on state highways;              
No access on local roads 

Reasonable access of five miles is 
permitted on state roads for access 
to terminals, food, fuel, repair and 
rest.  Reasonable access of one 
mile on local roads is only 
permitted off of interstate 
freeways. 

Minnesota 1 mile on state 
highways; 1 mile on 
local roads 
 

1 mile on state highways;               
1 mile on local roads 

 

Mississippi Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer does not require a 
permit, so it is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 

Missouri 10 miles on state 
highways; 10 miles  
on local roads 
 

10 miles on state highways;            
10 miles on local roads 

 

Montana Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer does not require a 
permit, so it is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 
 

Nebraska Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

Non-permitted loads are legally 
allowed to travel on all state roads 
without other restrictions, such as 
height or weight, to their delivery 
point. 
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Nevada Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer does not require a 
permit, so it is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 
 

New 
Hampshire 

1 mile on state 
highways; 1 mile on 
local roads 

1 mile on state highways;               
1 mile on local roads 

Reasonable access of one mile is 
permitted on roads without other 
restrictions, such as height or 
weight, to a place of loading or 
unloading, terminals, food, fuel, 
repair and rest. 

New Jersey Unlimited on state 
highways; Unlimited  
on local roads 
 

Unlimited on state highways; 
Unlimited on local roads 

 

New Mexico Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer does not require a 
permit, so it is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 

New York 1 mile on state 
highways; 1 mile on 
local roads 
 

No access on state highways;         
No access on local roads 

 

North 
Carolina 

3 miles on state 
highways; 3 miles on 
local roads 

3 miles on state highways;             
3 miles on local roads 

Reasonable access of three miles 
is permitted on roads without 
other restrictions, such as height 
or weight, to terminals, food, fuel, 
repair and rest. 
 

North Dakota Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer does not require a 
permit, so it is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 

Ohio Unlimited on state 
highways; 1 mile on  
local roads 
 

Unlimited on state highways;         
1 mile on local roads 

 

Oklahoma Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

Non-permitted loads are legally 
allowed to travel on all state roads 
without other restrictions, such as 
height or weight, to their delivery 
point. 

Oregon 1 mile on state 
highways; 1 mile on 
local roads 
 

1 mile on state highways;               
1 mile on local roads 

 

Pennsylvania 1 mile on state 
highways; 1 mile on 
local roads 
 

1 mile on state highways;               
1 mile on local roads 

One mile of reasonable access is 
allowed as long as the pavement is 
10' wide. 

Rhode Island 1 mile on state 
highways; 1 mile on 
local roads 
 

1 mile on state highways;               
1 mile on local roads 
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South 
Carolina 

Unlimited on state 
highways; 1 mile on  
local roads 
 

Unlimited on state highways;        
1 mile on local roads 

 

South Dakota Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 

Tennessee 15 miles on state 
highways; 15 miles on 
local roads 
 

15 miles on state highways;            
15 miles on local roads 

 

Texas Unlimited on state 
highways; 1 mile on 
local roads 
 

Unlimited on state highways;         
1 mile on local roads 

 

Utah Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer does not require a 
permit, so it is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 
 

Vermont 1 mile on state 
highways; 1 mile on 
local roads 
 

1 mile on state highways;               
1 mile on local roads 

 

Virginia 1 mile on state 
highways;                       
1 mile on local roads 

1 mile on state highways;               
1 mile on local roads 

Reasonable access of one mile is 
permitted on roads without other 
restrictions, such as height or 
weight, to terminals, food, fuel, 
repair and rest, except in 
incorporated towns and cities as 
well as Henrico and Arlington 
Counties. 
 

Washington Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

A 53' trailer does not require a 
permit, so it is legally allowed to 
travel on all state roads without 
other restrictions, such as height 
or weight, to their delivery point. 
 

West Virginia 2 miles on state 
highways; 2 miles on 
local roads 

2 miles on state highways;              
2 miles on local roads 

Reasonable access of two miles is 
permitted on roads without other 
restrictions, such as height or 
weight, to terminals, food, fuel, 
repair and rest. 
 

Wisconsin 5 miles on state 
highways; 5 miles on 
local roads 
 

5 miles on state highways;              
5 miles on local roads 

 

Wyoming Unlimited on state 
highways; 1 mile on  
local roads 

Unlimited on state highways;         
1 mile on local roads 

Non-permitted loads are legally 
allowed to travel on all state roads 
without other restrictions, such as 
height or weight, to their delivery 
point. 
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Appendix B:  Canadian Counties 
 
 
 
Canadian Counties that are included in the PC*MILER database are listed below.  
Regional districts and other types of sub-divisions that exist within Canadian 
provinces and territories are not included in the database and therefore not listed. 
 
 

Province Counties 

  
Alberta (No Counties) 
  
British Columbia (Contains a County) 

 CARIBOO 
  
Manitoba (No Counties) 
  
New Brunswick (Contains Counties) 

 ALBERT 
 CARLETON 
 CHARLOTTE 

 GLOUCESTER 
 KENT 
 KINGS 
 MADAWASKA 
 NORTHUMBERLAND 
 QUEENS 
 RESTIGOUCHE 
 ST. JOHN 
 SUNBURY 
 VICTORIA 
 WESTMORLAND 
 YORK 
  

Newfoundland and 
Labrador 

(No Counties) 

 
Northwest 
Territories 

(No Counties) 
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Nova Scotia (Contains Counties) 

 ANNAPOLIS 
 ANTIGONISH 
 CAPE BRETON 
 COLCHESTER 
 CUMBERLAND 
 DIGBY 
 GUYSBOROUGH 
 HALIFAX 
 HANTS 
 INVERNESS 
 KINGS 
 LUNENBURG 
 PICTOU 
 QUEENS 
 RICHMOND 
 SHELBURNE 
 VICTORIA 
 YARMOUTH 
  
Nunavut 
 
Ontario 
 

(No Counties) 
 
(Contains Counties) 
 

 ALGOMA 
 BRANT 
 BRUCE 
 COCHRANE 
 DUFFERIN 
 DURHAM 
 ELGIN 

 ESSEX 
 FRONTENAC 
 GREY 
 HALDIMAND 
 HALIBURTON 
 HASTINGS 
 HURON 
 KENORA 
 KENT 

 LAMBTON 
 LANARK 
 MANITOULIN 
 MIDDLESEX 
 NIPISSING 

NORFOLK 
 NORTHUMBERLAND 
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 OTTAWA - CARLETON 
 OXFORD 
 PARRY SOUND 
 PERTH 
 PETERBOROUGH 
 PRINCE EDWARD 
 RAINY RIVER 
 RENFREW 
 SIMCOE 
 SUDBURY RM 
 THUNDER BAY 
 TIMISKAMING 
 TORONTO 
 VICTORIA 
 WELLINGTON 
  
Prince Edward 
Island 

(Contains Counties) 

 KINGS 
 PRINCE 
 QUEENS 
  

Quebec (Contains Counties) 
 

 ABITIBI-TEMISCAMINGUE 
 BAS-SAINT-LAURENT 
 CENTRE-DU-QUEBEC 
 CHAUDIERE-APPALACHES 

 COMMUNAUTE-URBAINE-DE-MONTREAL 
 COTE-NORD 
 ESTRIE 
 GASPESIE - ILES-DE-LA-MADELEINE 
 LA CÔTE-DE-BEAUPRÉ 
 LANAUDIERE 
 LAURENTIDES 
 LES JARDINS-DE-NAPIERVILLE 
 MAURICIE 
 MONTEREGIE 
 MONTREAL 
 OUTAOUAIS 
 QUEBEC 
 ROUVILLE 
 SAGUENAY - LAC-SAINT-JEAN 

 
Saskatchewan (No Counties) 
 
Yukon (No Counties) 
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Appendix C: 
 State/Province/Country Abbreviations 

 
 
 

States/Provinces in the U.S., Canada, Mexico & Australia 
(For country abbreviations in North America, see “North America” in the Country Codes section 
of this appendix) 

 
States/Provinces in the United States & Canada 
 
AL Alabama 

AK Alaska 

AB Alberta 

AZ Arizona 

AR Arkansas 

BC British Columbia 

CA California 

CO Colorado 

CT Connecticut 

DE Delaware 

DC Dist. of Columbia 

FL Florida 

GA Georgia 

ID Idaho 

IL Illinois 

IN Indiana  

IA Iowa 

KS Kansas 

KY Kentucky 

LA Louisiana 

ME Maine 

MB Manitoba 

MD Maryland 

MA Massachusetts 

MI Michigan 

MN Minnesota 

MS Mississippi 

MO Missouri 

MT Montana 
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NE Nebraska 

NV Nevada 

NB New Brunswick 

NH New Hampshire 

NJ New Jersey 

NM New Mexico 

NY New York 

NL Newfoundland & Labrador 

NC North Carolina 

ND North Dakota 

NT Northwest Territory 

NS Nova Scotia 

NU* Nunavut 

OH Ohio 

OK Oklahoma 

ON Ontario 

OR Oregon 

PA Pennsylvania 

PE Prince Edward Island 

QC Quebec 

RI Rhode Island  

SK Saskatchewan 

SC South Carolina 

SD South Dakota 

TN Tennessee 

TX Texas 

UT Utah 

VT Vermont 

VA Virginia 

WA Washington 

WV West Virginia 

WI Wisconsin 

WY Wyoming 

YT Yukon Territory 
 
 

* The same FIPS code, NU, is used for Nicaragua and the province of Nunavut, Canada in the 
PC*MILER database. 
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Mexican Estados 

AG Aguascalientes 

BJ Baja California 

BS Baja California Sur 

CP Campeche 

CH Chiapas 

CI Chihuahua 

CU Coahuila de Zaragoza 

CL Colima 

DF Distrito Federal 

DG Durango 

GJ Guanajuato 

GR Guerrero 

HG Hidalgo 

JA Jalisco 

EM Mexico (Estado) 

MH Michoacan de Ocampo 

MR Morelos 

NA Nayarit 

NX * Nuevo Leon 

OA Oaxaca 

PU Puebla 

QA Queretaro Arteaga 

QR Quintana Roo 

SL San Luis Potosi 

SI Sinaloa 

SO Sonora 

TA Tabasco 

TM Tamaulipas 

TL Tlaxcala 

VZ Veracruz 

YC Yucatan 

ZT Zacatecas 
 

*  Please note that by default, “NX” is used for Nuevo Leon because the province of 
Newfoundland and Labrador in Canada already utilizes “NL” in the database.  However, there 
is an option that sets “NL” as the abbreviation for Nuevo Leon: in the File application menu, 
select Application Settings… .  In the NL Abbreviation drop-down, select Use for Nuevo Leon 
and click Save. 
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Australian Jurisdictions 
When using the Streets Oceania data set, use the jurisdiction abbreviations 
below instead of a country code to enter stops in Australia. 

ACT Australian Capital Territory 

NSW New South Wales 

NT Northern Territory 

QLD Queensland 

SA South Australia 

TAS Tasmania 

VIC Victoria 

WA Western Australia 
 
 

Country Codes For All Worldwide Regions 
 

Africa 
 

COUNTRY NAME  FIPS  ISO2  ISO3  GENC2  GENC3 

Algeria  AG  DZ  DZA  DZ  DZA 

Angola  AO  AO  AGO  AO  AGO 

Benin  BN  BJ  BEN  BJ  BEN 

Botswana  BC  BW  BWA  BW  BWA 

Burkina Faso  UV  BF  BFA  BF  BFA 

Burundi  BY  BI  BDI  BI  BDI 

Cameroon  CM  CM  CMR  CM  CMR 

Cape Verde  CV  CV  CPV  CV  CPV 

Central African Republic  CT  CF  CAF  CF  CAF 

Chad  CD  TD  TCD  TD  TCD 

Comoros  CN  KM  COM  KM  COM 

Congo Democratic Republic (Kinshasa)  CG  CG  COD  CD  COD 

Congo, Republic of the (Brazzaville)  CF  CD  COG  CG  COG 

Djibouti  DJ  DJ  DJI  DJ  DJI 

Egypt  EG  EG  EGY  EG  EGY 

Equatorial Guinea  EK  GQ  GNQ  GQ  GNQ 

Eritrea  ER  ER  ERI  ER  ERI 

Ethiopia  ET  ET  ETH  ET  ETH 

Gabon  GB  GA  GAB  GA  GAB 

Gambia  GA  GM  GMB  GM  GMB 

Ghana  GH  GH  GHA  GH  GHA 

Guinea  GV  GN  GIN  GN  GIN 

Guinea‐Bissau  PU  GW  GNB  GW  GNB 

Ivory Coast (Côte d’Ivoire)  IV  CI  CIV  CI  CIV 

Kenya  KE  KE  KEN  KE  KEN 
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COUNTRY NAME  FIPS  ISO2  ISO3  GENC2  GENC3 

Lesotho  LT  LS  LSO  LS  LSO 

Liberia  LI  LR  LBR  LR  LBR 

Libya  LY  LY  LBY  LY  LBY 

Madagascar  MA  MG  MDG  MG  MDG 

Malawi  MI  MW  MWI  MW  MWI 

Mali  ML  ML  MLI  ML  MLI 

Mauritania  MR  MR  MRT  MR  MRT 

Mauritius  MP  MU  MUS  MU  MUS 

Mayotte  MF  YT  MYT  YT  MYT 

Morocco  MO  MA  MAR  MA  MAR 

Mozambique  MZ  MZ  MOZ  MZ  MOZ 

Namibia  WA  NA  NAM  NA  NAM 

Niger  NG  NE  NER  NE  NER 

Nigeria  NI  NG  NGA  NG  NGA 

Reunion  RE  RE  REU  RE  REU 

Rwanda  RW  RW  RWA  RW  RWA 

Saint Helena  SH  SH  SHN  SH  SHN 

Sao Tome and Principe  TP  ST  STP  ST  STP 

Senegal  SG  SN  SEN  SN  SEN 

Seychelles  SE  SC  SYC  SC  SYC 

Sierra Leone  SL  SL  SLE  SL  SLE 

Somalia  SO  SO  SOM  SO  SOM 

South Africa  SF  ZA  ZAF  ZA  ZAF 

South Sudan  OD  SD  SDW  SS  SSD 

Sudan  SU  SD  SDN  SD  SDN 

Swaziland  WZ  SZ  SWZ  SZ  SWZ 

Tanzania  TZ  TZ  TZA  TZ  TZA 

Togo  TO  TG  TGO  TG  TGO 

Tunisia  TS  TN  TUN  TN  TUN 

Uganda  UG  UG  UGA  UG  UGA 

Western Sahara  WI  EH  ESH  EH  ESH 

Zambia  ZA  ZM  ZMB  ZM  ZMB 

Zimbabwe  ZI  ZW  ZWE  ZW  ZWE 
 

 

Asia 
 

Afghanistan  AF  AF  AFG  AF  AFG 

Armenia  AM  AM  ARM  AM  ARM 

Azerbaijan  AJ  AZ  AZE  AZ  AZE 

Bangladesh  BG  BD  BGD  BD  BGD 

Bhutan  BT  BT  BTN  BT  BTN 

Brunei   BX  BN  BRN  BN  BRN 

Burma (Myanmar)  BM  MM  MMR  MM  MMR 
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COUNTRY NAME  FIPS  ISO2  ISO3  GENC2  GENC3 

Cambodia  CB  KH  KHM  KH  KHM 

China  CH  CN  CHN  CN  CHN 

Georgia  GG  GE  GEO  GE  GEO 

Hong Kong  HK  HK  HKG  HK  HKG 

India  IN  IN  IND  IN  IND 

Indonesia  ID  ID  IDN  ID  IDN 

Japan  JA  JP  JPN  JP  JPN 

Kazakhstan  KZ  KZ  KAZ  KZ  KAZ 

Korea, North  KN  KP  PRK  KP  PRK 

Korea, South  KS  KR  KOR  KR  KOR 

Kyrgyzstan  KG  KGZ  KGZ  KG  KGZ 

Laos  LA  LA  LAO  LA  LAO 

Macao  MC  MO  MAC  MO  MAC 

Malaysia  MY  MY  MYS  MY  MYS 

Maldives  MV  MV  MDV  MV  MDV 

Mongolia  MG  MN  MNG  MN  MNG 

Nepal  NP  NP  NPL  NP  NPL 

Pakistan  PK  PK  PAK  PK  PAK 

Papua New Guinea  PP  PG  PNG  PG  PNG 

Philippines  RP  PH  PHL  PH  PHL 

Singapore  SN  SG  SGP  SG  SGP 

Sri Lanka  CE  LK  LKA  LK  LKA 

Taiwan  TW  TW  TWN  TW  TWN 

Tajikistan  TI  TJ  TJK  TJ  TJK 

Thailand  TH  TH  THA  TH  THA 

Timor‐Leste  TT  ‐‐  TMP  TL  TMP 

Turkmenistan  TX  TM  TKM  TM  TKM 

Uzbekistan  UZ  UZ  UZB  UZ  UZB 

Vietnam  VM  VN  VNM  VN  VNM 
 
 

Europe 
 

Akrotiri  AX  ‐‐  ‐‐  QZ  XQZ 

Albania  AL  AL  ALB  AL  ALB 

Andorra  AN  AND  AND  AD  AND 

Austria  AU  A  AUT  AT  AUT 

Belarus  BO  BY  BLR  BY  BLR 

Belgium  BE  B  BEL  BE  BEL 

Bosnia and Herzegovina  BK  BIH  BIH  BA  BIH 

Bulgaria  BU  BG  BGR  BG  BGR 

Croatia  HR  HR  HRV  HR  HRV 

Cyprus  CY  CY  CYP  CY  CYP 

Czech Republic  EZ  CZ  CZE  CZ  CZE 
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COUNTRY NAME  FIPS  ISO2  ISO3  GENC2  GENC3 

Denmark  DA  DK  DNK  DK  DNK 

Dhekelia  DX  ‐‐  ‐‐  XD  XXD 

Estonia  EN  EST  EST  EE  EST 

Faroe Islands  FO  FO  FRO  FO  FRO 

Finland  FI  FIN  FIN  FI  FIN 

France  FR  FR  FRA  FR  FRA 

Germany  GM  D  DEU  DE  DEU 

Gibraltar  GI  GI  GIB  GI  GIB 

Greece  GR  GR  GRC  GR  GRC 

Guernsey  GK  ‐‐  ‐‐  GG  GGY 

Hungary  HU  H  HUN  HU  HUN 

Iceland  IC  IS  ISL  IS  ISL 

Ireland  EI  IE  IRL  IE  IRL 

Isle of Man  IM  ‐‐  IMN  IM  IMN 

Italy  IT  I  ITA  IT  ITA 

Jersey  JE  ‐‐  ‐‐  JE  JEY 

Kosovo  KV  ‐‐  XKS  XK  XKS 

Latvia  LG  LV  LVA  LV  LVA 

Liechtenstein  LS  FL  LIE  LI  LIE 

Lithuania  LH  LT  LTU  LT  LTU 

Luxembourg  LU  L  LUX  LU  LUX 

Macedonia  MK  MK  MKD  MK  MKD 

Malta  MT  M  MLT  MT  MLT 

Moldova  MD  MD  MDA  MD  MDA 

Monaco  MN  MC  MCO  MC  MCO 

Montenegro  MJ  MNE  MNE  ME  MNE 

Netherlands  NL  NL  NLD  NL  NLD 

Norway  NO  N  NOR  NO  NOR 

Poland  PL  PL  POL  PL  POL 

Portugal  PO  P  PRT  PT  PRT 

Romania  RO  RO  ROU  RO  ROU 

Russia  RS  RUS  RUS  RU  RUS 

San Marino  SM  RSM  SMR  SM  SMR 

Serbia  RI  SRB  SRB  RS  SRB 

Slovakia  LO  SK  SVK  SK  SVK 

Slovenia  SI  SLO  SVN  SI  SVN 

Spain  SP  E  ESP  ES  ESP 

Svalbard and Jan Mayen Islands  SV  SJ  SJM  XR  XSV 

Sweden  SW  S  SWE  SE  SWE 

Switzerland  SZ  CH  CHE  CH  CHE 

Turkey  TU  TR  TUR  TR  TUR 

Ukraine  UP  UA  UKR  UA  UKR 

United Kingdom  UK  GB  GBR  GB  GBR 
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COUNTRY NAME  FIPS  ISO2  ISO3  GENC2  GENC3 

Vatican City  VT  V  VAT  VA  VAT 

Middle East 
Bahrain  BA  BH  BHR  BH  BHR 

Gaza Strip  GZ  ‐‐  XGZ  XG  XGZ 

Iran  IR  IR  IRN  IR  IRN 

Iraq  IZ  IQ  IRQ  IQ  IRQ 

Israel  IS  IL  ISR  IL  ISR 

Jordan  JO  JO  JOR  JO  JOR 

Kuwait  KU  KW  KWT  KW  KWT 

Lebanon  LE  LB  LBN  LB  LBN 

Oman  MU  OM  OMN  OM  OMN 

Palestinian Territory  ‐‐  PS  PSE  PS  PSE 

Qatar  QA  QA  QAT  QA  QAT 

Saudi Arabia  SA  SA  SAU  SA  SAU 

Syria  SY  SY  SYR  SY  SYR 

United Arab Emirates  AE  AE  ARE  AE  ARE 

West Bank  WE  ‐‐  XWB  XW  XWB 

Yemen  YM  YE  YEM  YE  YEM 

    

North America 
 

Bermuda  BD  BM  BMU  BM  BMU 

Canada  CA  CA  CAN  CA  CAN 

Greenland  GL  GL  GRL  GL  GRL 

Guantanamo Bay  ‐‐  ‐‐  ‐‐  A2  AX2 

Mexico  MX  MX  MEX  MX  MEX 

Puerto Rico*  PR*  PR  PRI  PR  PRI 

Saint Pierre and Miquelon  SB  PM  SPM  PM  SPM 

United States  US  US  USA  US  USA 

Virgin Islands, U.S.  VQ  VI  VIR  VI  VIR 

* Note: “PR” for Puerto Rico is a USPS code, not a FIPS code. 
 

 

Oceania 
 

American Samoa  AQ  AS  ASM  AS  ASM 

Australia*  AS  AU  AUS  AU  AUS 

Cook Islands  CW  CK  COK  CK  COK 

Fiji  FJ  FJ  FJI  FJ  FJI 

French Polynesia  FP  PF  PYF  PJ  PYF 

French Southern and Antarctic Islands  FS  TF  ATF  TF  ATF 

Guam  GQ  GU  GUM  GU  GUM 
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COUNTRY NAME  FIPS  ISO2  ISO3  GENC2  GENC3 

Kiribati  KR  KI  KIR  KI  KIR 

Marshall Islands  RM  MH  MHL  MH  MHL 

Micronesia, Federated States of  FM  FM  FSM  FM  FSM 

Midway Island  MQ  UM  ‐‐  QM  XMW 

Nauru  NR  NR  NRU  NR  NRU 

New Caledonia  NC  NC  NCL  NC  NCL 

New Zealand  NZ  NZ  NZL  NZ  NZL 

Niue  NE  NU  NIU  NU  NIU 

Norfolk Island  NF  NF  NFK  NF  NFK 

Northern Mariana Islands  CQ  MP  MNP  MP  MNP 

Palau  PS  PW  PLW  PW  PLW 

Pitcairn Islands  PC  PN  PCN  PN  PCN 

Samoa (Western Samoa)  WS  WS  WSM  WS  WSM 

Solomon Islands  BP  SB  SLB  SB  SLB 

Tokelau  TL  TK  TKL  TK  TKL 

Tonga  TN  TO  TON  TO  TON 

Tuvalu  TV  TV  TUV  TV  TUV 

Vanuatu  NH  VU  VUT  VU  VUT 

Wake Island  WQ  WQ  XWK  QW  XWK 

Wallis and Futuna  WF  WF  WLF  WF  WLF 

* When using the Streets Oceania data set, use state or territory abbreviations 
instead of the country abbreviation for locations in Australia – see the Jurisdictions 
section at the beginning of this appendix. 

    

South America 
 

Anguilla  AV  AI  AIA  AI  AIA 

Antigua and Barbuda  AC  AG  ATG  AG  ATG 

Argentina  AR  AR  ARG  AR  ARG 

Aruba  AA  AW  ABW  AW  ABW 

Bahamas  BF  BS  BHS  BS  BHS 

Barbados  BB  BB  BRB  BB  BRB 

Belize  BH  BZ  BLZ  BZ  BLZ 

Bolivia  BL  BO  BOL  BO  BOL 

Bonaire, Sint Eustatius, Saba  ‐‐  ‐‐  ‐‐  BQ  BES 

Brazil  BR  BR  BRA  BR  BRA 

Caribbean Netherlands  NT  AN  BES  BQ  BES 

Cayman Islands  CJ  KY  CYM  KY  CYM 

Chile  CI  CL  CHL  CL  CHL 

Colombia  CO  CO  COL  CO  COL 

Costa Rica  CS  CR  CRI  CR  CRI 

Cuba  CU  CU  CUB  CU  CUB 

Curacao  UC  ‐‐  ‐‐  CUW  CUW 
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COUNTRY NAME  FIPS  ISO2  ISO3  GENC2  GENC3 

Dominica  DO  DM  DMA  DM  DMA 

Dominican Republic  DR  DO  DOM  DO  DOM 

Ecuador  EC  EC  ECU  EC  ECU 

El Salvador  ES  SV  SLV  SV  SLV 

Falkland Islands (Islas Malvinas)  FK  FK  FLK  FK  FLK 

French Guiana  FG  GF  GUF  GF  GUF 

Grenada  GJ  GD  GRD  GD  GRD 

Guadeloupe  GP  GP  GLP  GP  GLP 

Guatemala  GT  GT  GTM  GT  GTM 

Guyana  GY  GY  GUY  GY  GUY 

Haiti  HA  HT  HTI  HT  HTI 

Honduras  HO  HN  HND  HN  HND 

Jamaica  JM  JM  JAM  JM  JAM 

Martinique  MB  MQ  MTQ  MQ  MTQ 

Montserrat  MH  MS  MSR  MS  MSR 

Nicaragua*  NU*  NI  NIC  NI  NIC 

Panama  PM  PA  PAN  PA  PAN 

Paraguay  PA  PY  PRY  PY  PRY 

Peru  PE  PE  PER  PE  PER 

Saint Barthalemy  TB  ‐‐  BLM  BL  BLM 

Saint Kitts and Nevis Islands  SC  KN  KNA  KN  KNA 

Saint Lucia  ST  LC  LCA  LC  LCA 

Saint Martin  RN  ‐‐  MAF  MF  MAF 

Saint Vincent and the Grenadines  VC  VC  VCT  VC  VCT 

Sint Maarten  NN  ‐‐  SXM  SX  SXM 

Suriname  NS  SR  SUR  SR  SUR 

Trinidad and Tobago  TD  TT  TTO  TT  TTO 

Turks and Caicos Islands  TK  TC  TCA  TC  TCA 

Uruguay  UY  UY  URY  UY  URY 

Venezuela  VE  VE  VEN  VE  VEN 

Virgin Islands, British  VI  VG  VGB  VG  VGB 

 * The same FIPS code, NU, is used for Nicaragua and the province of Nunavut, Canada in the PC*MILER 
database. 

 
 
 
Official Sources 
 
FIPS Country Codes: 
http://geonames.nga.mil/ggmagaz/geonames4.asp and  
http://www.state.gov/s/inr/rls/4250.htm 
 
ISO2 Country Codes: 
http://www.iso.org/iso/country_codes/iso_3166_code_lists/english_country_names_and_code_elements.htm and 
http://www.iso.org/iso/english_country_names_and_code_elements#s 
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ISO 3 Country Codes: 
http://unstats.un.org/unsd/methods/m49/m49alpha.htm 
 
GENC2 and GENC3 Country Codes (Geopolitical Entities, Names and Codes): 
Issued by the National Geospatial-Intelligence Agency 
https://www1.nga.mil/Pages/default.aspx  
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Appendix D:  
Valid Entries for Street Addresses 

 
 
 

For PC*MILER|Streets users, valid directional and street type abbreviations for street address 
entry in North America are listed below.  Spelling out the whole word is also acceptable.  
Capitalization is not necessary. 

 

Directional Synonyms for Address Entry – Prefix or Suffix 

Full Spelling Valid in PC*MILER 

EAST E 
EAST E. 
NORTH N 
NORTH N. 
NORTH NO 
NORTH NO. 
NORTHEAST N-E 
NORTHEAST N.E 
NORTHEAST N.E.
NORTHEAST NE 
NORTHEAST NE. 
NORTHEAST NORTH-EAST
NORTHWEST N-W
NORTHWEST N.W
NORTHWEST. N.W.
NORTHWEST NORTH-WEST
NORTHWEST NW 
NORTHWEST NW.
SOUTH S 
SOUTH S. 
SOUTH SO 
SOUTH SO. 
SOUTHEAST S-E 
SOUTHEAST S.E 
SOUTHEAST S.E. 
SOUTHEAST SE 
SOUTHEAST SE. 
SOUTHEAST SOUTH-EAST
SOUTHWEST S-W
SOUTHWEST S.W 
SOUTHWEST S.W.
SOUTHWEST SOUTH-WEST
SOUTHWEST SW 
SOUTHWEST SW. 
WEST W 
WEST W. 
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        Synonyms for Street Types 
 

Full Spelling Valid in 
PC*MILER 

Alley Al 
Alley Al. 
Alley All 
Alley All. 
Alley Aly 
Alley Aly. 
Arcade Arc 
Arcade Arc. 
Avenue Av 
Avenue Av. 
Avenue Avda 
Avenue Avda. 
Avenue Ave 
Avenue Ave. 
Avenue Aven 
Avenue Aven. 
Avenue Avenida 
Boulevard Blvd 
Boulevard Blvd. 
Boulevard Boul 
Bridge Brdg 
Bridge Brdg. 
Bridge Brg 
Bridge Brg. 
Bypass Byp 
Bypass Byp. 
Causeway Cause 
Causeway Cause. 
Causeway Cswy 
Causeway Cswy. 
Center Cntr 
Center Cntr. 
Center Ctr 
Center Ctr. 
Circle Cir 
Circle Cir. 
Circle Circ 
Circle Circ. 
Court Crt 
Court Crt. 
Court Ct 
Court Ct. 
Cove Cv 
Cove Cv. 
Crescent Cres 

Full Spelling Valid in 
PC*MILER 

Crescent Cres. 
Crescent Cresc 
Crescent Cresc. 
Crescent Cresnt 
Crossing Crsg 
Crossing Crsg. 
Crossing Xing 
Crossing Xing. 
Drive Dr 
Drive Dr. 
Drive Drv 
Drive Drv. 
Expressway Expr 
Expressway Expr. 
Expressway Expy 
Expressway Expy. 
Expressway Exwy 
Expressway Exwy. 
Farm-To-Market F-M 
Farm-To-Market FM 
Freeway Frwy 
Freeway Frwy. 
Harbor Hbr 
Heights Hts 
Highway Hwy 
Highway Hwy. 
Highway Hy 
Highway Hy. 
Lane La 
Lane La. 
Lane Ln 
Lane Ln. 
Loop Lp 
Loop Lp. 
Mall Ml 
Mall Ml. 
Motorway Mrwy 
Motorway Mrwy. 
Motorway Mtrwy 
Motorway Mtrwy. 
Motorway Mtwy 
Motorway Mtwy. 
Overpass Over 
Overpass Over. 
Overpass Ovps 
Overpass Ovps. 
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Full Spelling Valid in 
PC*MILER 

Overpass Ovrps 
Overpass Ovrps. 
Park Pk 
Park Pk. 
Park Prk 
Park Prk. 
Parkway Pkwy 
Parkway Pkwy. 
Parkway Prkwy 
Parkway Prkwy. 
Pass Ps 
Pass Ps. 
Path Pth 
Path Pth. 
Pike Pke 
Pike Pke. 
Place Pl 
Place Pl. 
Place Pla 
Place Pla. 
Place Plac 
Place Plac. 
Place Plc 
Place Plc. 
Plaza Plz 
Plaza Plz. 
Point Pnt 
Point Pnt. 
Point Pt 
Point Pt. 
Ramp Rmp 
Ramp Rmp. 
Road Rd 
Road Rd. 
Skyway Skwy 
Skyway Skwy. 
Square Sq 
Square Sq. 
Square Sqr 
Square Sqr. 
Street St 
Street St. 
Street Str 
Street Str. 
Terrace Ter 
Terrace Ter. 
Terrace Terr 

Full Spelling Valid in 
PC*MILER 

Terrace Terr. 
Terrace Trc 
Terrace Trc. 
Throughway Thruway 
Throughway Thwy 
Throughway Thwy. 
Trafficway Tfcwy 
Trafficway Tfcwy. 
Trafficway Tfwy 
Trafficway Tfwy. 
Trafficway Trwy 
Trail Trl 
Trail Trl. 
Tunnel Tun 
Tunnel Tun. 
Tunnel Tunl 
Tunnel Tunl. 
Tunnel Tunn 
Tunnel Tunn. 
Turnpike Tpk 
Turnpike Tpk. 
Turnpike Tpke 
Turnpike Tpke. 
Underpass Unp 
Underpass Unp. 
Underpass Unps 
Underpass Unps. 
Underpass Unrps 
Underpass Unrps. 
Way Wy 
Way Wy. 
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Appendix E:  
Default Road Speeds by Jurisdiction 

 
 

The table below lists PC*MILER default road speeds worldwide by jurisdiction and PC*MILER road category.  Speeds are in miles per 
hour.  To see default speeds for any world region, you can also open the Route Options dialog box, select a world region, then click the 
Road Speeds tab and select a country from the pick list.   
 

Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

Africa  Algeria  AG  62  56  56  43  50  31  37  25  25  18  26  26 

Africa  Angola  AO  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Botswana  BC  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Benin  BN  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Burundi  BY  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Chad  CD  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Congo  CF  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Republic of Congo  CG  50  45  40  35  35  30  30  25  20  15  23  23 

Africa  Cameroon  CM  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Comoros  CN  50  45  40  35  35  30  30  25  20  15  15  15 

Africa 
Central African 
Republic  CT  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Cape Verde  CV  50  45  40  35  35  30  30  25  20  15  23  23 

Africa  Djibouti  DJ  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Egypt  EG  62  56  56  43  37  31  25  25  18  12  27  27 

Africa  Equatorial Guinea  EK  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Eritrea  ER  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Ethiopia  ET  62  56  56  43  50  31  37  25  25  18  18  18 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

Africa  Gambia  GA  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Gabon  GB  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Ghana  GH  62  56  56  43  50  31  37  25  25  18  21  21 

Africa  Guinea  GV  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Ivory Coast  IV  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Kenya  KE  62  56  56  43  50  31  37  25  25  18  21  21 

Africa  Liberia  LI  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Lesotho  LT  50  45  40  35  35  30  30  25  20  15  23  23 

Africa  Libya  LY  50  45  40  35  35  30  30  25  20  15  26  26 

Africa  Madagascar  MA  50  45  40  35  35  30  30  25  20  15  15  15 

Africa  Mayotte  MF  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Malawi  MI  62  56  56  43  50  31  37  25  25  18  21  21 

Africa  Mali  ML  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Morocco  MO  62  56  56  43  50  31  37  25  25  18  26  26 

Africa  Mauritius  MP  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Mauritania  MR  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Mozambique  MZ  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Niger  NG  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Nigeria  NI  62  56  56  43  50  31  37  25  25  18  21  21 

Africa  South  Sudan  OD  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Guinea‐Bissau  PU  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Reunion  RE  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Rwanda  RW  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Seychelles  SE  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  South Africa  SF  68  62  56  43  50  31  37  25  25  18  24  24 

Africa  Senegal  SG  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Saint Helena  SH  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Sierra Leone  SL  50  45  40  35  35  30  30  25  20  15  18  18 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

Africa  Somalia  SO  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Sudan  SU  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Togo  TO  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Sao Tome and Principe  TP  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Tunisia  TS  62  56  56  43  50  31  37  25  25  18  26  26 

Africa  Tanzania  TZ  62  56  56  43  50  31  37  25  25  18  23  23 

Africa  Uganda  UG  62  56  56  43  50  31  37  25  25  18  23  23 

Africa  Burkina Faso  UV  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Namibia  WA  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Western Sahara  WI  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Swaziland  WZ  50  45  40  35  35  30  30  25  20  15  18  18 

Africa  Zambia  ZA  50  45  40  35  35  30  30  25  20  15  21  21 

Africa  Zimbabwe  ZI  62  56  50  43  43  31  37  25  25  18  23  23 

Asia  Afghanistan  AF  56  56  56 50 43 31 31 25 25 18 16  16 

Asia  Azerbaijan  AJ  56  56  56  50  43  31  31  25  25  18  20  20 

Asia  Armenia  AM  56  56  56  50  43  31  31  25  25  18  16  16 

Asia  Bahrain  BA  56  56  56  50  43  31  31  25  25  18  25  25 

Asia  Bangladesh  BG  50  50  50  43  43  31  31  18  25  12  21  21 

Asia  Burma (Myanmar)  BM  50  50  50  43  43  31  31  18  25  12  21  21 

Asia  Bhutan  BT  50  50  50  43  43  31  31  18  25  12  16  16 

Asia  Brunei Darussalam  BX  50  50  50  43  43  31  31  18  25  12  18  18 

Asia  Cambodia  CB  56  56  56  50  43  31  31  25  25  18  18  18 

Asia  Sri Lanka  CE  50  50  50  43  43  31  31  18  25  12  22  22 

Asia  China  CH  68  62  56  50  50  31  37  18  25  12  27  27 

Asia  Cyprus  CY  56  56  56  50  43  31  31  25  25  18  25  25 

Asia  Georgia  GG  56  56  56  50  43  31  31  25  25  18  20  20 

Asia  Gaza Strip  GZ  56  56  56  50  43  31  31  25  25  18  25  25 

Asia  Hong Kong  HK  31  31  31  31  25  25  18  18  12  12  27  27 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

Asia  Indonesia  ID  50  50  50  43  43  31  31  18  25  12  27  27 

Asia  India  IN  62  49  49  37  43  31  31  18  25  12  22  22 

Asia 
Iran (Islamic Republic 
of)  IR  56  56  56  50  43  31  31  25  25  18  25  25 

Asia  Israel  IS  56  56  56  50  43  31  31  25  25  18  25  25 

Asia  Iraq  IZ  56  56  56  50  43  31  31  25  25  18  21  21 

Asia  Japan  JA  62  56  50  43  37  31  31  18  25  12  26  26 

Asia  Jordan  JO  56  56  56  50  43  31  31  25  25  18  16  16 

Asia  Kyrgyzstan  KG  56  56  56  50  43  31  31  25  25  18  16  16 

Asia  Korea, North  KN  56  56  56  50  43  31  31  25  25  18  21  21 

Asia  Korea, South  KS  56  56  56  50  43  31  31  25  25  18  21  21 

Asia  Kuwait  KU  56  56  56  50  43  31  31  25  25  18  20  20 

Asia 
Lao People's 
Democratic Republic  LA  56  56  56  50  43  31  31  25  25  18  16  16 

Asia  Lebanon  LE  56  56  56  50  43  31  31  25  25  18  25  25 

Asia  Macao  MC  50  50  50  43  43  31  31  18  25  12  27  27 

Asia  Mongolia  MG  56  56  56  50  43  31  31  25  25  18  16  16 

Asia  Oman  MU  56  56  56  50  43  31  31  25  25  18  21  21 

Asia  Maldives  MV  56  56  56  50  43  31  31  25  25  18  22  22 

Asia  Malaysia  MY  50  50  50  43  43  31  31  18  25  12  27  27 

Asia  Nepal  NP  50  50  50  43  43  31  31  18  25  12  16  16 

Asia  Pakistan  PK  56  56  56  50  43  31  31  25  25  18  21  21 

Asia  Papua New Guinea  PP  50  50  50  43  43  31  31  18  25  12  18  18 

Asia  Qatar  QA  56  56  56  50  43  31  31  25  25  18  25  25 

Asia  Philippines  RP  50  50  50  43  43  31  31  18  25  12  25  25 

Asia  Saudi Arabia  SA  62  56  56  43  37  31  31  18  25  12  25  25 

Asia  Singapore  SN  56  56  56  50  43  31  31  25  25  18  27  27 

Asia  Syrian Arab Republic  SY  56  56  56  50  43  31  31  25  25  18  16  16 

Asia  United Arab Emirates  AE  68  62  62  56  50  37  37  25  25  18  27  27 



  

 
 Appendix E:  Default Road Speeds By Jurisdiction 239 

Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

Asia  Thailand  TH  50  50  50  43  43  31  31  18  25  12  21  21 

Asia  Tajikistan  TI  50  43  40  31  31  25  25  16  18  12  16  16 

Asia  East Timor  TT  50  50  50  43  43  31  31  18  25  12  18  18 

Asia  Taiwan  TW  50  50  50  43  43  31  31  18  25  12  25  25 

Asia  Turkmenistan  TX  56  56  56  50  43  31  31  25  25  18  20  20 

Asia  Vietnam  VM  50  50  50  43  43  31  31  18  25  12  21  21 

Asia  West Bank  WE  56  56  56  50  43  31  31  25  25  18  25  25 

Asia  Yemen  YM  56  56  56  50  43  31  31  25  25  18  21  21 

Europe  Albania  AL  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Andorra  AN  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Austria  AU  50  50  34  31  34  25  25  16  18  12  16  16 

Europe  Belgium  BE  56  56  45  31  30  25  25  16  18  12  16  16 

Europe 
Bosnia and 
Herzegovina  BK  62  43  50  31  39  25  25  16  18  12  16  16 

Europe  Belarus  BO  62  56  40  31  39  25  25  16  18  12  16  16 

Europe  Bulgaria  BU  62  62  34  31  34  25  25  16  18  12  16  16 

Europe  Denmark  DA  50  50  34  31  34  25  25  16  18  12  16  16 

Europe  Ireland  EI  50  50  40  31  39  25  25  16  18  12  16  16 

Europe  Estonia  EN  56  43  45  31  45  25  25  16  18  12  16  16 

Europe  Czech Republic  EZ  50  50  40  31  39  25  25  16  18  12  16  16 

Europe  Finland  FI  50  50  40  31  39  25  25  16  18  12  16  16 

Europe  Faroe Islands  FO  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  France  FR  56  43  40  31  31  25  25  16  18  12  16  16 

Europe  Gibraltar  GI  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Germany  GM  50  43  35  31  30  25  25  16  18  12  16  16 

Europe  Greece  GR  43  43  34  31  34  25  25  16  18  12  16  16 

Europe  Croatia  HR  50  50  34  31  34  25  25  16  18  12  16  16 

Europe  Hungary  HU  50  43  40  31  31  25  25  16  18  12  16  16 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

Europe  Iceland  IC  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Isle of Man  IM  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Italy  IT  50  43  35  31  34  25  25  16  18  12  16  16 

Europe  Kosovo  KV  50  50  34  31  34  30  25  16  18  12  16  16 

Europe  Kazakhstan  KZ  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Latvia  LG  50  50  40  31  39  25  25  16  18  12  16  16 

Europe  Lithuania  LH  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Slovakia  LO  50  50  40  37  39  30  25  16  18  12  16  16 

Europe  Liechtenstein  LS  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Luxembourg  LU  56  56  38  31  38  25  25  16  18  12  16  16 

Europe  Moldavia  MD  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Montenegro  MJ  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Macedonia  MK  43  43  34  31  34  25  25  16  18  12  16  16 

Europe  Monaco  MN  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Malta  MT  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Netherlands  NL  50  50  40  31  39  25  25  16  18  12  16  16 

Europe  Norway  NO  50  50  40  31  39  25  25  16  18  12  16  16 

Europe  Poland  PL  50  50  40  31  34  25  25  16  18  12  16  16 

Europe  Portugal  PO  50  50  34  25  34  20  25  16  18  12  16  16 

Europe  Serbia  RI  50  50  34  31  34  30  25  16  18  12  16  16 

Europe  Romania  RO  56  56  40  31  34  25  25  16  18  12  16  16 

Europe  Russian Federation  RS  62  56  40  31  39  25  25  16  18  12  16  16 

Europe  Slovenia  SI  50  50  34  31  34  25  25  16  18  12  16  16 

Europe  San Marino  SM  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Spain  SP  56  43  40  31  34  25  25  16  18  12  16  16 

Europe 
Svalbard and Jan 
Mayen Islands  SV  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Sweden  SW  50  50  40  31  39  25  25  16  18  12  16  16 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

Europe  Switzerland  SZ  50  50  40  31  39  25  25  16  18  12  16  16 

Europe  Turkey  TU  62  56  40  31  39  25  25  16  18  12  16  16 

Europe  United Kingdom  UK  60  40  46  30  32  24  25  16  18  12  16  16 

Europe  Ukraine  UP  62  56  40  31  39  25  25  16  18  12  16  16 

Europe  Uzbekistan  UZ  50  43  40  31  31  25  25  16  18  12  16  16 

Europe  Vatican City  VT  50  43  40  31  31  25  25  16  18  12  16  16 

N. America  Alberta  AB  62  62  62  43  56  37  43  37  31  25  21  21 

N. America  Aguascalientes  AG  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Alaska  AK  65  55  55  40  45  35  45  35  30  25  17  17 

N. America  Alabama  AL  68  60  55  40  45  35  45  35  30  25  15  15 

N. America  Arkansas  AR  65  55  55  40  45  35  45  35  35  25  15  15 

N. America  Arizona  AZ  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  British Columbia  BC  68  62  62  37  56  37  43  37  31  25  21  21 

N. America  Bermuda  BD  56  49  49  43  43  37  31  31  25  25  21  21 

N. America  Belize  BH  62  56  56  43  49  37  37  31  31  25  21  21 

N. America  Baja California  BJ  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Baja California Sur  BS  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  California  CA  55  55  55  40  45  30  40  30  30  25  16  16 

N. America  Chiapas  CH  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Chihuahua  CI  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Colima  CL  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Colorado  CO  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  Campeche  CP  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Costa Rica  CS  56  49  49  43  43  37  31  31  25  25  21  21 

N. America  Connecticut  CT  65  55  55  40  45  30  35  30  25  25  13  13 

N. America  Coahuila de Zaragoza  CU  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Dist. of Columbia  DC  55  50  45  40  40  35  35  30  25  25  13  13 

N. America  Delaware  DE  65  55  55  40  45  30  35  30  25  25  13  13 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

N. America  Distrito Federal  DF  62  62  43  43  37  37  31  31  25  25  23  23 

N. America  Durango  DG  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Mexico (Estado)  EM  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  El Salvador  ES  62  56  56  43  49  37  37  31  31  25  21  21 

N. America  Florida  FL  68  60  55  40  45  35  45  35  30  25  13  13 

N. America  Georgia  GA  68  60  55  40  45  35  40  30  30  25  13  13 

N. America  Guanajuato  GJ  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Greenland  GL  45  45  45  35  35  35  35  25  25  20  13  13 

N. America  Guerrero  GR  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Guatemala  GT  62  56  56  43  49  37  37  31  31  25  21  21 

N. America  Hidalgo  HG  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Hawaii  HI  60  50  45  35  35  35  25  25  25  25  13  13 

N. America  Honduras  HO  62  56  56  43  49  37  37  31  31  25  21  21 

N. America  Iowa  IA  68  55  60  40  45  35  45  35  35  25  15  15 

N. America  Idaho  ID  65  60  60  40  50  35  45  35  35  25  15  15 

N. America  Illinois  IL  65  55  55  40  45  35  45  35  35  25  15  15 

N. America  Indiana   IN  65  55  55  40  45  35  40  30  30  25  15  15 

N. America  Jalisco  JA  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Kansas  KS  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  Kentucky  KY  65  60  55  40  45  35  40  30  30  25  15  15 

N. America  Louisiana  LA  68  60  55  40  45  35  45  35  35  25  15  15 

N. America  Massachusetts  MA  65  60  55  40  45  30  35  30  25  25  13  13 

N. America  Manitoba  MB  68  62  62  43  56  37  43  37  31  25  21  21 

N. America  Maryland  MD  65  60  55  40  45  30  35  30  25  25  13  13 

N. America  Maine  ME  65  60  60  40  45  35  45  35  30  25  13  13 

N. America  Michoacan de Ocampo  MH  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Michigan  MI  60  55  55  40  45  35  40  30  30  25  18  18 

N. America  Minnesota  MN  68  60  60  40  45  35  45  35  35  25  15  15 



  

 
 Appendix E:  Default Road Speeds By Jurisdiction 243 

Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

N. America  Missouri  MO  68  60  60  40  45  35  45  35  35  25  15  15 

N. America  Morelos  MR  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Mississippi  MS  68  60  55  40  45  35  45  35  30  25  15  15 

N. America  Montana  MT  65  60  60  40  50  35  45  35  35  25  15  15 

N. America  Nayarit  NA  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  New Brunswick  NB  62  62  56  43  56  37  43  31  31  25  21  21 

N. America  North Carolina  NC  68  60  55  40  45  35  40  30  30  25  13  13 

N. America  North Dakota  ND  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  Nebraska  NE  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  New Hampshire  NH  65  60  55  40  45  35  45  35  30  25  13  13 

N. America  Nicaragua  NU  59  50  41  27  27  18  23  14  16  9  5  5 

N. America  New Jersey  NJ  65  55  55  40  45  30  35  30  25  25  13  13 

N. America 
Newfoundland and 
Labrador  NL  62  62  62  43  56  37  43  31  31  25  21  21 

N. America  New Mexico  NM  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  Nova Scotia  NS  62  62  62  43  56  37  43  31  31  25  21  21 

N. America  Northwest Territory  NT  56  56  56  43  56  37  43  31  31  25  21  21 

N. America  Nunavut  NU  59  50  41  27  27  18  23  14  16  9  5  5 

N. America  Nevada  NV  68  60  60  40  50  35  45  35  35  25  21  21 

N. America  Nuevo Leon  NX  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  New York  NY  65  60  55  40  45  30  35  30  25  25  13  13 

N. America  Oaxaca  OA  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Ohio  OH  65  60  55  40  45  35  40  30  30  25  15  15 

N. America  Oklahoma  OK  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  Ontario  ON  62  62  62  43  49  37  43  31  31  25  21  21 

N. America  Oregon  OR  55  55  50  40  45  35  40  30  30  25  16  16 

N. America  Pennsylvania  PA  65  55  55  40  45  30  35  30  25  25  13  13 

N. America  Prince Edward Island  PE  62  62  56  43  56  37  49  37  31  25  21  21 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

N. America  Panama  PM  62  56  56  43  49  37  37  31  31  25  21  21 

N. America  Puerto Rico  PR  65  55  45  40  45  30  30  30  30  25  15  15 

N. America  Puebla  PU  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Queretaro Arteaga  QA  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Quebec  QC  62  62  56  37  56  37  49  37  31  25  21  21 

N. America  Quintana Roo  QR  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Rhode Island   RI  65  55  55  40  45  30  35  30  25  25  13  13 

N. America  South Carolina  SC  68  60  55  40  45  35  40  30  30  25  13  13 

N. America  South Dakota  SD  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  Sinaloa  SI  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Saskatchewan  SK  62  62  62  43  56  37  43  37  31  25  21  21 

N. America  San Luis Potosi  SL  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Sonora  SO  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Tabasco  TA  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Tlaxcala  TL  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Tamaulipas  TM  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Tennessee  TN  68  60  55  40  45  35  40  30  30  25  15  15 

N. America  Texas  TX  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  Utah  UT  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  Virginia  VA  65  60  55  40  45  30  40  30  30  25  13  13 

N. America  Vermont  VT  65  55  55  40  45  35  45  35  30  25  15  15 

N. America  Veracruz  VZ  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Washington  WA  60  60  55  40  45  30  35  30  30  25  16  16 

N. America  Wisconsin  WI  65  60  60  40  45  35  45  35  35  25  18  18 

N. America  West Virginia  WV  68  55  55  40  45  35  35  30  30  25  15  15 

N. America  Wyoming  WY  68  60  60  40  50  35  45  35  35  25  15  15 

N. America  Yucatan  YC  68  62  56  43  49  37  43  31  31  25  23  23 

N. America  Yukon Territory  YT  56  56  56  43  56  37  49  37  31  25  21  21 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

N. America  Zacatecas  ZT  68  62  56  43  49  37  43  31  31  25  23  23 

Oceania  American Samoa  AQ  50  43  43  37  37  31  31  25  25  18  18  18 

Oceania  Australia  AS  68  56  56  43  50  37  37  25  25  18  22  22 

Oceania  Solomon Islands  BP  50  43  43  37  37  31  31  25  25  18  18  18 

Oceania 
Northern Mariana 
Islands  CQ  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Cook Islands  CW  50  43  43  37  37  31  31  25  25  18  18  18 

Oceania  Fiji  FJ  50  43  43  37  37  31  31  25  25  18  18  18 

Oceania 
Micronesia, Federated 
States of  FM  50  43  43  37  37  31  31  25  25  18  18  18 

Oceania  French Polynesia  FP  50  43  43  37  37  31  31  25  25  18  20  20 

Oceania 
French Southern and 
Antarctic Islands  FS  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Guam  GQ  45  45  45  35  35  35  35  25  25  18  18  18 

Oceania  Kiribati  KR  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Midway Island  MQ  50  43  43  37  37  31  31  25  25  18  18  18 

Oceania  New Caledonia  NC  50  43  43  37  37  31  31  25  25  18  22  22 

Oceania  Niue  NE  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Norfolk Island  NF  50  43  43  37  37  31  31  25  25  18  18  18 

Oceania  Vanuatu  NH  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Nauru  NR  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  New Zealand  NZ  62  56  56  43  43  31  37  25  25  18  23  23 

Oceania  Pitcairn  PC  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Palau  PS  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Marshall Islands  RM  50  43  43  37  37  31  31  25  25  18  18  18 

Oceania  Tokelau  TL  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Tonga  TN  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Tuvalu  TV  50  43  43  37  37  31  31  25  25  18  15  15 

Oceania  Wallis & Futuna Islands  WF  50  43  43  37  37  31  31  25  25  18  15  15 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

Oceania  Wake Island  WQ  50  43  43  37  37  31  31  25  25  18  18  18 

Oceania  Western Samoa  WS  50  43  43  37  37  31  31  25  25  18  18  18 

S. America  Aruba  AA  56  43  43  37  37  31  31  25  18  18  24  24 

S. America  Antigua and Barbuda  AC  56  43  43  37  37  31  31  25  18  18  16  16 

S. America  Argentina  AR  68  50  50  37  37  31  31  25  18  12  21  21 

S. America  Anguilla  AV  56  43  43  37  37  31  31  25  18  18  20  20 

S. America  Barbados  BB  56  43  43  37  37  31  31  25  18  18  16  16 

S. America  Bahamas  BF  56  43  43  37  37  31  31  25  18  18  26  26 

S. America  Bolivia  BL  62  50  50  37  37  31  31  25  18  12  21  21 

S. America  Brazil  BR  68  43  50  37  37  25  31  18  18  12  21  21 

S. America  Chile  CI  62  50  43  37  31  31  25  25  18  12  21  21 

S. America  Cayman Islands  CJ  56  43  43  37  37  31  31  25  18  18  20  20 

S. America  Colombia  CO  62  50  43  37  31  31  25  25  18  12  21  21 

S. America  Cuba  CU  56  43  43  37  37  31  31  25  18  18  23  23 

S. America  Dominica  DO  56  43  43  37  37  31  31  25  18  18  20  20 

S. America  Dominican Republic  DR  56  43  43  37  37  31  31  25  18  18  16  16 

S. America  Ecuador  EC  62  50  43  37  31  31  25  25  18  12  21  21 

S. America  French Guiana  FG  62  50  50  37  37  31  31  25  18  12  21  21 

S. America 
Falkland Islands 
(Malvinas)  FK  56  43  43  37  37  31  31  25  18  18  12  12 

S. America  Grenada  GJ  56  43  43  37  37  31  31  25  18  18  20  20 

S. America  Guadeloupe  GP  56  43  43  37  37  31  31  25  18  18  20  20 

S. America  Guyana  GY  62  50  50  37  37  31  31  25  18  12  21  21 

S. America  Haiti  HA  56  43  43  37  37  31  31  25  18  18  20  20 

S. America  Jamaica  JM  56  43  43  37  37  31  31  25  18  18  23  23 

S. America  Martinique  MB  56  43  43  37  37  31  31  25  18  18  20  20 

S. America  Montserrat  MH  56  43  43  37  37  31  31  25  18  18  16  16 

S. America  Sint Maarten  NN  56  43  43  37  37  31  31  25  18  18  16  16 
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Region State FIPS 
Interstate 
Highway 

Divided 
Highway 

Primary 
Highway 

Secondary 
Highway Local Ferries 

Rural  Urban  Rural  Urban Rural  Urban Rural  Urban Rural  Urban Rural  Urban 

S. America  Suriname  NS  62  50  50  37  37  31  31  25  18  12  21  21 

S. America  Netherlands Antilles  NT  56  43  43  37  37  31  31  25  18  18  16  16 

S. America  Paraguay  PA  62  50  50  37  37  31  31  25  18  12  21  21 

S. America  Peru  PE  62  50  43  37  31  31  25  25  18  12  21  21 

S. America  Saint Martin  RN  56  43  43  37  37  31  31  25  18  18  16  16 

S. America 
Saint Kitts and Nevis 
Islands  SC  56  43  43  37  37  31  31  25  18  18  16  16 

S. America  Saint Lucia  ST  56  43  43  37  37  31  31  25  18  18  20  20 

S. America  Saint Barthelemy  TB  56  43  43  37  37  31  31  25  18  18  16  16 

S. America  Trinidad and Tobago  TD  62  50  43  37  31  31  25  25  18  12  25  25 

S. America 
Turks and Caicos 
Islands  TK  56  43  43  37  37  31  31  25  18  18  16  16 

S. America  Curacao  UC  56  43  43  37  37  31  31  25  18  18  16  16 

S. America  Uruguay  UY  62  50  50  37  37  31  31  25  18  12  21  21 

S. America 
Saint Vincent and the 
Grenadines  VC  56  43  43  37  37  31  31  25  18  18  20  20 

S. America  Venezuela  VE  62  50  43  37  31  31  25  25  18  12  21  21 

S. America  British Virgin Islands  VI  56  43  43  37  37  31  31  25  18  18  24  24 

S. America 
United States Virgin 
Islands  VQ  56  43  43  37  37  31  31  25  18  18  24  24 
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Appendix F:  
Toll Plaza Names in Reports 

 
 
The chart below identifies the toll authorities that have assigned multiple names to the same toll plaza location.  When generating a route 
using PC*MILER|Tolls, only one name for each toll plaza location is provided in the Detailed Route Report.  Because a vehicle can travel 
through any of the sub-plazas at one of these locations, this chart may help you match up agency names to the names that appear along a 
route in the Detailed Route Report. 
 
Currently there is only one toll plaza location in the database that has multiple names assigned to it: 
 
 
Agency  Toll Road  Toll Plaza Name in 

PC*MILER|Connect 
Toll Plaza 
Abbreviation in 
Detailed Route 
Report 

Other Plaza 
Abbreviations Used 
By Agency at the 
Same Location 

Other Plaza Names 
Used by Agency at 
the Same Location 

VDOT  Chesapeake Expressway  Chesapeake Expressway  16, 17  18*   

 
* 18 is the abbreviation used for Discount Program Members. 
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Appendix G:  
Toll Roads Requiring Electronic Payment 

 
 
Table 1 below lists roads that only accept toll discount programs.  No cash or other payment option is offered, and driving on one of 
these roads without a transponder and discount program membership will cause an invoice to be sent with a surcharge added to the toll 
rate. 
 
Table 2 lists all electronic toll roads (Open Road Tolling).  Like the roads in Table 1, drivers without a transponder on these roads will 
receive an invoice with a video toll rate amount. 
 
What differentiates these two types of roads is the amount of the surcharge on the roads in Table 1: these roads carry a relatively 
expensive surcharge, and the transportation authorities strongly advise against driving on these roads without a transponder. 

 
 
TABLE 1.  Roads Accepting Only Toll Discount Programs – Additional Surcharge on Violations 
 

State  Toll Road/Exits  Discount Program  Video Toll/Cash  Comments 

Florida  Florida Turnpike  SunPass  None  For the Florida Turnpike, the five 
exits listed are SunPass Only. 
Drivers without SunPass are 
required to exit before or after 
these exits.  If used by mistake 
then an invoice is sent home with a 
surcharge. 

Becker Road  SunPass  None   

Jog Road exit 98  SunPass  None   

SR 710 exit 107  SunPass  None   

Consulate Drive exit 255  SunPass  None   

Kissimmee Park Rd exit 240  SunPass  None   
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Florida  Polk Parkway  SunPass  None  This exit on the Polk Parkway is 
SunPass only.  If used by mistake 
an invoice is sent to the user with 
a surcharge. 

Pennsylvania  Pennsylvania Turnpike  E‐ZPass  None  For the three exits listed here a 
video toll plus a surcharge is sent 
in an invoice to the user. 

Virginia Drive exit 340  E‐ZPass  None   

Street Road exit 352       

SR 29 exit 320  E‐ZPass  None   

Texas  Camino Colombia Toll Road  TxTag, TollTag, EZ TAG  None  You must have a TxTag account or 
other accepted prepaid account to 
pay tolls on Camino Colombia. 
Under Texas law, non‐payment of 
tolls is a misdemeanor offense, 
and you may be subject to 
Administrative fees and fines of up 
to $350 per violation. 

Texas  Fort Bend Westpark Tollway  EZ Tag, TxTag  None  A fee is added to the toll rate and 
an invoice is sent to drivers 
without EZ Tag.  

Texas  Fort Bend Parkway Toll Road 
(Fort Bend Section) 

EZ Tag, TxTag  None  A fee is added to the toll rate and 
an invoice it sent to drivers 
without EZ Tag. 

Texas  Westpark Tollway  EZ Tag   None  Driving without an EZ TAG results 
in a violation event. A toll violation  
invoice is sent to registered 
owner/renter for the past‐due toll 
amount plus fess od $33. 
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Texas  Sam Houston Tollway  EZ Tag, TxTag, TollTag     Video Toll  There are eleven plazas that 
require an EZ Tag.  For the first 
two violations drivers can go to 
store or call and pay the toll;  for 
the third violation an invoice with 
a  surcharge of $33 is generated. 

  North Gessner  EZ Tag, TxTag, TollTag     Video Toll   

  West Road Entrance Ramp  EZ Tag, TxTag, TollTag     Video Toll   

  Hammerly Blvd Entrance 
Ramp 

EZ Tag, TxTag, TollTag     Video Toll 
 

  Bellaire Blvd Entrance Ramp  EZ Tag, TxTag, TollTag     Video Toll   

  Tidwell Road  EZ Tag, TxTag, TollTag     Video Toll   

  Garrett Road  EZ Tag, TxTag, TollTag     Video Toll   

  Winfield Road  EZ Tag, TxTag, TollTag     Video Toll   

  Northeast Mainline Toll 
Plaza 

EZ Tag, TxTag, TollTag     Video Toll 
 

  W Lake Houston Parkway  EZ Tag, TxTag, TollTag     Video Toll   

  John Ralston Road  EZ Tag, TxTag, TollTag     Video Toll   

  Wilson Road  EZ Tag, TxTag, TollTag     Video Toll   

Texas  Hardy Toll Road  EZ Tag, TxTag, TollTag     Video Toll  There are two plazas that require 
an EZ Tag.  For the first two 
violations drivers can go to a store 
or call and pay the toll, for the 
third violation an invoice with a  
surcharge of $33 is generated. 

Rankin Road South  EZ Tag, TxTag, TollTag     Video Toll   

  Central Greens Blvd  EZ Tag, TxTag, TollTag     Video Toll   
 

 
 



  

  

 PC*MILER User’s Guide 252 

TABLE 2.  Electronic Toll Roads (Open Road Tolling) 
 

State  Toll Road/Exits  Discount Program 
Video 

Toll/Cash 
Comments 

British 
Columbia 

Golden Ears Bridge  Quickpass  Pay As You Go  If the driver is not a registered 
customer, the license plate information 
is forwarded electronically to ICBC 
when the bridge is crossed. TransLink 
uses the information received from 
ICBC to send a bill for the toll amount to 
the registered owner of the vehicle. 

Port Mann Bridge  TReO  Pay By Mail   

California  Golden Gate Bridge  FasTrak  Pay‐by‐Plate   

Foothills‐Eastern Toll Road  FasTrak  ExpressAccount
Invoice 

 

San Joaquin Hills Corridor  FasTrak  ExpressAccount
Invoice 

 

Florida  Snapper Creek Expressway SR 
878 

SunPass  Toll‐By‐Plate   

Don Shula Expressway SR 874  SunPass  Toll‐By‐Plate   

Gratigny Parkway SR 924  SunPass  Toll‐By‐Plate   

Homestead Extension Of Florida's 
Turnpike 

SunPass  Toll‐By‐Plate   

Selmon Expressway  SunPass  We Bill You   

New interchange I‐4/Selmon 
Expressway Interchange 
(Connector) 

SunPass  Toll‐By‐Plate   

Dolphin Expressway SR 836/137th 
Avenue 

SunPass  Toll‐By‐Plate   

Mid‐Bay Bridge Connector  SunPass  Toll‐By‐Plate   

Florida’s Turnpike  SunPass  Toll‐By‐Plate   
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Golden Glades Toll Plaza  SunPass  Toll‐By‐Plate   

Illinois   Tri‐State Tollway  I‐Pass, E‐ZPass  Video Toll Rate  For the highlighted exit which is an all 
electronic tolling ramps, no cash 
accepted. Cash customers will incur an 
unpaid toll and are responsible for 
paying the cash fare indicated within 7 
days of the event. 

Balmoral Northbound  I‐Pass, E‐ZPass  Video Toll Rate   

Ronald Reagan Tollway  I‐Pass, E‐ZPass  Video Toll Rate  For the highlighted exit which is an all 
electronic tolling ramps, no cash 
accepted. Cash customers will incur an 
unpaid toll and are responsible for 
paying the cash fare indicated within 7 
days of the event. 

Eola Road  I‐Pass, E‐ZPass  Video Toll Rate   

Jane Addams Tollway  I‐Pass, E‐ZPass  Video Toll Rate   

IL 47 EB ent WB exit  I‐Pass, E‐ZPass  Video Toll Rate   

IL 47 EB ent WB exit  I‐Pass, E‐ZPass  Video Toll Rate   

Maryland  Intercounty Connector MD 200  E‐ZPass  Video Toll Rate  Toll facility customers who do not have 
an E‐ZPass and travel the ICC will be 
sent a bill in the mail and charged the 
Video Toll Rate (VRT).  VRTs at all 
Maryland toll facilities are 150% of the 
base toll rates with a minimum of $1 
and a maximum of $15 above the base 
toll rate.      

North 
Carolina 

Triangle Expressway  NC Quick Pass  Bill By Mail   

Ontario  407 ETR  407 ETR 
Transponder 

Video Toll 
Charge 

 

Quebec  A 25 Bridge  A25 Transponder  Video Toll   
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Charge 

Rhode Island  Sakonnet River Toll Bridge  E‐ZPass  Video Toll 
Charge 

 

Texas  183A  TxTag, TollTag, EZ 
TAG 

Pay By Toll   

Central Texas Tollways Loop 1  TxTag, TollTag, EZ 
TAG 

ZipCash   

Central Texas Tollways SH 130  TxTag, TollTag, EZ 
TAG 

ZipCash   

Cetral Texas Tollways SH 45  TxTag, TollTag, EZ 
TAG 

ZipCash   

Manor Expressway  TxTag, TollTag, EZ 
TAG 

Pay By Mail   

Addison Airport Tunnel  TollTag, TxTag  ZipCash   

Dallas North Tollway  TollTag, TxTag  ZipCash   

Lewisville Lake Toll Bridge  TollTag, TxTag  ZipCash   

Mountain Creek Lake Toll Bridge  TollTag, TxTag  ZipCash   

Sam Rayburn Tollway  TollTag, TxTag  ZipCash   

President George Bush Turnpike  TollTag, TxTag  ZipCash   

PGBT Western Extension SH 161  TollTag, TxTag  ZipCash   

Texas SH 550  TxTag, TollTag, EZ 
TAG 

Pay By Mail 
Rate 

 

Texas State Highway 99  TxTag, TollTag, EZ 
TAG 

Notice By Mail   

Virginia  Pocahontas Parkway  E‐ZPass   E‐ZPass, Visa or 
Mastercard 

The two listed exits are no cash exits, 
The Mainline Plaza is also cashless 
overnight from 11 p.m to 5 a.m. 
Payment options are Visa/Mastercard 
Debit/Credit cards 

Laburnum Avenue  E‐ZPass  E‐ZPass, Visa or   
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Mastercard 

Airport Connector  E‐ZPass  E‐ZPass, Visa or 
Mastercard 

 

Midtown Tunnel  E‐ZPass  Pay by Plate   

Downtown Tunnel  E‐ZPass  Pay by Plate   

Washington  SR 520 Bridge  Good To Go  Pay By Mail   
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Appendix H:  Postal Code Formats  
In Worldwide Regions 

 
 

 

Legend: A = alphabetic (A,B,C,…Z) 
N = numeric (0,1,2,...9) 

 

NOTE:  The version of PC*MILER in which postal code coverage was started is 
noted for each country listed below.  This refers to postal code coverage only, the 
country may have been available for routing without postal code access in 
previous versions. 

North America 
Canada  
ANA NAN or ANANAN 

Mexico, starting in Version 25.1 
NNNNN 

Puerto Rico, starting in Version 27.1 
NNNNN 

United States 
NNNNN 

South America 
Brazil, starting in Version 24.1 
NNNNN 

Europe 
United Kingdom 
AANA N or AAN N or AANN N 
or, starting in PCM24, AANAN or AANN or AANNN 
or, starting in Version 25.1, AANA NAA or AANANAA or AAN NAA or 
AANNAA or AANN NAA or AANNNAA 

France, Germany, Italy, Vatican City, Spain, and Finland 
NNNNN 

Russian Federation, starting in Version 22.1 
NNNNNN 

Romania, starting in Version 23.1 
NNNNNN 
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Estonia and Croatia, starting in Version 22.1 
NNNNN 

Lithuania, starting in Version 23.1 
NNNNN 
 
Andorra, starting in Version 26.1 
AANNN 
 
Monaco, starting in Version 26.1 
NNNNN 

Ukraine and Turkey, starting in Version 24.1 
NNNNN 

Netherlands, Belgium, Luxemburg, Austria, Switzerland, Liechtenstein, 
Denmark, Norway and Hungary 
NNNN 

Latvia and Slovenia, starting in Version 22.1 
NNNN 

Bulgaria, starting in Version 23.1 
NNNN 

Iceland 
NNN 

Ireland (Dublin only) 
NN (single digit postcodes N are not supported for input in PC*MILER) 

Poland 
NN-NNN 
or, starting in Version 24.1: NNNNN 

Portugal 
NNNN 
or, starting in Version 24.1: NNNN-NNN or NNNNNNN 
 
San Marino, starting in Version 26.1 
NNNNN 

Sweden 
NNN 
or, starting in Version 22.1: NNN NN or NNNNN 

Czech Republic and Slovakia 
NNN NN or NNNNN 
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Greece, starting in Version 22.1 
NNN NN or NNNNN 

Africa 
Lesotho, starting in Version 27.1 
NNNN 
 
South Africa, starting in Version 24.1 
NNNN 
 
Swaziland, starting in Version 27.1 
ANNN 

Asia 
Japan, starting in Version 24.1 
NNN-NNNN or NNNNNNN  

India, starting in Version 24.1 
NNNNNN 
 
Indonesia, starting in Version 27.1 
NNNNN 
 
Malaysia, starting in Version 27.1 
NNNNN 
 
Taiwan, starting in Version 27.1 
NNN 
 
Thailand, starting in Version 27.1 
NNNNN 

Oceania 
Australia, starting in Version 24.1 
NNNN 
 
New Zealand, starting in Version 27.1 
NNNN 
 
Federated States of Micronesia, Guam, Marshall Islands, Northern Mariana 
Islands, and Palau, starting in Version 27.1 
NNNNN 
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Appendix I:  Worldwide Data Coverage & 
Postal Code Access 

 
 
Region abbreviations are: AF (Africa), AS (Asia), EU (Europe), ME (Middle East), NA (North 
America), OC (Oceania), and SA (South America).  Country, city and road coverage, and postal 
code accessibility are shown in the table below for each region.  
 
Highway and Street-Level Data Coverage by Region 
 

Region 
# of 

countries 

Highway 
Distance 

 (Km) 

Streets  
 Distance1 

(Km) 
# of Cities 

# of Postal 
Codes 

Africa  58 1,226,160 1,398,376 28,826 5,293 
Asia  36 1,574,981 1,653,237 391,744 421,435 
Europe  48 2,762,969 14,091,315 552,382 1,463,904 
Middle East 15 283,144 168,385 140,631 24,868 
North 
America  

7 
1,412,999 10,859,726 244,001 1,044,8302 

Oceania 25 256,836 1,092,867 21,803 32,902 
South 
America  

47 
924,245 785,342 168,185 54,155 

TOTAL 236 8,441,334 30,049,248 1,547,572 3,047,387 
1 Available with purchase of the PC*MILER|Streets add-on module.  Street-level coverage for each region is 

available only for select countries with Coverage Level: Comprehensive. 
2  Includes Canadian Postal Codes available with purchase of data add-on 

 
Worldwide Data Coverage 
 

Version 28 includes extensive updates in 61 countries, with upgrades to Comprehensive 
coverage in Egypt, Lesotho, Morocco, Namibia, South Africa, Swaziland, India, Bahrain, Jordan, 
Kuwait, Lebanon, Oman, Qatar, Saudi Arabia and United Arab Emirates.  

Additionally, a new Middle East region was added and the following countries were reclassified: 

 Bahrain, Jordan, Kuwait, Lebanon, Oman, Qatar, Saudi Arabia, United Arab Emirates, 
Iran, Iraq, Israel, Syria, West Bank and Yemen are now grouped in Middle East. 

 Cyprus is now included in Europe instead of Asia. 

 Central American countries of Belize, Costa Rica, El Salvador, Guatemala , Honduras, 
Nicaragua, Panama, Curacao, Saint Barthelemy, Saint Martin, Sint Maarten are now 
grouped with South America. 

 US Virgin Islands is included in North America. 
 

The map and table on the next page show the current level of PC*MILER road network coverage 
worldwide. 
 

A
p

p
en

d
ix

 I 



  

 

 PC*MILER User’s Guide                   260 

 

 
 
 

Coverage Level* Road Coverage Locations 
Truck-Specific 

Attributes 

Comprehensive 
High + Street Level 

Network 
Cities, postal codes, 

addresses  
Yes 

High 
Intermediate + Complete 

Highway Network 
Cities, postal codes Yes 

Intermediate 
Basic + Most primary & 

secondary roads 
Cities, postal codes  No 

Basic City to city road network Cities No 

*  Coverage levels are assigned based on road coverage.  Postal code and truck‐specific attributes generally 
correspond to the level of road coverage with some exceptions. 

 

 
 
 
 
 
 

PC*MILER|Worldwide 28 Map Data Coverage
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Index 
 
 
53-Foot Trailer or Twins routing, 13 
 
A 

abbreviations list, 221 
accented letters, 49 
access routes and policies, 12, 213 
Add Comments box, 154 
adding new PC*MILER products, 34 
address entry, 50, 126, 232 
ALK Technologies, 207 
Application Settings dialog, 43–44 
AS400 installation, 31 
Australian address entry, 50 
automobile routing, 137, 139, 164 
avoid road segments, 154–60 
avoid whole roads, 161–63 
avoid whole states, 161–63 
axles, 110, 111 
 
B 

border crossings, 56–57 
border wait time, 131 
borders open/closed, 125 
break hours, 131 
 
C 

Canadian counties, 218 
Canadian place names, 49 
Canadian postal codes, 49, 55 
Canadian province abbreviations, 221 
cashless toll plazas, 249–55 
CAT Scale weigh stations, 63 
change the data set, 52–53 
change the dataset, 52–53 
CICS installation, 31 
Citrix and Terminal Services installs, 30 
city names, entering, 47–48 
clean up distance, 126 
column adjustments, 74 
comments, 154 
Comparison report, 120 

confidence level, custom place importing, 
86 

copying a map, 153 
copying a stop, 68 
cost and time estimates, 72–73, 128–33 
country code formats, 52, 230–31 
custom place categories, 77 
Custom Place Manager, 79 
custom place names 

converting to Version 28, 89 
creating, 77–78 
exporting, 80 
importing, 81–88 
managing, 79 

custom road file conversion, 163 
custom roads. See custom routing 
Custom Roads report, 160 
custom route profiles, 166 
custom routing, 154–78 

adjust for hazmat permits, 184 
avoid/favor road segments, 154–60 
avoid/favor whole roads, 161–63 
avoid/favor whole states, 161–63 
drag route, 170 
geofences, 170–78 
hazmat permits, 184 
override restrictions, 157–58 
sets of preferences, 158–60 
Use Custom Roads option, 126 
via points, 167–69 

custom vehicle profiles, 164–66 
 
D 

data errors, reporting, 206 
data matching, 81 
data set - changing, 52–53 
database for PC*MILER, 8, 206 
deactivating a PC*MILER license, 35 
default city match, 53 
default route options, 142 
designated truck routes, 147 
destination, entering, 46 
Detailed Route report, 116–18 
distance calculation, 9 
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distance units, 128 
dock window pane, 42 
Drag Map mode, 146 
Drag Routing option, 170 
dragging a stop, 68 
Driver’s Report, 119 
driving directions, 119 
duplicate city names, 66 
duplicate route, 76 
 
E 

editing stops, 67 
Email Technical Support option, 202 
Enterprise Solutions, 208 
error messages, 65 
estado abbreviations, 221 
ETA/ETD, 94–101, 131 
Export All button, 160 
exporting custom places, 80 
 
F 

Fastest routing, 11 
favor road segments, 154–60, 184 
favor whole roads, 161–63 
favor whole states, 161–63 
Feature Reference Guide, 37 
File application menu, 39, 43–44 
file conversion from earlier versions, 32–33 
FIPS codes, 52 
float window pane, 42 
frame options, 144 
frame stop, 69 
framing routes, 74 
fuel costs, 129 
fuel tax reporting, 10 
full-size van, 137, 138, 164 
 
G 

gallons/liters conversion, 128 
GENC codes, 52 
geofence warnings, 173–74 
geofences, 170–78 

conversion utility, 177 
creating, 171 
customizing, 173 
deleting, 174 

report, 177 
greenhouse gases emission, 130 
 
H 

hazmat routing, 179–86 
adjust for permits, 184 

Help files, 36 
hide window pane, 42 
highway exits, 61 
highway junctions, 57 
Highway Only routing, 126 
HOS hours, 131 
Hub distances, 127 
 
I 

importing custom places, 81–88 
importing saved settings, 32–33 
installation, 20–35 
ISO codes, 52 
 
K 

kilometers, 128 
 
L 

labor costs, 130 
latitude/longitude points 

as custom points, 80 
as stops, 58–60 
copy feature, 58 
tracking, 58 
using with addresses, 60 

Least Cost routing, 15, 90–93 
legends, 147 
local mileage, 126 
location radius, 70–71 
 
M 

map data set - changing, 52–53 
Map Features dialog, 149 
map panning, 146 
map styles, 150 
map window. See RouteMap window 
Mexican postal codes, 49 
Mileage report, 75, 115 
miles/kilometers conversion, 128 
multiple routes, 75 
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multiple trailer, 137 
 
N 

National Network access policies, 213 
National Network designation, 147 
National Network routing, 12 
new PC*MILER features, 5–8 
new route, 45 
NL abbreviation setting, 49 
 
O 

open a saved trip, 76 
optimizing routes, 69 
origin, entering, 46 
override restrictions option, 126 
override truck restrictions, 157–58 
Oversized Access designation, 147 
 
P 

Pan map view, 146 
PC*MILER Sales, 202 
PC*MILER|Energy installation, 26 
PC*MILER|Worldwide installation, 26 
pick list for stop entry, 48, 51, 53 
pick list on/off, 51, 53 
picking stops from the map, 65, 151 
POI search, 70–71 
points of interest, 152 
postal code formats worldwide, 256 
postal code help, 55 
Practical route, 10–11 
preferred roads. See Custom Routing 
printing a map, 153 
printing reports, 122 
Provide Pick List option, 48, 53 
province abbreviations, 221 
proxy setup, 24, 32 
 
Q 

Quick Access Toolbar, 39 
 
R 

ramp speed, 140 
ReadMe file location, 37 
region 

changing, 51, 125 

default, 125 
region-to-region routing, 52 
report location, 115 
reporting data errors, 206 
reports 

Comparison, 120 
copying, 122 
Detailed Route, 116–18 
Driver’s Report, 119 
Least Cost comparison, 92 
memo field in, 128 
Mileage, 75, 115 
Road Type, 120 
saving, 122 
State/Country Report, 118 

requirements, 16–18 
restricted roads, 147, 157, 184 
restrictions - special time-based, 100 
reversing the stop order, 68 
Ribbon toolbars, 39 
right mouse map menu, 151 
road classifications, 141 
road speed defaults, 235–47 
road speeds, 140 
Road Type Report, 120 
route 

53-Foot Trailer or Twins, 13 
creating a new, 45–70 
Fastest, 11 
Least Cost, 15 
National Network, 12 
optimization, 69 
Practical, 10–11 
running, 72 
Shortest, 11 
Toll Discouraged, 14 
type descriptions, 10 
type, changing, 125 

route distance tooltip, 151 
route framing, 74 
route name, 124 
Route Options, 123–41 

border wait time, 131 
borders open/closed, 125 
break hours, 131 
cost and time estimates, 128–33 
ETA/ETD, 131 
fuel costs, 129 
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gallons/liters, 128 
greenhouse gases emission, 130 
hazmat routing, 179–86 
HOS hours, 131 
hub routing, 125, 127 
labor costs, 130 
miles/kilometers, 128 
miscellaneous costs, 130 
override restrictions, 126 
report memo, 128 
road speeds, 140 
route name, 124 
route type, 125 
state/country report order, 128 
Use Custom Roads, 126 
Use Highway Only, 126 
vehicle dimensions, 133, 138, 164 
vehicle profile, 124 

route options display, 45 
route window features, 45, 72–74 
RouteMap window, 39, 143–53 

copying, 153 
frame options, 144 
geofences, 170–78 
hiding/displaying features in, 149 
legends, 147 
map styles in, 150 
pick stops, 151 
picking stops from, 65 
points of interest, 152 
printing, 153 
right mouse menu, 151 
route distance tooltip, 151 
satellite image layer, 150 
scroll bars, 146 
stop labels, 151 
zoom options, 145 

Routes window, 39 
RouteSync, 190–201 
routing types, 10–15 
running a route, 72 
 
S 

satellite image map layer, 150 
save routes as text files, 76 
saved custom places - importing, 89 
saved custom roads - importing, 163 

saving trips, 76 
seasonal routing, 159 
sets of custom roads, 158–60 
Settings Importer, 32–33 
shortcut keys, 42 
Shortest Route, 11 
special restrictions warnings, 100 
spelling help, 53 
SPLC 

as stops, 56 
State Oversized designation, 147 
state weigh stations, 64 
state/country abbreviations, 48 
state/country abbreviations list, 221 
State/Country Report, 118 
state/country report order, 119, 128 
stop entry, 46 

accented letters, 49 
picking stops from the map, 65 
Zoom to Stop feature, 145 

stop labels, 151 
stop list 

copy a stop, 68 
deleting stops, 67 
drag a stop, 68 
editing stops, 67 
moving stops, 67 
optimization, 67 
reversing the stop order, 67 

system requirements, 16–18 
 
T 

technical support, 202 
time format setting, 97 
time zone display, 95 
time-based restrictions warnings, 100 
time-based routing, 94–101 
time-based toll cost reporting, 101 
toll barriers omission, 117 
toll costs 

by state, 114 
by trip leg, 73 
by weight and axle, 110 
calculation, 106 
cashless toll plazas, 108 
currency for, 109 
discount information in reports, 114 
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in reports, 112–14 
number of axles for, 136 
plaza names, 112 
totals for trip, 113, 114 
vehicle weight for, 110–12 

Toll Discouraged routing, 14 
toll plaza names in reports, 248 
toll plazas, electronic only, 249 
traffic data 

map display, 102–5 
use by default, 99 
with ETA/ETD calculation, 98 

Traffic subscription upgrade, 25 
travel time, 94–101, 140 
truck stops, 62 

picking from the map, 65 
truck-discouraged roads, 157 
truck-inaccessible locations, 151 
truck-inaccessible roads, 157 
truck-restricted roads, 147, 157 
 
U 

uninstalling PC*MILER, 35 
units of distance, 128 
updates, 203–5 
Use Highway Only option, 9, 72, 126 
Use Traffic Data option, 98 
 
V 

valid entries for addresses, 232 
vehicle dimension options, 133–39 
vehicle profile drop-down, 124 
via points, 167–69 
 
W 

warning - Highway Only, 50 
warnings in the Detailed Route report, 117 
waypoints, 167–69 
weigh stations, 64 
window options, 41 
 
Z 

ZIP Code help, 55 
ZIP codes, entering, 54 
zoom options, 145 
zoom to stop, 67, 69 



 

 

NOTES: 


