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PC*MILER® |Rail 

END-USER LICENSE AGREEMENT 
 

1. Grant of License:  Subject to the terms, conditions, use limitations and payment of fees 
as set forth herein, ALK Technologies, Inc. ("ALK") grants the end-user ("you") a non-
assignable, non-transferable, non-exclusive license to install and use the PC*MILER|Rail 
solution(s) you have purchased ("PC*MILER|Rail") on a single personal computer. The 
PC*MILER|Rail software, data and documentation are provided for your personal, 
internal use only and not for resale. They are protected by copyright held by ALK and its 
licensors and are subject to the following terms and conditions which are agreed to by 
you, on the one hand, and ALK and its licensors (including their licensors and suppliers) 
on the other hand. 
 
2. Title:  You acknowledge that the PC*MILER|Rail computer programs, data, concepts, 
graphics, documentation, manuals and other material owned by, developed by or licensed 
to ALK, including but not limited to program output (together, “program materials”), are 
the exclusive property of ALK or its licensors. You do not secure title to any 
PC*MILER|Rail program materials by virtue of this license. 
 
3. Copies:  You may make one (1) copy of the PC*MILER|Rail program materials, 
provided you retain such copy in your possession and use it solely for backup purposes.  
You agree to reproduce the copyright and other proprietary rights notices of ALK and its 
licensors on such a copy. Otherwise, you agree not to copy, reverse engineer, interrogate, 
or decode any PC*MILER|Rail program materials or attempt to defeat protection 
provided by ALK for preventing unauthorized copying or use of PC*MILER|Rail or to 
derive any source code or algorithms therefrom.  You acknowledge that unauthorized use 
or reproduction of copies of any program materials or unauthorized transfer of any copy 
of the program materials is a serious crime and is grounds for suit for damages, injunctive 
relief and attorneys' fees. 
 
4. Limitations on Transfer: This license is granted to you by ALK. You may not directly 
or indirectly lease, sublicense, sell, disseminate, or otherwise transfer PC*MILER|Rail or 
any PC*MILER|Rail program materials to third parties, or offer information services to 
third parties utilizing the PC*MILER|Rail program materials without ALK's prior written 
consent.  To comply with this limitation, you must uninstall and deactivate 
PC*MILER|Rail from your computer prior to selling or transferring that computer to a 
third party. 
 
5. Limitations on Network Access: You may not allow end-users or software applications 
on other computers or devices to directly or indirectly access this copy of 
PC*MILER|Rail via any type of computer or communications network (including but not 
limited to local area networks, wide area networks, intranets, extranets, the internet, 
virtual private networks, Wi-Fi, Bluetooth, and cellular and satellite communications 
systems), using middleware (including but not limited to Citrix MetaFrame and 
Microsoft Terminal Server) or otherwise (including but not limited to access through 
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PC*MILER|Rail interface products), or install or use PC*MILER|Rail on a network file 
server, without first notifying ALK, executing a written supplemental license agreement, 
and paying the license fee that corresponds to the number and types of uses to which 
access is to be allowed. 
 
6. Limitations on Data Extraction:  You may manually extract data (including but not 
limited to program output such as distances, maps, and reports) from PC*MILER|Rail 
and use it in other applications on the same computer on which PC*MILER|Rail is 
legally licensed and installed, as permitted below.  You may not transfer data extracted 
from PC*MILER|Rail onto any other computer or device unless you have licensed 
PC*MILER|Rail for that computer or device.  You agree that you will not, nor will you 
permit your trade partners or anyone else to, use content derived from PC*MILER|Rail, 
including route line data, nor display such data or integrate such data into another 
provider’s service, including, but not limited to, Google or Bing.  You agree not to pre-
fetch, retrieve, cache, index, or store any data, content, or other portion of the product 
output at any time, provided, however, that you may temporarily store (for less than 
thirty (30) days) limited amounts of such content for the sole and exclusive purpose of 
enhancing the performance of your implementation due to network latency, and only if 
you do so securely and in a manner that: (a) does not permit use of the content outside of 
the scope of this Agreement; (b) does not manipulate or aggregate any content or portion 
thereof; (c) does not prevent ALK from accurately tracking usage; and (d) does not 
modify attribution of the product in any way. 
 
7. Limitations on Mobile Communications: Without limiting the generality of the 
foregoing, you may not transmit PC*MILER|Rail street-level driving directions through 
mobile communications systems such as satellite, cellular services, electronic recording 
devices, or to mobile devices such as computers, telematics systems, on board or mobile 
computers or Smartphones, handhelds, pagers, electronic recording devices or telephones 
without first executing a written supplemental license agreement with ALK and paying 
the license fee that corresponds to the number and types of devices and systems to and 
through which transmission is to be permitted. You may not use this License, any of the 
Licensed Product, or its reports, to create a competitive product, solution or visualization 
platform. 
 
8. Limitations on Disclosure: You may disclose PC*MILER|Rail distances to trading 
partners, in the course of their providing services to you, for specific origin-destination 
moves for which you provide transportation services and use PC*MILER|Rail distances 
as a basis for payment.  You may not make any other disclosure of PC*MILER|Rail 
programs and materials, including, but not limited to, program output, to anyone outside 
the legal entity that paid for and holds this license, without prior written permission of 
ALK. You acknowledge that the PC*MILER|Rail programs and materials, developed by 
or licensed to ALK are very valuable to ALK and its licensors, and their use or disclosure 
to third parties, except as permitted by this license or by a written supplemental license 
agreement with ALK, is strictly prohibited. 
 
9. Security: You agree to take reasonable and prudent steps to safeguard the security of 
the PC*MILER|Rail program materials and to notify ALK immediately if you become 
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aware of the theft or unauthorized possession, use, transfer or sale of the PC*MILER|Rail 
program materials licensed to you by ALK. 
 
10. Acceptance:  You are deemed to have accepted the PC*MILER|Rail program 
materials upon receipt. 
 
11. Warranties:  ALK represents and warrants that: 
  

a) For ninety (90) days from date of purchase, PC*MILER|Rail, when delivered and 
properly installed, will function substantially according to its specifications on a 
computer purchased independently by you. 
 
b) For ninety (90) days from date of purchase, the software media on which ALK 
provides PC*MILER|Rail to you will function substantially free of errors and defects. 
ALK will replace defective media during the warranty period at no charge to you 
unless the defect is the result of accident, abuse, or misapplication of the product.  
 
c) THE FOREGOING WARRANTIES ARE IN LIEU OF ALL OTHER 
WARRANTIES EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITING 
THE GENERALITY OF THE FOREGOING ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. THE 
PC*MILER|Rail PROGRAM, DATA AND DOCUMENTATION IS SOLD "AS IS". 
IN NO EVENT SHALL ALK OR ITS LICENSORS BE LIABLE FOR ANY 
INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES SUCH AS, BUT NOT 
LIMITED TO, LOSS IN CONNECTION WITH OR ARISING OUT OF THE 
EXISTENCE OF THE FURNISHING, FUNCTIONING OR USE OF ANY ITEM 
OF SOFTWARE, DATA OR SERVICES PROVIDED FOR IN THIS 
AGREEMENT. IN NO EVENT SHALL DAMAGES TO WHICH ALK MAY BE 
SUBJECT UNDER THIS AGREEMENT EXCEED THE CONTRACT PRICE. 
THIS WARRANTY SHALL NOT ACCRUE TO THE BENEFIT OF THIRD 
PARTIES OR ASSIGNEES. 

 
12. Disclaimer: The data may contain inaccurate, incomplete or untimely information due 
to the passage of time, changing circumstances, sources used and the nature of collecting 
comprehensive geographic data, any of which may lead to incorrect results. 
PC*MILER|Rail’s suggested routings and distances data are provided without a warranty 
of any kind. The user assumes full responsibility for any delay, expense, loss or damage 
that may occur as a result of their use. The user shall have no recourse against Canada, 
whether by way of any suit or action, for any loss, liability, damage or cost that may 
occur at any time, by reason of possession or use of Natural Resources Canada data. 
 
This data is provided to you “as is,” and you agree to use it at your own risk. ALK and its 
licensors (and their licensors and suppliers) make no guarantees, representations or 
warranties of any kind, express or implied, arising by law or otherwise, including but not 
limited to, content, quality, accuracy, completeness, effectiveness, reliability, fitness for a 
particular purpose, usefulness, use or results to be obtained from this Data, or that the 
Data or server will be uninterrupted or error-free. 
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13. Termination:  This Agreement will terminate immediately upon any of the following 
events: 
 

a) If you seek an order for relief under the bankruptcy laws of the United States or 
similar laws of any other jurisdiction, or a composition with or assignment for the 
benefit of creditors, or dissolution or liquidation, or if proceedings under any 
bankruptcy or insolvency law are commenced against you and are not discharged 
within thirty (30) calendar days. 
 
b) If you materially breach any terms, conditions, use limitations, payment 
obligations, or any other terms of this Agreement. 
 
c) Upon expiration of any written supplemental license agreement between you and 
ALK of which this license is a part. 

 
14. Obligations on Termination: Termination or expiration of this Agreement shall not be 
construed to release you from any obligations that existed prior to the date of such 
termination or expiration. 
 
15. Hold Harmless and Indemnity:  To the maximum extent permitted by applicable law, 
you agree to hold harmless and indemnify ALK and its parent company, subsidiaries, 
affiliates, officers, agents, licensors, owners, co-branders, other partners, and employees 
from and against any third party claim (other than a third party claim for Intellectual 
Property Rights) arising from or in any way related to your use of PC*MILER|Rail, 
including any liability or expense arising from all claims, losses, damages (actual and/or 
consequential), suits, judgments, litigation costs and attorneys' fees, of every kind and 
nature. ALK shall use good faith efforts to provide you with written notice of such claim, 
suit or action. 
 
16. Intentionally omitted. 
 
17. Limitations on Export: You hereby expressly agree not to export PC*MILER|Rail, in 
whole or in part, or any data derived therefrom, in violation of any export or other laws 
or regulations of the United States. 
 
18. Aggregated Data: ALK may, from time to time, share information about You with 
parent and sister or affiliated companies for business purposes and when necessary for it 
to perform work under this Agreement.  In addition, ALK may, and is hereby authorized 
to, use, share and provide certain aggregated, non-identifiable information derived from 
Your use of PC*MILER|Rail to third parties. 
 
19. Intentionally omitted 
 
20. Additional Use Terms, Conditions, Restrictions and Obligations:  This agreement and 
your use of PC*MILER|Rail is expressly subject to the ALK Privacy Policy and the ALK 
End User License Agreement Terms and Conditions (“EULA”) set forth below. YOU 
ACKNOWLEDGE AND AGREE THAT YOU MAY NOT USE PC*MILER|Rail IF 
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YOU DO NOT ACCEPT THE TERMS AND CONDITIONS OF THE ALK EULA 
AND THAT YOU HAVE REVIEWED AND ACCEPT THE TERMS AND 
CONDITIONS OF THE ALK EULA BY INSTALLING OR ACTUALLY USING 
PC*MILER|Rail. 
 
21. Miscellaneous: This agreement shall be construed and applied in accordance with the 
laws of the State of New Jersey.  The Courts of the State of New Jersey shall be the 
exclusive forum for all actions or interpretation pertaining to this agreement.  Any 
amendments or addenda to this agreement shall be in writing executed by all parties 
hereto.  This is the entire agreement between the parties and supersedes any prior or 
contemporaneous agreements or understandings.  Should any provision of this agreement 
be found to be illegal or unenforceable, then only so much of this agreement as shall be 
illegal or unenforceable shall be stricken and the balance of this agreement shall remain 
in full force and effect. 
 
22. Date: This EULA was last updated on November 2, 2015. Visit www.pcmiler.com for 
regular updates. 
 
END USER LICENSE AGREEMENT FOR ALK DATA  
 
This license applies to ALK Data included in PC*MILER|Rail if any, as well as to ALK 
data you obtain separately that is formatted for use with your Software. 
 
The data (“Data”) is provided for your personal, internal use only and not for resale.  It is 
protected by copyright, and is subject to the following terms and conditions which are 
agreed to by you, on the one hand, and ALK Technologies, Inc. (“ALK”) and its 
licensors (including their licensors and suppliers) on the other hand. 
 
© 2015 ALK.  All rights reserved. 
 
1. Personal Use Only:  “You” means you as an End-user or as a “Company” on behalf of 
its End-Users which are subject to either a Non-Disclosure Agreement as employees or a 
License Agreement that contains the same restrictions as herein as a Value Added 
Reseller.  Also as used in this EULA “personal use” can also be understood in more 
general terms as for a Company’s use. You agree to use this Data together with 
PC*MILER|Rail for the solely personal, non-commercial purposes for which you were 
licensed, and not for service bureau, time-sharing or other similar purposes.  
Accordingly, but subject to the restrictions set forth in the following paragraphs, you may 
copy this Data only as necessary for your personal use to (i) view it, and (ii) save it, 
provided that you do not remove any copyright notices that appear and do not modify the 
Data in any way.  You agree not to otherwise reproduce copy, modify, decompile, 
disassemble or reverse engineer any portion of this Data, and may not transfer or 
distribute it in any form, for any purpose, except to the extent permitted by mandatory 
laws. 
 
2. Restrictions: Except where you have been specifically licensed to do so by ALK in the 
case of an integrated solution bundled or intended for use with specific smartphones, 
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similar mobile communication device(s) or personal navigation device(s), and without 
limiting the preceding paragraph, you may not use this Data (a) with any products, 
systems, or applications installed or otherwise connected to or in communication with 
vehicles, capable of vehicle navigation, positioning, dispatch, real time route guidance, 
fleet management or similar applications; or (b) with or in communication with any 
positioning devices or any mobile or wireless-connected electronic or computer devices, 
including without limitation cellular phones, smartphones, palmtop and handheld 
computers, pagers, and personal digital assistants or PDAs. You may not use this 
License, any of the Licensed Product, or its reports, to create a competitive product, 
solution or visualization platform. 
 
3. Warning: The Data may contain inaccurate, untimely or incomplete information due to 
the passage of time, changing circumstances, sources used and the nature of collecting 
comprehensive geographic data, any of which may lead to incorrect results.  The 
Highway Data is based on official highway maps, the Code of Federal Regulations, and 
information provided by state governments and other licensors.  It is provided without a 
warranty of any kind. The user assumes full responsibility for any delay, expense, loss or 
damage that may occur as a result of use of the Data. 
 
4. No Warranty: This Data is provided to you “as is,” and you agree to use it at your own 
risk.  ALK and its licensors (and their licensors and suppliers) make no guarantees, 
representations or warranties of any kind, express or implied, arising by law or otherwise, 
including but not limited to, content, quality, accuracy, completeness, effectiveness, 
reliability, fitness for a particular purpose, usefulness, use or results to be obtained from 
this Data, or that the Data or server will be uninterrupted or error-free. 
 
5. Disclaimer of Warranty: ALK AND ITS LICENSORS (INCLUDING THEIR 
LICENSORS AND SUPPLIERS) DISCLAIM ANY WARRANTIES, EXPRESS OR 
IMPLIED, OF QUALITY, PERFORMANCE, MERCHANTABILITY, FITNESS 
FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT.  Some States, 
Territories and Countries do not allow certain warranty exclusions, so to that extent the 
above exclusion may not apply to you. 
 
6. Disclaimer of Liability: ALK AND ITS LICENSORS (INCLUDING THEIR 
LICENSORS AND SUPPLIERS) SHALL NOT BE LIABLE TO YOU: IN 
RESPECT OF ANY CLAIM, DEMAND OR ACTION, IRRESPECTIVE OF THE 
NATURE OF THE CAUSE OF THE CLAIM, DEMAND OR ACTION 
ALLEGING ANY LOSS, INJURY OR DAMAGES, DIRECT OR INDIRECT, 
WHICH MAY RESULT FROM THE USE OR POSSESSION OF THE 
INFORMATION; OR FOR ANY LOSS OF PROFIT, REVENUE, CONTRACTS 
OR SAVINGS, OR ANY OTHER DIRECT, INDIRECT, INCIDENTAL, SPECIAL 
OR CONSEQUENTIAL DAMAGES ARISING OUT OF YOUR USE OF OR 
INABILITY TO USE THIS INFORMATION, ANY DEFECT IN THE 
INFORMATION, OR THE BREACH OF THESE TERMS OR CONDITIONS, 
WHETHER IN AN ACTION IN CONTRACT OR TORT OR BASED ON A 
WARRANTY, EVEN IF ALK OR ITS LICENSORS HAVE BEEN ADVISED OF 
THE POSSIBILITY OF SUCH DAMAGES.  Some States, Territories and Countries 

 
 PC*MILER Product End-User License Agreement ix 



 
  

do not allow certain liability exclusions or damages limitations, so to that extent the 
above may not apply to you. 
 
7. Export Control:  You agree not to export from anywhere any part of the Data provided 
to you or any direct product thereof except in compliance with and with all licenses and 
approvals required under, applicable export laws, rules and regulations. 
 
8. Entire Agreement:  These terms and conditions constitute the entire agreement 
between ALK (and its licensors, including their licensors and suppliers) and you 
pertaining to the subject matter hereof, and supersedes in their entirety any and all written 
or oral agreements previously existing between us with respect to such subject matter. 
 
9. Governing Law:  The above terms and conditions shall be governed by the laws of the 
State of New Jersey.  The courts of the State of New Jersey shall have exclusive 
jurisdiction to settle any and all disputes, claims and actions arising from or in connection 
with the Data provided to you hereunder.  You agree to submit to such jurisdiction. 
 
========================================= 
ALK TECHNOLOGIES, INC. | www.alk.com 
========================================= 
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                             Welcome 
 

 
Welcome to ALK's PC*MILER®|Rail!  By purchasing PC*MILER|Rail, you 
have invested in a high-quality, user-friendly software package for determining 
railroad routes and mileage. 
 

1.1  What Is PC*MILER|Rail? 
PC*MILER|Rail is point-to-point rail routing and mileage software.  Its powerful 
North American rail network contains over 240,000 miles of rail line, over 
49,400 active freight stations, 802 rail carriers, and over 4,000 unique 
junction interchanges.  PC*MILER|Rail provides rail routes and mileage for rate 
determination and negotiation, equipment management, rail car mileage auditing, 
and carrier selection. 
 
Through ALK’s close working relationship with all major railroads, 
PC*MILER|Rail features the industry-leading electronic representation of current 
North American railroad routes and mileage.  For over 30 years, ALK’s railroad 
database has proven to be an accurate source for determining the routes and 
mileage used in processing the U.S. Surface Transportation Board’s Carload 
Waybill Sample.  It has also been used in numerous traffic diversion studies and 
in a variety of costing applications.  ALK’s railroad database is widely used by 
virtually all major railroads and rail car lessors.  
 
PC*MILER|Rail generates routes and determines mileage between any two rail-
served locations in North America.  Each location can be identified by station 
name and state abbreviation or by commonly used geographic codes.  With 
PC*MILER|Rail you can quickly calculate the Shortest route (least distance) 
and/or the Practical route (based on historical operations) between any two 
points.  You may specify interline junctions or let PC*MILER|Rail choose 
junctions by weighing location versus gateway importance.  A Fuel Surcharge 
routing option is provided to accommodate the Surface Transportation Board 
ruling on mileage-based fuel surcharge calculations. Routings for Intermodal, 
Coal/Bulk and multi-level Auto Rack trains are also included. 
 
PC*MILER|Rail can also be used in conjunction with ALK’s PC*MILER|Rail-
Connect to generate mileages from within Microsoft® Excel®, display “pin maps” 
for integrated real time mapping, and provide seamless integration with other 
Windows-based transportation and logistics software.  An optional batch 
processing module, PC*MILER|Rail-BatchPro, enables quick processing and 

1 C
ha
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summarizing of large volumes of car location messages (CLM’s), SPLC codes or 
origin-destination pairs.   
 

1.2  Additional PC*MILER|Rail Solutions 
PC*MILER|Rail can be used on its own as a standalone product, or in 
conjunction with the following connectivity and batch processing applications: 
 
PC*MILER|Rail-Connect seamlessly interfaces PC*MILER|Rail routes, 
mileages and reports with transportation management software systems and third-
party software. Within other software applications, users can calculate 
PC*MILER|Rail mileage for an origin/destination pair of locations with 
intermediate stop-off points, display maps, run state-by-state mileage breakdowns 
and generate detailed station reports.  It also allows access to mileage and 
mapping information from within Microsoft® Excel®. 
 
PC*MILER|Rail-BatchPro enables users to quickly summarize empty, loaded, 
and total mileages by equipment ID, railroad, or state and province for a large 
number of rail movements.  Large volumes of origin/destination locations can be 
processed using a variety of geographic codes (identifiers) including station 
name/state abbreviation, SPLC, FSAC, ERPC (3-3-3) and R260. 
 
PC*MILER|Rail-TCP/IP provides an interface to PC*MILER|Rail-Connect trip 
calculation functions on Windows personal computers from any other computer 
platform over a TCP/IP network. 
 
PC*MILER|Rail Stations Geocode Files include a complete list of all 
PC*MILER|Rail freight stations by serving carrier and  contains Station 
Name/ST, SPLC, FSAC, 3-3-3, and R260 code information.  There are two 
versions of this file: one with latitude/longitude information and one without. 
 

1.3  What’s New in Version 22? 
• NEW!  Ribbon-Style Interface for an Updated Look and Easier 

Navigation.  Keeping pace with recent trends in software design that employ 
the latest technology to support newer operating systems and enhance 
usability, the PC*MILER|Rail user interface has been updated to include tools 
and layouts that are more user-friendly.  The same functionality that our 
customers value is now accessible with a new look and feel.   

 
The new interface features a ribbon style design for smoother navigation, and 
map and report windows that can be floated outside the application window to 
accommodate your workspace needs.  Users of recent versions of  Microsoft® 
Office 2007 and higher will already be familiar with the Ribbon format. 
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• NEW!  Proxy Server Setup.  A proxy server setup option has been added for 

those who need to bypass current security settings to access the Internet 
during license activation and while using PC*MILER|Rail. 

 
• ENHANCED!… Up-to-Date Rail Network Data Reflects the Latest 

Changes in the Industry.  The PC*MILER|Rail industry-standard rail 
network database is updated annually to include the most current data 
available.  Throughout the year, ALK Technologies’ team of Geographic 
Information System (GIS) specialists gathers new data and incorporates 
customer feedback.  Version 22 data updates include the following: 

- Over 240,000 total miles of rail line 

- Over 49,400 active freight stations 

- Over 4,000 unique junction interchanges 

- 802 rail carriers, including 34 new carriers since Version 21 (listed below): 

 

New Railroads Added in Version 22.0: 
WCRR WYOMING CONNECT RAILROAD LLC 
EBTC EAST BROAD TOP CONNECTING RAILROAD 
BS BIRMINGHAM SOUTHERN RR CO 
GOGR GEAUX GEAUX RAILROAD LLC 
LBWR LUBBOCK & WESTERN RAILWAY, L.L.C. 
ECBR EAST COOPER AND BERKELEY RAILROAD COMPANY 
HSR HAINESPORT SECONDARY, LLC 
GCSR GULF COLORADO & SAN SABA RAILWAY 
PRI PORT RAIL, INC. 
FWRY FILLMORE WESTERN RAILWAY COMPANY 
IRRS INTERNATIONAL RAIL ROAD SYSTEMS INC 
KE KANSAS EASTERN RAILROAD INC 
BLU BLUE RIDGE SOUTHERN RAILROAD LLC 
EZR ELIZABETHTOWN INDUSTRIAL RAILROAD, LLC 
RJCD RJ CORMAN RAILROAD COMPANY/TEXAS LINES, LLC 
ECYR EASTSIDE COMMUNITY RAIL, LLC 
ANRG ALTEX ENERGY LTD 
MVP MISSOURI & VALLEY PARK RAILROAD CORP 
BBAY BOGALUSA BAYOU RAILROAD LLC 
NENE NEBRASKA NORTHEASTERN RAILWAY COMPANY 
NJSL NEW JERSEY SEASHORE LINES, INC. 
MRA MINERAL RANGE, INC. 
PIR PERU INDUSTRIAL RAILROAD, LLC 
GRRY THE GREAT LAKE PORT CORPORATION D/B/A THE GRAND RIVER RAILWAY 
MKC MCKEESPORT CONNECTING RAILROAD COMPANY 
OTR OAKLAND TERMINAL RAILROAD COMPANY 
RJCS RJ CORMAN RAILROAD CO/CAROLINA LINES, LLC 
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CAMY CAMP CHASE RAILWAY COMPANY, LLC 
PTR PORT TERMINAL RAILROAD OF SOUTH CAROLINA 
PUCC PORT UTILITIES COMMISSION OF CHARLESTON SC 
TIRL TONAWANDA ISLAND RAILROAD INC 
QNSL QUEBEC NORTH SHORE AND LABRADOR RAILWAY COMPANY 
WCTR WCTU RAILWAY COMPANY 
SAW SOUTH PLAINS SWITCHING LTD CO 
CHRC CHAPARRAL RAILROAD COMPANY INC 
TXN TEXAS NEW MEXICO RAILWAY, L.L.C. 

 
 

Railroads Deleted in Version 22.0: 
CFS TRAINS TOURISTIQUES DE CHAUDIERE-APPALACHES INC. DBA CHEMIN DE FE 
WWR WESTERN WASHINGTON RAILROAD, LLC 
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             Getting Started 
 

 
PC*MILER|Rail is a standalone product.  The underlying data that the 
application uses is installed along with the product.  The data is stored in binary 
format that only the product can read.  No other database application is required 
to run PC*MILER|Rail.  
 

2.1  System Requirements 

 
Environment: • Stand-alone PC  with a 1.5-2 GHz processor or 

networked personal computers (LANs and Server/Thin 
Client Networks) 

 
Platforms: • Windows® 7, 8 and 10* running in 32-bit compatibility 

mode as well as support for 64-bit native applications – 
please see section 2.4 if installing connectivity products 
on a 64-bit machine 
* IMPORTANT: See the note for Windows 10 in 
section 2.4.   
NOTE: Windows 95, 98 , 2000, Vista and XP will not 
be supported.  We are strongly recommending that you 
upgrade your operating system. 

• Citrix Metaframe and Windows Terminal Services 
• TCP/IP functionality for use with other platforms 
 

Requirements: • 700 MB hard disk space  
• 512 MB of RAM minimum, 1 GB RAM recommended 

for standard desktop users.  For Citrix and Terminal 
Server, 200 MB RAM for each user running 
PC*MILER|Rail-Connect. 

  
For PC*MILER|Rail-Connect: 
• Additional 10 MB hard disk space 
• Microsoft Excel  
• A development system for the PC*MILER|Connect 

interface. (Interface definitions for Borland C++ 4.0 
and Visual Basic 3.0 are currently supported, although 
many other systems can also utilize the DLL.) 
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These additional components will also be installed: 
• Microsoft Visual C++ 2005 Redistributable Package 

(x86) -  Disk space 6 MB 
• WindowsInstaller-KB884016-v2-x86.exe (x86) – Disk 

space 2 MB 
• .NET dotnetfx.exe (x86) – Disk space 280 MB 
 
For PC*MILER|Rail-BatchPro: 
• Additional 5 MB hard disk space 
 
For PC*MILER|Rail-TCP/IP: 
• Additional 5 MB hard disk space 
• PC with 1.5-2 GHz processor and TCP/IP capability 
• UNIX or other host with TCP/IP capability 
• Physical connection (cable) 
• Client software on the UNIX or other host (sample 

PERL application provided) 
 

Other 
Requirements: 

• Minimum screen resolution 800x600 
• Color Quality Settings Supported: 16-bit and 32-bit 
   (8-bit not supported) 
• Internet Connection for License Activation 
   (manual license activation also available) 
• Email Address for License Activation 
 

Microsoft Windows 
Update 
Requirements 

The following service pack updates are required for 
Windows users. You can access these updates by 
regularly using the Windows Update feature or by going 
directly to Microsoft’s website.  The following 
requirements are the minimum level of maintenance 
needed to run PC*MILER|Rail. 
• Windows XP Service Pack 2 
• Windows Server 2003 Service Pack 1 
 

2.2  General Licensing Information 

Single-User License 
A single-user license can be installed to only one PC locally. 

 
Additional Copy License 
Users can install PC*MILER|Rail locally onto additional PC’s by purchasing 
additional copy licenses. If you purchase five copy licenses, you can install 
PC*MILER|Rail locally onto five additional PC’s or workstations. If you are 
installing onto a desktop PC and a laptop, two licenses are needed. 
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Multi-User License 
A multi-user license can be installed to a server environment, on the computer 
that will be sharing the licenses to other computers. It allows “x” number of 
concurrent workstation connections to PC*MILER|Rail at a time. For example, a 
5-User License allows PC*MILER|Rail to be installed on a central server or PC 
with as many workstation PCs as you want to have access, but it only allows five 
users to access PC*MILER|Rail at a time. 

 
Enterprise License 
An Enterprise License allows you to install PC*MILER|Rail on any combination 
of end-user PCs or workstations without limitations.  It’s a cost-effective 
installation and licensing solution for larger enterprises with several users.  It does 
not require license activation but requires signing an enterprise supplemental 
license agreement directly with ALK. 
 

2.3  Installation Types 
Non-Network (Local) Installations 
A non-network installation allows you to install PC*MILER|Rail to a PC or 
workstation locally, not onto a server environment to be shared with other 
computers. 
 
Network Installation 
A networked installation allows you to install PC*MILER|Rail on network file 
servers where each end-user can save their own option settings or can share 
option settings that are stored on the server. 
 
Citrix/Terminal Services Installation 
PC*MILER|Rail can be installed onto a Citrix Server or Terminal Services 
environment, if you have purchased a license to do so.  Each end-user must have a 
license to gain access. 
 
Trial Installation 
A trial installation is a 15-day license to access PC*MILER|Rail features and 
data.  A trial installation cannot be upgraded, it must be uninstalled and 
reinstalled to add another product or feature. 
 

2.4  Important Installation Notes 
Windows 10 Users:  Because of an unresolved issue with folder permissions in 
Windows 10, if you are installing from a network, you’ll need to copy the 
downloaded PC*MILER|Rail installation folder (PCRWIN22) to the desktop or C 
drive and then run the setup.exe from there in order to properly install some of the 
necessary files. 
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Microsoft Windows 7, 8 and 10 Users 
Your license must be installed and activated using an Administrator Account.  
Once installed, you do not need to “Run as an Administrator” provided you install 
to the recommended default directory or to another directory that doesn’t require 
useres to “Run as an Administrator”. 
 
COM DLL’s on a 64-Bit Computer: If you install PC*MILER|Rail-Connect 
Version 22 on a 64-bit computer, you are given the option of using either the 32-
bit versions or the 64-bit versions of the COM dll’s. To switch between the 
versions, you can run “Modify” in the setup to make the decision again or run 
“UseCom32.bat” to switch to 32-bits or “UseCom64.bat” to switch to 64-bits. 
These .bat files are found in your PCRWIN22/Connect/com folder. 
 
Data Execution Prevention (DEP) Setting 
On some versions of Windows, DEP might close PC*MILER|Rail without any 
type of error message.  If that happens, do the following: open the Windows Start 
menu and go to Settings > Control Panel > System and Security > System > 
Advanced System Settings > Advanced tab > Performance Setting > Data 
Execution Prevention tab.  Select “Turn on DEP for essential Windows 
programs and services only”. 
 
PC*MILER|Rail Interfaces 
For those who are interfacing any PC*MILER|Rail component to a third-party 
system, please contact the vendor directly to make sure that the interface to this 
new version of PC*MILER|Rail is updated and complete before you install. 
 
Website Support Center 
Please check ALK’s Website Support Center for posted updates and patches.  Go 
to www.alk.com/support. 
 

2.5  Single User (Non-Network) Installation  

NOTE: Have your Product Key Code on hand before beginning the installation 
process. It will be emailed to you from alkservices@alk.com in an email titled, 
“PC*MILER|Rail 22 Software Order…” (Enterprise License customers excluded, 
see note in Step 4 below). “Single” will be included in the list of product 
components in this email, indicating that you purchased a single-user license. If 
don’t see “Single” in the email, please contact a PC*MILER Sales Representative 
to purchase the correct license. 
 

UNINSTALLING AN OLDER VERSION: If you need to uninstall a previous 
version of PC*MILER|Rail on the computer that you are now installing to, you 
must uninstall the previous version before installing PC*MILER|Rail 22. If you 
do not need to uninstall, it is possible to have both versions  
of the desktop program installed on the same system. Please note that 
PC*MILER|Rail-Connect will be updated to the new version. 
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BEFORE INSTALLING, please double-check that the emailed Product Key 
Code(s) lists all purchased components. For example, the code shown below 
unlocks the following components: PC*MILER|Rail, PC*MILER|Rail-Connect, 
and PC*MILER|Rail-BatchPro. 
 
Order #: SO-000000001 
Product Order #: PC*MILER|Rail 22 
Date: 11/16/2015 10:33 AM 
Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2 
== PC*MILER|Rail 22 (Single), BatchPro, Connect 

 
To install your single-user version of PC*MILER|Rail, follow these steps: 

 
1. If you are downloading the installation, click the provided link in the email 

that was sent to you from ALK Technologies and follow the instructions in 
the email. 

 

NOTE for Windows 10 Users:  Windows 10 users installing from a network, 
please see the note in section 2.4.    
 

If you are installing using a DVD, place the PC*MILER|Rail Install DVD in 
the DVD or CD/DVD drive and the installation will start automatically.  If it 
does not start automatically, click the Windows Start menu. Then, depending 
on your operating system, either 1) type “d:\setup.exe” and click the search 
button (if the DVD drive is not the D drive, substitute the letter that designates 
the DVD drive); or 2) select Computer > [DVD drive letter] > setup.exe. 
 

IMPORTANT NOTE for Windows Users:  You will need to install 
PC*MILER|Rail as an administrator.  If you are not the designated 
administrator on your computer, you will receive a warning message.  Once 
the application is installed, you won’t have to “Run as an Administrator” to 
use it provided you install to the default directory or to another directory that 
does not require the user to be an administrator. 
   

To install as an administrator, cancel the installation if necessary (click 
Cancel and then Finish) and then follow these steps:  
1) Open Windows Explorer and navigate to the PC*MILER|Rail installation 

folder that was downloaded or is on your CD/DVD drive;   
2) Right-click on the setup.exe file in the installation folder and select “Run 

as administrator”;   
3) If the install doesn’t begin automatically, double-click on the setup.exe 

file to start the installation process again. 

2. In the InstallShield Wizard Welcome screen, click Next to review the terms 
and conditions of the End-User License Agreement.  To accept the terms of 
the license agreement, select I accept then click Next.   

3. Enter your User Name and Company Name then click Next. 
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4. Enter your Product Key Code. This 25-character code will be emailed to you 

from alkservices@alk.com in an email titled, “PC*MILER|Rail 22 Software 
Order…” The code can be copied and pasted.  If typing the Product Key 
Code, dashes are not required – dashes, spaces, or no spaces are all 
acceptable.  Click Next when finished. 

NOTE: As a convenience to our Enterprise License customers, your Product 
Key Code is hard-coded into the installation for you and is valid for each 
install. 

5. Select Features:  In the list of features to be installed, clear the checks next to 
any component that you do not want to install or test.  Click Next to continue. 

6. Choose Destination Location:  To install to the default folder (recommended), 
do not make any changes and click Next. 

To install to a location other than the default, click Browse to select another 
folder.   Be sure to add “Pcrwin22” to the end of the new path. For example: 
C:\Apps\PCRWIN22.  If you don’t, PC*MILER|Rail will install to the root of 
the specified directory. Click Next to continue. 
 

7. Start Copying Files: To change any setting, select Back. If you are satisfied 
with the settings, click Next to continue.  

If you have a previous version of PC*MILER|Rail-Connect installed, an alert 
will appear on the screen with the following message: “The install found a 
previous version of Connect. These files will be renamed with a .bak 
extension.” Click OK in the dialog to continue. 

8. Follow through with the rest of the installation.  This may take some time 
depending on the speed of the computer you are installing to.  Do not exit or 
reboot the computer during the installation.  If any error messages appear, 
please contact Technical Support.   

9. When the installation is complete, you will be prompted to view the 
ReadMe.txt and to activate your license.  If you need to use a Proxy Server 
to access the Internet, skip to section 2.5.1, Activation Using a Proxy Server.  
Otherwise, leave these boxes checked and click Finish to proceed to the 
automatic activation (Step 10 below).  (NOTE: It may take 5-15 seconds for 
the Product Activation window to open.)  When the ReadMe opens, review 
the information in it and then close the window. 

IMPORTANT: ALK provides a 15-day temporary license prior to 
completing the activation process. If you make a second attempt to install on 
the same computer, you will lose this 15-day temporary license. If you 
experience an activation error and need access  to PC*MILER|Rail before 
Technical Support is available, please do not attempt a second install without 
assistance. 
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AUTOMATIC LICENSE ACTIVATION 
 

10. The PC*MILER Product Activation window should be open.  (If it is not 
open, select Start menu > All Programs > PCMILER Rail 22 > License Status 
to open the License Tool window, then click Activate.)  
 

If you are an Enterprise License Customer: You can bypass the following 
license activation steps of the install because you are already activated and 
registered with ALK.  To continue, close the Product Activation window then 
proceed to Step 14 to open PC*MILER|Rail 22 and start using the application. 
 
If you are not an Enterprise License Customer: If the computer you are 
installing to has an Internet connection and you have a valid email address, 
the license activation can be processed automatically.  Enter your Email 
Address then click Activate.  “Manual Activation” should be left 
unchecked. 
 

NOTE:  Internet license activation is available 24 hours a day.  If you don’t 
have an active Internet connection or email address, please contact 
PC*MILER Technical Support during business hours for assistance. 

 
11. When the activation process is complete, you will receive a message in the 

Product Activation window saying, “License Activation Complete!”.  Close 
the window to continue.  If the activation failed, skip to Step 15 below for 
manual activation.   
 

12. To verify licensing, go to the Windows Start menu > All Programs > 
License Status.  In the PC*MILER License Tool window, verify that 
“Licensed” appears under Status.  If “Licensed” is NOT in the Status field, 
skip to Step 15 below for manual activation. 
 

13. If successful activation has been verified, close the License Tool window.  An 
email titled “PC*MILER|Rail 22 Activation Code for Product XXXXX…” 
from alkservices@alk.com will be sent to the email you entered in Step 10.  
You only need to keep this email for your records.  

  
14. To start PC*MILER|Rail once the installation is complete, click the 

PC*MILER|Rail 22  icon on the desktop, or click the Windows Start menu > 
All Programs > PCMILER Rail 22 > PCMILER Rail 22. 

 
MANUAL ACTIVATION 

 
15. (You only need to follow these steps if the automatic license activation 

process could not be completed.)  If the automatic activation (Steps 10-11 
above) fails for any reason, try manually activating.  In the Product Activation 
window, enter your Email Address then check “Manual Activation”.  

 
16. Next, click the provided URL for the ALK activation site. 
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17. You will be taken to the ALK Technical Support “Activate Product” web 

page, and your product key will automatically populate the Product Key 
fields.  Click Next to continue. 

 
18. In the next screen, enter your Email address and click Finish. 
 
19. An email titled “PC*MILER|Rail 22 Activation Code for Product XXXXX…” 

from alkservices@alk.com will immediately be sent to the email you entered. 
 
20. Copy the activation code directly from the Activation web page or from the 

email sent to you, and paste it into the Activation Code field in the Product 
Activation window. 

 
21. Click Activate in the Product Activation window to complete the activation. 
 
22. You will see the message “License Activation Complete!”.  Close the Product 

Activation window.  

23. Start PC*MILER|Rail once the installation is complete: click the 
PC*MILER|Rail 22 icon on the desktop, or click the Windows Start menu > 
All Programs > PCMILER|Rail 22 > PCMILER|Rail 22. 

 
 

2.5.1  Activation Using a Proxy Server 
 

1.  When the installation is complete (Steps 1-9 in section 2.5 above), uncheck 
the Activate check box and then click Finish. 

 
2. Next, start PC*MILER|Rail: either click the PC*MILER|Rail icon on the 

desktop, or click the Windows Start menu and then select All Programs > 
PCMILER Rail 22 > PCMILER Rail 22. 

 
3. Select the Help tab > Windows group > Proxy Setup. 
 
4. In the Proxy Setup dialog, check Use Proxy Server then enter a Host and Port. 
 
5. If needed, check Proxy Authentication then enter a Username and Password. 
 
6. Click OK to save your settings and close the dialog.  PC*MILER|Rail is now 

set up to use the indicated proxy server when connecting to the Internet. 
 
7. Close PC*MILER|Rail. 
 
8. Go to the Windows Start menu > All Programs > PCMILER Rail 22 > 

License Status and click Activate in the PC*MILER License Tool window. 
 
9. Follow the steps in section 2.5 for automatic activation, beginning at Step 10. 
 

 
 PC*MILER|Rail User’s Guide 12 

mailto:alkservices@alk.com


   
 

2.6  Multi-User Network Installation 

NOTE:  PC*MILER|Rail 22 supports silent installations. 
 
NOTE FOR INSTALLING TO A MAPPED DRIVE:  For customers who 
install to a mapped drive (this is rare), do not enter the location by its mapped 
name.  For example, if you mapped C:\Apps to F:\, just use C:\Apps as the install 
directory when InstallShield asks you for the location.  The Windows program 
that PC*MILER|Rail 22 uses to automate folder sharing cannot share mapped 
drives by using their mapped name (i.e. F:\ in the example above). 
 
NOTE: Have your Product Key Code on hand before beginning the installation 
process. It will be emailed to you from alkservices@alk.com in an email titled 
“PC*MILER|Rail 22 Software Order…” (Enterprise License customers excluded, 
see note in Step 4 below.) “(X-User)” will be included in the multi-user Product 
Key email. If it is not included, please contact a PC*MILER Sales Representative 
to purchase the correct license. 
 
BEFORE INSTALLING,  
please double-check that the emailed Product Key Code(s) lists all purchased 
components. For example, the code shown below unlocks these components: 
PC*MILER|Rail and PC*MILER|Rail-Connect. 
 
Order #: SO-000000001 
Product Order #: PC*MILER|Rail 22 
Date: 11/16/2015 10:33 AM 
Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2 
== PC*MILER|Rail (XX-User), Connect 
 
To install PC*MILER|Rail 22 on a network, follow these steps: 

1. Begin by installing PC*MILER|Rail to the server: follow steps 1-9 for a 
Single User (Non-Network) Installation (section 2.5 above). 

 
2. When the installation is done, you will see a message that says a shared folder has 

been created for the workstations on your network.  The message will include the 
name of the folder to install from on each workstation.  Click OK. 

3. You will be prompted to view the ReadMe.txt and to activate your license.  
If you need to use a Proxy Server to access the Internet, see section 2.5.1, 
Activation Using a Proxy Server.  Otherwise, leave these boxes checked and 
click Finish to continue.  Review the ReadMe and then close the window. 

 
IMPORTANT NOTE:  ALK provides a 15-day temporary license prior to 
completing the activation process.  If you make a second attempt to install you 
will lose this license.  If you experience an activation error and need access to 
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PC*MILER|Rail before Technical Support is available, please do not attempt 
a second installation without assistance. You’ll be able to use the application 
for 15 days without completing the activation. 

 
4. After you click Finish, the PC*MILER Product Activation window will open.     

 

If you are an Enterprise License Customer: You can bypass the following 
license activation steps of the install because you are already activated and 
registered with ALK.  To continue, close the Product Activation window. 
PC*MILER|Rail is installed on the server and can be opened by double-
clicking the PC*MILER|Rail icon on the desktop, or click the Windows Start 
menu and select All Programs > PCMILER Rail 22 > PCMILER Rail 22. 
 

If you are not an Enterprise License Customer: If the computer you are 
installing to has an Internet connection and you have a valid email address, 
the license activation can be processed automatically.  Enter your Email 
Address then click Activate.  “Manual Activation” should be left unchecked. 
 
NOTE:  Internet license activation is available 24 hours a day.  If you don’t 
have an active Internet connection or email address, please contact Technical 
Support during business hours for assistance – see section 2.11. 

5. If the activation is successful, you will see a “License Activation Complete” 
message that directs you to open an email from ALK Technologies for further 
instructions.  If the activation was NOT successful, try activating manually 
(Steps 15-23 in section 2.5) before calling Technical Support.  To contact 
Technical Support, see section 2.11. 

6. After activation, open the email you received, then follow the instructions for 
copying the “net.lic” file included with the email to the “App” folder in your 
PC*MILER|Rail installation.  Net.lic holds the license or user count for your 
installation.  Until you save this file to the designated folder, you will only 
have a single-user installation.   

The PC*MILER|Rail application is now accessible on the server (see Step 2 
in Installing on a Workstation below for access options). 

INSTALLING ON A WORKSTATION 

To install PC*MILER on each workstation, follow these steps: 
 
1. On the workstation, click the Windows Start menu and enter the network path 

to where the workstation setup program resides.  This path should match the 
network path sent to your email address as a result of running the server 
installation.  The only difference is that you will replace “App” with 
“Network”.  For example, if this path  was sent via the email as "\\PRI-QA-
2K332-02\PCRWIN22\App\" for the network license file, you will run the 
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workstation installation program from “\\PRI-QA-2K332-
02\PCRWIN22\Network\setup.exe” then press Enter. 
 
If you have lost the email that included the network path, you can determine 
the path as follows: navigate to the server’s “PCRWIN22” folder, right-click 
the folder, and go to Properties > Sharing.  The network path can be copied 
and pasted from there. 

2. Next, you will be asked to choose your workstation setup options.  Two 
screens will prompt you to select the type of settings you would like to use.   

The setup options in the first screen (Settings Location) are: 

• Use local setting – Allows the user at each workstation to customize 
default options and manage settings, including custom roads and places. 

• Share network settings – Provides each workstation the same default 
options and settings within the application. 

 
The setup options in the second screen (Settings Data) are: 

• Use local data – Installs data to the local workstation.  This option can 
decrease the time it takes PC*MILER|Rail to open and begin processing, 
and reduces network traffic.  In general, the performance is better.  
However, there must be enough hard disk space to accommodate the data.  

• Share data on your network, default – This is the default choice.  
PC*MILER|Rail uses the shared data that was installed on the server.  

3.  To start PC*MILER|Rail on a workstation once the installation is complete, 
double-click the desktop PC*MILER|Rail icon, or click the Windows Start 
menu and select All Programs > PCMILER Rail 22 > PCMILER Rail 22. 

 

 2.7  Citrix and Terminal Services Installations 

NOTE: Have your Product Key Code on hand before beginning the installation 
process.  It will be emailed to you from alkservices@alk.com in an email with the 
subject line “PC*MILER|Rail 22 Software Order…” (Enterprise License 
customers excluded).  “(Citrix/Terminal Services)” will be included in the 
Product Key email confirming that you have purchased a Citrix or Terminal 
Services license.  If not, please contact an Enterprise Solutions account executive 
to purchase the correct license and request one Product Key Code for each 
individual server you are installing to.  
 
UNINSTALLING AN OLDER VERSION: If you need to uninstall a previous 
version of PC*MILER|Rail on the computer that you are now installing to, you 
must do it before installing PC*MILE|Rail 22.  If you do not need to uninstall, 
you can have both versions of the desktop program installed on the same system.  
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Please note that PC*MILER|Rail-Connect and PC*MILER|Rail-BatchPro will be 
updated to the new version. 

 
BEFORE USING PC*MILER|Rail:  Citrix supports 16 bit and 24 bit color, 
while PC*MILER|Rail supports 16 bit and 32 bit color.  A Citrix end user must 
set the color resolution on their workstation to 16 bit before they log into a Citrix 
server to run PC*MILER|Rail.  If an end user has their color resolution set to 32 
bit and logs in to Citrix, the Citrix software will adjust it downward to 24 bit prior 
to loading PC*MILER|Rail, and the application will fail to load. 

 
BEFORE INSTALLING, please double-check that the emailed Product Key Code 
lists all purchased components.  For example, the code shown below unlocks the 
following components: PC*MILER|Rail, PC*MILER|Rail-Connect, 
PC*MILER|Rail-BatchPro. 
   

Order #: SO-000000001 
Product Order #: PC*MILER|Rail 22 
Date: 11/16//2015 10:33 AM 
Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2 
== PC*MILER|Rail 22 (Citrix/Term Serv), Connect, BatchPro 

 

Only a qualified Citrix administrator should be installing PC*MILER|Rail 
on a Citrix system.  With Citrix in Install Mode, follow the steps in section 2.5, 
Single User (Non-Network) Installation. 
 
If you were using another version of PC*MILER|Rail with PC*MILER|Rail-
Connect and/or PC*MILER|Rail-BatchPro in your Citrix environment, there may 
be existing files that require deletion.  Citrix and Terminal Servers can have 
multiple copies underneath C:\Users\<username>\Windows, C:\Documents and 
Settings\ <username>\Windows or in %homedir%\windows like H:\Windows.  
Copies of the pcrsrv.ini and pcrsrvXX.ini (“XX” being a version number) 
should be deleted from any location outside of C:\WINDOWS. 
 

2.8  Proxy Server Setup 
The following PC*MILER|Rail features require a connection to the Internet: 
 

• License activation 
• Software update and patch downloads via the Updater tool 

 
For those who need to bypass current security settings to access the Internet while 
activating and using PC*MILER|Rail, the steps to complete the proxy setup are 
below.  The setup can be implemented after PC*MILER|Rail has been activated 
or before activation during the temporary grace period after installation. 
 

1. Open PC*MILER|Rail and select the Help tab > Proxy Setup. 
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2. In the Proxy Setup dialog, check Use Proxy Server then enter a Host and Port. 

3. If needed, check Proxy Authentication then enter a Username and Password. 

4. Click OK to save your settings and close the dialog.  PC*MILER|Rail is now 
set up to use the indicated proxy server when connecting to the Internet. 

 

2.9  Adding a New Product To Your PC*MILER|Rail Installation 
You may find that you want to purchase an additional PC*MILER|Rail 
component sometime after the initial installation of PC*MILER|Rail.  To 
purchase and install an additional product at a later time, follow these steps: 

 
First, call PC*MILER Sales at 800.377.6453 (or 1.609.683.0220 outside of the 
U.S.), 9:00am-5:00 pm EST, Monday-Friday to purchase the product and obtain a 
new Product Key Code to license and install the new solution(s). 
 
Once you receive the new product key code, follow the instructions below for a 
single user or multi-user workstation. 

 
SINGLE USER AND MULTI-USER SERVER INSTALLATION 

1. Go to the Windows Start menu > All Programs > PCMILER Rail 22  > 
License Status. 

2. In the PC*MILER License Tool window, click Add License. 

3. In the PC*MILER Product Activation window, enter the product key for the 
purchased component(s) and click Add License. 

4. When prompted, enter your Email Address.   

5. Click Activate.  

6. When the activation process is complete, you will see the message “License 
Activation Complete!”.  Close the Product Activation window. 

7. Back in the License Tool window, make sure all new and existing 
PC*MILER|Rail components are listed under Licensed Components, then 
close the window.  

8. To install newly added components, go to the Windows Start menu > 
Control Panel > Programs and Features (or the equivalent on your system). 

9. In the list of installed programs, right click “PC*MILER|Rail 22” and choose 
Change. 
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10. In the InstallShield Wizard, choose Modify and click Next. 

11. In the next screen, you will see the list of Licensed Features. All activated 
features will be listed.  Check that the component you are installing is 
included in the list, then click Next to continue. 

12. In the next screen you’ll see the Destination Folder for the installation.  Click 
Next to start copying files. 

13. When the installation is complete, click Finish. 
 

 
MULTI-USER INSTALLATION, FROM A WORKSTATION 

1. Go to the workstation. 

2. Browse to the shared …\PCRWIN22\network folder on the server. 

3. Run the setup.exe and choose Modify. 

4. Follow through with the rest of the installation (steps 10-13 above). 
 

2.10  Deactivating and Uninstalling Your License 
You must fully deactivate your product license and uninstall all PC*MILER|Rail 
components, including local, network, enterprise, or server installations if you are: 
 

• Moving any PC*MILER|Rail installation to a new computer; 
• Reformatting a computer that PC*MILER|Rail is currently installed to; 
• Returning the product; 
• Reinstalling on the same PC. 
 
DEACTIVATION: 

 
1. Go to Start > All Programs > PCMILER Rail 22  > License Status and in 

the PC*MILER License Tool window click Deactivate. 

2. In the PC*MILER Product Deactivation window, click Deactivate. 

3. When the deactivation is complete, you will see a “Deactivation Complete” 
message, with the deactivated product keys listed below.   

4. Close the Product Deactivation and License Tool windows. 

 
UNINSTALLING: 
 
5. To uninstall after deactivating, go to the Start menu > Settings > Control 

Panel > Programs and Features (or the equivalent on your system). 
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6. Highlight PC*MILER Rail 22, right-mouse click and select Uninstall. 

7. Click Yes at the prompt to completely remove the application. 

8. Click Finish when the installation process is complete. 

NOTE:  If any messages appear during the uninstall process that say that a 
certain file cannot be removed, click OK to continue.   

 
9. !! IMPORTANT STEP !!  Once the uninstall process is finished, you will 

need to delete the …ALK Technologies\PCRWIN22 folder manually to 
completely remove the application from your system.  The default location for 
this folder is C:\ALK Technologies\PCRWIN22. 

 
NOTE: If you deactivated/uninstalled an installation that included 
PC*MILER|Rail components that were licensed and added after the initial 
installation, you will need to add those components separately again when you 
reinstall. 

   

2.11  Technical Support Options 
ALK Technologies offers free technical support to all users of PC*MILER|Rail 
and its related products.  If you have any questions about PC*MILER|Rail or 
problems with the software that can’t be resolved using the product user’s guides 
or online Help, contact ALK Technologies. 
 
Hours: 8:00am - 5:00pm, Mon-Fri, Eastern Standard Time 

Phone: 1.800.377.6453, ext. 2 or 1.609.683.0220, ext. 2 

Email: pcmsupport@alk.com or from within the PC*MILER|Rail user 
interface select the Help tab > Email Technical Support and 
follow the instructions provided.  If you have any supporting 
material, click Attach File and browse for the file(s) to attach. 
Attachments of supporting documentation can be up to 10 MB.  
When ready, click Send.  ALK's technical support team will 
send a confirmation email to the email entered in the "Enter 
your email here" field when it is received. 
 
Please include your Product Key Code and product version 
number (e.g. 22.0.1) in all correspondence.  To find this 
information, go to the Help tab > About. 

Fax: 1.609.252.8108   ATTN: PC*MILER|Rail Technical Support 

Web Site: www.pcmiler.com (click Support > PC*MILER|Rail) 
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2.12  User Guides and Online Help 

NOTE: You must have Adobe Acrobat Reader on your computer to properly 
view the PDF user guides for PC*MILER|Rail products.  (Using another PDF 
reader may cause faulty pagination or other problems.)  If you do not have this 
program installed already, a free copy can be downloaded from www.adobe.com.   
 
To make Adobe Reader your default reader, from within the Adobe Reader 
application select the Edit menu > Preferences > General and click Select Default 
PDF Handler.  Select Adobe Reader from the drop-down, and click Apply then 
OK to close the Preferences dialog. 
 
The PC*MILER|Rail User’s Guide can be accessed from within PC*MILER|Rail 
by selecting the Help tab > Help Index, by pressing the <F1> key while in the 
main application window, or by clicking a Help button in any dialog.   
 

Additionally, you can click the Windows Start button > All Programs (or the 
equivalent on your system) > PCMILER Rail 22 > PC*MILER|Rail User’s 
Guide.  
To search for a keyword or phrase in a user guide, use Adobe Reader’s Find 
option in the Edit menu or on the toolbar.   
 
All user guides can also be accessed at www.pcmiler.com/support.  If accessing a 
user guide from the Support pages, you’ll need to download the PDF to your hard 
drive to be able to search for keywords. 
 

2.13  Feature Reference Guide 
The PC*MILER|Rail Version 22 user interface has been updated with a new look 
and feel while retaining the same functionality as in previous versions.   
   
For users of Version 21 and previous versions of PC*MILER|Rail who are 
updating, a reference table in PDF format is provided so you can quickly look up 
the new way to access features and options that you are already familiar with.  
  
To access the Feature Reference Guide, click the Windows Start menu and select 
All Programs (or the equivalent option for your version of Windows) > 
PCMILER Rail 22 > User Guides > Feature Reference Guide.  
 
PDF documents can be searched for keywords – select the Edit menu > Find.  The 
drop-down menu off the Find box can be used to refine your search. 
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2.14  Email Us Your Data Corrections 
If you encounter any problems related to data errors, from within PC*MILER|Rail 
please go to the Help tab > Email Data Correction and follow the on-screen 
guidelines to submit the issue.   
 
To attach supporting documentation to the email form, click the Attach File 
button and browse for the file.  Attachments can be up to 10 MB.  
 
After filling out the form, click Send to send it.  ALK will make every effort to 
correctly analyze and incorporate your data suggestions.  
 
You can also print a copy of the route, highlighting the problem, and send it to: 
  

PC*MILER Products Division 
ALK TECHNOLOGIES, INC. 

457 North Harrison Street ∙ Princeton, NJ 08540 ∙ USA 
Email: pcmsupport@alk.com 

 

2.15  Check for Updates 
Select the Help tab > Check for Updates to check via the internet for any 
available patches or quarterly data updates to PC*MILER|Rail.  If no updates are 
available, a message to that effect will be displayed.  If there are updates, a list 
will be returned and you will have the option to download them. 
 

 
2.15.1  Using the Updater Tool 

 
Provided you have an internet connection, follow the steps below to install the 
available updates: 
 
1. Close all open instances of PC*MILER|Rail and its connectivity products.  If 

a third-party program that accesses any PC*MILER|Rail component is 
running, (for example, PC*MILER|Rail-Connect) it must be closed before 
updating. 

2. Open PC*MILER|Rail and select the Help tab > Windows group > Check for 
Updates.  The PC*MILER Updater dialog will open.  The Updater first 
checks for valid license information and then begins checking for available 
updates.  
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PC*MILER Updater 

 
3. When the search for updates is complete you will see all available updates 

listed.  In the Download & Install drop-down menu next to each available 
update, select either Download & Install to download and install right away 
or Download to download now and install at a later time.  Note the version 
number of the updates you will be installing  so you can check if the update 
installed properly (see Step 6 below). 

 

 
Download and Install Options 
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4. The download process will begin and the progress of the download will be 

reflected in a progress bar.  If any PC*MILER|Rail-related application is 
open, you will be prompted to close it.  After closing the application(s), click 
OK to continue with the download. 

 

 
 

5. If you chose Download and Install, the InstallShield Wizard will open when 
the download is finished.  Follow the instructions to complete the installation.  
After installing, you will see the update listed under “Installed Updates” in the 
Updater window. 

 

If you chose Download, when the download is finished the button to the 
right will now say “Install”.  You can complete the installation at any time in 
the future by opening the Updater window and clicking Install. 
 

IMPORTANT:  You must close the Updater after processing is finished.  
The next time you open the Updater, the files you downloaded will be shown 
in the “Downloaded Updates” section of the dialog. 
 

6. As a last step, check to make sure the update installed properly.  Select the 
Help tab > About and look for the Software Version number under “This 
Product is Licensed To”.  It should match what you downloaded. 

 
 

 
PC*MILER|Rail “About” Window 
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      Overview & Shortcut Keys 
 
 

3.1  Overview 

When you first open PC*MILER|Rail, you’ll see route windows on the left, the map 
window on the right, and a Ribbon toolbar at the top.  The Ribbon contains layered 
toolbars organized in tabs like a set of file folders.  Click a tab to see the toolbar 
attached to it.  Users of recent versions of Microsoft Office will already be familiar 
with the Ribbon format.  
 
 

 
 
 

                
               PC*MILER|Rail 22 User Interface – Initial View 

 
1 - File Application Menu.  Click the red File drop-down to open the PC*MILER 

application menu.  This menu can be used to print and save maps and reports, 
close all open routes or reports, and to exit the application window. 

 
2 - The Ribbon, with the Routes tab selected.  Click a tab on the Ribbon to bring 

its toolbar forward.  The Routes toolbar provides tools for entering and editing 
stops on a route, setting route options, and generating routes and reports.  There 
are five tabs on the Ribbon: Routes, AutoRouter, Map, Window, and Help.  
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1. File Application 
Menu 

2. The Ribbon 
 

3. Routes Window 

4. AutoRouter 
Window Tab 

 

5. Map Window 
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3 - Routes Window.  Select the Routes tab to access single route entry.  Click New 
Route on the Ribbon or <Ctrl+N> to open a new route window. Multiple single 
route windows can be open at the same time.  If there are more routes open than 
can be displayed, a scroll bar will appear on the right edge of the Routes 
window that allows access to the hidden routes.  Tools and options for route 
entry are in the Routes toolbar on the Ribbon. 

 
4 - AutoRouter Window.   Select the AutoRouter tab or <F6> to open the 

AutoRouter window.  The AutoRouter generates a scrollable list of all possible 
routes between the station locations that are entered.  Use the AutoRouter 
toolbar on the Ribbon to set avoid/favors and route options. 

 
5 - Map Window.   Routes are drawn automatically in the map window as they are 

generated.  Use the Map toolbar to access a variety of map tools, or right click 
on the map and select from the menu.   

 

3.2  Shortcut Keys 

Keystrokes that provide shortcuts to menu options and features are listed below. 
 

Key(s) Function 
Ctrl-N Open a new single route window. 
F1 Open the PC*MILER|Rail User’s Guide from the main window. 
Alt-F2 Invoke the Avoid/Favor Junctions dialog. 
F3 Display a scrollable list of state abbreviations. 
Alt-F3 Display a list of railroad names and abbreviations sorted by SCAC. 
Ctl-F3 Display a list of railroad names and abbreviations sorted by name. 
F4 Invoke the Options dialog for the active route. 
Alt-F4 Exit PC*MILER|Rail. 
Ctrl-F4 Close the active single route entry window. 
F5 Display the Detailed Report for the active route. 
Alt-F5 Display the Key Station Report for the active route. 
Ctrl-F5 Display the Detailed Geocode Report for the active route. 
F6 Activate the AutoRouter window. 
F7 Insert a stop above the highlighted stop (single route entry). 
F8 Delete the highlighted stop (single route entry). 
Alt-F8 Delete all stops in the single route entry window. 
F9 Open the map window in its default position if it is closed. 
F10 Generate routes and distances ("Run") in a single route window. 
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3.3  Window Position Options 

There are several screen layout options to choose from in the PC*MILER|Rail 
application window, and the Map and Reports windows can be floated, docked, or 
hidden. 
 
To float, dock or hide the Map or Reports window, click the Window Position 
drop-down in the upper right corner and select an option.   
 
 
 
 
In the Window toolbar, the Routes Window, AutoRoute Window, and Map 
Window buttons toggle those windows on/off – click a button to hide the window, 
and click again to display it.  Use the Report Location drop-down to choose a 
layout position for the Reports window – Top, Bottom, Left, Right, or Float. 
 

 
 
Click the Layouts drop-down to choose from four screen layouts in the 
application window:  
 
 
 
 
 
 

Default Layout Routes on the Left, Floating Reports 

Routes on the Right, Bottom Reports Routes and Reports, Hidden Map 
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                          Using PC*MILER|Rail 
 
 

This chapter describes how PC*MILER|Rail determines routes and mileage, 
explains how railroad families are used in PC*MILER|Rail, and provides detailed 
descriptions of location entry, routing options, and how to save and load 
generated routes.  
 

4.1  About Railroad Routes  
A railroad route is identified by the following components: an origin, an optional 
sequence of intermediate points, a destination, and the railroads that connect them.  
There are two types of routes: single line and inter-line. 
 
Single line routes include an origin location, a destination location, and a single rail 
carrier serving them both.  Inter-line routes occur when different railroads serve 
the origin and destination points, or another railroad must be used to "bridge" the 
origin and destination carrier(s).  Inter-line routes require the entry of one or more 
railroad-to-railroad junction locations. 
 
Between any two rail points in North America, there are a large number of possible 
routes (traffic between Atlanta and Dallas could go via New Orleans, Memphis, or 
conceivably even via Chicago).  Realistically, there are a limited number of feasible 
or practical routings based on which railroads serve the points, their operations, and 
the junctions at which they interchange cars. 
 
When the same railroad serves both the origin and destination, a single line route is 
usually most practical.  While in some cases inter-line routes may be valid 
alternatives to competing single-line routes, they require coordinated effort between 
multiple railroads to interchange traffic and share the responsibility/revenue of the 
shipment.  In other cases, no single-line route exists and one or more inter-line 
routes are the only way to get between the origin and destination. 
 
In the U.S. and Canada, there are about 7,500 route-miles where railroads operate 
primarily in one direction over a rail line, with traffic in the opposite direction 
moving over an alternate route.  These directional routes are reflected in 
PC*MILER|Rail’s routing and mapping.  As an example, in the screenshot below, 
southbound UP traffic from Chicago to Houston moves via Shreveport, LA, 
whereas the northbound traffic moves via Little Rock, AR.  
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Example of Directional Routing Between Chicago and Houston 

 

4.2  PC*MILER|Rail Route Calculation  
PC*MILER|Rail uses a minimum impedance routing program for computing 
routes.  The link impedance used in route calculations is derived as distance 
multiplied by a cost factor, which essentially corresponds to route quality.  High 
density mainlines are given a lower link cost, while medium density mainline, 
medium density branchline, and low density branchline have higher cost factors.  
The minimum impedance route between any two nodes (geographic locations) on 
ALK’s Rail Network is the sequence of links whose impedance sum is less than 
that of any other sequence of links.  
 
PC*MILER|Rail routes can be run in Single Route entry mode (the user specifies 
railroads and junctions manually) or using the AutoRouter to calculate all 
possible routes between locations.  For interline routes calculated from the 
AutoRouter, junction interchange impedances are added to link impedances.  The 
junction impedance for the forwarding and receiving railroads is based on the 
historic volume of traffic interchanged at that junction to/from those railroads. 
 
Link costs and junction costs may be different for each of the PC*MILER|Rail 
routing types. Additionally, the link costs are adjusted to accommodate any 
directional routing arrangements. 
 
All the various cost factors have been derived from extensive research using 
railroad timetables, maps provided by railroads, the Official Railway Guide, 
Official Railroad Station List, Railroad Atlas, and county maps.  ALK has 

 
 PC*MILER|Rail User’s Guide 28 



 

periodically updated these costs over the years to maintain a good match with 
current realistic routes. 
 
PC*MILER|Rail includes six different routing formulas: Practical, Shortest, 
Intermodal, Coal/Bulk, Auto Rack, and Fuel Surcharge.  See section 4.10, 
Route Options, for a description of routing formulas and other options. 
 

4.3  How To Enter Railroad Locations for a Route  
To generate a route in PC*MILER|Rail, at least two locations must be entered as 
stops.  There are two ways to calculate a route: 
 

• Single Route Entry: If you know a route and just want to get the mileage, 
you can enter a sequence of locations and railroads manually in a single 
route entry window – select the Routes tab > New Route or <Ctrl+N> on 
your keyboard, then enter at least two stops and click Run.  During stop 
entry, a Junction Helper becomes available when a junction between two 
locations is needed. (See section 4.4 for more on single route entry.)   

 
• Using the AutoRouter: If you want PC*MILER|Rail to suggest possible 

junctions and connecting railroads between two points, you can use the 
AutoRouter – select the AutoRouter tab on the Ribbon, or <F6> on your 
keyboard, then enter at least two stops and click Run.  (See section 4.5 for 
more on using the AutoRouter.) 

 
In either a single route window or the AutoRouter window, stops can be entered 
using any of the formats listed below and described in sections 4.3.1 – 4.3.5.  For 
either type of route entry, the correct format must be selected in the route 
window using the format drop-down: 
 

 
 

• Standard Point Location Code (SPLC) 
• Freight Station Accounting Code (FSAC) 
• Location Name and State/Province/Estado Abbreviation (Station ST) 
• Eastern Railroad President's Conference Codes (3-3-3) 
• Rule 260 Junction Codes (R260) 

 
If a station is served by more than one railroad, a pick list of railroads will be 
generated.  For a complete list of railroad SCAC’s, select the Help tab > Quick 
Help or see Appendix D and E at the end of this User’s Guide. 
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Pick List of Railroads Serving Chicago, IL (partial list with scroll bar) 

 

 
4.3.1  Station Name and State Abbreviation 

 
Select Station Name, ST in the format drop-down, then type a station name and 
state abbreviation in the Station Name, ST and click Add Stop or press <Enter>.  
Station names, as listed in the Centralized Station Master (CSM), can be entered 
with either a comma or a space between the station name and state 
abbreviation; for example, “newark, nj”, “newark,nj” or “newark nj”. 
 
If you are typing in the full station name, it must be entered exactly as it appears 
in the PC*MILER|Rail database (and as listed in the Centralized Station Master), 
otherwise an error message will be generated.     
 
When entering a station name, you can use up to 20 characters, and 2 characters 
for the state abbreviation.  To see a table of official state/province/estado names 
and abbreviations, select the Help tab > Quick Help or press <F3>.  
 
If a station name contains two or more words, they must be separated by spaces; 
for example, “new <space>york, ny”. 
 
Some examples of valid station name entries are: 
 

TEXARKANA, TX 
ST LOUIS, MO 
SALT LAKE CIT UT 
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Common abbreviations occurring in station names are: 
 
NORTH N BRIDGE BR MOUNTAIN MT 
SOUTH S FORT FT PARK PK 
EAST E JUNCTION JCT POINT PT 
WEST W MINE MIN SAINT ST 

 
For spelling help, enter at least the first letter of the station, followed by an 
asterisk (e.g. “b* id”  or  “MO*PQ”) and the state/province/estado abbreviation.   
In the pick list of possible matches, highlight the correct location name and click 
OK or double-click. 
 

 
Station Name Entry 

 
 

 
Pick List of Matches for Search On “bo* id” 

 
 

4.3.2  Standard Point Location Codes (SPLC) 
 

Select SPLC from the format drop-down, then enter any valid 6-digit Standard 
Point Location Code and click Add Stop or press <Enter>.  
 
If you’re unsure of the SPLC or receive an error message, enter at least the first 
three digits of the code immediately followed by an asterisk to invoke a pick list 
of matches.  For example, you could enter “503*”. In the pick list of possible 
matches, highlight the correct location name and click OK or double-click your 
choice. 
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Pick List of Matches for Search on “503*” 

 

4.3.3  Freight Station Accounting Codes (FSAC) 
 

Select FSAC from the format drop-down, then enter any valid 5-digit Freight 
Station Accounting Code and click Add Stop or press <Enter>.  FSACs are 
unique to a given railroad: the same 5-digit FSAC may refer to a completely 
different location on another railroad.   
 
If you’re unsure of a particular FSAC or if you receive an error message, enter at 
least the first three digits of the code immediately followed by an asterisk to 
invoke a pick list of matches.  For example, you could enter “103*”.  Highlight 
the correct station in the pick list and click OK, or double-click the location to 
select it. 

 

 
Pick List of Matches for FSAC Search on “103*” 
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4.3.4  Eastern Railroad President’s Conference Codes (3-3-3) 
 

Select 3-3-3 from the format drop-down, then enter any valid Eastern Railroad 
President's Conference Code and click Add Stop or press <Enter>. 
 
An ERPC (or 3-3-3) is similar to a station/state spelling, except that 3-3-3 codes 
are limited to nine characters and abbreviated in accordance with the specific 
rules of Railinc and the National Industrial Transportation League (NITL).  These 
requirements are published in the Rail User's Manual by the NITL (1700 N. 
Moore St., Arlington VA). 
 
For help with 3-3-3 code entry, enter at least two letters followed immediately by 
an asterisk and the state/province/estado abbreviation to invoke a pick list. 
Highlight the correct station in the pick list and click OK, or double-click the 
location to select it. 
  
For station names of nine or fewer characters, the normal spelling is used in 3-3-3 
codes.  For longer station names or multiple-word names, abbreviations for 
common words as well as a 3-3-3 spelling convention are used.  In all cases, the 
two-letter state/province/estado abbreviation is required, with or without a space 
before it.  For example: 
 

SANTA FE     NM . . . becomes . . . SANFE    NM 
FORT WAYNE   IN . . . becomes . . . FTWAYNE  IN 
SALT LAKE CITUT . . . becomes . . . SALLAKCITUT  

 
 

 
Pick List of Matches for 3-3-3 Code Search on “sa* tx” 
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4.3.5  Rule 260 (R260) Junction Codes 
 

Select R260 from the format drop-down, then enter any valid R260 code and click 
Add Stop or press <Enter>.  For help finding a Rule 260 code, enter at least one 
letter followed by an asterisk (*).  
  
Rule 260 codes represent officially designated locations where two or more 
railroads interchange traffic with each other.  They are abbreviated by unique 5- 
character alpha codes designated by Railinc.  Examples of Rule 260 entries are: 
 

KANCY KCITY STRTR CHI* 
B*   BUFF BUTLR 

 
 

 

 
Matches for R260 Code Search on “bal*” 

 

4.4  Generating a Single Route 
If you already know the route you want and just need to get the mileage, you’ll 
probably want to enter a sequence of locations and railroads manually in a single 
route entry window.  Multiple single routes can be open at one time – routes can 
be browsed using the scroll bar that appears on the right side of the Routes 
window as needed. 
 
For single route entry, select the Routes tab > New Route or <Ctrl+N> on the 
keyboard to open a new route window.  The single route sequence is made up of 
an origin location and railroad, a destination location and railroad, and 
(optionally) intermediate locations or junctions that define the route for 
consideration. For each stop except the origin, PC*MILER|Rail will automatically 
designate the inbound railroad at each location as the outbound railroad from the 
preceding location.  
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In a new route window, follow these steps for single route entry: 
 

 

1.  Select a format from the drop-down menu in the route window: 
 

 
2.  To enter an origin, first type a station name or code using the  

selected format: 
 
 
 
 

 
 

 

3. Enter a SCAC in the Railroad field then click Add Stop or press <Enter>; 
or click Add Stop or press <Enter> to invoke a pick list of railroads that 
serve this station, then select a railroad from the list:   

 
 
 
 
 

      
or 

 

 
 
 
5.  Repeat steps 1-4 to enter a destination and, optionally, intermediate stops. 
 
6.  Click Run or press <F10> to generate a route and mileage.   
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Single Route Mileage Generated – Newark to Louisville 

 
 

4.4.1  Using the Junction Helper 
 
To run a single route, you must specify each location where a change of railroads 
(or railroad families) occurs.  In the example shown below, a warning is generated 
because Norfolk Southern does not get to Tacoma, WA: 
 
 

 
“Junction is Required” Warning 
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In this case, you would click the Junction Helper link in the warning to get a list 
of valid railroad junctions between Norfolk Southern and a railroad that serves 
Tacoma, or click the AutoRouter link to use the AutoRouter (see section 4.5). 
 

 
Junction Helper 

 
 

4.5  Using the AutoRouter 
To generate a list of valid railroad junction sequences between any two points in 
North America, follow the steps below to use the AutoRouter. 
 

 
The AutoRouter Window and Toolbar 
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1.  Select the AutoRouter tab on the Ribbon. 
 
2.  To enter an origin, select a format from the drop-down menu: 
 

 
 

 

3.  Type a station name or code using the selected format: 
 
 

 
 

 
 
4.  Click Add Stop or press <Enter> and make a selection in the pick list that 

opens (possible routes won’t be limited by the carrier you pick): 
 
 
 
 
 
 
 
 
 
 
5.  The drop-down in the RR column lists valid carriers for the entered location – 

uncheck any carriers that you do not wish to include.  To generate every 
possible route, “All Railroads” needs to be checked. 

 
 
 
 
 
 
 
6.  Repeat steps 2-5 to enter a maximum of two more stops (a destination, and 

optionally, a via junction that you want the route to pass through). 
 
7.  Click Run or press <F10> to generate a list of possible routes.   
 

8. To examine any route on the list, click its View button.  The route will be 
displayed as a single route in the Routes window and will be drawn on the 
map.  As a single route, it can be edited and rerun. 
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TIPS: The width of columns in a single route window can be changed – see 
section 4.7.  When multiple single routes are open, a scroll bar appears on the 
right side of the Routes window as needed for browsing. 
 
Typically, the number of routes generated will be a product of the number of 
railroads serving the origin times the number of railroads serving the destination.  
Exceptions occur when a railroad serves both origin and destination; it is unlikely 
that this railroad will participate in other inter-line routings.  Routes with the 
originating or terminating carrier having a switch move only (common with 
terminal railroads) may be included or excluded depending on whether Include or 
Exclude is chosen under Terminal Switch RRs in the Route Options dialog (see 
section 4.10).  Exclude is the default option. 
 
The generated AutoRoutes will be listed in order of fewest junctions between 
railroads of different families and fewest total miles.  Routes are shown as a 
sequence of railroad SCACs and Rule 260 codes. 
 
NOTE:  The routing algorithms used in PC*MILER|Rail are identical to those 
used in the traffic diversion studies for major railroad and government clients that 
ALK Technologies has produced since 1979.  The routes generated are listed in 
order of fewest junctions and least miles, and are not necessarily the best or most 
efficient routing options.  They are merely feasible, practical routings based on 
ALK’s observation of actual, historical traffic movements over many years. 
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4.6  Editing the Stop List 
The stop list in a single route or AutoRouter window can be edited using the right 
mouse menu off any stop on the list.  To open the right mouse menu, right click 
any stop on the list in a route window. 
 

 
 

Menu optionsare: 
 
Edit:  Change or edit the stop. 
Insert Stop Above:  Insert a stop above the selected stop (<F7> does the same). 
Zoom to Stop:  Zoom to a close-up view of the sekected stop on the map. 
Delete Stop:  Delete this stop  (<F8> does the same). 
Column Chooser…: Choose columns to hide/display (see section 4.7 below). 
 
To delete all stops in a single route window, press the <ALT><F8> keys 
simultaneously or select the Delete All Stops button on the Routes toolbar.   
 
 
For single route entry, editing tools are available on the Routes toolbar as well: 

 

 
 

To delete all stops in the AutoRouter, select Clear in the AutoRouter toolbar. 
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4.7  Column Widths and the Column Chooser 
The width of individual columns in a single route window can be adjusted – place 
the cursor over a column divider so that it becomes a horizontal arrow, then click 
and drag to the left or right. 
 

 
 
 
The columns in a single route window can also be hidden and the column order 
can be changed using the Column Chooser.  To access this feature, right click any 
stop on the stop list and select Column Chooser…. 
 
 

 
 
 
 
 
 
 
 
 
       
 
 
 
 
 
 
 
The Column Chooser lists all available columns for the window.  There are eight 
optional columns in a single route window and four in an AutoRouter window.   
 
In the Columns list, check a column to display it, or uncheck to hide it. 
To change the column order, select a column name and click Move Up or Move 
Down.  As the column name moves up the list, it will be moved to the left in the 
route window, and vice versa.  Click the Reset button to reset to the default 
column order. 
 
 
 
 
 
 

Right Mouse Menu Column Chooser for a Single Route Window 
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4.8  Route Entry Error Messages 
  

REMINDER:  Always check that the format selected in the format drop-down 
matches your input.  

 
 

Error Message Description 
NO MATCHES FOUND No matches were found in the database.  Check spelling 

on a station name, or format if using a station code. 
 

STATE ABBREVIATION 
REQUIRED 

Station name is missing, or input does not include a 
space or comma between the station name and state 
abbreviation; or there is no state abbreviation provided 
with an ERPC. 
 

STATION NAME MUST BE 20 
CHARACTERS OR LESS 

Input of more than 20 characters for a station name is not 
accepted.  This is a rare case, usually the first 20 
characters of the entered station name will be accepted if 
there is a match in the database. 
 

3-3-3 MUST BE 12 
CHARACTERS OR LESS 

Input of more than 12 characters for an ERPC is not 
accepted.  This is a rare case, usually the first 12 
characters of the entered ERPC will be accepted if there 
is a match in the database. 
 

SPLC MUST BE NUMERIC If “SPLC” is the selected format, input must be numeric. 

SPLC HAS MAXIMUM 6 
DIGITS 

SPLC input cannot be more than 6 digits long. 

FSAC MUST BE NUMERIC If “FSAC” is the selected format, input must be numeric. 

FSAC HAS MAXIMUM 5 
DIGITS 

FSAC input cannot be more than 5 digits long. 

INVALID STATE 
ABBREVIATION 

State abbreviation input is not a valid jurisdiction. 

A junction is required. Please 
click here for Junction Helper or 
use the Auto Router  

For single route entry, a junction is required between two 
stations that were entered.  Click the link in the message 
to open the Junction Helper or use the AutoRouter.  Or 
the station that triggered the warning can be deleted 
(<F8>). 
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BAD LOCATION-RAILROAD 
COMBINATION 

The railroad that was entered does not serve the entered 
location. 

RAILROAD NOT FOUND The railroad that was entered does not have a match in 
the database.  Refer to Appendix D or E for the correct 
SCAC, or in the application window select the Help tab 
> Quick Help. 

OPTIONS SET TO EXCLUDE 
INTERMODAL-ONLY 
STATIONS 

To include intermodal-only stations, select the Routes tab 
> Options and choose “Include” in the Intermodal-Only 
Stations drop-down. 

THE STATION ENTERED IS A 
NON-INTERMODAL STATION 
 

Intermodal is selected as the route type, and the station 
entered is a non-intermodal station.  Change either the 
station or the route type. 

 
 

4.9   Using Override Files For Recurring Data Errors, Custom 
Name Creation and Junction Interchange Preferences 

If you are experiencing recurring errors during route entry because the station or 
railroad you attempted to enter can’t be found in the PC*MILER|Rail database, 
there are override files you can use to correct this problem.  These text files are 
located in the RailNet subdirectory of your PC*MILER|Rail installation, usually 
C:\ALK Technologies\PCRWIN22\Data\Rail\Base\RailNet. 
 
The data override files can be used whenever different codes or names for stations 
in the user’s database do not exactly match those registered with the Centralized 
Station Master files, the source for the PC*MILER|Rail database.   
 
Additionally, the override feature allows users to run routes to new stations 
created after the latest release of PC*MILER|Rail, by using a neighboring station 
as a proxy to generate non-error routes with almost correct mileage. 
 
Override files can also be used to create custom location names (use the 
OVERRIDE.NAM file) and to edit or create junction interchange preferences for 
interline routing (use the OVERRIDE.JCT file).   
Each override file now includes instructions for its use, in comment lines 
beginning with the pound sign (#) at the top of the file.  Additionally, an 
“Example Override Data.txt” file containing examples is included in the same 
folder as the override files. 
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There are six override files for six types of station and railroad input: 
 
OVERRIDE.ERP 
OVERRIDE.FSC 
OVERRIDE.NAM 
OVERRIDE.SCA 
OVERRIDE.SPL 
OVERRIDE.JCT   
 
These files are blank initially (except for instructions), and may be filled with 
records (rows of text) in the correct format for each type.  The records you add 
will tell PC*MILER|Rail that “when this is entered, it means that”.  
 
The added records must include an input column and a translation column.  The 
input column contains an abbreviation or numerical configuration that a user 
might enter as a station location or railroad during route entry, and the translation 
column contains the valid entry for that location that PC*MILER|Rail will 
recognize because it matches what’s in the database. 
 
Follow the steps below to add records to an override file:  
 
1. Find the RailNet folder in your PC*MILER|Rail installation.  For a typical 

installation, go to: 

C:\ALK Technologies\PCRWIN22\Data\Rail\Base\RailNet;  

or if the installation location was customized, search for the RailNet folder 
using Windows Explorer. 

2. Right-click on one of the override files and select Open from the menu.   
(If you can do this successfully, skip to step 5, otherwise continue to step 3.) 

 

 

 

 

 

 
 

 

3. If Windows does not recognize the file type, a prompt will appear that asks 
how you want to search for an application that will open the file.  Choose 
Select the program from a list. 
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4.  A list of applications will open.  Select Notepad or Wordpad. 
 

 
 
 

5. In the override file, type your entries, matching the column structure 
appropriate to the file type (see descriptions for each file type below). 

6. To save your changes, select File > Save at the top of the Notepad or Wordpad 
window.  The stations, railroads and/or preferences you added will now be 
valid when you input them during route entry.   

 
Sample records for each file type are shown below.  Detailed instructions for 
adding entries are included at the top of each file, in lines preceded by the pound 
sign (#).  
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OVERRIDE.SCA 
 
TFM KCSM; 
 
The format for the entry must be: old or custom RR (SCAC) in positions 1-4, a 
blank, the proxy SCAC (recognized by PC*MILER|Rail 22), and a semicolon at 
the end. 
 

OVERRIDE.FSC 
 
ABCD 10000 09999;   
 
The format for the entry must be: RR SCAC in positions 1-4, a blank, the new or 
custom 5-digit FSAC, a blank, the 5-digit proxy FSAC (recognized by 
PC*MILER|Rail 22), and a semicolon at the end. 
 
OVERRIDE.SPL 
 
ABCD 110000 089999;   
 
The format for the entry must be: RR SCAC in positions 1-4, a blank, the new or 
custom 6-digit SPLC, a blank, the 6-digit proxy SPLC (recognized by 
PC*MILER|Rail 22), and a semicolon at the end. 
 

OVERRIDE.ERP 
 
PALMCV      PALMER   MA;  
HAGECSXT MD HAGERSTOWMD; 
SALT LAKEUT SALLAKCITUT; 
 
The format for the entry must be: 11-char ERPC/3-3-3 (new or custom code), a 
blank, the 11-char (including a 2-character state abbreviation in the last two 
places) proxy ERPC/3-3-3 (recognized by PC*MILER|Rail 22), and a semicolon 
at the end. 
 

OVERRIDE.NAM 
 
MOOJAW SK MOOSE JAW SK; 
YOYO IL   CHICAGO IL; 
 
The format for the entry must be: up to 22-char name (new or custom station 
name), a blank, the up to 22-char (including a 2-character state abbreviation in the 
last two places) proxy Station Name (recognized by PC*MILER|Rail 22), and a 
semicolon at the end.   
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OVERRIDE.JCT 
 
BNSF CSXT BHAM  P A; 
BNSF CSXT BHAM  C A; 
BNSF NS   CHGO  I F; 
BNSF NS   CHGO  A F; 
 
The columns in this file from left to right are: 

- RR1, up to 4 characters followed by 1 blank  
- RR2, up to 4 characters followed by 1 blank  
- R260 junction code, up to 5 characters followed by 1 blank 
- Route type to which the preference will be applied (P=Practical, C=Coal/Bulk, 

I=Intermodal, A=Auto Racks), 1 character followed by 1 blank 
- Type of preference (A=Avoid, F=Favor), 1 character followed by a semicolon 
 
See section 4.11 for an alternate way to create junction interchange preferences. 
 
 

4.10  Route Options 
PC*MILER|Rail gives you several options to choose from when running a route.  
The available options vary depending on whether you use single route entry or the 
AutoRouter (see sections 4.10.1-4.10.3 below for option descriptions).  Route 
options affect how rail lines and junctions are selected for a route, total route 
mileage, and (with AutoRouting) the number of routes that are generated. 
  
There are three ways to open the Route Options dialog: 
 
1. Select the Options button in the Routes or AutoRouter tab. 
 
 

2. Select the gear button > Options in a single route or AutoRouter window. 

3. Press < F4>.  

4.  After selecting your options, click on OK to close the dialog and save your 
edits. 

 
Options in the Route Options dialog must be re-selected for each route you run.  
To set default options for a single route, see section 4.10.2.  
 
NOTE: See section 4.2, PC*MILER|Rail Route Calculation, for general 
information about how routes are calculated. 
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4.10.1  Options for Single Routes 
 

 
Route Options for Single Route Entry 

 
 

• Route Name:  To give a route a custom name, type the name in this field.  
This name appears in the route window, on reports, and on the Route Legend 
in the map window. 

  
• Intermodal-Only Stations:  This option indicates whether to Include or 

Exclude stations that provide only intermodal service.  Note that when the 
Intermodal route formula is selected (see below), excluding intermodal-only 
stations is not an option. 

 
• Route Preference:  Six route formulas are available to generate routes:   

 
- Practical routings simulate the most likely movements of general 

merchandise train traffic. Main lines are prefered to branch lines. A 
Practical route can sometimes be more circuitous than the shortest 
possible route.   

- Shortest route calculations find the rail route with the least distance 
between the stops. For single routes, the shortest path within the railroad is 
determined for each segment. In the AutoRouter, the shortest path across 
all North American railroads is calculated, irrespective of the origin and 
destination railroads chosen by the user. 

- Intermodal, Coal/Bulk, or Auto Racks may be used to determine the 
exceptional routings that these types of trains sometimes require. 

- Fuel Surcharge routing is essentially a combination of the Shortest and 
Practical route formulas (because some railroads use Shortest mileage and 
some use Practical mileage when figuring their fuel surcharges). It 
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provides mileage suitable for calculating fuel surcharges in conformance 
with the Surface Transportation Board ruling STB Ex Parte No. 661.  See 
Appendix C, Fuel Surcharge Railroad Reference, for which railroads use 
Practical vs. Shortest routing. 

 

• Distance Units:  Choose whether distances should be calculated in Miles or 
Kilometers. 

 

4.10.2  Setting Default Route Options (Single Route Only) 
 
Default route options can be set for single route entry, so that every time you open 
a new route window those options are automatically selected for the new route.  
Default values can be edited.   
 
To set default route options for a single route, select the Routes toolbar > 
Defaults.  Defaults for all options except the Route Name can be specified. 
 

 

4.10.3  Options for AutoRoutes 
 

Route options for AutoRoutes are the same as for a single route, except that: 
1) a custom route name cannot be entered; and 2) a terminal switching option 
is provided: 
 

• Terminal Switching:  When using the AutoRouter, routes with the originating 
or terminating carrier having a switch move only (common with terminal 
railroads) may be included or excluded.  The default for this option is Exclude.  
This option affects the number of routes that are generated. 

 

 
Route Options for AutoRoutes 

 
 Chapter 4: Using PC*MILER|Rail 49 



 
  

4.11  Avoid or Favor Interchange Junctions in the AutoRouter 
PC*MILER|Rail enables users to designate junction interchanges to be avoided or 
favored on a route.  These custom interline routing preferences are specified for 
the AutoRouter, and apply to both directions.   
 
Preferences are stored in an “OVERRIDE.JCT” text file that may be viewed and 
edited, allowing the user to manually add a long list of junctions to be avoided or 
favored if desired (see section 4.9 on editing these files). 
 
 

 
Avoid/Favor Junctions Dialog 

 
 
In the Avoid/Favor Junctions dialog, you enter railroad and location data to 
generate a pick list of all available junction interchanges.  You can then select a 
junction to avoid or favor from the pick list.  The three possible railroad/location 
combinations that can be entered are: 
 

• Enter a station name or R260, and one SCAC in either the Railroad 1 or 
Railroad 2 field, to generate a pick list of all junctions at the specified 
station for the entered railroad. 

• Enter two SCACs to generate a pick list of all stations with junction 
interchanges between those two railroads. 

• Enter a station name or R260 and two railroads.  If a pick list is generated, 
it will include only a very small number of choices.   
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The steps below provide an example of how to designate a junction to be avoided 
or favored in AutoRoutes.  This example uses the BNSF and CSXT railroads and 
Birmingham, AL as a junction to be avoided: 
 
1.  Select the AutoRouter tab > Avoid/Favor Junctions or hit <Alt+F2> on your 

keyboard to bring up the Avoid/Favor Junctions dialog. 
 
2. In the Avoid Junctions tab, enter “BNSF” as Railroad 1 and “CSXT” as 

Railroad 2.  (Note that either Railroad 1 or Railroad 2 can be the forwarding or 
receiving carrier.) 

 
3. Check one or more route type(s): AutoRacks, Coal, Practical, Intermodal. 

 
3. Click Add. 
 
4.  A Junction Helper pick list of all stations that have an interchange between 

BNSF and CSXT will open, with Birmingham, AL highlighted at the top.  
Click OK to add the BNSF-CSXT junction at Birmingham as a junction to be 
avoided. 

 

 
Pick List of BNSF-CSXT Interchanges 

 
 

NOTE:  If you attempt to add a duplicate of an existing junction preference 
(either of the same type, or adding an avoid as a favor or vice versa), an error 
message will be generated.  
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Birmingham, AL Designated As a Junction to Be Avoided 

 
 
NOTE:  Column widths can be adjusted in the Avoid/Favor Junctions dialog.  
 
A generated route from Little Rock, AR to Jacksonville, FL is shown below.  This 
route uses BNSF as the origin railroad and CSXT as the destination railroad, and 
illustrates the effect of a junction preference.   
 
The first screenshot shows the route before the preference was added; and the 
second screenshot shows how the route avoided Birmingham after that junction 
was designated to be avoided, routing through Memphis, TN instead.  
 
Before – Route Uses Birmingham, AL as an Interchange: 
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After – Route Uses Memphis, TN (Avalon Station) as an Interchange: 
 

 
 

 
To delete a preference in either the Avoid Junctions or Favor Junctions tab, 
click the Delete button on the same line as the preference, in the last column on 
the right.  To delete all preferences on the list, click Delete All. 

 
 

 
Delete an Avoid or Favor Preference 

 
 

Here is an example of saved junction preferences as they appear in the 
OVERRIDE.JCT text file, usually found in C:\ALK Technologies\PCRWIN22\ 
Data\Base\Rail\Railnet (see section 4.9): 

 

Delete 

Delete All 
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BNSF CSXT BHAM  P A; 
BNSF CSXT BHAM  C A; 
BNSF NS   CHGO  I F; 
BNSF NS   CHGO  A F; 
 
The columns from left to right are:  
- RR1, up to 4 characters followed by 1 blank  
- RR2, up to 4 characters followed by 1 blank  
- R260 junction code, up to 5 characters followed by 1 blank 
- Route type to which the preference will be applied (P=Practical, C=Coal/Bulk, 

I=Intermodal, A=Auto Racks), 1 character followed by 1 blank 
- Type of preference (A=Avoid, F=Favor), 1 character followed by a semicolon 

 
As mentioned, an unlimited number of preferences may be added manually to this 
file, in the format shown above. 
 

4.12  Changing the Map Data Set 

The PC*MILER|Rail industry-standard rail network database is updated annually 
to include the most current data available for each version release, and three 
additional updates to the base data are provided throughout the year.  Beginning 
in Version 20, each update is downloaded to a separate folder and users can 
choose which dataset to use at any time.  The active data set will always be 
displayed in the title bar of the application window, for example “22.0_Base”. 

To switch between data sets, in the PC*MILER|Rail application window select 
the Map tab > Change Data Set > and choose a set from the menu.  You will be 
prompted to close the PC*MILER|Rail application to apply the new data set. 
   
Note that for a data set other than the yearly base version to be available, it must 
have been downloaded using the Check for Updates tool in the Help toolbar.  

 

 
Change Data Set Menu 

 
 PC*MILER|Rail User’s Guide 54 



 

4.13  Saving and Loading Routes 
Routes may be saved for future use or reference.  Saving routes enables you to 
create a library of standard routings that can be maintained over time and re-used.   
 
To save a new route, select the Routes tab > Save > Save Route As to bring up the 
Save Route dialog.  The format of this dialog is a standard Windows feature for 
saving your files.   
 
 

 
Saving a Route 

 
 
Choose a drive and folder where you want the file to be saved, and type a file name 
in the File Name field.  Valid file names can be any length (though they are 
truncated when displayed in DOS).  Spaces, periods and other punctuation marks 
are not valid characters for the file name. 
 
To load a previously saved file, select the Routes tab > Open to open a standard 
Windows dialog for opening files.  Locate your route file and click Open.  
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4.14  Route Duplication 
Route duplication offers an efficient way to compare how different options will 
affect routing between the same locations.  To duplicate a route including all 
stops, carrier information and options, click on its route entry window to activate 
it and select the Routes tab > Duplicate.   
 

 

 
 
 
 
 

 
 
 

 
Duplicate Route Comparison: Practical vs. Shortest 
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Route Output: 
Route Window, Reports & Maps 

 
 
Routes between stops are calculated by PC*MILER|Rail using one of six routing 
formulas.  The output for every generated route includes leg and cumulative 
mileage in the route window and a map display of the route.  Optionally, up to six 
different route reports can also be generated. 
 

5.1  Output in the Route Window 
The output from each generated route includes leg mileage between stops and 
cumulative mileage for the whole trip.  Additionally, by default the station name 
and state, SPLC, FSAC, R260 and SCAC are displayed in columns for each 
station on the stop list.   
 
The width of individual columns in a single route window can be changed, and 
columns can be added, hidden, or moved – see section 4.7, Column Widths and 
the Column Chooser.) 
 
 

 
Output in a Route Window 
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5.2  Reports 
To generate reports for a route, the route must be active (click on the title bar of 
the route window).  Select the Routes tab > Reports and choose a report from the 
drop-down.   

 

 
Reports Menu in the Routes Toolbar 

 

Reports appear in a tabbed window when they are generated.  To change the 
position of the reports window, select an option from the Window toolbar on the 
Ribbon.  Alternatively, the reports window can be floated outside the application 
window – use the Window Position menu in the upper right corner.  
 
 

 
Reports Window in the Default Location 

Window Position 
Menu 

Report Tabs 
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5.2.1  Detailed Report 
 
The Detailed Report lists all points on the route, along with leg and cumulative 
mileage between the origin and destination.  At the bottom of the report you’ll also 
see summaries of leg mileage by state and by railroad. 
 
 

 
Trip Destination and State Mileage Summary in the Detailed Report 

 
 

5.2.2  Detailed Geocode Report 
 
The Detailed Geocode Report includes the same information as the Detailed 
Report, but also lists the SPLC, 3-3-3, and R260 for each stop. 
 

 
Detailed Geocode Report 
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5.2.3  Key Station Report 
 
The Key Station Report includes the user-specified stops on the route with leg 
and cumulative mileage, and leg mileage summaries by state and railroad at the 
end. The SCAC, SPLC, station name and state, 3-3-3 and R260 codes are shown 
for each key station. 
 
 

 
List of Stops in the Key Station Report 

 
 

5.2.4  Mileage Summaries 
 

The last three options in the Reports menu are leg mileage summary reports: 
By Railroad, By State, and By Railroad and State. 
 

 
Leg Mileage Summary Report by Railroad and State 
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5.2.5  Font Size and Page View 
 
Each report that is generated will be displayed with a toolbar that enables editing 
the page view and font size.   
 
To change the font size in the active report, use the Font Size drop-down.  For 
page view adjustments, there are eight buttons that control page layout (portrait 
vs. landscape) and magnification.  Place your cursor over any button to see a 
tooltip that tells you what the button does. 
 
 
 
 
 
 

 
 
 
 
 
 

5.2.6  Printing and Copying Reports 
 
 There are two ways to print a report: 
 

1. Click the Print icon on the report window toolbar. 

 

   

     2. Press the <Ctrl+P> shortcut on your keyboard.   
 
 
To copy a report to the clipboard for use in another application: 
 

1.  Click the Copy icon on the report window toolbar. 
 
 
 
 

2.  Press <Çtrl+V> to paste the report contents into  
your target application such as Microsoft Word.  

 
     
 

Page View Controls Font Size Control 

Tooltip 
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5.2.7  Saving Reports 
 
To save PC*MILER|Rail reports to disk: 
 

1. Select the File application menu > Save Report to File. 
 
 
 

2.  In the Save Report dialog, select the folder where the file will be saved 
and enter a file name in the File Name field. 

 
3.  Click Save.  

  
 

 
Save Report Dialog 
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5.3  Route Maps 
 

 
Routes Framed in the Map Window 

 
 
By default, PC*MILER|Rail automatically draws each generated route in the map 
window.  This enables you to examine routes in detail, visually evaluate routing 
alternatives, and to perform a variety of "what-if" analyses.  
 
If the map window is hidden, select the Window tab > Map Window. The map 
window can be floated outside the main application window – use the Window 
Position menu in the upper right corner.  
 
 

 

5.3.1  Zoom Options 
 
The PC*MILER|Rail map window features 20 possible zoom levels.  You will 
see the current zoom level in the window’s title bar (e.g. “Zoom Level 14 of 20”).     
 
To zoom into a specific area, select the Map tab > View group > Box Zoom (this 
option is turned on by default).  Then drag a box around the target area: press and 
hold the left mouse button down and drag the cursor on the map. 
 
To zoom directly to a stop in the route window, highlight it on the stop list, 
then do one of the following:  

• double-click the highlighted stop; 
• right-click the stop name and select Zoom to Stop from the menu; 
• select the Routes tab > Route group > Frame Stop on Map button;  
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Other ways to zoom your view of the map are:  

• simply double-click a point on the map; 
• use your mouse’s scroll wheel: roll up to zoom in, down to zoom out; 
• choose Zoom In or Zoom Out from the right mouse menu off the map; 
• or use the slider bar and compass in the upper left corner of the map as 

follows: either 1) click, hold and drag the zoom control to move up (zoom 
in) or down (zoom out); or 2) click the plus sign or minus sign to move up 
or down one zoom level.  To pan north, south, east or west as needed, 
click the directional arrows on the compass.   

 
 
 
 
 
 
 
 
 
 
 
 

5.3.2  Frame Options 
 

 
Frame Options on the Map Toolbar 

 
  

Framing options in the Map tab > Frame menu are: 
 

• Frame Areas:  Select an area to frame. 
• All Routes:  Frame all generated routes. 
• Auto Frame Routes: Toggle this option on to automatically frame each 

route after it is run. 
• Frame One Route:  All open routes are listed, select one to frame. 

 
To frame a stop on the map, select the Frame Stop on Map button in the Routes 
tab under Stops.   
 

Zoom Control 

Compass 

Zoom Out 

Zoom In 
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5.3.3  Drag Map or Pan To Shift the View 
 
Drag the Map: 
Select Drag Map in the right mouse menu off the map or click the Map tab > 
Drag Map.  With your cursor (now in the shape of a hand) in the map window, 
hold the left mouse button down and drag in the desired direction.  The map will 
redraw the new view. 
 

To turn this feature off, click Drag Map again. 
 
Pan: 
One way to pan the map is: select Pan in the right mouse menu off the map, then 
select any direction from the sub-menu.  You will see the map view shift in the 
chosen direction.  Other ways to pan are using the scroll bar (see section 5.3.4 
below) or the compass (see section 5.3.1). 
 

 
5.3.4  Scroll Bars in the Map Window 

 
The PC*MILER|Rail map window includes scroll bars that are hidden until 
activated.  To activate, touch any edge of the map window with your cursor and a 
translucent scroll bar will appear.  Click on this scroll bar to move the map 
incrementally in the direction indicated by the arrow, or click and hold to pan 
your view. 
   

 
 
 
 

 
  Scroll Bar for Map Panning 

Scroll Bar with 
directional arrow 
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5.3.5  Hiding and Displaying Map Features 
 
You can control which features are displayed and in what order features are 
drawn on the map using the Map Features dialog.  Select the Map tab > Map 
Features. 
 
 

 
Map Features Dialog 

 
 
The Map Features dialog lists all the available feature layers.  Features that are 
checked are  displayed.  To hide a feature layer, uncheck it.   
 
To show or hide all features, use the Show All and Hide All buttons.  Click on the 
Reset button to return to the default display. 
 
In the column on the left, feature layers are listed in the order they are drawn on 
the map: features on the bottom of the list are drawn under the ones at the top. To 
raise or lower a feature layer, highlight it and click Up, Down, To Top, or To 
Bottom.  Feature layers in the column on the right can be hidden, but the order in 
which they are drawn can’t be changed. 
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5.3.6  Turning Map Labels On and Off 
                              
 

                                                               
 
 
Railroad shields, station labels, and stop labels on the map can be added and 
deleted using the mouse.    
 
To Add or Remove Station Labels: 
 

1. Select the Map tab > Label Stations or select Label > Label Stations in the 
right mouse map menu.  The cursor changes to:   

 
 
 

2. Click on any point on the map where a station is located to label it.  To 
remove an existing label, click on it. 

 
To Label Railroads: 
 

1. Select the Map tab > Label Railroads or select Label > Label Railroads in the 
right mouse map menu.  The cursor changes to:   

 
 
 

2. Click on any point on a rail line to label it. To remove an existing label, click 
on it. 

 
To Clear All Station and Railroad Labels: 
 

To clear all station and railroad labels that were added manually, select the Map 
tab > Clear Labels or Label > Clear Labels in the right mouse map menu. 
 
To Label Stops: 
 

1.   Select the Map tab > Stop Labels or Stop Labels > in the right mouse map menu. 
 

2. Select > Station Name to label stops with a station name, and/or > Railroad to 
label with a SCAC. 
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5.3.7  Controlling the Display of Railroads 
 
You may wish to choose which railroads are displayed on the map.  To do this, first 
make sure “Railroads” is turned on in the Map Features dialog (Map tab > Map 
Features).  Then select the Map tab > Map Railroads. 
 
All available railroads and systems in North America are listed in two lists in the 
Railroad Display Control dialog.  Checked railroads will be displayed.  All 
railroad systems are drawn by default when “Railroads” is turned on in the Map 
Features dialog. 
   
Use the Show All/Hide All buttons to display/hide all railroad systems.  
Individual railroads must be checked and unchecked one at a time.   
 
If Display Track Ownership is checked, the colors used to draw rail lines on the 
map will reflect track ownership rather than trackage rights.  Check Frame 
Railroad(s) to frame the systems that are checked on the list.  Click Reset to 
return to the default display setting for all railroads. 
 
 

 
Railroad Display Control Dialog 

 
 

5.3.8  Legends 
 
There are three legends available in the map window: Route, Carrier and Scale of 
Miles.  All legends can be moved around within the map window by clicking and 
dragging.  To hide or show a legend, select the Map tab > Legends and toggle one 
or more legends on/off. 
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  If checked, the Route Legend appears after a route is run; the Carrier Legend 
appears when railroads are displayed; and the Scale of Miles always appears as 
part of the map. 
 
The Carrier Legend provides a key to the display of rail lines owned or operated 
through trackage or haulage rights.  By default, rail lines are drawn in different 
colors that show which railroad holds the trackage rights on any given line.  
However, if Display Track Ownership is checked in the Railroad Display 
Control dialog, the colors will reflect ownership (see section 5.3.7).  In this case 
there will be a color that indicates joint ownership.  To see which railroads jointly 
own a particular rail line, select the Map tab > Label Railroads then click on that 
rail line on the map. 
 

                         
    Route Legend      Carrier Legend         Scale of Miles 
 
 
 

5.3.9  Right Mouse Map Menu Options 
 

 

 
Right Mouse Map Menu 

 
 
You can right click anywhere on the map to bring up a map menu.  Most of the 
options on the Map toolbar can also be accessed from this menu. 
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5.3.10  Printing a Map    
 
To print the currently displayed map, select the Map tab > Print Map on the 
toolbar or File menu > Print Map.  A standard Windows Print dialog will open. 
 

 
 

 

 
Standard Windows Print Dialog 

 
 

5.3.11  Copying a Map to the Clipboard 
 
Maps can be copied to the clipboard for retrieval in other Windows programs 
such as Microsoft Word.  To do this, select the Map tab > Copy Map.  
 

  
 
 

 
      
 
 
 
 
 
 
 

                                    A Map Copied Into Microsoft Word 
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Two Sample Routes  
 
 

6.1  Single Route Entry: Atlanta, GA to Omaha, NE 
Our sample route in a single route window will generate mileage from Atlanta, 
GA on CSXT to Omaha, NE on BNSF using the Shortest route formula.  Because 
CSXT doesn’t run to Omaha, we’ll use the Junction Helper to find a junction 
interchange for the route. 
 
 
1. In the application window select the Routes tab > New Route. 

2. We’ll go with the default Station Name, ST format for a station – click on the 
station field in the new route window and type “atlanta ga”, then click Add 
Stop or press <Enter> on your keyboard. 

3. Select CSXT from the pick list and click OK. 

 
 

4. Enter “omaha ne” as above, selecting BNSF as the carrier.   

5. Click the Junction Helper link in the prompt that appears. 
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Junction Helper link 
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6. In the Junction Helper, click OK to select the first entry on the list 

(Birmingham, AL). 

 

7. Select the Routes tab > Options. 

8. In the Route Options dialog, type “Atlanta-Omaha” in the Route Name field, 
then click OK.  The custom route name will appear in the route window, on all 
reports, and in the Route legend on the map. 

 

 

9. Click Run or press the <F10> key.   
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Generated Route – Atlanta to Omaha via Birmingham 

 
 

Mileage appears in the route entry window when processing has finished, and the 
route is drawn on the map.   

 
From here, you might choose to select one of the following in the Routes tab: 
Reports > to generate one of six route reports; Duplicate > to duplicate the route 
and change routing options for a comparison; or Save > to save the route for future 
use. 
 
To clear all stops from the route window, select the Routes tab > Close or the Delete 
All Stops button.  
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6.2  Using the AutoRouter: Atlanta, GA to El Paso, TX 
The AutoRouter feature is a valuable tool for determining which railroads serve 
the origin or destination, and how they connect via intermediate junctions.  It 
enables you to set customized railroad routing preferences and get back several 
routes to choose from. The sample route below from Atlanta to El Paso uses the 
Shortest route formula. 
 
 
1. In the application window select the AutoRouter toolbar on the Ribbon.   
 
2. To enter an originating railroad, type “atlanta ga” in the Station Name, ST 

field and click Add Stop or press <Enter> on your keyboard. 
 

 
 
5. A pick list showing all railroads that serve Atlanta will open – click OK.  (It 

doesn’t matter which railroad you choose here.) 
 

 
 

6. Click the drop-down list of railroads for Atlanta and uncheck CSXT to exclude 
it from consideration. 

 

 
 
7. Enter “el paso tx” as the destination of this route. 
 
8. Click OK in the pick list of railroads that opens. 
 
9. Click Run. 
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10. After processing, all feasible routes will be listed below.  Note that the 
number of available railroads and routes generated will be affected by the 
Include/Exclude options in the Route Options dialog (see section 4.10). 

 

 

 
 

11. Click the View button for the second Norfolk Southern route to see its details 
displayed in a single route window and drawn on the map. 

 

 
 
 
The options for an AutoRoute can be edited like any other single route – select 
Options in the AutoRouter toolbar.  This can be especially useful when the 
AutoRouter is relied on to generate a valid junction interchange and the route then 
needs to be re-run for Fuel Surcharge mileage. 
 
Click the AutoRouter tab to go back and examine another route.  To clear the 
AutoRouter, select the AutoRouter toolbar > Clear. 
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     About ALK Technologies, Inc. 
 
 

7.1  About ALK Technologies 

ALK® Technologies, Inc., a Trimble® company headquartered in Princeton, NJ, 
was founded in 1979 as a transportation industry pioneer. ALK harnesses the 
power of information technology to enhance transportation and mobility, 
supporting competitive advantage and improved quality of life. 
 
Today, ALK is a global leader in GeoLogistics® solutions and navigation 
software, focused on developing innovative solutions for transportation, logistics, 
mobile workforces and consumers. Product lines include award-winning 
CoPilot®, a leading source of GPS navigation software for fleets, mobile 
operators, hardware OEMs, systems integrators, professional drivers and 
consumers. ALK’s PC*MILER® is widely recognized as a transportation industry 
standard for routing, mileage and mapping. ALK® Maps is a development 
platform designed for the transportation industry and provides commercial 
routing, geocoding and mapping visualization for enterprise applications. 
 
See section 7.2 below for an overview of ALK’s Enterprise Solutions.  For 
detailed product information, visit us at www.alk.com or www.pcmiler.com. 
 
  
 
 
 
 
 
  
 
 
 
 

 
 
 
 
 
 
 
 

7 C
ha

pt
er

 

 
 PC*MILER|Rail User’s Guide 76 

http://www.alk.com/
http://www.pcmiler.com/


  

7.2  Enterprise Solutions from ALK Technologies 
Contact an Enterprise Solutions account executive to find out how the following 
solutions can boost productivity, reduce out-of-route mileage and improve return 
on investment.  For more detailed information on each product, go to 
www.pcmiler.com.   
 
• PC*MILER — PC*MILER is truck-specific, point to point routing, mileage 

and mapping software that the transportation and logistics industry depends 
on to succeed. Accuracy and reliability have positioned PC*MILER as the 
software used by 98 of the top 100 motor carrier, 46 of the top 50 freight 
transportation firms and 47 of the top 50 logistics companies in North 
America. The U.S. Department of Defense (DoD), the General Services 
Administration (GSA) and the Federal Motor Carrier Safety Administration 
(FMCSA) also rely on PC*MILER as their worldwide distance standard. 

• PC*MILER|Streets — PC*MILER|Streets is street-level routing, mileage 
and mapping software designed to provide dock-to-dock driving directions 
over truck-specific routes.  It includes all the features and functionality of 
PC*MILER plus an enhanced street-level routing network, map database, and 
street address database. Ensure that your vehicles and loads get to the right 
place using the most precise truck-specific route possible, taking into 
consideration truck-preferred and truck-restricted roads. PC*MILER|Streets 
data is available for the U.S. and Canada and, with PC*MILER|Worldwide, 
for many countries outside North America. 

 
• PC*MILER|Traffic — PC*MILER|Traffic calculates more accurate transit 

times and ETAs with real time, historical and predictive traffic speed data. It 
allows visualization of traffic trends directly on the PC*MILER map. 
PC*MILER|Traffic includes a “Fastest” routing type that optimizes overall 
transit time, taking into account real time traffic congestion and predictive 
traffic speeds, by the hour and by the day. 
 

• PC*MILER|Tolls — PC*MILER|Tolls calculates truck-specific toll costs 
based on a vehicle’s weight, axle count, trailer count, transaction type (cash or 
discount program), and time of day travel in the U.S. and Canada. It is driven 
by the same technology and map data set as ALK's industry-standard 
PC*MILER routing, mileage and mapping software. When generating routes, 
truck-specific toll costs are added into a route’s overall calculation. Determine 
whether it's more cost-effective to take a toll route, or a non-toll route with a 
few additional miles, before routing a vehicle.  

 
• PC*MILER|HazMat — PC*MILER|HazMat generates point to point and 

street-level routes, mileage and driving directions for hauling hazardous 
materials and dangerous goods in the U.S. and Canada. Federal government 
mandates state that shippers and carriers are to implement security plans 
regarding the transport of hazardous materials. A major step in that process is 
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providing drivers with routes and mileage that ensure compliance with these 
federal, state/province and local restrictions and route designations. To ensure 
fleet and driver safety, PC*MILER|HazMat identifies where drivers should 
legally be traveling for the particular type of hazardous commodity they are 
hauling.  
 

• PC*MILER|Worldwide — PC*MILER|Worldwide is point-to-point routing, 
mileage and mapping software that generates routes, distances, maps and 
driving directions over the entire international highway network. Employ the 
functionality of PC*MILER across worldwide data coverage, including 
Africa, Asia, Europe, the Middle East, North America, Oceania, and South 
America.  Additionally, street-level address data modules are available for the 
U.S. and Canada, Europe, and many countries in worldwide regions. 

 
• PC*MILER|BatchPro — PC*MILER|BatchPro is a batch-processing tool 

that permits the simultaneous processing of large volumes of lanes (set as 
origin/destination pairs) entered as city/state combinations, ZIP or Postal 
Codes, or latitude/longitude coordinates rather than entering routes 
individually. It gives you the ability to generate routes, mileage, as well as 
cost and time information per route. 
 

• CoPilot® Truck — CoPilot Truck offers an easy to use, intuitive interface 
with spoken turn-by-turn directions and easy to follow, non-distracting 
guidance displays. Unlike standard car navigation systems, it calculates 
efficient routes based on your vehicle profile information, routing parameters 
and load type, including hazardous materials.  Running conveniently on a 
wide range of smartphones, tablets and laptops, CoPilot Truck uses street-
level ALK Digital Maps™ enhanced with industry standard PC*MILER 
truck-specific attributes featuring 3.52 million commercial truck restrictions 
and allowances. With powerful multi-stop routing it effortlessly provides the 
optimal route for any itinerary, while automatically avoiding commercial 
truck restrictions to increase efficiency, reduce mileage and help avoid costly 
fines and vehicle damage. 

• RouteSync – RouteSync provides the transportation and logistics industry 
with a crucial link between the planned route in the back office and the 
navigated route in the cab.  RouteSync delivers the guidance to drive the miles 
that are being billed.  Using RouteSync, dispatchers can send PC*MILER 
optimized routes directly to drivers running CoPilot Truck on an on-board 
device, smartphone or tablet.  

• ALK® Maps – ALK Maps is a JavaScript API for interactive visualizations 
tailored to the transportation industry.  Powered by the same core technology 
that drives ALK’s portfolio of GeoLogistics® and navigation software 
solutions, ALK Maps provides a high-quality customized alternative to 
consumer mapping services that can be used in web applications, mobile apps, 
or desktop products.  With only a few lines of code, an interactive map can be 
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displayed; and a few more lines of code enables route generation and address 
geocoding.  ALK Maps is designed to get you up and running quickly and 
with less overhead. 

 
• PC*MILER|Web – PC*MILER|Web is an internet-based version of 

PC*MILER, available in monthly, quarterly or annual subscription packages.  
This product is perfect for owner operators, fleets, brokers, or anyone else 
who needs instant, accurate mileage for rate calculation or truck-specific 
driving directions or maps.  And it’s accessible on the web through any 
internet-connected computer, in the office, at home, or on the road. 

 
• PC*MILER|Rail — PC*MILER|Rail is the rail and logistics industry's 

leading point-to-point routing, mileage and mapping software. Widely used in 
fuel surcharge calculation, equipment management, rail car mileage auditing, 
carrier selection, rate determination and negotiation, and ad valorem tax 
reporting, PC*MILER|Rail determines actual operating or fuel surcharge 
routes and mileage using station/state abbreviations or railroad industry codes. 
Through ALK’s close working relationship with all major railroads, 
PC*MILER|Rail features the most accurate digital representation of the North 
American rail network. 

 
 

CONNECTIVITY and INTERFACE PRODUCTS 
   
• PC*MILER|Connect — PC*MILER|Connect seamlessly interfaces 

PC*MILER routes, mileage and reports with third-party and custom systems, 
such as transportation and logistics management software systems. Client 
applications are able to retrieve PC*MILER distances, detailed driving 
directions, drive times, state-by-state mileage summaries, stop optimization 
functionalities and more. 
 

• Multi-Version Switch (MVS) — Multi-Version Switch is a high-end 
function of PC*MILER|Connect that serves as an integration tool designed to 
simultaneously support multiple versions of PC*MILER that are installed on 
one server or on several different servers.  Instead of manually querying data 
from each individual version, the Multi-Version Switch functions as the main 
connection point to programmatically gain access to the version of choice. 
 

• PC*MILER Web Services — PC*MILER Web Services is an integration 
tool designed to efficiently fulfill all PC*MILER routing, mileage and 
mapping transactions in a simple hardware and software-agnostic system 
interface to any computing platform. It offers a standardized way of 
integrating PC*MILER with Web Services, .NET, or Web-based applications 
using XML (Extensible Markup Language) and SOAP (Simple Object Access 
Protocol) over an Internet Protocol Backbone – all developed in Microsoft® 
.NET. 
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• PC*MILER|Mapping — PC*MILER|Mapping seamlessly interfaces 
PC*MILER routes and geographic data on maps for integration with real-time 
dispatch and operations analysis programs. PC*MILER|Mapping allows you 
to include commands in spreadsheets, databases and custom systems to obtain 
a visual overview of your data.  
 

• PC*MILER|Spreadsheets — PC*MILER|Spreadsheets gives you the ability 
to access PC*MILER features and functionality from within your own 
spreadsheet software. Generate point-to-point or street-level mileage and 
drive times within a spreadsheet program, and then use built-in functions to 
summarize and analyze your data. PC*MILER|Spreadsheets provides a 
seamless interface with PC*MILER and Microsoft Excel, allowing you to 
perform customized data analyses. 
 

• PC*MILER|TCP/IP — PC*MILER|TCP/IP is an integration tool that 
provides an interface to PC*MILER|Connect running in a Windows® 
environment to an application residing on another platform. Through a 
TCP/IP network, client applications can access a text-based interface to call 
PC*MILER|Connect's features and functionality. The interface opens cross 
platform communications in a thread-safe manner, giving you the flexibility to 
transmit the output of PC*MILER|Connect to multiple networks within your 
organization. 

• PC*MILER|Rail-Connect – This PC*MILER|Rail connectivity product 
seamlessly interfaces with custom third-party systems such as transportation 
and logistics management, costing and tracking software systems. Custom 
client applications are able to retrieve PC*MILER|Rail routes, maps, 
distances, detailed reports, state-by-state and railroad mileage summaries, and 
much more. Also includes the ability to access the PC*MILER|Rail database 
from within your own spreadsheet software. 

  
• PC*MILER|Rail-BatchPro – PC*MILER|Rail-BatchPro processes large 

volumes of origin-destination pairs formatted as city/state names, SPLC’s, 
FSAC’s, ERPC’s (3-3-3’s) or R260 junction codes.  PC*MILER|Rail users 
can save time using batch processing rather than entering rail routes 
individually. 

• PC*MILER|Rail-TCP/IP – This product is an integration tool that provides 
an interface to PC*MILER|Rail-Connect running in a Windows environment 
to an application residing on another platform.  Through a TCP/IP network, 
client applications can access a text-based interface to call PC*MILER|Rail-
Connect's features and functionality. The interface opens cross-platform 
communications in a thread-safe manner, giving you the flexibility to transmit 
the output of PC*MILER|Rail-Connect to multiple networks within your 
organization. 
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ADDITIONAL DATA MODULES 

• Canadian Postal Codes — Enhance the PC*MILER database with six-digit 
Canadian Postal Codes.  Enables search and display of corresponding 
city/province names to enter them as stops along a route. 
 

• Standard Point Location Codes (SPLC) — Add SPLC to the PC*MILER 
database to generate routes for rating and freight bill auditing.  A SPLC 
provides each point originating freight and each point receiving freight in 
North America with a unique code number that identifies the point by its 
geographic location. 

• PC*MILER|Energy — Provides oil- and gas-specific data and facilities 
including bonded or leased access roads.  Users can now generate precise 
mileage and driving directions that take them directly to facilities in the patch 
including off-road wells, compressor stations, and plants. 

 
 

 
 

1-800-377-MILE 
www.alk.com 

ALK Technologies, Inc. 
457 North Harrison Street 

Princeton, New Jersey 08540 
U.S.A. 
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     Abbreviations for States/Provinces 
in the U.S. and Canada 

 
 

The list below can be used as a reference for route entry.  All states/provinces that 
have at least one active railroad are listed.  For Mexican estados, see Appendix B. 

 
 

State Name – U.S. Abbreviation FIPS 
Alabama AL 01 
Alaska AK 02 
Arizona AZ 04 
Arkansas AR 05 
California CA 06 
Colorado CO 08 
Connecticut CT 09 
Delaware DE 10 
District of Columbia DC 11 
Florida FL 12 
Georgia GA 13 
Idaho ID 16 
Illinois IL 17 
Indiana IN 18 
Iowa IA 19 
Kansas KS 20 
Kentucky KY 21 
Louisiana LA 22 
Maine ME 23 
Maryland MD 24 
Massachusetts MA 25 
Michigan MI 26 
Minnesota MN 27 
Mississippi MS 28 
Missouri MO 29 
Montana MT 30 
Nebraska NE 31 
Nevada NV 32 
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New Hampshire NH 33 
New Jersey NJ 34 
New Mexico NM 35 
New York NY 36 
North Carolina NC 37 
North Dakota ND 38 
Ohio OH 39 
Oklahoma OK 40 
Oregon OR 41 
Pennsylvania PA 42 
Rhode Island RI 44 
South Carolina SC 45 
South Dakota SD 46 
Tennessee TN 47 
Texas TX 48 
Utah UT 49 
Vermont VT 50 
Virginia VA 51 
Washington WA 53 
West Virginia WV 54 
Wisconsin WI 55 
Wyoming WY 56 
   

Canadian Province Abbreviation FIPS 
Alberta AB 84 
British Columbia BC 83 
Manitoba MB 86 
New Brunswick NB 89 
Newfoundland & Labrador NF 92 
Northwest Territory NT 82 
Nova Scotia NS 91 
Ontario ON 87 
Prince Edward Island PE 90 
Quebec PQ 88 
Saskatchewan SK 85 

 

 
 Appendix A:  U.S. & Canadian Abbreviations for States/Provinces 83 



 

 
 

Abbreviations for Mexican Estados 
 
 
PC*MILER|Rail requires Mexican estado abbreviations to be entered when 
entering Mexican locations on a route.  All estados that have at least one active 
railroad are listed.  
 
 

Abbrev. Estado FIPS 
AG Aguascalientes 94 
BJ Baja California 95 
BS Baja California Sur 96 
CP Campeche 97 
CH Chiapas 98 
CI Chihuahua 99 
CU Coahuila 100 
CL Colima 101 
DF Distrito Federal 102 
DG Durango 103 
GJ Guanajuato 104 
HG Hidalgo 106 
JA Jalisco 107 
EM Mexico (Estado) 108 
MH Michoacan 109 
MR Morelos 110 
NA Nayarit 111 
NL Nuevo Leon 112 
OA Oaxaca 113 
PU Puebla 114 
QA Queretaro 115 
SL San Luis Potosi 117 
SI Sinaloa 118 
SO Sonora 119 
TA Tabasco 120 
TM Tamaulipas 121 
TL Tlaxcala 122 
VL Veracruz 123 
YC Yucatan 124 
ZT Zacatecas 125 
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Fuel Surcharge Railroad Reference 
 
 
Fuel surcharge calculations are now required by the Surface Transportation Board 
ruling STB Ex Parte No. 661.  The railroads listed below have chosen 
PC*MILER|Rail Practical miles as their standard for fuel surcharge calculations. 
All other major railroads chose PC*MILER|Rail Shortest miles as the standard.  
 
Therefore, PC*MILER|Rail uses Shortest miles by default when Fuel Surcharge 
routes are generated but uses Practical routing for the railroads listed below. 
 
 

SCAC RRN Routing Option 
CLP 169 Practical 

CN 103 Practical 

GMRC 314 Practical 

KCS 400 Practical 

MPLI 984 Practical 

NYOG 585 Practical 

TCWR 768 Practical 

VTR 817 Practical 

WACR 812 Practical 

WSOR 879 Practical 
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Railroads Sorted by SCAC 
 

 

SCAC Railroad NAME 
AA ANN ARBOR RAILROAD 
AB AKRON BARBERTON CLUSTER RAILWAY COMPANY 
ABL ALAMEDA BELT LINE 
ABR ATHENS LINE LLC, THE 
ABS ALABAMA SOUTHERN RAILROAD 
ABWR ALABAMA WARRIOR RAILWAY, LLC. 
ACJR ASHTABULA CARSON & JEFFERSON RAILROAD 
ACWR ABERDEEN CAROLINA & WESTERN RAILWAY CO 
ADBF ADRIAN & BLISSFIELD RAIL ROAD COMPANY 
AERC ALBANY & EASTERN RAILROAD COMPANY 
AF ALABAMA & FLORIDA RAILWAY CO 
AFR AMADOR FOOTHILLS RAILROAD 
AGCR ALAMO GULF COAST RAILROAD COMPANY 
AGR ALABAMA & GULF COAST RAILWAY LLC 
AIKR AIKEN RAILWAY COMPANY, LLC 
AKDN ACADIANA RAILWAY COMPANY 
AKMD ARKANSAS MIDLAND RAILROAD CO INC 
ALAB ALABAMA RAILROAD CO INC 
ALLN ALLENTOWN AND AUBURN RAILROAD 
ALM ARKANSAS LOUISIANA & MISSISSIPPI RAILROAD COMPANY 
ALS ALTON & SOUTHERN RAILWAY COMPANY 
ALT AIRLAKE TERMINAL RAILWAY COMPANY 
AM ARKANSAS AND MISSOURI RAILROAD CO 
AMTK AMTRAK-NATIONAL RAILROAD PASSENGER CORPORATION 
AN AN RAILWAY LLC 
ANR ANGELINA & NECHES RIVER RAILROAD COMPANY 
ANRG ALTEX ENERGY LTD 
AO APPALACHIAN & OHIO RAILROAD INC 
AOK ARKANSAS-OKLAHOMA RAILROAD INC 
AOR THE ALIQUIPPA & OHIO RIVER RAILROAD COMPANY 
APA APACHE RAILWAY COMPANY 
APD ALBANY PORT DISTRICT 
APNC APPANOOSE COUNTY COMMUNITY RAILROAD INC 
APR ALBERTA PRAIRIE RAILWAY 
AR ABERDEEN AND ROCKFISH RAILROAD COMPANY 

D A
pp

en
di

x 

 
 PC*MILER|Rail User’s Guide 86 



 

ARA ARCADE AND ATTICA RAILROAD CORPORATION 
ARC ALEXANDER RAILROAD COMPANY 
ARE A & R LINE INC 
ARR ALASKA RAILROAD CORPORATION 
ARS ARKANSAS SOUTHERN RAILROAD 
ARZC ARIZONA & CALIFORNIA RAILROAD CO 
ASR ALLEGHENY SOUTHERN RAILROAD INC 
ASRY ASHLAND RAILWAY CO 
AT AFFTON TERMINAL SERVICES RAILROAD, LLC 
ATLT AT & L RAILROAD CO INC 
ATN ALABAMA & TENNESSEE RIVER RAILWAY LLC 
ATW ATLANTIC & WESTERN RAILWAY, L P 
AUT AUTAUGA NORTHERN RAILROAD LLC 
AVR ALLEGHENY VALLEY RAILROAD COMPANY 
AVRR AG VALLEY RAILROAD, LLC 
AWRR AUSTIN WESTERN RAILROAD 
AWRY ADAMS WARNOCK RAILWAY, INC. 
AWW ALGERS WINSLOW AND WESTERN RAILWAY COMPANY 
AZCR ARIZONA CENTRAL RAILROAD INC 
AZER ARIZONA EASTERN RAILWAY COMPANY 
BAYL BAY LINE RAILROAD L L C, THE 
BB BUCKINGHAM BRANCH RAILROAD COMPANY 
BBAY BOGALUSA BAYOU RAILROAD LLC 
BCLR BAY COLONY RAILROAD CORPORATION 
BCR BAY COAST RAILROAD 
BCRY BARRIE-COLLINGWOOD RAILWAY 
BDR MCM RAIL SERVICES, LLC D/B/A BALTIMORE INDUSTRIAL RAILROAD 
BDRV BELVIDERE & DELAWARE RIVER RAILWAY COMPANY INC 
BDTL BALLARD TERMINAL RAILROAD CO LLC 
BDW BIGHORN DIVIDE & WYOMING RAILROAD INC 
BEEM BEECH MOUNTAIN RAILROAD COMPANY 
BFT BIG FOUR TERMINAL RAILROAD, LLC 
BGS BIG SKY RAIL CORP 
BH B&H RAIL CORP 
BHP BHP NEVADA RAILROAD COMPANY 
BHR BROOKHAVEN RAIL, LLC 
BHRR BIRMINGHAM TERMINAL RAILWAY LLC 
BHWY BOOT HILL & WESTERN RAILWAY CO LC 
BJRR BAJA CALIFORNIA RAILROAD INC 
BJRY BURLINGTON JUNCTION RAILWAY 
BKRR BATTEN KILL RAILROAD INC 
BLMR BLUE MOUNTAIN RAILROAD INC 
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BLOL BLOOMER LINE, THE 
BLR BLACKLANDS RAILROAD THE 
BLU BLUE RIDGE SOUTHERN RAILROAD LLC 
BML BELFAST AND MOOSEHEAD LAKE RAILROAD COMPANY 
BNG BLACKWELL NORTHERN GATEWAY RAILROAD COMPANY 
BNML BURLINGTON NORTHERN (MANITOBA) LTD 
BNSF BNSF RAILWAY COMPANY 
BOCT BALTIMORE AND OHIO CHICAGO TERMINAL RAILROAD CO 
BOP BORDER PACIFIC RAILROAD CO 
BPRR BUFFALO & PITTSBURGH RAILROAD INC 
BRAN BRANDON RAILROAD LLC 
BRC BELT RAILWAY COMPANY OF CHICAGO 
BRG BROWNSVILLE & RIO GRANDE INTERNATIONAL RAILWAY, LLC 
BRR BATTLE RIVER RAILWAY NGC INC 
BRW BLACK RIVER & WESTERN CORPORATION 
BS BIRMINGHAM SOUTHERN RR CO 
BSDA BI-STATE DEVELOPMENT AGENCY 
BSOR BUFFALO SOUTHERN RAILROAD INC 
BSR BIG SPRING RAIL SYSTEM, INC. 
BSVY BOONE & SCENIC VALLEY RAILROAD 
BTR BOUNDARY TRAIL RAILWAY COMPANY INC. 
BVRR BOISE VALLEY RAILROAD, INC. 
BVRY BRANDYWINE VALLEY RAILROAD COMPANY 
BXN BAUXITE & NORTHERN RAILWAY COMPANY 
CA CHESAPEAKE & ALBEMARLE 
CAGY COLUMBUS AND GREENVILLE RAILWAY 
CALA CAROLINA SOUTHERN RAILROAD COMPANY, THE 
CAMY CAMP CHASE RAILWAY COMPANY, LLC 
CBNS CAPE BRETON & CENTRAL NOVA SCOTIA RAILWAY 
CBR COOS BAY RAILROAD OPERATING CO., LLC 
CBRW COLUMBIA BASIN RAILROAD COMPANY INC 
CBRY COPPER BASIN RAILWAY INC 
CCET CCET, LLC 
CCH COLUMBUS & CHATTAHOOCHEE RAILROAD, INC 
CCKY CHATTOOGA & CHICKAMAUGA RAILWAY CO 
CCPN CORPUS CHRISTI TERMINAL RAILROAD INC 
CCRA CAMP CHASE INDUSTRIAL RAILROAD CORPORATION 
CCRL CLEVELAND COMMERCIAL RAILROAD COMPANY LLC 
CCRR CLAREMONT CONCORD RAILROAD CORPORATION 
CCT CENTRAL CALIFORNIA TRACTION COMPANY 
CCUO CHICAGO-CHEMUNG RAILROAD CORP 
CEIW CENTRAL INDIANA & WESTERN RAILROAD CO INC 
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CEMR CENTRAL MANITOBA RAILWAY INC 
CERA CENTRAL RAILROAD COMPANY OF INDIANAPOLIS 
CF CAPE FEAR RAILWAYS INC 
CFE CHICAGO FT WAYNE & EASTERN A DIVISION OF CENTRAL RAILROAD OF INDIANAPOLIS INC 
CFL C F LANAUDIERE INC 
CFNR CALIFORNIA NORTHERN RAILROAD COMPANY LP 
CFWR CANEY FORK AND WESTERN RR 
CGR CG RAILWAY INC 
CHAT CHATTAHOOCHEE BAY RAILROAD INC 
CHB CLEVELAND HARBOR BELT RAILROAD, LLC 
CHR CHESTNUT RIDGE RAILWAY COMPANY 
CHRC CHAPARRAL RAILROAD COMPANY INC 
CHRR CHESAPEAKE RAILROAD COMPANY 
CHS CHARLOTTE SOUTHERN RAILROAD COMPANY 
CI CAMBRIA AND INDIANA RAILROAD COMPANY 
CIC CEDAR RAPIDS & IOWA CITY RAILWAY COMPANY 
CIND CENTRAL RAILROAD OF INDIANA 
CIR CITY OF ROCHELLE ILLINOIS 
CIRR CHATTAHOOCHEE INDUSTRIAL RAILROAD 
CIRY CENTRAL ILLINOIS RAILROAD COMPANY 
CKIN CHESAPEAKE AND INDIANA RAILROAD COMPANY INC 
CLC COLUMBIA & COWLITZ RAILWAY LLC 
CLCY CHESSIE LOGISTICS CO., LLC 
CLNA CAROLINA COASTAL RAILWAY INC 
CLP CLARENDON AND PITTSFORD RAILROAD COMPANY, THE 
CM CENTRAL MONTANA RAIL INC 
CMPA MADISON RAILROAD (A DIV OF CITY OF MADISON PORT AUTHORITY) 
CMQ CENTRAL MAINE & QUEBEC RAILWAY 
CMR CENTRAL MIDLAND RAILWAY COMPANY 
CMRR COMSTOCK MOUNTAIN LION RAILROAD, INC. 
CMSL CAPE MAY SEASHORE LINES 
CN CANADIAN NATIONAL RAILWAYS 
CNAT CN AQUATRAIN 
CNOW COLUMBIA & NORTHERN RAILWAY CO 
CNUR C & NC RAILROAD CORPORATION 
CNYK CENTRAL NEW YORK RAILROAD CORPORATION 
CNZR CENTRAL NEW ENGLAND RAILROAD CO INC 
COEH CONECUH VALLEY RAILWAY LLC 
COER CRAB ORCHARD & EGYPTIAN RAILWAY A DIVISION OF PROGRESSIVE RAIL IN 
COP CITY OF PRINEVILLE RAILWAY 
CORP CENTRAL OREGON & PACIFIC RAILROAD INC 
CORY COLUMBIA & READING RAILWAY CO 
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CPDR CAROLINA PIEDMONT DIVISION SOUTH CAROLINA CENTRAL RAILROAD COMPANY INC 
CPMY COOPERSVILLE AND MARNE RAILWAY COMPANY 
CPR CATERPARROTT RAILNET, LLC 
CPRS CANADIAN PACIFIC RAILWAY 
CRL CHICAGO RAIL LINK 
CSCD CASCADE AND COLUMBIA RIVER RAILROAD COMPANY 
CSKR C & S RAILROAD CORPORATION 
CSO CONNECTICUT SOUTHERN RAILROAD INC 
CSR CAMDEN & SOUTHERN RAILROAD INC 
CSS CHICAGO SOUTHSHORE & SOUTH BEND RAILROAD 
CSXT CSX TRANSPORTATION 
CT COLUMBIA TERMINAL 
CTM CHICAGO TERMINAL RAILROAD 
CTN CANTON RAILROAD COMPANY 
CTR CLINTON TERMINAL RAILROAD COMPANY 
CTRR CLOQUET TERMINAL RAILROAD COMPANY INC 
CTRW CARLTON TRAIL RAILWAY COMPANY 
CUOH COLUMBUS & OHIO RAILROAD COMPANY 
CVR CIMARRON VALLEY RAILROAD L C 
CVRC PROGRESSIVE RAIL INC D/B/A CANNON VALLEY RAILROAD COMPANY 
CVYR CADDO VALLEY RAILROAD COMPANY 
CW COLORADO & WYOMING RWY CO 
CWA CENTRAL WASHINGTON RAILROAD COMPANY 
CWCY CALDWELL COUNTY RAILROAD COMPANY 
CWR CWRR INC 
CWRO CLEVELAND WORKS RAILWAY COMPANY 
CWRY COMMONWEALTH RAILWAY INC 
CZRY CARRIZO GORGE RAILWAY INC 
DAIR D & I RAILROAD COMPANY 
DAKS DAKOTA SHORT LINE 
DALT DALLAS TERMINAL RAILWAY 
DC DELRAY CONNECTING RAILROAD COMPANY 
DCLR DELAWARE COAST LINE RR CO 
DCON DETROIT CONNECTING RAILROAD COMPANY 
DCRR DUBOIS COUNTY RAILROAD 
DGNO DALLAS GARLAND & NORTHEASTERN RAILROAD INC 
DGVR DURBIN & GREENBRIER VALLEY RAILROAD INC 
DL DELAWARE-LACKAWANNA RAILROAD CO INC 
DLWR DEPEW LANCASTER & WESTERN RAILROAD CO INC 
DMM DANSVILLE AND MOUNT MORRIS RAILROAD COMPANY, THE 
DMVW DAKOTA MISSOURI VALLEY & WESTERN RAILROAD INC 
DN DAKOTA NORTHERN RAILROAD INC 
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DQE DEQUEEN & EASTERN RAILROAD LLC 
DR DARDANELLE & RUSSELLVILLE RAILROAD COMPANY 
DRIR DENVER ROCK ISLAND RAILROAD 
DSC DRAKE SWITCHING COMPANY, LLC 
DSRC DAKOTA SOUTHERN RAILWAY COMPANY 
DSRR DELTA SOUTHERN RAILROAD COMPANY 
DT DECATUR JUNCTION RAILWAY COMPANY 
DV DELAWARE VALLEY RAILWAY COMPANY INC 
DVR DEVCO RY (CAPE BRETON DEVELOPMENT CORP) 
DVS DELTA VALLEY & SOUTHERN RAILWAY COMPANY 
EACH EAST CAMDEN & HIGHLAND RR CO 
EARY EASTERN ALABAMA RAILWAY 
EBG EASTERN BERKS GATEWAY RAILROAD COMPANY 
EBSR EAST BROOKFIELD & SPENCER RAILROAD LLC 
EBTC EAST BROAD TOP CONNECTING RAILROAD 
ECBR EAST COOPER AND BERKELEY RAILROAD COMPANY 
ECO ECORAIL INC 
ECTB EAST CHATTANOOGA BELT RAILWAY COMPANY 
ECYR EASTSIDE COMMUNITY RAIL, LLC 
EDW EL DORADO AND WESSON RAILWAY COMPANY 
EE ELLIS & EASTERN COMPANY 
EEC EAST ERIE COMMERCIAL RAILROAD 
EFRR EFFINGHAM RAILROAD COMPANY 
EIRC EASTERN ILLINOIS RAILROAD COMPANY 
EIRR EASTERN IDAHO RAILROAD INC 
EJR EAST JERSEY RAILROAD AND TERMINAL COMPANY 
ELKR ELK RIVER RAILROAD INC 
ELS ESCANABA AND LAKE SUPERIOR RAILROAD COMPANY 
EMHR EAST MAHANOY & HAZELTON RAILROAD COMPANY 
EMRY EASTERN MAINE RAILWAY COMPANY 
ENR E & N RAILWAY COMPANY (1998) LTD 
ESPN EAST PENN RAILROAD LLC 
ETL ESSEX TERMINAL RAILWAY COMPANY THE 
ETRY EAST TENNESSEE RAILWAY, L P 
EV EVERETT RAILROAD 
EVWR EVANSVILLE WESTERN RAILWAY INC 
EWG EASTERN WASHINGTON GATEWAY RAILROAD COMPANY 
EWR ELKHART & WESTERN RAILROAD CO 
EZR ELIZABETHTOWN INDUSTRIAL RAILROAD, LLC 
FC FULTON COUNTY RAILROAD INC 
FCCM COMPANIA DE FERROCARRILES CHIAPAS MAYAB SA DE CV 
FCEN FLORIDA CENTRAL RAILROAD CO 
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FCR FULTON COUNTY RAILWAY LLC 
FCRD FIRST COAST RAILROAD INC 
FEC FLORIDA EAST COAST RAILWAY, LLC 
FGLK FINGER LAKES RAILWAY CORP 
FIR FLATS INDUSTRIAL RAILROAD COMPANY 
FMID FLORIDA MIDLAND RAILROAD CO INC 
FMRC FARMRAIL CORPORATION 
FNOR FLORIDA NORTHERN RAILROAD COMPANY INC 
FP FORDYCE AND PRINCETON RAILROAD CO 
FRR FALLS ROAD RAILROAD CO INC 
FRVT FORE RIVER TRANSPORTATION CORPORATION 
FSR FORT SMITH RAILROAD CO 
FSRR FERROSUR S A DE C V 
FWCR FLORIDA WEST COAST RAILROAD INC 
FWDB FORT WORTH & DALLAS BELT RAILROAD 
FWRY FILLMORE WESTERN RAILWAY COMPANY 
FWWR FORT WORTH & WESTERN RAILROAD 
FXE FERROCARRIL MEXICANO S A DE C V 
GC GEORGIA CENTRAL RAILWAY L P 
GCK GEORGES CREEK RAILWAY 
GCSR GULF COLORADO & SAN SABA RAILWAY 
GCW GARDEN CITY WESTERN RAILWAY COMPANY, THE 
GDLK GRAND ELK RAILROAD, LLC. 
GET GETTYSBURG & NORTHERN RAILROAD CO 
GEXR GODERICH-EXETER RAILWAY COMPANY LTD 
GFR GRAND FORKS RAILWAY COMPANY 
GFRR GEORGIA & FLORIDA RAILWAY, LLC 
GITM GOLDEN ISLES TERMINAL RAILROAD INC 
GLC GREAT LAKES CENTRAL RAILROAD 
GLSR GLOSTER SOUTHERN RAILROAD COMPANY 
GMR GEORGIA MIDLAND RAILROAD INC 
GMRC GREEN MOUNTAIN RAILROAD CORPORATION 
GNBC GRAINBELT CORPORATION 
GNPR GNP RLY INC. 
GNRR GEORGIA NORTHEASTERN RAILROAD CO 
GOGR GEAUX GEAUX RAILROAD LLC 
GR GRAND RAPIDS EASTERN RAILROAD INC 
GRD GARDENDALE RAILROAD, INC 
GRLW GREENVILLE & WESTERN RAILWAY COMPANY LLC 
GRNW GREAT NORTHWEST RAILROAD INC 
GRR GEORGETOWN RAILROAD COMPANY 
GRRY THE GREAT LAKE PORT CORPORATION D/B/A THE GRAND RIVER RAILWAY 
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GRW GARY RAILWAY COMPANY 
GRWR GREAT WALTON RAILROAD CO, THE 
GRYR GRENADA RAILROAD LLC D/B/A GRENADA RAILWAY 
GS GEORGIA SOUTHERN RAILWAY CO. 
GSM GREAT SMOKEY MOUNTAINS RAILWAY INC 
GSWR GEORGIA SOUTHWESTERN RAILROAD INC 
GTR GREAT RIVER RAILROAD 
GTRA GOLDEN TRIANGLE RAILROAD LLC 
GU GRAFTON AND UPTON RAILROAD COMPANY 
GVSR GALVESTON RAILROAD LP 
GWR GREAT WESTERN RAILWAY OF COLORADO LLC 
GWRC GEORGIA WOODLANDS RAILROAD CO 
GWRS GREAT WESTERN RAILWAY LTD 
GWWE GATEWAY EASTERN RAILWAY COMPANY 
HAL HILTON & ALBANY RAILOAD, INC. 
HB HAMPTON & BRANCHVILLE RAILROAD COMPANY 
HBRY HUDSON BAY RAILWAY COMPANY 
HCRR HONEY CREEK RAILROAD INC 
HCRY HURON CENTRAL RAILWAY INC 
HE HOLLIS & EASTERN R R CO 
HESR HURON AND EASTERN RAILWAY COMPANY INC 
HIRR HAINESPORT INDUSTRIAL RAILROAD LLC 
HLSC HAMPTON RAILWAY INC 
HMCR HUNTSVILLE & MADISON COUNTY RAILROAD AUTHORITY 
HN HUTCHINSON AND NORTHERN RAILWAY COMPANY, THE 
HOB HENDERSON OVERTON BRANCH 
HOG HEART OF GEORGIA RAILROAD INC 
HOS HOOSIER SOUTHERN RAILROAD 
HPTD HIGH POINT THOMASVILLE & DENTON RAILROAD COMPANY 
HR HERITAGE RAILROAD CORP 
HRR HONDO RAILWAY LLC 
HRRC HOUSATONIC RAILROAD COMPANY INC 
HRS HOLLIDAYSBURG AND ROARING SPRING RAILROAD COMPANY 
HRT HARTWELL RAILROAD COMPANY 
HSR HAINESPORT SECONDARY, LLC 
HSRR HARDIN SOUTHERN RAILROAD INC 
HTR HEART OF TEXAS RAILROAD, LP 
IAIS IOWA INTERSTATE RAILROAD LTD 
IANR IOWA NORTHERN RAILROAD 
IANW IOWA NORTHWESTERN RAILROAD 
IARR IOWA RIVER RAILROAD INC 
IATR IOWA TRACTION RAILWAY COMPANY 
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IBT INTERNATIONAL BRIDGE AND TERMINAL COMPANY, THE 
ICRK INDIAN CREEK RAILROAD COMPANY 
IERR INDIANA EASTERN RAILROAD LLC 
IHB INDIANA HARBOR BELT RAILROAD COMPANY 
ILW ILLINOIS WESTERN RAILROAD COMPANY 
IMRR ILLINOIS & MIDLAND RAILROAD INC 
IN INDIANA NORTHEASTERN RAILROAD COMPANY INC 
INPR IDAHO NORTHERN & PACIFIC RAILROAD COMPANY 
INRD INDIANA RAIL ROAD CORPORATION 
IORY INDIANA & OHIO RAILWAY COMPANY 
IR ILLINOIS RAILWAY, LLC 
IRRS INTERNATIONAL RAIL ROAD SYSTEMS INC 
ISR IOWA SOUTHERN RAILROAD COMPANY 
ISRR INDIANA SOUTHERN RAILROAD COMPANY INC 
ISW INDIANA SOUTHWESTERN RAILWAY CO 
JAIL JACKSON & LANSING RAILROAD COMPANY 
JKL J K LINE INC 
JVRR JUNIATA VALLEY RAILROAD COMPANY 
KAW KAW RIVER RAILROAD 
KBSR KANKAKEE BEAVERVILLE AND SOUTHERN RAILROAD COMPANY 
KCS KANSAS CITY SOUTHERN RAILWAY COMPANY 
KCSM KANSAS CITY SOUTHERN DE MEXICO S DE R L DE C V 
KCTL KANSAS CITY TRANSPORTATION CO LLC 
KE KANSAS EASTERN RAILROAD INC 
KFR KETTLE FALLS INTERNATIONAL RAILWAY LLC 
KGTR KINGMAN TERMINAL RAILROAD, LLC 
KJR KISKI JUNCTION RAILROAD 
KJRY KEOKUK JUNCTION RAILWAY 
KKRR KNOX & KANE RAILROAD COMPANY 
KNOR KLAMATH NORTHERN RAILWAY COMPANY 
KO KANSAS & OKLAHOMA RAILROAD INC 
KPR KELOWNA PACIFIC RAILWAY LTD 
KRL KASGRO RAIL LINES 
KRR KIAMICHI RAILROAD COMPANY LLC 
KSRY KOSCIUSKO SOUTHWESTERN RAILWAY 
KT KENTUCKY AND TENNESSEE RAILWAY 
KTR KENDALLVILLE TERMINAL RAILWAY CO 
KWT KWT RAILWAY INC 
KXHR KNOXVILLE & HOLSTON RIVER RAILROAD CO INC 
KYLE KYLE RAILROAD COMPANY 
LAJ LOS ANGELES JUNCTION RAILWAY COMPANY 
LAL LIVONIA, AVON & LAKEVILLE RAILROAD CORPORATION 
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LAS LOUISIANA SOUTHERN RAILROAD 
LBR LOWVILLE AND BEAVER RIVER RAILROAD COMPANY THE 
LBWR LUBBOCK & WESTERN RAILWAY, L.L.C. 
LC LANCASTER & CHESTER RAILROAD, LLC. 
LCR LAKE COUNTY RAILROAD 
LCRI LONG CREEK RAILROAD COMPANY INC 
LDRR LOUISIANA & DELTA RAILROAD INC 
LER LOGANSPORT & EEL RIVER SHORT-LINE CO INC 
LFCD LINEA COAHUILA DURANGO SA DE CV 
LI LONG ISLAND RAILROAD COMPANY 
LINC LEWIS & CLARK RAILWAY CO 
LIRC LOUISVILLE & INDIANA RAILROAD COMPANY 
LIRR LAPEER INDUSTRIAL RAILROAD COMPANY 
LKRR LITTLE KANAWHA RIVER RAIL INC 
LLR LAKE LINE RAILROAD INC. 
LMIC LAKE MICHIGAN AND INDIANA RAILROAD COMPANY 
LMR LAST MOUNTAIN RAILWAY 
LNAL LOUISVILLE NEW ALBANY & CORYDON RAILROAD 
LNVT LANDISVILLE TERMINAL & TRANSFER COMPANY 
LNW LOUISIANA AND NORTH WEST RAILROAD COMPANY, THE 
LRPA LITTLE ROCK PORT RAILROAD 
LRS LAURINBURG AND SOUTHERN RAILROAD COMPANY 
LRWN LITTLE ROCK & WESTERN RAILWAY, L P 
LRWY LEHIGH RAILWAY, LLC. 
LRY LRY LLC. 
LS LUZERNE AND SUSQUEHANNA RAILWAY COMPANY 
LSI LAKE SUPERIOR & ISHPEMING RAILROAD COMPANY 
LSRC LAKE STATE RAILWAY COMPANY 
LT LAKE TERMINAL RAILROAD COMPANY, THE 
LVR LANDISVILLE RAILROAD, LLC 
LVRB LEHIGH VALLEY RAIL MANAGEMENT LLC - BETHLEHEM DIVISION 
LVRC LAMOILLE VALLEY RAILROAD COMPANY 
LVRJ LEHIGH VALLEY RAIL MANAGEMENT LLC - JOHNSTOWN DIVISION 
LVRR LYCOMING VALLEY RAILROAD COMPANY 
LVSW LONGVIEW SWITCHING COMPANY 
LW LOUISVILLE AND WADLEY RAILWAY COMPANY 
LXVR LUXAPALILA VALLEY RAILROAD INC 
MAA MAGMA ARIZONA RAILROAD COMPANY 
MAL MICHIGAN AIR-LINE RAILWAY CO 
MAN MANNING RAIL, INC 
MAUP MANATEE COUNTY PORT AUTHORITY 
MAW MAUMEE & WESTERN RAILROAD CORPORATION 
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MC MASSACHUSETTS COASTAL RAILROAD LLC 
MCER MASSACHUSETTS CENTRAL RAILROAD CORPORATION 
MCLR MCLAUGHLIN LINE RAILROAD 
MCR MCCLOUD RAILWAY COMPANY 
MCSA MOSCOW, CAMDEN & SAN AUGUSTINE RAILROAD 
MD C&J RAILROAD COMPANY D/B/A MISSISSIPPI DELTA RAILROAD 
MDDE MARYLAND AND DELAWARE RAILROAD COMPANY 
MDS MERIDIAN SOUTHERN RAILWAY LLC 
MDW MINNESOTA DAKOTA & WESTERN RAILWAY COMPANY 
ME MORRISTOWN & ERIE RAILWAY INC 
MERR MORRISTOWN & ERIE RAILWAY INC D/B/A MAINE EASTERN RAILROAD 
MET MODESTO AND EMPIRE TRACTION COMPANY 
METW MUNICIPALITY OF EAST TROY WISCONSIN 
MGRI MG RAIL INC 
MH MT HOOD RAILROAD CO 
MHC MOHALL CENTRAL RAILROAD INC 
MHWA MOHAWK ADIRONDACK & NORTHERN RAILROAD CORP 
MIDH MIDDLETOWN & HUMMELSTOWN RAILROAD COMPANY 
MJ MANUFACTURERS JUNCTION RAILWAY COMPANY 
MKC MCKEESPORT CONNECTING RAILROAD COMPANY 
MMA MONTREAL MAINE AND ATLANTIC RAILWAY LTD 
MMID MARYLAND MIDLAND RAILWAY INC 
MMRR MID-MICHIGAN RAILROAD INC 
MMT MISSION MOUNTAIN RAILROAD 
MNA MISSOURI & NORTHERN ARKANSAS RAILROAD COMPANY INC 
MNBR M&B RAILROAD LLC 
MNC MOTIVE RAIL INC D/B/A MISSOURI NORTH CENTRAL RAILROAD 
MNJ MIDDLETOWN & NEW JERSEY RAILWAY LLC 
MNN MINNESOTA NORTHERN RAILROAD INC 
MNNR MINNESOTA COMMERCIAL RAILWAY CO 
MNR MAINE NORTHERN RAILWAY COMPANY 
MPLI MINNESOTA PRAIRIE LINE INC 
MQT MARQUETTE RAIL LLC 
MRA MINERAL RANGE, INC. 
MRI MOHALL RAILROAD INC 
MRL MONTANA RAIL LINK INC 
MS MICHIGAN SHORE RAILROAD INC 
MSCI MISSISSIPPI CENTRAL RAILROAD COMPANY 
MSE MISSISSIPPI EXPORT RAILROAD COMPANY 
MSN BALLARD TERMINAL RAILROAD COMPANY LLC D/B/A MEEKER SOUTHERN RAILROAD 
MSO MICHIGAN SOUTHERN RAILROAD CO INC 
MSR MISSISSIPPI SOUTHERN RAILROAD 
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MSRW MISSISSIPPIAN RAILWAY COOPERATIVE INC 
MSTR MASSENA TERMINAL RAILROAD COMPANY, THE 
MSV MISSISSIPPI & SKUNA VALLEY RAILROAD LLC 
MSWY MINNESOTA SOUTHERN RAILWAY INC 
MTNR MISSISSIPPI TENNESSEE RAILROAD LLC 
MVP MISSOURI & VALLEY PARK RAILROAD CORP 
MVRY MAHONING VALLEY RAILWAY COMPANY, THE 
MVT MT VERNON TERMINAL RAILWAY INC 
NAUG NAUGATUCK RAILROAD COMPANY INC 
NBER NITTANY & BALD EAGLE RAILROAD CO 
NBSR NEW BRUNSWICK SOUTHERN RAILWAY COMPANY LIMITED 
NCIR NEW CASTLE INDUSTRIAL RAILROAD 
NCPR NORTH CAROLINA PORTS RAILWAY COMMISSION 
NCRC NEBRASKA CENTRAL RAILROAD COMPANY 
NCRL NC RAILROAD INC 
NCVA NORTH CAROLINA & VIRGINIA RAILROAD CO INC 
NCYR NASH COUNTY RAILROAD CORP 
NDCR N D C RAILROAD COMPANY 
NECR NEW ENGLAND CENTRAL RAILROAD INC 
NEGS NEW ENGLAND SOUTHERN RAILROAD CO INC 
NENE NEBRASKA NORTHEASTERN RAILWAY COMPANY 
NERR NASHVILLE AND EASTERN RAILROAD CORP 
NFTS THE NELSON AND FT. SHEPPARD RAILWAY CORPORATION 
NHCR NEW HAMPSHIRE CENTRAL RAILROAD INC 
NHN NEW HAMPSHIRE NORTHCOAST CORP 
NHRR NEW HOPE & IVYLAND RAILROAD 
NHVT NEW HAMPSHIRE AND VERMONT RAILROAD COMPANY 
NJRC NEW JERSEY RAIL CARRIER LLC 
NJSL NEW JERSEY SEASHORE LINES, INC. 
NKCR NEBRASKA KANSAS & COLORADO RAILNET INC 
NLA NORTH LOUISIANA & ARKANSAS RAILROAD 
NLR NORTHERN LINES RAILWAY LLC 
NMGR NEW MEXICO GATEWAY RAILROAD LLC 
NNW NEBRASKA NORTHWESTERN RAILROAD INC. 
NOGC NEW ORLEANS & GULF COAST RAILWAY COMPANY INC 
NOKL NORTHWESTERN OKLAHOMA RAILROAD COMPANY 
NOPB NEW ORLEANS PUBLIC BELT RAILROAD 
NOW NORTHERN OHIO & WESTERN RAILWAY LTD 
NPB NORFOLK & PORTSMOUTH BELT LINE RAILROAD COMPANY 
NPR NORTHERN PLAINS RAILROAD INC 
NRI NEBKOTA RAILWAY INC 
NS NORFOLK SOUTHERN RAILWAY COMPANY (NORFOLK SOUTHERN) 
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NSHR NORTH SHORE RAILROAD CO 
NSR NEWBURGH & SOUTH SHORE RAILROAD COMPANY 
NTRY NIMISHILLEN & TUSCARAWAS LLC 
NTZR NATCHEZ RAILWAY LLC. 
NVRR NAPA VALLEY RAILROAD CO 
NWP NORTHWESTERN PACIFIC RAILROAD COMPANY 
NWR NASHVILLE & WESTERN RAILROAD CORP 
NYA NEW YORK & ATLANTIC RAILWAY COMPANY 
NYGL NEW YORK & GREENWOOD LAKE RAILWAY 
NYLE NEW YORK & LAKE ERIE RAILROAD 
NYNJ NEW YORK NEW JERSEY RAIL LLC 
NYOG NEW YORK & OGDENSBURG RAILWAY COMPANY INC 
NYSW NEW YORK SUSQUEHANNA AND WESTERN RAILWAY CORP 
OAR OLD AUGUSTA RAILROAD LLC 
OCTL OIL CREEK & TITUSVILLE LINES 
OERR OREGON EASTERN RAILROAD 
OHCR OHIO CENTRAL RAILROAD CO 
OHIC OHI-RAIL CORPORATION 
OHIO OHIO TERMINAL RAILWAY COMPANY 
OHPA OHIO & PENNSYLVANIA RAILROAD COMPANY 
OHRY OWEGO & HARFORD RAILWAY INC 
OKAN OKANAGAN VALLEY RAILWAY COMPANY 
OLB OMAHA LINCOLN AND BEATRICE RAILWAY COMPANY 
OLO ONTARIO L'ORIGNAL RAILWAY INC 
OLYR OLYMPIC RAILROAD CO, THE 
OMID ONTARIO MIDLAND RAILROAD CORPORATION 
ONCT ONTARIO CENTRAL RAILROAD CORPORATION 
ONT ONTARIO NORTHLAND RAILWAY (ONTARIO NORTHLAND TRANS COMMISSION) 
OPE OREGON PACIFIC & EASTERN RAILWAY COMPANY 
OPR OREGON PACIFIC RAILROAD CO 
OPT ORANGE PORT TERMINAL RAILWAY 
ORC OGEECHEE RAILROAD COMPANY 
OSCR INDIANA EASTERN RAILROAD, LLC D/B/A OHIO SOUTH CENTRAL RAILROAD 
OSRR OHIO SOUTHERN RAILROAD CO 
OTCO OWENSVILLE TERMINAL CO INC 
OTR OAKLAND TERMINAL RAILROAD COMPANY 
OTT OTTUMWA TERMINAL RAILROAD CO 
OTVR OTTERTAIL VALLEY RAILROAD CO INC 
OUCH OUACHITA RAILROAD 
OVR OHIO VALLEY RAILROAD COMPANY 
OVRR OZARK VALLEY RAILROAD INC 
PAL PADUCAH & LOUISVILLE RAILWAY 
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PAM PITTSBURGH ALLEGHENY & MCKEES ROCKS RR CO 
PAS PAN AM SOUTHERN, LLC. 
PBR PATAPSCO & BACK RIVERS RAILROAD COMPANY 
PBVR PORT BIENVILLE RAILROAD 
PCC PALOUSE RIVER & COULEE CITY RAILROAD INC 
PCN POINT COMFORT & NORTHERN RAILWAY COMPANY 
PDRR PEE DEE RIVER RAILROAD CORP 
PGR PROGRESSIVE RAIL INC 
PHL PACIFIC HARBOR LINE INC 
PHRR PORT HARBOR RAILROAD INC 
PI PADUCAH & ILLINOIS RAILROAD COMPANY 
PICK PICKENS RAILWAY COMPANY 
PIR PERU INDUSTRIAL RAILROAD, LLC 
PJR PORT JERSEY RAILROAD CO 
PKHP PICKENS RAILWAY COMPANY 
PN PENNSYLVANIA NORTHEASTERN RAILROAD, LLC 
PNR PANHANDLE NORTHERN RAILROAD COMPANY 
PNRW PIEDMONT RAILWAY LLC D/B/A PIEDMONT & NORTHERN RAILROAD 
PNW PRESCOTT AND NORTHWESTERN RAILROAD COMPANY 
PNWR PORTLAND & WESTERN RAILROAD INC 
POHC THE PITTSBURGH & OHIO CENTRAL RAILROAD COMPANY 
POTB PORT OF TILLAMOOK BAY RAILROAD 
POVA PEND OREILLE VALLEY RAILROAD (PORT OF PEND OREILLE) 
PR SOUTH CAROLINA DIVISION OF PUBLIC RAILWAYS D/B/A PALMETTO RAILWAY 
PRI PORT RAIL, INC. 
PRV PEARL RIVER VALLEY RAILROAD COMPANY 
PRY PIONEER INDUSTRIAL RAILWAY CO 

PSAP THE PUGET SOUND & PACIFIC RAILROAD COMPANY A DIVISION OF THE ARIZONA & 
CALIFORNIA RAILROAD CO LP 

PSC PYCO INDUSTRIES INC 
PSCC PENNSYLVANIA & SOUTHERN RAILWAY LLC 
PSWR PENNSYLVANIA SOUTHWESTERN RAILROAD INC 
PT PENINSULA TERMINAL COMPANY 
PTC PLAINVIEW TERMINAL COMPANY 
PTR PORT TERMINAL RAILROAD OF SOUTH CAROLINA 
PTRA PORT TERMINAL RAILROAD ASSOCIATION 
PTRC PORTLAND TERMINAL RAILROAD COMPANY 
PUCC PORT UTILITIES COMMISSION OF CHARLESTON SC 
PVJR PORTLAND VANCOUVER JUNCTION RAILROAD LLC 
PVRR PIONEER VALLEY RAILROAD COMPANY 
PVS PECOS VALLEY PERMIAN RAILROAD LLC DBA PECOS VALLEY SOUTHERN RAILW 
PW PROVIDENCE AND WORCESTER RAILROAD COMPANY 
QCR QUEBEC CENTRAL RAILWAY COMPANY 
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QGRY QUEBEC GATINEAU RAILWAY INC 
QNSL QUEBEC NORTH SHORE AND LABRADOR RAILWAY COMPANY 
QRR QUINCY RAILROAD COMPANY 
RARW RARUS RAILWAY COMPANY 
RBMN READING BLUE MOUNTAIN & NORTHERN RAILROAD COMPANY 
RCPE RAPID CITY, PIERRE & EASTERN RAILROAD, INC. 
RCRR RED COAT ROAD & RAIL LTD 
RCRY RARITAN CENTRAL RAILWAY LLC 
RJCC R J CORMAN RAILROAD COMPANY/CENTRAL KENTUCKY LINES 
RJCD RJ CORMAN RAILROAD COMPANY/TEXAS LINES, LLC 
RJCK R J CORMAN RAILROAD COMPANY/TENNESSEE TERMINAL LLC 
RJCL R J CORMAN RAILROAD COMPANY/CLEVELAND LINE 
RJCM R J CORMAN RAILROAD COMPANY/MEMPHIS LINE 
RJCN R J CORMAN RAILROAD COMPANY/ALLENTOWN LINES INC 
RJCP R J CORMAN RAILROAD COMPANY/PENNSYLVANIA LINES INC 
RJCR R J CORMAN RAILROAD CORPORATION/BARDSTOWN LINE 
RJCS RJ CORMAN RAILROAD CO/CAROLINA LINES, LLC 
RJCV R J CORMAN RAILROAD COMPANY/WV LINE 
RJCW R J CORMAN RAILROAD COMPANY/WESTERN OHIO LINE 
RL RUTLAND LINE INC 
RLHH RAILINK SOUTHERN ONTARIO 
RLK RAILINK OTTAWA VALLEY 
RMRR ROCKY MOUNTAIN RAILCAR AND RAILROAD INC 
RNA RIPLEY & NEW ALBANY RAILROAD COMPANY 
RPP RUSK, PALESTINE, & PACIFIC RAILROAD, LLC 
RPRC RICHMOND PACIFIC RAILROAD CORPORATION 
RRC REDMONT RAILWAY COMPANY INC 
RRRR ROCK & RAIL INC 
RRVW RED RIVER VALLEY & WESTERN RAILROAD CO 
RS ROBERVAL AND SAGUENAY RAILWAY COMPANY, THE 
RSL RSL RAILROAD LLC 
RSM RAILROAD SWITCHING SERVICE OF MISSOURI INC 
RSNR RED SPRINGS & NORTHERN RAILROAD CO 
RSOR RICEBORO SOUTHERN RAILWAY LLC 
RSP ROSCOE SNYDER & PACIFIC RAILWAY COMPANY 
RSR ROCHESTER & SOUTHERN RAILROAD INC 
RSS ROCKDALE SANDOW & SOUTHERN RAILROAD COMPANY 
RVPR RIVERPORT RAILROAD LLC 
RVSC RIO VALLEY SWITCHING COMPANY 
RVT ROGUE VALLEY TERMINAL RAILROAD CORPORATION 
SAC SAN ANTONIO CENTRAL RAILROAD, LLC 
SAN SANDERSVILLE RAILROAD COMPANY 
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SAPT SAVANNAH PORT TERMINAL RAILROAD INC 
SAV SACRAMENTO VALLEY RAILROAD 
SAW SOUTH PLAINS SWITCHING LTD CO 
SBG SAVAGE BINGHAM & GARFIELD RAILROAD COMPANY 
SBLN STERLING BELT LINE RAILWAY 
SBRR STOURBRIDGE RAILROAD COMPANY 
SBVR SOUTH BRANCH VALLEY RAIL ROAD 
SC SANTA CRUZ AND MONTEREY BAY RAILWAY COMPANY 
SCBG SANTA CRUZ BIG TREES & PACIFIC RAILWAY CO 
SCIH SOUTH CHICAGO & INDIANA HARBOR RAILWAY COMPANY 
SCRF SOUTH CAROLINA CENTRAL RAILROAD CO INC 
SCS SQUAW CREEK SOUTHERN RAILROAD 
SCTR SCTRR LLC 
SCXF SOUTH CENTRAL FLORIDA EXPRESS INC 
SCXY ST CROIX VALLEY RAILROAD COMPANY 
SDIY SAN DIEGO & IMPERIAL VALLEY RAILROAD CO INC 
SE SEMO PORT RAILROAD INC 
SERA SIERRA RAILROAD COMPANY 
SFG SOCIETE DU CHEMIN DE FER DE LA GASPESIE 
SFR SOUTHERN FREIGHT RAILROAD 
SFS SANTA FE SOUTHERN RAILWAY 
SGLR SEMINOLE GULF RAILWAY L P 
SH STEELTON & HIGHSPIRE RAILROAD COMPANY 
SIND SOUTHERN INDIANA RAILWAY INC 
SJVR SAN JOAQUIN VALLEY RAILROAD CO 
SKOL SOUTH KANSAS & OKLAHOMA RAILROAD INC 
SL SALT LAKE CITY SOUTHERN RAILROAD COMPANY INC 
SLAL SOUTH PLAINS LAMESA RAILROAD LTD 
SLC SAN LUIS CENTRAL RAILROAD COMPANY 
SLGG S & L RAILROAD LLC 
SLGW SALT LAKE GARFIELD AND WESTERN RAILWAY COMPANY 
SLQ ST LAWRENCE & ATLANTIC RAILROAD (QUEBEC) INC 
SLR ST LAWRENCE & ATLANTIC RAILROAD CO 
SLRG SAN LUIS & RIO GRANDE RAILROAD INC 
SLRS SMS RAIL SERVICE INC 
SLWC STILLWATER CENTRAL RAILROAD COMPANY INC 
SM SAINT MARYS RAILROAD COMPANY 
SMA SAN MANUEL ARIZONA RAILROAD COMPANY 
SMNR SOUTHERN MANITOBA RAILWAY INC 
SMRR SISSETON MILBANK RAILROAD 
SMV SANTA MARIA VALLEY RAILROAD COMPANY 
SMW ST MARYS RAILWAY WEST LLC 
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SNC SARATOGA & NORTH CREEK RAILWAY 
SNR SUNFLOUR RAILROAD INC 
SNY SMS RAIL LINES OF NEW YORK LLC 
SOM SOMERSET RAILROAD CORPORATION 
SORA SOUTHERN RAILS COOPERATIVE LIMITED 

SPSR SAN PEDRO RAILROAD OPERATING CO LLC D/B/A SAN PEDRO & SOUTHWESTERN RAILROAD 
COMPANY 

SQVR SEQUATCHIE VALLEY RAILROAD INC 
SRC STRASBURG RAILROAD COMPANY 
SRN SABINE RIVER & NORTHERN RAILROAD COMPANY 
SRNJ SOUTHERN RAILROAD COMPANY OF NEW JERSEY 
SRRR SWAN RANCH RAILROAD LLC 
SRY SOUTHERN RAILWAY OF BRITISH COLUMBIA LTD 
SS SAND SPRINGS RAILWAY COMPANY 
SSC SOUTHERN SWITCHING COMPANY 
SSR S&S SHORTLINE RAILROAD 
ST ST RAIL SYSTEM 
STE STOCKTON TERMINAL AND EASTERN RAILROAD 
STMA ST MARIES RIVER RAILROAD COMPANY 
STR SHAWNEE TERMINAL RAILWAY COMPANY INC 
STRT STEWARTSTOWN RAILROAD CO 
STS SANTA TERESA SOUTHERN RAILROAD, LLC 
SUN SUNSET RAILWAY COMPANY 
SVI SOUTHERN RAILWAY OF VANCOUVER ISLAND LIMITED 
SVRR SHAMOKIN VALLEY RAILROAD COMPANY 
SW SOUTHWESTERN RAILROAD COMPANY INC 
SWP SOUTHWEST PENNSYLVANIA RAILROAD COMPANY 
TASD TERMINAL RAILWAY ALABAMA STATE DOCKS 
TBRY THERMAL BELT RAILWAY 
TC TEMPLE & CENTRAL TEXAS RAILWAY, INC. 
TCB TEXAS CENTRAL BUSINESS LINES CORPORATION 
TCG TUCSON CORNELIA & GILA BEND RAILROAD COMPANY 
TCKR TURTLE CREEK INDUSTRIAL RAILROAD INC 
TCRY TRI-CITY RAILROAD COMPANY 
TCT TEXAS CITY TERMINAL RAILWAY COMPANY 
TCWR TWIN CITIES & WESTERN RAILROAD 
TFVM TERMINAL FERROVIARIA DEL VALLE DE MEXICO SA DE CV 
TI TURNERS ISLAND LLC 
TIBR TIMBERROCK RAILROAD COMPANY INC 
TIRL TONAWANDA ISLAND RAILROAD INC 
TKEN TENNKEN RAILROAD COMPANY INC 
TLE MIDWEST RAIL, LLC DBA TOLEDO, LAKE ERIE AND WESTERN RAILWAY 
TMBL TACOMA MUNCIPAL BELT LINE RAILWAY 
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TMSS TOWANDA AND MONROETON SHIPPERS LIFELINE, INC. 
TMUS TRANSMEX/USA INC 
TN TEXAS & NORTHERN 
TNER TEXAS NORTHEASTERN DIVISION MID-MICHIGAN RAILROAD INC 
TNHR THREE NOTCH RAILWAY LLC 
TNMR TEXAS-NEW MEXICO DIVISION (AUSTIN & NORTHWESTERN RAILROAD COMPANY INC) 
TPW TOLEDO PEORIA & WESTERN RAILWAY CORPORATION 
TR TOMAHAWK RAILWAY L P 
TRC TRONA RAILWAY COMPANY 
TRIN TRINIDAD RAILWAY INC 
TRMW TACOMA RAIL MOUNTAIN DIVISION 
TRR THUNDER RAIL LTD 
TRRA TERMINAL RAILROAD ASSOCIATION OF ST LOUIS 
TRRY TRILLIUM RAILWAY CO LTD 
TRV TORCH RIVER RAIL INC. 
TSE TEXAS SOUTH-EASTERN RAILROAD COMPANY 
TSRR TENNESSEE SOUTHERN RAILROAD CO INC 
TSU TULSA-SAPULPA UNION RAILWAY COMPANY L L C 
TTIS TRANSKENTUCKY TRANSPORTATION RAILROAD CO INC 
TTR TALLEYRAND TERMINAL RAILROAD COMPANY INC 
TVRR TULARE VALLEY RAILROAD COMPANY 
TXGN TEXAS GONZALES & NORTHERN RAILWAY COMPANY 
TXN TEXAS NEW MEXICO RAILWAY, L.L.C. 
TXNW TEXAS NORTH WESTERN RAILWAY COMPANY 
TXOR TEXAS AND OKLAHOMA RAILROAD COMPANY 
TXPF TEXAS PACIFICO TRANSPORTATION LTD 
TXR TEXAS ROCK CRUSHER RAILWAY COMPANY 
TYBR TYBURN RAILROAD, LLC 
TZPR TAZEWELL & PEORIA RAILROAD INC 
UCIR UNION COUNTY INDUSTRIAL RAILROAD COMPANY 
UCRY UTAH CENTRAL RAILWAY COMPANY 
UMP UPPER MERION AND PLYMOUTH RAILROAD COMPANY 
UP UNION PACIFIC RAILROAD COMPANY 
URR UNION RAILROAD COMPANY 
USNY U.S. RAIL OF NEW YORK, LLC 
USR UTAH SOUTHERN RAILROAD COMPANY LLC 
USRP U.S. RAIL CORPORATION LLC 
UTAH UTAH RAILWAY COMPANY 
VCRR VENTURA COUNTY RAILROAD COMPANY 
VR VALDOSTA RAILWAY L P 
VRR VAUGHN RAILROAD COMPANY 
VRRC VANDALIA RAILROAD COMPANY 
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VSOR VICKSBURG SOUTHERN RAILROAD INC 
VSR V AND S RAILWAY INC 
VSRR VIRGINIA SOUTHERN RAILROAD DIVISION NORTH CAROLINA & VIRGINIA RAILROAD 
VST V&S RAILWAY INC D/B/A TOWNER RAILWAY 
VTR VERMONT RAILWAY INC 
VVRR VERMILION VALLEY RAILROAD COMPANY INC 
WACR WASHINGTON COUNTY RAILROAD CORPORATION 
WBCR WABASH CENTRAL RAILROAD CORPORATION 
WCLR WACCAMAW COASTLINE RAILROAD CO INC 
WCOR WELLSBORO & CORNING RAILROAD LLC 
WCRR WYOMING CONNECT RAILROAD LLC 
WCTR WCTU RAILWAY COMPANY 
WE WHEELING & LAKE ERIE RAILWAY COMPANY 
WFS WEST ISLE LINE INC 
WGCR WIREGRASS CENTRAL RAILWAY LLC 
WHOE WALKING HORSE & EASTERN RAILROAD CO INC 
WHRC WINDSOR & HANTSPORT RAILWAY CO 
WIR WASHINGTON & IDAHO RAILWAY INC 
WKRL WESTERN KENTUCKY RAILWAY LLC 
WMI WEST MICHIGAN RAILROAD CO 
WN PROGRESSIVE RAIL INC D/B/A WISCONSIN NORTHERN RAILROAD 
WNFR KANAWHA RAIL CORP 
WNYP WESTERN NEW YORK & PENNSYLVANIA RAILROAD LLC 
WPRR WILLAMETTE & PACIFIC RAILROAD INC 
WRRC WESTERN RAILROAD COMPANY 
WRS WESTERN RAIL SWITCHING INC 
WSOR WISCONSIN & SOUTHERN RAILROAD COMPANY 
WSR WARREN & SALINE RIVER RAILROAD COMPANY 
WSRY WINAMAC SOUTHERN RAILWAY COMPANY 
WSS WINSTON-SALEM SOUTHBOUND RAILWAY COMPANY (CSX TRANSPORTATION) 
WTA WICHITA TERMINAL ASSOCIATION 
WTCO WESTERN TRANSPORTATION CO 
WTJR WICHITA TILLMAN & JACKSON RAILWAY COMPANY INC 
WTLC WEST TEXAS AND LUBBOCK RAILWAY COMPANY 
WTNN WEST TENNESSEE RAILROAD CORP 
WTRM WARREN & TRUMBULL RAILROAD COMPANY, THE 
WTRY WILMINGTON TERMINAL RAILROAD INC 
WURR WALLOWA UNION RAILROAD AUTHORITY 
WVC WEST VIRGINIA CENTRAL RAILROAD 
WVR WILLAMETTE VALLEY RAILWAY COMPANY INC 
WW WINCHESTER AND WESTERN RAILROAD COMPANY 
WWRC WILMINGTON & WESTERN RAILWAY CORP 
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WYEC WYE TRANSPORTATION CO 
YARR YOUNGSTOWN & AUSTINTOWN RAILROAD CO 
YB YOUNGSTOWN BELT RAILROAD COMPANY, THE 
YCR YCR CORP 
YRC YORK RAILWAY COMPANY 
YRPL YELM ROY PRAIRIE LINE 
YSRR YOUNGSTOWN & SOUTHEASTERN RAILROAD COMPANY INC 
YSVR YELLOWSTONE VALLEY RAILROAD INC 
YVRR YADKIN VALLEY RAILROAD COMPANY 
YVT YAKIMA VALLEY TRANSPORTATION COMPANY 
YW YREKA WESTERN RAILROAD COMPANY 
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                 Railroads Sorted by Name 

 
 
 

Railroad NAME SCAC 
A & R LINE INC ARE 
ABERDEEN AND ROCKFISH RAILROAD COMPANY AR 
ABERDEEN CAROLINA & WESTERN RAILWAY CO ACWR 
ACADIANA RAILWAY COMPANY AKDN 
ADAMS WARNOCK RAILWAY, INC. AWRY 
ADRIAN & BLISSFIELD RAIL ROAD COMPANY ADBF 
AFFTON TERMINAL SERVICES RAILROAD, LLC AT 
AG VALLEY RAILROAD, LLC AVRR 
AIKEN RAILWAY COMPANY, LLC AIKR 
AIRLAKE TERMINAL RAILWAY COMPANY ALT 
AKRON BARBERTON CLUSTER RAILWAY COMPANY AB 
ALABAMA & FLORIDA RAILWAY CO AF 
ALABAMA & GULF COAST RAILWAY LLC AGR 
ALABAMA & TENNESSEE RIVER RAILWAY LLC ATN 
ALABAMA RAILROAD CO INC ALAB 
ALABAMA SOUTHERN RAILROAD ABS 
ALABAMA WARRIOR RAILWAY, LLC. ABWR 
ALAMEDA BELT LINE ABL 
ALAMO GULF COAST RAILROAD COMPANY AGCR 
ALASKA RAILROAD CORPORATION ARR 
ALBANY & EASTERN RAILROAD COMPANY AERC 
ALBANY PORT DISTRICT APD 
ALBERTA PRAIRIE RAILWAY APR 
ALEXANDER RAILROAD COMPANY ARC 
ALGERS WINSLOW AND WESTERN RAILWAY COMPANY AWW 
ALLEGHENY SOUTHERN RAILROAD INC ASR 
ALLEGHENY VALLEY RAILROAD COMPANY AVR 
ALLENTOWN AND AUBURN RAILROAD ALLN 
ALTEX ENERGY LTD ANRG 
ALTON & SOUTHERN RAILWAY COMPANY ALS 
AMADOR FOOTHILLS RAILROAD AFR 
AMTRAK-NATIONAL RAILROAD PASSENGER CORPORATION AMTK 
AN RAILWAY LLC AN 
ANGELINA & NECHES RIVER RAILROAD COMPANY ANR 

E A
pp

en
di

x 
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ANN ARBOR RAILROAD AA 
APACHE RAILWAY COMPANY APA 
APPALACHIAN & OHIO RAILROAD INC AO 
APPANOOSE COUNTY COMMUNITY RAILROAD INC APNC 
ARCADE AND ATTICA RAILROAD CORPORATION ARA 
ARIZONA & CALIFORNIA RAILROAD CO ARZC 
ARIZONA CENTRAL RAILROAD INC AZCR 
ARIZONA EASTERN RAILWAY COMPANY AZER 
ARKANSAS AND MISSOURI RAILROAD CO AM 
ARKANSAS LOUISIANA & MISSISSIPPI RAILROAD COMPANY ALM 
ARKANSAS MIDLAND RAILROAD CO INC AKMD 
ARKANSAS SOUTHERN RAILROAD ARS 
ARKANSAS-OKLAHOMA RAILROAD INC AOK 
ASHLAND RAILWAY CO ASRY 
ASHTABULA CARSON & JEFFERSON RAILROAD ACJR 
AT & L RAILROAD CO INC ATLT 
ATHENS LINE LLC, THE ABR 
ATLANTIC & WESTERN RAILWAY, L P ATW 
AUSTIN WESTERN RAILROAD AWRR 
AUTAUGA NORTHERN RAILROAD LLC AUT 
B&H RAIL CORP BH 
BAJA CALIFORNIA RAILROAD INC BJRR 
BALLARD TERMINAL RAILROAD CO LLC BDTL 
BALLARD TERMINAL RAILROAD COMPANY LLC D/B/A MEEKER SOUTHERN 
RAILROAD MSN 

BALTIMORE AND OHIO CHICAGO TERMINAL RAILROAD CO BOCT 
BARRIE-COLLINGWOOD RAILWAY BCRY 
BATTEN KILL RAILROAD INC BKRR 
BATTLE RIVER RAILWAY NGC INC BRR 
BAUXITE & NORTHERN RAILWAY COMPANY BXN 
BAY COAST RAILROAD BCR 
BAY COLONY RAILROAD CORPORATION BCLR 
BAY LINE RAILROAD L L C, THE BAYL 
BEECH MOUNTAIN RAILROAD COMPANY BEEM 
BELFAST AND MOOSEHEAD LAKE RAILROAD COMPANY BML 
BELT RAILWAY COMPANY OF CHICAGO BRC 
BELVIDERE & DELAWARE RIVER RAILWAY COMPANY INC BDRV 
BHP NEVADA RAILROAD COMPANY BHP 
BIG FOUR TERMINAL RAILROAD, LLC BFT 
BIG SKY RAIL CORP BGS 
BIG SPRING RAIL SYSTEM, INC. BSR 
BIGHORN DIVIDE & WYOMING RAILROAD INC BDW 
BIRMINGHAM SOUTHERN RR CO BS 
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BIRMINGHAM TERMINAL RAILWAY LLC BHRR 
BI-STATE DEVELOPMENT AGENCY BSDA 
BLACK RIVER & WESTERN CORPORATION BRW 
BLACKLANDS RAILROAD THE BLR 
BLACKWELL NORTHERN GATEWAY RAILROAD COMPANY BNG 
BLOOMER LINE, THE BLOL 
BLUE MOUNTAIN RAILROAD INC BLMR 
BLUE RIDGE SOUTHERN RAILROAD LLC BLU 
BNSF RAILWAY COMPANY BNSF 
BOGALUSA BAYOU RAILROAD LLC BBAY 
BOISE VALLEY RAILROAD, INC. BVRR 
BOONE & SCENIC VALLEY RAILROAD BSVY 
BOOT HILL & WESTERN RAILWAY CO LC BHWY 
BORDER PACIFIC RAILROAD CO BOP 
BOUNDARY TRAIL RAILWAY COMPANY INC. BTR 
BRANDON RAILROAD LLC BRAN 
BRANDYWINE VALLEY RAILROAD COMPANY BVRY 
BROOKHAVEN RAIL, LLC BHR 
BROWNSVILLE & RIO GRANDE INTERNATIONAL RAILWAY, LLC BRG 
BUCKINGHAM BRANCH RAILROAD COMPANY BB 
BUFFALO & PITTSBURGH RAILROAD INC BPRR 
BUFFALO SOUTHERN RAILROAD INC BSOR 
BURLINGTON JUNCTION RAILWAY BJRY 
BURLINGTON NORTHERN (MANITOBA) LTD BNML 
C & NC RAILROAD CORPORATION CNUR 
C & S RAILROAD CORPORATION CSKR 
C F LANAUDIERE INC CFL 
C&J RAILROAD COMPANY D/B/A MISSISSIPPI DELTA RAILROAD MD 
CADDO VALLEY RAILROAD COMPANY CVYR 
CALDWELL COUNTY RAILROAD COMPANY CWCY 
CALIFORNIA NORTHERN RAILROAD COMPANY LP CFNR 
CAMBRIA AND INDIANA RAILROAD COMPANY CI 
CAMDEN & SOUTHERN RAILROAD INC CSR 
CAMP CHASE INDUSTRIAL RAILROAD CORPORATION CCRA 
CAMP CHASE RAILWAY COMPANY, LLC CAMY 
CANADIAN NATIONAL RAILWAYS CN 
CANADIAN PACIFIC RAILWAY CPRS 
CANEY FORK AND WESTERN RR CFWR 
CANTON RAILROAD COMPANY CTN 
CAPE BRETON & CENTRAL NOVA SCOTIA RAILWAY CBNS 
CAPE FEAR RAILWAYS INC CF 
CAPE MAY SEASHORE LINES CMSL 
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CARLTON TRAIL RAILWAY COMPANY CTRW 
CAROLINA COASTAL RAILWAY INC CLNA 
CAROLINA PIEDMONT DIVISION SOUTH CAROLINA CENTRAL RAILROAD 
COMPANY INC CPDR 

CAROLINA SOUTHERN RAILROAD COMPANY, THE CALA 
CARRIZO GORGE RAILWAY INC CZRY 
CASCADE AND COLUMBIA RIVER RAILROAD COMPANY CSCD 
CATERPARROTT RAILNET, LLC CPR 
CCET, LLC CCET 
CEDAR RAPIDS & IOWA CITY RAILWAY COMPANY CIC 
CENTRAL CALIFORNIA TRACTION COMPANY CCT 
CENTRAL ILLINOIS RAILROAD COMPANY CIRY 
CENTRAL INDIANA & WESTERN RAILROAD CO INC CEIW 
CENTRAL MAINE & QUEBEC RAILWAY CMQ 
CENTRAL MANITOBA RAILWAY INC CEMR 
CENTRAL MIDLAND RAILWAY COMPANY CMR 
CENTRAL MONTANA RAIL INC CM 
CENTRAL NEW ENGLAND RAILROAD CO INC CNZR 
CENTRAL NEW YORK RAILROAD CORPORATION CNYK 
CENTRAL OREGON & PACIFIC RAILROAD INC CORP 
CENTRAL RAILROAD COMPANY OF INDIANAPOLIS CERA 
CENTRAL RAILROAD OF INDIANA CIND 
CENTRAL WASHINGTON RAILROAD COMPANY CWA 
CG RAILWAY INC CGR 
CHAPARRAL RAILROAD COMPANY INC CHRC 
CHARLOTTE SOUTHERN RAILROAD COMPANY CHS 
CHATTAHOOCHEE BAY RAILROAD INC CHAT 
CHATTAHOOCHEE INDUSTRIAL RAILROAD CIRR 
CHATTOOGA & CHICKAMAUGA RAILWAY CO CCKY 
CHESAPEAKE & ALBEMARLE CA 
CHESAPEAKE AND INDIANA RAILROAD COMPANY INC CKIN 
CHESAPEAKE RAILROAD COMPANY CHRR 
CHESSIE LOGISTICS CO., LLC CLCY 
CHESTNUT RIDGE RAILWAY COMPANY CHR 
CHICAGO FT WAYNE & EASTERN A DIVISION OF CENTRAL RAILROAD OF 
INDIANAPOLIS INC CFE 

CHICAGO RAIL LINK CRL 
CHICAGO SOUTHSHORE & SOUTH BEND RAILROAD CSS 
CHICAGO TERMINAL RAILROAD CTM 
CHICAGO-CHEMUNG RAILROAD CORP CCUO 
CIMARRON VALLEY RAILROAD L C CVR 
CITY OF PRINEVILLE RAILWAY COP 
CITY OF ROCHELLE ILLINOIS CIR 
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CLAREMONT CONCORD RAILROAD CORPORATION CCRR 
CLARENDON AND PITTSFORD RAILROAD COMPANY, THE CLP 
CLEVELAND COMMERCIAL RAILROAD COMPANY LLC CCRL 
CLEVELAND HARBOR BELT RAILROAD, LLC CHB 
CLEVELAND WORKS RAILWAY COMPANY CWRO 
CLINTON TERMINAL RAILROAD COMPANY CTR 
CLOQUET TERMINAL RAILROAD COMPANY INC CTRR 
CN AQUATRAIN CNAT 
COLORADO & WYOMING RWY CO CW 
COLUMBIA & COWLITZ RAILWAY LLC CLC 
COLUMBIA & NORTHERN RAILWAY CO CNOW 
COLUMBIA & READING RAILWAY CO CORY 
COLUMBIA BASIN RAILROAD COMPANY INC CBRW 
COLUMBIA TERMINAL CT 
COLUMBUS & CHATTAHOOCHEE RAILROAD, INC CCH 
COLUMBUS & OHIO RAILROAD COMPANY CUOH 
COLUMBUS AND GREENVILLE RAILWAY CAGY 
COMMONWEALTH RAILWAY INC CWRY 
COMPANIA DE FERROCARRILES CHIAPAS MAYAB SA DE CV FCCM 
COMSTOCK MOUNTAIN LION RAILROAD, INC. CMRR 
CONECUH VALLEY RAILWAY LLC COEH 
CONNECTICUT SOUTHERN RAILROAD INC CSO 
COOPERSVILLE AND MARNE RAILWAY COMPANY CPMY 
COOS BAY RAILROAD OPERATING CO., LLC CBR 
COPPER BASIN RAILWAY INC CBRY 
CORPUS CHRISTI TERMINAL RAILROAD INC CCPN 
CRAB ORCHARD & EGYPTIAN RAILWAY A DIVISION OF PROGRESSIVE RAIL 
IN COER 

CSX TRANSPORTATION CSXT 
CWRR INC CWR 
D & I RAILROAD COMPANY DAIR 
DAKOTA MISSOURI VALLEY & WESTERN RAILROAD INC DMVW 
DAKOTA NORTHERN RAILROAD INC DN 
DAKOTA SHORT LINE DAKS 
DAKOTA SOUTHERN RAILWAY COMPANY DSRC 
DALLAS GARLAND & NORTHEASTERN RAILROAD INC DGNO 
DALLAS TERMINAL RAILWAY DALT 
DANSVILLE AND MOUNT MORRIS RAILROAD COMPANY, THE DMM 
DARDANELLE & RUSSELLVILLE RAILROAD COMPANY DR 
DECATUR JUNCTION RAILWAY COMPANY DT 
DELAWARE COAST LINE RR CO DCLR 
DELAWARE VALLEY RAILWAY COMPANY INC DV 
DELAWARE-LACKAWANNA RAILROAD CO INC DL 
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DELRAY CONNECTING RAILROAD COMPANY DC 
DELTA SOUTHERN RAILROAD COMPANY DSRR 
DELTA VALLEY & SOUTHERN RAILWAY COMPANY DVS 
DENVER ROCK ISLAND RAILROAD DRIR 
DEPEW LANCASTER & WESTERN RAILROAD CO INC DLWR 
DEQUEEN & EASTERN RAILROAD LLC DQE 
DETROIT CONNECTING RAILROAD COMPANY DCON 
DEVCO RY (CAPE BRETON DEVELOPMENT CORP) DVR 
DRAKE SWITCHING COMPANY, LLC DSC 
DUBOIS COUNTY RAILROAD DCRR 
DURBIN & GREENBRIER VALLEY RAILROAD INC DGVR 
E & N RAILWAY COMPANY (1998) LTD ENR 
EAST BROAD TOP CONNECTING RAILROAD EBTC 
EAST BROOKFIELD & SPENCER RAILROAD LLC EBSR 
EAST CAMDEN & HIGHLAND RR CO EACH 
EAST CHATTANOOGA BELT RAILWAY COMPANY ECTB 
EAST COOPER AND BERKELEY RAILROAD COMPANY ECBR 
EAST ERIE COMMERCIAL RAILROAD EEC 
EAST JERSEY RAILROAD AND TERMINAL COMPANY EJR 
EAST MAHANOY & HAZELTON RAILROAD COMPANY EMHR 
EAST PENN RAILROAD LLC ESPN 
EAST TENNESSEE RAILWAY, L P ETRY 
EASTERN ALABAMA RAILWAY EARY 
EASTERN BERKS GATEWAY RAILROAD COMPANY EBG 
EASTERN IDAHO RAILROAD INC EIRR 
EASTERN ILLINOIS RAILROAD COMPANY EIRC 
EASTERN MAINE RAILWAY COMPANY EMRY 
EASTERN WASHINGTON GATEWAY RAILROAD COMPANY EWG 
EASTSIDE COMMUNITY RAIL, LLC ECYR 
ECORAIL INC ECO 
EFFINGHAM RAILROAD COMPANY EFRR 
EL DORADO AND WESSON RAILWAY COMPANY EDW 
ELIZABETHTOWN INDUSTRIAL RAILROAD, LLC EZR 
ELK RIVER RAILROAD INC ELKR 
ELKHART & WESTERN RAILROAD CO EWR 
ELLIS & EASTERN COMPANY EE 
ESCANABA AND LAKE SUPERIOR RAILROAD COMPANY ELS 
ESSEX TERMINAL RAILWAY COMPANY THE ETL 
EVANSVILLE WESTERN RAILWAY INC EVWR 
EVERETT RAILROAD EV 
FALLS ROAD RAILROAD CO INC FRR 
FARMRAIL CORPORATION FMRC 
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FERROCARRIL MEXICANO S A DE C V FXE 
FERROSUR S A DE C V FSRR 
FILLMORE WESTERN RAILWAY COMPANY FWRY 
FINGER LAKES RAILWAY CORP FGLK 
FIRST COAST RAILROAD INC FCRD 
FLATS INDUSTRIAL RAILROAD COMPANY FIR 
FLORIDA CENTRAL RAILROAD CO FCEN 
FLORIDA EAST COAST RAILWAY, LLC FEC 
FLORIDA MIDLAND RAILROAD CO INC FMID 
FLORIDA NORTHERN RAILROAD COMPANY INC FNOR 
FLORIDA WEST COAST RAILROAD INC FWCR 
FORDYCE AND PRINCETON RAILROAD CO FP 
FORE RIVER TRANSPORTATION CORPORATION FRVT 
FORT SMITH RAILROAD CO FSR 
FORT WORTH & DALLAS BELT RAILROAD FWDB 
FORT WORTH & WESTERN RAILROAD FWWR 
FULTON COUNTY RAILROAD INC FC 
FULTON COUNTY RAILWAY LLC FCR 
GALVESTON RAILROAD LP GVSR 
GARDEN CITY WESTERN RAILWAY COMPANY, THE GCW 
GARDENDALE RAILROAD, INC GRD 
GARY RAILWAY COMPANY GRW 
GATEWAY EASTERN RAILWAY COMPANY GWWE 
GEAUX GEAUX RAILROAD LLC GOGR 
GEORGES CREEK RAILWAY GCK 
GEORGETOWN RAILROAD COMPANY GRR 
GEORGIA & FLORIDA RAILWAY, LLC GFRR 
GEORGIA CENTRAL RAILWAY L P GC 
GEORGIA MIDLAND RAILROAD INC GMR 
GEORGIA NORTHEASTERN RAILROAD CO GNRR 
GEORGIA SOUTHERN RAILWAY CO. GS 
GEORGIA SOUTHWESTERN RAILROAD INC GSWR 
GEORGIA WOODLANDS RAILROAD CO GWRC 
GETTYSBURG & NORTHERN RAILROAD CO GET 
GLOSTER SOUTHERN RAILROAD COMPANY GLSR 
GNP RLY INC. GNPR 
GODERICH-EXETER RAILWAY COMPANY LTD GEXR 
GOLDEN ISLES TERMINAL RAILROAD INC GITM 
GOLDEN TRIANGLE RAILROAD LLC GTRA 
GRAFTON AND UPTON RAILROAD COMPANY GU 
GRAINBELT CORPORATION GNBC 
GRAND ELK RAILROAD, LLC. GDLK 

 
 PC*MILER|Rail User’s Guide 112 



 

GRAND FORKS RAILWAY COMPANY GFR 
GRAND RAPIDS EASTERN RAILROAD INC GR 
GREAT LAKES CENTRAL RAILROAD GLC 
GREAT NORTHWEST RAILROAD INC GRNW 
GREAT RIVER RAILROAD GTR 
GREAT SMOKEY MOUNTAINS RAILWAY INC GSM 
GREAT WALTON RAILROAD CO, THE GRWR 
GREAT WESTERN RAILWAY LTD GWRS 
GREAT WESTERN RAILWAY OF COLORADO LLC GWR 
GREEN MOUNTAIN RAILROAD CORPORATION GMRC 
GREENVILLE & WESTERN RAILWAY COMPANY LLC GRLW 
GRENADA RAILROAD LLC D/B/A GRENADA RAILWAY GRYR 
GULF COLORADO & SAN SABA RAILWAY GCSR 
HAINESPORT INDUSTRIAL RAILROAD LLC HIRR 
HAINESPORT SECONDARY, LLC HSR 
HAMPTON & BRANCHVILLE RAILROAD COMPANY HB 
HAMPTON RAILWAY INC HLSC 
HARDIN SOUTHERN RAILROAD INC HSRR 
HARTWELL RAILROAD COMPANY HRT 
HEART OF GEORGIA RAILROAD INC HOG 
HEART OF TEXAS RAILROAD, LP HTR 
HENDERSON OVERTON BRANCH HOB 
HERITAGE RAILROAD CORP HR 
HIGH POINT THOMASVILLE & DENTON RAILROAD COMPANY HPTD 
HILTON & ALBANY RAILOAD, INC. HAL 
HOLLIDAYSBURG AND ROARING SPRING RAILROAD COMPANY HRS 
HOLLIS & EASTERN R R CO HE 
HONDO RAILWAY LLC HRR 
HONEY CREEK RAILROAD INC HCRR 
HOOSIER SOUTHERN RAILROAD HOS 
HOUSATONIC RAILROAD COMPANY INC HRRC 
HUDSON BAY RAILWAY COMPANY HBRY 
HUNTSVILLE & MADISON COUNTY RAILROAD AUTHORITY HMCR 
HURON AND EASTERN RAILWAY COMPANY INC HESR 
HURON CENTRAL RAILWAY INC HCRY 
HUTCHINSON AND NORTHERN RAILWAY COMPANY, THE HN 
IDAHO NORTHERN & PACIFIC RAILROAD COMPANY INPR 
ILLINOIS & MIDLAND RAILROAD INC IMRR 
ILLINOIS RAILWAY, LLC IR 
ILLINOIS WESTERN RAILROAD COMPANY ILW 
INDIAN CREEK RAILROAD COMPANY ICRK 
INDIANA & OHIO RAILWAY COMPANY IORY 
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INDIANA EASTERN RAILROAD LLC IERR 

INDIANA EASTERN RAILROAD, LLC D/B/A OHIO SOUTH CENTRAL RAILROAD OSCR 

INDIANA HARBOR BELT RAILROAD COMPANY IHB 
INDIANA NORTHEASTERN RAILROAD COMPANY INC IN 
INDIANA RAIL ROAD CORPORATION INRD 
INDIANA SOUTHERN RAILROAD COMPANY INC ISRR 
INDIANA SOUTHWESTERN RAILWAY CO ISW 
INTERNATIONAL BRIDGE AND TERMINAL COMPANY, THE IBT 
INTERNATIONAL RAIL ROAD SYSTEMS INC IRRS 
IOWA INTERSTATE RAILROAD LTD IAIS 
IOWA NORTHERN RAILROAD IANR 
IOWA NORTHWESTERN RAILROAD IANW 
IOWA RIVER RAILROAD INC IARR 
IOWA SOUTHERN RAILROAD COMPANY ISR 
IOWA TRACTION RAILWAY COMPANY IATR 
J K LINE INC JKL 
JACKSON & LANSING RAILROAD COMPANY JAIL 
JUNIATA VALLEY RAILROAD COMPANY JVRR 
KANAWHA RAIL CORP WNFR 
KANKAKEE BEAVERVILLE AND SOUTHERN RAILROAD COMPANY KBSR 
KANSAS & OKLAHOMA RAILROAD INC KO 
KANSAS CITY SOUTHERN DE MEXICO S DE R L DE C V KCSM 
KANSAS CITY SOUTHERN RAILWAY COMPANY KCS 
KANSAS CITY TRANSPORTATION CO LLC KCTL 
KANSAS EASTERN RAILROAD INC KE 
KASGRO RAIL LINES KRL 
KAW RIVER RAILROAD KAW 
KELOWNA PACIFIC RAILWAY LTD KPR 
KENDALLVILLE TERMINAL RAILWAY CO KTR 
KENTUCKY AND TENNESSEE RAILWAY KT 
KEOKUK JUNCTION RAILWAY KJRY 
KETTLE FALLS INTERNATIONAL RAILWAY LLC KFR 
KIAMICHI RAILROAD COMPANY LLC KRR 
KINGMAN TERMINAL RAILROAD, LLC KGTR 
KISKI JUNCTION RAILROAD KJR 
KLAMATH NORTHERN RAILWAY COMPANY KNOR 
KNOX & KANE RAILROAD COMPANY KKRR 
KNOXVILLE & HOLSTON RIVER RAILROAD CO INC KXHR 
KOSCIUSKO SOUTHWESTERN RAILWAY KSRY 
KWT RAILWAY INC KWT 
KYLE RAILROAD COMPANY KYLE 
LAKE COUNTY RAILROAD LCR 
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LAKE LINE RAILROAD INC. LLR 
LAKE MICHIGAN AND INDIANA RAILROAD COMPANY LMIC 
LAKE STATE RAILWAY COMPANY LSRC 
LAKE SUPERIOR & ISHPEMING RAILROAD COMPANY LSI 
LAKE TERMINAL RAILROAD COMPANY, THE LT 
LAMOILLE VALLEY RAILROAD COMPANY LVRC 
LANCASTER & CHESTER RAILROAD, LLC. LC 
LANDISVILLE RAILROAD, LLC LVR 
LANDISVILLE TERMINAL & TRANSFER COMPANY LNVT 
LAPEER INDUSTRIAL RAILROAD COMPANY LIRR 
LAST MOUNTAIN RAILWAY LMR 
LAURINBURG AND SOUTHERN RAILROAD COMPANY LRS 
LEHIGH RAILWAY, LLC. LRWY 
LEHIGH VALLEY RAIL MANAGEMENT LLC - BETHLEHEM DIVISION LVRB 
LEHIGH VALLEY RAIL MANAGEMENT LLC - JOHNSTOWN DIVISION LVRJ 
LEWIS & CLARK RAILWAY CO LINC 
LINEA COAHUILA DURANGO SA DE CV LFCD 
LITTLE KANAWHA RIVER RAIL INC LKRR 
LITTLE ROCK & WESTERN RAILWAY, L P LRWN 
LITTLE ROCK PORT RAILROAD LRPA 
LIVONIA, AVON & LAKEVILLE RAILROAD CORPORATION LAL 
LOGANSPORT & EEL RIVER SHORT-LINE CO INC LER 
LONG CREEK RAILROAD COMPANY INC LCRI 
LONG ISLAND RAILROAD COMPANY LI 
LONGVIEW SWITCHING COMPANY LVSW 
LOS ANGELES JUNCTION RAILWAY COMPANY LAJ 
LOUISIANA & DELTA RAILROAD INC LDRR 
LOUISIANA AND NORTH WEST RAILROAD COMPANY, THE LNW 
LOUISIANA SOUTHERN RAILROAD LAS 
LOUISVILLE & INDIANA RAILROAD COMPANY LIRC 
LOUISVILLE AND WADLEY RAILWAY COMPANY LW 
LOUISVILLE NEW ALBANY & CORYDON RAILROAD LNAL 
LOWVILLE AND BEAVER RIVER RAILROAD COMPANY THE LBR 
LRY LLC. LRY 
LUBBOCK & WESTERN RAILWAY, L.L.C. LBWR 
LUXAPALILA VALLEY RAILROAD INC LXVR 
LUZERNE AND SUSQUEHANNA RAILWAY COMPANY LS 
LYCOMING VALLEY RAILROAD COMPANY LVRR 
M&B RAILROAD LLC MNBR 
MADISON RAILROAD (A DIV OF CITY OF MADISON PORT AUTHORITY) CMPA 
MAGMA ARIZONA RAILROAD COMPANY MAA 
MAHONING VALLEY RAILWAY COMPANY, THE MVRY 
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MAINE NORTHERN RAILWAY COMPANY MNR 
MANATEE COUNTY PORT AUTHORITY MAUP 
MANNING RAIL, INC MAN 
MANUFACTURERS JUNCTION RAILWAY COMPANY MJ 
MARQUETTE RAIL LLC MQT 
MARYLAND AND DELAWARE RAILROAD COMPANY MDDE 
MARYLAND MIDLAND RAILWAY INC MMID 
MASSACHUSETTS CENTRAL RAILROAD CORPORATION MCER 
MASSACHUSETTS COASTAL RAILROAD LLC MC 
MASSENA TERMINAL RAILROAD COMPANY, THE MSTR 
MAUMEE & WESTERN RAILROAD CORPORATION MAW 
MCCLOUD RAILWAY COMPANY MCR 
MCKEESPORT CONNECTING RAILROAD COMPANY MKC 
MCLAUGHLIN LINE RAILROAD MCLR 
MCM RAIL SERVICES, LLC D/B/A BALTIMORE INDUSTRIAL RAILROAD BDR 
MERIDIAN SOUTHERN RAILWAY LLC MDS 
MG RAIL INC MGRI 
MICHIGAN AIR-LINE RAILWAY CO MAL 
MICHIGAN SHORE RAILROAD INC MS 
MICHIGAN SOUTHERN RAILROAD CO INC MSO 
MIDDLETOWN & HUMMELSTOWN RAILROAD COMPANY MIDH 
MIDDLETOWN & NEW JERSEY RAILWAY LLC MNJ 
MID-MICHIGAN RAILROAD INC MMRR 
MIDWEST RAIL, LLC DBA TOLEDO, LAKE ERIE AND WESTERN RAILWAY TLE 
MINERAL RANGE, INC. MRA 
MINNESOTA COMMERCIAL RAILWAY CO MNNR 
MINNESOTA DAKOTA & WESTERN RAILWAY COMPANY MDW 
MINNESOTA NORTHERN RAILROAD INC MNN 
MINNESOTA PRAIRIE LINE INC MPLI 
MINNESOTA SOUTHERN RAILWAY INC MSWY 
MISSION MOUNTAIN RAILROAD MMT 
MISSISSIPPI & SKUNA VALLEY RAILROAD LLC MSV 
MISSISSIPPI CENTRAL RAILROAD COMPANY MSCI 
MISSISSIPPI EXPORT RAILROAD COMPANY MSE 
MISSISSIPPI SOUTHERN RAILROAD MSR 
MISSISSIPPI TENNESSEE RAILROAD LLC MTNR 
MISSISSIPPIAN RAILWAY COOPERATIVE INC MSRW 
MISSOURI & NORTHERN ARKANSAS RAILROAD COMPANY INC MNA 
MISSOURI & VALLEY PARK RAILROAD CORP MVP 
MODESTO AND EMPIRE TRACTION COMPANY MET 
MOHALL CENTRAL RAILROAD INC MHC 
MOHALL RAILROAD INC MRI 
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MOHAWK ADIRONDACK & NORTHERN RAILROAD CORP MHWA 
MONTANA RAIL LINK INC MRL 
MONTREAL MAINE AND ATLANTIC RAILWAY LTD MMA 
MORRISTOWN & ERIE RAILWAY INC ME 

MORRISTOWN & ERIE RAILWAY INC D/B/A MAINE EASTERN RAILROAD MERR 

MOSCOW, CAMDEN & SAN AUGUSTINE RAILROAD MCSA 
MOTIVE RAIL INC D/B/A MISSOURI NORTH CENTRAL RAILROAD MNC 
MT HOOD RAILROAD CO MH 
MT VERNON TERMINAL RAILWAY INC MVT 
MUNICIPALITY OF EAST TROY WISCONSIN METW 
N D C RAILROAD COMPANY NDCR 
NAPA VALLEY RAILROAD CO NVRR 
NASH COUNTY RAILROAD CORP NCYR 
NASHVILLE & WESTERN RAILROAD CORP NWR 
NASHVILLE AND EASTERN RAILROAD CORP NERR 
NATCHEZ RAILWAY LLC. NTZR 
NAUGATUCK RAILROAD COMPANY INC NAUG 
NC RAILROAD INC NCRL 
NEBKOTA RAILWAY INC NRI 
NEBRASKA CENTRAL RAILROAD COMPANY NCRC 
NEBRASKA KANSAS & COLORADO RAILNET INC NKCR 
NEBRASKA NORTHEASTERN RAILWAY COMPANY NENE 
NEBRASKA NORTHWESTERN RAILROAD INC. NNW 
NEW BRUNSWICK SOUTHERN RAILWAY COMPANY LIMITED NBSR 
NEW CASTLE INDUSTRIAL RAILROAD NCIR 
NEW ENGLAND CENTRAL RAILROAD INC NECR 
NEW ENGLAND SOUTHERN RAILROAD CO INC NEGS 
NEW HAMPSHIRE AND VERMONT RAILROAD COMPANY NHVT 
NEW HAMPSHIRE CENTRAL RAILROAD INC NHCR 
NEW HAMPSHIRE NORTHCOAST CORP NHN 
NEW HOPE & IVYLAND RAILROAD NHRR 
NEW JERSEY RAIL CARRIER LLC NJRC 
NEW JERSEY SEASHORE LINES, INC. NJSL 
NEW MEXICO GATEWAY RAILROAD LLC NMGR 
NEW ORLEANS & GULF COAST RAILWAY COMPANY INC NOGC 
NEW ORLEANS PUBLIC BELT RAILROAD NOPB 
NEW YORK & ATLANTIC RAILWAY COMPANY NYA 
NEW YORK & GREENWOOD LAKE RAILWAY NYGL 
NEW YORK & LAKE ERIE RAILROAD NYLE 
NEW YORK & OGDENSBURG RAILWAY COMPANY INC NYOG 
NEW YORK NEW JERSEY RAIL LLC NYNJ 
NEW YORK SUSQUEHANNA AND WESTERN RAILWAY CORP NYSW 

 
 Appendix E:  Railroads Sorted by Name 117 



  

NEWBURGH & SOUTH SHORE RAILROAD COMPANY NSR 
NIMISHILLEN & TUSCARAWAS LLC NTRY 
NITTANY & BALD EAGLE RAILROAD CO NBER 
NORFOLK & PORTSMOUTH BELT LINE RAILROAD COMPANY NPB 
NORFOLK SOUTHERN RAILWAY COMPANY (NORFOLK SOUTHERN) NS 
NORTH CAROLINA & VIRGINIA RAILROAD CO INC NCVA 
NORTH CAROLINA PORTS RAILWAY COMMISSION NCPR 
NORTH LOUISIANA & ARKANSAS RAILROAD NLA 
NORTH SHORE RAILROAD CO NSHR 
NORTHERN LINES RAILWAY LLC NLR 
NORTHERN OHIO & WESTERN RAILWAY LTD NOW 
NORTHERN PLAINS RAILROAD INC NPR 
NORTHWESTERN OKLAHOMA RAILROAD COMPANY NOKL 
NORTHWESTERN PACIFIC RAILROAD COMPANY NWP 
OAKLAND TERMINAL RAILROAD COMPANY OTR 
OGEECHEE RAILROAD COMPANY ORC 
OHIO & PENNSYLVANIA RAILROAD COMPANY OHPA 
OHIO CENTRAL RAILROAD CO OHCR 
OHIO SOUTHERN RAILROAD CO OSRR 
OHIO TERMINAL RAILWAY COMPANY OHIO 
OHIO VALLEY RAILROAD COMPANY OVR 
OHI-RAIL CORPORATION OHIC 
OIL CREEK & TITUSVILLE LINES OCTL 
OKANAGAN VALLEY RAILWAY COMPANY OKAN 
OLD AUGUSTA RAILROAD LLC OAR 
OLYMPIC RAILROAD CO, THE OLYR 
OMAHA LINCOLN AND BEATRICE RAILWAY COMPANY OLB 
ONTARIO CENTRAL RAILROAD CORPORATION ONCT 
ONTARIO L'ORIGNAL RAILWAY INC OLO 
ONTARIO MIDLAND RAILROAD CORPORATION OMID 
ONTARIO NORTHLAND RAILWAY (ONTARIO NORTHLAND TRANS 
COMMISSION) ONT 

ORANGE PORT TERMINAL RAILWAY OPT 
OREGON EASTERN RAILROAD OERR 
OREGON PACIFIC & EASTERN RAILWAY COMPANY OPE 
OREGON PACIFIC RAILROAD CO OPR 
OTTERTAIL VALLEY RAILROAD CO INC OTVR 
OTTUMWA TERMINAL RAILROAD CO OTT 
OUACHITA RAILROAD OUCH 
OWEGO & HARFORD RAILWAY INC OHRY 
OWENSVILLE TERMINAL CO INC OTCO 
OZARK VALLEY RAILROAD INC OVRR 
PACIFIC HARBOR LINE INC PHL 
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PADUCAH & ILLINOIS RAILROAD COMPANY PI 
PADUCAH & LOUISVILLE RAILWAY PAL 
PALOUSE RIVER & COULEE CITY RAILROAD INC PCC 
PAN AM SOUTHERN, LLC. PAS 
PANHANDLE NORTHERN RAILROAD COMPANY PNR 
PATAPSCO & BACK RIVERS RAILROAD COMPANY PBR 
PEARL RIVER VALLEY RAILROAD COMPANY PRV 
PECOS VALLEY PERMIAN RAILROAD LLC DBA PECOS VALLEY SOUTHERN 
RAILW PVS 

PEE DEE RIVER RAILROAD CORP PDRR 
PEND OREILLE VALLEY RAILROAD (PORT OF PEND OREILLE) POVA 
PENINSULA TERMINAL COMPANY PT 
PENNSYLVANIA & SOUTHERN RAILWAY LLC PSCC 
PENNSYLVANIA NORTHEASTERN RAILROAD, LLC PN 
PENNSYLVANIA SOUTHWESTERN RAILROAD INC PSWR 
PERU INDUSTRIAL RAILROAD, LLC PIR 
PICKENS RAILWAY COMPANY PICK 
PICKENS RAILWAY COMPANY PKHP 
PIEDMONT RAILWAY LLC D/B/A PIEDMONT & NORTHERN RAILROAD PNRW 
PIONEER INDUSTRIAL RAILWAY CO PRY 
PIONEER VALLEY RAILROAD COMPANY PVRR 
PITTSBURGH ALLEGHENY & MCKEES ROCKS RR CO PAM 
PLAINVIEW TERMINAL COMPANY PTC 
POINT COMFORT & NORTHERN RAILWAY COMPANY PCN 
PORT BIENVILLE RAILROAD PBVR 
PORT HARBOR RAILROAD INC PHRR 
PORT JERSEY RAILROAD CO PJR 
PORT OF TILLAMOOK BAY RAILROAD POTB 
PORT RAIL, INC. PRI 
PORT TERMINAL RAILROAD ASSOCIATION PTRA 
PORT TERMINAL RAILROAD OF SOUTH CAROLINA PTR 
PORT UTILITIES COMMISSION OF CHARLESTON SC PUCC 
PORTLAND & WESTERN RAILROAD INC PNWR 
PORTLAND TERMINAL RAILROAD COMPANY PTRC 
PORTLAND VANCOUVER JUNCTION RAILROAD LLC PVJR 
PRESCOTT AND NORTHWESTERN RAILROAD COMPANY PNW 
PROGRESSIVE RAIL INC PGR 

PROGRESSIVE RAIL INC D/B/A CANNON VALLEY RAILROAD COMPANY CVRC 

PROGRESSIVE RAIL INC D/B/A WISCONSIN NORTHERN RAILROAD WN 
PROVIDENCE AND WORCESTER RAILROAD COMPANY PW 
PYCO INDUSTRIES INC PSC 
QUEBEC CENTRAL RAILWAY COMPANY QCR 
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QUEBEC GATINEAU RAILWAY INC QGRY 
QUEBEC NORTH SHORE AND LABRADOR RAILWAY COMPANY QNSL 
QUINCY RAILROAD COMPANY QRR 
R J CORMAN RAILROAD COMPANY/ALLENTOWN LINES INC RJCN 
R J CORMAN RAILROAD COMPANY/CENTRAL KENTUCKY LINES RJCC 
R J CORMAN RAILROAD COMPANY/CLEVELAND LINE RJCL 
R J CORMAN RAILROAD COMPANY/MEMPHIS LINE RJCM 
R J CORMAN RAILROAD COMPANY/PENNSYLVANIA LINES INC RJCP 
R J CORMAN RAILROAD COMPANY/TENNESSEE TERMINAL LLC RJCK 
R J CORMAN RAILROAD COMPANY/WESTERN OHIO LINE RJCW 
R J CORMAN RAILROAD COMPANY/WV LINE RJCV 
R J CORMAN RAILROAD CORPORATION/BARDSTOWN LINE RJCR 
RAILINK OTTAWA VALLEY RLK 
RAILINK SOUTHERN ONTARIO RLHH 
RAILROAD SWITCHING SERVICE OF MISSOURI INC RSM 
RAPID CITY, PIERRE & EASTERN RAILROAD, INC. RCPE 
RARITAN CENTRAL RAILWAY LLC RCRY 
RARUS RAILWAY COMPANY RARW 
READING BLUE MOUNTAIN & NORTHERN RAILROAD COMPANY RBMN 
RED COAT ROAD & RAIL LTD RCRR 
RED RIVER VALLEY & WESTERN RAILROAD CO RRVW 
RED SPRINGS & NORTHERN RAILROAD CO RSNR 
REDMONT RAILWAY COMPANY INC RRC 
RICEBORO SOUTHERN RAILWAY LLC RSOR 
RICHMOND PACIFIC RAILROAD CORPORATION RPRC 
RIO VALLEY SWITCHING COMPANY RVSC 
RIPLEY & NEW ALBANY RAILROAD COMPANY RNA 
RIVERPORT RAILROAD LLC RVPR 
RJ CORMAN RAILROAD CO/CAROLINA LINES, LLC RJCS 
RJ CORMAN RAILROAD COMPANY/TEXAS LINES, LLC RJCD 
ROBERVAL AND SAGUENAY RAILWAY COMPANY, THE RS 
ROCHESTER & SOUTHERN RAILROAD INC RSR 
ROCK & RAIL INC RRRR 
ROCKDALE SANDOW & SOUTHERN RAILROAD COMPANY RSS 
ROCKY MOUNTAIN RAILCAR AND RAILROAD INC RMRR 
ROGUE VALLEY TERMINAL RAILROAD CORPORATION RVT 
ROSCOE SNYDER & PACIFIC RAILWAY COMPANY RSP 
RSL RAILROAD LLC RSL 
RUSK, PALESTINE, & PACIFIC RAILROAD, LLC RPP 
RUTLAND LINE INC RL 
S & L RAILROAD LLC SLGG 
S&S SHORTLINE RAILROAD SSR 
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SABINE RIVER & NORTHERN RAILROAD COMPANY SRN 
SACRAMENTO VALLEY RAILROAD SAV 
SAINT MARYS RAILROAD COMPANY SM 
SALT LAKE CITY SOUTHERN RAILROAD COMPANY INC SL 
SALT LAKE GARFIELD AND WESTERN RAILWAY COMPANY SLGW 
SAN ANTONIO CENTRAL RAILROAD, LLC SAC 
SAN DIEGO & IMPERIAL VALLEY RAILROAD CO INC SDIY 
SAN JOAQUIN VALLEY RAILROAD CO SJVR 
SAN LUIS & RIO GRANDE RAILROAD INC SLRG 
SAN LUIS CENTRAL RAILROAD COMPANY SLC 
SAN MANUEL ARIZONA RAILROAD COMPANY SMA 
SAN PEDRO RAILROAD OPERATING CO LLC D/B/A SAN PEDRO & 
SOUTHWESTERN RAILROAD COMPANY SPSR 

SAND SPRINGS RAILWAY COMPANY SS 
SANDERSVILLE RAILROAD COMPANY SAN 
SANTA CRUZ AND MONTEREY BAY RAILWAY COMPANY SC 
SANTA CRUZ BIG TREES & PACIFIC RAILWAY CO SCBG 
SANTA FE SOUTHERN RAILWAY SFS 
SANTA MARIA VALLEY RAILROAD COMPANY SMV 
SANTA TERESA SOUTHERN RAILROAD, LLC STS 
SARATOGA & NORTH CREEK RAILWAY SNC 
SAVAGE BINGHAM & GARFIELD RAILROAD COMPANY SBG 
SAVANNAH PORT TERMINAL RAILROAD INC SAPT 
SCTRR LLC SCTR 
SEMINOLE GULF RAILWAY L P SGLR 
SEMO PORT RAILROAD INC SE 
SEQUATCHIE VALLEY RAILROAD INC SQVR 
SHAMOKIN VALLEY RAILROAD COMPANY SVRR 
SHAWNEE TERMINAL RAILWAY COMPANY INC STR 
SIERRA RAILROAD COMPANY SERA 
SISSETON MILBANK RAILROAD SMRR 
SMS RAIL LINES OF NEW YORK LLC SNY 
SMS RAIL SERVICE INC SLRS 
SOCIETE DU CHEMIN DE FER DE LA GASPESIE SFG 
SOMERSET RAILROAD CORPORATION SOM 
SOUTH BRANCH VALLEY RAIL ROAD SBVR 
SOUTH CAROLINA CENTRAL RAILROAD CO INC SCRF 
SOUTH CAROLINA DIVISION OF PUBLIC RAILWAYS D/B/A PALMETTO 
RAILWAY PR 

SOUTH CENTRAL FLORIDA EXPRESS INC SCXF 
SOUTH CHICAGO & INDIANA HARBOR RAILWAY COMPANY SCIH 
SOUTH KANSAS & OKLAHOMA RAILROAD INC SKOL 
SOUTH PLAINS LAMESA RAILROAD LTD SLAL 

 
 Appendix E:  Railroads Sorted by Name 121 



  

SOUTH PLAINS SWITCHING LTD CO SAW 
SOUTHERN FREIGHT RAILROAD SFR 
SOUTHERN INDIANA RAILWAY INC SIND 
SOUTHERN MANITOBA RAILWAY INC SMNR 
SOUTHERN RAILROAD COMPANY OF NEW JERSEY SRNJ 
SOUTHERN RAILS COOPERATIVE LIMITED SORA 
SOUTHERN RAILWAY OF BRITISH COLUMBIA LTD SRY 
SOUTHERN RAILWAY OF VANCOUVER ISLAND LIMITED SVI 
SOUTHERN SWITCHING COMPANY SSC 
SOUTHWEST PENNSYLVANIA RAILROAD COMPANY SWP 
SOUTHWESTERN RAILROAD COMPANY INC SW 
SQUAW CREEK SOUTHERN RAILROAD SCS 
ST CROIX VALLEY RAILROAD COMPANY SCXY 
ST LAWRENCE & ATLANTIC RAILROAD (QUEBEC) INC SLQ 
ST LAWRENCE & ATLANTIC RAILROAD CO SLR 
ST MARIES RIVER RAILROAD COMPANY STMA 
ST MARYS RAILWAY WEST LLC SMW 
ST RAIL SYSTEM ST 
STEELTON & HIGHSPIRE RAILROAD COMPANY SH 
STERLING BELT LINE RAILWAY SBLN 
STEWARTSTOWN RAILROAD CO STRT 
STILLWATER CENTRAL RAILROAD COMPANY INC SLWC 
STOCKTON TERMINAL AND EASTERN RAILROAD STE 
STOURBRIDGE RAILROAD COMPANY SBRR 
STRASBURG RAILROAD COMPANY SRC 
SUNFLOUR RAILROAD INC SNR 
SUNSET RAILWAY COMPANY SUN 
SWAN RANCH RAILROAD LLC SRRR 
TACOMA MUNCIPAL BELT LINE RAILWAY TMBL 
TACOMA RAIL MOUNTAIN DIVISION TRMW 
TALLEYRAND TERMINAL RAILROAD COMPANY INC TTR 
TAZEWELL & PEORIA RAILROAD INC TZPR 
TEMPLE & CENTRAL TEXAS RAILWAY, INC. TC 
TENNESSEE SOUTHERN RAILROAD CO INC TSRR 
TENNKEN RAILROAD COMPANY INC TKEN 
TERMINAL FERROVIARIA DEL VALLE DE MEXICO SA DE CV TFVM 
TERMINAL RAILROAD ASSOCIATION OF ST LOUIS TRRA 
TERMINAL RAILWAY ALABAMA STATE DOCKS TASD 
TEXAS & NORTHERN TN 
TEXAS AND OKLAHOMA RAILROAD COMPANY TXOR 
TEXAS CENTRAL BUSINESS LINES CORPORATION TCB 
TEXAS CITY TERMINAL RAILWAY COMPANY TCT 
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TEXAS GONZALES & NORTHERN RAILWAY COMPANY TXGN 
TEXAS NEW MEXICO RAILWAY, L.L.C. TXN 
TEXAS NORTH WESTERN RAILWAY COMPANY TXNW 
TEXAS NORTHEASTERN DIVISION MID-MICHIGAN RAILROAD INC TNER 
TEXAS PACIFICO TRANSPORTATION LTD TXPF 
TEXAS ROCK CRUSHER RAILWAY COMPANY TXR 
TEXAS SOUTH-EASTERN RAILROAD COMPANY TSE 
TEXAS-NEW MEXICO DIVISION (AUSTIN & NORTHWESTERN RAILROAD 
COMPANY INC) TNMR 

THE ALIQUIPPA & OHIO RIVER RAILROAD COMPANY AOR 

THE GREAT LAKE PORT CORPORATION D/B/A THE GRAND RIVER RAILWAY GRRY 

THE NELSON AND FT. SHEPPARD RAILWAY CORPORATION NFTS 
THE PITTSBURGH & OHIO CENTRAL RAILROAD COMPANY POHC 
THE PUGET SOUND & PACIFIC RAILROAD COMPANY A DIVISION OF THE 
ARIZONA & CALIFORNIA RAILROAD CO LP PSAP 

THERMAL BELT RAILWAY TBRY 
THREE NOTCH RAILWAY LLC TNHR 
THUNDER RAIL LTD TRR 
TIMBERROCK RAILROAD COMPANY INC TIBR 
TOLEDO PEORIA & WESTERN RAILWAY CORPORATION TPW 
TOMAHAWK RAILWAY L P TR 
TONAWANDA ISLAND RAILROAD INC TIRL 
TORCH RIVER RAIL INC. TRV 
TOWANDA AND MONROETON SHIPPERS LIFELINE, INC. TMSS 
TRANSKENTUCKY TRANSPORTATION RAILROAD CO INC TTIS 
TRANSMEX/USA INC TMUS 
TRI-CITY RAILROAD COMPANY TCRY 
TRILLIUM RAILWAY CO LTD TRRY 
TRINIDAD RAILWAY INC TRIN 
TRONA RAILWAY COMPANY TRC 
TUCSON CORNELIA & GILA BEND RAILROAD COMPANY TCG 
TULARE VALLEY RAILROAD COMPANY TVRR 
TULSA-SAPULPA UNION RAILWAY COMPANY L L C TSU 
TURNERS ISLAND LLC TI 
TURTLE CREEK INDUSTRIAL RAILROAD INC TCKR 
TWIN CITIES & WESTERN RAILROAD TCWR 
TYBURN RAILROAD, LLC TYBR 
U.S. RAIL CORPORATION LLC USRP 
U.S. RAIL OF NEW YORK, LLC USNY 
UNION COUNTY INDUSTRIAL RAILROAD COMPANY UCIR 
UNION PACIFIC RAILROAD COMPANY UP 
UNION RAILROAD COMPANY URR 
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UPPER MERION AND PLYMOUTH RAILROAD COMPANY UMP 
UTAH CENTRAL RAILWAY COMPANY UCRY 
UTAH RAILWAY COMPANY UTAH 
UTAH SOUTHERN RAILROAD COMPANY LLC USR 
V AND S RAILWAY INC VSR 
V&S RAILWAY INC D/B/A TOWNER RAILWAY VST 
VALDOSTA RAILWAY L P VR 
VANDALIA RAILROAD COMPANY VRRC 
VAUGHN RAILROAD COMPANY VRR 
VENTURA COUNTY RAILROAD COMPANY VCRR 
VERMILION VALLEY RAILROAD COMPANY INC VVRR 
VERMONT RAILWAY INC VTR 
VICKSBURG SOUTHERN RAILROAD INC VSOR 
VIRGINIA SOUTHERN RAILROAD DIVISION NORTH CAROLINA & VIRGINIA 
RAILROAD VSRR 

WABASH CENTRAL RAILROAD CORPORATION WBCR 
WACCAMAW COASTLINE RAILROAD CO INC WCLR 
WALKING HORSE & EASTERN RAILROAD CO INC WHOE 
WALLOWA UNION RAILROAD AUTHORITY WURR 
WARREN & SALINE RIVER RAILROAD COMPANY WSR 
WARREN & TRUMBULL RAILROAD COMPANY, THE WTRM 
WASHINGTON & IDAHO RAILWAY INC WIR 
WASHINGTON COUNTY RAILROAD CORPORATION WACR 
WCTU RAILWAY COMPANY WCTR 
WELLSBORO & CORNING RAILROAD LLC WCOR 
WEST ISLE LINE INC WFS 
WEST MICHIGAN RAILROAD CO WMI 
WEST TENNESSEE RAILROAD CORP WTNN 
WEST TEXAS AND LUBBOCK RAILWAY COMPANY WTLC 
WEST VIRGINIA CENTRAL RAILROAD WVC 
WESTERN KENTUCKY RAILWAY LLC WKRL 
WESTERN NEW YORK & PENNSYLVANIA RAILROAD LLC WNYP 
WESTERN RAIL SWITCHING INC WRS 
WESTERN RAILROAD COMPANY WRRC 
WESTERN TRANSPORTATION CO WTCO 
WHEELING & LAKE ERIE RAILWAY COMPANY WE 
WICHITA TERMINAL ASSOCIATION WTA 
WICHITA TILLMAN & JACKSON RAILWAY COMPANY INC WTJR 
WILLAMETTE & PACIFIC RAILROAD INC WPRR 
WILLAMETTE VALLEY RAILWAY COMPANY INC WVR 
WILMINGTON & WESTERN RAILWAY CORP WWRC 
WILMINGTON TERMINAL RAILROAD INC WTRY 
WINAMAC SOUTHERN RAILWAY COMPANY WSRY 
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WINCHESTER AND WESTERN RAILROAD COMPANY WW 
WINDSOR & HANTSPORT RAILWAY CO WHRC 
WINSTON-SALEM SOUTHBOUND RAILWAY COMPANY (CSX 
TRANSPORTATION) WSS 

WIREGRASS CENTRAL RAILWAY LLC WGCR 
WISCONSIN & SOUTHERN RAILROAD COMPANY WSOR 
WYE TRANSPORTATION CO WYEC 
WYOMING CONNECT RAILROAD LLC WCRR 
YADKIN VALLEY RAILROAD COMPANY YVRR 
YAKIMA VALLEY TRANSPORTATION COMPANY YVT 
YCR CORP YCR 
YELLOWSTONE VALLEY RAILROAD INC YSVR 
YELM ROY PRAIRIE LINE YRPL 
YORK RAILWAY COMPANY YRC 
YOUNGSTOWN & AUSTINTOWN RAILROAD CO YARR 
YOUNGSTOWN & SOUTHEASTERN RAILROAD COMPANY INC YSRR 
YOUNGSTOWN BELT RAILROAD COMPANY, THE YB 
YREKA WESTERN RAILROAD COMPANY YW 
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single route, 34, 71 
station format, 29 
stop editing, 40 
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S 
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single line route, 27 
single route entry, 29, 71 
spelling help, 31 
SPLC entry, 31 
SPLC search, 31 
station formats, 29 

3-3-3, 33 
FSAC, 32 
R260, 34 
SPLC, 31 
station name and state, 30 

station name entry, 30 
station name search, 31 
stop entry, 29 

Zoom to Stop feature, 63 
stop labels, 67 
switch move only railroads, 39, 49 
 
T 

TCP/IP, 2 
technical support, 19 
terminal switch RRs, 39, 49 
trackage rights, 69 
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U 
uninstalling, 18 
updates, 21 
user guides, 20 
 
W 
window position options, 26 
 
Z 
zooming the map view, 63 
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