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PC*MILER® |Rail
END-USER LICENSE AGREEMENT

1. Grant of License: Subject to the terms, conditions, use limitations and payment of fees
as set forth herein, ALK Technologies, Inc. ("ALK") grants the end-user ("you™) a non-
assignable, non-transferable, non-exclusive license to install and use the PC*MILER|Rail
solution(s) you have purchased ("PC*MILER|Rail") on a single personal computer. The
PC*MILER|Rail software, data and documentation are provided for your personal,
internal use only and not for resale. They are protected by copyright held by ALK and its
licensors and are subject to the following terms and conditions which are agreed to by
you, on the one hand, and ALK and its licensors (including their licensors and suppliers)
on the other hand.

2. Title: You acknowledge that the PC*MILER|Rail computer programs, data, concepts,
graphics, documentation, manuals and other material owned by, developed by or licensed
to ALK, including but not limited to program output (together, “program materials™), are
the exclusive property of ALK or its licensors. You do not secure title to any
PC*MILER|Rail program materials by virtue of this license.

3. Copies: You may make one (1) copy of the PC*MILER|Rail program materials,
provided you retain such copy in your possession and use it solely for backup purposes.
You agree to reproduce the copyright and other proprietary rights notices of ALK and its
licensors on such a copy. Otherwise, you agree not to copy, reverse engineer, interrogate,
or decode any PC*MILER|Rail program materials or attempt to defeat protection
provided by ALK for preventing unauthorized copying or use of PC*MILER|Rail or to
derive any source code or algorithms therefrom. You acknowledge that unauthorized use
or reproduction of copies of any program materials or unauthorized transfer of any copy
of the program materials is a serious crime and is grounds for suit for damages, injunctive
relief and attorneys' fees.

4. Limitations on Transfer: This license is granted to you by ALK. You may not directly
or indirectly lease, sublicense, sell, disseminate, or otherwise transfer PC*MILER|Rail or
any PC*MILER|Rail program materials to third parties, or offer information services to
third parties utilizing the PC*MILER|Rail program materials without ALK's prior written
consent. To comply with this limitation, you must uninstall and deactivate
PC*MILER|Rail from your computer prior to selling or transferring that computer to a
third party.

5. Limitations on Network Access: You may not allow end-users or software applications
on other computers or devices to directly or indirectly access this copy of
PC*MILER|Rail via any type of computer or communications network (including but not
limited to local area networks, wide area networks, intranets, extranets, the internet,
virtual private networks, Wi-Fi, Bluetooth, and cellular and satellite communications
systems), using middleware (including but not limited to Citrix MetaFrame and Microsoft
Terminal Server) or otherwise (including but not limited to access through
PC*MILER|Rail interface products), or install or use PC*MILER|Rail on a network file
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server, without first notifying ALK, executing a written supplemental license agreement,
and paying the license fee that corresponds to the number and types of uses to which
access is to be allowed.

6. Limitations on Data Extraction: You may manually extract data (including but not
limited to program output such as distances, maps, and reports) from PC*MILER|Rail
and use it in other applications on the same computer on which PC*MILER|Rail is
legally licensed and installed, as permitted below. You may not transfer data extracted
from PC*MILER|Rail onto any other computer or device unless you have licensed
PC*MILER|Rail for that computer or device. You agree that you will not, nor will you
permit your trade partners or anyone else to, use content derived from PC*MILER|Rail,
including route line data, nor display such data or integrate such data into another
provider’s service, including, but not limited to, Google or Bing. You agree not to pre-
fetch, retrieve, cache, index, or store any data, content, or other portion of the product
output at any time, provided, however, that you may temporarily store (for less than thirty
(30) days) limited amounts of such content for the sole and exclusive purpose of
enhancing the performance of your implementation due to network latency, and only if
you do so securely and in a manner that: (a) does not permit use of the content outside of
the scope of this Agreement; (b) does not manipulate or aggregate any content or portion
thereof; (c) does not prevent ALK from accurately tracking usage; and (d) does not
modify attribution of the product in any way.

7. Limitations on Mobile Communications: Without limiting the generality of the
foregoing, you may not transmit PC*MILER|Rail street-level driving directions through
mobile communications systems such as satellite, cellular services, electronic recording
devices, or to mobile devices such as computers, telematics systems, on board or mobile
computers or Smartphones, handhelds, pagers, electronic recording devices or telephones
without first executing a written supplemental license agreement with ALK and paying
the license fee that corresponds to the number and types of devices and systems to and
through which transmission is to be permitted. You may not use this License, any of the
Licensed Product, or its reports, to create a competitive product, solution or visualization
platform.

8. Limitations on Disclosure: You may disclose PC*MILER|Rail distances to trading
partners, in the course of their providing services to you, for specific origin-destination
moves for which you provide transportation services and use PC*MILER|Rail distances
as a basis for payment. You may not make any other disclosure of PC*MILER|Rail
programs and materials, including, but not limited to, program output, to anyone outside
the legal entity that paid for and holds this license, without prior written permission of
ALK. You acknowledge that the PC*MILER|Rail programs and materials, developed by
or licensed to ALK are very valuable to ALK and its licensors, and their use or disclosure
to third parties, except as permitted by this license or by a written supplemental license
agreement with ALK, is strictly prohibited.

9. Security: You agree to take reasonable and prudent steps to safeguard the security of
the PC*MILER|Rail program materials and to notify ALK immediately if you become
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aware of the theft or unauthorized possession, use, transfer or sale of the PC*MILER|Rail
program materials licensed to you by ALK.

10. Acceptance: You are deemed to have accepted the PC*MILER|Rail program
materials upon receipt.

11. Warranties: ALK represents and warrants that:

a) For ninety (90) days from date of purchase, PC*MILER|Rail, when delivered and
properly installed, will function substantially according to its specifications on a
computer purchased independently by you.

b) For ninety (90) days from date of purchase, the software media on which ALK
provides PC*MILER|Rail to you will function substantially free of errors and defects.
ALK will replace defective media during the warranty period at no charge to you
unless the defect is the result of accident, abuse, or misapplication of the product.

c) THE FOREGOING WARRANTIES ARE IN LIEU OF ALL OTHER
WARRANTIES EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITING
THE GENERALITY OF THE FOREGOING ANY WARRANTY OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. THE
PC*MILER|Rail PROGRAM, DATA AND DOCUMENTATION IS SOLD "AS IS".
IN NO EVENT SHALL ALK OR ITS LICENSORS BE LIABLE FOR ANY
INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES SUCH AS, BUT NOT
LIMITED TO, LOSS IN CONNECTION WITH OR ARISING OUT OF THE
EXISTENCE OF THE FURNISHING, FUNCTIONING OR USE OF ANY ITEM
OF SOFTWARE, DATA OR SERVICES PROVIDED FOR IN THIS
AGREEMENT. IN NO EVENT SHALL DAMAGES TO WHICH ALK MAY BE
SUBJECT UNDER THIS AGREEMENT EXCEED THE CONTRACT PRICE.
THIS WARRANTY SHALL NOT ACCRUE TO THE BENEFIT OF THIRD
PARTIES OR ASSIGNEES.

12. Disclaimer: The data may contain inaccurate, incomplete or untimely information due
to the passage of time, changing circumstances, sources used and the nature of collecting
comprehensive geographic data, any of which may lead to incorrect results.
PC*MILER|Rail’s suggested routings and distances data are provided without a warranty
of any kind. The user assumes full responsibility for any delay, expense, loss or damage
that may occur as a result of their use. The user shall have no recourse against Canada,
whether by way of any suit or action, for any loss, liability, damage or cost that may
occur at any time, by reason of possession or use of Natural Resources Canada data.

This data is provided to you “as is,” and you agree to use it at your own risk. ALK and its
licensors (and their licensors and suppliers) make no guarantees, representations or
warranties of any kind, express or implied, arising by law or otherwise, including but not
limited to, content, quality, accuracy, completeness, effectiveness, reliability, fitness for a
particular purpose, usefulness, use or results to be obtained from this Data, or that the
Data or server will be uninterrupted or error-free.
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13. Termination: This Agreement will terminate immediately upon any of the following
events:

a) If you seek an order for relief under the bankruptcy laws of the United States or
similar laws of any other jurisdiction, or a composition with or assignment for the
benefit of creditors, or dissolution or liquidation, or if proceedings under any
bankruptcy or insolvency law are commenced against you and are not discharged
within thirty (30) calendar days.

b) If you materially breach any terms, conditions, use limitations, payment
obligations, or any other terms of this Agreement.

c¢) Upon expiration of any written supplemental license agreement between you and
ALK of which this license is a part.

14. Obligations on Termination: Termination or expiration of this Agreement shall not be
construed to release you from any obligations that existed prior to the date of such
termination or expiration.

15. Hold Harmless and Indemnity: To the maximum extent permitted by applicable law,
you agree to hold harmless and indemnify ALK and its parent company, subsidiaries,
affiliates, officers, agents, licensors, owners, co-branders, other partners, and employees
from and against any third party claim (other than a third party claim for Intellectual
Property Rights) arising from or in any way related to your use of PC*MILER|Rail,
including any liability or expense arising from all claims, losses, damages (actual and/or
consequential), suits, judgments, litigation costs and attorneys' fees, of every kind and
nature. ALK shall use good faith efforts to provide you with written notice of such claim,
suit or action.

16. Intentionally omitted.

17. Limitations on Export: You hereby expressly agree not to export PC*MILER|Rail, in
whole or in part, or any data derived therefrom, in violation of any export or other laws or
regulations of the United States.

18. Agaregated Data: ALK may, from time to time, share information about You with
parent and sister or affiliated companies for business purposes and when necessary for it
to perform work under this Agreement. In addition, ALK may, and is hereby authorized
to, use, share and provide certain aggregated, non-identifiable information derived from
Your use of PC*MILER|Rail to third parties.

19. Intentionally omitted

20. Additional Use Terms, Conditions, Restrictions and Obligations: This agreement and
your use of PC*MILER|Rail is expressly subject to the ALK Privacy Policy and the ALK
End User License Agreement Terms and Conditions (“EULA”) set forth below. YOU
ACKNOWLEDGE AND AGREE THAT YOU MAY NOT USE PC*MILER|Rail IF
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YOU DO NOT ACCEPT THE TERMS AND CONDITIONS OF THE ALK EULA
AND THAT YOU HAVE REVIEWED AND ACCEPT THE TERMS AND
CONDITIONS OF THE ALK EULA BY INSTALLING OR ACTUALLY USING
PC*MILER|Rail.

21. Miscellaneous: This agreement shall be construed and applied in accordance with the
laws of the State of New Jersey. The Courts of the State of New Jersey shall be the
exclusive forum for all actions or interpretation pertaining to this agreement. Any
amendments or addenda to this agreement shall be in writing executed by all parties
hereto. This is the entire agreement between the parties and supersedes any prior or
contemporaneous agreements or understandings. Should any provision of this agreement
be found to be illegal or unenforceable, then only so much of this agreement as shall be
illegal or unenforceable shall be stricken and the balance of this agreement shall remain
in full force and effect.

22. Date: This EULA was last updated on November 16, 2016. Visit www.pcmiler.com
for regular updates.

END USER LICENSE AGREEMENT FOR ALK DATA

This license applies to ALK Data included in PC*MILER|Rail if any, as well as to ALK
data you obtain separately that is formatted for use with your Software.

The data (“Data”) is provided for your personal, internal use only and not for resale. It is
protected by copyright, and is subject to the following terms and conditions which are
agreed to by you, on the one hand, and ALK Technologies, Inc. (“ALK”) and its
licensors (including their licensors and suppliers) on the other hand.

© 2016 ALK. All rights reserved.

1. Personal Use Only: “You” means you as an End-user or as a “Company” on behalf of
its End-Users which are subject to either a Non-Disclosure Agreement as employees or a
License Agreement that contains the same restrictions as herein as a Value Added
Reseller. Also as used in this EULA “personal use” can also be understood in more
general terms as for a Company’s use. You agree to use this Data together with
PC*MILER|Rail for the solely personal, non-commercial purposes for which you were
licensed, and not for service bureau, time-sharing or other similar purposes. Accordingly,
but subject to the restrictions set forth in the following paragraphs, you may copy this
Data only as necessary for your personal use to (i) view it, and (ii) save it, provided that
you do not remove any copyright notices that appear and do not modify the Data in any
way. You agree not to otherwise reproduce copy, modify, decompile, disassemble or
reverse engineer any portion of this Data, and may not transfer or distribute it in any
form, for any purpose, except to the extent permitted by mandatory laws.

2. Restrictions: Except where you have been specifically licensed to do so by ALK in the
case of an integrated solution bundled or intended for use with specific smartphones,
similar mobile communication device(s) or personal navigation device(s), and without
limiting the preceding paragraph, you may not use this Data (a) with any products,
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systems, or applications installed or otherwise connected to or in communication with
vehicles, capable of vehicle navigation, positioning, dispatch, real time route guidance,
fleet management or similar applications; or (b) with or in communication with any
positioning devices or any mobile or wireless-connected electronic or computer devices,
including without limitation cellular phones, smartphones, palmtop and handheld
computers, pagers, and personal digital assistants or PDASs. You may not use this
License, any of the Licensed Product, or its reports, to create a competitive product,
solution or visualization platform.

3. Warning: The Data may contain inaccurate, untimely or incomplete information due to
the passage of time, changing circumstances, sources used and the nature of collecting
comprehensive geographic data, any of which may lead to incorrect results. The
Highway Data is based on official highway maps, the Code of Federal Regulations, and
information provided by state governments and other licensors. It is provided without a
warranty of any kind. The user assumes full responsibility for any delay, expense, loss or
damage that may occur as a result of use of the Data.

4. No Warranty: This Data is provided to you “as is,” and you agree to use it at your own
risk. ALK and its licensors (and their licensors and suppliers) make no guarantees,
representations or warranties of any kind, express or implied, arising by law or otherwise,
including but not limited to, content, quality, accuracy, completeness, effectiveness,
reliability, fitness for a particular purpose, usefulness, use or results to be obtained from
this Data, or that the Data or server will be uninterrupted or error-free.

5. Disclaimer of Warranty: ALK AND ITS LICENSORS (INCLUDING THEIR
LICENSORS AND SUPPLIERS) DISCLAIM ANY WARRANTIES, EXPRESS OR
IMPLIED, OF QUALITY, PERFORMANCE, MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT. Some States,
Territories and Countries do not allow certain warranty exclusions, so to that extent the
above exclusion may not apply to you.

6. Disclaimer of Liability: ALK AND ITS LICENSORS (INCLUDING THEIR
LICENSORS AND SUPPLIERS) SHALL NOT BE LIABLE TO YOU: IN
RESPECT OF ANY CLAIM, DEMAND OR ACTION, IRRESPECTIVE OF THE
NATURE OF THE CAUSE OF THE CLAIM, DEMAND OR ACTION
ALLEGING ANY LOSS, INJURY OR DAMAGES, DIRECT OR INDIRECT,
WHICH MAY RESULT FROM THE USE OR POSSESSION OF THE
INFORMATION; OR FOR ANY LOSS OF PROFIT, REVENUE, CONTRACTS
OR SAVINGS, OR ANY OTHER DIRECT, INDIRECT, INCIDENTAL, SPECIAL
OR CONSEQUENTIAL DAMAGES ARISING OUT OF YOUR USE OF OR
INABILITY TO USE THIS INFORMATION, ANY DEFECT IN THE
INFORMATION, OR THE BREACH OF THESE TERMS OR CONDITIONS,
WHETHER IN AN ACTION IN CONTRACT OR TORT OR BASED ON A
WARRANTY, EVEN IF ALK OR ITS LICENSORS HAVE BEEN ADVISED OF
THE POSSIBILITY OF SUCH DAMAGES. Some States, Territories and Countries
do not allow certain liability exclusions or damages limitations, so to that extent the
above may not apply to you.
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7. Export Control: You agree not to export from anywhere any part of the Data provided
to you or any direct product thereof except in compliance with and with all licenses and
approvals required under, applicable export laws, rules and regulations.

8. Entire Agreement: These terms and conditions constitute the entire agreement
between ALK (and its licensors, including their licensors and suppliers) and you
pertaining to the subject matter hereof, and supersedes in their entirety any and all written
or oral agreements previously existing between us with respect to such subject matter.

9. Governing Law: The above terms and conditions shall be governed by the laws of the
State of New Jersey. The courts of the State of New Jersey shall have exclusive
jurisdiction to settle any and all disputes, claims and actions arising from or in connection
with the Data provided to you hereunder. You agree to submit to such jurisdiction.

PC*MILER|Rail User’s Guide



Chapter

Welcome

Welcome to ALK's PC*MILER®|Rail! By purchasing PC*MILER|Rail, you have
invested in a high-quality, user-friendly software package for determining railroad
routes and mileage.

1.1 What Is PC*MILER|Rail?

PC*MILER|Rail is point-to-point rail routing and mileage software. Its powerful
North American rail network contains close to 200,000 miles of rail line, 49,165
active freight stations, 807 active rail carriers, and over 4,000 unique junction
interchanges. PC*MILER|Rail provides rail routes and mileage for rate
determination and negotiation, equipment management, rail car mileage auditing,
and carrier selection.

Through ALK’s close working relationship with all major railroads,
PC*MILER|Rail features the industry-leading electronic representation of current
North American railroad routes and mileage. For over 30 years, ALK’s railroad
database has proven to be an accurate source for determining the routes and mileage
used in processing the U.S. Surface Transportation Board’s Carload Waybill
Sample. It has also been used in numerous traffic diversion studies and in a variety
of costing applications. ALK’s railroad database is widely used by virtually all
major railroads and rail car lessors.

PC*MILER|Rail generates routes and determines mileage between any two rail-
served locations in North America. Each location can be identified by station name
and state abbreviation or by commonly used geographic codes.  With
PC*MILER|Rail you can quickly calculate the Shortest route (least distance)
and/or the Practical route (based on historical operations) between any two points.
You may specify interline junctions or let PC*MILER|Rail choose junctions by
weighing location versus gateway importance. A Fuel Surcharge routing option
is provided to accommodate the Surface Transportation Board ruling on mileage-
based fuel surcharge calculations. Routings for Intermodal, Coal/Bulk and multi-
level Auto Rack trains are also included.

PC*MILER|Rail can also be used in conjunction with ALK’s PC*MILER|Rail-
Connect to generate mileages from within Microsoft® Excel®, display “pin maps”
for integrated real time mapping, and provide seamless integration with other
Windows-based transportation and logistics software.  An optional batch
processing module, PC*MILER|Rail-BatchPro, enables quick processing and
summarizing of large volumes of car location messages (CLM’s), SPLC codes or
origin-destination pairs.
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1.2 Additional PC*MILER|Rail Solutions

PC*MILER|Rail can be used on its own as a standalone product, or in conjunction
with the following connectivity and batch processing applications:

PC*MILER|Rail-Connect seamlessly interfaces PC*MILER|Rail routes,
mileages and reports with transportation management software systems and third-
party software. Within other software applications, users can calculate
PC*MILER|Rail mileage for an origin/destination pair of locations with
intermediate stop-off points, display maps, run state-by-state mileage breakdowns
and generate detailed station reports. It also allows access to mileage information
from within Microsoft® Excel®.

PC*MILER|Rail-BatchPro enables users to quickly summarize empty, loaded,
and total mileages by equipment ID, railroad, or state and province for a large
number of rail movements. Large volumes of origin/destination locations can be
processed using a variety of geographic codes (identifiers) including station
name/state abbreviation, SPLC, FSAC, ERPC (3-3-3) and R260.

PC*MILER|Rail-TCP/IP provides an interface to PC*MILER|Rail-Connect trip
calculation functions on Windows personal computers from any other computer
platform over a TCP/IP network.

PC*MILER|Rail Stations Geocode Files include a complete list of all
PC*MILER|Rail freight stations by serving carrier and contains Station Name/ST,
SPLC, FSAC, 3-3-3, and R260 code information. There are two versions of this
file: one with latitude/longitude information and one without.

1.3 What's New in Version 23?

e NEW! 9-Digit SPLCs for Station Locations. PC*MILER|Rail software now
recognizes 9-digit SPLCs for stations. The output format of SPLCs will be in
9 digits, while the input format can be either 6 or 9 digits. Canadian SPLCs can
be entered with or without leading zeroes.

e NEW! Show/Hide Route and Frame Route Options in the Route Window.
Two options have been added to the Route Window to more easily frame a route
on the map and to show or hide the route on the map directly from the route
window, as shown below.

Show/Hide Route

Frame Route on Map

N\
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e ENHANCED!... Up-to-Date Rail Network Data Reflects the Latest
Changes in the Industry. The PC*MILER|Rail industry-standard rail network
database is updated annually to include the most current data available.
Throughout the year, ALK Technologies’ team of Geographic Information
System (GIS) specialists gathers new data and incorporates customer feedback.
Version 23 data updates include the following:

- Close to 200,000 total miles of rail line
- 49,165 active freight stations
- Over 4,000 unique junction interchanges

- 807 active rail carriers, including 18 new carriers and the removal of 13
carriers

New Railroads Added Since Version 22.0:

ART A & R TERMINAL RAILROAD

CERR CICERO CENTRAL RAILROAD, L.L.C.

CFs TRAINS TOURISTIQUES DE CHAUDIERE-APPALACHES INC. DBA
CHEMIN DE FE

CTXR CENTRAL TEXAS & COLORADO RIVER RAILWAY, LLC

FMR FORTY MILE RAILROAD, INC.

GSR GREAT SANDHILLS RAILWAY, LTD.

ISRY IOWA SOUTHERN RAILWAY COMPANY

KNWA KANAWHA RIVER RAILROAD L.L.C.

NCA NORTH CAROLINA & ATLANTIC RAILROAD

NLRL NORTHERN LIGHTS RAIL LTD.

0s ONTARIO SOUTHLAND RAILWAY INC
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OYLO
SCR
SIR
SSS
TBFR
WRI
WWR

OLYMPIA & BELMORE RAILROAD, INC.

SYDNEY COAL RAILWAY

SAN JACINTO TRANSPORTATION COMPANY, INCORPORATED
STEWART SOUTHERN RAILWAY INC

TRANSDISTRIBUTION BROOKFIELD RAILROAD LLC
WHEATLAND RAIL INC

WESTERN WASHINGTON RAILROAD, LLC

Railroads Deleted Since Version 22.0:

ANRG
BBAY
BS
FWRY
GCSR
IRRS
MKC
MRA
NJSL
OTR
QNSL
WCRR
WCTR

ALTEX ENERGY LTD

BOGALUSA BAYOU RAILROAD LLC

BIRMINGHAM SOUTHERN RR CO

FILLMORE WESTERN RAILWAY COMPANY

GULF COLORADO & SAN SABA RAILWAY
INTERNATIONAL RAIL ROAD SYSTEMS INC
MCKEESPORT CONNECTING RAILROAD COMPANY
MINERAL RANGE, INC.

NEW JERSEY SEASHORE LINES, INC.

OAKLAND TERMINAL RAILROAD COMPANY
QUEBEC NORTH SHORE AND LABRADOR RAILWAY COMPANY
WYOMING CONNECT RAILROAD LLC

WCTU RAILWAY COMPANY
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Chapter

Getting Started

PC*MILER|Rail is a standalone product. The underlying data that the application
uses is installed along with the product. The data is stored in binary format that
only the product can read. No other database application is required to run

PC*MILER|Rail.

2.1 System Requirements

Environment:

Platforms:

Requirements:

e Stand-alone PC with a 1.5-2 GHz processor or
networked personal computers (LANSs and Server/Thin
Client Networks)

e Windows® 7, 8 and 10* running in 32-bit compatibility
mode as well as support for 64-bit native applications —
please see section 2.4 if installing connectivity products
on a 64-bit machine
* IMPORTANT: All available Windows updates
should be installed; for Windows 7 and Windows
Server 2008 R2, Service Pack 1 (KB976932) should be
installed.

NOTE: Windows 95, 98, 2000, 2003, Vista and XP
will not be supported. We are strongly recommending
that you upgrade your operating system.

e Citrix Metaframe and Windows Terminal Services
e TCP/IP functionality for use with other platforms

e 700 MB hard disk space

¢ 512 MB of RAM minimum, 1 GB RAM recommended
for standard desktop users. For Citrix and Terminal
Server, 200 MB RAM for each user running
PC*MILER|Rail-Connect.

For PC*MILER|Rail-Connect:

¢ Additional 10 MB hard disk space

e Microsoft Excel

e A development system for the PC*MILER|Connect
interface. (Interface definitions for Borland C++ 4.0
and Visual Basic 3.0 are currently supported, although
many other systems can also utilize the DLL.)
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These additional components will also be installed:

e Microsoft Visual C++ 2005 Redistributable Package
(x86) - Disk space 6 MB

e WindowslInstaller-KB884016-v2-x86.exe (x86) — Disk
space 2 MB

o NET dotnetfx.exe (x86) — Disk space 280 MB

For PC*MILER|Rail-BatchPro:
e Additional 5 MB hard disk space

For PC*MILER|Rail-TCP/IP:

¢ Additional 5 MB hard disk space

e PC with 1.5-2 GHz processor and TCP/IP capability

e UNIX or other host with TCP/IP capability

e Physical connection (cable)

e Client software on the UNIX or other host (sample
PERL application provided)

Other e Minimum screen resolution 800x600
Requirements: e Color Quality Settings Supported: 16-bit and 32-bit
(8-bit not supported)
e Internet Connection for License Activation
(manual license activation also available)
e Email Address for License Activation

2.2 General Licensing Information

Single-User License
A single-user license can be installed to only one PC locally.

Additional Copy License

Users can install PC*MILER|Rail locally onto additional PC’s by purchasing
additional copy licenses. If you purchase five copy licenses, you can install
PC*MILER|Rail locally onto five additional PC’s or workstations. If you are
installing onto a desktop PC and a laptop, two licenses are needed.

Multi-User License

A multi-user license can be installed to a server environment, on the computer that
will be sharing the licenses to other computers. It allows “x” number of concurrent
workstation connections to PC*MILER|Rail at a time. For example, a 5-User
License allows PC*MILER|Rail to be installed on a central server or PC with as
many workstation PCs as you want to have access, but it only allows five users to
access PC*MILER|Rail at a time.
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Enterprise License

An Enterprise License allows you to install PC*MILER|Rail on any combination
of end-user PCs or workstations without limitations. It’s a cost-effective
installation and licensing solution for larger enterprises with several users. It does
not require license activation but requires signing an enterprise supplemental
license agreement directly with ALK.

2.3 Installation Types

Non-Network (Local) Installations

A non-network installation allows you to install PC*MILER|Rail to a PC or
workstation locally, not onto a server environment to be shared with other
computers.

Network Installation

A networked installation allows you to install PC*MILER|Rail on network file
servers where each end-user can save their own option settings or can share option
settings that are stored on the server.

Citrix/Terminal Services Installation

PC*MILER|Rail can be installed onto a Citrix Server or Terminal Services
environment, if you have purchased a license to do so. Each end-user must have a
license to gain access.

Trial Installation

A trial installation is a 15-day license to access PC*MILER|Rail features and data.
A trial installation cannot be upgraded, it must be uninstalled and reinstalled to add
another product or feature.

2.4 Important Installation Notes

IMPORTANT: All available Windows updates should be installed before
installing PC*MILER|Rail. For Windows 7 and Windows Server 2008 R2, installed
updates should include Service Pack 1 (KB976932).

Microsoft® Windows® 8 and Above

It is strongly recommended that you avoid installing to the Program Files or
Program Files (x86) folder. If you need to do so, you’ll have to Run as
Administrator when you open PC*MILER.

Microsoft Windows 7, 8 and 10 Users
Your license may need to be installed and activated using an Administrator
Account. Once installed, you do not need to “Run as an Administrator” provided
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you install to the recommended default directory or to another directory that doesn’t
require users to “Run as an Administrator”. Additionally, the administrator should
grant write permissions to the PC*MILER|Rail default directory since some of the
newer operating systems require an administrator to grant these write permissions.

COM DLL’s on a 64-Bit Computer

If you install PC*MILER|Rail-Connect Version 23 on a 64-bit computer, you are
given the option of using either the 32-bit versions or the 64-bit versions of the
COM dIlI’s. To switch between the versions, you can run “Modify” in the setup to
make the decision again or run “UseCom32.bat” to switch to 32-bits or
“UseCom64.bat” to switch to 64-bits. These .bat files are found in your
PCRWIN23/Connect/com folder.

Data Execution Prevention (DEP) Setting

On some versions of Windows, DEP might close PC*MILER|Rail without any type
of error message. If that happens, do the following: open the Windows Start menu
and go to Settings > Control Panel > System and Security > System > Advanced
System Settings > Advanced tab > Performance Setting > Data Execution
Prevention tab. Select “Turn on DEP for essential Windows programs and
services only”.

PC*MILER|Rail Interfaces

For those who are interfacing any PC*MILER|Rail component to a third-party
system, please contact the vendor directly to make sure that the interface to this
new version of PC*MILER|Rail is updated and complete before you install.

Website Support Center
Please check ALK’s Website Support Center for posted updates and patches. Go
to www.alk.com/support.

2.5 Single User (Non-Network) Installation

NOTE: Have your Product Key Code on hand before beginning the installation
process. It will be emailed to you from alkservices@alk.com in an email titled,
“PC*MILER|Rail 23 Software Order...” (Enterprise License customers excluded,
see note in Step 4 below). “Single” will be included in the list of product
components in this email, indicating that you purchased a single-user license. If
don’t see “Single” in the email, please contact a PC*MILER Sales Representative
to purchase the correct license.

UNINSTALLING AN OLDER VERSION: If you need to uninstall a previous
version of PC*MILER|Rail on the computer that you are now installing to, you
must uninstall the previous version before installing PC*MILER|Rail 23. If you do
not need to uninstall, it is possible to have both versions
of the desktop program installed on the same system. Please note that
PC*MILER|Rail-Connect will be updated to the new version.
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BEFORE INSTALLING, please double-check that the emailed Product Key
Code(s) lists all purchased components. For example, the code shown below
unlocks the following components: PC*MILER|Rail, PC*MILER|Rail-Connect,
and PC*MILER|Rail-BatchPro.

Order #: SO-000000001

Product Order #: PC*MILER|Rail 23

Date: 12/6/2016 10:33 AM

Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2
== PC*MILER|Rail 23 (Single), BatchPro, Connect

To install your single-user version of PC*MILER|Rail, follow these steps:

1. If you are downloading the installation, click the provided link in the email
that was sent to you from ALK Technologies and follow the instructions in
the email.

NOTE for Windows 10 Users: Windows 10 users installing from a network,
please see the note in section 2.4.

If you are installing using a DVD, place the PC*MILER|Rail Install DVD in
the DVD or CD/DVD drive and the installation will start automatically. If it
does not start automatically, click the Windows Start menu. Then, depending
on your operating system, either 1) type “d:\setup.exe” and click the search
button (if the DVD drive is not the D drive, substitute the letter that designates
the DVD drive); or 2) select Computer > [DVD drive letter] > setup.exe.

IMPORTANT NOTE for Windows Users: You will need to install
PC*MILER|Rail as an administrator. If you are not the designated
administrator on your computer, you will receive a warning message. Once
the application is installed, you won’t have to “Run as an Administrator” to
use it provided you install to the default directory or to another directory that
does not require the user to be an administrator.

To install as an administrator, cancel the installation if necessary (click
Cancel and then Finish) and then follow these steps:

1) Open Windows Explorer and navigate to the PC*MILER|Rail installation
folder that was downloaded or is on your CD/DVD drive;

2) Right-click on the setup.exe file in the installation folder and select “Run
as administrator”;

3) If the install doesn’t begin automatically, double-click on the setup.exe
file to start the installation process again.

2. Inthe InstallShield Wizard Welcome screen, click Next to review the terms
and conditions of the End-User License Agreement. To accept the terms of
the license agreement, select | accept then click Next.

3. Enter your User Name and Company Name then click Next.
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4. Enter your Product Key Code. This 25-character code will be emailed to you
from alkservices@alk.com in an email titled, “PC*MILER|Rail 23 Software
Order...” The code can be copied and pasted. If typing the Product Key
Code, dashes are not required — dashes, spaces, or no spaces are all
acceptable. Click Next when finished.

NOTE: As a convenience to our Enterprise License customers, your Product
Key Code is hard-coded into the installation for you and is valid for each
install.

5. Select Features: In the list of features to be installed, clear the checks next to
any component that you do not want to install or test. Click Next to continue.

6. Choose Destination Location: To install to the default folder (recommended),
do not make any changes and click Next.

To install to a location other than the default, click Browse to select another
folder. Be sure to add “Pcrwin23” to the end of the new path. For example:
C:\Apps\PCRWINZ23. If you don’t, PC*MILER|Rail will install to the root of
the specified directory. Click Next to continue.

7. Start Copying Files: To change any setting, select Back. If you are satisfied
with the settings, click Next to continue.

If you have a previous version of PC*MILER|Rail-Connect installed, an alert
will appear on the screen with the following message: “The install found a
previous version of Connect. These files will be renamed with a .bak
extension.” Click OK in the dialog to continue.

8. Follow through with the rest of the installation. This may take some time
depending on the speed of the computer you are installing to. Do not exit or
reboot the computer during the installation. If any error messages appear,
please contact Technical Support.

9. When the installation is complete, you will be prompted to view the
ReadMe.txt and to activate your license. If you need to use a Proxy Server
to access the Internet, skip to section 2.5.1, Activation Using a Proxy Server.
Otherwise, leave these boxes checked and click Finish to proceed to the
automatic activation (Step 10 below). (NOTE: It may take 5-15 seconds for
the Product Activation window to open.) When the ReadMe opens, review
the information in it and then close the window.

IMPORTANT: ALK provides a 15-day temporary license prior to
completing the activation process. If you make a second attempt to install on
the same computer, you will lose this 15-day temporary license. If you
experience an activation error and need access to PC*MILER|Rail before
Technical Support is available, please do not attempt a second install without
assistance.
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AUTOMATIC LICENSE ACTIVATION

10. The PC*MILER Product Activation window should be open. (If it is not
open, select Start menu > All Programs > PCMILER Rail 23 > License Status
to open the License Tool window, then click Activate.)

If you are an Enterprise License Customer: You can bypass the following
license activation steps of the install because you are already activated and
registered with ALK. To continue, close the Product Activation window then
proceed to Step 14 to open PC*MILER|Rail 23 and start using the application.

If you are not an Enterprise License Customer: If the computer you are
installing to has an Internet connection and you have a valid email address, the
license activation can be processed automatically. Enter your Email Address
then click Activate. “Manual Activation” should be left unchecked.

NOTE: Internet license activation is available 24 hours a day. If you don’t
have an active Internet connection or email address, please contact PC*MILER
Technical Support during business hours for assistance.

11. When the activation process is complete, you will receive a message in the
Product Activation window saying, “License Activation Complete!”. Close
the window to continue. If the activation failed, skip to Step 15 below for
manual activation.

12. To verify licensing, go to the Windows Start menu > All Programs >
License Status. Inthe PC*MILER License Tool window, verify that
“Licensed” appears under Status. If “Licensed” is NOT in the Status field,
skip to Step 15 below for manual activation.

13. If successful activation has been verified, close the License Tool window. An
email titled “PC*MILER|Rail 23 Activation Code for Product XXXXX...”
from alkservices@alk.com will be sent to the email you entered in Step 10.
You only need to keep this email for your records.

14. To start PC*MILER|Rail once the installation is complete, click the
PC*MILER|Rail 23 icon on the desktop, or click the Windows Start menu >
All Programs > PCMILER Rail 23 > PCMILER Rail 23.

MANUAL ACTIVATION

15. (You only need to follow these steps if the automatic license activation
process could not be completed.) If the automatic activation (Steps 10-11
above) fails for any reason, try manually activating. In the Product Activation
window, enter your Email Address then check “Manual Activation”.

16. Next, click the provided URL for the ALK activation site.
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17.

18.

19.

20.

21.

22,

23.

You will be taken to the ALK Technical Support “Activate Product” web
page, and your product key will automatically populate the Product Key
fields. Click Next to continue.

In the next screen, enter your Email address and click Finish.

An email titled “PC*MILER|Rail 23 Activation Code for Product XXXXX...”
from alkservices@alk.com will immediately be sent to the email you entered.

Copy the activation code directly from the Activation web page or from the
email sent to you, and paste it into the Activation Code field in the Product
Activation window.

Click Activate in the Product Activation window to complete the activation.

You will see the message “License Activation Complete!”. Close the Product
Activation window.

Start PC*MILER|Rail once the installation is complete: click the
PC*MILER|Rail 23 icon on the desktop, or click the Windows Start menu >
All Programs > PCMILER|Rail 23 > PCMILER|Rail 23.

2.5.1 Activation Using a Proxy Server

1.

When the installation is complete (Steps 1-9 in section 2.5 above), uncheck
the Activate check box and then click Finish.

Next, start PC*MILER|Rail: either click the PC*MILER|Rail icon on the
desktop, or click the Windows Start menu and then select All Programs >
PCMILER Rail 23 > PCMILER Rail 23.

Select the Help tab > Proxy Setup.
In the Proxy Setup dialog, check Use Proxy Server then enter a Host and Port.
If needed, check Proxy Authentication then enter a Username and Password.

Click OK to save your settings and close the dialog. PC*MILER|Rail is now
set up to use the indicated proxy server when connecting to the Internet.

Close PC*MILER|Rail.

Go to the Windows Start menu > All Programs > PCMILER Rail 23 >
License Status and click Activate in the PC*MILER License Tool window.

Follow the steps in section 2.5 for automatic activation, beginning at Step 10.

PC*MILER|Rail User’s Guide 12


mailto:alkservices@alk.com

2.6 Multi-User Network Installation

NOTE: PC*MILER|Rail 23 supports silent installations.

NOTE FOR INSTALLING TO A MAPPED DRIVE: For customers who install
to a mapped drive (this is rare), do not enter the location by its mapped name. For
example, if you mapped C:\Apps to F:\, just use C:\Apps as the install directory
when InstallShield asks you for the location. The Windows program that
PC*MILER|Rail 23 uses to automate folder sharing cannot share mapped drives by
using their mapped name (i.e. F:\ in the example above).

NOTE: Have your Product Key Code on hand before beginning the installation
process. It will be emailed to you from alkservices@alk.com in an email titled
“PC*MILER|Rail 23 Software Order...” (Enterprise License customers excluded,
see note in Step 4 below.) “(X-User)” will be included in the multi-user Product
Key email. If it is not included, please contact a PC*MILER Sales Representative
to purchase the correct license.

BEFORE INSTALLING,

please double-check that the emailed Product Key Code(s) lists all purchased
components. For example, the code shown below unlocks these components:
PC*MILER|Rail and PC*MILER|Rail-Connect.

Order #: SO-000000001

Product Order #: PC*MILER|Rail 23

Date: 12/6/2016 10:33 AM

Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2
== PC*MILER|Rail (XX-User), Connect

To install PC*MILER|Rail 23 on a network, follow these steps:

1. Begin by installing PC*MILER|Rail to the server: follow steps 1-9 for a
Single User (Non-Network) Installation (section 2.5 above).

2. When the installation is done, you will see a message that says a shared folder has
been created for the workstations on your network. The message will include the
name of the folder to install from on each workstation. Click OK.

3. You will be prompted to view the ReadMe.txt and to activate your license.
If you need to use a Proxy Server to access the Internet, see section 2.5.1,
Activation Using a Proxy Server. Otherwise, leave these boxes checked and
click Finish to continue. Review the ReadMe and then close the window.

IMPORTANT NOTE: ALK provides a 15-day temporary license prior to
completing the activation process. If you make a second attempt to install you
will lose this license. If you experience an activation error and need access to
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PC*MILER|Rail before Technical Support is available, please do not attempt a
second installation without assistance. You’ll be able to use the application for
15 days without completing the activation.

4. After you click Finish, the PC*MILER Product Activation window will open.

If you are an Enterprise License Customer: You can bypass the following
license activation steps of the install because you are already activated and
registered with ALK. To continue, close the Product Activation window.
PC*MILER|Rail is installed on the server and can be opened by double-
clicking the PC*MILER|Rail icon on the desktop, or click the Windows Start
menu and select All Programs > PCMILER Rail 23 > PCMILER Rail 23.

If you are not an Enterprise License Customer: If the computer you are
installing to has an Internet connection and you have a valid email address, the
license activation can be processed automatically. Enter your Email Address
then click Activate. “Manual Activation” should be left unchecked.

NOTE: Internet license activation is available 24 hours a day. If you don’t
have an active Internet connection or email address, please contact Technical
Support during business hours for assistance — see section 2.11.

5. If the activation is successful, you will see a “License Activation Complete”
message that directs you to open an email from ALK Technologies for further
instructions. If the activation was NOT successful, try activating manually
(Steps 15-23 in section 2.5) before calling Technical Support. To contact
Technical Support, see section 2.11.

6. After activation, open the email you received, then follow the instructions for
copying the “net.lic” file included with the email to the “App” folder in your
PC*MILER|Rail installation. Net.lic holds the license or user count for your
installation. Until you save this file to the designated folder, you will only have
a single-user installation.

The PC*MILER|Rail application is now accessible on the server (see Step 2 in
Installing on a Workstation below for access options).

INSTALLING ON A WORKSTATION

To install PC*MILER on each workstation, follow these steps:

1. On the workstation, click the Windows Start menu and enter the network path
to where the workstation setup program resides. This path should match the
network path sent to your email address as a result of running the server
installation. The only difference is that you will replace “App” with
“Network”. For example, if this path was sent via the email as "\\PRI-QA-
2K332-02\PCRWIN23\App\" for the network license file, you will run the
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workstation installation program from “\\PRI-QA-2K332-
02\PCRWIN23\Network\setup.exe” then press Enter.

If you have lost the email that included the network path, you can determine the
path as follows: navigate to the server’s “PCRWIN23” folder, right-click the
folder, and go to Properties > Sharing. The network path can be copied and
pasted from there.

Your workstation installation will be configured to share network settings
(each workstation is provided with the same default options and settings within
the application) and share data on your network (PC*MILER|Rail will use
the shared data that was installed on the server).

2. To start PC*MILER|Rail on a workstation once the installation is complete,
double-click the desktop PC*MILER|Rail icon, or click the Windows Start
menu and select All Programs > PCMILER Rail 23 > PCMILER Rail 23.

2.7 Citrix and Terminal Services Installations

NOTE: Have your Product Key Code on hand before beginning the installation
process. It will be emailed to you from alkservices@alk.com in an email with the
subject line “PC*MILER|Rail 23 Software Order...” (Enterprise License
customers excluded). “(Citrix/Terminal Services)” will be included in the Product
Key email confirming that you have purchased a Citrix or Terminal Services
license. If not, please contact an Enterprise Solutions account executive to purchase
the correct license and request one Product Key Code for each individual server
you are installing to.

UNINSTALLING AN OLDER VERSION: If you need to uninstall a previous
version of PC*MILER|Rail on the computer that you are now installing to, you
must do it before installing PC*MILE|Rail 23. If you do not need to uninstall, you
can have both versions of the desktop program installed on the same system. Please
note that PC*MILER|Rail-Connect and PC*MILER|Rail-BatchPro will be updated
to the new version.

BEFORE USING PC*MILER|Rail: Citrix supports 16 bit and 24 bit color, while
PC*MILER|Rail supports 16 bit and 32 bit color. A Citrix end user must set the
color resolution on their workstation to 16 bit before they log into a Citrix server to
run PC*MILER|Rail. If an end user has their color resolution set to 32 bit and logs
in to Citrix, the Citrix software will adjust it downward to 24 bit prior to loading
PC*MILER|Rail, and the application will fail to load.

BEFORE INSTALLING, please double-check that the emailed Product Key Code
lists all purchased components. For example, the code shown below unlocks the
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following components: PC*MILER|Rail, PC*MILER|Rail-Connect,
PC*MILER|Rail-BatchPro.

Order #: SO-000000001

Product Order #: PC*MILER|Rail 23

Date: 12/6//2016 10:33 AM

Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2

== PC*MILER|Rail 23 (Citrix/Term Serv), Connect, BatchPro

Only a qualified Citrix administrator should be installing PC*MILER|Rail on
a Citrix system. With Citrix in Install Mode, follow the steps in section 2.5, Single
User (Non-Network) Installation.

If you were using another version of PC*MILER|Rail with PC*MILER|Rail-
Connect and/or PC*MILER|Rail-BatchPro in your Citrix environment, there may
be existing files that require deletion. Citrix and Terminal Servers can have
multiple copies underneath C:\Users\<username>\Windows, C:\Documents and
Settings\  <username>\Windows or in  %homedir%\windows like
H:\Windows. Copies of the pcrsrv.ini and pcrsrvXX.ini (“XX” being a version
number) should be deleted from any location outside of C:\WINDOWS.

2.8 Proxy Server Setup

The following PC*MILER|Rail features require a connection to the Internet:

e License activation
e Software update and patch downloads via the Updater tool

For those who need to bypass current security settings to access the Internet while
activating and using PC*MILER|Rail, the steps to complete the proxy setup are
below. The setup can be implemented after PC*MILER|Rail has been activated or
before activation during the temporary grace period after installation.

1. Open PC*MILER|Rail and select the Help tab > Proxy Setup.
2. Inthe Proxy Setup dialog, check Use Proxy Server then enter a Host and Port.
3. If needed, check Proxy Authentication then enter a Username and Password.

4. Click OK to save your settings and close the dialog. PC*MILER|Rail is now set
up to use the indicated proxy server when connecting to the Internet.

2.9 Adding a New Product To Your PC*MILER|Rail Installation

You may find that you want to purchase an additional PC*MILER|Rail component
sometime after the initial installation of PC*MILER|Rail. To purchase and install
an additional product at a later time, follow these steps:

PC*MILER|Rail User’s Guide 16



First, call PC*MILER Sales at 800.377.6453 (or 1.609.683.0220 outside of the
U.S.), 9:00am-5:00 pm EST, Monday-Friday to purchase the product and obtain a
new Product Key Code to license and install the new solution(s).

Once you receive the new product key code, follow the instructions below for a
single user or multi-user workstation.

SINGLE USER AND MULTI-USER SERVER INSTALLATION

1.

10.
11.

12.

13.

Go to the Windows Start menu > All Programs > PCMILER Rail 23 >
License Status.

In the PC*MILER License Tool window, click Add License.

In the PC*MILER Product Activation window, enter the product key for the
purchased component(s) and click Add License.

When prompted, enter your Email Address.
Click Activate.

When the activation process is complete, you will see the message “License
Activation Complete!”. Close the Product Activation window.

Back in the License Tool window, make sure all new and existing
PC*MILER|Rail components are listed under Licensed Components, then
close the window.

To install newly added components, go to the Windows Start menu >
Control Panel > Programs and Features (or the equivalent on your system).

In the list of installed programs, right click “PC*MILER|Rail 23" and choose
Change.

In the InstallShield Wizard, choose Modify and click Next.

In the next screen, you will see the list of Licensed Features. All activated
features will be listed. Check that the component you are installing is
included in the list, then click Next to continue.

In the next screen you’ll see the Destination Folder for the installation. Click
Next to start copying files.

When the installation is complete, click Finish.

MULTI-USER INSTALLATION, FROM A WORKSTATION

1.

2
3.
4

Go to the workstation.

Browse to the shared ...\PCRWIN23\network folder on the server.
Run the setup.exe and choose Modify.

Follow through with the rest of the installation (steps 10-13 above).
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2.10 Deactivating and Uninstalling Your License

You must fully deactivate your product license and uninstall all PC*MILER|Rail
components, including local, network, enterprise, or server installations if you are:

Moving any PC*MILER|Rail installation to a new computer;
Reformatting a computer that PC*MILER|Rail is currently installed to;
Returning the product;

Reinstalling on the same PC.

DEACTIVATION:

1.

Go to Start > All Programs > PCMILER Rail 23 > License Status and in
the PC*MILER License Tool window click Deactivate.

In the PC*MILER Product Deactivation window, click Deactivate.

When the deactivation is complete, you will see a “Deactivation Complete”
message, with the deactivated product keys listed below.

Close the Product Deactivation and License Tool windows.

UNINSTALLING:

5.

To uninstall after deactivating, go to the Start menu > Settings > Control
Panel > Programs and Features (or the equivalent on your system).

Highlight PC*MILER Rail 23, right-mouse click and select Uninstall.
Click Yes at the prompt to completely remove the application.

Click Finish when the installation process is complete.

NOTE: If any messages appear during the uninstall process that say that a
certain file cannot be removed, click OK to continue.

ITIMPORTANT STEP ! Once the uninstall process is finished, you will
need to delete the ... ALK Technologies\PCRWIN23 installation folder
manually to completely remove the application from your system. The default
location for this folder is C:\ALK Technologies\PCRWIN23.

NOTE: If you deactivated/uninstalled an installation that included
PC*MILER|Rail components that were licensed and added after the initial
installation, you will need to add those components separately again when you
reinstall.
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2.11 Technical Support Options

ALK Technologies offers technical support to users of PC*MILER|Rail and its
related products. If you have any questions about PC*MILER|Rail or problems
with the software that can’t be resolved using the product user’s guides or online
Help, contact ALK Technologies.

Hours: 8:00am - 5:00pm, Mon-Fri, Eastern Standard Time
Phone: 1.800.377.6453, ext. 2 or 1.609.683.0220, ext. 2
Email: pcmsupport@alk.com or from within the PC*MILER|Rail user

interface select the Help tab > Email Technical Support and
follow the instructions provided. If you have any supporting
material, click Attach File and browse for the file(s) to attach.
Attachments of supporting documentation can be up to 10 MB.
When ready, click Send. ALK's technical support team will send
a confirmation email to the email entered in the "Enter your
email here" field when it is received.

Please include your Product Key Code and product version
number (e.g. 23.0.1) in all correspondence. To find this
information, go to the Help tab > About.

Fax: 1.609.252.8108 ATTN: PC*MILER|Rail Technical Support
Web Site: www.pcmiler.com (click Support > PC*MILER|Rail)

2.12 User Guides and Online Help

NOTE: You must have Adobe Acrobat Reader on your computer to properly view
the PDF user guides for PC*MILER|Rail products. (Using another PDF reader may
cause faulty pagination or other problems.) If you do not have this program
installed already, a free copy can be downloaded from www.adobe.com.

To make Adobe Reader your default reader, from within the Adobe Reader
application select the Edit menu > Preferences > General and click Select Default
PDF Handler. Select Adobe Reader from the drop-down, and click Apply then
OK to close the Preferences dialog.

The PC*MILER|Rail User’s Guide can be accessed from within PC*MILER|Rail
by selecting the Help tab > Help Index, by pressing the <F1> key while in the main
application window, or by clicking a Help button in any dialog. @

Additionally, you can click the Windows Start button > All Programs (or the
equivalent on your system) > PCMILER Rail 23 > PC*MILER|Rail User’s Guide.
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To search for a keyword or phrase in a user guide, use Adobe Reader’s Find option
in the Edit menu or on the toolbar.

All user guides can also be accessed at www.pcmiler.com/support. If accessing a
user guide from the Support pages, you’ll need to download the PDF to your hard
drive to be able to search for keywords.

2.13 Feature Reference Guide

Beginning with Version 22, the PC*MILER|Rail user interface has been updated
with a new look and feel while retaining the same functionality as in previous
versions.

For users of Version 21 and previous versions of PC*MILER|Rail who are
updating, a reference table in PDF format is provided so you can quickly look up
the new way to access features and options that you are already familiar with.

To access the Feature Reference Guide, click the Windows Start menu and select
All Programs (or the equivalent option for your version of Windows) > PCMILER
Rail 23 > User Guides > Feature Reference Guide.

PDF documents can be searched for keywords — select the Edit menu > Find. The
drop-down menu off the Find box can be used to refine your search.

2.14 Email Us Your Data Corrections

If you encounter any problems related to data errors, from within PC*MILER|Rail
please go to the Help tab > Email Data Correction and follow the on-screen
guidelines to submit the issue.

To attach supporting documentation to the email form, click the Attach File button
and browse for the file. Attachments can be up to 10 MB. After filling out the form,
click Send to send it. ALK will make every effort to correctly analyze and
incorporate your data suggestions.

You can also print a copy of the route, highlighting the problem, and send it to:

ALK TECHNOLOGIES, INC. - PC*MILER Products Division
1 Independence Way - Suite 400 - Princeton, NJ 08540 - USA
Email: pcmsupport@alk.com

2.15 Check for Updates

Select the Help tab > Check for Updates to check via the internet for any available
patches or quarterly data updates to PC*MILER|Rail. If no updates are available,
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a message to that effect will be displayed. If there are updates, a list will be returned
and you will have the option to download them.

2.15.1 Using the Updater Tool

Provided you have an internet connection, follow the steps below to install the
available updates:

1. Close all open instances of PC*MILER|Rail and its connectivity products. If
a third-party program that accesses any PC*MILER|Rail component is
running (for example, PC*MILER|Rail-Connect), close it before updating.

2. Open PC*MILER|Rail and select the Help tab > Check for Updates. The

PC*MILER Updater dialog will open. The Updater checks for valid license
information and then begins checking for available updates.

€ Check for Updates

® PCMILER e

Available Updates

Checking for updates...

Installed Updates

No Updates Installed

PC*MILER Updater

3. When the search for updates is complete you will see all available updates
listed. Inthe Download & Install drop-down menu next to each available
update, select either Download & Install to download and install right away
or Download to download now and install at a later time. Note the version
number of the updates you will be installing so you can check if the update
installed properly (see Step 6 below).
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Available Updates

[ PormiLeR Rail 2210 Software update
More Infra

tion

Installed Updates

No Updates Installed

(7] Close

Download and Install Options

4. The download process will begin and the progress of the download will be
reflected in a progress bar. If any PC*MILER|Rail-related application is
open, you will be prompted to close it. After closing the application(s), click
OK to continue with the download.

Available Updates

m PC*MILER Rail 22.1.0 Software update loading... (€Y

More Information

5. If you chose Download and Install, the InstallShield Wizard will open when
the download is finished. Follow the instructions to complete the installation.
After installing, you will see the update listed under “Installed Updates” in the
Updater window.

If you chose Download, when the download is finished the button to the
right will now say “Install”. You can complete the installation at any time in
the future by opening the Updater window and clicking Install.

IMPORTANT: You must close the Updater after processing is finished. The
next time you open the Updater, the files you downloaded will be shown in the
“Downloaded Updates” section of the dialog.

6. As a last step, check to make sure the update installed properly. Select the
Help tab > About and look for the Software Version number under “This
Product is Licensed To”. It should match what you downloaded.
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a About PC*MILER 23.0.16.0

SPCMILER>S

This Product is Licensed to:
User
Company
AAS3V-PITK2-B2524-334)2-C5572
Software Version: 23.0.16.0
Data Version: 23.0.0.1

\

Sales Department

Sales Support: 1.800.377.6453
Web Site: www.alk.com
Email: sales@alk.com

Technical Support

Hours: 2:00AM - 5:00PM EST, Mon - Fn
Tech Support: 1.800.377.6453 (ext. 2)

Web Site: www.pcmiler.com/support
Email: pcmsupport@alk.com

PC*MILER is a registered trademark of ALK
Technologies, Inc.

This computer software is protected by U.5.
and International copyright laws.
Unauthorized reproduction or distribution of
this program or any portion of it may result in
severe civil and criminal penalties and will be
prosecuted to the maximum extent possible
under these laws,

Copyright © 2016
ALK Technolegies, Inc. - All Rights Reserved

PC*MILER|Rail “About” Window
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Chapter

Overview & Shortcut Keys

3.1 Overview

When you first open PC*MILER|Rail, you’ll see route windows on the left, the map
window on the right, and a Ribbon toolbar at the top. The Ribbon contains layered
toolbars organized in tabs like a set of file folders. Click a tab to see the toolbar attached
to it. Users of recent versions of Microsoft Office will already be familiar with the

Ribbon format.

1. File Application
Menu

3. Routes Window

L

.

4. AutoRouter
Window Tab \72 The Ribbon
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PC*MILER|Rail 23 User Interface — Initial View

1 - File Application Menu. Click the red File drop-down to open the PC*MILER
application menu. This menu can be used to print and save maps and reports,
close all open routes or reports, and to exit the application window.

2 - The Ribbon, with the Routes tab selected. Click a tab on the Ribbon to bring
its toolbar forward. The Routes toolbar provides tools for entering and editing
stops on a route, setting route options, and generating routes and reports. There
are five tabs on the Ribbon: Routes, AutoRouter, Map, Window, and Help.
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3 - Routes Window. Select the Routes tab to access single route entry. Click New
Route on the Ribbon or <Ctrl+N> to open a new route window. Multiple single
route windows can be open at the same time. If there are more routes open than
can be displayed, a scroll bar will appear on the right edge of the Routes
window that allows access to the hidden routes. Tools and options for route
entry are in the Routes toolbar on the Ribbon.

4 - AutoRouter Window. Select the AutoRouter tab or <F6> to open the
AutoRouter window. The AutoRouter generates a scrollable list of all possible
routes between the station locations that are entered. Use the AutoRouter
toolbar on the Ribbon to set avoid/favors and route options.

5 - Map Window. Routes are drawn automatically in the map window as they are
generated. Use the Map toolbar to access a variety of map tools, or right click
on the map and select from the menu.

3.2 Shortcut Keys

Keystrokes that provide shortcuts to menu options and features are listed below.

Key(s) Function

CtrI-N Open a new single route window.

F1 Open the PC*MILER|Rail User’s Guide from the main window.
Alt-F2 Invoke the Avoid/Favor Junctions dialog.

F3 Display a scrollable list of state abbreviations.

Alt-F3 Display a list of railroad names and abbreviations sorted by SCAC.
Ctl-F3 Display a list of railroad names and abbreviations sorted by name.
F4 Invoke the Options dialog for the active route.

Alt-F4 Exit PC*MILER|Rail.

Ctrl-F4 Close the active single route entry window.

F5 Display the Detailed Report for the active route.

Alt-F5 Display the Key Station Report for the active route.
Ctrl-F5 Display the Detailed Geocode Report for the active route.

F6 Activate the AutoRouter window.

F7 Insert a stop above the highlighted stop (single route entry).

F8 Delete the highlighted stop (single route entry).

Alt-F8 Delete all stops in the single route entry window.

F9 Open the map window in its default position if it is closed.

F10 Generate routes and distances ("Run") in a single route window.
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3.3 Window Position Options

There are several screen layout options to choose from in the PC*MILER|Rail
application window.

The Map and Reports windows can be floated, docked, or hidden — click the
Window Position drop-down in the upper right corner of the map or right click the

map window title bar or a report tab to select an option. -
oat [

Dock
Hide

In the Window toolbar, the Routes Window, AutoRoute Window, and Map Window
buttons toggle windows on/off — click a button to hide the window, and click again
to display it. Use the Report Location drop-down to choose a layout position for
the Reports window — Top, Bottom, Left, Right, or Float.

Routes |AutoRoute | Map Report
Window | Window | Window | Location =

Click the Layouts drop-down to choose from four screen layouts in the application
window:

Layouts

L4

Routes on the Right, Bottom Reports Routes and Reports, Hidden Map
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Chapter

Using PC*MILER|Rail

This chapter describes how PC*MILER|Rail determines routes and mileage,
explains how railroad families are used in PC*MILER|Rail, and provides detailed
descriptions of location entry, routing options, and how to save and load generated
routes.

4.1 About Railroad Routes

A railroad route is identified by the following components: an origin, an optional
sequence of intermediate points, a destination, and the railroads that connect them.
There are two types of routes: single line and inter-line.

Single line routes include an origin location, a destination location, and a single rail
carrier serving them both. Inter-line routes occur when different railroads serve the
origin and destination points, or another railroad must be used to "bridge" the origin
and destination carrier(s). Inter-line routes require the entry of one or more railroad-
to-railroad junction locations.

Between any two rail points in North America, there are a large number of possible
routes (traffic between Atlanta and Dallas could go via New Orleans, Memphis, or
conceivably even via Chicago). Realistically, there are a limited number of feasible
or practical routings based on which railroads serve the points, their operations, and
the junctions at which they interchange cars.

When the same railroad serves both the origin and destination, a single line route is
usually most practical. While in some cases inter-line routes may be valid
alternatives to competing single-line routes, they require coordinated effort between
multiple railroads to interchange traffic and share the responsibility/revenue of the
shipment. In other cases, no single-line route exists and one or more inter-line routes
are the only way to get between the origin and destination.

In the U.S. and Canada, there are about 7,500 route-miles where railroads operate
primarily in one direction over a rail line, with traffic in the opposite direction
moving over an alternate route. These directional routes are reflected in
PC*MILER|Rail’s routing and mapping. As an example, in the screenshot below,
southbound UP traffic from Chicago to Houston moves via Shreveport, LA,
whereas the northbound traffic moves via Little Rock, AR.
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Example of Directional Routing Between Chicago and Houston

4.2 PC*MILER]|Rail Route Calculation

PC*MILER|Rail uses a minimum impedance routing program for computing
routes. The link impedance used in route calculations is derived as distance
multiplied by a cost factor, which essentially corresponds to route quality. High
density mainlines are given a lower link cost, while medium density mainline,
medium density branchline, and low density branchline have higher cost factors.
The minimum impedance route between any two nodes (geographic locations) on
ALK’s Rail Network is the sequence of links whose impedance sum is less than
that of any other sequence of links.

PC*MILER|Rail routes can be run in Single Route entry mode (the user specifies
railroads and junctions manually) or using the AutoRouter to calculate all possible
routes between locations. For interline routes calculated from the AutoRouter,
junction interchange impedances are added to link impedances. The junction
impedance for the forwarding and receiving railroads is based on the historic
volume of traffic interchanged at that junction to/from those railroads.

Link costs and junction costs may be different for each of the PC*MILER|Rail
routing types. Additionally, the link costs are adjusted to accommodate any
directional routing arrangements.

All the various cost factors have been derived from extensive research using
railroad timetables, maps provided by railroads, the Official Railway Guide,
Official Railroad Station List, Railroad Atlas, and county maps. ALK has
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periodically updated these costs over the years to maintain a good match with
current realistic routes.

PC*MILER|Rail includes six different routing formulas: Practical, Shortest,
Intermodal, Coal/Bulk, Auto Rack, and Fuel Surcharge. See section 4.10, Route
Options, for a description of routing formulas and other options.

4.3 How To Enter Railroad Locations for a Route

To generate a route in PC*MILER|Rail, at least two locations must be entered as
stops. There are two ways to calculate a route:

e Single Route Entry: If you know a route and just want to get the mileage,
you can enter a sequence of locations and railroads manually in a single
route entry window — select the Routes tab > New Route or <Ctrl+N> on
your keyboard, then enter at least two stops and click Run. During stop
entry, a Junction Helper becomes available when a junction between two
locations is needed. (See section 4.4 for more on single route entry.)

e Using the AutoRouter: If you want PC*MILER|Rail to suggest possible
junctions and connecting railroads between two points, you can use the
AutoRouter — select the AutoRouter tab on the Ribbon, or <F6> on your
keyboard, then enter at least two stops and click Run. (See section 4.5 for
more on using the AutoRouter.)

In either a single route window or the AutoRouter window, stops can be entered
using any of the formats listed below and described in sections 4.3.1 — 4.3.5. For
either type of route entry, the correct format must be selected in the route window
using the format drop-down:

+ |spLC v

FSAC
Station Name, ST
3-3-3
R260

« Standard Point Location Code (SPLC)

e Freight Station Accounting Code (FSAC)

o Location Name and State/Province/Estado Abbreviation (Station ST)
o Eastern Railroad President's Conference Codes (3-3-3)

e Rule 260 Junction Codes (R260)

If a station is served by more than one railroad, a pick list of railroads will be
generated. For a complete list of railroad SCAC’s, select the Help tab > Quick Help
or see Appendix D and E at the end of this User’s Guide.
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503

LOMGWORTH, MN 503013000 62184 LONGWORT CN
WARROAD, MM 503017000 62180 WARROAD CN
WARROAD, MM 503017000 00872 WARROAD CPRS
SWIFT, MN 503043000 62174 SWIFT CM
ROOSEVELT, MM 503047000 62168 ROOSEVELT CM
SALOL, MM 503053000 00873 SALOL CPRS
ROSEAU, MM 503080000 55204 ROSEAL BMSF
ROSEAU, MM 503080000 00874 ROSEAL CPRS
ROSEAU, MM 503080000 55204 ROSEAL MMM
BADGER, MM 503067000 55281 BADGER BMSF
BADGER, MM 503067000 00875 BADGER CPRS
BADGER, MM 503067000 55281 BADGER MKN
GREEMBUSH, MN 303092000 55271 GREENBUSE BNSF
GREEMBUSH, MN 503092000 00876 GREENBUSE CFRS

oK Cancel

Pick List of Railroads Serving Chicago, IL (partial list with scroll bar)

4.3.1 Station Name and State Abbreviation

Select Station Name, ST in the format drop-down, then type a station name and state
abbreviation in the Station Name, ST and click Add Stop or press <Enter>. Station
names, as listed in the Centralized Station Master (CSM), can be entered with
either a comma or a space between the station name and state abbreviation; for
example, “newark, nj”, “newark,nj” or “newark nj”.

If you are typing in the full station name, it must be entered exactly as it appears in
the PC*MILER|Rail database (and as listed in the Centralized Station Master),
otherwise an error message will be generated.

When entering a station name, you can use up to 20 characters, and 2 characters for
the state abbreviation. To see a table of official state/province/estado names and
abbreviations, select the Help tab > Quick Help or press <F3>.

If a station name contains two or more words, they must be separated by spaces;
for example, “new <space>york, ny”.

Some examples of valid station name entries are:

TEXARKANA, TX
ST LOUIS, MO
SALT LAKE CIT UT
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Common abbreviations occurring in station names are:

NORTH N BRIDGE BR MOUNTAIN MT
SOUTH S FORT FT PARK PK
EAST E JUNCTION JCT  POINT PT
WEST W  MINE MIN  SAINT ST

For spelling help, enter at least the first letter of the station, followed by an asterisk
(e.g. “b* id” or “MO*PQ”) and the state/province/estado abbreviation. In the
pick list of possible matches, highlight the correct location name and click OK or
double-click.

Routes X | AutoRouter X

Route 1

Practical -

+! | Station Name, ST = |texarkar'|a t)J |

Add Stop

Station Name Entry

ba* id

BANCROFT UP
BANEKS, ID 838138000  0OOVO BAMKS INPR
BAMEKS, ID 838138000 05249 BAMEKS uUp
BANMOCE, ID 836318000 04072 BAMMOCK UP
BARRYMORE, ID 837677000 00305 BARRYMOR! EIRR
BEARRYMORE, ID 837677000 04985 BARRYMOR! UP
BASSETT, ID 832797000 04374 BASSETT Up

oK Cancel

Pick List of Matches for Search On “ba* id”’

4.3.2 Standard Point Location Codes (SPLC)

Select SPLC from the format drop-down, then enter any valid 6- or 9-digit Standard
Point Location Code and click Add Stop or press <Enter>.

If you’re unsure of the SPLC or receive an error message, enter at least the first
three digits of the code immediately followed by an asterisk to invoke a pick list of
matches. For example, you could enter “503*”. In the pick list of possible matches,
highlight the correct location name and click OK or double-click your choice.
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503~

LOMGWORTH, MN - 503013000 62184 LOMGWORT CN
WARROAD, MN 503017000 2180 WARROAD CN
WARROAD, MN 503017000 00872 WARROAD CPRS
SWIFT, MM 503043000 62174 SWIFT CN
ROOSEVELT, MN 503047000 62168 ROOSEVELT CN
SALOL, MN 503053000 00873 SALOL CPRS
ROSEAU, MM 503060000 55204 ROSEAU BMNSF
ROSEAU, MN 503060000 00874 ROSEAU CPRS
ROSEAU, MN 503060000 55204 ROSEAU MMNN
BADGER, MN 503067000 55281 BADGER BMNSF
BADGER, MN 503067000 00875 BADGER CPRS
BADGER, MN 503067000 55281 BADGER MMNN
GREENBUSH, MM 503092000 55271 GREENBUSE BNSF
GREEMBUSH, MM 503092000 00878 GREENBUSE CPRS

oK Cancel

Pick List of Matches for Search on “503*”

4.3.3 Freight Station Accounting Codes (FSAC)

Select FSAC from the format drop-down, then enter any valid 5-digit Freight
Station Accounting Code and click Add Stop or press <Enter>. FSACs are unique
to a given railroad: the same 5-digit FSAC may refer to a completely different
location on another railroad.

If you’re unsure of a particular FSAC or if you receive an error message, enter at
least the first three digits of the code immediately followed by an asterisk to invoke
a pick list of matches. For example, you could enter “103*”. Highlight the correct
station in the pick list and click OK, or double-click the location to select it.

103~
TURMAGAIN, AK 810123000 00103 TURMAGAIN ARR
COLUMBUS CAMP ( 353103000 00103 COMPC COLCAMCH CAMY
ROCK ISLAND JCT, | 567727000 00103 ROCISLICT CMR
ALRED, AL 477262000 00103 ALRED COEH
HOMEWOOD, AR 600438000 00103 HOMEWOO LRWN
FOREST CITY, NC 418766000 00103 FORCITY TERY
HILLSDALE, WA 846137000 00103 HILLSDALE  TRMW
CHICAMUP, IL 380033000 00103 CHICANUP UP
KASSON, MM 507543000 01030 KASSON CPRS
FLAMDERS, NJ 192283000 01030 FLAMDERS ME
MYRTLE, WA 261509000 01030 MYRTLE NS
SOUTH GLOUSTER, 353410000 01030 SGLOUSTER OSRR
HADLEY, NY 171712000 01030 HADLEY SHC
LAHOGUE, IL 387157000 01030 LAHOGUE  TPW
0K Cancel

Pick List of Matches for FSAC Search on “103*”
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4.3.4 Eastern Railroad President’s Conference Codes (3-3-3)

Select 3-3-3 from the format drop-down, then enter any valid Eastern Railroad

President's Conference Code and click Add Stop or press <Enter>.

An ERPC (or 3-3-3) is similar to a station/state spelling, except that 3-3-3 codes
are limited to nine characters and abbreviated in accordance with the specific rules

of Railinc and the National Industrial Transportation League (NITL).

These

requirements are published in the Rail User's Manual by the NITL (1700 N. Moore

St., Arlington VA).

For help with 3-3-3 code entry, enter at least two letters followed immediately by
an asterisk and the state/province/estado abbreviation to invoke a pick list.
Highlight the correct station in the pick list and click OK, or double-click the

location to select it.

For station names of nine or fewer characters, the normal spelling is used in 3-3-3
codes. For longer station names or multiple-word names, abbreviations for
common words as well as a 3-3-3 spelling convention are used. In all cases, the
two-letter state/province/estado abbreviation is required, with or without a space

before it. For example:

SANTAFE NM...becomes...SANFE NM
FORT WAYNE IN...becomes... FTWAYNE IN
SALT LAKE CITUT ... becomes...SALLAKCITUT

=a* tx

SABINAL, TX 692762000 58612 SABINAL up
SACHSE, TX 667211000 09206 SACHSE KCS
SADLER, TX 663155000 54302 SADLER up
SAGINAW, TX 668141000 40345 SAGINAW  BNSF
SAGINAW, TX 668141000 09394 SAGINAW  KICS
SAGINAW, TX 668141000 54830 SAGINAW  UP
SAIT, TX 687514000 53007 SAIT Up
SALT MINE SPUR, T. 684732000 58708 SALMINSPU UP
SALMON, TX 666858000 52912 SALMON Up
SALTER, TX 682456000 53188 SALTER Up
SAM FORDYCE, TX 689983000 00070 SAMFORDYY BOP
SAM FORDYCE, TX 689983000 52808 SAMFORDY: UP
SAN ANGELO, TX 691450000 91121 SANANGELC BNSF
SAN ANGELO, TX 691450000 12358 SANANGELC FXE

OK Cancel

Pick List of Matches for 3-3-3 Code Search on ““sa* tx”’
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4.3.5 Rule 260 (R260) Junction Codes

Select R260 from the format drop-down, then enter any valid R260 code and click
Add Stop or press <Enter>. For help finding a Rule 260 code, enter at least one
letter followed by an asterisk (*).

Rule 260 codes represent officially designated locations where two or more
railroads interchange traffic with each other. They are abbreviated by unique 5-
character alpha codes designated by Railinc. Examples of Rule 260 entries are:

KANCY KCITY STRTR CHI*
B* BUFF BUTLR

bal*

BALTIMORE BAY VIE 234004000 70939 BALBV BALBAYVIE NS
BALTIMORE BAY VIE 234004000 000771 BALBY BALBAYVIE PEBR
BALTIMORE BAY VIE 234004000 91102 BALBV  BALBAYVIE AMTK
BALDWIN, TX 665323000 09042 BALDN BALDWIN  KCS
BALDWIN, FL 491385000 14765 BALFL  BALDWIN  CSXT
BALLARD JCT, WA 845234000 02190 BALIC  BALICT BOTL
BALLARD JCT, WA 845234000 02790 BALIC  BALICT BNSF
BALLINGER, TX 691170000 35124 BALLI  BALLINGER UP
BALLAST PIT, PQ 020863000 16653 BALPT  BALPIT CN
BALLARD, IL 387404000 57126 BALRD BALLARD UP
BALATOMN, MM 500392000 01138 BALTN BALATON  CPRS
BALTIMORE, MD 234000000 70121 BALTO BALTIMORE CSXT
BALTIMORE, MD 234000000 00005 BALTO BALTIMORE CTN

CK Cancel

Matches for R260 Code Search on ““bal*”

4.4 Generating a Single Route

If you already know the route you want and just need to get the mileage, you’ll
probably want to enter a sequence of locations and railroads manually in a single
route entry window. Multiple single routes can be open at one time — routes can be
browsed using the scroll bar that appears on the right side of the Routes window as
needed.

For single route entry, select the Routes tab > New Route or <Ctrl+N> on the
keyboard to open a new route window. The single route sequence is made up of an
origin location and railroad, a destination location and railroad, and (optionally)
intermediate locations or junctions that define the route for consideration. For each
stop except the origin, PC*MILER|Rail will automatically designate the inbound
railroad at each location as the outbound railroad from the preceding location.
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In a new route window, follow these steps for single route entry:

1. Select a format from the drop-down menu in the route window:

FSAC k
Station Name, 5T
3-3,-3
2. To enter an origin, first type a station name or code using the et
selected format:
+ s +| | 191500 |
ad Stop

3. Enter a SCAC in the Railroad field then click Add Stop or press <Enter>;
or click Add Stop or press <Enter> to invoke a pick list of railroads that
serve this station, then select a railroad from the list:

191600
| CS}('I'I Add Stop
or
191600
NEWARK, NI 191600 JO185 MEARK NEWARK CEXT
MNEWARK, MJ 191600 75223 MEARK MEWARK NS
MEWARK C580, M 191600 75253 MEARK MEWCSAD NS
MEWARK, MJ 191600 91055 MNEARK MEWARK AMTE
0K Cancel

4. Repeat steps 1-4 to enter a destination and, optionally, intermediate stops.

5. Click Run or press <F10> to generate a route and mileage. |F:=1TE 3
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Routes X | AutoRouter X
Route 1
Practical -
@ MEWAREK, M) 191600000 30185 MEARK  CSXT
INDIAMAPOLIS, IN 368700000 75128  INDAP  CSXT 918.1
CHICAGO, IL 380000000 40599  CHGO  C3XT 2429
@ LOUISVILLE, KY 286550000 41000 LOUWL CSXT 3761
1,537.1
+| | Station Name, ST | |

Single Route Mileage Generated — Newark to Louisville

4.4.1 Using the Junction Helper

To run a single route, you must specify each location where a change of railroads
(or railroad families) occurs. In the example shown below, a warning is generated
because Norfolk Southern does not get to Tacoma, WA:

Routes X | AutoRouter X

Route 1

Practical -

ation Mame, state 2L FaAL el L 5

@ ATLAMNTA, GA 456200000 56396  ATLA NS

A junction is required. Please use the Junction Helper

or AutoRouter.

@ TACOMA, WA 846200000 00072  TACOM UP

+ | Station Name, ST ~ || |

“Junction is Required” Warning
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In this case, you would click the Junction Helper link in the warning to get a list of
valid railroad junctions between Norfolk Southern and a railroad that serves
Tacoma, or click the AutoRouter link to use the AutoRouter (see section 4.5).

Junction Helper nl
RR1 R260 Station Name, ST RR2
NS DMOCIN  DES MOINES, 1A up
NS ALTON ALTON, IL up
NS BTOMN BLOOMINGTON, IL up
NS BRICT BRIDGE JUNCTION, IL up
NS CALMT  CALUMET, IL up
NS CHGO CHICAGO, IL up
NS ASHAA  CHICAGO ASHLAND AVE, IL up
NS CHGWD CHICAGO WOOD STREET,IL  UP
NS DANVL  DANVILLE, IL up
NS DOLTN DOLTON, IL up
NS ESTL EAST ST LOUIS, IL up
NS FEDER FEDERAL, IL up
NS GLOBL GLOBAL 2, IL up
hIC =71 Y] nt IBPORIDALE 1) (M 2]
oK Cancel

Junction Helper

4.5 Using the AutoRouter

To generate a list of valid railroad junction sequences between any two points in
North America, follow the steps below to use the AutoRouter.

File Routes AutoRouter Map Window Help

Generate multiple routes for an erigin and desti

Junction interchange.

Routes X  AutoRouter X

Route Options:

Route Preference:

Practical A

+]
\a]
@ BALTIMORE, MD CSXT, CTM, NS M
MILWAUKEE
+| Enter Location As: DJ
Station Name, 5T - || | \CH AGO :

The AutoRouter Window and Toolbar
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1. Select the AutoRouter tab on the Ribbon.

2. To enter an origin, select a format from the drop-down menu: +

FSAC k
Station Mame, 5T
3-3-3
R260
3. Type a station name or code using the selected format:
+) Enter Location As:
SPLC - |234:::| | dd Stop

4. Click Add Stop or press <Enter> and make a selection in the pick list that
opens (possible routes won’t be limited by the carrier you pick):

234000

BALTIMORE, MD» 25 o121 BALTIMORE
BALTIMORE, MD 23400 00005 BALTO BALTIMORE CTN
BALTIMORE, MD» 23000 70942 BALTO BALTIMORE NS
BALTIMORE CSXT, MD 23400 70572 BALTO BALCSXT N5
BALTIMORE TERMINAL, 234000 70954 BALTERMIN N5
BALTIMORE, MD 234000 91105 BALTIMORE AMTE
OK Cancel

5. The drop-down in the RR column lists valid carriers for the entered location —
uncheck any carriers that you do not wish to include. To generate every
possible route, “All Railroads” needs to be checked.

Routes X | AutoRouter X
Route Options:
Route Preference:
Practical v
@ BALTIMORE, MD 234000000 |CSXT, CTN, NS [ -
[] Al Railroads
+) Enter Location As:
- []cers
SPLC v csxT
CTN
NS
[] mer
[] AMTK
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Route Options:

@)
@
®

1

w

6. Repeat steps 2-5 to enter a maximum of two more stops (a destination, and
optionally, a via junction that you want the route to pass through).

7. Click Run or press <F10> to generate a list of possible routes. Run =

8. To examine any route on the list, click its View button. The route will be
displayed as a single route in the Routes window and will be drawn on the map.
As a single route, it can be edited and rerun.

Routes X AutoRouter X
Route Preference:
Practical -
Routes X || AutoRouter X
BALTIMORE, MD  |CSXT, CTN, NS - AutoRoute 2
ATLANTA, GA BNSF, CSXT, NS
Practical -
MIAMI, FL ST, FEC, NS
15191 CSXT-ATLA (© BALTIMORE, MD 27 BA CS
[ view | BIRMINGHAM, AL 4 9 BH BN
23705 CSXT - BHAM BNSF - ATLA - BHAM CSXT - JACVL FEC ATLANTA. GA 4 5 AT BN
m-—>
BIRMINGHAM, AL 4 1 BEH CS
1453.9  CSXT- ATLANS
JACKSONVILLE, FL 4 O JAC FE
[ view |
22890  CTN - PENMY CSXT - BHAM BNSF - ATLA - BHAM CSXT - JACVL © mimR a2 MEFR
[ view | 22
23227 CTN - PENMY CSXT - BHAM BNSF - ATLA - BHAM NS
+) | Station Name, ST
[ view |
1509.4 NS - ATLA
[ view |
22534 NS - BHAM BNSF - ATLA - BHAM CSXT - JACVL FEC

TIPS: The width of columns in a single route window can be changed — see section
4.7. When multiple single routes are open, a scroll bar appears on the right side of
the Routes window as needed for browsing.

Typically, the number of routes generated will be a product of the number of
railroads serving the origin times the number of railroads serving the destination.
Exceptions occur when a railroad serves both origin and destination; it is unlikely
that this railroad will participate in other inter-line routings.

Routes with the originating or terminating carrier having a switch move only
(common with terminal railroads) may be included or excluded depending on
whether Include or Exclude is chosen under Terminal Switch RRs in the Route
Options dialog (see section 4.10). Exclude is the default option.
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The generated AutoRoutes will be listed in order of fewest junctions between
railroads of different families and fewest total miles. Routes are shown as a
sequence of railroad SCACs and Rule 260 codes.

NOTE: The routing algorithms used in PC*MILER|Rail are identical to those used
in the traffic diversion studies for major railroad and government clients that ALK
Technologies has produced since 1979. The routes generated are listed in order of
fewest junctions and least miles, and are not necessarily the best or most efficient
routing options. They are merely feasible, practical routings based on ALK’s
observation of actual, historical traffic movements over many years.

4.6 Editing the Stop List

The stop list in a single route or AutoRouter window can be edited using the right
mouse menu off any stop on the list. To open the right mouse menu, right click any
stop on the list in a route window.

Edit

| Insert Stop Above

Zoom to Stop

Delete Stop (F8)

Column Chooser...

Menu optionsare:

Edit: Change or edit the stop.

Insert Stop Above: Insert a stop above the selected stop (<F7> does the same).
Zoom to Stop: Zoom to a close-up view of the sekected stop on the map.
Delete Stop: Delete this stop (<F8> does the same).

Column Chooser...: Choose columns to hide/display (see section 4.7 below).

To delete all stops in a single route window, press the <ALT><F8> keys
simultaneously or select the Delete All Stops button on the Routes toolbar. E

For single route entry, editing tools are available on the Routes toolbar as well:

To delete all stops in the AutoRouter, select Clear in the AutoRouter toolbar.
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4.7 Column Widths and the Column Chooser

The width of individual columns in a single route window can be adjusted — place
the cursor over a column divider so that it becomes a horizontal arrow, then click
and drag to the left or right.

@ BALTIMORE, MD 234DD;: fil21 BALTO  CSXT

The columns in a single route window can also be hidden and the column order can
be changed using the Column Chooser. To access this feature, right click any stop
on the stop list and select Column Chooser....

Columns:
V| FormattedStopType Move Up
Station Name, State Mave Down
SPLC
FSAC
Edit el
Insert Stop Above [13z-3-3
Zoom to Stop [] Lat/len
Delete Stop (FE)
| Column Chooser... D,*J s oK Reset Cance!
Right Mouse Menu Column Chooser for a Single Route Window

The Column Chooser lists all available columns for the window. There are eight
optional columns in a single route window and four in an AutoRouter window.

In the Columns list, check a column to display it, or uncheck to hide it.

To change the column order, select a column name and click Move Up or Move
Down. As the column name moves up the list, it will be moved to the left in the
route window, and vice versa. Click the Reset button to reset to the default column
order.

Chapter 4: Using PC*MILER|Rail 41



4.8 Route Entry Error Messages

REMINDER: Always check that the format selected in the format drop-down

matches your input.

Error Message
NO MATCHES FOUND

STATE ABBREVIATION
REQUIRED

STATION NAME MUST BE 20
CHARACTERS OR LESS

3-3-3 MUST BE 12
CHARACTERS OR LESS

SPLC MUST BE NUMERIC

SPLC HAS MAXIMUM 9
DIGITS

FSAC MUST BE NUMERIC

FSAC HAS MAXIMUM 5
DIGITS

INVALID STATE
ABBREVIATION

A junction is required. Please
click here for Junction Helper or
use the Auto Router

Description

No matches were found in the database. Check spelling
on a station name, or format if using a station code.

Station name is missing, or input does not include a
space or comma between the station name and state
abbreviation; or there is no state abbreviation provided
with an ERPC.

Input of more than 20 characters for a station name is
not accepted. This is a rare case, usually the first 20
characters of the entered station name will be accepted if
there is a match in the database.

Input of more than 12 characters for an ERPC is not
accepted. This is a rare case, usually the first 12
characters of the entered ERPC will be accepted if there
Is a match in the database.

If “SPLC” is the selected format, input must be numeric.

SPLC input cannot be more than 9 digits long.

If “FSAC” is the selected format, input must be
numeric.

FSAC input cannot be more than 5 digits long.
State abbreviation input is not a valid jurisdiction.

For single route entry, a junction is required between
two stations that were entered. Click the link in the
message to open the Junction Helper or use the
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AutoRouter. Or the station that triggered the warning
can be deleted (<F8>).

BAD LOCATION-RAILROAD The railroad that was entered does not serve the entered
COMBINATION location.

RAILROAD NOT FOUND The railroad that was entered does not have a match in
the database. Refer to Appendix D or E for the correct
SCAC, or in the application window select the Help tab

> Quick Help.
OPTIONS SET TO EXCLUDE | To include intermodal-only stations, select the Routes
INTERMODAL-ONLY tab > Options and choose “Include” in the Intermodal-
STATIONS Only Stations drop-down.

THE STATION ENTERED IS A | Intermodal is selected as the route type, and the station
NON-INTERMODAL STATION | entered is a non-intermodal station. Change either the
station or the route type.

4.9 Using Override Files For Recurring Data Errors, Custom
Name Creation and Junction Interchange Preferences

If you are experiencing recurring errors during route entry because the station or
railroad you attempted to enter can’t be found in the PC*MILER|Rail database,
there are override files you can use to correct this problem. These text files are
located in the RailNet subdirectory of your PC*MILER|Rail installation, usually
C:\ALK Technologies\PCRWIN23\Data\Rail\Base\RailNet.

The data override files can be used whenever different codes or names for stations
in the user’s database do not exactly match those registered with the Centralized
Station Master files, the source for the PC*MILER|Rail database.

Additionally, the override feature allows users to run routes to new stations created
after the latest release of PC*MILER|Rail, by using a neighboring station as a proxy
to generate non-error routes with almost correct mileage.

Override files can also be used to create custom location names (use the
OVERRIDE.NAM file) and to edit or create junction interchange preferences for
interline routing (use the OVERRIDE.JCT file).

Each override file now includes instructions for its use, in comment lines beginning
with the pound sign (#) at the top of the file. Additionally, an “Example Override
Data.txt” file containing examples is included in the same folder as the override
files.
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There are six override files for six types of station and railroad input:

OVERRIDE.ERP
OVERRIDE.FSC
OVERRIDE.NAM
OVERRIDE.SCA
OVERRIDE.SPL
OVERRIDE.JCT

These files initially include only instructions for the user, and may be filled by the
user with records (rows of text) in the correct format for each type. The records
you add will tell PC*MILER|Rail that “when this is entered, it means that”.

Added records must include an input column and a translation column. The input
column contains an abbreviation or numerical configuration that a user might enter
as a station location or railroad during route entry, and the translation column
contains the valid entry for that location that PC*MILER|Rail will recognize
because it matches what’s in the database.

Follow the steps below to add records to an override file:

1. Find the RailNet folder in your PC*MILER|Rail installation. For a typical
installation, go to:

C:\ALK Technologies\PCRWIN23\Data\Rail\Base\RailNet;
or if the installation location was customized, search for the RailNet folder
using Windows Explorer.

2. Right-click on one of the override files and select Open from the menu.
(If you can do this successfully, skip to step 5, otherwise continue to step 3.)

Name = | Size | Type
OVERRIDE.ERP OKE ERP File

|1#] oveRRIDE F5C 0KE F5CFile

=] OVERRIDE == 1KB MAM File
|i#] OVERRIDE.5¢ OKE SCAFile
% OVERRIDE.SF 3 1ZArc » OKE Flash Movie
pomet2nd . . . | 83KB 2MDFie
pernet, 2pt SR e 1KB 2PTFile
pernet. 260 send To » 19KB 260 File
@®poneteed 349KB Managed Informati...
pernet.dst ot 83KB DSTFile
pernet.epp Copy 10KB EPP File

m pcrnet.erp Create Shortout 826 KB ERP File
parnet.fam Delete 1KE FAMFile
pernet. fsa —— 389KB FSA File
panetfio — 1KE FSO0File
pernet. fsp FEE 4KB FSPFile
pernet.jet 1,003KB ICTFile
pernet.jctnam 1,117KB  JCTMNAM File
pcrnet.key 5KB KEY File

= parnet.nam 1,117KB  MAM File
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3. If Windows does not recognize the file type, a prompt will appear that asks
how you want to search for an application that will open the file. Choose
Select the program from a list, or in Windows 10 choose More Apps.

windows 21 x|
J Windows cannot open this file:
: File:  OVERRIDE.MAM
To open this file, Windows needs to know what program created it. Windows
can go online to look it up automatically, or you can manually select from a list of

programs on your computer.

What do you want to do?

™ Use the Web service to find the appropriate program
%" gelect the program from a list

QK I Cancel |

4. Alist of applications will open. Select Notepad or Wordpad.

Open With 2lx|
j Choose the program you want to use to open this file:

File:  OVERRIDE.SCA

[ Programs

@ Microsoft Office Document Imaging ;I
@ Microsoft Office Excel

Microsoft Office InfoPath

@ Microsoft Office Picture Manager

2] Microsoft Office Visio

@ Microsoft Office word

_g Motepad

1.j Paint

™1 ouarkxPress 6.5r0 LI

Type a description that you want to use for this kind of file:

[V Always use the select=d program to open this kind of file

Browse... |
If the program you want is not in the list or on your computer, you can look
for the appropriate program on the Web.
|

5. Inthe override file, type your entries, matching the column structure
appropriate to the file type (see descriptions for each file type below).

6. To save your changes, select File > Save at the top of the Notepad or Wordpad
window. The stations, railroads and/or preferences you added will now be
valid when you input them during route entry.
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Sample records for each file type are shown below. Detailed instructions for adding
entries are included at the top of each file, in lines preceded by the pound sign (#).

OVERRIDE.SCA

TFM KCSM;

The format for the entry must be: old or custom RR (SCAC) in positions 1-4, a
blank, the proxy SCAC (recognized by PC*MILER|Rail 23), and a semicolon at
the end.

OVERRIDE.FSC

ABCD 10000 09999;
The format for the entry must be: RR SCAC in positions 1-4, a blank, the new or

custom 5-digit FSAC, a blank, the 5-digit proxy FSAC (recognized by
PC*MILER|Rail 23), and a semicolon at the end.

OVERRIDE.SPL

ABCD 110000 089999;

The format for the entry must be: RR SCAC in positions 1-4, a blank, the new or
custom 6-digit SPLC, a blank, the 6-digit proxy SPLC (recognized by
PC*MILER|Rail 23), and a semicolon at the end.

OVERRIDE.ERP

PALMCV PALMER MA;
HAGECSXT MD HAGERSTOWMD;
SALT LAKEUT SALLAKCITUT;

The format for the entry must be: 11-char ERPC/3-3-3 (new or custom code), a
blank, the 11-char (including a 2-character state abbreviation in the last two places)
proxy ERPC/3-3-3 (recognized by PC*MILER|Rail 23), and a semicolon at the end.

OVERRIDE.NAM

MOOJAW SK MOOSE JAW SK;
YOYO IL  CHICAGO IL;

The format for the entry must be: up to 22-char name (new or custom station name),
a blank, the proxy Station Name (up to 22-char, including a 2-character state
abbreviation in the last two places, recognized by PC*MILER|Rail 23), and a
semicolon at the end.

PC*MILER|Rail User’s Guide 46



OVERRIDE.JCT

BNSF CSXT BHAM
BNSF CSXT BHAM
BNSF NS  CHGO
BNSF NS  CHGO

> =0T
mm> >

This file contains any junction interchange avoid/favors created using the

Avoid/Favor Junctions dialog (see section 4.11). It can be manually edited as well.

The columns from left to right are:

- RR1, up to 4 characters followed by 1 blank

- RR2, up to 4 characters followed by 1 blank

- R260 junction code, up to 5 characters followed by 1 blank

- Route type to which the preference will be applied (P=Practical, C=Coal/Bulk,
I=Intermodal, A=Auto Racks), 1 character followed by 1 blank

- Type of preference (A=Avoid, F=Favor), 1 character followed by a semicolon

See section 4.11 for an alternate way to create junction interchange preferences.

4.10 Route Options

PC*MILER|Rail gives you several options to choose from when running a route.
The available options vary depending on whether you use single route entry or the
AutoRouter (see sections 4.10.1-4.10.3 below for option descriptions). Route
options affect how rail lines and junctions are selected for a route, total route
mileage, and (with AutoRouting) the number of routes that are generated.

There are three ways to open the Route Options dialog:

1. Select the Options button in the Routes or AutoRouter tab.

2. Select the gear button > Options in a single route or AutoRouter window. %

Press < F4>.
4. After selecting your options, click on OK to close the dialog and save your
edits.

Options in the Route Options dialog must be re-selected for each route you run. To
set default options for a single route, see section 4.10.2.

NOTE: See section 4.2, PC*MILER|Rail Route Calculation, for general
information about how routes are calculated.
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4.10.1 Options for Single Routes

@ Route Options - O X
Route Name: Route Preference;
AutoRoute 2 Practical -
Intermodal-Only Stations: Distance Units;
Include A Miles v
7] oK Cancel

Route Options for Single Route Entry

e Route Name: To give a route a custom name, type the name in this field. This
name appears in the route window, on reports, and on the Route Legend in the
map window.

e Intermodal-Only Stations: This option indicates whether to Include or
Exclude stations that provide only intermodal service. Note that when the
Intermodal route formula is selected (see below), excluding intermodal-only
stations is not an option.

e Route Preference: Six route formulas are available to generate routes:

- Practical routings simulate the most likely movements of general
merchandise train traffic. Main lines are preferred to branch lines. A
Practical route can sometimes be more circuitous than the shortest possible
route.

- Shortest route calculations find the rail route with the least distance
between the stops. For single routes, the shortest path within the railroad is
determined for each segment. In the AutoRouter, the shortest path across
all North American railroads is calculated, irrespective of the origin and
destination railroads chosen by the user.

- Intermodal, Coal/Bulk, or Auto Racks may be used to determine the
exceptional routings that these types of trains sometimes require.

- Fuel Surcharge routing is essentially a combination of the Shortest and
Practical route formulas (because some railroads use Shortest mileage and
some use Practical mileage when figuring their fuel surcharges). It
provides mileage suitable for calculating fuel surcharges in conformance
with the Surface Transportation Board ruling STB Ex Parte No. 661. See
Appendix C, Fuel Surcharge Railroad Reference, for which railroads use
Practical vs. Shortest routing.
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e Distance Units: Choose whether distances should be calculated in Miles or

Kilometers.

4.10.2 Setting Default Route Options (Single Route Only)

Default route options can be set for single route entry, so that every time you open
a new route window those options are automatically selected for the new route.

Default values can be edited.

To set default route options for a single route, select the Routes toolbar > Defaults.

Defaults for all options except the Route Name can be specified.

4.10.3 Options for AutoRoutes

BS Defaults

Route options for AutoRoutes are the same as for a single route, except that: 1)
a custom route name cannot be entered; and 2) a terminal switching option is

provided:

e Terminal Switching: When using the AutoRouter, routes with the originating
or terminating carrier having a switch move only (common with terminal
railroads) may be included or excluded. The default for this option is Exclude.

This option affects the number of routes that are generated.

a AutoRoute Options

AutoRoute

Intermodal-Only Stations

Include

Terminal Switching:

Include

°

Route Preference

Practical

Distance Units
Miles

OK

Cancel

Route Options for AutoRoutes
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4.11 Avoid or Favor Interchange Junctions in the AutoRouter

PC*MILER|Rail enables users to designate junction interchanges to be avoided or
favored on a route. These custom interline routing preferences are specified for the
AutoRouter, and apply to both directions.

Preferences are stored in an “OVERRIDE.JCT” text file that may be viewed and
edited, allowing the user to manually add a long list of junctions to be avoided or
favored if desired (see section 4.9 on editing thise file).

In the Avoid/Favor Junctions dialog, you enter railroad and location data to
generate a pick list of all available junction interchanges. You can then select a
junction to avoid or favor from the pick list. The three possible railroad/location
combinations that can be entered are:

e Enter a station name or R260, and one SCAC in either the Railroad 1 or
Railroad 2 field, to generate a pick list of all junctions at the specified
station for the entered railroad.

e Enter two SCACs to generate a pick list of all stations with junction
interchanges between those two railroads.

e Enter a station name or R260 and two railroads. If a pick list is generated,
it will include only a very small number of choices.

The steps below provide an example of how to designate a junction to be avoided
or favored in AutoRoutes. This example uses the BNSF and CSXT railroads and
Birmingham, AL as a junction to be avoided:

1. Select the AutoRouter tab > Avoid/Favor Junctions or hit <Alt+F2> on your
keyboard to bring up the Avoid/Favor Junctions dialog.

ESESCN(S|
EEE

Station, State | R260 Inbound Railroad Qutbound Railroad Route Formula
BIRMINGHAM, A bnsf = Practical, Coal/Bulk, Auto Rac Delete

Delete All Avoids

@ oK Cancel

Avoid/Favor Junctions Dialog
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2. In the Avoid Junctions tab, enter “BNSF” as Railroad 1 and “CSXT” as
Railroad 2. (Note that either Railroad 1 or Railroad 2 can be the forwarding or
receiving carrier.)

3. Check one or more route type(s): AutoRacks, Coal, Practical, Intermodal.

4. Click Add.

5. A Junction Helper pick list of all stations that have an interchange between
BNSF and CSXT will open, with Birmingham, AL highlighted at the top.

Click OK to add the BNSF-CSXT junction at Birmingham as a junction to be
avoided.

B
RR1 R260 Station Name, ST RR2
bnsf BHAM BIRMINGHAM, AL caxt
bnsf PENSA PENSACOLA, FL caxt
bnsf ATLA ATLANTA, GA ot
bnsf BEDPK BEDFORD PARK, IL osxt
bnsf CHGO CHICAGO, IL osxt
bnsf CRWTH  CORWITH, IL =
bnsf EFEOR  EAST PEORIA, IL osxt
bnsf ESTL EAST 5T LOUIS, IL osxt
bnsf JOLE JOLIET, IL osxt
bnsf MADIS MADISON, IL osxt
bnsf OTTWA OTTAWA, IL osxt
bnsf SMTEO SMITHBORO, IL osxt
bnsf WILST WILLOW SPRINGS, 1L osxt
bnsf NEWOR NEW ORLEANS, LA osxt
bnsf STLOU ST LOUIS, MO osxt
bnsf MEMPH  MEMPHIS, TN osxt

oK Cancel

Pick List of BNSF-CSXT Interchanges

NOTE: If you attempt to add a duplicate of an existing junction preference (either
of the same type, or adding an avoid as a favor or vice versa), an error message will
be generated.

T Avoid/Favor Junctions [_ O]
Avoid Junctions | Favor Junctions:
Station Name, 5T - é;;TRacks
Practical
Intermodal
Station, State | R260 Inbound Railroad Outbound Railroad Route Formula
BIRMINGHAM, A bnsf = Practical, Coal/Bulk, Auto Rac Delete
Delete All Avoids
@ oK. Cancel

Birmingham, AL Designated As a Junction to Be Avoided

NOTE: Column widths can be adjusted in the Avoid/Favor Junctions dialog.
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A generated route from Little Rock, AR to Jacksonville, FL is shown below. This
route uses BNSF as the origin railroad and CSXT as the destination railroad, and
illustrates the effect of a junction preference.

The first screenshot shows the route before the preference was added; and the
second screenshot shows how the route avoided Birmingham after that junction was
designated to be avoided, routing through Memphis, TN instead.

Before — Route Uses Birmingham, AL as an Interchange:

Routes X AutoRouter X Mot - 22.0_Baris {Zoom Level 6 of 20)
FOMILERIRad 72 Copynght PPALK Technologie £201%

AR AKMD, BNEE, LAPA, LAWK, UP

E, FL CSXT, FEC, NS, 507, TR

e )

N System
b RS Sysiem 0

m — CHAT System JACKSONYILLE, on G

KCS System
o MEMES ——— NiSptem

UP Syme

m Other Symema

B ™ BNSF £AM X
] Latitude/Longitude: 28 30° 32,3067 N, B9 32" 25,6507 W (26.556000 N, 69541204 W)

After — Route Uses Memphis, TN (Avalon Station) as an Interchange:

T PLUMILER Rl

anse &
AvaLONST, Thran CST
10018 mx reoi_mirrm'_w:r

HNSF System |
N ystem
CPRE Spstem |

e CSKT System gHER’IN

KES System

— NS Srrtem | JACKSONYILLE, KL on €
UP Spstem
Other Systems

Labtude/Lengiude: 20 I 35.002° N, 88 30 S5.3007 W (20.043081 N, 88515372 W)
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To delete a preference in either the Avoid Junctions or Favor Junctions tab, click
the Delete button on the same line as the preference, in the last column on the right.
To delete all preferences on the list, click Delete All.

Avoid Junctions Fz Juncti

Statios AutoRacks

Station Name, ST -
Practical
Intermodal

Delete
Station, State | R260 Inbound Railroad Outhound Railroad Route Formula
BIRMINGHAM, A brsf ot Practical, Coal/Bulk, Auto Rac Delete
Delet All Avoids \;
@ OK Cancel

Delete an Avoid or Favor Preference

Here is an example of saved junction preferences as they appear in the
OVERRIDE.JCT text file, usually found in C:\ALK Technologies\PCRWIN23\
Data\Base\Rail\Railnet (see section 4.9):

BNSF CSXT BHAM
BNSF CSXT BHAM
BNSF NS CHGO
BNSF NS  CHGO

> =0T
mm> >

The columns from left to right are:

- RR1, up to 4 characters followed by 1 blank

- RR2, up to 4 characters followed by 1 blank

- R260 junction code, up to 5 characters followed by 1 blank

- Route type to which the preference will be applied (P=Practical, C=Coal/Bulk,
I=Intermodal, A=Auto Racks), 1 character followed by 1 blank

- Type of preference (A=Avoid, F=Favor), 1 character followed by a semicolon

As mentioned, an unlimited number of preferences may be added manually to this
file, in the format shown above.

Chapter 4: Using PC*MILER|Rail 53



4.12 Changing the Map Data Set

The PC*MILER|Rail industry-standard rail network database is updated annually
to include the most current data available for each version release, and three
additional updates to the base data are provided throughout the year. Beginning in
Version 20, each update is downloaded to a separate folder and users can choose
which dataset to use at any time. The active data set will always be displayed in
the title bar of the application window, for example “23.0_Base”.

To switch between data sets, in the PC*MILER|Rail application window select the
Map tab > Change Data Set > and choose a set from the menu.

Note that for a data set other than the yearly base version to be available, it must
have been downloaded using the Check for Updates tool in the Help toolbar.

va
»Y

Change
Data Set =

v | 22,0 Base
22.1_lpdate
22.2_Update

Change Data Set Menu
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4.13 Saving and Loading Routes

Routes may be saved for future use or reference. Saving routes enables you to create
a library of standard routings that can be maintained over time and re-used.

To save a new route, select the Routes tab > Save > Save Route As to bring up the
Save Route dialog. The format of this dialog is a standard Windows feature for
saving your files.

6 Save Route *
« v P <« ALK Technol.. » PCRWIN23 » v O Search PCRWINZ3 »

Organize v New folder =R o

[ This PC ” Mame Date medified Type

[ Desktop App File folder
BatchPro

Bitmaps

|= Documents File folder

¥ Downloads
D Music

File folder

Connect File folder

Data File folder
=/ Pictures

Routes File folder

2
[ videos TCPIP 11/17/2016 12:06 ... File folder
i Local Disk (C:)

= L-Drive (L)

= M-Drive (M:)

=% R-Drive (R:)

== U-Drive (U] Rl RS >

File name: | Newark-Calgary-Bulk ~

Save astype: | Route Files (*.rte) ~

+ Hide Folders Cancel

Saving a Route

Choose a drive and folder where you want the file to be saved, and type a file
name in the File Name field. Valid file names can be any length (though they are
truncated when displayed in DOS). Spaces, periods and other punctuation marks are
not valid characters for the file name.

To load a previously saved file, select the Routes tab > Open to open a standard
Windows dialog for opening files. Locate your route file and click Open.
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4.14 Route Duplication

Route duplication offers an efficient way to compare how different options will
affect routing between the same locations. To duplicate a route including all stops,
carrier information and options, click on its route entry window to activate it and

select the Routes tab > Duplicate.

Route 1
Practical -
@ CHICAGO, IL 380000000 66000 CHGO  BNSF

@ LOS ANGELES, CA 583000000 23000  LOSAN BNSF 2197.7

2,197.7
1 Duplicate
Route 1 - Copy
Shortest -
@ CHICAGO, IL 380000000 66000 CHGO  BNSF
@ LOS ANGELES, CA 583000000 23000 LOSAN  BNSF 21264
2,126.4

Map - 23.0 Base (Zoom Level 5 of 20)

—
f BO| e Route 1
Route 1-C...
+
BNSF System

)

CN System r
CPRS System
CSXT System
KCS System

[1[1]]

Facramfinto NE Sygtam
o UP System
esn W_T' LAS \LEGAS

: (Ch 5 % ALBUQgERQUENSF B

g “w/BNSF
®,. PHOENIX [h

0S ANGELES, c-ﬁgm BNSF . DALLAS

San Diego SMexicali L Tty Juirez 2 \Q

Aust L. '
‘ PC*MILER|Rail 23 Copyright @ ALK Technologies 2016 using HOUST.ON. "Wt
HERMOSILLO \:r

Duplicate Route Comparison: Practical vs. Shortest
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Route Output:
Route Window, Reports & Maps

Chapter

Routes between stops are calculated by PC*MILER|Rail using one of six routing
formulas. The output for every generated route includes leg and cumulative
mileage in the route window and a map display of the route. Optionally, up to six
different route reports can also be generated.

5.1 Output in the Route Window

The output from each generated route includes leg mileage between stops and
cumulative mileage for the whole trip. Additionally, by default the station name
and state, SPLC, FSAC, R260 and SCAC are displayed in columns for each station
on the stop list.

The width of individual columns in a single route window can be changed, and

columns can be added, hidden, or moved — see section 4.7, Column Widths and the
Column Chooser.)

Route 1

Practical -

@ MNEWARK, MNJ 191200000 39135  MEARK  CSXT
INDIANAPOLIS, IN 368700000 75128  INDAP  CSXT 9181
CHICAGO, IL 380000000 40800  CHGO  CSXT 2428
CHICAGD 59TH STR. 380839000 56050  CHENS CNM 8.5

@ CALGARY, AR 082400000 81679  CALGY CN 18476

3.018.1

+! | Station Mame, 5T -

Output in a Route Window
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5.2 Reports

To generate reports for a route, the route must be active (click on the title bar of the
route window). Select the Routes tab > Reports and choose a report from the drop-

down.

P
1t

Detailed
Key Stabion k
Detailed Geocods

By Railroad

By State

By Railroad & State

Reports Menu in the Routes Toolbar

Reports appear in a tabbed window when they are generated. To change the position

of the reports window, select an

option from the Window toolbar on the Ribbon.

Alternatively, the reports window can be floated outside the application window —
window position menu.

right click a report tab to open the

30181

Decaied fepoet for Route 1 K Ky Samticn Repan for Route | X

80 aedoBEODRS:-

SEATTLE
Report Tabs ol
@ cu ]i : _g,y_n}uscﬁ eHEEH Window POSition =

S eras 23 commblits Ak zacRf
L
..: I

Latitude/Longude: 5046 1513° N, 62 523519

Detailed Geocode Report for >

. NJ & CEXT

Menu

-t

L

e

DETAILED GEOCODE REPORT

Route 1: Newark. NJ (CSXT) 1o Caigary. AB (CN)

3018.1 Mibes. Prachcal Include Intermodal-Onty

RR SPLC ST Station Name Station (3.3.3) R0 Leg Miles  Todal Mises
Diwigin: Newark, N.J

CEXT M) Kearny Junclion 25 25
C8xT HJ Kearmy Shops 13 g
CEXT 199433000 MU Soumh Keamy SREARNY SOKAZ 1m0 43
CEXT 191581000 RS Hack Fver HACHIVER il 58
CEXT 191520000 MJ  Marion MARICH MARL 03 LR
CSXT 191407000 M) Seadoard SEABOARD SLERO 18 79
CEXT 191575000 MJ Fangmanns Siing  FAMSIDING 08 a7

Reports Window in the Default Location
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5.2.1 Detailed Report

The Detailed Report lists all points on the route, along with leg and cumulative
mileage between the origin and destination. At the bottom of the report you’ll also
see summaries of leg mileage by state and by railroad.

CN AB  Kathyrn 88 30409
CN AB  Delacour 57 30556
CN AB  Calgary Log Park 4.0 30506
CN AB  Conrich 1.0 3060.6
CN AB  Hubalta 70 3067 86
CN AB  Calgary 158 30691

Destination: Calgary, AB
TOTAL 3069.1

State Leg Miles

AB arag
L 911
IN 256.1
MB 3198
COMN 2051
NJ 287
NY 4305
OH 2704
ON 581
P4 437
SK 529.4

Wi 400.3
TOTAL 3069.1

RR Leg Miles

CSXT
CN
TOTAL

11093
1959.8
3069.1

Trip Destination and State Mileage Summary in the Detailed Report

5.2.2 Detailed Geocode Report

The Detailed Geocode Report includes the same information as the Detailed
Report, but also lists the SPLC, 3-3-3, and R260 for each stop.

DETAILED GEOCODE REPORT

Route 2: Newark, MJ (CSXT) to Calgary, AB (CN)
30691 Miles, Coal/Bulk, Include Intermodal-Only

RR SPLC ST Station Name Station (3-3-3) R260 Leg Miles Total Miles
Origin: Newark, NJ

CSXT MJ  Keamy Shops 27 27
CSXT 191488 MNJ  South Kearny SKEARMNY SOKRZ 1.1 3.8
CSXT 191580 NJ  Marion MARION MARIJ 18 5.4
C8XT 191487 NJ Seaboard SEABCARD SEBRO 1.5 6.9
CE8XT 191578 NJ Fangmanns Siding FANSIDING 0.9 7.8

Detailed Geocode Report
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5.2.3 Key Station Report

The Key Station Report includes the user-specified stops on the route with leg and
cumulative mileage, and leg mileage summaries by state and railroad at the end.
The SCAC, SPLC, station name and state, 3-3-3 and R260 codes are shown for
each key station.

KEY STATION REPORT

Route 2: Newarl, MJ (CSXT) to Calgary, AB (CN)
3069.1 Miles, Coal/iBulk, Include Intermodal-Cnly

RR SPLC ST Station Name Station (3-3-3) R260 Leg Miles Total Miles

Origin: Newark, NJ
CSXT 388700 IN Indianapolis INDIAMNAPO INDAP 907.3 907.3

Stop 1: Indianapolis, IN

CSXT 380000 IL  Chicago CHICAGO CHGO 202.0 1109.3
Stop 2: Chicago, IL
CN 82400 AB Calgary CALGARY CALGY 1958.8 306%9.1

Destination: Calgary, AB
TOTAL 3069.1

List of Stops in the Key Station Report

5.2.4 Mileage Summaries

The last three options in the Reports menu are leg mileage summary reports:
By Railroad, By State, and By Railroad and State.

RAILROAD STATE REPORT

Route 2: Newark, NJ (CSXT) to Calgary, AB (CN)
30691 Miles, Coal/Bulk, Include Intermodal-Only
RR 5T Leg Miles

CN AB 780

CN IL 502

CN MB 3198

CN TN 2051

CN ON 581

CN SK 5204

CN Wi 4003

CSXT IL K]

CSXT IM 2561

C8XT N 267

C3XT NY 4805

C8XT OH 270.4

CSXT PA 437

TOTAL 3069.1

Leg Mileage Summary Report by Railroad and State
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5.2.5 Font Size and Page View

Each report that is generated will be displayed with a toolbar that enables editing

the page view and font size.

To change the font size in the active report, use the Font Size drop-down. For page
view adjustments, there are eight buttons that control page layout (portrait vs.
landscape) and magnification. Place your cursor over any button to see a tooltip

that tells you what the button does.

Page View Controls

Font Size Control

~\ V

I %QQJEDD Font Size:
"

[
|Increase the size of the content (Ctrd +}J\
I

Tooltip

5.2.6 Printing and Copying Reports
There are two ways to print a report:

1. Click the Print icon on the report window toolbar.
A O &
L,

2. Press the <Ctrl+P> shortcut on your keyboard.

To copy a report to the clipboard for use in another application:

1. Click the Copy icon on the report window toolbar.

ﬁ@%@l‘i

A,

2. Press <Ctrl+V> to paste the report contents into
your target application such as Microsoft® Word®.
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5.2.7 Saving Reports
To save PC*MILER|Rail reports to disk:

1. Select the File application menu > Save Report to File.

2. Inthe Save Report dialog, select the folder where the file will be saved and
enter a file name in the File Name field.

3. Click Save.

& SaveReport X
1 « PCRWINZ3 » App » v @ Search App 2
Organize ¥ MNew folder == w o
[ This PC ) Name - Date modified Type
; Desktop bin 11/17/2016 210 PM  File folder

E] Documents log 11 01612:09..  File folder
; Downlaads £ maps 11 016 12:06...  File folder

) u ReadMe 11/10/2016 5:00 PM Text Docum
J‘) Music
&=/ Pictures
g Videos
“ . Local Disk (C:)

== |-Drive (L)
== M-Drive (M)

=g R-Drive (R:)
= |J-Drive (L) v £ >
File name: | Detailed Geocode Report Mewark-Calgary] w
Save as type: | Text (Tab delimited) (*.tx) w

» Hide Folders Cancel

Save Report Dialog
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5.3 Route Maps

5.3.1 Zoom Options

(=] BNSF

Map - 22.0_Base (Zoom Level 4 of 20) - X
é il 22 CopyripDMOMNT OMhnologies 2015
- \\ BNSF System
N "y SASKATOON I
(4> Rafitd CPRS System —
Y FIne TTTERS CSXT System 0 Miles 400
(+] ] e KCS System
\=ACOUVER Eraen
UP System
SEATTLE Other Systems
BISMARCK: QUEBEC
N =
OR'?.‘AND TINNEAPOLIS MONTREAL
BOISE JCT PIESRE \\ EAST TOR EWT,
H ) HILV\%UKEE i
0 SR OMAHA™- £ CUEVELARND | "t
1R SALT LAKECITZE™ ¢ % JMAHAT o, Aol e
=) . j f O\ CHI,E,H‘_Cﬁﬁ.@}'”!-Qm;BNSE LR~ (0]
]L KANSAS'CL: " EW YORK, NY on CSXT

SANIFRANEISE0)CA/ONIBNSF

ALBUQUERQUE
. m -
LOSAIiQELES PHO‘ENIX

L -\

Routes Framed in the Map Window

By default, PC*MILER|Rail automatically draws each generated route in the map
window. This enables you to examine routes in detail, visually evaluate routing
alternatives, and to perform a variety of "what-if" analyses.

If the map window is hidden, select the Window tab > Map Window. The map
window can be floated outside the main application window — click the drop-dodwn
in the upper right corner of the map or right click the title bar. E x |

Dock
Hide

The PC*MILER|Rail map window features 20 possible zoom levels. You will see
the current zoom level in the window’s title bar (e.g. “Zoom Level 14 of 20”).

To zoom into a specific area, select the Map tab > Box Zoom (this option is turned
on by default). Then drag a box around the target area: press and hold the left
mouse button down and drag the cursor on the map.

To zoom directly to a stop in the route window, highlight it on the stop list, then
do one of the following:
e double-click the highlighted stop;
e right-click the stop name and select Zoom to Stop from the menu;
e select the Routes tab > Frame Stop on Map button;
il
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Other ways to zoom your view of the map are:
e simply double-click a point on the map;

e use your mouse’s scroll wheel: roll up to zoom in, down to zoom out;
e choose Zoom In or Zoom Out from the right mouse menu off the map;

e or use the slider bar and compass in the upper left corner of the map as
follows: either 1) click, hold and drag the zoom control to move up (zoom
in) or down (zoom out); or 2) click the plus sign or minus sign to move up
or down one zoom level. To pan north, south, east or west as needed,
click the directional arrows on the compass.

(«m») 4= Compass
Zoom In (5

Zoom Control

= Zoom Out

5.3.2 Frame Options

Frame Areas

All Routes
" Auto Frame Routes

Frame One Route  »

Frame Options on the Map Toolbar

Framing options in the Map tab > Frame menu are:

e Frame Areas: Select an area to frame.
e All Routes: Frame all generated routes.

e Auto Frame Routes: Toggle this option on to automatically frame each
route after it is run.

e Frame One Route: All open routes are listed, select one to frame.
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5.3.3 Frame Route and Show/Hide Options in the Route Window

Two buttons enable you to frame a route or show/hide the route on the map directly
from the route window:

Show/Hide Route

Frame Route on Map

Practical -

@ TEXARKAMA, TX 661150000 34340  THRKA  BNSF
@ CHICAGO, IL 380000000 66000 CHGO  BNSF 931.2

931.2

+! | Station Name, ST ‘ |

Frame Route and Show/Hide Route Buttons

5.3.4 Drag Map or Pan To Shift the View

Drag the Map:

Select Drag Map in the right mouse menu off the map or click the Map tab > Drag
Map. With your cursor (now in the shape of a hand) in the map window, hold the
left mouse button down and drag in the desired direction. The map will redraw the
new view.

To turn this feature off, click Drag Map again.

Pan:

One way to pan the map is: select Pan in the right mouse menu off the map, then
select any direction from the sub-menu. You will see the map view shift in the
chosen direction. Other ways to pan are using the scroll bar (see section 5.3.5
below) or the compass (see section 5.3.1).
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5.3.5 Scroll Bars in the Map Window

The PC*MILER|Rail map window includes scroll bars that are hidden until
activated. To activate, touch any edge of the map window with your cursor and a
translucent scroll bar will appear. Click on this scroll bar to move the map
incrementally in the direction indicated by the arrow, or click and hold to pan your
view.

Scroll Bar with
directional arrow

Map - 22.0_Base (Zoom Level 3 of 20} R 4 > X

‘ PC*MI‘.ERlI’qn 22 Copyright © ALK Technologies 2015 A

AN
[_4![! ASHTABULA HBR

(+]

A

Scroll Bar for Map Panning

5.3.6 Hiding and Displaying Map Features

You can control which features are displayed and in what order features are drawn
on the map using the Map Features dialog. Select the Map tab > Map Features.

The Map Features dialog lists all the available feature layers. Features that are
checked are displayed. To hide a feature layer, uncheck it.

To show or hide all features, use the Show All and Hide All buttons. Click on the
Reset button to return to the default display.

In the column on the left, feature layers are listed in the order they are drawn on the
map: features on the bottom of the list are drawn under the ones at the top. To raise
or lower a feature layer, highlight it and click Up, Down, To Top, or To Bottom.
Feature layers in the column on the right can be hidden, but the order in which they
are drawn can’t be changed.
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& Moap Features - O x

Features displayed on the map:

Rail Stations Zoom Slider Bar
[C] Rail Junctions Water

Stop Name Parks

Routes [C] Urban Areas
Railroads Airports

Road Shields - Land

Polygon Labels - Military Bases
Cities County Boundaries

State Boundaries
Country Boundaries

Interstate Road Shields

Large Cities

[E] Road Names To Bottom
Roads

O Time Zones

Show All Hide All

@ oK Reset Cancel

Map Features Dialog

5.3.7 Turning Map Labels On and Off

Label Stations

lera = T
H Stop Labels ~ == Label Railroads

Clear Labels

Railroad shields, station labels, and stop labels on the map can be added and deleted
using the mouse.
To Add or Remove Station Labels:

1. Select the Map tab > Label Stations or select Label > Label Stations in the
right mouse map menu. The cursor changes to: %
@

2. Click on any point on the map where a station is located to label it. To
remove an existing label, click on it.
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To Label Railroads:

1. Select the Map tab > Label Railroads or select Label > Label Railroads in the
right mouse map menu. The cursor changes to: %

2. Click on any point on a rail line to label it. To remove an existing label, click
on it.

To Clear All Station and Railroad Labels:

To clear all station and railroad labels that were added manually, select the Map tab
> Clear Labels or Label > Clear Labels in the right mouse map menu.

To Label Stops:
1. Select the Map tab > Stop Labels or Stop Labels > in the right mouse map menu.

2. Select > Station Name to label stops with a station name, and/or > Railroad to
label with a SCAC.

5.3.8 Controlling the Display of Railroads
You may wish to choose which railroads are displayed on the map. To do this, first

make sure “Railroads” is turned on in the Map Features dialog (Map tab > Map
Features). Then select the Map tab > Map Railroads.

& Railroad Display Control = O X
Railroad Systems: Individual Railroads:
BNSF System [ A
CN System [ ag
CPRS System [ aBL
CSXT System [ aer
KCS System [ ABs
NS System [C1 apwr
UP System [ acir
Other Systems [ Acwr
[E ADeF
[T AErC
Show Al Hide All [ AF
[ arR
[C] Display Track Ownership A
AGCR
[E1 Frame Railroad(s)
@ OK Reset Cancel

Railroad Display Control Dialog
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All available railroads and systems in North America are listed in two lists in the
Railroad Display Control dialog. Checked railroads will be displayed. All railroad
systems are drawn by default when “Railroads” is turned on in the Map Features
dialog.

Use the Show All/Hide All buttons to display/hide all railroad systems. Individual
railroads must be checked and unchecked one at a time.

If Display Track Ownership is checked, the colors used to draw rail lines on the
map will reflect track ownership rather than trackage rights. Check Frame
Railroad(s) to frame the systems that are checked on the list. Click Reset to return
to the default display setting for all railroads.

5.3.9 Legends

There are three legends available in the map window: Route, Carrier and Scale of
Miles. All legends can be moved around within the map window by clicking and
dragging. To hide or show a legend, select the Map tab > Legends and toggle one
or more legends on/off.

If checked, the Route Legend appears after a route is run; the Carrier Legend
appears when railroads are displayed; and the Scale of Miles always appears as part
of the map.

The Carrier Legend provides a key to the display of rail lines owned or operated
through trackage or haulage rights. By default, rail lines are drawn in different
colors that show which railroad holds the trackage rights on any given line.
However, if Display Track Ownership is checked in the Railroad Display Control
dialog, the colors will reflect ownership (see section 5.3.8). In this case there will
be a color that indicates joint ownership. To see which railroads jointly own a
particular rail line, select the Map tab > Label Railroads then click on that rail line
on the map.

BEMSF System
CM System
CPRS System
CSXT System
KCS System

NS System

UP System
Other Systems
Joint Ownership

Route 1
Route 2

T

0 Miles 125

Route Legend Carrier Legend Scale of Miles
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5.3.10 Right Mouse Map Menu Options

Zoom In
Zoom Qut

Frame 3

Drag Map

Map Features

Railroads
Label b

| Stop Labels *|| ¥ | | Station Name .
Legends k| & | | Railroad .l

Right Mouse Map Menu

You can right click anywhere on the map to bring up a map menu. Most of the
options on the Map toolbar can also be accessed from this menu.

5.3.11 Printing a Map

To print the currently displayed map, select the Map tab > Print Map on the toolbar
or File menu > Print Map. A standard Windows Print dialog will open.

= Print H
General

~ Select Printer
= Fax [=IHP Deskjet 3510 serie
IFax (redirected 4) M Microsoft Print to PC
& HP Deskjet 3510 series (Copy 1) (redirected 4) 7= Microsoft Print to PC
< >
Status: Ready Preferences |
Location:
Comment Find Printer... |

~ Page Range
= Al Number of copies: I'I 3:
" Selection € Curent Page
{” Pages: I W Collate

231 23
Enter either a single page number or a single 1 1
page range. For example, 5-12
Prirt Cancel | Apply |

Standard Windows Print Dialog
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5.3.12 Copying a Map to the Clipboard

Maps can be copied to the clipboard for retrieval in other Windows programs such
as Microsoft Word. To do this, select the Map tab > Copy Map.

Newark, NJ — Chicago, IL]

A Map Copied Into Microsoft Word
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Chapter

Two Sample Routes

6.1 Single Route Entry: Atlanta, GA to Omaha, NE

Our sample route in a single route window will generate mileage from Atlanta, GA
on CSXT to Omaha, NE on BNSF using the Shortest route formula. Because CSXT
doesn’t run to Omaha, we’ll use the Junction Helper to find a junction interchange

for the route.

1. In the application window select the Routes tab > New Route.

2. We’ll go with the default Station Name, ST format for a station — click on the
station field in the new route window and type “atlanta ga”, then click Add
Stop or press <Enter> on your keyboard.

3. Select CSXT from the pick list and click OK.

atlanta ga

ATLANTA, GA
ATLANTA, GA
ATLANTA, GA
ATLANTA, GA

456200000 50910 ATLA  ATLANTA  BMSF
456200000 13699 ATIA  ATLANTA  CSXT
456200000 56306 ATLA  ATLANTA NS

456200000 19080 ATLA  ATLANTA  AMTE

OK Cancel

4. Enter “omaha ne” as above, selecting BNSF as the carrier.

5. Click the Junction Helper link in the prompt that appears.

Route 1

Practical -

(© ATLANTA, GA

456200000

el

Junction Helper link

13699 ATLY Al

A junction is required. Please use the Junction Helper

or AutoRouter.

(o) omAHA NE

+! | Station Name, ST =

553200000

80214  OMAHA  BMNSF
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6. Inthe Junction Helper, click OK to select the first entry on the list (Birmingham,
AL).

Junction Helper nl

RR1 R260 Station Name, 5T RR2

CSXT EHAM BIRMINGHAM, AL BEMSF
CSXT PENSA PENSACOLA, FL BNSF
CsXT ATLA ATLANTA, GA BMNSF
CSXT BEDPK BEDFORD PARK, IL BNSF
CsXT CHGOD CHICAGO, IL BMNSF
CSXT CRWTH  CORWITH, IL BMNSF
CSXT EPEOR EAST PEORIA, IL BNSF
CSXT ESTL EAST ST LOUIS, IL BMNSF
CSXT JOLIE JOLIET, IL BNSF
CsXT MADIS MADISOM, IL BMNSF
CSXT OTTWA  OTTAWA, IL BNSF
CsXT SMTBO  SMITHBORO, IL BMNSF
CSXT WILSI WILLOW SPRINGS, IL BNSF
SENT RICL AT RICAAE D] CAKRIC 1 A DRICC

OK Cancel

7. Select the Routes tab > Options.

8. In the Route Options dialog, type “Atlanta-Omaha” in the Route Name field,
then click OK. The custom route name will appear in the route window, on all
reports, and in the Route legend on the map.

& Route Options — O x
Route Mame: Route Preference:
| Atlanta-Omaha Practical -
Intermodal-Only Stations: Distance Units:
Include - files -

6 0K Cancel
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9. Click Run or press the <F10> key.

B PCTMILER 23001

Map - 230 ese [Zoam Level 6 ol 20}

anta-C =
e = am»
actica Run m ¥

|
MM BT BNSF -~ s

; i-_Hsz_urou

T

Vei

TULSA

Generated Route — Atlanta to Omaha via Birmingham
Mileage appears in the route entry window when processing has finished, and the
route is drawn on the map.
From here, you might choose to select one of the following in the Routes tab:
Reports > to generate one of six route reports; Duplicate > to duplicate the route and

change routing options for a comparison; or Save > to save the route for future use.

To clear all stops from the route window, select the Routes tab > Close or the Delete

All Stops button. E
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6.2 Using the AutoRouter: Atlanta, GA to El Paso, TX

The AutoRouter feature is a valuable tool for determining which railroads serve the
origin or destination, and how they connect via intermediate junctions. It enables
you to set customized railroad routing preferences and get back several routes to
choose from. The sample route below from Atlanta to El Paso uses the Shortest
route formula.

1. In the application window select the AutoRouter toolbar on the Ribbon.

2. To enter an originating railroad, type “atlanta ga” in the Station Name, ST field
and click Add Stop or press <Enter> on your keyboard.

Routes 3 AutoRouter 2

Route Options:

Route Preference:

Intermodal -

—+) Enter Location As:

Station Name, ST hd |atlanta gal | Add Stop

3. A pick list showing all railroads that serve Atlanta will open — click OK. (It
doesn’t matter which railroad you choose here.)

atlanta ga

ATLANTS, GA (CSXT)
ATLANTS, GA (NS)

OK Cancel

4. Click the drop-down list of railroads for Atlanta and uncheck CSXT to exclude
it from consideration.

|BNSF, CEXT, NS -

[ &l Railroads
[ BNSF

¥ ns k

5. Enter “new orleans la” as the destination of this route.

6. Click OK in the pick list of railroads that opens.

7. Click Run.
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8.  After processing, all feasible routes will be listed below. Note that the
number of available railroads and routes generated will be affected by the
Include/Exclude options in the Route Options dialog (see section 4.10).

Routes X | AutoRouter X

Route Options:

Route Preference:

Intermodal -

4

(©  ATLANTA, GA BINSF, CSXT, NS

@ MEW ORLEANS, LA BMSF, CM, CSXT, NS, UP

R

+) Enter Location As:

Station Mame, ST -

1 4004 CEXT

2 5158 NS

9. Click the View button for the second Norfolk Southern route to see its details
displayed in a single route window and drawn on the map.

B PCTMILER 23001

RIGOLET:

Miden n
G RIS g & ALK Tecmaloes 1016 — = 2

Latitude/Longtude: 34 12° 15015° N, 5218 580367 W (34204172 N, 88316371 W)

The options for an AutoRoute can be edited like any other single route — select
Options in the AutoRouter toolbar. This can be especially useful when the

PC*MILER|Rail User’s Guide 76



AutoRouter is relied on to generate a valid junction interchange and the route then
needs to be re-run for Fuel Surcharge mileage.

Click the AutoRouter tab to go back and examine another route. To clear the
AutoRouter, select the AutoRouter toolbar > Clear.
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Chapter

About ALK Technologies, Inc.

7.1 About ALK Technologies

ALK® Technologies, Inc., a Trimble® company headquartered in Princeton, NJ,
was founded in 1979 as a transportation industry pioneer. ALK harnesses the power
of information technology to enhance transportation and mobility, supporting
competitive advantage and improved quality of life.

Today, ALK is a global leader in GeoLogistics® solutions and navigation software,
focused on developing innovative solutions for transportation, logistics, mobile
workforces and consumers. Product lines include award-winning CoPilot®, a
leading source of GPS navigation software for fleets, mobile operators, hardware
OEMs, systems integrators, professional drivers and consumers. ALK’s
PC*MILER® is widely recognized as a transportation industry standard for routing,
mileage and mapping. ALK® Maps is a development platform designed for the
transportation industry and provides commercial routing, geocoding and mapping
visualization for enterprise applications.

See section 7.2 below for an overview of ALK’s Enterprise Solutions. For detailed
product information, visit us at www.alk.com or www.pcmiler.com.

- | ‘ L.L, ‘ PCGMILER

A TRIMBLE COMPANY
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7.2 Enterprise Solutions from ALK Technologies

PC*MILER

Commercially accepted, industry preferred. PC*MILER is the industry’s leading off-
the-shelf integrated, street-level routing and mileage solution. More than 95% of North
American for hire carriers, logistics companies and the majority of the Fortune 500 rely on
PC*MILER to maximize revenues and minimize costs, while providing their vehicles and
shipments the safest, most cost-effective routing available today.

The preferred commercially accepted routing, mileage and mapping software
Easily integrated with leading fuel optimization, routing & scheduling,
transportation and supply chain management systems, for complete customization
and standardization across your entire business

Maintain compliance by entering necessary breaks and stops when creating a
route, helping to generate more realistic ETAs. Dispatchers can easily customize
rest and break locations based on preferences, while still maintaining that their
driver stays HOS compliant.

Unique capability to send your planned route directly to the driver to follow
through CoPilot Truck* in-cab navigation, ensuring true route compliance and
guaranteeing your back office route plan is fully executed

Map data continuously updated to keep you current*

Only solution to provide Worldwide* and Rail* routing and map data

* Additional license required

PC*MILER Value Add-Ons

PC*MILER|Streets — Street-level routing, mileage and mapping software.
0 Reduce out-of-route mileage saving money, time, toll costs* and fuel costs
o0 Customize the map by avoiding or favoring roads per your needs

* Additional license required

PC*MILER|Tolls — Calculates the most cost-effective toll route or non-toll route,

factoring in additional mileage over costs.

o0 Know the real costs of your lanes instead of estimating or averaging toll costs
in your transportation planning or rate negotiations

o0 Stay competitive and profitable with precise operating costs and freight bill
calculations

PC*MILER|Traffic - Real-time and predictive traffic speed features.
o Improve hours of service compliance
0 Generate more accurate transit times and ETAs
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e PC*MILER|Worldwide - Point-to-point routing, mileage and mapping software
that generates routes, distances, maps and driving directions in over 230 countries
around the world.

0 Generate exact U.S. and worldwide DoD distances for freight rating
o Compliance with U.S. Department of Defense (DoD) and GSA distance
compliance for approved freight rating and billing

e PC*MILER|HazMat - Point to point and street-level routes, and mileage for
hauling hazardous materials and dangerous goods in the U.S. and Canada.
o0 Ensure driver compliance with DOT, nationwide hazmat, and nationwide
dangerous goods regulations
0 Ensure accurate driver pay and payroll auditing by providing hazmat-specific
mileage calculations

e PC*MILER|Rail - Generate point-to-point routes over the complete North
American railroad system.
o0 Minimize empty haulage costs by tracking empty and loaded mileage by rail
car, carrier, and state
0 See routes on a map and generate detailed route reports that include mileage
summaries by state and railroad, in addition to leg and cumulative miles for
via points and major cities

e PC*MILER|Energy - Unique solution that provides industry-critical routing and
mileage data you need to make accurate planning and billing decisions when
operating in the patch.

0 Generate precise mileage and distance using actual oil and gas lease roads for
accurate billing

o0 Calculate accurate travel times to and from wells, from well to well, or from
public to private oil and gas lease roads for enhanced dispatch planning

PC*MILER Seamless Integration

e PC*MILER|Connect - Interfaces PC*MILER routes, mileage and reports with
third-party and custom systems, such as transportation and logistics management
software systems.

o Client applications are able to retrieve PC*MILER distances, detailed driving
directions, drive times, state-by-state mileage summaries, stop optimization
functionalities and more.

o0 Interact with the PC*MILER database through thread-safe Application
Programming Interfaces (APIs) and access the features of choice
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e PC*MILER Web Services - Fulfills all PC*MILER routing, mileage and mapping
transactions in a simple hardware and software-agnostic system interface to any
computing platform.

o0 Generate truck-specific routes, maps, and driving directions online without the
need to purchase, install, or maintain computer software
o0 Software-as-a-Service (SaaS), developed in .NET

e Multi-Version Switch (MVS) - High-end function of PC*MILER|Connect that
serves as an integration tool designed to simultaneously support multiple versions
of PC*MILER that are installed on one server or on several different servers.

0 Main connection point to programmatically gain access to PC*MILER
0 Reduce hardware expenses by decreasing the number of network servers that
need to be supported along with their maintenance costs and setup fees

e PC*MILER|TCP/IP - Tool that provides an interface to PC*MILER|Connect
running in a Windows environment to an application residing on another
platform.

0 Opens cross platform communications in a thread-safe manner, giving you the
flexibility to transmit the output of PC*MILER|Connect to multiple networks
within your organization.

e PC*MILER|Spreadsheets - Access PC*MILER features and functionality from
within your own spreadsheet software.
0 Analyze transportation costs to and from customers
0 Enhance strategic planning and forecasting

e PC*MILER|Mapping - Interfaces PC*MILER routes and geographic data on
maps for integration with real-time dispatch and operations analysis programs.
o0 Integrate real-time maps into your dispatch operations
o Ideal for vehicle tracking, route visualization, and viewing geographic data

e PC*MILER|BatchPro - Simultaneously processes large volumes of origin-
destination pairs.
0 Generate leg and total mileage, cost and time estimates
o Easily populate your mileage database without additional software
programming effort

MAXIMIZE Your PC*MILER Experience

e CoPilot Truck — CoPilot Truck provides voice-guided, truck-specific in-cab
navigation. By using PC*MILER truck-specific routing, CoPilot Truck
effortlessly provides the optimal route.

0 Reduction of out-of-route mileage by 5-10% annually (on average)
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0 Increase in back office productivity by lessening driver support needs

e RouteSync & TripDirect — With RouteSync, dispatchers can send PC*MILER

optimized routes directly to drivers running CoPilot Truck.

o Operational consistency between navigation and PC*MILER driver pay,
rating, billing, costing, load planning and fuel tax reporting

0 Reduction of non-revenue mileage by minimizing the mileage variance

between actual and planned routes

1-800-377-MILE
www.alk.com
www.pcmiler.com

LB BN

A TRIMBLE COMPANY

@
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Abbreviations for States/Provinces
In the U.S. and Canada

Appendix

The list below can be used as a reference for route entry. All states/provinces that
have at least one active railroad are listed. For Mexican estados, see Appendix B.

State Name — U.S. Abbreviation FIPS
Alabama AL 01
Alaska AK 02
Arizona AZ 04
Arkansas AR 05
California CA 06
Colorado CcoO 08
Connecticut CT 09
Delaware DE 10
District of Columbia DC 11
Florida FL 12
Georgia GA 13
Idaho ID 16
Ilinois IL 17
Indiana IN 18
lowa 1A 19
Kansas KS 20
Kentucky KY 21
Louisiana LA 22
Maine ME 23
Maryland MD 24
Massachusetts MA 25
Michigan Ml 26
Minnesota MN 27
Mississippi MS 28
Missouri MO 29
Montana MT 30
Nebraska NE 31
Nevada NV 32
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New Hampshire NH 33

New Jersey NJ 34
New Mexico NM 35
New York NY 36
North Carolina NC 37
North Dakota ND 38
Ohio OH 39
Oklahoma OK 40
Oregon OR 41
Pennsylvania PA 42
Rhode Island RI 44
South Carolina SC 45
South Dakota SD 46
Tennessee TN 47
Texas ™ 48
Utah uT 49
Vermont VT 50
Virginia VA 51
Washington WA 53
West Virginia wvVv 54
Wisconsin WI 55
Wyoming WY 56
Canadian Province Abbreviation FIPS
Alberta AB 84
British Columbia BC 83
Manitoba MB 86
New Brunswick NB 89
Newfoundland & Labrador NF 92
Northwest Territory NT 82
Nova Scotia NS 91
Ontario ON 87
Prince Edward Island PE 90
Quebec PQ 88
Saskatchewan SK 85
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Appendix

Abbreviations for Mexican Estados

PC*MILER|Rail requires Mexican estado abbreviations to be entered when
entering Mexican locations on a route. All estados that have at least one active
railroad are listed.

Abbrev. Estado FIPS
AG Aguascalientes 94
BJ Baja California 95
BS Baja California Sur 96
CP Campeche 97
CH Chiapas 98
Cl Chihuahua 99
Cu Coahuila 100
CL Colima 101
DF Distrito Federal 102
DG Durango 103
GJ Guanajuato 104
HG Hidalgo 106
JA Jalisco 107
EM Mexico (Estado) 108
MH Michoacan 109
MR Morelos 110
NA Nayarit 111
NL Nuevo Leon 112
OA Oaxaca 113
PU Puebla 114
QA Queretaro 115
SL San Luis Potosi 117
SI Sinaloa 118
SO Sonora 119
TA Tabasco 120
™ Tamaulipas 121
TL Tlaxcala 122
VL Veracruz 123
YC Yucatan 124
ZT Zacatecas 125
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Appendix

Fuel Surcharge Railroad Reference

Fuel surcharge calculations are now required by the Surface Transportation Board
ruling STB Ex Parte No. 661. The railroads listed below have chosen
PC*MILER|Rail Practical miles as their standard for fuel surcharge calculations.
All other major railroads chose PC*MILER|Rail Shortest miles as the standard.

Therefore, PC*MILER|Rail uses Shortest miles by default when Fuel Surcharge
routes are generated but uses Practical routing for the railroads listed below.

SCAC RRN Routing Option
CLP 169 Practical
CN 103 Practical
GMRC 314 Practical
KCS 400 Practical
MPLI 984 Practical
NYOG 585 Practical
TCWR 768 Practical
VTR 817 Practical
WACR 812 Practical
WSOR 879 Practical
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Appendix

SCAC

AB
ABL
ABR
ABS
ABWR
ACJR
ACWR
ADBF
AERC
AF
AFR
AGCR
AGR
AIKR
AKDN
AKMD
ALAB
ALLN
ALM
ALS
ALT
AM
AMTK
AN
ANR
AO
AOK
AOR
APA
APD
APNC
APR
AR
ARA
ARC

Railroads Sorted by SCAC

Railroad Name

ANN ARBOR RAILROAD

AKRON BARBERTON CLUSTER RAILWAY COMPANY
ALAMEDA BELT LINE

ATHENS LINE LLC, THE

ALABAMA SOUTHERN RAILROAD

ALABAMA WARRIOR RAILWAY, LLC.

ASHTABULA CARSON & JEFFERSON RAILROAD
ABERDEEN CAROLINA & WESTERN RAILWAY CO
ADRIAN & BLISSFIELD RAIL ROAD COMPANY
ALBANY & EASTERN RAILROAD COMPANY
ALABAMA & FLORIDA RAILWAY CO

AMADOR FOOTHILLS RAILROAD

ALAMO GULF COAST RAILROAD COMPANY
ALABAMA & GULF COAST RAILWAY LLC

AIKEN RAILWAY COMPANY, LLC

ACADIANA RAILWAY COMPANY

ARKANSAS MIDLAND RAILROAD CO INC
ALABAMA RAILROAD CO INC

ALLENTOWN AND AUBURN RAILROAD

ARKANSAS LOUISIANA & MISSISSIPPI RAILROAD COMPANY
ALTON & SOUTHERN RAILWAY COMPANY
AIRLAKE TERMINAL RAILWAY COMPANY
ARKANSAS AND MISSOURI RAILROAD CO
AMTRAK-NATIONAL RAILROAD PASSENGER CORPORATION
AN RAILWAY LLC

ANGELINA & NECHES RIVER RAILROAD COMPANY
APPALACHIAN & OHIO RAILROAD INC
ARKANSAS-OKLAHOMA RAILROAD INC

THE ALIQUIPPA & OHIO RIVER RAILROAD COMPANY
APACHE RAILWAY COMPANY

ALBANY PORT DISTRICT

APPANOOSE COUNTY COMMUNITY RAILROAD INC
ALBERTA PRAIRIE RAILWAY

ABERDEEN AND ROCKFISH RAILROAD COMPANY
ARCADE AND ATTICA RAILROAD CORPORATION
ALEXANDER RAILROAD COMPANY
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ARE
ARR
ARS
ART
ARZC
ASR
ASRY
AT
ATLT
ATN
ATW
AUT
AVR
AVRR
AWRR
AWRY
AWW
AZCR
AZER
BAYL
BB
BCLR
BCR
BCRY
BDR
BDRV
BDTL
BDW
BEEM
BFT
BGS
BH
BHP
BHR
BHRR
BHWY
BJRR
BJRY
BKRR
BLMR
BLOL
BLR

A & RLINE INC

ALASKA RAILROAD CORPORATION
ARKANSAS SOUTHERN RAILROAD

A & R TERMINAL RAILROAD

ARIZONA & CALIFORNIA RAILROAD CO
ALLEGHENY SOUTHERN RAILROAD INC
ASHLAND RAILWAY CO

AFFTON TERMINAL SERVICES RAILROAD, LLC
AT & L RAILROAD CO INC

ALABAMA & TENNESSEE RIVER RAILWAY LLC
ATLANTIC & WESTERN RAILWAY, L P
AUTAUGA NORTHERN RAILROAD LLC
ALLEGHENY VALLEY RAILROAD COMPANY
AG VALLEY RAILROAD, LLC

AUSTIN WESTERN RAILROAD

ADAMS WARNOCK RAILWAY, INC.

ALGERS WINSLOW AND WESTERN RAILWAY COMPANY
ARIZONA CENTRAL RAILROAD INC

ARIZONA EASTERN RAILWAY COMPANY

BAY LINE RAILROAD L L C, THE
BUCKINGHAM BRANCH RAILROAD COMPANY
BAY COLONY RAILROAD CORPORATION

BAY COAST RAILROAD
BARRIE-COLLINGWOOD RAILWAY

SPARROWS POINT RAIL, LLC D/B/A BALTIMORE INDUSTRIAL RAILROAD

BELVIDERE & DELAWARE RIVER RAILWAY COMPANY INC
BALLARD TERMINAL RAILROAD CO LLC
BIGHORN DIVIDE & WYOMING RAILROAD INC
BEECH MOUNTAIN RAILROAD COMPANY

BIG FOUR TERMINAL RAILROAD, LLC

BIG SKY RAIL CORP

B&H RAIL CORP

BHP NEVADA RAILROAD COMPANY
BROOKHAVEN RAIL, LLC

BIRMINGHAM TERMINAL RAILWAY LLC

BOOT HILL & WESTERN RAILWAY CO LC

BAJA CALIFORNIA RAILROAD INC
BURLINGTON JUNCTION RAILWAY

BATTEN KILL RAILROAD INC

BLUE MOUNTAIN RAILROAD INC

BLOOMER LINE, THE

BLACKLANDS RAILROAD THE
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BLU
BML
BNG
BNML
BNSF
BOCT
BOP
BPRR
BRAN
BRC
BRG
BRR
BRW
BSDA
BSOR
BSR
BSVY
BTR
BVRR
BVRY
BXN
CA
CAGY
CALA
CAMY
CBNS
CBR
CBRW
CBRY
CCET
CCH
CCKY
CCPN
CCRA
CCRL
CCRR
CCT
CCuo
CEIW
CEMR
CERA
CERR

BLUE RIDGE SOUTHERN RAILROAD LLC
BELFAST AND MOOSEHEAD LAKE RAILROAD COMPANY
BLACKWELL NORTHERN GATEWAY RAILROAD COMPANY
BURLINGTON NORTHERN (MANITOBA) LTD

BNSF RAILWAY COMPANY

BALTIMORE AND OHIO CHICAGO TERMINAL RAILROAD CO
BORDER PACIFIC RAILROAD CO

BUFFALO & PITTSBURGH RAILROAD INC

BRANDON RAILROAD LLC

BELT RAILWAY COMPANY OF CHICAGO

BROWNSVILLE & RIO GRANDE INTERNATIONAL RAILWAY, LLC
BATTLE RIVER RAILWAY NGC INC

BLACK RIVER & WESTERN CORPORATION

BI-STATE DEVELOPMENT AGENCY

BUFFALO SOUTHERN RAILROAD INC

BIG SPRING RAIL SYSTEM, INC.

BOONE & SCENIC VALLEY RAILROAD

BOUNDARY TRAIL RAILWAY COMPANY INC.

BOISE VALLEY RAILROAD, INC.

BRANDYWINE VALLEY RAILROAD COMPANY

BAUXITE & NORTHERN RAILWAY COMPANY
CHESAPEAKE & ALBEMARLE

COLUMBUS AND GREENVILLE RAILWAY

CAROLINA SOUTHERN RAILROAD COMPANY, THE
CAMP CHASE RAILWAY COMPANY, LLC

CAPE BRETON & CENTRAL NOVA SCOTIA RAILWAY
COOS BAY RAILROAD OPERATING CO., LLC

COLUMBIA BASIN RAILROAD COMPANY INC

COPPER BASIN RAILWAY INC

CCET, LLC

COLUMBUS & CHATTAHOOCHEE RAILROAD, INC
CHATTOOGA & CHICKAMAUGA RAILWAY CO

CORPUS CHRISTI TERMINAL RAILROAD INC

CAMP CHASE INDUSTRIAL RAILROAD CORPORATION
CLEVELAND COMMERCIAL RAILROAD COMPANY LLC
CLAREMONT CONCORD RAILROAD CORPORATION
CENTRAL CALIFORNIA TRACTION COMPANY
CHICAGO-CHEMUNG RAILROAD CORP

CENTRAL INDIANA & WESTERN RAILROAD CO INC
CENTRAL MANITOBA RAILWAY INC

CENTRAL RAILROAD COMPANY OF INDIANAPOLIS
CICERO CENTRAL RAILROAD, L.L.C.
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CF
CFE
CFL
CFNR
CFS
CFWR
CGR
CHAT
CHB
CHR
CHRC
CHRR
CHS
Cl
CIC
CIND
CIR
CIRR
CIRY
CKIN
CLC
CLCY
CLNA
CLP
CM
CMPA
cMQ
CMR
CMRR
CMSL
CN
CNAT
CNOW
CNUR
CNYK
CNZR
COEH
COER
cop
CORP
CORY
CPDR

CAPE FEAR RAILWAYS INC

CHICAGO FT WAYNE & EASTERN A DIVISION OF CENTRAL RAILROAD OF INDIANAPOLIS INC
C F LANAUDIERE INC

CALIFORNIA NORTHERN RAILROAD COMPANY LP

TRAINS TOURISTIQUES DE CHAUDIERE-APPALACHES INC. DBA CHEMIN DE FE
CANEY FORK AND WESTERN RR

CG RAILWAY INC

CHATTAHOOCHEE BAY RAILROAD INC

CLEVELAND HARBOR BELT RAILROAD, LLC

CHESTNUT RIDGE RAILWAY COMPANY

CHAPARRAL RAILROAD COMPANY INC

CHESAPEAKE RAILROAD COMPANY
CHARLOTTE SOUTHERN RAILROAD COMPANY

CAMBRIA AND INDIANA RAILROAD COMPANY

CEDAR RAPIDS & IOWA CITY RAILWAY COMPANY

CENTRAL RAILROAD OF INDIANA

CITY OF ROCHELLE ILLINOIS

CHATTAHOOCHEE INDUSTRIAL RAILROAD

CENTRAL ILLINOIS RAILROAD COMPANY

CHESAPEAKE AND INDIANA RAILROAD COMPANY INC

COLUMBIA & COWLITZ RAILWAY LLC

CHESSIE LOGISTICS CO., LLC

CAROLINA COASTAL RAILWAY INC

CLARENDON AND PITTSFORD RAILROAD COMPANY, THE

CENTRAL MONTANA RAIL INC

MADISON RAILROAD (A DIV OF CITY OF MADISON PORT AUTHORITY)
CENTRAL MAINE & QUEBEC RAILWAY

CENTRAL MIDLAND RAILWAY COMPANY

COMSTOCK MOUNTAIN LION RAILROAD, INC.

CAPE MAY SEASHORE LINES

CANADIAN NATIONAL RAILWAYS

CN AQUATRAIN

COLUMBIA & NORTHERN RAILWAY CO

C & NC RAILROAD CORPORATION

CENTRAL NEW YORK RAILROAD CORPORATION

CENTRAL NEW ENGLAND RAILROAD CO INC

CONECUH VALLEY RAILWAY LLC

CRAB ORCHARD & EGYPTIAN RAILWAY A DIVISION OF PROGRESSIVE RAIL IN
CITY OF PRINEVILLE RAILWAY

CENTRAL OREGON & PACIFIC RAILROAD INC

COLUMBIA & READING RAILWAY CO

CAROLINA PIEDMONT DIVISION SOUTH CAROLINA CENTRAL RAILROAD COMPANY INC
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CPMY
CPR
CPRS
CRL
CSCD
CSKR
CsoO
CSR
CSS
CSXT
CcT
CT™M
CTN
CTR
CTRR
CTRW
CTXR
CUOH
CVR
CVRC
CVYR
cw
CWA
CwcCy
CWR
CWRO
CWRY
CZRY
DAIR
DAKS
DALT
DC
DCLR
DCON
DCRR
DGNO
DGVR
DL
DLWR
DMM
DMVW
DN

COOPERSVILLE AND MARNE RAILWAY COMPANY
CATERPARROTT RAILNET, LLC

CANADIAN PACIFIC RAILWAY

CHICAGO RAIL LINK

CASCADE AND COLUMBIA RIVER RAILROAD COMPANY
C & S RAILROAD CORPORATION
CONNECTICUT SOUTHERN RAILROAD INC

CAMDEN & SOUTHERN RAILROAD INC

CHICAGO SOUTHSHORE & SOUTH BEND RAILROAD
CSX TRANSPORTATION

COLUMBIA TERMINAL

CHICAGO TERMINAL RAILROAD

CANTON RAILROAD COMPANY

CLINTON TERMINAL RAILROAD COMPANY
CLOQUET TERMINAL RAILROAD COMPANY INC
CARLTON TRAIL RAILWAY COMPANY

CENTRAL TEXAS & COLORADO RIVER RAILWAY, LLC
COLUMBUS & OHIO RAILROAD COMPANY
CIMARRON VALLEY RAILROAD LC

PROGRESSIVE RAIL INC D/B/A CANNON VALLEY RAILROAD COMPANY
CADDO VALLEY RAILROAD COMPANY

COLORADO & WYOMING RWY CO

CENTRAL WASHINGTON RAILROAD COMPANY
CALDWELL COUNTY RAILROAD COMPANY

CWRR INC

CLEVELAND WORKS RAILWAY COMPANY
COMMONWEALTH RAILWAY INC

CARRIZO GORGE RAILWAY INC

D & | RAILROAD COMPANY

DAKOTA SHORT LINE

DALLAS TERMINAL RAILWAY

DELRAY CONNECTING RAILROAD COMPANY
DELAWARE COAST LINE RR CO

DETROIT CONNECTING RAILROAD COMPANY
DUBOIS COUNTY RAILROAD

DALLAS GARLAND & NORTHEASTERN RAILROAD INC
DURBIN & GREENBRIER VALLEY RAILROAD INC
DELAWARE-LACKAWANNA RAILROAD CO INC
DEPEW LANCASTER & WESTERN RAILROAD CO INC
DANSVILLE AND MOUNT MORRIS RAILROAD COMPANY, THE
DAKOTA MISSOURI VALLEY & WESTERN RAILROAD INC
DAKOTA NORTHERN RAILROAD INC
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DQE
DR
DRIR
DSC
DSRC
DSRR
DT
DV
DVR
DVS
EACH
EARY
EBG
EBSR
EBTC
ECBR
ECO
ECTB
ECYR
EDW
EE
EEC
EFRR
EIRC
EIRR
EJR
ELKR
ELS
EMHR
EMRY
ENR
ESPN
ETL
ETRY
EV
EVWR
EWG
EWR
EZR
FC
FCCM
FCEN

DEQUEEN & EASTERN RAILROAD LLC

DARDANELLE & RUSSELLVILLE RAILROAD COMPANY
DENVER ROCK ISLAND RAILROAD

DRAKE SWITCHING COMPANY, LLC

DAKOTA SOUTHERN RAILWAY COMPANY

DELTA SOUTHERN RAILROAD COMPANY

DECATUR JUNCTION RAILWAY COMPANY
DELAWARE VALLEY RAILWAY COMPANY INC

DEVCO RY (CAPE BRETON DEVELOPMENT CORP)
DELTA VALLEY & SOUTHERN RAILWAY COMPANY
EAST CAMDEN & HIGHLAND RR CO

EASTERN ALABAMA RAILWAY

EASTERN BERKS GATEWAY RAILROAD COMPANY
EAST BROOKFIELD & SPENCER RAILROAD LLC

EAST BROAD TOP CONNECTING RAILROAD

EAST COOPER AND BERKELEY RAILROAD COMPANY
ECORAIL INC

EAST CHATTANOOGA BELT RAILWAY COMPANY
EASTSIDE COMMUNITY RAIL, LLC

EL DORADO AND WESSON RAILWAY COMPANY
ELLIS & EASTERN COMPANY

EAST ERIE COMMERCIAL RAILROAD

EFFINGHAM RAILROAD COMPANY

EASTERN ILLINOIS RAILROAD COMPANY

EASTERN IDAHO RAILROAD INC

EAST JERSEY RAILROAD AND TERMINAL COMPANY
ELK RIVER RAILROAD INC

ESCANABA AND LAKE SUPERIOR RAILROAD COMPANY
EAST MAHANOY & HAZELTON RAILROAD COMPANY
EASTERN MAINE RAILWAY COMPANY

E & N RAILWAY COMPANY (1998) LTD

EAST PENN RAILROAD LLC

ESSEX TERMINAL RAILWAY COMPANY THE

EAST TENNESSEE RAILWAY, L P

EVERETT RAILROAD

EVANSVILLE WESTERN RAILWAY INC

EASTERN WASHINGTON GATEWAY RAILROAD COMPANY
ELKHART & WESTERN RAILROAD CO
ELIZABETHTOWN INDUSTRIAL RAILROAD, LLC
FULTON COUNTY RAILROAD INC

COMPANIA DE FERROCARRILES CHIAPAS MAYAB SA DE CV
FLORIDA CENTRAL RAILROAD CO

PC*MILER|Rail User’s Guide 92



FCR
FCRD
FEC
FGLK
FIR
FMID
FMR
FMRC
FNOR
FP
FRR
FRVT
FSR
FSRR
FWCR
FWDB
FWWR
FXE
GC
GCK
GCW
GDLK
GET
GEXR
GFR
GFRR
GITM
GLC
GLSR
GMR
GMRC
GNBC
GNPR
GNRR
GOGR
GR
GRD
GRLW
GRNW
GRR
GRRY
GRW

FULTON COUNTY RAILWAY LLC

FIRST COAST RAILROAD INC

FLORIDA EAST COAST RAILWAY, LLC

FINGER LAKES RAILWAY CORP

FLATS INDUSTRIAL RAILROAD COMPANY
FLORIDA MIDLAND RAILROAD CO INC

FORTY MILE RAILROAD, INC.

FARMRAIL CORPORATION

FLORIDA NORTHERN RAILROAD COMPANY INC
FORDYCE AND PRINCETON RAILROAD CO
FALLS ROAD RAILROAD CO INC

FORE RIVER TRANSPORTATION CORPORATION
FORT SMITH RAILROAD CO
FERROSURSADECYV

FLORIDA WEST COAST RAILROAD INC

FORT WORTH & DALLAS BELT RAILROAD

FORT WORTH & WESTERN RAILROAD
FERROCARRIL MEXICANO SADECYV

GEORGIA CENTRAL RAILWAY L P

GEORGES CREEK RAILWAY

GARDEN CITY WESTERN RAILWAY COMPANY, THE
GRAND ELK RAILROAD, LLC.

GETTYSBURG & NORTHERN RAILROAD CO
GODERICH-EXETER RAILWAY COMPANY LTD
GRAND FORKS RAILWAY COMPANY

GEORGIA & FLORIDA RAILWAY, LLC

GOLDEN ISLES TERMINAL RAILROAD INC
GREAT LAKES CENTRAL RAILROAD

GLOSTER SOUTHERN RAILROAD COMPANY
GEORGIA MIDLAND RAILROAD INC

GREEN MOUNTAIN RAILROAD CORPORATION
GRAINBELT CORPORATION

GNP RLY INC.

GEORGIA NORTHEASTERN RAILROAD CO
GEAUX GEAUX RAILROAD LLC

GRAND RAPIDS EASTERN RAILROAD INC
GARDENDALE RAILROAD, INC

GREENVILLE & WESTERN RAILWAY COMPANY LLC
GREAT NORTHWEST RAILROAD INC
GEORGETOWN RAILROAD COMPANY

THE GREAT LAKE PORT CORPORATION D/B/A THE GRAND RIVER RAILWAY
GARY RAILWAY COMPANY
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GRWR
GRYR
GS
GSM
GSR
GSWR
GTR
GTRA
GU
GVSR
GWR
GWRC
GWRS
GWWE
HAL
HB
HBRY
HCRR
HCRY
HE
HESR
HIRR
HLSC
HMCR
HN
HOB
HOG
HOS
HPTD
HR
HRR
HRRC
HRS
HRT
HSR
HSRR
HTR
IAIS
IANR
IANW
IARR
IATR

GREAT WALTON RAILROAD CO, THE

GRENADA RAILROAD LLC D/B/A GRENADA RAILWAY
GEORGIA SOUTHERN RAILWAY CO.

GREAT SMOKEY MOUNTAINS RAILWAY INC

GREAT SANDHILLS RAILWAY, LTD.

GEORGIA SOUTHWESTERN RAILROAD INC

GREAT RIVER RAILROAD

GOLDEN TRIANGLE RAILROAD LLC

GRAFTON AND UPTON RAILROAD COMPANY
GALVESTON RAILROAD LP

GREAT WESTERN RAILWAY OF COLORADO LLC
GEORGIA WOODLANDS RAILROAD CO

GREAT WESTERN RAILWAY LTD

GATEWAY EASTERN RAILWAY COMPANY

HILTON & ALBANY RAILOAD, INC.

HAMPTON & BRANCHVILLE RAILROAD COMPANY
HUDSON BAY RAILWAY COMPANY

HONEY CREEK RAILROAD INC

HURON CENTRAL RAILWAY INC

HOLLIS & EASTERN RR CO

HURON AND EASTERN RAILWAY COMPANY INC
HAINESPORT INDUSTRIAL RAILROAD LLC

HAMPTON RAILWAY INC

HUNTSVILLE & MADISON COUNTY RAILROAD AUTHORITY
HUTCHINSON AND NORTHERN RAILWAY COMPANY, THE
HENDERSON OVERTON BRANCH

HEART OF GEORGIA RAILROAD INC

HOOSIER SOUTHERN RAILROAD

HIGH POINT THOMASVILLE & DENTON RAILROAD COMPANY
HERITAGE RAILROAD CORP

HONDO RAILWAY LLC

HOUSATONIC RAILROAD COMPANY INC
HOLLIDAYSBURG AND ROARING SPRING RAILROAD COMPANY
HARTWELL RAILROAD COMPANY

HAINESPORT SECONDARY, LLC

HARDIN SOUTHERN RAILROAD INC

HEART OF TEXAS RAILROAD, LP

IOWA INTERSTATE RAILROAD LTD

IOWA NORTHERN RAILROAD

IOWA NORTHWESTERN RAILROAD

IOWA RIVER RAILROAD INC

IOWA TRACTION RAILWAY COMPANY
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IBT INTERNATIONAL BRIDGE AND TERMINAL COMPANY, THE

ICRK INDIAN CREEK RAILROAD COMPANY

IERR INDIANA EASTERN RAILROAD LLC

IHB INDIANA HARBOR BELT RAILROAD COMPANY

ILW ILLINOIS WESTERN RAILROAD COMPANY

IMRR ILLINOIS & MIDLAND RAILROAD INC

IN INDIANA NORTHEASTERN RAILROAD COMPANY INC
INPR IDAHO NORTHERN & PACIFIC RAILROAD COMPANY
INRD INDIANA RAIL ROAD CORPORATION

IORY INDIANA & OHIO RAILWAY COMPANY

IR ILLINOIS RAILWAY, LLC

ISR IOWA SOUTHERN RAILROAD COMPANY

ISRR INDIANA SOUTHERN RAILROAD COMPANY INC

ISRY IOWA SOUTHERN RAILWAY COMPANY

ISW INDIANA SOUTHWESTERN RAILWAY CO

JAIL JACKSON & LANSING RAILROAD COMPANY

JKL JKLINE INC

JVRR JUNIATA VALLEY RAILROAD COMPANY

KAW KAW RIVER RAILROAD

KBSR KANKAKEE BEAVERVILLE AND SOUTHERN RAILROAD COMPANY
KCS KANSAS CITY SOUTHERN RAILWAY COMPANY
KCSM KANSAS CITY SOUTHERN DE MEXICOSDERLDECYV
KCTL KANSAS CITY TRANSPORTATION CO LLC

KE KANSAS EASTERN RAILROAD INC

KFR KETTLE FALLS INTERNATIONAL RAILWAY LLC

KGTR KINGMAN TERMINAL RAILROAD, LLC

KIR KISKI JUNCTION RAILROAD

KIRY KEOKUK JUNCTION RAILWAY

KKRR KNOX & KANE RAILROAD COMPANY

KNOR KLAMATH NORTHERN RAILWAY COMPANY
KNWA KANAWHA RIVER RAILROAD L.L.C.

KO KANSAS & OKLAHOMA RAILROAD INC

KPR KELOWNA PACIFIC RAILWAY LTD

KRL KASGRO RAIL LINES

KRR KIAMICHI RAILROAD COMPANY LLC

KSRY KOSCIUSKO SOUTHWESTERN RAILWAY

KT KENTUCKY AND TENNESSEE RAILWAY

KTR KENDALLVILLE TERMINAL RAILWAY CO

KWT KWT RAILWAY INC

KXHR KNOXVILLE & HOLSTON RIVER RAILROAD CO INC
KYLE KYLE RAILROAD COMPANY

LAJ LOS ANGELES JUNCTION RAILWAY COMPANY
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LAL
LAS
LBR
LBWR
LC
LCR
LCRI
LDRR
LER
LFCD
LI
LINC
LIRC
LIRR
LKRR
LLR
LMIC
LMR
LNAL
LNVT
LNW
LRPA
LRS
LRWN
LRWY
LRY
LS

LSI
LSRC
LT
LVR
LVRB
LVRC
LVRJ
LVRR
LVSW
LW
LXVR
MAA
MAL
MAN
MAUP

LIVONIA, AVON & LAKEVILLE RAILROAD CORPORATION
LOUISIANA SOUTHERN RAILROAD

LOWVILLE AND BEAVER RIVER RAILROAD COMPANY THE
LUBBOCK & WESTERN RAILWAY, L.L.C.

LANCASTER & CHESTER RAILROAD, LLC.

LAKE COUNTY RAILROAD

LONG CREEK RAILROAD COMPANY INC

LOUISIANA & DELTA RAILROAD INC

LOGANSPORT & EEL RIVER SHORT-LINE CO INC

LINEA COAHUILA DURANGO SA DE CV

LONG ISLAND RAILROAD COMPANY

LEWIS & CLARK RAILWAY CO

LOUISVILLE & INDIANA RAILROAD COMPANY

LAPEER INDUSTRIAL RAILROAD COMPANY

LITTLE KANAWHA RIVER RAIL INC

LAKE LINE RAILROAD INC.

LAKE MICHIGAN AND INDIANA RAILROAD COMPANY
LAST MOUNTAIN RAILWAY

LOUISVILLE NEW ALBANY & CORYDON RAILROAD
LANDISVILLE TERMINAL & TRANSFER COMPANY
LOUISIANA AND NORTH WEST RAILROAD COMPANY, THE
LITTLE ROCK PORT RAILROAD

LAURINBURG AND SOUTHERN RAILROAD COMPANY
LITTLE ROCK & WESTERN RAILWAY, L P

LEHIGH RAILWAY, LLC.

LRY LLC.

LUZERNE AND SUSQUEHANNA RAILWAY COMPANY
LAKE SUPERIOR & ISHPEMING RAILROAD COMPANY
LAKE STATE RAILWAY COMPANY

LAKE TERMINAL RAILROAD COMPANY, THE
LANDISVILLE RAILROAD, LLC

LEHIGH VALLEY RAIL MANAGEMENT LLC - BETHLEHEM DIVISION
LAMOILLE VALLEY RAILROAD COMPANY

LEHIGH VALLEY RAIL MANAGEMENT LLC - JOHNSTOWN DIVISION
LYCOMING VALLEY RAILROAD COMPANY

LONGVIEW SWITCHING COMPANY

LOUISVILLE AND WADLEY RAILWAY COMPANY
LUXAPALILA VALLEY RAILROAD INC

MAGMA ARIZONA RAILROAD COMPANY

MICHIGAN AIR-LINE RAILWAY CO

MANNING RAIL, INC

MANATEE COUNTY PORT AUTHORITY
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MAW
MC
MCER
MCLR
MCR
MCSA
MD
MDDE
MDS
MDW
ME
MERR
MET
METW
MGRI
MH
MHC
MHWA
MIDH
M)
MMA
MMID
MMRR
MMT
MNA
MNBR
MNC
MNJ
MNN
MNNR
MNR
MPLI
MQT
MRI
MRL
MS
MSCI
MSE
MSN
MSO
MSR
MSRW

MAUMEE & WESTERN RAILROAD CORPORATION
MASSACHUSETTS COASTAL RAILROAD LLC

MASSACHUSETTS CENTRAL RAILROAD CORPORATION
MCLAUGHLIN LINE RAILROAD

MCCLOUD RAILWAY COMPANY

MOSCOW, CAMDEN & SAN AUGUSTINE RAILROAD

C&J RAILROAD COMPANY D/B/A MISSISSIPPI DELTA RAILROAD
MARYLAND AND DELAWARE RAILROAD COMPANY

MERIDIAN SOUTHERN RAILWAY LLC

MINNESOTA DAKOTA & WESTERN RAILWAY COMPANY
MORRISTOWN & ERIE RAILWAY INC

MORRISTOWN & ERIE RAILWAY INC D/B/A MAINE EASTERN RAILROAD
MODESTO AND EMPIRE TRACTION COMPANY

MUNICIPALITY OF EAST TROY WISCONSIN

MG RAIL INC

MT HOOD RAILROAD CO

MOHALL CENTRAL RAILROAD INC

MOHAWK ADIRONDACK & NORTHERN RAILROAD CORP
MIDDLETOWN & HUMMELSTOWN RAILROAD COMPANY
MANUFACTURERS JUNCTION RAILWAY COMPANY
MONTREAL MAINE AND ATLANTIC RAILWAY LTD

MARYLAND MIDLAND RAILWAY INC

MID-MICHIGAN RAILROAD INC

MISSION MOUNTAIN RAILROAD

MISSOURI & NORTHERN ARKANSAS RAILROAD COMPANY INC
M&B RAILROAD LLC

MOTIVE RAIL INC D/B/A MISSOURI NORTH CENTRAL RAILROAD
MIDDLETOWN & NEW JERSEY RAILWAY LLC

MINNESOTA NORTHERN RAILROAD INC

MINNESOTA COMMERCIAL RAILWAY CO

MAINE NORTHERN RAILWAY COMPANY

MINNESOTA PRAIRIE LINE INC

MARQUETTE RAIL LLC

MOHALL RAILROAD INC

MONTANA RAIL LINK INC

MICHIGAN SHORE RAILROAD INC

MISSISSIPPI CENTRAL RAILROAD COMPANY

MISSISSIPPI EXPORT RAILROAD COMPANY

BALLARD TERMINAL RAILROAD COMPANY LLC D/B/A MEEKER SOUTHERN RAILROAD
MICHIGAN SOUTHERN RAILROAD CO INC

MISSISSIPPI SOUTHERN RAILROAD

MISSISSIPPIAN RAILWAY COOPERATIVE INC
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MSTR
MSV
MSWY
MTNR
MVP
MVRY
MVT
NAUG
NBER
NBSR
NCA
NCIR
NCPR
NCRC
NCRL
NCVA
NCYR
NDCR
NECR
NEGS
NENE
NERR
NFTS
NHCR
NHN
NHRR
NHVT
NJRC
NKCR
NLA
NLR
NLRL
NMGR
NNW
NOGC
NOKL
NOPB
NOW
NPB
NPR
NRI
NS

MASSENA TERMINAL RAILROAD COMPANY, THE
MISSISSIPPI & SKUNA VALLEY RAILROAD LLC
MINNESOTA SOUTHERN RAILWAY INC

MISSISSIPPI TENNESSEE RAILROAD LLC

MISSOURI & VALLEY PARK RAILROAD CORP

MAHONING VALLEY RAILWAY COMPANY, THE

MT VERNON TERMINAL RAILWAY INC

NAUGATUCK RAILROAD COMPANY INC

NITTANY & BALD EAGLE RAILROAD CO

NEW BRUNSWICK SOUTHERN RAILWAY COMPANY LIMITED
NORTH CAROLINA & ATLANTIC RAILROAD

NEW CASTLE INDUSTRIAL RAILROAD

NORTH CAROLINA PORTS RAILWAY COMMISSION
NEBRASKA CENTRAL RAILROAD COMPANY

NC RAILROAD INC

NORTH CAROLINA & VIRGINIA RAILROAD CO INC

NASH COUNTY RAILROAD CORP

N D C RAILROAD COMPANY

NEW ENGLAND CENTRAL RAILROAD INC

NEW ENGLAND SOUTHERN RAILROAD CO INC
NEBRASKA NORTHEASTERN RAILWAY COMPANY
NASHVILLE AND EASTERN RAILROAD CORP

THE NELSON AND FT. SHEPPARD RAILWAY CORPORATION
NEW HAMPSHIRE CENTRAL RAILROAD INC

NEW HAMPSHIRE NORTHCOAST CORP

NEW HOPE & IVYLAND RAILROAD

NEW HAMPSHIRE AND VERMONT RAILROAD COMPANY
NEW JERSEY RAIL CARRIER LLC

NEBRASKA KANSAS & COLORADO RAILNET INC

NORTH LOUISIANA & ARKANSAS RAILROAD
NORTHERN LINES RAILWAY LLC
NORTHERN LIGHTS RAIL LTD.

NEW MEXICO GATEWAY RAILROAD LLC

NEBRASKA NORTHWESTERN RAILROAD INC.

NEW ORLEANS & GULF COAST RAILWAY COMPANY INC
NORTHWESTERN OKLAHOMA RAILROAD COMPANY
NEW ORLEANS PUBLIC BELT RAILROAD

NORTHERN OHIO & WESTERN RAILWAY LTD

NORFOLK & PORTSMOUTH BELT LINE RAILROAD COMPANY
NORTHERN PLAINS RAILROAD INC

NEBKOTA RAILWAY INC

NORFOLK SOUTHERN RAILWAY COMPANY (NORFOLK SOUTHERN)
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NSHR
NSR
NTRY
NTZR
NVRR
NWP
NWR
NYA
NYGL
NYLE
NYNJ
NYOG
NYSW
OAR
OCTL
OERR
OHCR
OHIC
OHIO
OHPA
OHRY
OKAN
OLB
oLo
OLYR
OMID
ONCT
ONT
OPE
OPR
OPT
ORC
(0N
OSCR
OSRR
OTCO
OoTT
OTVR
OUCH
OVR
OVRR
OYLO

NORTH SHORE RAILROAD CO

NEWBURGH & SOUTH SHORE RAILROAD COMPANY
NIMISHILLEN & TUSCARAWAS LLC

NATCHEZ RAILWAY LLC.

NAPA VALLEY RAILROAD CO

NORTHWESTERN PACIFIC RAILROAD COMPANY
NASHVILLE & WESTERN RAILROAD CORP

NEW YORK & ATLANTIC RAILWAY COMPANY

NEW YORK & GREENWOOD LAKE RAILWAY

NEW YORK & LAKE ERIE RAILROAD

NEW YORK NEW JERSEY RAIL LLC

NEW YORK & OGDENSBURG RAILWAY COMPANY INC
NEW YORK SUSQUEHANNA AND WESTERN RAILWAY CORP
OLD AUGUSTA RAILROAD LLC

OIL CREEK & TITUSVILLE LINES

OREGON EASTERN RAILROAD

OHIO CENTRAL RAILROAD CO

OHI-RAIL CORPORATION

OHIO TERMINAL RAILWAY COMPANY

OHIO & PENNSYLVANIA RAILROAD COMPANY
OWEGO & HARFORD RAILWAY INC

OKANAGAN VALLEY RAILWAY COMPANY

OMAHA LINCOLN AND BEATRICE RAILWAY COMPANY
ONTARIO L'ORIGNAL RAILWAY INC

OLYMPIC RAILROAD CO, THE

ONTARIO MIDLAND RAILROAD CORPORATION
ONTARIO CENTRAL RAILROAD CORPORATION
ONTARIO NORTHLAND RAILWAY (ONTARIO NORTHLAND TRANS COMMISSION)
OREGON PACIFIC & EASTERN RAILWAY COMPANY
OREGON PACIFIC RAILROAD CO

ORANGE PORT TERMINAL RAILWAY

OGEECHEE RAILROAD COMPANY

ONTARIO SOUTHLAND RAILWAY INC

INDIANA EASTERN RAILROAD, LLC D/B/A OHIO SOUTH CENTRAL RAILROAD
OHIO SOUTHERN RAILROAD CO

OWENSVILLE TERMINAL CO INC

OTTUMWA TERMINAL RAILROAD CO

OTTERTAIL VALLEY RAILROAD CO INC

OUACHITA RAILROAD

OHIO VALLEY RAILROAD COMPANY

OZARK VALLEY RAILROAD INC

OLYMPIA & BELMORE RAILROAD, INC.
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PAL
PAM
PAS
PBR
PBVR
PCC
PCN
PDRR
PGR
PHL
PHRR
Pl
PICK
PIR
PJR
PKHP
PN
PNR
PNRW
PNW
PNWR
POHC
POTB
POVA
PR
PRI
PRV
PRY

PSAP
PSC
PSCC
PSWR
PT
PTC
PTR
PTRA
PTRC
PUCC
PVIR
PVRR
PVS
PW

PADUCAH & LOUISVILLE RAILWAY

PITTSBURGH ALLEGHENY & MCKEES ROCKS RR CO

PAN AM SOUTHERN, LLC.

PATAPSCO & BACK RIVERS RAILROAD COMPANY

PORT BIENVILLE RAILROAD

PALOUSE RIVER & COULEE CITY RAILROAD INC

POINT COMFORT & NORTHERN RAILWAY COMPANY

PEE DEE RIVER RAILROAD CORP

PROGRESSIVE RAIL INC

PACIFIC HARBOR LINE INC

PORT HARBOR RAILROAD INC

PADUCAH & ILLINOIS RAILROAD COMPANY

PICKENS RAILWAY COMPANY

PERU INDUSTRIAL RAILROAD, LLC

PORT JERSEY RAILROAD CO

PICKENS RAILWAY COMPANY

PENNSYLVANIA NORTHEASTERN RAILROAD, LLC
PANHANDLE NORTHERN RAILROAD COMPANY

PIEDMONT RAILWAY LLC D/B/A PIEDMONT & NORTHERN RAILROAD
PRESCOTT AND NORTHWESTERN RAILROAD COMPANY
PORTLAND & WESTERN RAILROAD INC

THE PITTSBURGH & OHIO CENTRAL RAILROAD COMPANY
PORT OF TILLAMOOK BAY RAILROAD

PEND OREILLE VALLEY RAILROAD (PORT OF PEND OREILLE)
SOUTH CAROLINA DIVISION OF PUBLIC RAILWAYS D/B/A PALMETTO RAILWAY
PORT RAIL, INC.

PEARL RIVER VALLEY RAILROAD COMPANY

PIONEER INDUSTRIAL RAILWAY CO
THE PUGET SOUND & PACIFIC RAILROAD COMPANY A DIVISION OF THE ARIZONA & CALIFORNIA
RAILROAD CO LP

PYCO INDUSTRIES INC

PENNSYLVANIA & SOUTHERN RAILWAY LLC
PENNSYLVANIA SOUTHWESTERN RAILROAD INC
PENINSULA TERMINAL COMPANY

PLAINVIEW TERMINAL COMPANY

PORT TERMINAL RAILROAD OF SOUTH CAROLINA
PORT TERMINAL RAILROAD ASSOCIATION

PORTLAND TERMINAL RAILROAD COMPANY

PORT UTILITIES COMMISSION OF CHARLESTON SC
PORTLAND VANCOUVER JUNCTION RAILROAD LLC
PIONEER VALLEY RAILROAD COMPANY

PECOS VALLEY PERMIAN RAILROAD LLC DBA PECOS VALLEY SOUTHERN RAILW
PROVIDENCE AND WORCESTER RAILROAD COMPANY
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QCR
QGRY
QRR
RARW
RBMN
RCPE
RCRR
RCRY
RICC
RICD
RICK
RICL
RICM
RICN
RICP
RICR
RICS
RICV
RICW
RL
RLHH
RLK
RMRR
RNA
RPP
RPRC
RRC
RRRR
RRVW
RS
RSL
RSM
RSNR
RSOR
RSP
RSR
RSS
RVPR
RVSC
RVT
SAC
SAN

QUEBEC CENTRAL RAILWAY COMPANY

QUEBEC GATINEAU RAILWAY INC

QUINCY RAILROAD COMPANY

RARUS RAILWAY COMPANY

READING BLUE MOUNTAIN & NORTHERN RAILROAD COMPANY
RAPID CITY, PIERRE & EASTERN RAILROAD, INC.

RED COAT ROAD & RAIL LTD

RARITAN CENTRAL RAILWAY LLC

R J CORMAN RAILROAD COMPANY/CENTRAL KENTUCKY LINES
RJ CORMAN RAILROAD COMPANY/TEXAS LINES, LLC

R J CORMAN RAILROAD COMPANY/TENNESSEE TERMINAL LLC
R J CORMAN RAILROAD COMPANY/CLEVELAND LINE

R J CORMAN RAILROAD COMPANY/MEMPHIS LINE

R J CORMAN RAILROAD COMPANY/ALLENTOWN LINES INC
R J CORMAN RAILROAD COMPANY/PENNSYLVANIA LINES INC
R J CORMAN RAILROAD CORPORATION/BARDSTOWN LINE
RJ CORMAN RAILROAD CO/CAROLINA LINES, LLC

R J CORMAN RAILROAD COMPANY/WYV LINE

R J CORMAN RAILROAD COMPANY/WESTERN OHIO LINE
RUTLAND LINE INC

RAILINK SOUTHERN ONTARIO

RAILINK OTTAWA VALLEY

ROCKY MOUNTAIN RAILCAR AND RAILROAD INC

RIPLEY & NEW ALBANY RAILROAD COMPANY

RUSK, PALESTINE, & PACIFIC RAILROAD, LLC

RICHMOND PACIFIC RAILROAD CORPORATION

REDMONT RAILWAY COMPANY INC

ROCK & RAIL INC

RED RIVER VALLEY & WESTERN RAILROAD CO

ROBERVAL AND SAGUENAY RAILWAY COMPANY, THE

RSL RAILROAD LLC

RAILROAD SWITCHING SERVICE OF MISSOURI INC

RED SPRINGS & NORTHERN RAILROAD CO

RICEBORO SOUTHERN RAILWAY LLC

ROSCOE SNYDER & PACIFIC RAILWAY COMPANY
ROCHESTER & SOUTHERN RAILROAD INC

ROCKDALE SANDOW & SOUTHERN RAILROAD COMPANY
RIVERPORT RAILROAD LLC

RIO VALLEY SWITCHING COMPANY

ROGUE VALLEY TERMINAL RAILROAD CORPORATION

SAN ANTONIO CENTRAL RAILROAD, LLC

SANDERSVILLE RAILROAD COMPANY
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SAPT
SAV
SAW
SBG
SBLN
SBRR
SBVR
SC
SCBG
SCIH
SCR
SCRF
SCS
SCTR
SCXF
SCXY
SDIY
SE
SERA
SFG
SFR
SFS
SGLR
SH
SIND
SIR
SJVR
SKOL
SL
SLAL
SLC
SLGG
SLGW
SLQ
SLR
SLRG
SLRS
SLWC
SM
SMA
SMNR
SMRR

SAVANNAH PORT TERMINAL RAILROAD INC
SACRAMENTO VALLEY RAILROAD

SOUTH PLAINS SWITCHING LTD CO

SAVAGE BINGHAM & GARFIELD RAILROAD COMPANY
STERLING BELT LINE RAILWAY

STOURBRIDGE RAILROAD COMPANY

SOUTH BRANCH VALLEY RAIL ROAD

SANTA CRUZ AND MONTEREY BAY RAILWAY COMPANY
SANTA CRUZ BIG TREES & PACIFIC RAILWAY CO
SOUTH CHICAGO & INDIANA HARBOR RAILWAY COMPANY
SYDNEY COAL RAILWAY

SOUTH CAROLINA CENTRAL RAILROAD CO INC
SQUAW CREEK SOUTHERN RAILROAD

SCTRR LLC

SOUTH CENTRAL FLORIDA EXPRESS INC

ST CROIX VALLEY RAILROAD COMPANY

SAN DIEGO & IMPERIAL VALLEY RAILROAD CO INC
SEMO PORT RAILROAD INC

SIERRA RAILROAD COMPANY

SOCIETE DU CHEMIN DE FER DE LA GASPESIE
SOUTHERN FREIGHT RAILROAD

SANTA FE SOUTHERN RAILWAY

SEMINOLE GULF RAILWAY L P

STEELTON & HIGHSPIRE RAILROAD COMPANY
SOUTHERN INDIANA RAILWAY INC

SAN JACINTO TRANSPORTATION COMPANY, INCORPORATED
SAN JOAQUIN VALLEY RAILROAD CO

SOUTH KANSAS & OKLAHOMA RAILROAD INC

SALT LAKE CITY SOUTHERN RAILROAD COMPANY INC
SOUTH PLAINS LAMESA RAILROAD LTD

SAN LUIS CENTRAL RAILROAD COMPANY

S & L RAILROAD LLC

SALT LAKE GARFIELD AND WESTERN RAILWAY COMPANY
ST LAWRENCE & ATLANTIC RAILROAD (QUEBEC) INC
ST LAWRENCE & ATLANTIC RAILROAD CO

SAN LUIS & RIO GRANDE RAILROAD INC

SMS RAIL SERVICE INC

STILLWATER CENTRAL RAILROAD COMPANY INC
SAINT MARYS RAILROAD COMPANY

SAN MANUEL ARIZONA RAILROAD COMPANY
SOUTHERN MANITOBA RAILWAY INC

SISSETON MILBANK RAILROAD
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SMV SANTA MARIA VALLEY RAILROAD COMPANY

SMW ST MARYS RAILWAY WEST LLC

SNC SARATOGA & NORTH CREEK RAILWAY
SNR SUNFLOUR RAILROAD INC

SNY SMS RAIL LINES OF NEW YORK LLC
SOM SOMERSET RAILROAD CORPORATION

SORA SOUTHERN RAILS COOPERATIVE LIMITED
SAN PEDRO RAILROAD OPERATING CO LLC D/B/A SAN PEDRO & SOUTHWESTERN RAILROAD
SPSR COMPANY

SQVR SEQUATCHIE VALLEY RAILROAD INC

SRC STRASBURG RAILROAD COMPANY

SRN SABINE RIVER & NORTHERN RAILROAD COMPANY
SRNJ SOUTHERN RAILROAD COMPANY OF NEW JERSEY
SRRR SWAN RANCH RAILROAD LLC

SRY SOUTHERN RAILWAY OF BRITISH COLUMBIA LTD
SS SAND SPRINGS RAILWAY COMPANY

SSC SOUTHERN SWITCHING COMPANY

SSR S&S SHORTLINE RAILROAD

SSS STEWART SOUTHERN RAILWAY INC

ST ST RAIL SYSTEM

STE STOCKTON TERMINAL AND EASTERN RAILROAD
STMA ST MARIES RIVER RAILROAD COMPANY

STR SHAWNEE TERMINAL RAILWAY COMPANY INC
STRT STEWARTSTOWN RAILROAD CO

STS SANTA TERESA SOUTHERN RAILROAD, LLC

SUN SUNSET RAILWAY COMPANY

SVI SOUTHERN RAILWAY OF VANCOUVER ISLAND LIMITED
SVRR SHAMOKIN VALLEY RAILROAD COMPANY

SW SOUTHWESTERN RAILROAD COMPANY INC

SWP SOUTHWEST PENNSYLVANIA RAILROAD COMPANY
TASD TERMINAL RAILWAY ALABAMA STATE DOCKS
TBFR TRANSDISTRIBUTION BROOKFIELD RAILROAD LLC
TBRY THERMAL BELT RAILWAY

TC TEMPLE & CENTRAL TEXAS RAILWAY, INC.

TCB TEXAS CENTRAL BUSINESS LINES CORPORATION
TCG TUCSON CORNELIA & GILA BEND RAILROAD COMPANY
TCKR TURTLE CREEK INDUSTRIAL RAILROAD INC

TCRY TRI-CITY RAILROAD COMPANY

TCT TEXAS CITY TERMINAL RAILWAY COMPANY

TCWR TWIN CITIES & WESTERN RAILROAD

TFVM TERMINAL FERROVIARIA DEL VALLE DE MEXICO SA DE CV
T TURNERS ISLAND LLC

TIBR TIMBERROCK RAILROAD COMPANY INC
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TIRL
TKEN
TLE
TMBL
TMSS
TMUS
TN
TNER
TNHR
TNMR
TPW
TR
TRC
TRIN
TRMW
TRR
TRRA
TRRY
TRV
TSE
TSRR
TSU
TTIS
TTR
TVRR
TXGN
TXN
TXNW
TXOR
TXPF
TXR
TYBR
TZPR
UCIR
UCRY
UMP
up
URR
USNY
USR
USRP
UTAH

TONAWANDA ISLAND RAILROAD INC

TENNKEN RAILROAD COMPANY INC

MIDWEST RAIL, LLC DBA TOLEDO, LAKE ERIE AND WESTERN RAILWAY
TACOMA MUNCIPAL BELT LINE RAILWAY

TOWANDA AND MONROETON SHIPPERS LIFELINE, INC.
TRANSMEX/USA INC

TEXAS & NORTHERN

TEXAS NORTHEASTERN DIVISION MID-MICHIGAN RAILROAD INC
THREE NOTCH RAILWAY LLC

TEXAS-NEW MEXICO DIVISION (AUSTIN & NORTHWESTERN RAILROAD COMPANY INC)
TOLEDO PEORIA & WESTERN RAILWAY CORPORATION
TOMAHAWK RAILWAY L P

TRONA RAILWAY COMPANY

TRINIDAD RAILWAY INC

TACOMA RAIL MOUNTAIN DIVISION

THUNDER RAILLTD

TERMINAL RAILROAD ASSOCIATION OF ST LOUIS
TRILLIUM RAILWAY CO LTD

TORCH RIVER RAIL INC.

TEXAS SOUTH-EASTERN RAILROAD COMPANY
TENNESSEE SOUTHERN RAILROAD CO INC
TULSA-SAPULPA UNION RAILWAY COMPANY LLC
TRANSKENTUCKY TRANSPORTATION RAILROAD CO INC
TALLEYRAND TERMINAL RAILROAD COMPANY INC
TULARE VALLEY RAILROAD COMPANY

TEXAS GONZALES & NORTHERN RAILWAY COMPANY
TEXAS NEW MEXICO RAILWAY, L.L.C.

TEXAS NORTH WESTERN RAILWAY COMPANY

TEXAS AND OKLAHOMA RAILROAD COMPANY

TEXAS PACIFICO TRANSPORTATION LTD

TEXAS ROCK CRUSHER RAILWAY COMPANY

TYBURN RAILROAD, LLC

TAZEWELL & PEORIA RAILROAD INC

UNION COUNTY INDUSTRIAL RAILROAD COMPANY
UTAH CENTRAL RAILWAY COMPANY

UPPER MERION AND PLYMOUTH RAILROAD COMPANY
UNION PACIFIC RAILROAD COMPANY

UNION RAILROAD COMPANY

U.S. RAIL OF NEW YORK, LLC

UTAH SOUTHERN RAILROAD COMPANY LLC

U.S. RAIL CORPORATION LLC

UTAH RAILWAY COMPANY
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VCRR
VR
VRR
VRRC
VSOR
VSR
VSRR
VST
VTR
VVRR
WACR
WBCR
WCLR
WCOR
WE
WEFS
WGCR
WHOE
WHRC
WIR
WKRL
WMI
WN
WNFR
WNYP
WPRR
WRI
WRRC
WRS
WSOR
WSR
WSRY
WSS
WTA
WTCO
WTIR
WTLC
WTNN
WTRM
WTRY
WURR
WwvC

VENTURA COUNTY RAILROAD COMPANY

VALDOSTA RAILWAY L P

VAUGHN RAILROAD COMPANY

VANDALIA RAILROAD COMPANY

VICKSBURG SOUTHERN RAILROAD INC

V AND S RAILWAY INC

VIRGINIA SOUTHERN RAILROAD DIVISION NORTH CAROLINA & VIRGINIA RAILROAD
V&S RAILWAY INC D/B/A TOWNER RAILWAY
VERMONT RAILWAY INC

VERMILION VALLEY RAILROAD COMPANY INC
WASHINGTON COUNTY RAILROAD CORPORATION
WABASH CENTRAL RAILROAD CORPORATION
WACCAMAW COASTLINE RAILROAD CO INC
WELLSBORO & CORNING RAILROAD LLC

WHEELING & LAKE ERIE RAILWAY COMPANY

WEST ISLE LINE INC

WIREGRASS CENTRAL RAILWAY LLC

WALKING HORSE & EASTERN RAILROAD CO INC
WINDSOR & HANTSPORT RAILWAY CO

WASHINGTON & IDAHO RAILWAY INC

WESTERN KENTUCKY RAILWAY LLC

WEST MICHIGAN RAILROAD CO

PROGRESSIVE RAIL INC D/B/A WISCONSIN NORTHERN RAILROAD
KANAWHA RAIL CORP

WESTERN NEW YORK & PENNSYLVANIA RAILROAD LLC
WILLAMETTE & PACIFIC RAILROAD INC

WHEATLAND RAIL INC

WESTERN RAILROAD COMPANY

WESTERN RAIL SWITCHING INC

WISCONSIN & SOUTHERN RAILROAD COMPANY
WARREN & SALINE RIVER RAILROAD COMPANY
WINAMAC SOUTHERN RAILWAY COMPANY
WINSTON-SALEM SOUTHBOUND RAILWAY COMPANY (CSX TRANSPORTATION)
WICHITA TERMINAL ASSOCIATION

WESTERN TRANSPORTATION CO

WICHITA TILLMAN & JACKSON RAILWAY COMPANY INC
WEST TEXAS AND LUBBOCK RAILWAY COMPANY
WEST TENNESSEE RAILROAD CORP

WARREN & TRUMBULL RAILROAD COMPANY, THE
WILMINGTON TERMINAL RAILROAD INC

WALLOWA UNION RAILROAD AUTHORITY

WEST VIRGINIA CENTRAL RAILROAD
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WVR WILLAMETTE VALLEY RAILWAY COMPANY INC
WW WINCHESTER AND WESTERN RAILROAD COMPANY
WWR WESTERN WASHINGTON RAILROAD, LLC

WWRC WILMINGTON & WESTERN RAILWAY CORP

WYEC WYE TRANSPORTATION CO

YARR YOUNGSTOWN & AUSTINTOWN RAILROAD CO

YB YOUNGSTOWN BELT RAILROAD COMPANY, THE

YCR YCR CORP

YRC YORK RAILWAY COMPANY

YRPL YELM ROY PRAIRIE LINE

YSRR YOUNGSTOWN & SOUTHEASTERN RAILROAD COMPANY INC
YSVR YELLOWSTONE VALLEY RAILROAD INC

YVRR YADKIN VALLEY RAILROAD COMPANY

YVT YAKIMA VALLEY TRANSPORTATION COMPANY

YW YREKA WESTERN RAILROAD COMPANY
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Appendix

Railroads Sorted by Name

Railroad Name SCAC
A & RLINE INC ARE
A & R TERMINAL RAILROAD ART
ABERDEEN AND ROCKFISH RAILROAD COMPANY AR
ABERDEEN CAROLINA & WESTERN RAILWAY CO ACWR
ACADIANA RAILWAY COMPANY AKDN
ADAMS WARNOCK RAILWAY, INC. AWRY
ADRIAN & BLISSFIELD RAIL ROAD COMPANY ADBF
AFFTON TERMINAL SERVICES RAILROAD, LLC AT
AG VALLEY RAILROAD, LLC AVRR
AIKEN RAILWAY COMPANY, LLC AIKR
AIRLAKE TERMINAL RAILWAY COMPANY ALT
AKRON BARBERTON CLUSTER RAILWAY COMPANY AB
ALABAMA & FLORIDA RAILWAY CO AF
ALABAMA & GULF COAST RAILWAY LLC AGR
ALABAMA & TENNESSEE RIVER RAILWAY LLC ATN
ALABAMA RAILROAD CO INC ALAB
ALABAMA SOUTHERN RAILROAD ABS
ALABAMA WARRIOR RAILWAY, LLC. ABWR
ALAMEDA BELT LINE ABL
ALAMO GULF COAST RAILROAD COMPANY AGCR
ALASKA RAILROAD CORPORATION ARR
ALBANY & EASTERN RAILROAD COMPANY AERC
ALBANY PORT DISTRICT APD
ALBERTA PRAIRIE RAILWAY APR
ALEXANDER RAILROAD COMPANY ARC
ALGERS WINSLOW AND WESTERN RAILWAY COMPANY AWW
ALLEGHENY SOUTHERN RAILROAD INC ASR
ALLEGHENY VALLEY RAILROAD COMPANY AVR
ALLENTOWN AND AUBURN RAILROAD ALLN
ALTON & SOUTHERN RAILWAY COMPANY ALS
AMADOR FOOTHILLS RAILROAD AFR
AMTRAK-NATIONAL RAILROAD PASSENGER CORPORATION AMTK
AN RAILWAY LLC AN
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ANGELINA & NECHES RIVER RAILROAD COMPANY

ANN ARBOR RAILROAD

APACHE RAILWAY COMPANY

APPALACHIAN & OHIO RAILROAD INC

APPANOOSE COUNTY COMMUNITY RAILROAD INC
ARCADE AND ATTICA RAILROAD CORPORATION
ARIZONA & CALIFORNIA RAILROAD CO

ARIZONA CENTRAL RAILROAD INC

ARIZONA EASTERN RAILWAY COMPANY

ARKANSAS AND MISSOURI RAILROAD CO

ARKANSAS LOUISIANA & MISSISSIPPI RAILROAD COMPANY
ARKANSAS MIDLAND RAILROAD CO INC

ARKANSAS SOUTHERN RAILROAD
ARKANSAS-OKLAHOMA RAILROAD INC

ASHLAND RAILWAY CO

ASHTABULA CARSON & JEFFERSON RAILROAD

AT & L RAILROAD CO INC

ATHENS LINE LLC, THE

ATLANTIC & WESTERN RAILWAY, L P

AUSTIN WESTERN RAILROAD

AUTAUGA NORTHERN RAILROAD LLC

B&H RAIL CORP

BAJA CALIFORNIA RAILROAD INC

BALLARD TERMINAL RAILROAD CO LLC

BALLARD TERMINAL RAILROAD COMPANY LLC D/B/A MEEKER SOUTHERN RAILROAD
BALTIMORE AND OHIO CHICAGO TERMINAL RAILROAD CO
BARRIE-COLLINGWOOD RAILWAY

BATTEN KILL RAILROAD INC

BATTLE RIVER RAILWAY NGC INC

BAUXITE & NORTHERN RAILWAY COMPANY

BAY COAST RAILROAD

BAY COLONY RAILROAD CORPORATION

BAY LINE RAILROAD L L C, THE

BEECH MOUNTAIN RAILROAD COMPANY

BELFAST AND MOOSEHEAD LAKE RAILROAD COMPANY
BELT RAILWAY COMPANY OF CHICAGO

BELVIDERE & DELAWARE RIVER RAILWAY COMPANY INC
BHP NEVADA RAILROAD COMPANY

BIG FOUR TERMINAL RAILROAD, LLC

BIG SKY RAIL CORP

BIG SPRING RAIL SYSTEM, INC.

ANR
AA
APA
AO
APNC
ARA
ARZC
AZCR
AZER
AM
ALM
AKMD
ARS
AOK
ASRY
ACJR
ATLT
ABR
ATW
AWRR
AUT
BH
BJRR
BDTL
MSN
BOCT
BCRY
BKRR
BRR
BXN
BCR
BCLR
BAYL
BEEM
BML
BRC
BDRV
BHP
BFT
BGS
BSR
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BIGHORN DIVIDE & WYOMING RAILROAD INC BDW
BIRMINGHAM TERMINAL RAILWAY LLC BHRR
BI-STATE DEVELOPMENT AGENCY BSDA
BLACK RIVER & WESTERN CORPORATION BRW
BLACKLANDS RAILROAD THE BLR
BLACKWELL NORTHERN GATEWAY RAILROAD COMPANY BNG
BLOOMER LINE, THE BLOL
BLUE MOUNTAIN RAILROAD INC BLMR
BLUE RIDGE SOUTHERN RAILROAD LLC BLU
BNSF RAILWAY COMPANY BNSF
BOISE VALLEY RAILROAD, INC. BVRR
BOONE & SCENIC VALLEY RAILROAD BSVY
BOOT HILL & WESTERN RAILWAY CO LC BHWY
BORDER PACIFIC RAILROAD CO BOP
BOUNDARY TRAIL RAILWAY COMPANY INC. BTR
BRANDON RAILROAD LLC BRAN
BRANDYWINE VALLEY RAILROAD COMPANY BVRY
BROOKHAVEN RAIL, LLC BHR
BROWNSVILLE & RIO GRANDE INTERNATIONAL RAILWAY, LLC BRG
BUCKINGHAM BRANCH RAILROAD COMPANY BB
BUFFALO & PITTSBURGH RAILROAD INC BPRR
BUFFALO SOUTHERN RAILROAD INC BSOR
BURLINGTON JUNCTION RAILWAY BJRY
BURLINGTON NORTHERN (MANITOBA) LTD BNML
C & NC RAILROAD CORPORATION CNUR
C & S RAILROAD CORPORATION CSKR
C F LANAUDIERE INC CFL
C&J RAILROAD COMPANY D/B/A MISSISSIPPI DELTA RAILROAD MD
CADDO VALLEY RAILROAD COMPANY CVYR
CALDWELL COUNTY RAILROAD COMPANY CWCY
CALIFORNIA NORTHERN RAILROAD COMPANY LP CFNR
CAMBRIA AND INDIANA RAILROAD COMPANY Cl
CAMDEN & SOUTHERN RAILROAD INC CSR
CAMP CHASE INDUSTRIAL RAILROAD CORPORATION CCRA
CAMP CHASE RAILWAY COMPANY, LLC CAMY
CANADIAN NATIONAL RAILWAYS CN
CANADIAN PACIFIC RAILWAY CPRS
CANEY FORK AND WESTERN RR CFWR
CANTON RAILROAD COMPANY CTN
CAPE BRETON & CENTRAL NOVA SCOTIA RAILWAY CBNS
CAPE FEAR RAILWAYS INC CF
Appendix E: Railroads Sorted by Name 109



CAPE MAY SEASHORE LINES

CMSL

CARLTON TRAIL RAILWAY COMPANY CTRW
CAROLINA COASTAL RAILWAY INC CLNA
CAROLINA PIEDMONT DIVISION SOUTH CAROLINA CENTRAL RAILROAD COMPANY INC CPDR
CAROLINA SOUTHERN RAILROAD COMPANY, THE CALA
CARRIZO GORGE RAILWAY INC CZRY
CASCADE AND COLUMBIA RIVER RAILROAD COMPANY CSCD
CATERPARROTT RAILNET, LLC CPR
CCET, LLC CCET
CEDAR RAPIDS & IOWA CITY RAILWAY COMPANY CIC
CENTRAL CALIFORNIA TRACTION COMPANY CCT
CENTRAL ILLINOIS RAILROAD COMPANY CIRY
CENTRAL INDIANA & WESTERN RAILROAD CO INC CEIW
CENTRAL MAINE & QUEBEC RAILWAY cMQ
CENTRAL MANITOBA RAILWAY INC CEMR
CENTRAL MIDLAND RAILWAY COMPANY CMR
CENTRAL MONTANA RAIL INC CM
CENTRAL NEW ENGLAND RAILROAD CO INC CNZR
CENTRAL NEW YORK RAILROAD CORPORATION CNYK
CENTRAL OREGON & PACIFIC RAILROAD INC CORP
CENTRAL RAILROAD COMPANY OF INDIANAPOLIS CERA
CENTRAL RAILROAD OF INDIANA CIND
CENTRAL TEXAS & COLORADO RIVER RAILWAY, LLC CTXR
CENTRAL WASHINGTON RAILROAD COMPANY CWA
CG RAILWAY INC CGR
CHAPARRAL RAILROAD COMPANY INC CHRC
CHARLOTTE SOUTHERN RAILROAD COMPANY CHS
CHATTAHOOCHEE BAY RAILROAD INC CHAT
CHATTAHOOCHEE INDUSTRIAL RAILROAD CIRR
CHATTOOGA & CHICKAMAUGA RAILWAY CO CCKY
CHESAPEAKE & ALBEMARLE CA
CHESAPEAKE AND INDIANA RAILROAD COMPANY INC CKIN
CHESAPEAKE RAILROAD COMPANY CHRR
CHESSIE LOGISTICS CO., LLC CLCY
CHESTNUT RIDGE RAILWAY COMPANY CHR
CHICAGO FT WAYNE & EASTERN A DIVISION OF CENTRAL RAILROAD OF INDIANAPOLIS INC = CFE
CHICAGO RAIL LINK CRL
CHICAGO SOUTHSHORE & SOUTH BEND RAILROAD CSS
CHICAGO TERMINAL RAILROAD CT™M
CHICAGO-CHEMUNG RAILROAD CORP CCuo
CICERO CENTRAL RAILROAD, L.L.C. CERR
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CIMARRON VALLEY RAILROAD L C

CVR

CITY OF PRINEVILLE RAILWAY COP
CITY OF ROCHELLE ILLINOIS CIR
CLAREMONT CONCORD RAILROAD CORPORATION CCRR
CLARENDON AND PITTSFORD RAILROAD COMPANY, THE CLP
CLEVELAND COMMERCIAL RAILROAD COMPANY LLC CCRL
CLEVELAND HARBOR BELT RAILROAD, LLC CHB
CLEVELAND WORKS RAILWAY COMPANY CWRO
CLINTON TERMINAL RAILROAD COMPANY CTR
CLOQUET TERMINAL RAILROAD COMPANY INC CTRR
CN AQUATRAIN CNAT
COLORADO & WYOMING RWY CO [any
COLUMBIA & COWLITZ RAILWAY LLC CLC
COLUMBIA & NORTHERN RAILWAY CO CNOW
COLUMBIA & READING RAILWAY CO CORY
COLUMBIA BASIN RAILROAD COMPANY INC CBRW
COLUMBIA TERMINAL CT
COLUMBUS & CHATTAHOOCHEE RAILROAD, INC CCH
COLUMBUS & OHIO RAILROAD COMPANY CUOH
COLUMBUS AND GREENVILLE RAILWAY CAGY
COMMONWEALTH RAILWAY INC CWRY
COMPANIA DE FERROCARRILES CHIAPAS MAYAB SA DE CV FCCM
COMSTOCK MOUNTAIN LION RAILROAD, INC. CMRR
CONECUH VALLEY RAILWAY LLC COEH
CONNECTICUT SOUTHERN RAILROAD INC CsO
COOPERSVILLE AND MARNE RAILWAY COMPANY CPMY
COOS BAY RAILROAD OPERATING CO., LLC CBR
COPPER BASIN RAILWAY INC CBRY
CORPUS CHRISTI TERMINAL RAILROAD INC CCPN
CRAB ORCHARD & EGYPTIAN RAILWAY A DIVISION OF PROGRESSIVE RAIL IN COER
CSX TRANSPORTATION CSXT
CWRR INC CWR
D & | RAILROAD COMPANY DAIR
DAKOTA MISSOURI VALLEY & WESTERN RAILROAD INC DMVW
DAKOTA NORTHERN RAILROAD INC DN
DAKOTA SHORT LINE DAKS
DAKOTA SOUTHERN RAILWAY COMPANY DSRC
DALLAS GARLAND & NORTHEASTERN RAILROAD INC DGNO
DALLAS TERMINAL RAILWAY DALT
DANSVILLE AND MOUNT MORRIS RAILROAD COMPANY, THE DMM
DARDANELLE & RUSSELLVILLE RAILROAD COMPANY DR
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DECATUR JUNCTION RAILWAY COMPANY DT
DELAWARE COAST LINE RR CO DCLR
DELAWARE VALLEY RAILWAY COMPANY INC DV
DELAWARE-LACKAWANNA RAILROAD CO INC DL
DELRAY CONNECTING RAILROAD COMPANY DC
DELTA SOUTHERN RAILROAD COMPANY DSRR
DELTA VALLEY & SOUTHERN RAILWAY COMPANY DVS
DENVER ROCK ISLAND RAILROAD DRIR
DEPEW LANCASTER & WESTERN RAILROAD CO INC DLWR
DEQUEEN & EASTERN RAILROAD LLC DQE
DETROIT CONNECTING RAILROAD COMPANY DCON
DEVCO RY (CAPE BRETON DEVELOPMENT CORP) DVR
DRAKE SWITCHING COMPANY, LLC DSC
DUBOIS COUNTY RAILROAD DCRR
DURBIN & GREENBRIER VALLEY RAILROAD INC DGVR
E & N RAILWAY COMPANY (1998) LTD ENR
EAST BROAD TOP CONNECTING RAILROAD EBTC
EAST BROOKFIELD & SPENCER RAILROAD LLC EBSR
EAST CAMDEN & HIGHLAND RR CO EACH
EAST CHATTANOOGA BELT RAILWAY COMPANY ECTB
EAST COOPER AND BERKELEY RAILROAD COMPANY ECBR
EAST ERIE COMMERCIAL RAILROAD EEC
EAST JERSEY RAILROAD AND TERMINAL COMPANY EJR
EAST MAHANOY & HAZELTON RAILROAD COMPANY EMHR
EAST PENN RAILROAD LLC ESPN
EAST TENNESSEE RAILWAY, L P ETRY
EASTERN ALABAMA RAILWAY EARY
EASTERN BERKS GATEWAY RAILROAD COMPANY EBG
EASTERN IDAHO RAILROAD INC EIRR
EASTERN ILLINOIS RAILROAD COMPANY EIRC
EASTERN MAINE RAILWAY COMPANY EMRY
EASTERN WASHINGTON GATEWAY RAILROAD COMPANY EWG
EASTSIDE COMMUNITY RAIL, LLC ECYR
ECORAIL INC ECO
EFFINGHAM RAILROAD COMPANY EFRR
EL DORADO AND WESSON RAILWAY COMPANY EDW
ELIZABETHTOWN INDUSTRIAL RAILROAD, LLC EZR
ELK RIVER RAILROAD INC ELKR
ELKHART & WESTERN RAILROAD CO EWR
ELLIS & EASTERN COMPANY EE
ESCANABA AND LAKE SUPERIOR RAILROAD COMPANY ELS
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ESSEX TERMINAL RAILWAY COMPANY THE

ETL

EVANSVILLE WESTERN RAILWAY INC EVWR
EVERETT RAILROAD EV
FALLS ROAD RAILROAD CO INC FRR
FARMRAIL CORPORATION FMRC
FERROCARRIL MEXICANOSADECYV FXE
FERROSURSADECYV FSRR
FINGER LAKES RAILWAY CORP FGLK
FIRST COAST RAILROAD INC FCRD
FLATS INDUSTRIAL RAILROAD COMPANY FIR
FLORIDA CENTRAL RAILROAD CO FCEN
FLORIDA EAST COAST RAILWAY, LLC FEC
FLORIDA MIDLAND RAILROAD CO INC FMID
FLORIDA NORTHERN RAILROAD COMPANY INC FNOR
FLORIDA WEST COAST RAILROAD INC FWCR
FORDYCE AND PRINCETON RAILROAD CO FP
FORE RIVER TRANSPORTATION CORPORATION FRVT
FORT SMITH RAILROAD CO FSR
FORT WORTH & DALLAS BELT RAILROAD FWDB
FORT WORTH & WESTERN RAILROAD FWWR
FORTY MILE RAILROAD, INC. FMR
FULTON COUNTY RAILROAD INC FC
FULTON COUNTY RAILWAY LLC FCR
GALVESTON RAILROAD LP GVSR
GARDEN CITY WESTERN RAILWAY COMPANY, THE GCW
GARDENDALE RAILROAD, INC GRD
GARY RAILWAY COMPANY GRW
GATEWAY EASTERN RAILWAY COMPANY GWWE
GEAUX GEAUX RAILROAD LLC GOGR
GEORGES CREEK RAILWAY GCK
GEORGETOWN RAILROAD COMPANY GRR
GEORGIA & FLORIDA RAILWAY, LLC GFRR
GEORGIA CENTRAL RAILWAY L P GC
GEORGIA MIDLAND RAILROAD INC GMR
GEORGIA NORTHEASTERN RAILROAD CO GNRR
GEORGIA SOUTHERN RAILWAY CO. GS
GEORGIA SOUTHWESTERN RAILROAD INC GSWR
GEORGIA WOODLANDS RAILROAD CO GWRC
GETTYSBURG & NORTHERN RAILROAD CO GET
GLOSTER SOUTHERN RAILROAD COMPANY GLSR
GNP RLY INC. GNPR
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GODERICH-EXETER RAILWAY COMPANY LTD
GOLDEN ISLES TERMINAL RAILROAD INC
GOLDEN TRIANGLE RAILROAD LLC

GRAFTON AND UPTON RAILROAD COMPANY
GRAINBELT CORPORATION

GRAND ELK RAILROAD, LLC.

GRAND FORKS RAILWAY COMPANY

GRAND RAPIDS EASTERN RAILROAD INC

GREAT LAKES CENTRAL RAILROAD

GREAT NORTHWEST RAILROAD INC

GREAT RIVER RAILROAD

GREAT SANDHILLS RAILWAY, LTD.

GREAT SMOKEY MOUNTAINS RAILWAY INC
GREAT WALTON RAILROAD CO, THE

GREAT WESTERN RAILWAY LTD

GREAT WESTERN RAILWAY OF COLORADO LLC
GREEN MOUNTAIN RAILROAD CORPORATION
GREENVILLE & WESTERN RAILWAY COMPANY LLC
GRENADA RAILROAD LLC D/B/A GRENADA RAILWAY
HAINESPORT INDUSTRIAL RAILROAD LLC
HAINESPORT SECONDARY, LLC

HAMPTON & BRANCHVILLE RAILROAD COMPANY
HAMPTON RAILWAY INC

HARDIN SOUTHERN RAILROAD INC

HARTWELL RAILROAD COMPANY

HEART OF GEORGIA RAILROAD INC

HEART OF TEXAS RAILROAD, LP

HENDERSON OVERTON BRANCH

HERITAGE RAILROAD CORP

HIGH POINT THOMASVILLE & DENTON RAILROAD COMPANY

HILTON & ALBANY RAILOAD, INC.

HOLLIDAYSBURG AND ROARING SPRING RAILROAD COMPANY

HOLLIS & EASTERN RR CO

HONDO RAILWAY LLC

HONEY CREEK RAILROAD INC

HOOSIER SOUTHERN RAILROAD
HOUSATONIC RAILROAD COMPANY INC
HUDSON BAY RAILWAY COMPANY

HUNTSVILLE & MADISON COUNTY RAILROAD AUTHORITY

HURON AND EASTERN RAILWAY COMPANY INC
HURON CENTRAL RAILWAY INC

GEXR
GITM
GTRA
GU
GNBC
GDLK
GFR
GR
GLC
GRNW
GTR
GSR
GSM
GRWR
GWRS
GWR
GMRC
GRLW
GRYR
HIRR
HSR
HB
HLSC
HSRR
HRT
HOG
HTR
HOB
HR
HPTD
HAL
HRS
HE
HRR
HCRR
HOS
HRRC
HBRY
HMCR
HESR
HCRY
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HUTCHINSON AND NORTHERN RAILWAY COMPANY, THE HN
IDAHO NORTHERN & PACIFIC RAILROAD COMPANY INPR
ILLINOIS & MIDLAND RAILROAD INC IMRR
ILLINOIS RAILWAY, LLC IR
ILLINOIS WESTERN RAILROAD COMPANY ILW
INDIAN CREEK RAILROAD COMPANY ICRK
INDIANA & OHIO RAILWAY COMPANY IORY
INDIANA EASTERN RAILROAD LLC IERR
INDIANA EASTERN RAILROAD, LLC D/B/A OHIO SOUTH CENTRAL RAILROAD OSCR
INDIANA HARBOR BELT RAILROAD COMPANY IHB
INDIANA NORTHEASTERN RAILROAD COMPANY INC IN
INDIANA RAIL ROAD CORPORATION INRD
INDIANA SOUTHERN RAILROAD COMPANY INC ISRR
INDIANA SOUTHWESTERN RAILWAY CO ISW
INTERNATIONAL BRIDGE AND TERMINAL COMPANY, THE IBT
IOWA INTERSTATE RAILROAD LTD IAIS
IOWA NORTHERN RAILROAD IANR
IOWA NORTHWESTERN RAILROAD IANW
IOWA RIVER RAILROAD INC IARR
IOWA SOUTHERN RAILROAD COMPANY ISR
IOWA SOUTHERN RAILWAY COMPANY ISRY
IOWA TRACTION RAILWAY COMPANY IATR
JKLINE INC JKL
JACKSON & LANSING RAILROAD COMPANY JAIL
JUNIATA VALLEY RAILROAD COMPANY JVRR
KANAWHA RAIL CORP WNFR
KANAWHA RIVER RAILROAD L.L.C. KNWA
KANKAKEE BEAVERVILLE AND SOUTHERN RAILROAD COMPANY KBSR
KANSAS & OKLAHOMA RAILROAD INC KO
KANSAS CITY SOUTHERN DE MEXICOSDERLDECV KCSM
KANSAS CITY SOUTHERN RAILWAY COMPANY KCS
KANSAS CITY TRANSPORTATION CO LLC KCTL
KANSAS EASTERN RAILROAD INC KE
KASGRO RAIL LINES KRL
KAW RIVER RAILROAD KAW
KELOWNA PACIFIC RAILWAY LTD KPR
KENDALLVILLE TERMINAL RAILWAY CO KTR
KENTUCKY AND TENNESSEE RAILWAY KT
KEOKUK JUNCTION RAILWAY KIRY
KETTLE FALLS INTERNATIONAL RAILWAY LLC KFR
KIAMICHI RAILROAD COMPANY LLC KRR
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KINGMAN TERMINAL RAILROAD, LLC

KISKI JUNCTION RAILROAD

KLAMATH NORTHERN RAILWAY COMPANY

KNOX & KANE RAILROAD COMPANY

KNOXVILLE & HOLSTON RIVER RAILROAD CO INC
KOSCIUSKO SOUTHWESTERN RAILWAY

KWT RAILWAY INC

KYLE RAILROAD COMPANY

LAKE COUNTY RAILROAD

LAKE LINE RAILROAD INC.

LAKE MICHIGAN AND INDIANA RAILROAD COMPANY
LAKE STATE RAILWAY COMPANY

LAKE SUPERIOR & ISHPEMING RAILROAD COMPANY
LAKE TERMINAL RAILROAD COMPANY, THE
LAMOILLE VALLEY RAILROAD COMPANY

LANCASTER & CHESTER RAILROAD, LLC.

LANDISVILLE RAILROAD, LLC

LANDISVILLE TERMINAL & TRANSFER COMPANY
LAPEER INDUSTRIAL RAILROAD COMPANY

LAST MOUNTAIN RAILWAY

LAURINBURG AND SOUTHERN RAILROAD COMPANY
LEHIGH RAILWAY, LLC.

LEHIGH VALLEY RAIL MANAGEMENT LLC - BETHLEHEM DIVISION
LEHIGH VALLEY RAIL MANAGEMENT LLC - JOHNSTOWN DIVISION
LEWIS & CLARK RAILWAY CO

LINEA COAHUILA DURANGO SA DE CV

LITTLE KANAWHA RIVER RAIL INC

LITTLE ROCK & WESTERN RAILWAY, L P

LITTLE ROCK PORT RAILROAD

LIVONIA, AVON & LAKEVILLE RAILROAD CORPORATION
LOGANSPORT & EEL RIVER SHORT-LINE CO INC
LONG CREEK RAILROAD COMPANY INC

LONG ISLAND RAILROAD COMPANY

LONGVIEW SWITCHING COMPANY

LOS ANGELES JUNCTION RAILWAY COMPANY
LOUISIANA & DELTA RAILROAD INC

LOUISIANA AND NORTH WEST RAILROAD COMPANY, THE
LOUISIANA SOUTHERN RAILROAD

LOUISVILLE & INDIANA RAILROAD COMPANY
LOUISVILLE AND WADLEY RAILWAY COMPANY
LOUISVILLE NEW ALBANY & CORYDON RAILROAD

KGTR
KIR
KNOR
KKRR
KXHR
KSRY
KWT
KYLE
LCR
LLR
LMIC
LSRC
LSI
LT
LVRC
LC
LVR
LNVT
LIRR
LMR
LRS
LRWY
LVRB
LVRJ
LINC
LFCD
LKRR
LRWN
LRPA
LAL
LER
LCRI
LI
LVSW
LAJ
LDRR
LNW
LAS
LIRC
LW
LNAL
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LOWVILLE AND BEAVER RIVER RAILROAD COMPANY THE LBR

LRY LLC. LRY
LUBBOCK & WESTERN RAILWAY, L.L.C. LBWR
LUXAPALILA VALLEY RAILROAD INC LXVR
LUZERNE AND SUSQUEHANNA RAILWAY COMPANY LS
LYCOMING VALLEY RAILROAD COMPANY LVRR
M&B RAILROAD LLC MNBR
MADISON RAILROAD (A DIV OF CITY OF MADISON PORT AUTHORITY) CMPA
MAGMA ARIZONA RAILROAD COMPANY MAA
MAHONING VALLEY RAILWAY COMPANY, THE MVRY
MAINE NORTHERN RAILWAY COMPANY MNR
MANATEE COUNTY PORT AUTHORITY MAUP
MANNING RAIL, INC MAN
MANUFACTURERS JUNCTION RAILWAY COMPANY M)
MARQUETTE RAIL LLC MQT
MARYLAND AND DELAWARE RAILROAD COMPANY MDDE
MARYLAND MIDLAND RAILWAY INC MMID
MASSACHUSETTS CENTRAL RAILROAD CORPORATION MCER
MASSACHUSETTS COASTAL RAILROAD LLC MC
MASSENA TERMINAL RAILROAD COMPANY, THE MSTR
MAUMEE & WESTERN RAILROAD CORPORATION MAW
MCCLOUD RAILWAY COMPANY MCR
MCLAUGHLIN LINE RAILROAD MCLR
MERIDIAN SOUTHERN RAILWAY LLC MDS
MG RAIL INC MGRI
MICHIGAN AIR-LINE RAILWAY CO MAL
MICHIGAN SHORE RAILROAD INC MS
MICHIGAN SOUTHERN RAILROAD CO INC MSO
MIDDLETOWN & HUMMELSTOWN RAILROAD COMPANY MIDH
MIDDLETOWN & NEW JERSEY RAILWAY LLC MNJ
MID-MICHIGAN RAILROAD INC MMRR
MIDWEST RAIL, LLC DBA TOLEDO, LAKE ERIE AND WESTERN RAILWAY TLE
MINNESOTA COMMERCIAL RAILWAY CO MNNR
MINNESOTA DAKOTA & WESTERN RAILWAY COMPANY MDW
MINNESOTA NORTHERN RAILROAD INC MNN
MINNESOTA PRAIRIE LINE INC MPLI
MINNESOTA SOUTHERN RAILWAY INC MSWY
MISSION MOUNTAIN RAILROAD MMT
MISSISSIPPI & SKUNA VALLEY RAILROAD LLC MSV
MISSISSIPPI CENTRAL RAILROAD COMPANY MSCI
MISSISSIPPI EXPORT RAILROAD COMPANY MSE
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MISSISSIPPI SOUTHERN RAILROAD MSR
MISSISSIPPI TENNESSEE RAILROAD LLC MTNR
MISSISSIPPIAN RAILWAY COOPERATIVE INC MSRW
MISSOURI & NORTHERN ARKANSAS RAILROAD COMPANY INC MNA
MISSOURI & VALLEY PARK RAILROAD CORP MVP
MODESTO AND EMPIRE TRACTION COMPANY MET
MOHALL CENTRAL RAILROAD INC MHC
MOHALL RAILROAD INC MRI
MOHAWK ADIRONDACK & NORTHERN RAILROAD CORP MHWA
MONTANA RAIL LINK INC MRL
MONTREAL MAINE AND ATLANTIC RAILWAY LTD MMA
MORRISTOWN & ERIE RAILWAY INC ME
MORRISTOWN & ERIE RAILWAY INC D/B/A MAINE EASTERN RAILROAD MERR
MOSCOW, CAMDEN & SAN AUGUSTINE RAILROAD MCSA
MOTIVE RAIL INC D/B/A MISSOURI NORTH CENTRAL RAILROAD MNC
MT HOOD RAILROAD CO MH
MT VERNON TERMINAL RAILWAY INC MVT
MUNICIPALITY OF EAST TROY WISCONSIN METW
N D C RAILROAD COMPANY NDCR
NAPA VALLEY RAILROAD CO NVRR
NASH COUNTY RAILROAD CORP NCYR
NASHVILLE & WESTERN RAILROAD CORP NWR
NASHVILLE AND EASTERN RAILROAD CORP NERR
NATCHEZ RAILWAY LLC. NTZR
NAUGATUCK RAILROAD COMPANY INC NAUG
NC RAILROAD INC NCRL
NEBKOTA RAILWAY INC NRI
NEBRASKA CENTRAL RAILROAD COMPANY NCRC
NEBRASKA KANSAS & COLORADO RAILNET INC NKCR
NEBRASKA NORTHEASTERN RAILWAY COMPANY NENE
NEBRASKA NORTHWESTERN RAILROAD INC. NNW
NEW BRUNSWICK SOUTHERN RAILWAY COMPANY LIMITED NBSR
NEW CASTLE INDUSTRIAL RAILROAD NCIR
NEW ENGLAND CENTRAL RAILROAD INC NECR
NEW ENGLAND SOUTHERN RAILROAD CO INC NEGS
NEW HAMPSHIRE AND VERMONT RAILROAD COMPANY NHVT
NEW HAMPSHIRE CENTRAL RAILROAD INC NHCR
NEW HAMPSHIRE NORTHCOAST CORP NHN
NEW HOPE & IVYLAND RAILROAD NHRR
NEW JERSEY RAIL CARRIER LLC NJRC
NEW MEXICO GATEWAY RAILROAD LLC NMGR
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NEW ORLEANS & GULF COAST RAILWAY COMPANY INC

NOGC

NEW ORLEANS PUBLIC BELT RAILROAD NOPB
NEW YORK & ATLANTIC RAILWAY COMPANY NYA
NEW YORK & GREENWOOD LAKE RAILWAY NYGL
NEW YORK & LAKE ERIE RAILROAD NYLE
NEW YORK & OGDENSBURG RAILWAY COMPANY INC NYOG
NEW YORK NEW JERSEY RAIL LLC NYNJ
NEW YORK SUSQUEHANNA AND WESTERN RAILWAY CORP NYSW
NEWBURGH & SOUTH SHORE RAILROAD COMPANY NSR
NIMISHILLEN & TUSCARAWAS LLC NTRY
NITTANY & BALD EAGLE RAILROAD CO NBER
NORFOLK & PORTSMOUTH BELT LINE RAILROAD COMPANY NPB
NORFOLK SOUTHERN RAILWAY COMPANY (NORFOLK SOUTHERN) NS
NORTH CAROLINA & ATLANTIC RAILROAD NCA
NORTH CAROLINA & VIRGINIA RAILROAD CO INC NCVA
NORTH CAROLINA PORTS RAILWAY COMMISSION NCPR
NORTH LOUISIANA & ARKANSAS RAILROAD NLA
NORTH SHORE RAILROAD CO NSHR
NORTHERN LIGHTS RAIL LTD. NLRL
NORTHERN LINES RAILWAY LLC NLR
NORTHERN OHIO & WESTERN RAILWAY LTD NOW
NORTHERN PLAINS RAILROAD INC NPR
NORTHWESTERN OKLAHOMA RAILROAD COMPANY NOKL
NORTHWESTERN PACIFIC RAILROAD COMPANY NWP
OGEECHEE RAILROAD COMPANY ORC
OHIO & PENNSYLVANIA RAILROAD COMPANY OHPA
OHIO CENTRAL RAILROAD CO OHCR
OHIO SOUTHERN RAILROAD CO OSRR
OHIO TERMINAL RAILWAY COMPANY OHIO
OHIO VALLEY RAILROAD COMPANY OVR
OHI-RAIL CORPORATION OHIC
OIL CREEK & TITUSVILLE LINES OCTL
OKANAGAN VALLEY RAILWAY COMPANY OKAN
OLD AUGUSTA RAILROAD LLC OAR
OLYMPIA & BELMORE RAILROAD, INC. OYLO
OLYMPIC RAILROAD CO, THE OLYR
OMAHA LINCOLN AND BEATRICE RAILWAY COMPANY OLB
ONTARIO CENTRAL RAILROAD CORPORATION ONCT
ONTARIO L'ORIGNAL RAILWAY INC oLo
ONTARIO MIDLAND RAILROAD CORPORATION OMID
ONTARIO NORTHLAND RAILWAY (ONTARIO NORTHLAND TRANS COMMISSION) ONT
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ONTARIO SOUTHLAND RAILWAY INC

ORANGE PORT TERMINAL RAILWAY

OREGON EASTERN RAILROAD

OREGON PACIFIC & EASTERN RAILWAY COMPANY
OREGON PACIFIC RAILROAD CO

OTTERTAIL VALLEY RAILROAD CO INC
OTTUMWA TERMINAL RAILROAD CO

OUACHITA RAILROAD

OWEGO & HARFORD RAILWAY INC
OWENSVILLE TERMINAL CO INC

OZARK VALLEY RAILROAD INC

PACIFIC HARBOR LINE INC

PADUCAH & ILLINOIS RAILROAD COMPANY
PADUCAH & LOUISVILLE RAILWAY

PALOUSE RIVER & COULEE CITY RAILROAD INC
PAN AM SOUTHERN, LLC.

PANHANDLE NORTHERN RAILROAD COMPANY
PATAPSCO & BACK RIVERS RAILROAD COMPANY
PEARL RIVER VALLEY RAILROAD COMPANY

PECOS VALLEY PERMIAN RAILROAD LLC DBA PECOS VALLEY SOUTHERN RAILW

PEE DEE RIVER RAILROAD CORP

PEND OREILLE VALLEY RAILROAD (PORT OF PEND OREILLE)
PENINSULA TERMINAL COMPANY

PENNSYLVANIA & SOUTHERN RAILWAY LLC
PENNSYLVANIA NORTHEASTERN RAILROAD, LLC
PENNSYLVANIA SOUTHWESTERN RAILROAD INC
PERU INDUSTRIAL RAILROAD, LLC

PICKENS RAILWAY COMPANY

PICKENS RAILWAY COMPANY

PIEDMONT RAILWAY LLC D/B/A PIEDMONT & NORTHERN RAILROAD
PIONEER INDUSTRIAL RAILWAY CO

PIONEER VALLEY RAILROAD COMPANY

PITTSBURGH ALLEGHENY & MCKEES ROCKS RR CO
PLAINVIEW TERMINAL COMPANY

POINT COMFORT & NORTHERN RAILWAY COMPANY
PORT BIENVILLE RAILROAD

PORT HARBOR RAILROAD INC

PORT JERSEY RAILROAD CO

PORT OF TILLAMOOK BAY RAILROAD

PORT RAIL, INC.

PORT TERMINAL RAILROAD ASSOCIATION

0s
OPT
OERR
OPE
OPR
OTVR
oTT
OUCH
OHRY
0TCO
OVRR
PHL
PI
PAL
PCC
PAS
PNR
PBR
PRV
PVS
PDRR
POVA
PT
PSCC
PN
PSWR
PIR
PICK
PKHP
PNRW
PRY
PVRR
PAM
PTC
PCN
PBVR
PHRR
PIR
POTB
PRI
PTRA
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PORT TERMINAL RAILROAD OF SOUTH CAROLINA PTR
PORT UTILITIES COMMISSION OF CHARLESTON SC PUCC
PORTLAND & WESTERN RAILROAD INC PNWR
PORTLAND TERMINAL RAILROAD COMPANY PTRC
PORTLAND VANCOUVER JUNCTION RAILROAD LLC PVIR
PRESCOTT AND NORTHWESTERN RAILROAD COMPANY PNW
PROGRESSIVE RAIL INC PGR
PROGRESSIVE RAIL INC D/B/A CANNON VALLEY RAILROAD COMPANY CVRC
PROGRESSIVE RAIL INC D/B/A WISCONSIN NORTHERN RAILROAD WN
PROVIDENCE AND WORCESTER RAILROAD COMPANY PW
PYCO INDUSTRIES INC PSC
QUEBEC CENTRAL RAILWAY COMPANY QCR
QUEBEC GATINEAU RAILWAY INC QGRY
QUINCY RAILROAD COMPANY QRR
R J CORMAN RAILROAD COMPANY/ALLENTOWN LINES INC RICN
R J CORMAN RAILROAD COMPANY/CENTRAL KENTUCKY LINES RICC
R J CORMAN RAILROAD COMPANY/CLEVELAND LINE RJCL
R J CORMAN RAILROAD COMPANY/MEMPHIS LINE RICM
R J CORMAN RAILROAD COMPANY/PENNSYLVANIA LINES INC RICP
R J CORMAN RAILROAD COMPANY/TENNESSEE TERMINAL LLC RJCK
R J CORMAN RAILROAD COMPANY/WESTERN OHIO LINE RICW
R J CORMAN RAILROAD COMPANY/WV LINE RICV
R J CORMAN RAILROAD CORPORATION/BARDSTOWN LINE RJCR
RAILINK OTTAWA VALLEY RLK
RAILINK SOUTHERN ONTARIO RLHH
RAILROAD SWITCHING SERVICE OF MISSOURI INC RSM
RAPID CITY, PIERRE & EASTERN RAILROAD, INC. RCPE
RARITAN CENTRAL RAILWAY LLC RCRY
RARUS RAILWAY COMPANY RARW
READING BLUE MOUNTAIN & NORTHERN RAILROAD COMPANY RBMN
RED COAT ROAD & RAILLTD RCRR
RED RIVER VALLEY & WESTERN RAILROAD CO RRVW
RED SPRINGS & NORTHERN RAILROAD CO RSNR
REDMONT RAILWAY COMPANY INC RRC
RICEBORO SOUTHERN RAILWAY LLC RSOR
RICHMOND PACIFIC RAILROAD CORPORATION RPRC
RIO VALLEY SWITCHING COMPANY RVSC
RIPLEY & NEW ALBANY RAILROAD COMPANY RNA
RIVERPORT RAILROAD LLC RVPR
RJ CORMAN RAILROAD CO/CAROLINA LINES, LLC RICS
RJ CORMAN RAILROAD COMPANY/TEXAS LINES, LLC RJCD
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ROBERVAL AND SAGUENAY RAILWAY COMPANY, THE RS
ROCHESTER & SOUTHERN RAILROAD INC RSR
ROCK & RAIL INC RRRR
ROCKDALE SANDOW & SOUTHERN RAILROAD COMPANY RSS
ROCKY MOUNTAIN RAILCAR AND RAILROAD INC RMRR
ROGUE VALLEY TERMINAL RAILROAD CORPORATION RVT
ROSCOE SNYDER & PACIFIC RAILWAY COMPANY RSP
RSL RAILROAD LLC RSL
RUSK, PALESTINE, & PACIFIC RAILROAD, LLC RPP
RUTLAND LINE INC RL
S & L RAILROAD LLC SLGG
S&S SHORTLINE RAILROAD SSR
SABINE RIVER & NORTHERN RAILROAD COMPANY SRN
SACRAMENTO VALLEY RAILROAD SAV
SAINT MARYS RAILROAD COMPANY SM
SALT LAKE CITY SOUTHERN RAILROAD COMPANY INC SL
SALT LAKE GARFIELD AND WESTERN RAILWAY COMPANY SLGW
SAN ANTONIO CENTRAL RAILROAD, LLC SAC
SAN DIEGO & IMPERIAL VALLEY RAILROAD CO INC SDIY
SAN JACINTO TRANSPORTATION COMPANY, INCORPORATED SIR
SAN JOAQUIN VALLEY RAILROAD CO SIVR
SAN LUIS & RIO GRANDE RAILROAD INC SLRG
SAN LUIS CENTRAL RAILROAD COMPANY SLC
SAN MANUEL ARIZONA RAILROAD COMPANY SMA
SAN PEDRO RAILROAD OPERATING CO LLC D/B/A SAN PEDRO & SOUTHWESTERN
RAILROAD COMPANY SPSR
SAND SPRINGS RAILWAY COMPANY SS
SANDERSVILLE RAILROAD COMPANY SAN
SANTA CRUZ AND MONTEREY BAY RAILWAY COMPANY SC
SANTA CRUZ BIG TREES & PACIFIC RAILWAY CO SCBG
SANTA FE SOUTHERN RAILWAY SFS
SANTA MARIA VALLEY RAILROAD COMPANY SMV
SANTA TERESA SOUTHERN RAILROAD, LLC STS
SARATOGA & NORTH CREEK RAILWAY SNC
SAVAGE BINGHAM & GARFIELD RAILROAD COMPANY SBG
SAVANNAH PORT TERMINAL RAILROAD INC SAPT
SCTRR LLC SCTR
SEMINOLE GULF RAILWAY L P SGLR
SEMO PORT RAILROAD INC SE
SEQUATCHIE VALLEY RAILROAD INC SQVR
SHAMOKIN VALLEY RAILROAD COMPANY SVRR
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SHAWNEE TERMINAL RAILWAY COMPANY INC STR
SIERRA RAILROAD COMPANY SERA
SISSETON MILBANK RAILROAD SMRR
SMS RAIL LINES OF NEW YORK LLC SNY
SMS RAIL SERVICE INC SLRS
SOCIETE DU CHEMIN DE FER DE LA GASPESIE SFG
SOMERSET RAILROAD CORPORATION SOM
SOUTH BRANCH VALLEY RAIL ROAD SBVR
SOUTH CAROLINA CENTRAL RAILROAD CO INC SCRF
SOUTH CAROLINA DIVISION OF PUBLIC RAILWAYS D/B/A PALMETTO RAILWAY PR
SOUTH CENTRAL FLORIDA EXPRESS INC SCXF
SOUTH CHICAGO & INDIANA HARBOR RAILWAY COMPANY SCIH
SOUTH KANSAS & OKLAHOMA RAILROAD INC SKOL
SOUTH PLAINS LAMESA RAILROAD LTD SLAL
SOUTH PLAINS SWITCHING LTD CO SAW
SOUTHERN FREIGHT RAILROAD SFR
SOUTHERN INDIANA RAILWAY INC SIND
SOUTHERN MANITOBA RAILWAY INC SMNR
SOUTHERN RAILROAD COMPANY OF NEW JERSEY SRNJ
SOUTHERN RAILS COOPERATIVE LIMITED SORA
SOUTHERN RAILWAY OF BRITISH COLUMBIA LTD SRY
SOUTHERN RAILWAY OF VANCOUVER ISLAND LIMITED SVI
SOUTHERN SWITCHING COMPANY SSC
SOUTHWEST PENNSYLVANIA RAILROAD COMPANY SWP
SOUTHWESTERN RAILROAD COMPANY INC SW
SPARROWS POINT RAIL, LLC D/B/A BALTIMORE INDUSTRIAL RAILROAD BDR
SQUAW CREEK SOUTHERN RAILROAD SCS
ST CROIX VALLEY RAILROAD COMPANY SCXY
ST LAWRENCE & ATLANTIC RAILROAD (QUEBEC) INC SLQ
ST LAWRENCE & ATLANTIC RAILROAD CO SLR
ST MARIES RIVER RAILROAD COMPANY STMA
ST MARYS RAILWAY WEST LLC SMW
ST RAIL SYSTEM ST
STEELTON & HIGHSPIRE RAILROAD COMPANY SH
STERLING BELT LINE RAILWAY SBLN
STEWART SOUTHERN RAILWAY INC SSS
STEWARTSTOWN RAILROAD CO STRT
STILLWATER CENTRAL RAILROAD COMPANY INC SLWC
STOCKTON TERMINAL AND EASTERN RAILROAD STE
STOURBRIDGE RAILROAD COMPANY SBRR
STRASBURG RAILROAD COMPANY SRC
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SUNFLOUR RAILROAD INC SNR

SUNSET RAILWAY COMPANY SUN
SWAN RANCH RAILROAD LLC SRRR
SYDNEY COAL RAILWAY SCR
TACOMA MUNCIPAL BELT LINE RAILWAY TMBL
TACOMA RAIL MOUNTAIN DIVISION TRMW
TALLEYRAND TERMINAL RAILROAD COMPANY INC TTR
TAZEWELL & PEORIA RAILROAD INC TZPR
TEMPLE & CENTRAL TEXAS RAILWAY, INC. TC
TENNESSEE SOUTHERN RAILROAD CO INC TSRR
TENNKEN RAILROAD COMPANY INC TKEN
TERMINAL FERROVIARIA DEL VALLE DE MEXICO SA DE CV TFVM
TERMINAL RAILROAD ASSOCIATION OF ST LOUIS TRRA
TERMINAL RAILWAY ALABAMA STATE DOCKS TASD
TEXAS & NORTHERN TN
TEXAS AND OKLAHOMA RAILROAD COMPANY TXOR
TEXAS CENTRAL BUSINESS LINES CORPORATION TCB
TEXAS CITY TERMINAL RAILWAY COMPANY TCT
TEXAS GONZALES & NORTHERN RAILWAY COMPANY TXGN
TEXAS NEW MEXICO RAILWAY, L.L.C. TXN
TEXAS NORTH WESTERN RAILWAY COMPANY TXNW
TEXAS NORTHEASTERN DIVISION MID-MICHIGAN RAILROAD INC TNER
TEXAS PACIFICO TRANSPORTATION LTD TXPF
TEXAS ROCK CRUSHER RAILWAY COMPANY TXR
TEXAS SOUTH-EASTERN RAILROAD COMPANY TSE
TEXAS-NEW MEXICO DIVISION (AUSTIN & NORTHWESTERN RAILROAD COMPANY INC) TNMR
THE ALIQUIPPA & OHIO RIVER RAILROAD COMPANY AOR
THE GREAT LAKE PORT CORPORATION D/B/A THE GRAND RIVER RAILWAY GRRY
THE NELSON AND FT. SHEPPARD RAILWAY CORPORATION NFTS
THE PITTSBURGH & OHIO CENTRAL RAILROAD COMPANY POHC
THE PUGET SOUND & PACIFIC RAILROAD COMPANY A DIVISION OF THE ARIZONA &

CALIFORNIA RAILROAD CO LP PSAP
THERMAL BELT RAILWAY TBRY
THREE NOTCH RAILWAY LLC TNHR
THUNDER RAIL LTD TRR
TIMBERROCK RAILROAD COMPANY INC TIBR
TOLEDO PEORIA & WESTERN RAILWAY CORPORATION TPW
TOMAHAWK RAILWAY L P TR
TONAWANDA ISLAND RAILROAD INC TIRL
TORCH RIVER RAIL INC. TRV
TOWANDA AND MONROETON SHIPPERS LIFELINE, INC. TMSS
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TRAINS TOURISTIQUES DE CHAUDIERE-APPALACHES INC. DBA CHEMIN DE FE CFS

TRANSDISTRIBUTION BROOKFIELD RAILROAD LLC TBFR
TRANSKENTUCKY TRANSPORTATION RAILROAD CO INC TTIS
TRANSMEX/USA INC TMUS
TRI-CITY RAILROAD COMPANY TCRY
TRILLIUM RAILWAY CO LTD TRRY
TRINIDAD RAILWAY INC TRIN
TRONA RAILWAY COMPANY TRC
TUCSON CORNELIA & GILA BEND RAILROAD COMPANY TCG
TULARE VALLEY RAILROAD COMPANY TVRR
TULSA-SAPULPA UNION RAILWAY COMPANY LLC TSU
TURNERS ISLAND LLC T
TURTLE CREEK INDUSTRIAL RAILROAD INC TCKR
TWIN CITIES & WESTERN RAILROAD TCWR
TYBURN RAILROAD, LLC TYBR
U.S. RAIL CORPORATION LLC USRP
U.S. RAIL OF NEW YORK, LLC USNY
UNION COUNTY INDUSTRIAL RAILROAD COMPANY UCIR
UNION PACIFIC RAILROAD COMPANY up
UNION RAILROAD COMPANY URR
UPPER MERION AND PLYMOUTH RAILROAD COMPANY UMP
UTAH CENTRAL RAILWAY COMPANY UCRY
UTAH RAILWAY COMPANY UTAH
UTAH SOUTHERN RAILROAD COMPANY LLC USR
V AND S RAILWAY INC VSR
V&S RAILWAY INC D/B/A TOWNER RAILWAY VST
VALDOSTA RAILWAY L P VR
VANDALIA RAILROAD COMPANY VRRC
VAUGHN RAILROAD COMPANY VRR
VENTURA COUNTY RAILROAD COMPANY VCRR
VERMILION VALLEY RAILROAD COMPANY INC VVRR
VERMONT RAILWAY INC VTR
VICKSBURG SOUTHERN RAILROAD INC VSOR
VIRGINIA SOUTHERN RAILROAD DIVISION NORTH CAROLINA & VIRGINIA RAILROAD VSRR
WABASH CENTRAL RAILROAD CORPORATION WBCR
WACCAMAW COASTLINE RAILROAD CO INC WCLR
WALKING HORSE & EASTERN RAILROAD CO INC WHOE
WALLOWA UNION RAILROAD AUTHORITY WURR
WARREN & SALINE RIVER RAILROAD COMPANY WSR
WARREN & TRUMBULL RAILROAD COMPANY, THE WTRM
WASHINGTON & IDAHO RAILWAY INC WIR
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WASHINGTON COUNTY RAILROAD CORPORATION
WELLSBORO & CORNING RAILROAD LLC

WEST ISLE LINE INC

WEST MICHIGAN RAILROAD CO

WEST TENNESSEE RAILROAD CORP

WEST TEXAS AND LUBBOCK RAILWAY COMPANY
WEST VIRGINIA CENTRAL RAILROAD

WESTERN KENTUCKY RAILWAY LLC

WESTERN NEW YORK & PENNSYLVANIA RAILROAD LLC
WESTERN RAIL SWITCHING INC

WESTERN RAILROAD COMPANY

WESTERN TRANSPORTATION CO

WESTERN WASHINGTON RAILROAD, LLC

WHEATLAND RAIL INC

WHEELING & LAKE ERIE RAILWAY COMPANY

WICHITA TERMINAL ASSOCIATION

WICHITA TILLMAN & JACKSON RAILWAY COMPANY INC
WILLAMETTE & PACIFIC RAILROAD INC

WILLAMETTE VALLEY RAILWAY COMPANY INC
WILMINGTON & WESTERN RAILWAY CORP
WILMINGTON TERMINAL RAILROAD INC

WINAMAC SOUTHERN RAILWAY COMPANY
WINCHESTER AND WESTERN RAILROAD COMPANY
WINDSOR & HANTSPORT RAILWAY CO
WINSTON-SALEM SOUTHBOUND RAILWAY COMPANY (CSX TRANSPORTATION)
WIREGRASS CENTRAL RAILWAY LLC

WISCONSIN & SOUTHERN RAILROAD COMPANY

WYE TRANSPORTATION CO

YADKIN VALLEY RAILROAD COMPANY

YAKIMA VALLEY TRANSPORTATION COMPANY

YCR CORP

YELLOWSTONE VALLEY RAILROAD INC

YELM ROY PRAIRIE LINE

YORK RAILWAY COMPANY

YOUNGSTOWN & AUSTINTOWN RAILROAD CO
YOUNGSTOWN & SOUTHEASTERN RAILROAD COMPANY INC
YOUNGSTOWN BELT RAILROAD COMPANY, THE
YREKA WESTERN RAILROAD COMPANY

WACR
WCOR
WEFS
WMI
WTNN
WTLC
WwvC
WKRL
WNYP
WRS
WRRC
WTCO
WWR
WRI
WE
WTA
WTIR
WPRR
WVR
WWRC
WTRY
WSRY
WW
WHRC
WSS
WGCR
WSOR
WYEC
YVRR
YVT
YCR
YSVR
YRPL
YRC
YARR
YSRR
YB

YW

PC*MILER|Rail User’s Guide

126



E

editing stops, 40
error messages, 42

Index

3-3-3 entry, 33

3-3-3 search, 33 F
Feature Reference guide, 20
A File application menu, 24
font size, 61

apbreviations list frame options on map, 64, 65

Mexican estados, 85
: Frame Route button, 65
U.S. & Canada, 83 FSAC entry, 32

adding new products, 16 FSAC search, 32

ALK Technologies, 78 fuel surcharge railroad reference, 86

application menu, 24 :
Auto Racks routing, 48 Fuel Surcharge routing, 48

AutoRouter, 25, 29, 37, 75 G

avoid/favor junctions, 50
Geocode Files, 2

B
: H
batch processing, 2
box zoom, 63 haulage rights, 69
bulk commodity routing, 48
|
C include/exclude railroads, 49
Canadian province abbreviations, 83 installation
change data set, 54 additional products, 16
check for updates, 20 Citrix and Terminal Services, 15
Coal/Bulk routing, 48 deactivation, 18
Column Chooser, 41 important notes, 7
column widths (single route window), 41 license activation, 11
connectivity application, 2 modify, 16
copying a report, 61 multi-user network, 13
copying maps, 71 proxy server activation, 12
requirements, 5
D single user, 8
data corrections, 20 t;pae?a;pped drive, 13

data error override, 43

database for PC*MILER|Rail, 1, 3
deactivation, 18

default route options, 49

uninstalling, 18
inter-line route, 27
Intermodal routing, 48
Intermodal-Only Stations include/exclude,

Detailed Geocode report, 59 48

Detailed report, 59

directional routes, 27 ]

drag map, 65

duplicating a route, 56 joint ownership of rail lines, 69

Junction Helper, 36
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junction overrides, 43

K

Key Station report, 60
keystrokes, 25
kilometers/miles, 49

L

label railroads, 68

label stations, 67

label stops, 68

license agreement, iv
licensing information, 6

M

map data sets, 54
Map Features, 66
Map Railroads, 68
map window, 25, 63
copying, 71
drag map, 65
frame options, 64, 65
hiding/displaying features in, 66
panning, 65
printing, 70
railroad display in, 68
right mouse menu, 70
scroll bars, 66
zoom options, 63
Mexican estados, 85
mileage, 57
mileage calculation, 1
mileage summaries, 60
miles/kilometers, 49

N
new features in VVersion 22, 2

@)

options, 47
AutoRouter, 49
default, 49
single route), 48
override files, 43
override junctions, 50
ownership of rail lines on map, 69

P

PC*MILER|Rail-Connect, 2
Practical route, 48

printing maps, 70

printing reports, 61

proxy server, 12, 16

R

R260 entry, 34
R260 search, 34
rail network, 1, 3
rail network additions/deletions, 3
railroads display control, 68
railroads listed by name, 107
railroads listed by SCAC, 87
reports, 58
Detailed, 59
Detailed Geocode, 59
font size, 61
Key Station, 60
mileage summaries, 60
printing and copying, 61
saving, 62
Ribbon toolbars, 24
route calculation, 28
route entry, 29
AutoRouter, 37, 75
default options for, 49
options, 47
Routes window, 34
single route, 34, 72
station format, 29
stop editing, 40
route formulas, 48
route options, 47
Routes window, 25

S

saving/loading routes, 55
SCAC list, 87

shortcut keys, 25
Shortest route, 48
Show/Hide button, 65
single line route, 27
single route entry, 29, 72
spelling help, 31
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SPLC entry, 31
SPLC search, 31
station formats, 29
3-3-3,33
FSAC, 32
R260, 34
SPLC, 31
station name and state, 30
station name entry, 30
station name search, 31
stop entry, 29
Zoom to Stop feature, 63
stop labels, 68
switch move only railroads, 39, 49

T

TCP/IP, 2

technical support, 19
terminal switch RRs, 39, 49
trackage rights, 69
Trimble, 78

U

uninstalling, 18
updates, 20
user guides, 19

w
window position options, 26

z
zooming the map view, 63
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