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General Information:  
Updates and Patches 

 

 

Between version releases, updates and patches are periodically made available as the need arises. These 

may include corrections to any reported errors in the software or data, or access to new data releases 

(for applicable products and license types*).   

 

Please note that patches and updates are cumulative, meaning they include items from previously 

released patches/updates of the same type and for the version identified.  ALK strongly recommends 

checking for the most current updates regularly.   

 

*NOTE: If a PC*MILER product was purchased along with signing up for ALK’s Annual Update Program 

(AUP license purchase), customers are entitled to use PC*MILER during the term of their agreement as 

well as to receive software patches and data updates when and if available.  AUP licensed users will 

have access to the base version data set as well as to any more recently released data sets as they are 

available, if they are downloaded and installed.  For those who do not sign up for the AUP, PC*MILER is 

purchased as a Perpetual license which entitles the licensed user to any available software patches 

released for the purchased version, and any available toll data updates if PC*MILER|Tolls was 

purchased.  
 

For more information on upgrading a Perpetual license to an AUP license, please contact an Enterprise 

Solutions account executive at 800-377-6453 ext. 1 or email sales@alk.com. 
 

 
Downloading and Installing Updates and Patches: 
Provided you have an Internet connection, follow the steps below to install the available updates:  

 

1. Close all open instances of PC*MILER and its connectivity products.  If a third-party program that 

accesses any PC*MILER component is running, (for example, PC*MILER|Connect or 

PC*MILER|Mapping) it must be closed before updating.  

2. Open PC*MILER and select the Help tab > Windows group > Check for Updates.  The PC*MILER 

Updater dialog will open.  The Updater first checks for valid license information and then begins 

checking for available updates. 
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3. When the search for updates is complete you will see all available updates listed.  In the Download 

& Install drop-down menu next to each available update, select either Download & Install to 

download and install right away or Download to download now and install at a later time. 

 

4. Note the version number of the updates you will be downloading so you can check if the update 

installed properly (see Step 7 below).  

5. Selecting either option will begin the download process.  You will see the progress of the 

download reflected in a progress bar.  If any PC*MILER-related application is open, you will be 

prompted to close it.  After closing the application(s), click OK to continue with the download. 

 

6. If you chose Download and Install, the InstallShield Wizard will open when the download is 

finished.  Follow the instructions to complete the installation.  After installing, you will see the 

update listed under “Installed Updates” in the Updater window.  

If you chose Download, when the download is finished the button to the right will now say 

“Install”.  You can complete the installation as described above at any time in the future by 

opening the Updater window and clicking Install.  
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7. As a last step, check to make sure the update installed properly. Select the Help tab > About 

group > About… and look for the Software Version number under “This Product is Licensed To”. 

It should match what you downloaded. 

 

 
Special Notes: 
There are no special notes related to this software patch. 
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Issues Resolved 
in this Release 

 
 

General Information: 

Update Type: Software Patch 

Version Number: Version 28.0.0.341 

Date Released:  February 9, 2015 

 
Issues Resolved: 
 

Specific to PC*MILER-Windows 
 

Case ID Category Summary 

ET-57224 Documentation Documentation updated to correct a discrepancy in the reported default vehicle 

dimension settings in Europe (see section 9.6.3) 

ET-64138 Documentation Documentation updated to clarify installation steps when installing a multi-user 

license on a workstation (see pages 29-30) 

ET-64546 Installation/ 

Licensing 

For Enterprise License users, corrected the cause of a -709 licensing error that 

occurred because the application was not detecting that a workstation was 

installed as an Enterprise version 

ET-63917 Installation/ 

Licensing 

In the user.cfg file, fixed an issue where invalid entries caused the file to 

become corrupt which then caused the application to crash or become unable 

to generate a route 

ET-64395 Installation/ 

Licensing 

In the ALK.PCMiler.LicenseTool, fixed an issue that truncated user count values 

to three digits instead of four digits 

ET-62822 Installation/ 

Licensing 

After installing and activating a license, fixed an issue that caused a fatal 

exception due to Microsoft Windows security settings 

ET-63843 Installation/ 

Licensing 

For multi-user licenses, fixed issue with running a new client install from a 

server that had installed PC*MILER 28 Software Patch 28.0.0.223 

ET-61563 Avoids/Favors When importing saved geofences into PC*MILER 28, fixed an issue in the import 

process that caused geofences not to import 

ET-62538 Avoids/Favors In the Avoid/Favor Manager, fixed an issue where saved data was disabled after 

a data set change occurred 

ET-64050 Avoids/Favors In the Avoid/Favor Manager, fixed an issue where the saved data was not 

displaying in the manager immediately after it was saved but was displayed only 

after closing and re-launching the application 

ET-63449 Routing Options After setting an Arrive by date/time, fixed an issue where the ETA/ETD time 

column was not displayed in the Route window 
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ET-64049 User Interface Fixed an issue where, if Frame Areas was selected in the Map > Frame menu, 

changing the data set caused the feature not to work 

ET-63895 User Interface Fixed an issue where, after receiving a geocoding error then switching to a 

different data set, the previous error message was not being cleared 

ET-63941 User Interface If during installation you choose to remove an installed data set, fixed an issue 

where the User Interface still allowed you to switch to that data set which 

caused an error 

ET-63991 User Interface Fixed a bug that did not allow you to change to a new Map Style after changing 

a data set 

ET-64203, 

ET-64234 

User Interface If PC*MILER was installed to a Windows Server 2012 machine, fixed an issue 

that was causing the application to crash when right-clicking the map  

ET-64977 User Interface If in the Windows Taskbar and Start Menu Properties the "Auto-hide the 

taskbar" setting is selected, fixed an issue where the application wasn't allowing 

the taskbar to be displayed 

ET-65021, 

ET-64307 

User Interface If a custom Windows Display/Color Scheme was selected, fixed an issue where 

high contrast color schemes were not being accepted 

 

Specific to PC*MILER-AS/400* 

ID Category Summary 

ET-64222 Interface After installing PC*MILER 28 Software Patch 28.0.0.223, fixed a bug that broke 

the connection to the PC*MILER-AS/400 interface 

 

Specific to PC*MILER|BatchPro* 

There were no specific issues resolved in this product. 

 

Specific to PC*MILER|Connect* 

Also includes information on PC*MILER|TCP/IP* and PC*MILER|RouteMatrix* 

ID Category Summary 

ET-64104 Documentation Documentation updated to clarify the default values in the pcmserve.ini file (see 

sections 2.10 and 3.17) 

ET-65663 Interface Fixed an issue in PC*MILER|Connect that caused a disruption in the connection 

to a JD Edwards EnterpiseOne interface 

ET-63942 Interface Fixed an issue in PC*MILER|Connect that caused a disruption in the connection 

to an Oracle OTM interface 

ET-64819 Interface Fixed an issue that made the Java.new sample unable to run due to a disabled 

wrapper 

ET-65048 Interface In PCMSCalculate() fixed an issue where a 0 was returned instead of -1 for 

invalid routes 
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Specific to PC*MILER|Energy* 

ID Category Summary 

ET-64362 User Interface When using the "Pick Places on the Map" feature in Tools > Custom Place 

Manager section, fixed a geocoding error that occurred when picking a location 

near a road labeled as Energy Road 

 

Specific to PC*MILER|HazMat* 

There were no specific issues resolved in this product. 

 

Specific to PC*MILER|Mapping* 

ID Category Summary 

ET-63925 Map Fixed an issue in PC*MILER|Mapping that caused map layers to show/hide 

improperly 

ET-64004 Map Fixed an issue in PC*MILER|Mapping that caused the zoom accuracy to be 

inconsistent 

ET-65196 Interface Fixed an issue in the PC*MILER|Mapping Excel Add-In where the PlotPin and 

circle drawing functions could not be used properly 

 

Specific to PC*MILER|Spreadsheets* 

ID Category Summary 

ET-64624 Interface Fixed an issue with the PC*MILER|Spreadsheets Excel Add-In that caused the 

data to be returned as text format rather than general 

 

Specific to PC*MILER|Streets*  

There were no specific issues resolved in this product. 

 

Specific to PC*MILER|Tolls*  

There were no specific issues resolved in this product. 

 

Specific to PC*MILER|Traffic*  

There were no specific issues resolved in this product. 

 

 

 

 



 
 

PC*MILER 28 Release Notes | PC*MILER Version 28.0.0.341 Update                                                                                      Page| 7 

Specific to PC*MILER|Worldwide* 

ID Category Summary 

ET-64016 User Interface In PC*MILER|Worldwide, if the data set was changed from Worldwide-Highway 

to Streets-Middle East, fixed a crash that occurred when the new data set tried 

to load 

ET-63996 User Interface If a data set outside of North America is installed, fixed an issue where the 

Country Abbreviation drop down was missing from File > Application Settings 

 

Specific to RouteSync* 

Case ID Category Summary 

ET-63928 User Interface In the RouteSync Send Route window, fixed a display issue in the Select Vehicle 

field that listed the same vehicle name multiple times 

ET-63973 User Interface Fixed a crash when the data set is changed after signing into RouteSync in the 

User Interface 

 

 

*NOTE: Additional license applies. 
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Contact Information 
 

 

PC*MILER Technical Support. 

H: 9:00 AM – 5:00 PM EST, Monday-Friday,  

     except U.S. holidays 

P: 800-377-6453, ext. 2 

P: 609-683-0220, ext. 2 (outside the U.S.) 

F: 609-252-8108 

W: http://www.pcmiler.com/support  

E: pcmsupport@alk.com 

 

PC*MILER Sales.  

H: 9:00 AM – 5:00 PM EST, Monday-Friday,  

     except U.S. holidays 

P. 800-377-6453, ext. 1  

P: 609-683-0220, ext. 1 (outside the U.S.) 

E. sales@alk.com  

F. 609-252-8108 

W. www.pcmiler.com  

 

 
About ALK® Technologies 

ALK Technologies, a Trimble Company and global leader in GeoLogistics® solutions and navigation 

software, is focused on developing innovative solutions for transportation, logistics, mobile workforces 

and consumers.  Product lines include award-winning CoPilot®, a leading source of GPS navigation 

software for fleets, mobile operators, hardware OEMs, systems integrators, professional drivers and 

consumers.  ALK’s PC*MILER® is widely recognized as a transportation industry standard for routing, 

mileage and mapping.  ALK® Maps is a development platform designed for the transportation industry 

and provides commercial routing, geocoding and mapping visualization for enterprise applications. 

 

For more information on ALK Technologies, visit: www.alk.com or follow us at: 

https://twitter.com/ALKTech 

http://blog.alk.com/ 
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