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pc*miler® contact options

pc*miler sales                            	 technical support

Phone: 		 800-377-6453, ext 1                         Phone: 	 609-683-0220, ext 2 or		
				   609-683-0220 (Outside the U.S.)		  1.800.377.6453, ext 2
Fax: 		  609-252-8108             		  Fax: 	 609-252-8108
Email: 		  sales@pcmiler.com		  Email: 	 pcmsupport@alk.com
Web Site: 	www.pcmiler.com                         	 Web Site: 	www.pcmiler.com/support          	
				   www.alk.com		  Hours: 	 8:00am - 5:00pm EST, Mon-Fri
				 

			

system requirements   

NOTE:  Please check for updates regularly to maintain the usability of your current copy of 
PC*MILER – select the Help tab > Check for Updates.

platforms 
• PC/LAN Windows® 7, 8 and 10 running in 32-bit compatibility mode as well  
    as support for 64-bit native applications on Windows 7 and 8*
• AS/400 
• CICS®/MVS
• UNIX® (AIX, HP-UX, Sun-Solaris) and Linux™
• Citrix® Metaframe and TCP/IP functionality for use with other platforms
• Windows Server® (Terminal Server 2012, Terminal Servers, and Server 2008 including 

Server 2008 R2 running in 32-bit compatibility mode for the Interactive GUI and on 64-bit 	
processor for PC*MILER Connect, Mapping, BatchPro and Spreadsheets)

* If you install PC*MILER|Connect or Mapping v30 on a 64-bit computer, you are given the 
option of using either the 32-bit versions or the 64-bit versions of the COM dll’s.  To switch 
between versions, you can run “Modify” in the setup to make the decision again or run 
“UseCom32.bat” to switch to 32-bits or “UseCom64.bat” to switch to 64-bits.  These .bat 
files are found in the PCMILER30\Mapping\com and PCMILER30\Connect\com folders.

NOTE: Platforms not supported include: Windows Vista, XP, Server 2000, and Server 2003.

windows® requirements

Environment: 
• PC with a minimum 1.5-2 GHz processor or networked personal computers
• 512 MB of RAM minimum, 1 GB strongly recommended for desktop users. For Citrix 

and Terminal Server, 200 MB RAM for each user running PC*MILER|Connect and 
Spreadsheets.

Other Requirements: 
• Minimum screen resolution of 800x600
• Color Quality Settings Supported: 16-bit and 32-bit (8-bit and 24-bit not supported)
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• Internet Connection for license activation (recommended) and access to select features 	
    such as Satellite imagery, real-time Traffic data, fuel prices, and Weather data.
• Email address for license activation

PC*MILER (all values are approximate): 
• PC*MILER – 3.1 GB hard disk space for full install (including all Add-ons listed below 

except PC*MILER|Energy, and all Connectivity products)
	 ○ PC*MILER|Tolls – 50 MB hard disk space
	 ○ PC*MILER|HazMat – 50 MB hard disk space
	 ○ PC*MILER|Streets (U.S. Data) – 1.3 GB hard disk space
	 ○ PC*MILER|Streets (Canadian Data) – 60 MB hard disk space
	 ○ Canadian Postal Codes – 50 MB hard disk space
	 ○ Standard Point Location Codes (SPLC) – 2 MB hard disk space
	 ○ PC*MILER|Worldwide – See the PC*MILER User’s Guide, Requirements section
	 ○ PC*MILER|Energy – Additional 2.6 GB hard disk space

Connectivity Products:
• PC*MILER|Connect – 13 MB hard disk space  
• PC*MILER|Mapping – 7 MB hard disk space
• PC*MILER|Spreadsheets – 3 MB hard disk space
• PC*MILER|BatchPro – 7 MB hard disk space
• PC*MILER|TCP/IP – 6 MB hard disk space

NOTE: PC*MILER|Connect and PC*MILER|Spreadsheets support x86-64 architecture.  
Our software was not ported to IA-64 architecture although it will still be supported 
through a hardware compatibility mode.

TripDirect™ Requirements:
• CoPilot® Truck™ running on one or more mobile devices and registered with CoPilot  
    Live messaging  (only works with appstore CoPilot Truck, not with any integrated products)
• CoPilot Truck Version 9 supported platforms are: iPhone, iPad, and Android
• TripDirect license key code and street-level data in the US and/or Canada
• TMS solution to dispatch the route to the device
• PC*MILER 30
• PC*MILER|Streets or other confirmed 6-digit precision lat/longs
• Active remote connection on the device (no airplane mode)

These additional components will also be installed:
• Microsoft® Visual C++ 2005 Re distributable Package (x86) – 6 MB hard disk space
• WindowsInstaller-KB884016-v2-x86.exe (x86) – 2 MB hard disk space 
• .NET dotnetfx.exe (x86) – 280 MB hard disk space
• Microsoft .NET Framework 4.6

as/400 requirements 
PC to AS/400 Connectivity Options (Not Provided by ALK) 
• PC with a 2+ GHz processor
• Client Access Express V4R4MO or higher, also known as iSeries Access (recommended)
• Supports OS/400, i5/OS and IBMi operating systems; Version 4.2 (V4R2) and higher on 
    IBM AS/400, System i and Power Systems™ hardware
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cics requirements

Because PC*MILER-CICS employs a distributed processing solution, the following 
additional hardware is required to run the software:

• A dedicated PC with a high-end Pentium processor (1.5-2 GHz or greater) 
• 512 MB of RAM (minimum), 1 GB strongly recommended 
• Communication software from Quotium Technologies (formerly ICOM Informatics)  
   called Winsurf+ can be found at www.Quotium.com
 

unix and linux requirements
 

Contact PC*MILER Technical Support for more information. 

general licensing information

Single-User License: Can be installed to only one PC/workstation locally.

Multi-User License: A multi-user license can be installed to a server environment, on the 
computer that will be sharing the licenses to other computers.  It allows “x” number of 
concurrent workstation connections to PC*MILER at a time.  For example, a 5-User License 
allows PC*MILER to be installed on a central server or PC with as many workstation PCs as 
you want to have access, but it only allows 5 users to access PC*MILER at the same time.

Enterprise License: An Enterprise License allows users to install PC*MILER on any 
combination of end-user PCs or workstations without license limitations.  It’s a cost-effective 
installation and licensing solution for larger companies with several users.  It does not 
require license activation but requires signing an enterprise license supplemental agreement 
directly with ALK.

Additional Copy License: Users can install PC*MILER locally onto additional PCs by 
purchasing additional copy licenses.  If you purchase 5 copy licenses, you can install 
PC*MILER locally onto five additional PCs or workstations.  If you are installing onto a 
desktop PC and a laptop, two licenses are needed. 

installation

Available PC*MILER installation types are the following:

Non-Network (Local) Installations: Allows you to install PC*MILER to a PC or workstation 
locally, not onto a server environment to be shared with other computers.
 
Network Installations: Allows you to install PC*MILER on network file servers where each 
end-user can save their own option settings or can share option settings that are stored on 
the server.  

NOTE:  PC*MILER 30 supports silent installations.

Citrix/Terminal Services Installations: PC*MILER can be installed onto a Citrix Server or 
into a Terminal Services environment, if you have purchased a license to do so.  Each end-
user must have a license to gain access to PC*MILER.
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Trial Installation: A trial installation is a 15-day license to access PC*MILER’s features 
and data.  It includes an installation of PC*MILER that provides highway-level routing, 
mileage and mapping, with options to install street-level routing, truck-specific 
toll costs, PC*MILER|Energy data, worldwide highway-level mileage and mapping 
(PC*MILER|Worldwide), Canadian postal codes, and SPLC.  (These additional features 
are paid upgrades when purchased.)  A trial installation cannot be upgraded, it must be 
uninstalled and reinstalled to add another product or feature. 

important notes

IMPORTANT — Microsoft® Windows® 8 and Above : It is strongly recommended that you 
avoid installing to the Program Files or Program Files (x86) folder. If you need to do so, you’ll 
have to Run as Administrator when you open PC*MILER.

PC*MILER Interfaces: For those who are interfacing any PC*MILER component to a 
transportation management, logistics management or other third-party software system, 
please contact the vendor directly to make sure that the interface to this new version of 
PC*MILER is updated and complete before you install.

Access to Updates and Patches: Just a friendly reminder to frequently check PC*MILER’s 
Updater for posted updates and patches applicable to your license type and components.  In 
PC*MILER, go to the Help tab > Check for Updates.  

Microsoft Windows 7, 8, 10 and Windows Server 2012 Users Only: Your license must be 
installed and activated using an Administrator Account.  Once installed, you do not have to 
“Run as an Administrator” provided you install to the recommended default directory or to 
another directory that doesn’t require users to “Run as an Administrator”

Automatic Installation of Microsoft® .NET Framework 4.6:  The PC*MILER Version 30 
installation will automatically install Microsoft .NET Framework 4.6.  This upgrade resolves 
some feature display issues in the previous version of PC*MILER for users of Windows 8.1, 
10 and Server 2012 operating systems.

single-user local (non-network) installations

NOTE: Have your Product Key Code on hand before beginning the installation. It will be 
emailed to you from alkservices@alk.com in an email titled, “PC*MILER Software Order…” 
(Enterprise License customers excluded, see note in Step 5 below.) You will see “Single” 
in the Product Key email, indicating that you have purchased a single-user license.  If not, 
please contact an Enterprise Solutions Account Executive to purchase the correct license.

NOTE for Upgrade Installations: If a an additional license was purchased, a separate email will 
be sent with a second Product Key Code and you will need to upgrade the PC*MILER license 
with this code at the end of the installation.  See Installing an Upgrade Product on page 8.

BEFORE INSTALLING, please double-check that the emailed Product Key Code(s) lists 
all purchased components.  For example, the code shown below unlocks the following 
components: PC*MILER|BatchPro, TripDirect, PC*MILER|Tolls, and PC*MILER|Streets. 
 Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2
== PC*MILER 30 (Single), BatchPro, Canadian Streets, TripDirect, Tolls, US Streets 
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UNINSTALLING A PREVIOUS VERSION: If you need to uninstall a previous version of 
PC*MILER on the computer that you are now installing to, you must uninstall the previous 
version before installing PC*MILER 30.  If you do not need to uninstall, it is possible to 
have both versions of the desktop program installed on the same system.  Please note that 
PC*MILER|Connect, PC*MILER|Mapping and PC*MILER|Spreadsheets will be updated to 
the new version.

NOTE on CONVERTING SAVED FILES: To import saved settings and files from your previous 
version of PC*MILER, see the PC*MILER User’s Guide that is installed with PC*MILER (see 
p. 15 on how to access the User’s Guide).

1. 	 If you are downloading the installation, click the provided link in the email that was 
sent to you from ALK Technologies and follow the instructions in the email.

	 If you are installing using a DVD, place the PC*MILER Install DVD in the DVD or CD/DVD 
drive and the installation will start automatically.  If it does not start automatically, click 
the Windows Start menu.  Then, depending on your operating system, either 
1) type “d:\setup.exe” and click the search button (if the DVD drive is not the D drive, 
substitute the letter that designates the DVD drive); or 2) select Computer > [DVD drive 
letter] > setup.exe.

2. 	 A Welcome screen will open.  Click Next to review the terms and conditions of the End-
User License Agreement.  NOTE:  Depending on the current status of your Windows op-
erating system, some Windows updates may install automatically before the PC*MILER 
installation begins. 

3. 	 In the next screen, review the license agreement then choose “I accept…”  If this option 
isn’t selected, the setup won’t continue.  After selecting it, click Next to continue.

4. 	 When prompted, enter a User Name and Company Name and click Next.

5. 	 Enter the Product Key Code.  This 25-character code will be emailed to you from  
alkservices@alk.com with the subject line “PC*MILER Software Order…”  It can be cop-
ied from the email and pasted in.  If entering the code manually, dashes are not required 
– dashes, spaces, or no spaces are all acceptable.  Click Next when finished.

	 NOTE:  For Enterprise License customers, the Product Key Code is hard-coded into the 
installation and is valid for each install under the contracted terms.

6. 	 In the next screen you will see a list of the Licensed Features that will be installed.  
Check to make sure all the purchased features are in the list, then click Next.  Enterprise 
Users please see Disabling Licensed Features, page 10, to disable unwanted features.

7.	 Now you will see the Destination Location where all components will be installed.  To 
install to the default directory (recommended), do not make any changes and click Next.

	 By default, PC*MILER 30 installs directly to C:\ALK Technologies\PCMILER30.
		 If you decide to install to a location other than the default, click Browse to select a 

directory.  (Be sure to add “PCMILER30” to the end of the new path; for example, “C:\
PCMILER\Version 30\PCMILER30”.  If this folder is not detected, PC*MILER will add  
it automatically – see note below.)  Click OK then Next to continue.

	 IMPORTANT!  DO NOT attempt to rename your PC*MILER30 folder after installation.  
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The “PCMILER30” name is required and renaming it may cause product failure or 
unpredictable results.

8.	 In the next screen click Next to Start Copying Files.  To change any settings, select Back.  

	 If you have a previous version of PC*MILER|Connect or PC*MILER|Mapping installed, this 
alert will appear: “The install found a previous version of Connect (Mapping).  These files 
will be renamed with a .bak extension”.  If both products were previously installed, you will 
receive two alerts.  Click OK in the dialog box(es) to continue.

9. 	 Follow through with the rest of the installation.  This may take some time depending on 
the speed of the computer you are installing to.  Do not exit or reboot the computer 
during the installation.  If any error messages appear, please contact PC*MILER 
Technical Support – see page 1.

10. 	When the installation is complete, you will be prompted to view the ReadMe.txt and to 
activate your license.  If you need to use a Proxy Server to access the Internet, skip to 
Activation Using a Proxy Server on page 8.  Otherwise, leave these boxes checked and 
click Finish to proceed to the automatic activation (Step 11 below).  (NOTE: It may take 
5-15 seconds for the Product Activation window to open.)  When the ReadMe opens, 
review the information in it and then close the window.

	
	 IMPORTANT NOTE: ALK provides a 15-day temporary license prior to completing the 

activation process.  If you make a second attempt to install on the same computer, you 
will lose this 15-day temporary license.  If you experience an activation error and need 
access to PC*MILER before Technical Support is available, please do not attempt a 
second installation without assistance.

automatic license activation

11. 	The PC*MILER Product Activation window should be open.  (If it is not open, select the 
Start menu > All Programs (or equivalent) > PCMILER 30 > License Status to open  
the License Tool window, then click Activate.) 

	 If you are an Enterprise License Customer: You can bypass the following license 
activation steps of the install because you are already activated and registered with 
ALK.  To continue, close the Product Activation window then proceed to Step 15 to open 
PC*MILER and start using the application.

	 If you are not an Enterprise License Customer: If the computer you are installing to has 
an Internet connection and you have a valid email address, the license activation can 
be processed automatically.  Enter your Email Address then click Activate.  “Manual 
Activation” should be left unchecked.

	 	NOTE: Internet license activation is available 24 hours a day.  If you don’t have an active 
Internet connection or email address, please contact PC*MILER Technical Support 
during business hours for assistance.

12.	 When the activation process is complete, you will receive a message in the Product 
Activation window saying, “License Activation Complete!”.  Close the window to continue.  
If the activation failed, skip to Step 16 below for manual activation.

13.	 To verify that PC*MILER is now licensed, go to the Windows Start menu > All Programs 
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        (or equivalent) > PCMILER 30 > License Status.  In the PC*MILER License Tool window, 
        verify that “Licensed” appears under Status.  PC*MILER is now activated.  If “Licensed”  
        is NOT in the Status field, skip to Step 17 below for manual activation.

	 If PC*MILER|Traffic was purchased, you can install it right after activation or it can be  
	 installed at a later time.  Skip to the PC*MILER|Traffic Subscription Upgrade section on 	
	 page 8 for instructions on how to add the license to your base PC*MILER application.
	
14.	 If the automatic activation was completed, close the License Tool window.  An email 	
	 titled “PC*MILER 30 Activation Code for Product XXXXX…” from alkservices@alk.com 	
	 will be sent to the email you entered in Step 11.  Just keep this email for your records.

15. 	To start PC*MILER once the installation is complete, double-click the PC*MILER icon 
on the desktop, or select the Windows Start menu > All Programs (or equivalent) > 
PCMILER 30 >  and choose PCMILER 30 or another installed PC*MILER product.

	
16.	 Before using PC*MILER, click the Help tab > Check for Updates and download and       
        install any available updates.

manual activation

17.	 (You only need to follow these steps if the automatic license activation process failed.)  	
	 If the automatic activation (Steps 11-12 above) fails for any reason, try manually  
	 activating.  In the Product Activation window, enter your Email Address (and TripDirect 	
	 password if applicable) then check “Manual Activation”.

18.	 Next, click the provided URL for the ALK activation site.

19.	 You will be taken to the ALK Technical Support “Activate Product” web page, and your 	
	 PC*MILER product key will automatically populate the Product Key fields.  Click Next.

20.	 Now enter your Email address and click Finish.

21.	 An email titled “PC*MILER 30 Activation Code for Product XXXXX…” from  
	 alkservices@alk.com will immediately be sent to the email you entered.

22.	 Copy the activation code directly from the Activation web page or from the email sent to 	
	 you, and paste it into the Activation Code field in the Product Activation window.

23.	 Click Activate in the Product Activation window to complete the activation.

24.	 You will see the message “License Activation Complete!”.  Close the Product Activation 	
	 window, and check the license status as in Step 13 above.

25. 	To start PC*MILER once the installation is complete, double-click the PC*MILER icon 
on the desktop, or select the Windows Start menu > All Programs (or equivalent) > 
PCMILER 30 >  and choose PCMILER 30 or another installed PC*MILER product.

26.	 Before using PC*MILER, click the Help tab > Check for Updates and download and       
        install any available updates.
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installing additional licensed pc*miler products

NOTE:  For data upgrades (for example, PC*MILER|Worldwide), see page 9.

If an additional license was purchased (for example, PC*MILER|Traffic, PC*MILER|Weather 
or TripDirect), a separate upgrade product key will be sent in an email along with the base 
PC*MILER product key.  Follow the steps below to install the upgrade after PC*MILER has 
been installed and activated. 

1. 	 If the PC*MILER License Tool window is not already open, click the Windows Start  
menu and select Programs > PCMILER 30 > License Status to open this window.

2. 	 Click Add License.

3. 	 In the PC*MILER Product Activation window, enter the upgrade product key that was 
emailed to you and click Add License.

4. 	 When prompted, enter your Email Address then click Activate.  

5. 	 When the activation process is complete, you will receive a message on the screen say-
ing, “License Activated Successfully.”  The upgrade is now complete.

6.	 You will immediately receive an email from ALK Technologies that contains the new 
activation code for this upgrade.  Keep this email for your records.

7.	 To start PC*MILER, double-click the PC*MILER icon on the desktop, or click the Windows 
Start menu > All Programs (or equivalent) > PCMILER 30 > PCMILER 30.

activation using a proxy server

To activate PC*MILER using a Proxy Server, follow these steps:

1. 	 When the installation is complete (Steps 1-9 on page 5-6), uncheck the Activate  
check box and then click Finish.

2. 	 Next, start PC*MILER:  either click the PC*MILER icon on the desktop, or click the  
Windows Start menu > All Programs (or equivalent) > PCMILER 30 > PCMILER 30.

3. 	 Select the File menu > Application Settings > Proxy.

4. 	 Check Use Proxy Server then enter a Host and Port.

5. 	 If needed, check Proxy Authentication then enter a Username and Password.

6.	 Click OK to save your settings and close the dialog.  PC*MILER is now set up to use  
the indicated proxy server when connecting to the Internet.

7.	 Close PC*MILER.

8.	 In the Windows Start menu, select All Programs (or equivalent) > PCMILER 30 >  
License Status to open the PC*MILER License Tool window, then click Activate.

9.	 Follow the steps beginning on page 6 for automatic activation.
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installing pc*miler data add-ons

To install additional add-ons (for example, PC*MILER|Worldwide*, PC*MILER|Energy or 
DTOD-Compliant data) to the base installation of PC*MILER, follow the steps below.  The steps 
assume that, after purchasing the data add-on(s), you either 1) received an email from ALK 
Technologies that provides one or more URL link(s) to the setup.exe required for the data 
install; or 2) received an installation DVD which includes the data you are adding (or two DVDs 
if you purchased Worldwide data).
* Including PC*MILER|Worldwide Streets data sets.

NOTE:  Please check that you have the latest updates before installing additional components. 
Open PC*MILER and select the Help tab > Check for Updates.

1.	 If you are using a DVD, insert the DVD and skip to Step 7 below.

If you are using the email sent to you by ALK, click the download link at the bottom of 
the email.  The email’s subject line will say “PC*MILER 30 Software Oder #...”.  You may 
see more than one link, depending on what was purchased – begin with the topmost link.

2.	 A web page will open and you will be prompted to open or save the PC*MILER zip file.  
Click Save and select a folder where you want to save the zip file.

3.	 The download will begin.  A very small progress bar in the upper right corner of the web 
page will track the progress of the download.  The progress bar will disappear when the 
download is finished.

4.	 Navigate to the folder where you saved the zip file, and double-click the file to open it.

5.	 Click Extract at the top of the window that opens to extract the contents of the zip file to a 
separate folder in the same location.  The progress of the extraction will be tracked at the 
bottom of the window.

6.	 When the extraction is complete, open the extracted folder and run the setup.
exe as follows:  For Windows 7 users, right click the setup.exe and select “Run as 
administrator”.  For other operating systems, just double-click the setup.exe.

7.	 The PC*MILER Data Installer – InstallShield Wizard will open.  Click Next to continue.

NOTE:  If an update to PC*MILER is available, you will be prompted to install it before 
continuing with the upgrade.  Click OK at the prompt.

8. 	 Select “I accept the terms of the license agreement” then click Next.

9. 	 A prompt will tell you to select “Add License” in the next screen – click OK.

10. 	After a few seconds the PC*MILER License Tool window will open – click Add License.

11.	 In the PC*MILER Product Activation window, enter the Product Key for the purchased 
data add-on, then click Add License.  The product key can be copied and pasted from  
the email that was sent to you at the time of purchase.

12.	 Enter your Email Address in the next screen, then click Activate.

13.	 When the activation is finished you will see a “License Activation Complete!” message.  
Close the Product Activation and License Tool windows by clicking on the “X” in the upper 
right corner of each window.
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14.	 (AUP Customers Only)  At this point, you may see a prompt asking if you want to delete the 
data from the previous quarter.  Select Yes or No.

15.	 Back in the InstallShield Wizard, you will see a list of all the PC*MILER Licensed Features 
that will now be installed.  Click Next.

16.	 Now you will see the Destination Location where the new data will be installed.  To 
install to the default directory (recommended), do not make any changes and click 
Next; or click Change to change the destination folder.  The default destination folder is 
C:\ALK Technologies\PCMILER30.

17.	 In the next screen, click Next to Start Copying Files.

18.	 At the end of the copying process, a prompt will appear that says “Setup will now create  
a backup copy of your user.cfg file…”.  Click OK.

19.	 Click Finish in the next screen.  Your data add-on is now ready to use.

The title bar of the PC*MILER application window will include the installed data add-ons, and 
you will see the new data set in the Map tab > Utilities group > Change Data Set menu.  All 
installed data sets are listed in this menu, and the data set you just installed will be activated 
by default.  Refer to the PC*MILER User’s Guide on changing the map data set (see page 15 
on how to access this Guide).

disabling licensed features (enterprise users only)
If you are an Enterprise User and need to disable one or more licensed features that came 
packaged with your installation, follow the steps below.

1.	 Open a command prompt window (for Windows 7, click the Windows Start menu, type 
“cmd” and then press Enter).

2.	 In the command prompt window, navigate to the folder containing PC*MILER’s  
	 setup.exe by typing cd “C:\your_install_location”.  
	 Example: cd “C:\alk technologies\pcmiler30”

3. 	 To launch the install while turning a specific feature off, use the following example 
of what to type but use the feature names of your choice (see below for valid feature 
names):  setup.exe<space>Connect<space>off<space>Mapping<space>off.   

	 Any combination of the features listed below can be disabled, feature names are not 
case sensitive.

	 CanPost	 Connect	 TCPIP	 HazMat
	 MVSConnect	 Mapping	 Tolls		  Spreadsheets
	 AS400	 TripMatrix	 Traffic	 BatchPro
	 AS400 Tolls	 Streets	 TripDirect	 SPLC
		  CanadaStreets	
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multi-user network installations

NOTE: Have your Product Key Code on hand before beginning the installation. It will be 
emailed to you from alkservices@alk.com in an email titled, “PC*MILER Software Order…” 
(Enterprise License customers excluded, see note in Step 4 below.)  You should see“X-User” 
in the Product Key email, signifying that you have purchased a multi-user license.  If not, 
please contact an Enterprise Solutions account executive to purchase the correct license.

UNINSTALLING A PREVIOUS VERSION: See note on page 5 under Single User Installations.

CONVERTING SAVED FILES: See note on page 5 under Single User Installations.

NOTE FOR INSTALLING TO A MAPPED DRIVE: For customers who install to a mapped drive 
(this is rare), do not enter the location by its mapped name.  For example, if you mapped 
C:\Apps to F:\, just use C:\Apps as the install directory when InstallShield asks you for the 
location.  Beginning in Version 28, the Windows program that PC*MILER uses to automate 
folder sharing cannot share mapped drives by using their mapped name (i.e. F:\ in the 
example above).

BEFORE INSTALLING, please double-check that the emailed Product Key Code(s) lists 
all purchased components.  For example, the code shown below unlocks the following 
components: PC*MILER|Connect, PC*MILER|Tolls, TripDirect, and PC*MILER|Streets.  

Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2
== PC*MILER 30 (XX-User), Canadian Streets, Connect, Tolls, TripDirect, US Streets 

To install PC*MILER 30 on a network, follow these steps:

1. 		 Begin by installing PC*MILER to the server: follow steps 1-9 for Single User Installations 
on pages 4-6.

2.	 When the installation is complete, you will see an InstallShield Wizard message that says 
“PC*MILER has set up your UNC Path and created a shared folder on this server.  Your 
workstations can now access this shared network folder to install PC*MILER.”  The last 
line of the message will provide the location of PC*MILER on the server.  Click OK

3.	 You will be prompted to view the ReadMe.txt and to activate your license.  If you need 
to use a Proxy Server to access the Internet, skip to Activation Using a Proxy Server on 
page 8.  Otherwise, leave these boxes checked and click Finish to continue.  Review the 
ReadMe and then close the window.

	 IMPORTANT NOTE: ALK provides a 15-day temporary license prior to completing the 
activation process.  If you make a second attempt to install on the same computer, you 
will lose this 15-day temporary license.  If you experience an activation error and need 
access to PC*MILER before Technical Support is available, please do not attempt a 
second installation without assistance. 

4.	 After you click Finish, the PC*MILER Product Activation window will open.    

	 If you are an Enterprise License Customer: You can bypass the following license 
activation steps of the install because you are already activated and registered with ALK.  
To continue, close the Product Activation window.  PC*MILER is installed on the server  
and can be opened by double-clicking the PC*MILER icon on the desktop, or clicking the 
Windows Start menu > All Programs (or equivalent) > PCMILER 30 > PCMILER 30.
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	 If you are not an Enterprise License Customer: If the computer you are installing to has 
an Internet connection and you have a valid email address, the license activation can 
be processed automatically.  Enter your Email Address then click Activate.  “Manual 
Activation” should be left unchecked.

	 	NOTE: Internet license activation is available 24 hours a day.  If you don’t have an active 
Internet connection or email address, please contact Technical Support during business 
hours for assistance.

5.	 If the activation is successful, you will see a “License Activation Complete!” message 
that directs you to open an email from ALK Technologies for further instructions.  If the 
activation was NOT successful, try activating manually (Steps 16-23 on page 7) before 
calling Technical Support.  To contact PC*MILER Technical Support, see page 1.

6.	 After activation, open the email you received, then follow the instructions for copying the 
“net.lic” file included with the email to the “App” folder in your PC*MILER installation.  
Net.lic holds the license or user count for your installation.  Until you save this file to the 
designated folder, you will only have a single-user installation.  The PC*MILER application 
is now accessible on the server (see Step 2 below for access options).

installing on a workstation (multi-user)
To install PC*MILER 30 on each workstation, follow these steps:

1.	 Click the Windows Start menu and enter the network path, then press Enter on the keyboard.  
To find this path, navigate to the server’s “PCMILER30” folder, right-click the folder, and go to 
Properties > Sharing.  The network path can be copied and pasted from there.  

2.	 Next, you will be asked to choose your workstation setup options.  Two screens will prompt 
you to select the type of settings you would like to use.  

	 The setup options in the first screen (Settings Location) are:

	 • Use local setting – Allows each workstation to customize default options and  
	 settings within the application.

	 • Share network settings – Provides each workstation the same default options  
	 and settings within the application.

	 The setup options in the second screen (Settings Data) are:
	 • Use local data – Installs data to the local workstation.  This option can decrease  

	 the time it takes PC*MILER to open and begin processing, and reduces network 
		  traffic.  In general, the performance is better.  However, there must be enough hard 	

	 disk space to accommodate the data.
	 • Share data on your network, default – This is the default choice.  PC*MILER uses  

	 the shared data that was installed on the server.

	 NOTE: for TripDirect Users:  Currently only one TripDirect account is allowed per 
installation.  To access TripDirect functionality from multiple workstations, one master 
TripDirect account must be shared.

3.	 To start PC*MILER on a workstation once the installation is complete, double-click the 
PC*MILER icon on the desktop, or click the Windows Start menu and select All Programs  
(or equivalent) > PCMILER 30 > PCMILER 30.
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citrix and terminal services installations

NOTE: Have your Product Key Code(s) on hand before beginning the installation process.   
They will be emailed to you from alkservices@alk.com in an email titled, “PC*MILER  
Software Order…” (Enterprise License customers excluded)  “(Citrix/Terminal Services)” will 
be included in the Product Key email signifying that you have purchased a Citrix or Terminal 
Services license.  If this is not listed, please contact an Enterprise Solutions account 
executive to purchase the correct license and request one Product Key Code for each 
individual server you are installing to.

NOTE: If you need to uninstall a previous version of PC*MILER on the computer that you  
are now installing to, you must uninstall the previous version before installing PC*MILER 30.   
If you do not need to uninstall, it is possible to have both versions of the desktop program 
installed on the same system.  Please note that PC*MILER|Connect, PC*MILER|Mapping  
and PC*MILER|Spreadsheets will be updated to the new version.

CONVERTING SAVED FILES:  To import saved custom settings and files from your previous 
version of PC*MILER, refer to the PC*MILER User’s Guide that is installed with PC*MILER 
(see page 15 on how to access it).

BEFORE USING PC*MILER:  Citrix supports 16 bit and 24 bit color, while PC*MILER  
supports 16 bit and 32 bit color.  A Citrix end user must set the color resolution on their 
workstation to 16 bit before they log into a Citrix server to run PC*MILER.  If an end user 
has their color resolution set to 32 bit and logs in to Citrix, the Citrix software will adjust it 
downward to 24 bit prior to loading PC*MILER, and PC*MILER will fail to load.

BEFORE INSTALLING, please double-check that the emailed Product Key Code(s) lists 
all purchased components.  For example, the code shown below unlocks the following 
components: PC*MILER|BatchPro, PC*MILER|Tolls, TripDirect and PC*MILER|Streets.  

Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2
== PC*MILER 30 (Citrix), BatchPro, Canadian Streets, TripDirect, Tolls, US Streets 

If you were using an existing version of PC*MILER with PC*MILER|Connect and/
or PC*MILER|Mapping in your Citrix environment, there may be existing files that re-
quire deletion.  Citrix and Terminal Servers can have multiple copies underneath C:\
Users\<username>\Windows,  C:\Documents and Settings\ <username>\Windows or in 
%homedir%\windows like H:\Windows.  Copies of the following files should be deleted from 
any location outside of C:\WINDOWS: 

• Pcmserve.ini	 • Pmwssrv.ini
• Pcmserve.ctx	 • Pmwxxrv.ctx

IMPORTANT:  Only a qualified Citrix administrator should be installing PC*MILER on a 
Citrix system.  With Citrix in Install Mode, follow the steps in Single User Local Installations 
on pages 4-6.

as/400 and cics installations 
Please contact PC*MILER Technical Support (see page 1) if assistance is needed. 
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proxy setup for internet access 
The following PC*MILER features require a connection to the Internet: license activation; 
software update and patch downloads via the Updater tool; real-time traffic data; satellite 
imagery on the PC*MILER map; and TripDirect.

For those who need to bypass current security settings to access the Internet while using 
PC*MILER, the steps to complete the proxy setup are below.  The setup can be implemented 
after PC*MILER has been activated or before activation during the temporary grace period 
after installation.

1. 	 Open PC*MILER and select the File menu > Application Settings > Proxy.

2. 	 Check Use Proxy Server then enter a Host and Port.

3. 	 If needed, check Proxy Authentication then enter a Username and Password.

4.	 Click OK to save your settings and close the dialog.  PC*MILER is now set up to use  
the indicated proxy server when connecting to the Internet.

importing saved files and settings from a previous version 
Saved route files, custom road preferences, custom places, and geofence files can all be 
transferred from the previous version of PC*MILER (Version 28) to the newly-installed 
version.  Saved route files will be automatically updated when they are opened in PC*MILER 
30.  Refer to the PC*MILER User’s Guide for custom place, custom road, and geofence file 
conversion (see page 15 on how to access the Guide).

Additionally, a Settings Importer utility is provided that lets you import most custom route 
options, custom road speeds, map feature settings, custom route profiles, and general 
application settings from the previous version.  See the PC*MILER User’s Guide for details 
and a list of settings that won’t be imported using this utility.

frequently asked questions (FAQ)

For FAQs related to problems you may have with the installation of your PC*MILER products, 
please go to www.pcmiler.com/support.

updates and patches

PC*MILER Updates and Patches 
To check for mid-release updates/patches from within PC*MILER, select the Help tab > 
Windows group > Check for Updates.  A dialog box will appear that alerts you to any available 
updates.  You can then choose to “Download and Install” or download now and install later.  

Refer to the PC*MILER User’s Guide for more detailed instructions (see page 15).  

You can also search for PC*MILER product updates by going to www.pcmiler.com/support: 
select a product, then click the “Updates/Patches” link in the upper right corner of the web 
page.  If you choose to download an update, you’ll need to double-click the downloaded file 
on your PC to begin the installation. 14



PC*MILER|Tolls Updates
To receive quarterly toll data updates, you must first sign up for ALK’s Update Program 
Subscription Plan.  If you’re an Enterprise License customer, you are automatically 
enrolled in this program.  Once enrolled, ALK will contact you when each new quarterly toll 
data update is available for download.  

To make sure all applicable parties in your organization receive update notifications, email 
tolls@alk.com with their contact information.  Quarterly update notifications are sent via email 
from replies@alk.com in HTML format.  Please put both these emails on your email provider’s 
Safe Sender Recipients List to ensure that you receive all related emails.

getting help within the program

PC*MILER includes a user guide that can be opened from within the application.  For best 
results you should have Adobe Acrobat Reader installed to open and navigate through this 
document.  If you don’t have this software, go to www.adobe.com for a free download.

To make Adobe Reader your default reader, from within the Adobe Reader application select 
the Edit menu > Preferences > General and click Select Default PDF Handler.  Select Adobe 
Reader from the drop-down, then click Apply and OK to close the Preferences dialog.

To open the PC*MILER User’s Guide from within PC*MILER, select the Help tab > Help 
Index, press the F1 key on your keyboard, or click a help button where one appears in a 
dialog.

To search for a keyword or phrase in a user guide, use Adobe Reader’s Find option in the Edit 
menu or on the tool bar.

accessing user guides using the windows start menu or web 
To access the user guide for any PC*MILER product without first opening an application, click 
the Windows Start menu and select All Programs (or the equivalent option) > PCMILER 30 
> User Guides.  

All user guides can also be accessed at www.pcmiler.com/support.

feature reference guide 
For users of Version 29 or a previous version of PC*MILER, a Feature Reference Guide is 
provided to get you up and running quickly with Version 30.  To access it, click the Windows 
Start menu and select All Programs (or the equivalent option) > PCMILER 30 > User Guides 
> Feature Reference Guide.

readme file 
Consult the ReadMe file for last-minute product information, updates to the PC*MILER 
documentation and additional feature information.  To open the ReadMe, click the Windows 
Start menu > All Programs (or the equivalent option) > PCMILER 30 > ReadMe.
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deactivating and uninstalling a license

You must fully deactivate the product’s license and uninstall all PC*MILER components, 
including local, network, enterprise, or server installations if you are:
     • Moving any PC*MILER installation to a new computer
	 • Reformatting a computer that PC*MILER is currently installed to
	 • Returning the product
	 • Reinstalling on the same PC

Follow the steps below to deactivate.

1. 	 Go to the Windows Start menu > Programs (or the equivalent option) > PCMILER 30 > 
License Status and in the PC*MILER License Tool window click Deactivate.  

2. 	 In the PC*MILER Product Deactivation window, click Deactivate.

3.	 When the deactivation is complete, you will see a “Deactivation Complete” message, with 
the deactivated product keys listed below.  Close the Product Deactivation and License 
Tool windows.

4.	 To uninstall after deactivating, go to the Start menu > Settings > Control Panel >  
Programs and Features (or  the equivalent on your system).

5.	 In the Programs and Features window, highlight PC*MILER 30.  Right-mouse click and 
select Uninstall.

6.	 Click Yes at the prompt to completely remove the application.

7.	 Click Finish when the installation process is complete.

NOTE:  If any messages appear during the uninstall process that say that a certain file 
cannot be removed, click OK to continue.

8.	 !! IMPORTANT STEP !!  Once the uninstall is finished, delete the …ALK Technologies\
PCMILER30 folder manually to completely remove the PC*MILER application from your 
system.  The default location for this folder is C:\ALK Technologies\PCMILER30.

NOTE:  If you deactivated/uninstalled an installation that included PC*MILER compo-
nents that were licensed and added after the initial installation, you will need to add 
those components separately again when you reinstall.
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pc*miler product line end-user license agreement

Please carefully review the terms and conditions included in the End-User License Agreement 
(EULA) before using this product.  The agreement provides a documented license to use the 
software and contains warranty information and liability disclaimers.  By installing or using 
the software, you are confirming acceptance of the software and agreeing to become bound 
by the terms of the agreement. The EULA can be viewed at the beginning of the installation 
process and in the PC*MILER User’s Guide.  

ALK, CoPilot, and PC*MILER are registered trademarks of  
ALK Technologies, Inc.  All other brands or product names are trademarks  

or registered trademarks of their respective holders.
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