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New Features & Enhancements 

 
 
 

 
 

New features and enhancements in PC*MILER Version 30 products are briefly described below.  For 
more details, see the PC*MILER User’s Guide that was installed with PC*MILER.   Products covered in 
these Version Release Notes include: 
 

• PC*MILER • PC*MILER|Spreadsheets • Multi-Version Switch (MVS) 
• PC*MILER|Connect • PC*MILER|BatchPro  
• PC*MILER|Mapping • PC*MILER|TCP/IP  

 

 

PC*MILER User Interface 
 
SUMMARY: 

 NEW!  Access to PC*MILER|Weather information and alerts. 
 NEW!  ALK’s MapSure Service for custom data enhancements. 

 NEW!  Route and Vehicle Profiles combined into one new Route Profiles feature. 
 NEW!  National Network and 53' Trailer and Twins routing combined and renamed to “State + 

National Network”. 
 NEW!  U.S.-based 60/70-hour duty limits factored into HOS route planning. 
 NEW!  Optional empty/loaded miles designation between stops.  
 NEW!  Optional Governor (maximum) road speed designation. 

 NEW!  Frame Route and Show/Hide Route buttons in route windows. 
 NEW!  PC*MILER|Tolls discount program update. 
 ENHANCED!  Redesigned Application Settings dialog. 
 ENHANCED!  Redesigned Route Options dialog. 

 ENHANCED!  Improved U and K turn routing logic for medium and heavy duty trucks. 
 ENHANCED!  Search for saved Custom Places when planning a route or inserting HOS stops. 
 ENHANCED!  RouteSync feature renamed to “PC*MILER|TripDirect” in the User Interface. 
 ENHANCED!  ETA’s refined and streamlined with other ALK products. 
 ENHANCED!  “Divided” road type renamed “Major Highway”. 

 ENHANCED!  Automatic .NET Framework upgrade from Version 4.5 to 4.6 during installation. 
 ENHANCED!  Yearly database enhancements and routing improvements in North America. 

 

Se
ct

io
n 
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FEATURE DETAILS: 

 NEW!...  PC*MILER|Weather to Access Weather Information and Alerts. 

NOTE:  This feature requires a purchased license and an Internet connection, and is only available in 
the User Interface.  If PC*MILER is integrated with other systems, access to Weather features is 
available with an ALK Maps license. 
 
Now PC*MILER users can visualize predicted weather patterns across the U.S. and Canada on the 
map through the use of radar, precipitation, and general alert layers.  Additionally, a Weather Alerts 
Report is available that summarizes predicted weather alerts for a route.*  This feature enables 
users to identify where a planned route is scheduled to pass through a predicted weather alert zone.  
Weather data is provided by Environment Canada (EC), U.S. National Weather Services (NWS) with 
data from the U.S. National Oceanic and Atmospheric Administration (NOAA), and AerisWeather. 
 

* NOTE: The predicted weather information provided should not be construed to mean that significant and/or 
hazardous conditions will occur, it should only serve as a notice that the event described is possible. 

 
Weather features are enabled by default if PC*MILER|Weather is licensed and installed.  To 
enable/disable weather features, select the File menu > Application Settings > Weather.   You will 
see the date and time of the last data update below the Enable Weather check box.   Weather data 
is refreshed each time the PC*MILER application is started, and then at 30-minute intervals or less 
until the application is closed.  Here you can also uncheck any Weather Alert Categories that you 
don’t want to see or receive alerts for.   
 
 

 
PC*MILER|Weather Features Enabled 
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Weather Alerts on Planned Routes 
When Weather features are enabled and you run a route, a warning will be generated on any leg of 
the trip that travels through an alert zone for the types of alerts selected in Application Settings.  
Because alerts are time sensitive, this feature requires you to set an Arrival/Departure time of 
Now, Arrive by or Depart at.  
 
 
 
 

 
 
 
 
 
 
 
 
 

 
Weather Reports 
Click “View Report” in any warning message in the route window to open a report that provides 
details of all alerts generated along the route. For each alert, the information in this report includes, 
from left to right, the route leg, alert type, effective time, expiration time, and the certainty, 
severity, and urgency ratings.  Double-click a bolded alert to zoom to that trip leg on the map. 
 

 

 
Weather Report for a Route – Louisville, KY to Memphis, TN 

 

Weather Display on the Map 
To display weather data on the map, select the Map tab > Weather > and check one or more options 
(Radar Layer, Cloud Layer, or Weather Alerts).  You will immediately see the type(s) of data you 
selected on the map. 
 

Radar Layer – Displays current weather patterns as they are received from Aeris Weather. 
Cloud Layer – Displays current patterns of precipitation (cloud formations) as they are 

received from Aeris Weather.  This data does not contribute to the 
generation of alerts, it is a visual aid only. 

Weather Warning on a Route Affected Area on the Map 
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Weather Alerts – Displays polygons in different colors (see Alerts Legend below) that represent 
areas where a predicted weather alert has been issued by the U.S. National 
Weather Service or Environment Canada.   

 

 

 
Cloud and Radar Layers Enabled 

(Weather data provided by Aeris Weather) 
 

Important NOTE:  The predicted weather information provided should not be 
construed to mean that significant and/or hazardous conditions will occur, it should only 
serve as a notice that the event described is possible. 
 

Weather alerts and weather patterns on the map reflect current conditions, which are 
updated every 30 minutes or less.  Therefore, conditions that trigger an alert at the time 
a planned route is generated may not trigger that alert if the route is run again at a later 
time. 

 
 

Alerts Legend & Tooltips on the Map 
To see an Alerts legend, select the Map tab > Legends and check Weather Alerts.  To see a descriptive 
tooltip, place your cursor over a colored polygon on the map. 
 

 
 
 

 
 

 
 
 
 

 
 
 
 

 
 
 

Turning on the Alerts Map Legend 

Alerts Legend 

Tooltip on an Alert Area 
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 NEW!...  ALK’s MapSure Service for Custom Data Enhancements.  
In Version 30, PC*MILER|Streets users with an ALK Cloud account now have access to the ALK 
MapSure website to submit map data enhancement requests.  A request may be related to any 
problems you encounter on the map related to missing or incorrect street addresses, street or 
highway names, turn restrictions, one-way designations, truck restrictions and allowances, toll road 
designations, or ZIP/Postal Codes.   

From within PC*MILER select the Help tab > Open MapSure in Browser or right-click the map and 
select Report a Map Problem….* On ALK’s MapSure web page, follow the on-screen instructions to 
report an error or a needed enhancement. 
* ALK’s MapSure feature is only available if PC*MILER|Streets is licensed and installed, and won’t appear in 

Highway-Only versions of PC*MILER. 
 
NOTE:  If you have PC*MILER installed behind a Proxy and have trouble accessing the MapSure 
feature, please go to the File menu > Application Settings > Proxy Setup and enter your proxy 
information.  If the problem still persists, in a web browser go directly to http://mapsure.alk.com 
and login using your ALK Cloud account information. 
 
 
 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Accessing the MapSure Website 
 

 

 NEW!...  Route & Vehicle Profiles Combined into One Route Profiles Feature. 
Custom Route Profile and Vehicle Profile creation have been combined into one new Route Profiles 
feature.  Users can now create comprehensive sets of custom route options, grouped together as 
route profiles for quick access.  A profile can be applied to individual routes, or globally to all new 
routes through the use of a Default profile.  
 
Note that route options can still be applied directly to the currently open route without using a 
profile – click the Route Options button (         ) in the route window or select the Routes tab > 
Options. 
 
 

“Open MapSure in Browser” 
button in the Help tab 

“Report a Map Problem…” option in 
the right mouse map menu 
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Off the shelf, PC*MILER applies a Default profile to each new route that includes options suitable for 
48 foot semi-trailer trucks, and provides several other sample profiles suitable for different vehicle 
types.  The default 48 foot options are the same standard default settings that were historically 
applied to PC*MILER routes. These default values can be adjusted by the user to be more reflective 
of the equipment used in the field, e.g. light, medium-duty and/or heavy vehicles. 
 
To access the Manage Profiles dialog, select the Routes tab > Profiles.  To create, edit and manage 
route profiles, refer to the PC*MILER User’s Guide. 
 
 

 
Manage Profiles Dialog 

 
 

 NEW!...  National Network and 53' Trailer and Twins Routing Combined. 
The “National Network” and “53-Foot Trailer or Twins” route options are now combined into one 
“State + National Network” option in Version 30.   

In previous versions, the National Network option applied a preference to favor using the U.S. 
Federally designated National Network (primary Interstates with reasonable entry/egress points up 
to 1 mile off the Interstate).  The 53' Foot Trailer or Twins option applied a preference to favor using 
the state designated extensions to the Federal National Network (additional highways and 
supporting roads that can be any distance off the Interstate, as determined by the individual states).  
For Version 30, the State + National Network option now functions as if both options were selected. 

NOTE:  This also applies to PC*MILER|Connect, PC*MILER|Spreadsheets, Multi-Version Switch, and 
PC*MILER|TCP/IP.   
 
   

 NEW!...  U.S.-based 60/70-hour Duty Limits Factored into HOS Route Planning. 
(PC*MILER|Streets must be installed)  The HOS Manager now includes U.S.-based 60/70-Hour Duty 
Limits, in addition to the 14-hour duty limit and 11-hour driving limit.  The Federal Motor Carrier 
Safety Administration hours-of-service regulations state that a driver may restart a 7 or 8 
consecutive day period after taking 34 or more consecutive hours off duty.   
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In the HOS Manager, select your company’s schedule (US Federal 60-Hour/7 Long Haul or US 
Federal 70-Hour/8 Long Haul) in the HOS Rule Type drop-down.  Under Available Cycle Time Duty 
Hours at Origin, enter the number of on-duty hours remaining until the driver must take the next 
34-hour break.  These settings are additional to the Available Driving Hours at Origin settings. 
 

 
HOS Manager  

 

 NEW!... Empty/Loaded Miles Designation Reinstated. 
The ability to designate stops as either Loaded or Empty has been added back into Version 30.  By 
default, all stops are designated as Loaded.  To change to Empty, right-click a stop on the list in the 
route window and select Loaded to uncheck it.  Each stop in the Detailed Route report will be 
labeled “Arrive Loaded” or “Arrive Empty”, and the State/Country Distance report will list loaded 
and empty mileage by state.  Note that this designation can also be set in the HOS Manager. 
 
 
 
 
 
 
 
 
 

 

 NEW!... Optional Governor (Maximum) Road Speed Designation. 
Users can now define a “governor” (maximum) road speed that overrides all other speed values for 
a trip.  This new feature will help users to: 

• more accurately calculate ETA’s in PC*MILER; 
• publish ETA’s from PC*MILER to customers with more confidence; 
• and calculate a more accurate HOS-planned route if desired. 
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For example, PC*MILER’s default average road speed on Interstates is set to 65 mph, which directly 
affects a trip's travel time and ETA calculation. However, XYZ Trucking has a governor speed of 55 
mph on any type of road.  XYZ Trucking wants their governor speed factored into PC*MILER when it 
computes an ETA and sets the governor speed to 55 mph.  In this scenario: 

• for link A, the existing speed is 35 mph and PC*MILER’s ETA calculations use 35 mph for 
that link; 

• for link B, the existing speed is 60 mph and PC*MILER’s ETA calculations use 55 mph for 
that link. 

 
The PC*MILER default governor speed is 55 mph and is configurable. To enable this setting, select 
the Routes tab > Options > Routing Preferences and select Enable under Governor Speed Limiting.  
Then enter a maximum speed and click Save.   
 
 

  
Governor Speed Setting – Route Options Dialog 

 
 

 NEW!...  Frame Route and Show/Hide Route Buttons in the Route Window. 
These new buttons in the route window frame the route on the map and toggle the map display of 
the route on/off. 
 
 
 

 
New Route Window 

 

Show/Hide  
Route on Map 

Frame Route  
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 NEW!...   PC*MILER|Tolls Discount Programs Update. 
(PC*MILER|Tolls must be licensed and installed.)  For Version 30, all Version 29 toll discount 
programs are available and a new program, RiverLink, has been added.  This new tolling system on 
three bridges between Louisville, KY and Indiana is scheduled by the tolling authority to become 
active in “late 2016” (currently, the construction of the bridges is not complete, and no date has 
been set).  Therefore, the toll rate in PC*MILER will be zero ($0.00) until the active program is 
incorporated in a quarterly toll data update.  Note that the tolling authority is issuing two types of 
transponders for these bridges: RiverLink and EZPass. 
 
PC*MILER’s use of toll discount programs is enabled by default when PC*MILER|Tolls is installed.  To 
enable/disable discounts, select the Routes tab > Options > Reporting Preferences.  To enable/ 
disable individual discount programs, select the File menu > Application Settings > Tolls.   
 
 

 
Available Toll Discount Programs – Application Settings Dialog 

 
 

 ENHANCED!...  Redesigned Route Options Dialog for Individual Routes. 
The new Route Options dialog still allows customized options to be set for one route at a time.  It 
includes the same tabs as the Profile Options dialog, with an additional Arrival/Departure tab.  Most 
options will be familiar from previous versions, although several Routing Preferences have been 
renamed.  New route options in Version 30 are: 
 
• Governor Speed Limiting (Routing Preferences tab)   

 
 
 
 
 

Select Enabled in the drop-down and enter a maximum speed that overrides all other speed 
values for a trip.  See page 7-8 for details. 
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 Road Network (Routing Preferences tab) 
 
 
 
 

The new State + National Network routing option combines the National Network and 53 Foot 
Trailer or Twins options from previous versions of PC*MILER.   See page 6 for details. 

 

NOTE:  The Tolls* and Road Speeds tabs of the Route Options dialog in previous versions have 
been moved to File menu > Application Settings; and HazMat route types are now under Routing 
Preferences in Route Options. 
* Appears in Application Settings only when PC*MILER|Tolls has been purchased and installed. 

 
NOTE Also:  Fields in the Route Options dialog will be disabled if the user does not have 
permission to edit them due to network installation restrictions.   

 

 Alerts  (Reporting Preferences tab) 
 
 
 
 

If PC*MILER|Weather is licensed and installed, the Enable Weather Analysis option turns 
weather reporting and alerts on/off.  In the Application Settings dialog Weather tab, the 
“Enable” option has the same function and controls whether this option is enabled in Route 
Options, but not vice versa.   This allows the setting to be turned on/off for a single route in 
Route Options without affecting the application setting that affects all new routes. 

 

 ENHANCED!...  Redesigned Application Settings Dialog. 

The Application Settings dialog has been revamped with tabs that group related options, and 
includes additional options that were formerly accessed through the Route Options dialog or the 
Help ribbon.  To open Application Settings, select the File menu > Application Settings. 
 

Click on each category on the left to access its options.  Click Apply to apply your edits to the 
currently open route, click Save to save changes and close the dialog.  
 
 

 

Redesigned Application Settings Dialog 
 



Options that have been moved to the Application Settings dialog in Version 30 are: 
 

In Version 29  New Location in Version 30 

Help ribbon > Proxy Setup File menu > Application Settings > Proxy 
Route Options > Road Speeds tab File menu > Application Settings > Road Speeds 
Route Options > Tolls tab* 
* (appears only if PC*MILER|Tolls is installed) 

File menu > Application Settings > Tolls – Note:  The use  
of toll discount programs must be enabled in the Route 
Options dialog > Reporting Preferences tab. 

Route Options > Cost/Time tab File menu > Application Settings > Route Costs 
Route Options > State/Country Report Order  File menu > Application Settings > Report 
Route Options > Ferry Distances  File menu > Application Settings > Report 
Route Options > Region  File menu > Application Settings > General 
Route Options > Length and Distance in  File menu > Application Settings > Units 
Route Options > Fuel in  File menu > Application Settings > Units 

 
 

 ENHANCED!...  Improved U and K Turn Routing for Medium and Heavy Duty Trucks. 
ALK has improved its routing logic to estimate whether a turn-around on a twinned highway 
(highway that has lanes going in opposite directions, e.g. southbound and northbound lanes) is likely 
to be an easy U turn, a difficult U turn, or a very difficult K turn.  In Version 30, when a turn-around 
is necessary an easier turn-around location will be chosen for the route. 

 
 

 ENHANCED!...  Search for Custom Places When Planning a Route or Inserting HOS Stops. 
Users can now search for saved custom places on a planned route.  For example, you may want to 
change an inserted HOS stop to a custom place on a route generated using the HOS Manager.  To do 
this, follow these steps in the route window (PC*MILER|Streets must be installed): 

1. Click Change. 
2. HOS Stop should be selected in the stop type drop-down. 

 
3. In the category drop-down, uncheck all categories except Custom Place. 

 
4. Click Search to open a pick list of all saved custom places. 

5. Make a selection from the list and click OK. 
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 ENHANCED!...  RouteSync Feature Renamed to “TripDirect”. 
The RouteSync feature has been renamed “PC*MILER|TripDirect” in the PC*MILER user interface.  
The functionality of this feature remains the same, it enables users to send a PC*MILER route 
directly to ALK’s CoPilot Truck navigation software that’s downloaded from an app store and used in 
the cab.  This change is intended to distinguish the trip dispatch functionality within the PC*MILER 
user interface from the related but different RouteSync functionality available for integration with 
third party systems via PC*MILER|Connect.  (A license for PC*MILER|TripDirect is required to use 
this feature.) 
 

   
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 ENHANCED!...  ETA’s Refined and Streamlined With Other ALK Products. 
For Version 30, ALK has put significant effort into further enhancing the accuracy of PC*MILER’s 
estimated times of arrival to ensure consistency between PC*MILER and other ALK products such as 
CoPilot Truck. 

 
 

 ENHANCED!...  “Divided” Road Type Renamed “Major Highway”. 
You’ll see this name change in the File > Application Settings > Road Speeds tab, the Road Type 
report, and the Road legend on the map. 

 
 

 ENHANCED!...   .NET Framework Upgrade from Version 4.5 to 4.6. 
The PC*MILER Version 30 installation will automatically install Microsoft .NET Framework 4.6 if it is 
not already installed.  This upgrade resolves some feature display issues in the previous version of 
PC*MILER for users of Windows 8.1, 10 and Server 2012 operating systems. 

 
 

 ENHANCED!...  Yearly Database Enhancements and Routing Improvements in North America. 
Routing improvements are a major part of each PC*MILER release and each annual version release 
confirms our commitment to enhancing the quality of PC*MILER’s truck-specific routing database.  
Each year we add many routing enhancements to improve PC*MILER’s truck-specific database, 
mileage calculations and driving directions.   
 

Access to TripDirect in PC*MILER 
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In addition to the ongoing improvements mentioned above, Version 30 features improved precision 
and coverage of nationwide U.S. street-level address ranges (requires an installation of 
PC*MILER|Streets). 
 
 

 ENHANCED!...  Annual Updates of Defaults for US$/CAD$ Conversion Rate and Trip Costs. 
In Version 30, the default US dollar/Canadian dollar conversion rate as applied to toll rates (if 
PC*MILER|Tolls is installed) and default fuel/trip costs are as shown below (in U.S. dollars).  To 
customize these values go to the File menu > Application Settings > Tolls tab and Route Costs tab.   
 

Reference Notes: 
(1)  http://www.fiscal.treasury.gov/fsreports/rpt/treasRptRateExch/treasRptRateExch_home.htm  
(2)  Transport Topics 3.21.2016, p. 4 
(3) James Langley, TMW VP of Business Analytics, 2013, from a survey of 62 North American truck carriers 

with > 200 mile average haul, totaling 21,000 trucks. 
(4)   Emission Facts, U.S. Environmental Protection Agency publication EPA420-F-05-003, February 2005, p. 2 
 

American Transportation Research Institute (ATRI) Reference: 
2015 updated study – http://atri-online.org/2015/09/29/an-analysis-of-the-operational-costs-of-trucking-
2015-update/ 

 
 

 

 
SUMMARY: 

 NEW!  Three API’s to query/create route profiles created in the PC*MILER user interface. 
 NEW!  API and PCMSERVE.INI global setting for converting diacriticals to usable characters. 
 NEW!  HOS API to factor in U.S.-based 60/70-Hour Duty Limits. 
 NEW!  API’s to set and get a global Governor (maximum) road speed. 
 NEW!  “State + National Network” route type. 
 NEW!  Toll discount program added. 
 NEW!  JAVA-based wrapper server.jar relaced by alk.jar. 
 ENHANCED!  ROADTYPE_DIVIDED constant changed to ROADTYPE_MAJORHIGHWAY. 
 ENHANCED!  Updated sample code. 
 Deprecated in Version 30:  
• PCMSSetProfileName() API (use PCMSSetRoutingProfileName() instead) 
• PCMSZipCodeUSAndMexico() API (use PCMSZipCodeOption() instead) 

Cost/Time Parameter Version 30 Version 29 

US$/Canadian$ Conversion Rate (note 1) $1.00/$1.29 $1.00/$1.277 
Fuel Cost Per Gallon (note 2) $2.10 $2.78 
Fuel Cost Per Liter  $0.55 $.73 
Fuel Cost Per Mile (Loaded or Empty) $.32 $.43 
Fuel Cost Per Kilometer (Loaded or Empty) $.20 $.43 
Other Cost Per Mile (Loaded or Empty) $.20 $.19 
Other Cost Per Kilometer (Loaded or Empty) $.12 $.12 
Labor Cost Per Hour (Loaded or Empty) $35.85 $32.89 
MPG – Loaded and Empty (note 3) 6.48 6.48 
Greenhouse Gas Estimates (note 4) 22.2 22.2 

PC*MILER|Connect 
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• PCMSZipCodeMexicoOnly() API (use PCMSZipCodeOption() instead) 
• PCMSZipCodeUSOnly() API (use PCMSZipCodeOption() instead) 
• PCMSSetOptions() API (use API’s for individual options) 
• PCMSGetOptions() API 
• PCMSCityToLatLong() API (use PCMSLookup with PCMSGetFmtMatch4) 
• PCMSLatLongToCity() API (use PCMSLookup) 
• PCMSLatLongToAddress() API (use PCMSLookup) 
• Defined constant ROADTYPE_DIVIDED 
• server.jar (use alk.jar instead) 

 
NOTE on ALK’s DEPRECATION POLICY:  If the “deprecated” status is applied to an API, it indicates 
that the API should be avoided when interfacing to PC*MILER.  ALK generally deprecates an API 
when a better alternative has been developed, in order to encourage users to work with the newer 
functionality.  
 
Although deprecated API’s may remain in the software, their use can produce warning messages 
and/or non-optimal results.  Features are deprecated, rather than immediately removed, in order to 
provide backward compatibility and give  developers who have been using the feature time to bring 
their code into compliance with the new standards.  A deprecated API may be removed from the 
product in the future. 
 
If a deprecated API is used in your interface to PC*MILER, when logging is turned on, a message will 
indicate where interface changes are suggested to bring your code into compliance as well as for 
best performance. 

FEATURE DETAILS: 

 NEW!...  Three API’s to Query/Apply Route Profiles Created in the PC*MILER user interface. 
 

int PCMSSetRoutingProfileName(Trip trip, const char *profileName) 

For a particular trip, the above function turns on the specified route profile created in PC*MILER.  
Use in place of the deprecated PCMSSetProfileName() API. 

Parameters: 
Trip – The trip to which this route profile will be applied. 
const char *profileName – The name assigned to the route profile when it was created in PC*MILER. 

Return Values: 
Returns -1 on error.  “Profile not found” error message will write to the log file if input name is not a 
valid route profile name. 
 
 
int PCMSGetNumRoutingProfiles(PCMServerID server) 

Gets the number of created route profiles. 

Parameters: 
PCMServerID server – The PC*MILER server ID. 
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Return Values: 
Returns the number of route profiles on success, -1 indicates an error. 
 
 

int PCMSGetRoutingProfileName(PCMServerID server, int RoutingProfileIndex, char* buffer, int 
bufSize) 

Gets the name of the route profile given its index. 

Parameters: 
PCMServerID server – The PC*MILER server ID. 
RoutingProfileIndex – The index starts from 0 and has a maximum value of the total number of 
created route profiles minus 1. 
buffer – The returned route profile name. 
bufSize – The buffer size of the returned route profile name. 

Return Values: 
Returns the number of bytes written in the buffer. 
 
 

 NEW!...  API and PCMSERVE.INI Global Setting for Converting Diacriticals to Usable Characters.  
The API and PCMSERVE.INI option below provide a global setting that turns the conversion of 
diacriticals in a text string on/off.  For example, if geocoding the address “Charny, QC; 1021 École” fails, 
the user would need to convert the diacritical in the text string “École” to a usable character.   
 
An existing API, PCMSAnglicize(),  can be used to do this for an individual trip.  The new API and INI 
setting activate automatic diacritical conversion for all trips.  Some environments and compilers do not 
have a simple way to convert UTF-8 to a string that is usable and/or properly displays on a screen or  
 
printer.  Using the new API or INI setting below can alleviate problems and crashes that are caused by 
strings that are unusable due to the inclusion of diacriticals.  
 
 

int PCMSSetAnglicize(PCMServerID server, bool onOff); 
 
Parameters: 
PCMServerID server – The PC*MILER server ID. 
bool onOff – Set to True to turn on special character conversion, the default value is False. 
Return Values:  The return is 0 for success, returns -1 on error.  
To use the PCMSERVE.INI setting, add the following line under “Connect Options”: 
 

[ConnectOptions] 
 Anglicize=true 
 
PC*MILER|Connect functions that are affected by PCMSSetAnglicize() are: 
 

PCMSGetFmtMatch PCMSGetRpt 
PCMSGetFmtMatch2 PCMSGetRptLine 
PCMSGetFmtMatch3 PCMSGetStop 
PCMSGetFmtMatch4 PCMSLatLongToCity 
PCMSGetLocAtMiles PCMSGetHTMLRpt 
PCMSGetLocAtMinutes PCMSLatLongToAddress 
PCMSGetMatch  
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 NEW!...  Hours of Service API’s Factor In U.S.-based 60/70-Hour Duty Limits.  
(PC*MILER|Streets must be installed)  The HOS Manager in PC*MILER now factors in the U.S.-based 
60/70-Hour Duty Limits.  The rule states that a driver may restart a 7/8 consecutive day period after 
taking 34 or more consecutive hours off duty.  In PC*MILER|Connect, one new and one modified API 
enable this new functionality.   
 
 

int PCMSSetHOSWeekSchedule(Trip trip, int weekScheduleType); 
 
The new function above sets a 60-hour or 70-hour duty limit. 
 
Parameters: 
Trip trip – ID of the trip. 
int weekScheduleType  – 0 = 60-hour schedule (default), 1 = 70-hour schedule. 
 
Return Values:  This API will return zero (0) upon success.  A negative one (-1) indicates an error has 
occurred.  PCMSGetError() and PCMSGetErrorString() can be used to retrieve the detailed error code 
and message if desired.  
 
 

int PCMSSetHOSAvailableTime(Trip trip, 
drivingTimeUntilRestBreakinMinutes,  
drivingTimeUntilEODinMinutes,  
onDutyTimeUntilEODinMinutes,  
onDutyTimeUntilEOWinMinutes) 

 
A new parameter has been added to the existing PCMSSetHOSAvailableTime() API: 
  
OnDutyTimeUntilEOWinMinutes  – Time in minutes of total on duty time the driver has left in their 
work week before a 34-hour break is required.  A hard limit of 3600 or 4200 minutes will apply, 
depending on the 60/70 hour schedule set with PCMSSetHOSWeekSchedule(). 
 
 

 NEW!...  API’s to Set and Get a Global Governor (Maximum) Speed.  
Users can now define a “governor” (maximum) road speed that overrides all other speed values for 
a trip.   For example, PC*MILER’s default average road speed on Interstates is set to 65 mph, which 
directly affects a trip's travel time and ETA calculation. However, XYZ Trucking has a governor speed 
of 55 mph on any type of road.  XYZ Trucking wants their governor speed factored into PC*MILER 
when it computes an ETA and sets the governor speed to 55 mph.  In this scenario: 

• for link A, the existing speed is 35 mph and PC*MILER’s ETA calculations use 35 mph for 
that link; 

• for link B, the existing speed is 60 mph and PC*MILER’s ETA calculations use 55 mph for 
that link. 

 
All estimated travel time calculations are affected by the governor speed.  Fastest routing calculations 
also take this speed into account.   
 
The PC*MILER default governor speed is 55 mph and is configurable. Use the API’s below to set and get 
a governor speed.  To disable the feature, set to zero.   
 
 
 

PC*MILER 30 Windows Version Release Notes | Page 16 
 



int PCMSSetGovernorSpeed (Trip trip, long speed); 
 
Sets the governor speed for a trip. 
 
Parameters: 
Trip trip – The trip ID. 
long speed – The governor speed must be a positive number to be in effect or set to zero (0) to 
disable the feature.  A negative speed value will result in an error being returned. There is no upper 
bound on the speed value that can be set. However, unrealistically high values will have no effect on 
the trip’s estimated travel times.  The speed unit (MPH vs KPH) is determined by the distance units 
setting of the trip. 
 
Return Values: 
Returns -1 on failure, 0 on success.  
 
 

int PCMSGetGovernorSpeed (Trip trip); 
 
Returns the governor speed setting for the trip.  The speed will be returned in units that match the 
distance units setting of the trip (MPH or KPH). 
 
Parameters: 
Trip trip – The trip ID. 
 
Return Values: 
Zero is returned if the governor speed is disabled, a positive number is returned if it is enabled. 
 
 

 NEW!...  Official End-of-Life for JAVA-based Wrapper Server.jar.   
For Java users, Version 30 marks the end-of-life for the JAVA-based wrapper server.jar.  This wrapper 
has been replaced with alk.jar, which has already been accessible to users in several previous versions 
of PC*MILER|Connect.  Alk.jar is installed in ALK Technologies\PCMILER30\Connect\Java.new. 
 
 

 NEW!...  National Network and 53' Trailer and Twins Route Options Combined.  
In PC*MILER, the route options “National Network” and “53' Trailer or Twins” from previous 
versions have been combined into one option named “State + National Network”.  See the 
description of this new route type on page 6 in the PC*MILER User Interface section.   For any API 
that calls the routing type parameter in PC*MILER|Connect, the “FiftyThree” option will be 
deprecated, leaving the “National” option to now function as if both options were selected.  
Backward compatibility for the FiftyThree option will be maintained in existing systems. 
 
 

 NEW!...  Toll Discount Program Update. 
(PC*MILER|Tolls must be licensed and installed)  A new toll discount program, RiverLink, has been 
added for use with toll calculation API’s.  This new tolling system on three bridges between 
Louisville, KY and Indiana is scheduled by the tolling authority to become active in “late 2016” 
(currently, construction of the bridges is not complete and no date has been set); therefore, the toll 
rate in PC*MILER will be zero ($0.00) until the active program is incorporated in a quarterly toll data 
update.  Note that the tolling authority is issuing two types of transponders for these bridges: 
RiverLink and EZPass. 

PC*MILER 30 Windows Version Release Notes | Page 17 
 



 ENHANCED!... ROADTYPE_DIVIDED Constant Changed to ROADTYPE_MAJORHIGHWAY.  
This defined constant is used with the PCMSSetRoadSpeed() and PCMSGetRoadSpeed() API’s.  Only the 
naming has changed, the road type attributes remain the same. 
 
 

 ENHANCED!...  Updated Sample Code.  
Updated sample code, supplemental documentation, and descriptive ReadMe files can be found in 
your PC*MILER\Connect installation folder, usually C:\ALK Technologies\PCMILER30\Connect 
\C_CPP\StaticLink.  Some sample code in the PC*MILER|Connect User’s Guide has been updated as 
well. 
 
 

 

 
SUMMARY: 

 NEW!  Two API’s to create .PNG images. 
 NEW!  “State + National Network” route type. 
 NOTE:  No API’s were deprecated in Version 30. 

FEATURE DETAILS: 

 NEW…  Ability to Create .PNG Images. 

Two new Mapping functions enable users to save .PNG, .GIF or .BMP map images.   
 

long PCMGCreateImageFile(int ImageFormat long sx, long sy, const char* buffer); 
 
Example in C#: 

 
<image button handler> 

{ int x = pbMapWin.Size.Width; int y = pbMapWin.Size.Height; 
<which image button was selected?> imageFormat = 2; fileExt = 
".gif";  
imageFormat = 3; fileExt = ".png";  
imageFormat = 1; fileExt = ".bmp";  
ret = PCMGMap.PCMGCreateImageFile(imageFormat, x, y, 
    <filename>);  
<if (ret < 0) then error> } 

 
 
 

long PCMGCreateImageBuffer(long sx, long sy, char* fileName, long option); 
 
Example in C#: 

 
int x = pbMapWin.Size.Width; 
int y = pbMapWin.Size.Height; 
 
//the first call with “null” buffers the image in core and 

PC*MILER|Mapping 
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returns the size of the buffer 
PCMGMap.PCMGCreateImageBuffer(2, x, y, null, ref 
     bufLen); 
 
//create the local buffer based on bufLen 
StringBuilder imageBuffer = new StringBuilder(bufLen); 
 
//the second call copies the image in core into the local 
buffer 
Ret = PCMGMap.PCMGCreateImageBuffer(0, 0, 0, 
     imageBuffer, bufLen); 

 
 
 

 NEW!...  “State + National Network” Route Type. 

The PC*MILER route options “National Network” and “53' Trailer or Twins” from previous versions have 
been combined into one option named “State + National Network”.   See the description of this new 
route type on page 6 in the PC*MILER User Interface section.   For plotted trips that use a route type 
parameter, the “53Foot” option has been deprecated and the “Natl” option now functions as if both 
options were selected.  Backward compatibility is maintained for the 53Foot option. 

 
 

PC*MILER|Spreadsheets 
 
SUMMARY: 

 NEW! … “State + National Network” route type.  
 NEW! … Toll discount program added. 
 Deprecated in Version 30:  No toll discount programs have been removed in Version 30. 

FEATURE DETAILS: 

 NEW!...  “State + National Network” Route Type. 
In PC*MILER, the route options “National Network” and “53' Trailer or Twins” from previous 
versions have been combined into one option named “State + National Network”.  See the 
description of this new route type on page 6 in the PC*MILER User Interface section.  For any 
function that uses a routing type parameter in PC*MILER|Spreadsheets, the “53Foot” option has 
been deprecated and the “Natl” option now functions as if both options were selected.  Backward 
compatibility is maintained for the 53Foot option. 
  
 

 NEW!...  Toll Discount Program Update. 
(PC*MILER|Tolls must be licensed and installed)  A new toll discount program, RiverLink, has been 
added for use with the =Tolls() and =DiscountedTolls() functions.  This new tolling system on 
three bridges between Louisville, KY and Indiana is scheduled by the tolling authority to 
become active in “late 2016” (currently, construction of the bridges is not complete and no 
date has been set); therefore, the toll rate in PC*MILER will be zero ($0.00) until the active 
program is incorporated in a quarterly toll data update.  Note that the tolling authority is 
issuing two types of transponders for these bridges: RiverLink and EZPass. 
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PC*MILER|BatchPro 
 
SUMMARY: 

 NEW!  “State + National Network” route type (not available in the Beta Release). 
 NEW!  Empty/Loaded miles designation (not available in the Beta Release).  
 NOTE:  No existing features have been deprecated or changed. 

FEATURE DETAILS: 

 NEW!...  “State + National Network” Route Type. 
The PC*MILER route options “National Network” and “53' Trailer or Twins” from previous versions 
have been combined into one option named “State + National Network”.   See the description of 
this new route type on page 6 in the PC*MILER User Interface section.  For Version 30, the 53’ 
Trailer or Twins option has been deprecated and the State + National Network option now functions 
as if both options were selected. 
   
 

 NEW!...  Empty/Loaded Miles Designation. 
The ability to designate stops as either Loaded or Empty has been added back into Version 30.  By 
default, all stops are designated as Loaded.   
 
 

PC*MILER|TCP/IP 
 
SUMMARY:  

 NEW!  “State + National Network” route type.  
 NEW!  Two PC*MILER|Connect functions that are now accessible in the TCP/IP layer. 
 NOTE:  No existing features have been deprecated or changed. 

FEATURE DETAILS: 

 NEW!...  “State + National Network” Route Type. 
The PC*MILER route options “National Network” and “53' Trailer or Twins” from previous versions 
have been combined into one option named “State + National Network”.   See the description of 
this new route type on page 6 in the PC*MILER User Interface section.    
 
 

 NEW! … Two Additional PC*MILER|Connect Functions Are Now Accessible. 
Two existing PC*MILER|Connect functions – PCMSSetNLAbbreviation() and PCMSAnglicize() – are now 
accessible in the TCP/IP layer in Version 30. 
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Multi-Version Switch (MVS) 
 
SUMMARY:  

 NEW!  “State + National Network” route type.  
 NEW!  Two PC*MILER|Connect functions that are now accessible in the Multi-Version Switch layer. 
 NOTE:  No existing features have been deprecated or changed. 

FEATURE DETAILS: 

 NEW!...  “State + National Network” Route Type. 
The PC*MILER route options “National Network” and “53' Trailer or Twins” from previous versions 
have been combined into one option named “State + National Network”.   See the description of 
this new route type on page 6 in the PC*MILER User Interface section.   The 53’ Trailer or Twins 
option has been deprecated and the State + National Network option now functions as if both 
options were selected.  Backward compatibility is maintained for the 53 Foot option. 
 
 

 NEW! … Two Additional PC*MILER|Connect Functions Are Now Accessible. 
Two existing PC*MILER|Connect functions – PCMSZipCodeOption() and PCMSSetNLAbbreviation() – 
are now accessible in the Multi-Version Switch layer in Version 30. 
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System Requirements 

 
 
 

 

SYSTEM REQUIREMENTS 
 

 
PC*MILER for Windows Version 30 Requirements: 
 

• PC with a minimum 1.5-2 GHz processor  
• Windows® 7, 8 and 10 running in 32-bit compatibility mode for the Interactive GUI (the 

PC*MILER Connect, Mapping, BatchPro and Spreadsheets programs will run on 64-bit processors) 
• Citrix and TCP/IP functionality for use with other platforms 
• Windows Server® (Windows Server 2012, Terminal Servers, and Server 2008 including Server 

2008 R2 running in 32-bit compatibility mode for the PC*MILER user interface and on 64-bit 
processors for PC*MILER Connect, Mapping, BatchPro, and Spreadsheets)  

• 512 MB RAM minimum, 1 GB strongly recommended for standard desktop users.  For Citrix and 
Terminal Server, 200 MB RAM per user for  PC*MILER|Connect and PC*MILER|Spreadsheets. 

• 3.1 GB Hard Disk Space for full install (including all Add-ons except PC*MILER|Energy) 

NOTE:  In Version 30, automatic installation of Microsoft® .NET Framework 4.6 requires 4.5 GB, 
which reduces in size down to 39 MB once it is installed. 
 

• Color Quality Settings Supported: 16-bit and 32-bit (8-bit and 24-bit not supported) 
• Minimum Screen Resolution of 800 x 600 
• Internet Connection for License Activation and access to select features such as Satellite imagery, 

PC*MILER|Weather updates, real-time Traffic data on the RouteMap, and updated fuel prices. 
 
 
 

NOTE:  PC*MILER|Connect and PC*MILER|Spreadsheets support x86-64 architecture.  Our software was 
not ported to IA-64 architecture although it will still be supported through a hardware compatibility 
mode. 

 
NOTE:  Platforms not supported include Windows 95, 98 First/Second Edition, Me, 2000, NT, 2003, 
Vista, XP, Windows Server 2000, and Windows Server 2003. 
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Addendum:  Overview of HOS Functionality in PC*MILER 30 
 
 

The table below summarizes the U.S. government’s Hours of Service (HOS) regulations that PC*MILER’s 
HOS functionality incorporates into Version 30. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 

 
A summary of federal HOS regulations can be found on the following web page: 

https://cms.fmcsa.dot.gov/regulations/hours-service/summary-hours-service-regulations 
 

For more detailed coverage of the HOS rules for drivers, see: 
https://cms.fmcsa.dot.gov/regulations/title49/part/395 

Hours of Service Rules (HOS) for  
Property Carrying Drivers in the U.S. – PC*MILER 30 

11-Hour Driving 
Limit 

May drive a maximum of 11 hours 
after 10 consecutive hour’s off-duty. 

14-Hour Limit 

May not drive beyond the 14th 
consecutive hour after coming on 
duty, following 10 consecutive hours 
off-duty.  
 
Off-duty time does not extend the 14-
hour period. 

Rest Breaks 

May drive only if 8 hours or less have 
passed since end of driver’s last off-
duty or sleeper berth period of at least 
30 minutes.  
 
Does not apply to drivers using either 
of the short-haul exceptions in 
395.1(e). 
 
[49 CFR 397.5 mandatory “in 
attendance” time may be included in 
break if no other duties performed] 

60/70-Hour  
Duty Limit 
 

May not drive after 60/70 hours on 
duty in 7/8 consecutive days. A driver 
may restart a 7/8 consecutive day 
period after taking 34 or more 
consecutive hours off duty.  
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