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General Information:  
Updates and Patches 

 
 
Between version releases, updates and patches are periodically made available as the need arises. These 
may include corrections to any reported errors in the software or data, or access to new data releases 
(for applicable products and license types*).   
 
This particular release includes the: 

• PC*MILER 29 Software Patch 29.2.61.0 
 
Please note that patches and updates are cumulative, meaning they include items from previously 
released patches/updates of the same type and for the version identified.  ALK strongly recommends 
checking for the most current updates regularly.   
 
*If a PC*MILER product was purchased along with ALK’s Annual Support & Update Program (an AUP license purchase), 
customers are entitled to use PC*MILER during the term of their agreement as well as to receive data updates when and if 
available. Otherwise, PC*MILER is purchased as a Perpetual license. For more information on upgrading a Perpetual license to 
an AUP license, please contact a PC*MILER Account Executive at 800-377-6453 ext. 1 or email sales@alk.com. 

 
Downloading and Installing Updates and Patches: 
PC*MILER is equipped with a web-based update tool to facilitate the download and installation of 
software patches and updates.  To access this feature, open PC*MILER and select the Help tab > Check 
for Updates and follow the instructions on the screen.  This feature requires an Internet connection.   
 
Provided you have an Internet connection and applicable license type, follow the steps below to install 
the available updates:  
 

1. Close all open instances of PC*MILER and its connectivity products.  If a third-party program that 
accesses any PC*MILER component is running, (for example, PC*MILER|Connect or 
PC*MILER|Mapping) it must be closed before updating.  

2. Open PC*MILER and select the Help tab > Windows group > Check for Updates.  The PC*MILER 
Updater dialog will open.  The Updater first checks for valid license information and then begins 
checking for available updates. 

3. When the search for updates is complete you will see all available updates listed.  In the Download 
& Install drop-down menu next to each available update, select either Download & Install to 
download and install right away or Download to download now and install at a later time. 

4. Note the version number of the updates you will be downloading so you can check if the update 
installed properly (see Step 7 below).  

5. Selecting either option will begin the download process.  You will see the progress of the 
download reflected in a progress bar.  If any PC*MILER-related application is open, you will be 
prompted to close it.  After closing the application(s), click OK to continue with the download. 
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6. If you chose Download and Install, the InstallShield Wizard will open when the download is 
finished.  Follow the instructions to complete the installation.  After installing, you will see the 
update listed under “Installed Updates” in the Updater window.  

If you chose Download, when the download is finished the button to the right will now say 
“Install”.  You can complete the installation as described above at any time in the future by 
opening the Updater window and clicking Install.  

7. As a last step, check to make sure the update installed properly. Select the Help tab > About 
group > About… and look for the Software Version number under “This Product is Licensed To”. 
It should match what you downloaded. 

 
 

Special Notes: 
There are no special notes related to this software patch. 
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Issues Resolved 
in this Release 

 
 

General Information: 
Product: PC*MILER 29 

Update Type: Software Patch 

Version Number: Version 29.2.61.0 

Date Released:  January 20, 2016 

 
Issues Resolved: 
 

Specific to Installation 
Case ID Category Summary 

PCM-210 General Fixed an issue in the system Add/Remove Programs window where 
PC*MILER's installation size was not displayed correctly. 

PCM-448 General Fixed an issue when after installing PC*MILER 29 Software Patch 1 
(released 10/5/2015), the installed files overwrote the pcmserve.ini file 
back to default settings on workstation installs. 

PCM-628 General Fixed an issue with the Silent Install where installers were unable to 
bypass the License Status screen at the end of the install. 

PCM-677 General During the install of PC*MILER|Worlwide* and/or the DTOD Data Add-
On*, if you choose to remove your base NA data set and then go to the 
Map menu's > Change Data Set menu, the base data set is still listed 
and causes a crash if selected. 

 
Specific to PC*MILER User Interface 

Case ID Category Summary 

PCM-247, 
PCM-447 

ALK Cloud Fixed an issue when logged into the ALK Cloud and the Data Set is 
changed (in Map > Change Data Set), where the active login status was 
not showing as "online".  

PCM-248 Avoids/Favors Fixed a save error when trying to save more than one custom 
avoid/favor set. 
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PCM-385, 
PCM-616 

General Fixed an issue where some special character letters were not displayed 
correctly in the POI search pick list and in saved Custom Places. 

PCM-429 General Fixed a drive time calculation issue where the Drive Time column was 
miscalculating the total trip time by including stop time entered at the 
origin. 

PCM-436 General Fixed a crash observed when no default printer is set up on the 
computer where PC*MILER is installed to. 

PCM-626 General In Map menu > Legends, corrected a misnamed feature where Scale of 
Miles was misnamed Scale Bar. 

PCM-661 General Fixed a crash stating that the "OpenClipboard Failed" after clicking on 
the Copy button in the State/Country Report. 

PCM-173 Map Fixed an issue on the map where the rectangular geofence map pointer 
was not being refreshed to the general map pointer when the geofence 
features were turned off. 

PCM-256 Map Fixed an issue in PC*MILER|Worldwide's Middle East region where 
some Arabic city names were not displayed correctly on the map. 

PCM-172 Reports When saving a report from the File > Application menu, fixed an issue 
where the active report was not being saved and instead only the last 
opened report was saved. 

PCM-372 Reports Fixed a calculation in the Road Type Report that incorrectly tallied miles 
on Interstate and Divided classed roads. 

PCM-425 Route Options Fixed an issue in the Route window's Options dialog where the Save 
button was disabled when the Permits button was checked. 

PCM-168 Tools Fixed an issue during the conversion of saved geofences that 
interpreted a rectangular geofence incorrectly as a free form polygon. 

PCM-297 Tools Fixed an issue importing geofences where the conversion completed 
but the Geofence Manager was not showing the imported geofences. 

PCM-701 Tools Fixed an issue when moving geofences.db from PC*MILER 28 into 
PC*MILER 29, where when opening the User Interface the UI hung and 
would not open. 

PCM-253 User Interface In the Route window's Column Chooser feature, fixed an issue where 
the "Move Up" and "Move Down" buttons didn't function as 
documented. 
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Specific to PC*MILER-AS/400*  
There were no specific issues resolved in this product. 

 
Specific to PC*MILER|BatchPro* 

There were no specific issues resolved in this product. 

 
Specific to PC*MILER|Connect* 
Also includes information on PC*MILER|TCP/IP* and PC*MILER|RouteMatrix* 

Case ID Category Summary 

PCM-658 APIs Fixed an issue with PCMSSetProfileName() where it failed to select the 
26' Straight Truck and 48' Semitrailer Vehicle Profiles when requested. 

PCM-388 Documentation Updated the documentation to include a list of time zone indices for 
use with APIs that calculate ETA/ETD. 

PCM-401 Documentation Documented these existing APIs in the Visual Studio IntelliSense: 
PCMSZipCodeUSAndMexico(), PCMSZipCodeMexicoOnly() and 
PCMSZipCodeUSOnly(). 

PCM-312 PC*MILER|TCP/IP Fixed a crash observed while starting pcmsock64.exe. 

PCM-349 PC*MILER|TCP/IP Fixed an issue where the TCP/IP interface was not returning a valid XML 
document that included <ORIGIN> and <DESTINATION> in log files.  

PCM-645 Performance Fixed a memory management issue which caused a small amount of 
memory to be released which was used by the trip and trip options.  For 
users of Connect and TCP/IP who have a large number of transactions, 
this fix will help to alleviate system freezes and/or disconnects. 

 
Specific to PC*MILER|Energy*  

There were no specific issues resolved in this product. 

 
Specific to PC*MILER|HazMat* 
There were no specific issues resolved in this product. 

 
Specific to PC*MILER|Mapping*  

There were no specific issues resolved in this product. 
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Specific to PC*MILER|Spreadsheets* 
Case ID Category Summary 

PCM-367 Documentation Updated the documentation for the function =LatLongToAddress() to 
confirm the expected output. 

PCM-351 General Fixed an issue where ZIP Codes starting with "00" weren't being 
interpreted correctly, e.g. ZIP Codes in the US Virgin Islands. 

PCM-379 General Fixed an issue where the LatLonFormatDecimal setting in the 
pcmserve.ini file was not correctly outputting the lat/long, e.g. setting 
true should return decimal degrees and setting false should return 
DDDMMSS. 

PCM-416 General Fixed a Visual Basic error in Microsoft Office 2007 when opening 
pcmsrv32.xla. 

PCM-660 General Corrected an application error of "Error 1004: Application-defined or 
object-defined error" when exiting Microsoft Excel 2013 64-bit. 

 
Specific to PC*MILER|Streets*  
There were no specific issues resolved in this product. 

 

Specific to PC*MILER|Tolls*  
There were no specific issues resolved in this product. 

 
Specific to PC*MILER|Traffic*  
There were no specific issues resolved in this product. 

 
Specific to PC*MILER|Worldwide* 

Case ID Category Summary 

PCM-302 Route Options Fixed an issue where the "Use Highway Only" route option was not 
available if only a few Worldwide Street-level regions were installed. 

PCM-361 Route Options Fixed an issue in Default Route Option where Vehicle Profiles were not 
updated when the Region was changed. 

PCM-362 Route Options Fixed an issue in the Route window's Options dialog where the "Use 
Highway Only" check box was displayed even though the data set 
loaded did not include a Streets region. 

PCM-619 Route Options If the Asia Street Region is installed, fixed an issue where the Route 
window's route option summary did not display Streets when it was 
turned on. 
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PCM-391 Tools Fixed an issue in the Avoid/Favor Manager window where the display of 
the nearest city was sometimes listed in the wrong country. 

PCM-663 Tools Fixed an issue selecting and saving Vehicle Profiles. 

PCM-630 User Interface Fixed an issue when generating routes with the Region set to Europe, 
the sample "12m straight truck" Vehicle Profile was forced on and it 
should have only been an optional setting. 

 
Specific to RouteSync* 

Case ID Category Summary 

PCM-282 RouteSync Fixed an issue in the RouteSync Send window where the message 
confirming that a route was sent was not being displayed after “Send to 
CoPilot” was selected. 

PCM-283 RouteSync Fixed an issue in the ALK Cloud's Vehicle Manager where the Manager 
was not refreshing itself after logging out. 

PCM-639 RouteSync Fixed a display issue that occurred after logging into an ALK Cloud 
account and selecting Show Vehicles on the map. 

PCM-293 PC*MILER|Connect Fixed an issue with PCMSGetRouteSyncMsg() when 
RouteSyncJSONFormat=true in the pcmserve.ini, where the external 
RouteID was not displayed in the output file. 

PCM-495 PC*MILER|Connect Fixed an issue in PCMSReduceTrip() where routing results were being 
returned on roads not included in the initial bread crumb trail of 
lat/longs. 

 
 

*NOTE: Additional license applies. 

 
 

  

  Page | 7 



  
Contact Information 

 

 
PC*MILER Technical Support. 
H: 8:00 AM – 5:00 PM EST, Monday-Friday,  
     except U.S. holidays 
P: 800-377-6453, ext 2 
P: 609-683-0220, ext 2 (outside the U.S.) 
E: pcmsupport@alk.com 
W: http://www.pcmiler.com/support  
 

PC*MILER Sales.  
H: 9:00 AM – 5:00 PM EST, Monday-Friday,  
     except U.S. holidays 

P. 800-377-6453, ext 1  
P: 609-683-0220, ext 1 (outside the U.S.) 
E. sales@alk.com  
W. www.pcmiler.com  

 
 

 

 

About ALK Technologies 
ALK® Technologies, Inc., a Trimble® company headquartered in Princeton, NJ, was founded in 1979 as a 
transportation industry pioneer. ALK harnesses the power of information technology to enhance 
transportation and mobility, supporting competitive advantage and improved quality of life 

Today, ALK is a global leader in GeoLogistics® solutions and navigation software, focused on developing 
innovative solutions for transportation, logistics, mobile workforces and consumers. Product lines 
include award-winning CoPilot®, a leading source of GPS navigation software for fleets, mobile 
operators, hardware OEMs, systems integrators, professional drivers and consumers. ALK’s PC*MILER® 
is widely recognized as a transportation industry standard for routing, mileage and mapping. ALK® Maps 
is a development platform designed for the transportation industry and provides commercial routing, 
geocoding and mapping visualization for enterprise applications. 

For more information on ALK, visit: www.alk.com or follow us at: www.twitter.com/ALKTech. 
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